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By Mike Price, Entrada/San Juan, Inc.

Modeling Doppler Radar 
  in ArcGIS 

In late August 2002, I attended the annual 
meeting of the International Association of Fire 
Chiefs in Kansas City, Missouri, accompanied 
by administrative staff from the Wilson, North 
Carolina, Fire Department. The Wilson Fire 
Department is a leader in the implementation 
and use of GIS for public safety and emergency 
management. Near the end of the conference, 
Wilson Fire Chief Don Oliver received an 
emergency call from one of his crew members 
back in North Carolina. “Chief, where would 
you like your desk?” When Oliver replied, 
“Why, right where it is!” he learned that his of-
fice was under two feet of water. That call led 
me to model the flooding of Hominy Swamp 
that submerged the downtown area of the city 
of Wilson.
 The storm that inundated Wilson, North 
Carolina, and surrounding areas began in the 
early hours of August 26, 2002. A large upper-
level, low-pressure system over the Southeast 
merged with a frontal boundary over the Caro-
linas to produce areas of locally heavy rainfall. 
The system moved slowly north, producing 
widespread showers and thunderstorms. Nine 
hours of regional data, obtained from ESRI 
business partner Meteorlogix LLC, for the 
period from 4:00 a.m. to 12:55 p.m. EDT (or 
0900 Z to 1755 Z). [Greenwich Mean Time 
(GMT) time was also called Z time in reference 
to the letter identifying the time zone centered 
on the Greenwich Prime Meridian. Although 
time references in meteorological reports are 
now given in Universal Coordinated Time 
(UCT), rather than GMT, the Z designation 
has persisted for time citations meteorological 
reports.]
 Clive Reece, GIS products manager for 
Meteorlogix, and I spent a year acquiring, 
modeling, and analyzing data for this storm, 
and we now understand its dynamics and 
consequences. Using NEXRAD Doppler data 
from Meteorlogix, we re-created four hours 
of precipitation history for the region. During 
this analysis, we devised several ArcGIS data 
development and modeling procedures that can 
be applied to Doppler data from anywhere in 
the country as well as any other regularly ar-
rayed repetitive trend data. [The 158 NEXRAD 
(or Next Generation Weather Radar) radar 
systems deployed throughout the United States 

What฀You฀Will฀Need
•฀ ArcGIS฀8.2฀or฀higher฀(ArcView,฀ArcEditor,฀or฀
฀ ArcInfo฀license)
•฀ ArcGIS฀Spatial฀Analyst฀extension
•฀ Sample฀data฀downloaded฀from฀ArcUser฀Online
•฀ An฀unzipping฀program฀such฀as฀WinZip

When unzipping the sample data 
archive, make sure that Use Folder 
Names is checked. The archive should generate four subdirectories—DBFFiles, GRDFiles, 
LYRFiles, and SHPFiles—and place the data files in the appropriate subdirectories.

and at selected overseas locations gather infor-
mation about dangerous weather conditions 
and allow meteorologists to warn populations 
endangered by weather events.] 
 Clive and I presented a paper entitled De-
riving and Modeling Flood Dynamics From 
GIS-Based Doppler Radar at the 2003 ESRI 
International User Conference. The exercise 
described in this article grew out of both the 
paper and our work analyzing the weather 
events of August 26, 2002. It presents several 
of these methods and applies them to four hours 
of NEXRAD data that was captured from the 
actual storm between 6:00 a.m. to 9:55 a.m. 
EDT, a period of intense rainfall. Raw data 
points arranged in a one-kilometer array and 
registered in North American Datum of 1983 
(NAD83) coordinates will be used. The attri-
butes for each point include fields for System 
Index, Type (i.e., of precipitation), DateTime, 
and dBZ value. [Decibels of Z (dBZ) is a unit 

measurement that uses a logarithmic scale and 
indicates the intensity of the reflectivity (or Z) of 
radar echoes.] The DateTime field is especially 
important because 48 five-minute Doppler sets 
were used to model Wilson precipitation.
 This exercise was designed for use in the 
classroom, and it teaches the following ArcGIS 
procedures:
• Data acquisition and management
• Working with projected and geographic data
• Table editing
• Summarizing tabular fields
• Interpolating point data

Data for the Exercise
Some data included in the sample archive was 
preprocessed to save time for readers working 
this tutorial. Creating summary five-minute in-
terval rainfall data for each point required merg-
ing the 48 point shapefiles. Several new fields 
were added to the attribute table to control data 
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Verify that the projection for 
the Data Frame is NAD_1983_
StatePlane_North_Carolina_FIPS_
3200_Feet, the same projection as 
Clippol2.

development. Processing this data required cal-
culating longitude and latitude coordinates for 
the entire dataset and building a spatial index 
for each stacked point by truncating and con-
catenating the decimal x and y values for each 
point. (For information about performing these 
types of calculations, search the ArcGIS online 
help for “making field calculations” and select 
the topic entitled “Adding the x,y coordinates in 
a point layer to a new field.” The instructions 
include sample Visual Basic code that can be 
used to populate the new fields.)
 Finally, specific time fields, including lo-
cal time as both an HH:MM:SS string and a 
24-hour clock value, were added. All Doppler 
data development was performed in geographic 
NAD83 and the resulting merged shapefile, 
dopxmrg2, was included in the sample dataset. 
Creating a location-based index that is unique 
for each one-kilometer point location was a bit 
more difficult but very important. This location 
index will be used to perform a tabular sum-
mary of five-minute rainfall intervals. Daniel 
Elroi, prinicipal of ESRI business partner Elroi 
Consulting, created a Visual Basic script that 
generated this index. Equivalent rainfall in mil-
limeters was calculated using the formula de-
veloped by National Oceanic and Atmospheric 
Administration (NOAA) Radar Operations 
Center staff that is shown in Figure 1. These 
calculations are stored in A300_B14.dbf, a 
table included with the sample data. 

Rainfall฀(R,฀mm/hr)฀=฀(Z/A)฀^฀(1/B),฀
where฀Z฀=฀10฀^฀(dBZ/10)
Figure 1: Equivalent rainfall in millimeters 
formula 

Setting Up the Project
Begin by downloading the sample dataset from 
the ArcUser Online Web site at www.esri.com/
arcuser. 

Set the storage defaults to 
relative paths by choosing 
File > Map Properties and 
clicking the Store Relative 
Path Names radio button.

1. Create a directory called W_Flood and 
unzip the sample data archive using WinZip. 
Make sure the box next to Use Folder Names is 
checked. The archive should generate four sub-
directories—DBFFiles, GRDFiles, LYRFiles, 
and SHPFiles—and place the data files in the 
appropriate subdirectories.
2. Start an ArcMap session and open a new 
blank map. Add Clippol2 from the SHPFiles\
NCSP83F subdirectory.
3. Right-click on the Data Frame and choose 
Properties. Click on the Coordinate System tab 
and verify that the projection is NAD_1983_
StatePlane_North_Carolina_FIPS_3200_Feet, 
the same projection as Clippol2. ArcMap sets 
the Data Frame projection based on the projec-
tion of the first data layer added. 
4. Choose Tools > Extensions and make sure 
the Spatial Analyst extension is loaded. Next, 
turn on the Editor and Spatial Analyst toolbars 
by choosing View > Toolbars. 

Join A300_
B14.dbf to 
dopxmrg2 
using the DBZ 
field.

5. Set the storage defaults to relative paths by 
choosing File > Map Properties and clicking 
the Store Relative Path Names radio button.
6. Add the dopxmrg2 shapefile (the merged, 
preprocessed Doppler point data) from 
\SHPFiles\LatLon83. Open the attribute table. 
Notice that there are 20,034 merged points 
and the dBZ values but no five-minute rainfall 
amounts. Save the project as W_Flood.

Summarizing Rainfall 
Data in Time and Space
In the dopxmrg2 table, study the EDT_Value 
field. Using Boolean selections, this numeric 
field can be used to create data reflecting time 
intervals smaller than four hours. 
1. Add A300_B14.dbf, the table containing the 
equivalent rainfall in millimeters. 
2. Join A300_B14.dbf to dopxmrg2 using the 
DBZ field. If necessary, consult the ArcGIS 

Continued on page 42
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Modeling Doppler Radar in ArcGIS
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online help for information on joining tables.
3. Open the attribute table for dopxmrg2. It now 
contains five-minute equivalent rainfall, calculat-
ed in inches, that will be summarized over time. 
4. Right-click on the dopxmrg2.LOC_INDEX 
field and select Summarize from the context 
menu. The Summarize dialog box lists all avail-
able fields alphabetically, including the joined 
fields. In the Summarize dialog box, expand 
A300_B14.In/5Min and check Sum. Expand 
dopxmrg2.LonDec and dopxmrg2.LatDec and 
check Average for both. Specify \DBFFiles\
DopxSum1 as for the output table. Click OK.
5. Be patient while your computer calculates a 
sophisticated summary of several fields. When 
processing is finished, add the table to the map, 
open it, and explore the fields.

Displaying Summarized Doppler Data
In DopxSum1, sort the data using the Sum_IN/
5MI field and notice that the rainfall varies 
from approximately 3.5 inches to more than 
9.3 inches. That s̓ more than two inches per 
hour in some areas! When summarizing this 
data, the averages for LonDec and LatDec were 
used because they will allow four-hour sum-
mary data to be added to the model. However 
data registration will need to be specified be-
cause the map will include data in geographic 
and State Plane coordinates.
1. In the Table of Contents, right-click on 
DopxSum1 and select Display XY Data from 
the context menu.
2. For X, specify Ave_LONDEC and for Y, 
specify Ave_LATDEC. Click on the Select 
button to set the spatial reference using a pre-
defined coordinate system. 
3. In the Spatial Reference dialog box, choose 
Predefined > Geographic Coordinate Systems 
> North American and select North American 
Datum of 1983 as the spatial reference. The 
DopxSum1 Events layer loads automatically 
into the map.

Creating the Rainfall Raster
Now the ArcGIS Spatial Analyst extension can 
be used to grid this summarized rainfall data. 
Since precipitation is very continuous data, us-
ing a tension spline often works well. Kriging 
or Inverse Distance Weight (IDW) interpola-
tion can also be applied.
1. In the ArcGIS Spatial Analyst toolbar, click 
on the drop-down menu and select Options. In 
the Options dialog box, set the working direc-
tory to \GRDFiles\NCSP83F. Set the analysis 
mask to \GRDFiles\NCSP83F\clipgrd2. Click 
the lower radio button to set the Analysis Coor-
dinate System as the active frame.
2. Click on the Extent tab and set the extent 
to \GRDFiles\NCSP83F\clipgrd2. Click on 

Summarize on the dopxmrg2.LOC_INDEX field using A300_B14.In/5Min, dopxmrg2.LonDec, 
and dopxmrg2.LatDec and specify \DBFFiles\DopxSum1 as for the output table.

When setting the parameters for displaying the x,y data, be sure to click on Selection in the 
Spatial Reference dialog box and choose Predefined > Geographic Coordinate Systems > 
North American and select North American Datum of 1983 as the spatial reference.
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Add the infrastructure shapefiles and 
layer files to enhance the map and pro-
vide the basis for further analysis.

the Cell tab and set the cell size to \GRDFiles\
NCSP83F\clipgrd2.
3. In the ArcGIS Spatial Analyst toolbar, 
choose Spatial Analyst > Interpolate to Raster > 
Spline and specify DopxSum1 Events as input 
points and Sm_In/5MI as the Z value. Change 
spline type to tension and leave defaults for 
weight, number of points, and output cell. Click 
OK.
4. After generating the spline, turn off the 
other layers and add hlshgrd2. Set transparency 
for this layer to 50 percent. 
 This summary dataset splines quite nicely. 
Not all data will behave this well. Sometimes 
the spline grid will interpolate negative values 
around the margin of a storm—an undesirable 
effect. If this occurs, it is necessary to reset the 
negative (and possibly null) values to zero.

Optional Activities
The model can be further enhanced by adding 
the shapefiles and layer files that are included 
in the sample dataset. The layers for roads, 
schools, fire stations, streams, identified flood-
plains, watersheds airports, hydrologic basins, 
street centerlines, streets, flooded intersections, 
flooded streets, historic flood zones, hydrog-
raphy lines, schools, and fire stations provide 
context and the basis for further analysis of the 
flood events.
 Use your cartographic license to rearrange 
and emphasize different datasets. Zoom in to 
the Hominy Swamp area and notice the rela-
tionship between high rainfall, hard surfaces 

(i.e., streets and airport), public buildings, and 
mapped flood channels. 

Summary
We continue to expand and improve the meth-
ods developed for the Wilson, North Carolina, 
NEXRAD Doppler study. The techniques for 
gathering and modeling periodic Doppler-
derived rainfall can be used in many natural 
resource-based industries including mining and 
earth science, watershed and ecosystem man-
agement, construction and civil engineering, 
and public safety. 
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Exercise฀Summary
1.฀Create฀directory/unzip฀data.
2.฀Load฀Clippol2.
3.฀Check฀coordinate฀system.
4.฀Load฀extension฀and฀toolbars.
5.฀Store฀relative฀paths.
6.฀Load฀dopxmrg2.
7.฀Add฀A300_B14.dbf.
8.฀Join฀to฀dopxmrg2฀on฀DBZ฀field.
9.฀Summarize฀on฀LOC_INDEX฀field.
10.฀Add฀DopxSum1฀to฀map.
11.฀Choose฀Display฀XY฀Data.
12.฀Specify฀Ave_LONDEC฀as฀X฀and฀Ave_LAT-
DEC฀as฀Y.
13.฀Select฀NAD83฀as฀spatial฀reference.
14.฀Set฀working฀directory฀and฀analysis฀mask฀
in฀Spatial฀Analyst.
15.฀Set฀Analysis฀Coordinate฀System฀as฀active฀
frame.
16.฀Select฀Spatial฀Analyst฀>฀Interpolate฀to฀
Raster฀>฀Spline.
17.฀Specify฀DopxSum1฀Events฀as฀input฀points฀
and฀Sm_In/5MI฀as฀Z฀value฀18.฀Change฀spline฀
type฀to฀tension฀and฀leave฀other฀defaults.
18.฀Create฀spline฀and฀turn฀off฀other฀layers.
19.฀Add฀hlshgrd2฀and฀set฀transparency฀to฀
50฀percent.
20.฀Make฀contour,฀add฀layer฀files,฀and฀re-
arrange฀layers.


