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Presentation 

Objectives 

The objective of this document is to provide the user of CreateBMG the relevant information to 
understand how to install, launch and use the application. 

Technical content summary 

This document is divided in two main parts: 

- The prerequisites detail the hardware and software requirements to run the application, 
explain how to install and launch the application. 

- The second part explains how to use the application and details its main functions. 

Diffusion 

Name Organisation 

Julien Forest 

Benoît Thiébault 

Jérémie Turbet 

Artenum 

Sébastien Theetten 

Fabrice Lecornu 

Jean-François Le Roux 

Franck Dumas 

Pascal Douillet 

IFREMER 

 

Changes 

Version Revision Date Auteur / Observation 

1 1 15/04/2009 Benoît Thiébault / Document creation 

1 2 20/10/2009 Benoît Thiébautl / Update to take into account version 2.0 Alpha  

1 3 16/12/2009 Benoît Thiébault / Update to take into account version 2.0 Bêta 

2 0 24/02/2010 Benoît Thiébault / Update to take into account version 2.0 

3 0 17/12/2010 Benoît Thiébault / update to take into account version 3.0.0-alpha 



 
BMGTOOLS 

CreateBMG User Manual 
PAGE 

3/25 

 

Reference: IFR_BMGV3_D1B_Create_User_Manual Version: 3 Revision: 0 

Status: Final Date: 17/12/2010  

This document is the property of Artenum. It cannot be used, copied or distributed without prior written approval. 

Table of contents 

1.	
   INTRODUCTION ................................................................................ 4	
  

1.1.	
   CreateBMG and BMGTools ................................................................... 4	
  

1.2.	
   Applicable documents .......................................................................... 4	
  

1.3.	
   Acronyms, abbreviations and definitions ........................................... 4	
  

2.	
   PREREQUISITES .............................................................................. 5	
  

2.1.	
   Configuration ......................................................................................... 5	
  

2.1.1.	
   Hardware requirements ................................................................................... 5	
  

2.1.2.	
   Software requirements ..................................................................................... 5	
  

2.2.	
   Installation .............................................................................................. 5	
  

2.3.	
   Running the application ........................................................................ 5	
  

3.	
   USING THE APPLICATION .............................................................. 7	
  

3.1.	
   User interface ......................................................................................... 7	
  

3.1.1.	
   Overview .......................................................................................................... 7	
  

3.1.2.	
   Menu bar .......................................................................................................... 7	
  

3.1.3.	
   Side bar ............................................................................................................ 8	
  

3.1.4.	
   Map viewer ....................................................................................................... 9	
  

3.1.5.	
   Status bar ....................................................................................................... 11	
  

3.2.	
   Creating a new project ........................................................................ 11	
  

3.3.	
   Saving the project ............................................................................... 13	
  

3.4.	
   Opening an existing project ............................................................... 13	
  

3.5.	
   Closing the project .............................................................................. 13	
  

3.6.	
   Setting up the preferences ................................................................. 13	
  

3.7.	
   Exiting the application ........................................................................ 16	
  

3.8.	
   Manipulating the map .......................................................................... 16	
  

3.9.	
   Creating new grids .............................................................................. 17	
  

3.10.	
   Editing existing grids ........................................................................ 18	
  

3.11.	
   Undoing an action ............................................................................. 21	
  

3.12.	
   Computing interpolation ................................................................... 21	
  

ANNEX A	
   COASTLINE FILE .LINE ............................................ 22	
  

ANNEX B	
   COLOUR BAR FILE FORMAT ................................... 25	
  
 



 
BMGTOOLS 

CreateBMG User Manual 
PAGE 

4/25 

 

Reference: IFR_BMGV3_D1B_Create_User_Manual Version: 3 Revision: 0 

Status: Final Date: 17/12/2010  

This document is the property of Artenum. It cannot be used, copied or distributed without prior written approval. 

1. Introduction 

1.1. CreateBMG and BMGTools 

The BMGTools, created by IFREMER, are a set of pre-processing tools that help you to create, check 
and modify bathymetric grids. 

CreateBMG is a part of the BMGTools. Its purpose is to help you create a hierarchy of grids on a map, 

resize them and interpolate bathymetry data on them, either from sounding measurements or 
numerically computed ground models. 

The present document is the user manual of CreateBMG. 

1.2. Applicable documents 

 [DA1] Statement of work: 2008_08_11_v14_specifications_creaverimaille.pdf 

1.3. Acronyms, abbreviations and definitions 

• TBC: to be confirmed 

• TBD: to be determined 

• AGRIF: an AGRIF grid is a grid whose grid cells sizes are computed as a fraction of the 

parent grid cells sizes. The refining coefficients indicate the fraction of the parent cell size to 
apply. In this case, the child grid cells are aligned with the parent grid cells. 

• Non-AGRIF: a non-AGRIF grid is a grid whose cells sizes are independent on the parent grid 
cells sizes. 
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2. Prerequisites 

2.1. Configuration 

2.1.1. Hardware requirements 

The minimal hardware configuration to properly run the BMG Tools 
is: 

- Intel/AMD x86 32/64bit processor, with a frequency higher 

than 1.7GHz (Intel Core 2 Duo T7700 at 2.4 GHz 

recommended) 

- 1Gb of RAM (2Gb recommended, especially for large grids) 

- Graphic card with more than 128Mb of video memory 
(NVIDIA Quadro FX 570M or equivalent recommended) 

- Screen resolution of 1024x768 pixels (1280x1024 resolution 
recommended) 

- 100Mb of free space on the hard drive 

2.1.2. Software requirements 

The BMG Tools have been tested to work under Windows XP SP3 

and Linux Fedora Core 8. It requires SUN Java 6 or higher installed 
(cf. http://www.java.com for the latest version download). 

In order to use properly the Fortran interpolation codes, you need to 

compile them on the targeted operating system (see the Fortran 
code user manual). 

The executable file generated has to be named 

INTERP_BATHY.exe and to be placed in the directory 

thirdpart/fortran/interp_bathy. If the folder does not exist, you have 
to create it manually. 

Depending on the algorithm provided, the executable file name and 
directory may change. 

2.2. Installation 

The application should be provided in a compressed archive (.zip or 

.gz for instance). Simply uncompress the archive to the desired 
location of your hard drive. 

The folder obtained after decompression is illustrated on Figure 1. 

2.3. Running the application 

In the create folder, there are two executable files. Under Windows, these are: 

- CreateBMG.bat, a DOS batch command that can be launched by double-clicking it; 

- ProfileCreateBMG.bat, a DOS batch command that can be launched by double-clicking it; 

Figure 1: Application folder 
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On Linux machines the executable files are: 

- CreateBMG.sh, the shell script command that can be executed via command line; 

- ProfileCreateBMG.sh, the shell script command that can be executed via command line; 

The profile command is present for test purpose only. It logs in the terminal the different times to 
execute some key functions (like refreshing the user interface). 

For users who want to create grid with the tools, the CreateBMG command is sufficient. 
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3. Using the application 

3.1. User interface 

3.1.1. Overview 

When the application is first opened, the window displayed in Figure 2 appears on the screen. It is 
divided in 4 main parts: 

1) The menu bar gives you access to some of the application main functions. It is composed of 

four menu items, File, Views, History and Help, and of a tool bar containing buttons for 

frequently used actions. 

2) The side bar contains the layers view of the loaded layers (on the top of the side bar) and the 
processing tabs, giving access to grid information and computing operations. 

3) The map view allows you to interact with the map representation of the data. It is composed of 
a tool bar on the top, and of the map viewer itself. 

4) The status bar gives you information about the projection system and the mouse cursor 
position on the map. 

 

Figure 2: Interface overview 

3.1.2. Menu bar 

The menu bar (cf. Figure 3) contains three menu items and a tool bar: 

- The File menu contains the application main operations: 
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o New project to create a new project 

o Open project to open an existing project 

o Close project to close the current project 

o Save project to save the current project 

o Save project as to save the current project under a different name 

o Export to save the map either in PNG or EPS format. Beware that the EPS format is a 

vector representation of the image. This means that every graphic element displayed 

on the screen is saved as a vector object in the file. This has the advantage of 

providing a file that can be indefinitely zoomed in without loss of quality. The 

counterpart is that for maps containing a lot of elements, the EPS file can quickly 

become huge and hard to manipulate. In that case, prefer the use of the PNG bitmap 
format. 

o Preferences to access the application settings 

o Quit to exit the application 

- The Views menu contains the list of the different views the user can display or hide. 

- The History menu contains the list of the last user actions that can be undone. 

- The Help menu contains a command to display the About dialog, indicating general 
information about the application. 

- The tool bar provides shortcuts for the following menu functions: 

o New project 

o Open project 

o Close project 

o Save project 

o Preferences 

Some of the menu items and tool bar buttons are deactivated by default. They activate automatically 
when necessary. 

 

Figure 3: Menu bar 

3.1.3. Side bar 

The side bar (cf. Figure 4) is divided in two main parts: 

- The top part of the side bar contains the layers view of the loaded layers. 

You can select the grids directly in this tree. 
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- The bottom part contains several processing tabs corresponding to information or 
computation capabilities available for the grid selected in the tree view. 

 

 

Figure 4: Side bar 

3.1.4. Map viewer 

The map viewer (cf. Figure 6) is composed of the map and the tool bar: 

- The map itself displays loaded information, such as grids, coastlines, soundings, etc. In order 

to keep the rendering quick and efficient, a Level Of Detail (LOD) algorithm is automatically 

applied to the data when seen from far away and only displays a part of the real data. When 

this algorithm is activated, a LOD icon is displayed on the top left corner of the map (cf. 

Figure 5). The level of the algorithm is also displayed. The higher the level, the more data is 
hidden. 
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Figure 5: Level Of Detail warning icon and algorithm level 

- The tool bar allows you to interact with the map. It is composed of one isolated button on the 

left and of a toggle buttons bar. The isolated button at the left resets the view to the initial map 

zoom when pressed. The toggle buttons bar contains several buttons. One and only one 

button of this tool bar is always selected. Depending on which button is selected, the main 

mouse action on the map have different effects (the main action can attributed to any of the 
mouse buttons, as seen in 3.6): 

o The Move button, on the left, lets you move the map 

o The Zoom in button allows you to zoom in the map by either clicking a place on the 
map or selecting a zoom zone with a mouse drag and drop action. 

o The Zoom out button allows you to zoom out the map by either clicking a place on the 
map or selecting a zoom zone with a mouse drag and drop action. 

o The Edit grid button allows resizing the existing grid that is selected in the grid tree. 

Whatever the selected tool, you can zoom in or out the map with the mouse wheel. The new 

grid button offers the possibility to draw a new grid on the map with a mouse “drag and drop” 
action. 

- Four handles are drawn at the grid boundaries to show which grid is selected in the grid tree. 

 

Figure 6: Map viewer 



 
BMGTOOLS 

CreateBMG User Manual 
PAGE 

11/25 

 

Reference: IFR_BMGV3_D1B_Create_User_Manual Version: 3 Revision: 0 

Status: Final Date: 17/12/2010  

This document is the property of Artenum. It cannot be used, copied or distributed without prior written approval. 

3.1.5. Status bar 

The status bar (cf. Figure 7) displays two kinds of information: 

- On the left, the projection system in which the data is drawn on the map is displayed; 

- On the right, the mouse cursor coordinates on the map are given either in geographic 
coordinates (degrees), in projected coordinates (meters) or in grid indexes. 

 

Figure 7: Status bar 

3.2. Creating a new project 

There are two ways of creating a new project: via the menu item File>New project… or by clicking 
the shortcut New project icon. 

When this action is performed, the New project window is displayed (cf. Figure 8). 

 

Figure 8: New project window 

There are two main parts in this window: 

- The right part of the window contains a panel displaying a preview of the map. The default 

settings button at the bottom reloads the file and applies the default projection, zoom and 

rotation characteristics.  

There is a tool bar at the top of the preview panel. This tool bar can be used to move or zoom 

the map. It works the same way than the map tool bar of the main windows (cf. 3.8).  
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On the top left of the preview panel, there is a small square check box. By clicking it, you 

make vertical and horizontal guidelines appear. These guidelines can help you to visualise the 

correct alignment of the map with the horizontal and vertical, which is especially useful when 

performing a map rotation. Dragging the black triangles at the end of the guidelines moves 
them. 

- The left part contains the form of all the project characteristics. It is divided in 5 parts: 

o The project characteristics panel allows you to enter a project name, a project 

acronym (limited to 4 characters) and a “coastlines file”, containing coastlines and/or 

isobaths data. This file can be provided either in the .line format, described in Annex A 

or in the Shapefile format. The Shapefile format is however only partially supported for 

files coming from the SHOM or SEXTANT database.  

You can also load coordinates files created with NEMO (http://www.nemo-ocean.eu/). 
This NEMO file is however optional. 

o The geodetic and projection systems: 

§ The geodetic system is read from the coastline file. 

§ The projection system is set by default to the most relevant projection given 

the geodetic system and the coastlines file dimensions and position. You can 

change this default projection by either choosing one of the projections 

provided in the drop down menu or click on the advanced button. You can 

then enter the EPSG code of the desired projection (see for instance 

http://www.epsg-registry.org) and click the OK button to see the effect on the 
preview window. 

§ The grid creation mode. In geographic coordinates mode, the grid are 

created with cells dimensions constant in degrees, on the reference spheroid, 

while in projected coordinates mode, the cells dimensions are constant in 

meters, on the projection. As illustrated on Figure 9, a tool tip will appear if 
you pass the mouse over the grid creation mode menu. 

 

Figure 9: Illustration of the difference between geographic and projected creation modes 

o The map initial zoom is set by default to the coastline file data dimensions. You can 

modify the initial zoom to look more precisely on a specific geographical zone of the 

map. You can only modify the latitude values or the longitude values at the same time 
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to prevent map distortion. To apply the changes on the preview map, you have to click 
the Apply changes button. 

o The map rotation panel allows you to define a map rotation by providing the rotation 

centre and angle. When the map is rotated, the grid creation mode is automatically set 

to projected coordinates. To validate the value of the rotation centre and apply the 
changes on the preview map, you have to press the Return key. 

o The validation panel contains the OK and Cancel buttons. When the project is 

properly configured, you can press the OK button to confirm the parameters and 
create the project. 

3.3. Saving the project 

Once a project has been created, you can save it by choosing the File>Save menu item or by clicking 
the Save shortcut button. 

If the project has never been saved, you will be asked to confirm the project name and acronym and to 

provide a project parent folder (cf. Figure 10). A new folder, named after the project name, will be 
created in this parent folder. 

You can only save the project when a modification has been made. At anytime, however, you can 

choose the File>Save as… menu item to save the project with a different name or at a different 
location. 

 

Figure 10: Save project as... 

3.4. Opening an existing project 

To open an existing project, you have to click the File>Open project menu item or to select the open 
project shortcut button. 

You will then be asked to select the .glo file of the project to load. 

3.5. Closing the project 

To close an opened project, you have to select the File>Close project menu item or to click the close 
project shortcut button. 

If the project has been modified since last save, you will be proposed to save the project. 

3.6. Setting up the preferences 

To edit the application preferences, select the File>Preferences… menu item or click the 
Preferences shortcut button. 
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The preferences window is separated in two tabs: 

- The General tab (cf. Figure 11) contains preferences common throughout the BMGTools. 

You can here change the interface language (requires to restart the application to be 

effective), change the different coastline file elements colour and set the colour gradient 
associated with the isobaths depth (see below for more details). 

 

Figure 11: General preferences 

If you want to edit one of the colour bars available, you have to select the colour bar and click the Edit 

color bar button that shows the Edit color bar window (cf. Figure 12). There are three colour bars 

provided by default. These default colour bar cannot be deleted or overridden, so if you wish to modify 

them, you will have to change their name in the Edit color bar window. You can also import an 

existing colour bar by using the Load… button. The file format for colour bar files is described in 
Annex E. 

In the Edit color bar window, you can add new colours in the colour bar or delete existing ones. 

To add a new colour, click the coloured button next to the Color text. A dialog will let you choose the 

colour you want to add. After choosing a colour, input a colour position in the colour bar. The colour 

bar contains a configurable number of colours (say nbColours). The position of the new colour has to 

be between 1 and nbColours – 2 (as the starting and ending colours are at positions 0 and nbColours 
– 1). Then click the Add color button. 

To remove a colour, simply select the thumb representing it and click the Delete color button. 

You can also change colours position in the gradient by dragging the colourʼs thumb, change the total 

number of colours in the colour bar and choose an automatic range (that will be adapted to the data 
scalar range when data is loaded) or force a given one. 
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Figure 12: Edit color bar window 

- The CreateBMG preferences tab (cf. Figure 13) contains preferences specific to this 

application. You can choose the colour of the created grid depending on its level in the 
hierarchical grid tree. 

You can go back to default settings by pressing the Default button. 
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Figure 13: Create BMG preferences 

3.7. Exiting the application 

To close the application, you have to select the File>Quit menu. 

If the project has been modified, you will be proposed to save the project. 

3.8. Manipulating the map 

The navigation map tool bar (cf. Figure 14) allows you to manipulate the map. The initial zoom 
button on the left of the tool bar resets the zoom level to the initial one when pressed. 

The move button lets you move the map 

The zoom in button allows you to zoom in the map by either clicking a place on the map or selecting a 
zoom zone with a mouse drag and drop action on the map. 

The zoom out button allows you to zoom out the map by either clicking a place on the map or 
selecting a zoom zone with a mouse drag and drop action on the map. 

You can as well use the mouse wheel to zoom in or out in the map. 

 

Figure 14: Navigation map tool bar 
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3.9. Creating new grids 

The new grid button (cf. Figure 15) allows you to create a new grid by dragging and dropping the 

mouse on the map area. 

 

Figure 15: New grid button 

If no other grid has been created, the root grid dialog will be shown (cf. Figure 16). This dialog allows 

you to specify new grid bounds, to choose the grid type (AGRIF or non-AGRIF) and the definition 
mode. 

There are four possible definition modes: 

- Mesh number: in this case, you provide the total meshes number of the grid (this total 
meshes number does not include the ghost cells that will be added automatically); 

- Projected coordinates, where you provide the size in meters of the central mesh on the 
projection; 

- Geographic coordinates, where you provide the size in degrees of the central mesh on the 
reference spheroid. 

- Curvilinear mode, where you provide the size in meters of the central mesh on the reference 
spheroid. 

 

Figure 16: New root grid dialog box 

If there is already at least an existing grid, a new grid will be created if the following criteria are fulfilled: 

- There can be only one root grid 

- A child grid has to be fully contained in its parent grid 

- Two sister grids cannot intersect 
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A warning will be raised if the child grid is too close from its parent border (less than 5 cells). This 
could indeed cause boundary conditions problems to MARS3D. 

If the child grid is an AGRIF grid, the AGRIF child grid dialog box will be displayed (cf. Figure 17). 
You can specify in this dialog the refining coefficients in i and j directions. 

 

Figure 17: AGRIF child grid dialog box 

If the child grid is a non-AGRIF grid, the non-AGRIF child grid dialog box will be displayed (cf. Figure 

18). You can specify in this dialog the grid characteristics by choosing a definition mode, in the same 
way than for root grids. 

 

Figure 18: Non-AGRIF child grid dialog box 

3.10. Editing existing grids 

Only grids without children can be modified. There are two ways to edit an existing grid: 
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- With the mouse by selecting the Edit grid button in the map tool bar (cf. Figure 19). 

- By providing new characteristics in the grid tab of the side panel. 

 

Figure 19: Edit grid button 

By selecting the edit grid button, you can modify an existing grid with the mouse. You just need to click 
on one of the grid handles and drag the mouse to modify the grid size. 

For root grids and non-AGRIF child grids, a menu will appear next to the edit grid button allowing you 
to choose either to keep the number of meshes or the mesh size after resizing the grid. 

There are three different panels available in the grid tab: 

- The geographic coordinates panel (cf. Figure 20) allows you to change the grid 
characteristics expressed in degrees on the reference spheroid. 

 

Figure 20: Editing grid geographic coordinates 

- The projected coordinates panel (cf. Figure 21) allows you to change the grid 
characteristics expressed in meters on the projection. 
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Figure 21: Editing grid projected coordinates 

- The mesh characteristics panel (cf. Figure 22) offers the possibility to change the number of 

meshes in each direction for the root grid and the non-AGRIF child grids, to change the 

refining coefficients for the AGRIF child grids and to change the inner bounds for child grids. 

 

Figure 22: Editing grid mesh characteristics 
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3.11. Undoing an action 

You can undo some user actions. To do so, you have to go in the History menu (cf. Figure 23) and 

select the last undoable action. 

 

Figure 23: History menu 

3.12. Computing interpolation 

To interpolate the depth on the grid, select the desired grid in the grid tree and select the 

Interpolation tab (cf. Figure 24). Depending on the configuration, the proposed algorithms may differ. 
You have to fill the interpolation parameters form and click the Interpolate button. 

If your project is not saved, you will be asked to save it. 

 

Figure 24: Interpolation tab 
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Annex A Coastline file .line 

The coastline file is an ASCII file which name ends with the .line extension. It contains the definition of 
the coastlines, the isobaths, the reefs and fringing reefs. 

The file starts with a two lines header: 

• The first line is composed of four spaces separated floats defining the geographical 

boundaries of the area described by the file: longitude_min longitude_max latitude_min 
latitude_max 

• The second line is composed of a string and an integer indicating respectively the geodetic 

reference system and the number of coastlines, isobaths and/o reefs: geodetic_system_name 
polylines_number. 

The body of the file is then composed of blocks. There are as many blocks as polylines number. 

Each block starts with a one-line header indicating the number of points composing the polyline and a 

code describing the line type. The code is an number taking the following values: 

• 0 for coastlines 

• Any positive value for isobaths 

• A negative value (-1 or -2) for reefs 

.line sample file: 

165.33000000  167.50000000  -23.10000000  -21.41000000 
    WGS84        9 
     16      50 
166.50180000  -22.49082000 
166.47880000  -22.50999000 
166.47970000  -22.51010000 
166.48050000  -22.51051000 
166.48120000  -22.51100000 
166.48190000  -22.51141000 
166.48270000  -22.51155000 
166.48340000  -22.51152000 
166.48410000  -22.51137000 
166.48490000  -22.51107000 
166.48570000  -22.51067000 
166.48660000  -22.50985000 
166.48700000   22.50921000 
166.48720000  -22.50843000 
166.48740000  -22.50751000 
166.48750000  -22.50663000 
     14      40 
166.43440000  -22.49340000 
166.43500000   22.49416000 
166.43560000  -22.49497000 
166.43620000  -22.49562000 
166.43690000  -22.49644000 
166.43750000  -22.49734000 
166.43790000  -22.49813000 
166.43820000  -22.49858000 
166.43890000  -22.49874000 
166.43960000  -22.49858000 
166.44060000  -22.49823000 
166.44140000  -22.49783000 
166.44230000  -22.49744000 
166.44320000  -22.49701000 
     22      30 
166.57450000  -22.38101000 
166.57490000  -22.38060000 
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166.57560000  -22.37996000 
166.57660000  -22.37965000 
166.57710000  -22.37977000 
166.57770000  -22.38009000 
166.57830000  -22.38048000 
166.57880000  -22.38086000 
166.57980000  -22.38141000 
166.58030000  -22.38165000 
166.58120000  -22.38203000 
166.58160000  -22.38256000 
166.58080000  -22.38298000 
166.57990000  -22.38298000 
166.57890000  -22.38291000 
166.57770000  -22.38291000 
166.57640000  -22.38299000 
166.57510000  -22.38299000 
166.57410000  -22.38288000 
166.57360000  -22.38248000 
166.57370000  -22.38160000 
166.57450000  -22.38101000 
     11      10 
166.50130000  -22.39190000 
166.50210000  -22.39210000 
166.50290000  -22.39240000 
166.50370000  -22.39280000 
166.50470000  -22.39334000 
166.50570000  -22.39392000 
166.50670000  -22.39444000 
166.50740000  -22.39485000 
166.50810000  -22.39527000 
166.50880000  -22.39580000 
166.50910000  -22.39628000 
     37       0 
166.48120000  -22.29772000 
166.48190000  -22.29785000 
166.48230000  -22.29828000 
166.48260000  -22.29891000 
166.48260000  -22.29972000 
166.48260000  -22.30054000 
166.48250000  -22.30135000 
166.48240000  -22.30189000 
166.48240000  -22.30247000 
166.48240000  -22.30305000 
166.48220000  -22.30360000 
166.48180000  -22.30436000 
166.48110000  -22.30449000 
166.48030000  -22.30461000 
166.47940000  -22.30512000 
166.47900000   22.30551000 
166.47800000   22.30622000 
166.47750000  -22.30650000 
166.47680000  -22.30702000 
166.47680000  -22.30773000 
166.47700000   22.30846000 
166.47710000  -22.30923000 
166.47730000  -22.30998000 
166.47810000  -22.31051000 
166.47860000  -22.31076000 
166.47930000  -22.31094000 
166.48040000  -22.31099000 
166.48140000  -22.31068000 
166.48220000  -22.30995000 
166.48240000  -22.30944000 
166.48260000  -22.30891000 
166.48280000  -22.30829000 
166.48290000  -22.30765000 
166.48300000   22.30707000 
166.48320000  -22.30649000 
166.48350000  -22.30595000 
166.48380000  -22.30547000 
      6       0 
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166.49470000  -22.31503000 
166.49480000  -22.31563000 
166.49450000  -22.31613000 
166.49410000  -22.31569000 
166.49440000  -22.31512000 
166.49470000  -22.31503000 
     14       0 
166.50450000  -22.27433000 
166.50430000  -22.27465000 
166.50360000  -22.27492000 
166.50310000  -22.27531000 
166.50310000  -22.27610000 
166.50270000  -22.27567000 
166.50260000  -22.27505000 
166.50270000  -22.27440000 
166.50270000  -22.27376000 
166.50320000  -22.27329000 
166.50380000  -22.27342000 
166.50440000  -22.27378000 
166.50450000  -22.27413000 
166.50450000  -22.27433000 
      7      -1 
166.50340000  -22.26714000 
166.50360000  -22.26778000 
166.50410000  -22.26836000 
166.50350000  -22.26864000 
166.50320000  -22.26804000 
166.50320000  -22.26747000 
166.50340000  -22.26714000 
      9      -2 
166.56890000  -22.23719000 
166.56880000  -22.23836000 
166.56890000  -22.23892000 
166.56870000  -22.23955000 
166.56810000  -22.24013000 
166.56740000  -22.24079000 
166.56670000  -22.24158000 
166.56610000  -22.24210000 
166.56550000  -22.24192000 

 

Fortran writing procedure: 

! ecriture en-tete 
write(24,110)lon_min ,lon_max,lat_min,lat_max 
write(24,111)sys_geo,nb_lines 
 
! 
do i=1,nb_lines 
  ! ecriture en-tete ligne 
  write(24,112) nb_points, code 
 
  do j = 1, nb_points 
     ! ecriture points 
     write(24,113),lon(j),lat(j) 
  end do 
 
enddo 
 
110 format(f13.8,1x,f13.8,1x,f13.8,1x,f13.8) 
111 format(a10,x,i8) 
112 format(i8,i8) 
113 format(f13.8,1x,f13.8) 
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Annex B Colour bar file format 

The colour bar file is a XML file describing a colour gradient. 

The root element is the <Gradient> element. It contains three mandatory attributes: startColor, 

endColor and nbColors. The two first ones represent the gradient starting and ending colours 

(expressed using their hexadecimal code), the last one is the number of colours composing the 
gradient. 

Then, there are as many <Color> elements as required, each one describing the colour position index 

and value (in hexadecimal code). The index positions in the gradient start at 0 and end at nbColors – 
1. However, these two extreme positions are reserved for the startColor and the endColor. 

Example of colour gradient file: 

 
<?xml version="1.0" encoding="UTF-8"?> 
<Gradient startColor="#ff0000" endColor="#0000ff" nbColors="50"> 
   <Color position="37" code="#00ffff"/> 
   <Color position="25" code="#00ff00"/> 
   <Color position="12" code="#ffff00"/> 
</Gradient> 
 


