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About this tutorial

In this tutorial, you will learn how to create an interactive purchase order form that includes a Print Form button. When the person filling 

the form clicks this button, the form is printed. The person then returns the printed form to you. In addition to basic concepts, you will learn 

how to add simple calculations. No matter what type of form you create later, you will find this tutorial a useful introduction. 

Additional information

For information about See

Other form design tutorials Creating a purchase order form that has a flowable layout

Creating and using fragments in form designs

http://www.adobe.com/go/learn_lc_qs_poformflowable_9
http://www.adobe.com/go/learn_lc_qs_fragments_9
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Creating a purchase order form

Here are the steps involved with creating the purchase order form:

About creating a purchase order form

Starting the form design

Adding a logo

Adding the purchase order title

Adding a text field for the P.O. Number

Adding a date field for P.O. Date

Previewing your work

Adding an address block

Adding the purchase order details

Moving the purchase order table

Sizing the purchase order table

Entering labels in the header row

Specifying the Part No. and Description cells as text fields

Changing the cells to numeric fields

Naming the fields

Performing a calculation in the Amount column

Adding rows to the purchase order table

Renaming the contents of your form

Inserting the subtotal at the bottom of the table

Inserting the Tax fields

Inserting the Shipping Charge field

Inserting the Grand Total field

Adding the Terms and Conditions section

Adding the Authorized By Signature field object
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About creating a purchase order form

During the course of a workday, you may deal with many different types of forms, such as order forms, invoices, paychecks, and time sheets:

• Forms you fill directly, either by hand or electronically.

• Forms you fill in conjunction with a server-based process that merges the form with data.

• Forms are a combination of both.

When you have completed this tutorial, the form you create will look like this purchase order.
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Starting the form design

The requirement for the purchase order form is that it be a single page in PDF. Users will fill the form electronically using Adobe Reader, 

print it using the Print button included on the form, and then manually return the form.

LiveCycle Designer ES2 offers several ways to get started quickly when creating a form design. For this tutorial, you will use the New Form 

Assistant to create the purchase order form design. The New Form Assistant simplifies the process of starting a form design by guiding you 

through the steps of how the form is distributed and how users return the filled form.

1 Select File > New. 

The New Form Assistant appears. 

2 Click Next. 

3 In the Page Size list, select Letter.

4 Click Next. 

5 Select Add A Print Button. If Add An Email Button is selected, deselect it.

LiveCycle Designer ES2 adds a Print Form button to the form design. When a user finishes filling the form, they click the Print Form 

button to print the form.

6 Click Finish. 

The new form design appears in the Layout Editor.

Adding a logo

In this section, you will add a logo to the purchase order.

1 In the Object Library palette, click the Standard category and then drag the Image object  onto the form design in the upper left 

corner.

2 Double-click the placeholder and locate an image file.

For example, if you installed the samples that come with LiveCycle Designer ES2, locate the LiveCycle Designer ES2 install folder and 

open the following image file: 

EN\Samples\Forms\Purchase Order\Images\Purchase Order.tif.

3 In the Object palette, select Use Original Size from the Sizing list.



ADOBE LIVECYCLE DESIGNER ES2

Adding the purchase order title Creating a  Purchase Order Form

7

Adding the purchase order title

In this section, you will add a title to the purchase order.

1 In the Object Library palette, click the Standard category and then drag the Text object  below the logo.

2 Select the text in the Text object and type Purchase Order.

3 Select the text in the Text object and, in the Font palette, select 20 from the Size list, and Bold from the Style list. 

You can set the default font for objects. For example, if you want to set the default font for all Text objects to Arial, insert a text object in 

your form, change the font to Arial, and then drag the Text object into the Standard category of the Object Library palette. In the Add 

Library Object dialog box, type Text and click OK. LiveCycle Designer ES2 asks you to confirm that you want to replace the existing Text 

object. Click Yes.

Adding a text field for the P.O. Number

Next, you need to use a text field for the P.O. Number. In this form, it consists of 10 numbers.

1 In the Object Library palette, click the Standard category and then drag the Text Field object  onto the form in the upper right corner.

2 Select the text in the Text Field object and type P.O. Number.
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After the Text Field is selected, you can change the font, font size, and style of both the caption and the value. The caption (the field’s 

label) is beside the value (where the person filling the form enters the data). In the Font palette, use the palette menu to change the fonts 

for the caption and value.

Next, you must set the field length to 10 numbers.

3 In the Object palette, click the Field tab and select the Limit Length option. Type 10 in the Max Chars box.

Adding a date field for P.O. Date

You can use the Date/Time Field object to make it easy for your users to pick a date. This calendar is what users see in the form when they 

click the drop-down list for P.O. Date when viewing the form in Acrobat.

1 In the Object Library palette, click the Standard category and then drag the Date/Time Field object  onto the form under the P.O. 

Number.

2 Select the text in the Date/Time Field object and type P.O. Date.
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Previewing your work

As you work, you can preview your form design to see how it will look to the form filler. For example, here is how your form should look now.

1 Click the Preview PDF tab.

2 Click the Design View tab to continue editing the form design.

Saving the form design

It is a good idea to save your form now. You will save the form design as a PDF file so that people can fill it out electronically and then print 

it using the Print Form button. 

1 Click File > Save As.

2 Select a location for the form design and type a name in the File Name box.

3 In the Save As Type list, select Adobe Static PDF Form (*.pdf).

Adding an address block

LiveCycle Designer ES2 includes some predefined custom objects that you can use to quickly create forms. For example, in this tutorial, we 

will use the Address Block custom library object to insert several fields at once.

1 In the Object Library palette, click the Custom category and then drag the Address Block field object  onto the form under the 

Purchase Order title.
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2 Rename the Name text field to Ordered By.

3 In the Object Library palette, click the Standard category and then drag the Text Field object  onto the form under the Country field.

4 Name the Text Field object Phone Number.

5 Add another Text Field object for Fax Number.

6 Add another Text Field object onto the form under the fax number.

7 Name the Text Field object Contact Name.

8 To be able to insert a second address block beside this one, drag to select all the fields created in steps 1 to 7 and reduce the width of 

them by about half an inch using the sizing handle on the right side.

9 Copy and paste the selected fields next to the Ordered By address block.

10 Rename the second Ordered By field to Deliver To.

Your form should look like this now.

You can preview your form with the Preview PDF tab again. 

To improve the appearance of the form, you can change the look of the sunken box fields. To do this, select the object, and then in the Object 

palette, click the Field tab and select Underlined from the Appearance list.

Adding the purchase order details

Now, you need to add a table that will contain the part numbers, item descriptions, quantities, unit prices, and amounts of each item. Using 

tables helps you build this section quickly. The table will have five columns.

The Table Assistant is an easy way to create a new table if you are new to creating tables in LiveCycle Designer ES2.

1 Select Table > Insert Table.

2 Select the Create Table Using Assistant option and click OK.

3 Under Body Has Fixed Dimensions, type 5 for the number of columns and 1 for the number of body rows, and then click Next.
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4 Select the Has Header Row option and click Next.

5 Ensure the No Footer Row option is selected and click Next.

6 Select the Has Body Rows And No Sections option and click Next.

7 Clear the Alternating Row Colors option and click Finish.

Moving the purchase order table

Here is the table that you just inserted. 

A. Cursor for moving the whole table B. Header row C. Body row

Now you need to position the table under the address blocks.

1 If the table is not selected, move the cursor to the upper left corner until you see the following cursor:

2 Click to select the whole table.

Another way to select the whole table is to select a cell, then select Table > Select, and then select Table, or you can click and drag to select.

3Move the mouse to the upper left corner of the table until the move cursor  appears.

4 Drag the table to the new location.

Sizing the purchase order table

You can size the table so that it spans the width of the page. By default, it is centered on the page.

1 Select the table.

2 Move the cursor to the middle handle on the right so that the move cursor appears (shown in the previous step).

3 Drag to make the table fill the width of the page.

To make the width of all the columns the same, select Table > Distribute Columns Evenly.
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Entering labels in the header row

1 Double-click the first cell in the table and type Part No.

2 Repeat step 1 for the remaining cells in the header row so that it looks like this.

You can apply a color fill to this row to make it distinctive. To do this, select the row by moving the cursor to the left of the row until this 

cursor appears . 

Then, in the Border palette, select Solid from the Background Fill Style list. Finally, choose a color from the Color picker .

Your form should look like this now.

Specifying the Part No. and Description cells as text fields

By default, the cells in tables are set as text objects. Now you must set the Description column cell as a text field. Text fields enable users to 

type, select, edit, cut, copy, paste, and delete any of the text inside the field. (Text objects present read-only text that end users cannot edit.)

1 Select the cell under Part No.

2 In the Object palette, click the Cell tab and in the Type list select Text Field.

3 From the Appearance list, select None.
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4 Select the Allow Multiple Lines option.

5 Repeat steps 1 to 4 for the Description cells.

Changing the cells to numeric fields

Now you must set Quantity, Unit Price, and Amount as numeric fields.

1 Select the first cell under Quantity.

2 In the Object palette, click the Cell tab and select Numeric Field in the Type list.

3 In the Cell tab, select None from the Appearance list.

4 Repeat steps 1 to 3 for Unit Price and Amount:

The Unit Price and Amount fields show currency. To format the data to show numbers as currency, drag to select the cells in the Unit 

Price and Amount columns. Then in the Object palette, click the Cell tab, click the Patterns button, and in the Pattern box, type 

$z,zz9.99.

Naming the fields

To make your form more readable and usable, and to be able to perform calculations, it is a good idea to rename the fields. If you want to 

perform calculations, you will need to know the exact name of the field.

Note: LiveCycle Designer ES2 is case-sensitive. 

1 Select the cell under Part No.

2 In the Object palette, click the Binding tab and type partNo in the Name box.

3 Repeat steps 1 and 2 for the remaining columns and name them as follows:

• description 

• quantity 

• unitPrice 

• amount 

Performing a calculation in the Amount column

The Amount column must show the number of items ordered multiplied by the unit price. You perform calculations in 

LiveCycle Designer ES2 using FormCalc or JavaScript. We will use FormCalc for this calculation. FormCalc is a simple yet powerful calcu-

lation language modeled on common spreadsheet software. Its purpose is to facilitate fast and efficient form design without requiring a 

knowledge of traditional scripting techniques or languages. You use the Script Editor to enter calculations for the different objects on the 

form. 
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1 If the Script Editor is not already showing, select Window > Script Editor. 

2 If you want, drag the Script Editor palette bar until the palette is larger.

3 Select the cell under Amount.

4 Select Calculate from the Show list.

5 Select FormCalc from the Language list and Client from the Run At list.

6 In the Script Source field, type the following calculation:

quantity * unitPrice

7 Deselect the cell to add the script to your form.

8 To set this column as read-only, select the cell again, then in the Object palette, click the Value tab and select Calculated - Read Only 

from the Type list.

Adding rows to the purchase order table

For this form, you need seven rows in which users can enter the items they want to purchase. A quick way to add several rows at once is to 

use the Copy Multiple command.

1 Drag to select the body row.

2 Select Edit > Copy Multiple.

3 In the Number of Copies box, type 6.

4 Select the Place Below option.

5 Ensure the Touching option is selected in the Vertical Spacing box.
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Your form should look like this now:

Renaming the contents of your form

It is a good idea to rename the objects in your form to organize it and identify the different areas of the form. To do this, the easiest way is 

to use the Hierarchy palette. The Hierarchy is a graphical representation of the contents of your form.

1 Select Window > Hierarchy.

2 Select the first object in the hierarchy, form1.

3 Press F2 or right-click and select Rename Object.

4 Type the new name, PurchaseOrderForm.

5 Rename (untitled Subform) (page 1) to PurchaseOrder. 

You can rename the rest of the contents of your form, if you want, but it is not necessary to complete this tutorial.
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You can also move objects around in the Hierarchy by selecting them and dragging them up or down.

Inserting the subtotal at the bottom of the table

To perform calculations, FormCalc needs to know what object to use in the calculation. In this step, we want to find out the total of all the 

data in the Amount column. If you select a cell in the Amount column, you can see the internal name in the Script Editor (if you resize the 

Script Editor to be larger). 

What you see in the internal name relates to what you see in the hierarchy. “PurchaseOrderForm” is at the top, followed by “PurchaseOrder”, 

and so on. 

All the rows in the table are named “Row1” followed by a default instance number. To be able to add the data in one column, all the rows 

have to be named the same.

Now, you will add the calculation for the subtotal at the bottom of the table.

1 In the Object Library palette, click the Standard category and then drag the Numeric Field object  onto the form below the table 

under the Amount column.

2 Select the caption text in the Numeric Field object and type Total.

3 In the Object palette, click the Field tab and select Solid Box form the Appearance list. 

4 In the Script Editor, select Calculate from the Show list.

5 Select FormCalc from the Language list and Client from the Run At list.

6 In the Script Source field, type the following calculation:

sum(Table1.Row1[*].amount[*])

The wildcard character (*) tells LiveCycle Designer ES2 to collect all the data in the rows labeled Row1 and all the data in the Amount 

column.
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7 Deselect the Numeric Field object to add the script to your form, then select it again.

8 In the Object palette, click the Binding tab and type total in the Name box. 

9 Click the Field tab, click the Patterns button, and in the Pattern box, type $z,zz9.99. 

10 Click the Value tab and in the Type list, select Calculated - Read Only.

Inserting the Tax fields

The purchase order needs to calculate the appropriate state and federal taxes. To do this, you create a field that shows the tax rate and a calcu-

lated field that shows the tax amount.

To insert the State Tax % field

1 In the Object Library palette, click the Standard category and then drag the Numeric Field object  onto the form below the Total field.

2 Select the caption text in the Numeric Field object and type State Tax %.

You may want to resize the field to make it smaller.

3 In the Object palette, click the Field tab and select Solid Box in the Appearance list. 

4 Click the Patterns button and in the Pattern box, type z9.99%.

5 Click the Binding tab and type stateTaxPercent in the Name box,.

6 Click the Value tab and in the Default box, type 6 .

To insert the State Tax field

1 Copy the State Tax % field and position the new field beside the State Tax % field.

2 Select the text and type State Tax.

3 In the Script Editor, select Calculate from the Show list.

4 In the Script Source field, type the following calculation:

(total * stateTaxPercent / 100) 

5 Deselect the Numeric Field object to add the script to your form.

6 In the Object palette, click the Binding tab and type stateTax in the Name box.

7 Click the Field tab, click the Patterns button and in the Pattern box, type $z,zz9.99.

8 Click the Value tab and in the Type list, select Calculated - Read Only.

To insert the Federal Tax % and Federal Tax fields

1 Repeat the procedure for inserting the State Tax % field.

2 Repeat the procedure for inserting the State Tax field.

3 Ensure the following changes to make the fields applicable for Federal Tax: 

• Change all instances of the word state to federal. 

• Set the default value for the federal tax percent to 8. 

• Set the calculation for federalTax to:
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(total * federalTaxPercent / 100)

Inserting the Shipping Charge field

By default, a shipping charge of $50.00 applies. However, this form lets users enter a different shipping charge if required.

1 In the Object Library palette, click the Standard category and then drag the Numeric Field object  onto the form below the federal 

tax field.

2 Select the caption text in the Numeric Field object and type Shipping Charge.

3 In the Object palette, click the Binding tab and type shippingCharge in the Name box. 

4 Click the Field tab and in the Appearance list, select Solid Box.

5 Click the Field tab, click the Patterns button and in the Pattern box, type $z,zz9.99.

6 Click the Value tab and in the Default box, type 50.

Inserting the Grand Total field

You now need to add a Grand Total field that shows the total for the items, taxes, and shipping charges.

1 In the Object Library palette, click the Standard category and then drag the Numeric Field object  onto the form below the table.

2 Select the caption text in the Numeric Field object and type Grand Total.

3 In the Object palette, click the Binding tab and type grandTotal in the Name box.

4 Click the Field tab and in the Appearance list, select Solid Box.

5 Click the Patterns button and in the Pattern box, type $z,zz9.99. 

6 Click the Value tab and in the Type list, select Calculated - Read Only.

7 In the Script Editor, select Calculate from the Show list.

8 In the Script Source field, type the following calculation:

sum (total, stateTax, federalTax, shippingCharge)

9 Deselect the Numeric Field object to add the script to your form.
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Adding the Terms and Conditions section

Now you can add the terms and conditions explaining how the items will be paid for.

1 In the Object Library palette, click the Standard category and then drag the Text Field object  onto the form under the table beside 

the calculations.

2 Name it Terms and Conditions.

You may have to resize the field so that you can fit the caption. To do this, move the cursor over the left border of the field. Click and 

drag to resize. 

3 In the Object palette, click the Field tab and select the Allow Multiple Lines option.

4 Select Solid Box from the Appearance list.

5 In the Layout palette, select Top from the Caption Position list.

6 Drag to resize the box and make it bigger.

Adding the Authorized By Signature field object

If you want the person filling the form to use the Adobe Acrobat Signature feature to sign the document, you add a Signature Field object 

to the form design. 

1 In the Object Library palette, click the Standard category and then drag the Signature Field object  onto the form below the Terms 

and Conditions section.

2 Select the Signature Field object text and type Authorized By.

3 In the Object palette, select Underlined from the Appearance list.

4 Drag to resize the field and make it bigger.
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Your form should look like this now.



ADOBE LIVECYCLE DESIGNER ES2

What’s next? Creating a  Purchase Order Form

21

What’s next?

This type of form is just one of many types that you can create using LiveCycle Designer ES2. For additional information about creating 

forms, see the topic "About forms" in LiveCycle Designer ES2 Help.

You may also want to complete the tutorial Creating a purchase order form that has a flowable layout.

http://www.adobe.com/go/learn_lc_designer_9
http://www.adobe.com/go/learn_lc_qs_poformflowable_9

