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System Requirements

 Windows prerequisites
— Server — Windows XP or higher
— Admin console — Windows XP or higher
— Agent — Windows XP or higher

 Mac OS X prerequisites
— Server — Mac OS 10.4 or higher
— Admin console — Mac OS 10.5 or higher
— Agent — 10.3.9 or higher

- NO HARDWARE REQUIREMENTS, only recommendations

— Check Absolute Manage Optimization Guide in Resource Center -
http://www.lanrev.com/nc/support/resource-center.html - for hardware
recommendations for different site sizes

— You may get less than peak performance on lesser hardware than the
recommendations. You also need to configure settings according to the
guide.
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Server Best Practices

* Reserve a static IP address or your server

« Set up a DNS name for your server — Required to manage clients over
internet if you want to keep the server inside your firewall (#2 below)
— Benefit — makes it easier to move your server later
« For managing clients over the internet
1. Put your server in the DMZ or
2. Set up a split DNS that resolves both internally and externally
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Resolves internally to private IP
Resolves externally to public IP of internet router

Set up port forwarding on internet router for TCP 3971 to the internal
IP address

Net result is agent traffic always routed to internal IP address of
server.




Installing the Server

« Step by step

— Windows Server
* Unzip the Absolute Manage ZIP file
» Double-click the ‘Absolute Manage Server\setup.exe’ file
» Click Next or Continue through the rest of the prompts

— Mac Server
* Mount the Absolute Manage DMG
* Double-click the Absolute Manage Server.pkg file
» Click Next or Continue through the rest of the prompts
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Installing the Admin Console

« Step by step
— Windows
* Run the ‘Absolute Manage Admin\setup.exe’ file
» Click Next or Continue through all the prompts
— Mac

» Drag the Absolute Manage Admin.app package to the /Applications
folder
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Post-Installation Setup Wizard

1. Launch admin console from the Start menu or the /Applications
folder

2. Atthe login screen enter the address (IP, hostname, DNS name) of
your server, leave the port as 3971, and leave both Name and
Password blank

3. At registration dialog fill out ‘Name’ and ‘Company’

— Demo button — Generates generic serial num/key (10 seats each of AM
and MDM for 45 days) or

— Enter custom ‘Serial number’ and ‘Activation key’

4. At default administrator account screen enter username/password to
be assigned to default superadmin account

5. You'll be logged into the server using this default superadmin
account at end of the setup wizard
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Exporting the SSL Server Certificate

Since version 5.3, Blowfish encryption has been replaced with SSL
encryption. The benefit of this is that the session key is not hard coded
but dynamically generated for each session so it's much harder to
circumvent. The session key is what allows you to decrypt the data
transmitted. The server certificate from your server must be installed on
every agent. Otherwise the server will discard traffic from the agent if it's
not present.

1. Go to Window > Server Center.

2. Click Hide/Show Server or Server Setup in the menu bar and pick
Server > Server Settings on the left-hand pane.

3. Click the Save Certificate button at the bottom on the right-nand
pane.

AbsoluteSoftware



Customizing the Agent Installer

1. Go to Edit > Settings or Absolute Manage Admin > Preferences and
click the Deployment tab.

2. Click on the Set button for SD Server, enter in the IP or DNS
address of your Absolute Manage server, click the Set button, select
the server certificate you saved, and click OK.

3. Click on the Set button for LM Server and follow the same steps as
the SD Server settings.

4. Click on the plus sign in the lower left, enter in the IP or DNS
address of your Absolute Manage server, click the Set button, and
select the server certificate you saved.

5. Check any other optional information you want to inventory
automatically and click OK.

6. Close the Settings or Preferences window.
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Customizing the Agent Installer

Inventory Server Properties E|
Inventory server address; | oberon.lanrevcorp.com |
Part: | 3971 |
Heartheat interval {min): | 15 |

|

Inventory push interval (min): | 720

S0 Server: oberon.anrevcorp.com:3|  Set, ., Inventory server certificate:  walid Set...

LM Server:  oberon.lanrevcorp.oom:3] et Send inventory: () Basic

Inventaory servers (%) standard

Include Fant inf ki
aM Server Address | Pork | Basic Inv, Only | Heartbeat Interval(mind = Inventory Push In [Jinclude fant information

oberon.lanrevcorp,,, 3971 Mo 15 720 Includs printer information
[l 1nclude skartup item information (Macinkosh anly)
Include services information (Windows only)
Installed software
Scan installer receipts
Scan Far missing operating system patches

[]5can For applications:

(] 4 l[ Zancel ]
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Exporting a Customized Agent Installer

If you need to deploy the agent some other way besides the Agent
Deployment Center — such as via AD GPO, ARD, some other client
management system, or manually — export the agent installer.

1. Go to Window > Agent Deployment Center.

2. Find any agent machine that says OK for the Access Status column,
right-click, and pick Install Agent.

3. Click the Export Installer Package button at the bottom of the
window.

When deploying via AD GPO make sure to deploy the 1SScript9.msi first
before deploying the LANrev Agent.msi.
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Agent Installation

« Manual installation

— Make sure you customize the agent first to point to your server and have
the server certificate specified

* Mass deployment

— Agent Deployment Center — Be sure to set up the Deployment tab first

* Requires Windows File & Printer Sharing or Mac Remote Login
Access for push install

* Requires credentials with admin access to target over network

* Finding target machines — scan Windows Network, AD, custom zones
(IP ranges)

o — gray - no Windows F&P or Remote Login access

e — red - Windows F&P or Remote Login access available
e — green - current or newer version of agent installed

o — yellow - older version of agent installed
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Agent Installation

* Mass deployment (continued)
— No Windows File & Printer Sharing or Mac Remote Login access
* Windows — Deploy custom agent installer MSI via AD GPO

* Mac — Deploy custom agent PKG installer via ARD’s ‘Install
packages’ command

« An admin console can only push-install agents to targets of the
same platform as itself
— Windows => Windows, Mac => Mac, but NOT Windows => Mac)

 Including custom agent as part of a disk image

— Windows — Stop ‘LANrev Agent’ service and delete following registry
value before taking disk image

e HKLM\SOFTWARE\Pole Position Software\LANrev
Agent\AgentSerialno

— Mac — Delete /Library/Preferences/com.poleposition-
sw.lanrev_agent_serialnumber.plist before taking disk image
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Configuring Absolute Manage
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Configuring the Admin Console

1. Go to Edit > Settings or LANrev Admin Console > Preferences and
pick the Deployment tab.

2. Enter the default username/password to be used for agent push
installs in the ADC.

zeneral | Deployment Center |Remn:-te Contral || Power Consurnpkion

sername: | | |

Password: | |

Password verification: | |

Agent pork: 3970

3. Disable the auto-scan option for the Windows Networking and Active
Directory protocols.  rtocos

Use Bonjour
Use Active Directary

[ ] Auto-scan when window opens
Lse Windows Metworking

[ ] Auto-scan when window opens
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Configuring/Customizing the Agent Installer

1. Pick the Deployment tab and configure the inventory, SD, and LM
server addresses and specify the server certificate file for them.

S0 Server: oberon.lanrevcorp.com:3|  Set, ..

LM Server: oberonlanrevcorp.comid|  3et. .

Irnventory servers

&M Server Address | Port | Basic Inv, Only | Heartbeat Intervalimind | Inventory Push Interval{mind
oberon,lanrevcorp,.., 3971 Mo 15 720

2. Specify SD and LM intervals appropriate for your site size from the
Optimization Guide.

3.  When configuring the inventory server choose heartbeat and inventory
intervals appropriate for your site size from the Optimization Guide.
Check optional inventory info to be gathered automatically.
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Optimizing Server Settings

Go to Window > Server Center > Show/Hide Server or Server
Settings. Then browse to Server > Server Settings on the left-hand
pane and pick the General tab on the right.

 Offline threshold - Adjust this to match your shortest heartbeat interval.
Any agent the server has not received a heartbeat from within this
interval is prefixed with a red offline dot.

» Server admin port - Consider changing this to 3972. This will allow you
to log in even when your server is swamped responding to agent
requests. By default the server listens for both admin and agent traffic
on the same port, 3971.

* Run database maintenance every - Should be set to every 1 day.

« Backup database every - Should keep at least 21 days of backups, so
backup every 3 days and keep 7 backups at minimum.
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Optimizing Server Settings

General | Client Info Titles | License Monitoring | ODEC Expork || Ackive Direckbory | 05 MDM || FOG

Server

Offline threshold: rninutes

Maxirmurn number of entries in license hiskary:

Connection timeaout: seconds

Maximurm nurnber of connections:

Server admin port:

Server agent pork;

Server MDM server porkt: 3971

[Juse administrator information from server: none Set..,
[ ]Use custom Fields from server: none Set...
[ | Discard computer tracking data after: I:I days

Database maintenance

Run database mainkenance every EI days at |11;|:||:|;|:||:| =1 | [ Run Maow ]

Database backup
[+] Backup database every days at |11:3IZI:IZIIZI PR | [ Run Mo ]

keep backups
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Monitoring Your Server

The Server > Server Monitor area of the Server Center lets you
monitor the health of your server. From here you can view

e Current number of network connections open on the server

« Server uptime

« Date/time of last database maintenance and backup

- Admins tab — name, address, and date of current admins logged in
 Active Commands — current active commands being executed

« Caches — Cached agent requests if the server is under heavy load. If
the server is unable to process agent requests in a timely manner it will
cache them to disk and processes them later to free up network
connections.
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Monitoring Your Server

Server yersion: 5.4 (w1972)
Last ODBC export: 912010 2:37:26 PM {OFF)
Last database backup: 372011 12:51:50 PM (On)

Last database maintenance: 3/Z9/2011 10:00:00 PM {Cn)

Metwork connections: 1
Max. connections: 400
Max. simultaneous conn.: 12
Connections since launch: 1547

Uptime:
SErYer Yersion: 5.4 (w1972)

Last ODBC export: Qi1/2010 2:37:26 PM {OFF)
Last database backup: 3fF2011 12:51:50 PM (Cn)

Last database maintenance: 3292011 10:00:00 PM {On)

Metwork connections: 1

i Ackive Car
52 ) Max. connections: 400

Max. simultaneous conn.: 12

Count - Connections since launch: 1546

Uptime: 1 day, 14:33:55 Last status update: 313002011 12:21:05 AM
Admins (3 i
(3) | Active MNetwork connections: 1 SErvYer Yersion: 5.4 (w1972)
Max. connections: 400 Last ODBC export: af1/2010 2:37:26 PM (CFF)
I;P 1'??;8;;2 Max. simultaneous conn.: 12 Last database backup: 3/7I2011 12:51:50 PM (On)

Last database maintenance: 3/29/2011 10:00:00 PM {Cn)
/302011 12:21:45 AM

10,10, 160, 100 Connections since launch: 1547

10,10,10,201  Uptime: 1 daw, 14:34:36 Last status update:

admins (3 || Ackive Commands | Caches

Cached Agent request Cached Inventories

Get software packages:
Get 05 patches:

Get licensing packages:
Get distribution point:
Update installation status:
Update 05 patch status:

Report licensing status:

Maximum requests cached:
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Gather inwentory:
Regular inventory:
Other data gathered:
Other regular data:

Maximum inventory cached:

- O o O O




To Enter New Registration Information

Enter new key to increase number of licenses or converting demo to
purchase key.

Go to Server > Change Server Registration to enter your serial number
and new activation key.

Absolute Manage Admin - Registration

Ackivation key
Name:

COmpary': Absolute

Serial number:

Ackivation key:
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Upgrading from prior to 5.3

1. Upgrade the Server and Admin console.
2. Stop the LANrev Agent service on Distribution Points.
3. Install the customized Agent on Distribution Points.

For more details: http://www.lanrev.com/forum/viewtopic.php?t=618
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