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UUssiinngg  tthhee  RRiibbbboonn  iinn  EExxcceell  22000077  

The Ribbon is the backbone of the Office 2007 applications and is now your control center for creating 

a spreadsheet. Four tabs remain constant in each of the Office 2007 applications that use the Ribbon 

(Word, Excel, and PowerPoint): Home, Insert, Review, and View. Excel 2007 uses several additional 

tabs including Page Layout, Formulas, and Data (see Figure 1). The tab groups and features of each 

are outlined in the table below. To reduce clutter, some tabs are shown only when needed. For 

example, the Design tab for headers and footers is shown only when you click in a header or footer 

area. Likewise, the Chart Tools tab is shown only when a chart is selected. 

 

Tab  Functions 

Home tab 

Contains the Clipboard group, Font group, the typical formatting buttons for font type and 

size, bold, italic, color, alignment and so on in the Font and Alignment groups. Options also 

available for formatting numbers styles in the Number group. Formatting and cell appearance 

options in the Styles group.  Options for inserting/deleting cells, rows and columns in the Cells 

group. The Editing group holds the clear formatting command, Sorting and Filtering tools, and 

Find and Replace settings. 

Insert tab 
Contains all the things you might want to put on a spreadsheet — from tables, pictures, charts, 

and text boxes to hyperlinks, headers, footers, and symbols. 

Page Layout tab 

Contains many of the options that were found in the File menu and the Page Setup option of 

the older Excel programs. This includes: margins, page orientation, print area and print titles 

(all in the Page Setup group), options for scaling the pages and displaying gridlines/headings 

and commands for arranging objects in the Arrange group.  

Formulas tab All the Excel formulas you love to use are here.  

Data tab 
Pull data in from outside sources, use the sorting, filtering and other data related tools found 

on this tab. 

Review tab 
Find the spelling checker and other proofing tools here. Markup the spreadsheet with 

comments or turn on track changes and workbook protection. 

View tab 
Make a quick switch to any one of the five views, turn on gridlines, zoom in on sheets, or 

arrange all your open spreadsheets in the window. 

 

If your screen resolution is not set high enough, or if you do not have the Excel 2007 window 

maximized, you will not see the full listing of Ribbon tools. For example, with a higher resolution you 

will see all the commands in the Show/Hide group on the View tab. However, with 800 by 600 

resolution, you will see the Show/Hide button only, not the commands in the group (see Figure 2). 

 

In that case, click the arrow on the Show/Hide button to display the commands in the group. 

Generally, the groups that display only the group name at a lower resolution are those with less 

frequently used commands. 
 

 

Figure 1: The new Ribbon in Excel 2007. 
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If necessary, adjust the screen resolution used with your monitor. Use the maximize button in the upper 

right corner of the Excel window to expand the program so it fills the screen and the Ribbon expands 

to full size.  
 

LLooccaattiinngg  BBaassiicc  CCoommmmaannddss  

The Home tab holds the commands most people use frequently when they develop spreadsheets. This 

includes all the options for changing font types, styles, cell alignment, adding/deleting rows and 

columns, clearing cell formatting, and pasting content from other applications. If you need to change 

cell styles (for example, from text to currency), you'll find the commands for it in the Number group of 

the Home tab.  

 

The Insert tab contains all of the objects (Excel refers to some of them as "Illustrations") and text 

based components that you can add to the spreadsheet. An extensive list of charts you can insert and 

use can be found in the Insert tab. 

 

The Page Layout tab contains just about all of the features you need to manage the overall appearance 

of the spreadsheet. Most of the options on this tab (margins, scaling, print titles, etc.) were located in 

the FilePage Setup menu option of previous Excel versions. 

 

All keyboard shortcuts you may have used in previous versions of Excel work in 2007.  

 

To help you find Excel 2003 commands in the new Excel 2007 interface, you can use the interactive 

command reference guide found on the Microsoft Office web site. The guide maps all the previous 

menu commands to their new location in the Ribbon or elsewhere in Excel 2007. You can find the 

guide at the following web site: http://office.microsoft.com/en-us/help/HA101491511033.aspx 

 

TIP:  If you have the Getting Started tab installed, you can find the Interactive Guide in the Find a 

Command group on this tab. 
 

Additional file level options (new, open, save, save as, print, close, etc.) can be found by clicking 

the Microsoft Office Button in the upper left corner of the Excel window. 

Figure 2: The top image shows the View tab on the Excel 2007 Ribbon at a lower resolution. Notice the collapsed 

Show/Hide group with a small arrow below the group name. The bottom image shows the same tab on the Ribbon 
when displayed at a higher resolution. 
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DDeeffaauulltt  FFoonntt  CChhaannggee  

In Excel 2007, fonts in newly created spreadsheets look different than in previous versions of Excel. 

All new spreadsheets use the Body Font (Calibri font at 11 points) when you type data into the 

spreadsheet, header or footer, or a text box. The default Excel 2007 change in font face and size were 

designed with on-screen readability in mind.  

 

To change the default Excel 2007 font face and size, follow these steps: 

1) Click the Microsoft Office Button. 

2) Click the Excel Options button. 

3) In the Popular category, under When creating new workbooks, do the following (see Figure 3): 

a. In the Use this font box, click the font that you want to use. 

b. In the Font Size box, enter the font size that you want to use. 

4) Click the OK button to apply the change. 
 

NOTE:  To begin using the new default font and font size, you must restart Excel. The new default 

font and font size are used only in new workbooks that you create after you restart Excel; existing 

workbooks are not affected. 
 

 

FFoorrmmaatt  aanndd  EEddiitt  DDaattaa  

Editing data in Excel 2007 hasn't changed much since previous versions of Excel. You can still edit the 

contents of a cell by clicking the cell and retyping the information over the existing cell contents, 

pressing the F2 key to place the cursor in the cell for editing or edit directly from the Formula bar.  

 

Text and Cell Formatting 
You can change text formatting using the tools found on the 

Ribbon or the options in the Font dialog box. From the Home 

tab, use the options in the Font group to format text or cells (see 

Figure 4). Some of the font formatting options in this group 

have a small down arrow on the right side of the button. Click 

the arrow to see more formatting choices open in a drop down 

list. As you hover the mouse arrow over some of the choices in 

the list, you will see a preview of the change on the spreadsheet. 

 

To apply font formatting changes using the dialog box option, click the dialog box launcher in the 

lower right corner of the Font group found on the Home tab (outlined in the red box in Figure 4). 

Browse through the many font formatting options available in this dialog box. Adjust the settings for 

the font faces using the options in the Font dialog box and click the OK button when finished. 

Figure 3: Easily change the default Excel 2007 font. 

Dialog box 

launcher 

 

Figure 4: The Font group on the 
Home tab. 
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Figure 5: The Alignment group 

on the Home tab. 

Figure 8:  Format options appear in the smart tag 
after inserting a row within a formatted area. 

To align cell contents either horizontally or vertically within a cell, use 

the options available within the Alignment group on the Home tab (see 

Figure 5).  

 

Several preformatted cell styles are available in the Cell Styles option on 

the Styles group on the Home tab. These cell styles are based on the 

applied spreadsheet theme found on the Page Layout tab in the Themes 

group. 

 

The Format option in the Cells group found on the Home tab contains 

many of the commonly used options for changing columns and rows 

(see Figure 6). This includes: adjusting row height and column width, 

hiding and unhiding rows, columns and sheets.  

 

Clear Command 
Although not a new feature in Excel, the Clear command is available on 

the Home tab, in the Editing group. You can remove all cell formatting 

while preserving text formatting in selected cells (e.g., fill color, 

alignment, and borders will be cleared, but text color, font size, and font 

face will not be cleared). This feature was "hidden" in one of the many 

nested menus in previous versions of Excel. 

 

1) Select the cell(s) containing the formatting to be cleared. 

2) From the Home tab, in the Editing group, click Clear  

and select Clear Formats. 

3) The cell formatting is removed. 
 

 

IInnsseerrtt//DDeelleettee  RRoowwss  aanndd  CCoolluummnnss  

A common Excel task is to add or delete rows and columns from a spreadsheet. The 

options for inserting and deleting rows and columns are in the Cells group on the Home 

tab (see Figure 7). Oddly enough, the option for inserting rows and columns is not found 

on the Insert tab.  

 

When you insert rows or columns in an area of the 

spreadsheet where there is existing formatting (cell fill color, 

borders, etc.) you will be prompted with an option to retain 

formatting from adjacent cells or clear formatting from the 

newly inserted row or column. These choices are visible 

when you click the smart tag (small paintbrush icon) that 

appears in the area where you have inserted the new rows or 

columns (see Figure 8). Choose the appropriate option or 

simply ignore the paintbrush icon altogether. 

 

Additionally, you can still right click the column/row labels 

and choose Insert or Delete from the context menu that 

appears to add/delete columns and rows. 

Figure 7: The 
Cells group on 

the Home tab. 

Figure 6: The Format option 
found in the Cells group. 
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Figure 9: The Header area of a spreadsheet and related Design tab on the Ribbon. 

PPaaggee  SSeettuuppss  aanndd  PPrriinnttiinngg  

In Excel 2007, you'll find that the Page Layout tab contains the majority of the tools you need to setup 

the overall appearance of your spreadsheets. As mentioned in a previous section, this tab contains most 

of the settings from previous versions of Excel that were stored in the FilePage Setup menu option. 

You can still get into the familiar Page Setup dialog box by clicking the dialog box launcher in the 

lower right corner of the Page Setup, Scale to Fit, or Sheet Options groups. 

 

Page Layout View 
Page Layout view is new in Excel 2007. If you have worked in Print Layout view in Microsoft Office 

Word, this new view in Excel will look familiar to you. 

 

In Page Layout view there are page margins at the top, sides, and bottom of the worksheet, and a bit of 

blue space between worksheets. While in this view, there are rulers at the top and side that you can use 

to adjust margins. You can turn the margins on and off as you need them. 

 

To change views, click the View tab, and select a view in the Workbook Views group. Or select a view 

by clicking a button on the zoom slider toolbar  in the bottom right of the window. 

 

Headers and Footers 
Adding headers and footers to spreadsheets has changed in Excel 2007. Headers and footers repeat on 

every printed page of the worksheet and each worksheet in a workbook can have different headers and 

footers. In previous versions of Excel, you worked in a dialog box to add a header or footer. Now, you 

can add and edit the header or footer directly in the Page Layout view while seeing the rest of the 

spreadsheet. 

 

To add headers and footers, follow these steps: 

1) Select the worksheet tab in the lower left corner to which you want to add the header or footer. 

2) If you are in Normal view, on the Insert tab, in the Text group, click Header & Footer. A 

header area appears at the top of the sheet and the Design tab is visible on the Ribbon. If you 

are already in Page Layout view, the header area is visible at the top of the sheet.  

3) One section of the header appears on the left of the top margin, one in the center, and one on 

the right. Although all three sections may not be visible, clicking in one of these areas will 

trigger that section to appear (see Figure 9). 



Up to Speed with Microsoft Office Excel  2007  

 

St. Joseph’s College   6 
Technology & Information Services 

4) Click the section of the header where you want to add content. 

5) Type in the text you want to repeat at the top of each printed page or click one of the options 

from the Header & Footer Elements group on the Design tab (current time, file name, etc.). 

a. To change the formatting of the text, select the text that you want to format.  

b. Select the Home tab and use the formatting commands in the Font group. 

6) To stop working with your header, click outside of it. 

7) If necessary, change your screen view back to Normal using the option on the View tab in the 

Workbook Views group. 

 

To add a footer to the spreadsheet, follow the same steps as listed above with the exception of a 

change in step 2. Before entering any text, click the Go to Footer button in the Navigation group 

on the Design tab. 

 

 

Print Preview 
Working in the Print Preview mode has changed in Excel 2007. To start with, there is no visible 

command for Print Preview on the Ribbon (you can add a button for it on the Quick Access toolbar). 

This option is found by clicking the Microsoft Office Button, pointing to the Print option and then 

clicking Print Preview.  

The spreadsheet view changes so there is only a Print Preview tab on the Ribbon. There aren't too 

many tools within the tab and each is pretty self-explanatory. Notice the large Close Print Preview 

option (see Figure 10). Use this option to return to the Normal spreadsheet view; not the "x" in the 

upper right corner of the program window that you may have used in previous versions of Excel. 

 

 

Zooming Controls 
You can quickly zoom in to get a close-up view of your spreadsheet or zoom out to see more of the 

page at a reduced size using the new zoom slider (see Figure 11). In the lower right corner of the status 

bar, drag the zoom slider or click the plus/minus buttons to adjust the zoom to suit your needs. The 

center point of the slider is equivalent to 100%. 

TIP:  Additional zoom options are found on the Ribbon in the Zoom group of the View tab or by left 

clicking the displayed percentage on the left side of the zoom slider . 

 

 

Figure 10: The Print Preview option in Excel 2007. 

Figure 11: The new zoom slider in Excel 2007. 

Excel view buttons 
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SSoorrttiinngg  aanndd  FFiilltteerriinngg  DDaattaa  

Sorting and filtering are powerful Excel tools that can help you manage large lists. You can sort data 

by text (A to Z or Z to A), numbers (smallest to largest or largest to smallest), and dates and times 

(oldest to newest and newest to oldest), or by font or cell colors in one or more columns. Filtering 

allows you to display only data that meets certain criteria. For example, only records where the 

abbreviation NY is found in the State field. If you had used these tools in previous versions of Excel, 

you'll notice some changes when you use these tools in Excel 2007. 

 

Sorting Data 
Older versions of Excel limited sorting to up to three sets of criteria. In Excel 

2007, you can sort by up to 64 columns. To sort data follow these steps: 

1) Make sure there are no empty rows or columns in the list (remove 

them if any are found). Click any cell inside the list. 

2) On the Home tab, in the Editing group, click Sort & Filter and then 

click Custom Sort (see Figure 12). The Sort dialog box is displayed.  

3) If your list has a header row, make sure the "My data has headers" box 

is selected. Click the box if it is not checked. 

4) Under Column, in the Sort by drop down list, select the first column 

that you want to sort (see Figure 13). 

5) Under Sort On, select the type of sort. Do one of the following: 

a. To sort by text, number, or date and time, select Values. 

b. To sort by format, select Cell Color, Font Color, or Cell Icon. 

6) Under Order, select how you want to sort. Do one of the following: 

a. For text values, select A to Z or Z to A. 

b. For number values, select Smallest to Largest or Largest to Smallest. 

c. For date or time values, select Oldest to Newest or Newest to Oldest. 

d. To sort based on a custom list, select Custom List. 

7) To add another column to sort on, click Add Level and then repeat steps four through six. For 

example, you may way to sort on the column that contains the list of majors and then last name 

or last name and then town. 

8) To delete a column used for the sort, select the entry and then click Delete Level. (You must 

keep at least one entry in the list.) 

Figure 12: Sort & Filter 
option in the Editing group. 

Figure 13:  Choose the columns to be sorted on in the Sort dialog box. 
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9) To change the order in which the columns are sorted, select an entry and then click the Up or 

Down arrow to change the order.  Entries higher in the list are sorted before entries lower in the 

list. 

10) Click the OK button when you are finished. Excel sorts the list based on the criterion you 

selected. 

 

Using AutoFilter 
To filter an Excel database to just a relevant list of records, follow these 

steps: 

1) Make sure there are no empty rows or columns in the list (remove 

them if any are found). Click any cell inside the list.  

2) On the Home tab, in the Editing group, click Sort & Filter and then 

click the Filter option. The filter arrow appears at the right end of 

each of the cells in the header row. 

3) Click the filter arrow at the right end of the first cell in the column 

you want to filter.  

4) All of the possible data entries in the column are selected in the filter 

list.  Click the check boxes to the left of each item you want to 

include or remove in the filter or click the box next to (Select All) at 

the top of the list (see Figure 14).  

5) Click the OK button to filter the Excel list. 

 

To clear the filter, on the Home tab, in the Editing group, click Sort & Filter 

and then click the Clear option. 

 

There are additional text and number based filters available when you click the filter arrow at the right 

end of the first cell in the column you want to filter. These additional filters, found by pointing to the 

Text Filters option, allow you to focus on ranges of data or locate partial matches (e.g., all zip codes 

that start with 117). 

 

CCrreeaattiinngg  CChhaarrttss  

The entire charting engine in Excel 2007 has been overhauled. In previous versions of Excel, you used 

a Wizard interface to gradually build the chart by adding in each element found in a series a tabs. Now, 

you can quickly insert a chart and use specific chart related tabs on the Ribbon to add, remove, and 

change chart elements. 

 

The type of chart you choose depends on the type of data you have, how much data you have, and the 

message you want to communicate. Choose one of the 11 Excel chart types by following these steps: 

1) Select the range of data to be charted. 

2) From the Insert tab, in the Charts group, click the type of chart you prefer (see Figure 15). A 

pull-down list of gallery choices appears. 

Figure 14: A sample AutoFilter 

list of entries.  

Figure 15: Available chart types are listed in the Charts 
group on the Insert tab. 
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Figure 17: Creating a PDF version is as easy as saving the file. 

3) Click the specific chart subtype you want from the list of choices in the gallery.  

4) Excel places the chart as an embedded object on the current worksheet and the Design, Layout, 

and Format tabs appear on the Ribbon under Chart Tools. 

 

When you create a chart, the chart tools become available and the Design, Layout, and Format tabs are 

displayed (see Figure 16). You can use the commands on these tabs to modify the chart so that it 

presents the data the way that you want. For example, use the Design tab to make changes to the 

source data of the chart, change the location of the chart, change the chart type, or select predefined 

layout and formatting options. Use the Layout tab to add or change the display of chart elements such 

as chart titles and data labels, use drawing tools, or add text boxes and pictures to the chart. Use the 

Format tab to add fill colors, change line styles, or apply special effects. 

 

FFiillee  FFoorrmmaattss  aanndd  CCoommppaattiibbiilliittyy  

Saving as PDF 
Generating a printable version of your spreadsheet hasn't changed in Excel 2007. You can still print the 

spreadsheet, the entire workbook or just a selected range of cells on paper. New to this version is the 

ability to save a PDF version of the spreadsheet. With just a few clicks you can generate a non-editable 

PDF file that can be emailed, distributed on CD, or uploaded into your Blackboard course. 

1) Click the Microsoft Office Button  in the upper left corner of the program. 

2) Point to the Save As option in the Office Button menu. 

3) Click the PDF or XPS option in the Save as submenu. 

4) In the Publish as PDF dialog box, browse to the location where you want to save the file using 

the drop down list in the Save in field at the top. 

5) Enter a meaningful file name in the bottom of the dialog box (see Figure 17). If you plan to 

distribute the PDF via email or Blackboard, avoid using spaces in the file name. Instead, use a 

hyphen or underscore. 

6) In the Optimize for area, choose Minimum size. 

7) Click the Options button to view additional options available before the PDF is created. 

8) Click the Publish button to save the PDF. 

 

Figure 16: The Design tab under Chart Tools provides tools needed to change the chart type, layout, style, and location. 
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New Spreadsheet Format (xlsx) 
Excel 2007 automatically saves new spreadsheet files in a new format (Excel Spreadsheet .xlsx). There 

are several benefits to using the new file format including: reduced file size, improved blocking of 

malicious code, improved damaged file recovery, and easier integration with other applications. You 

can open old spreadsheets just fine and save in the new format. However, the file format change does 

affect spreadsheet sharing between Excel 2007 and older versions of Excel. 

 

There's no problem opening and editing an older spreadsheet in Excel 2007. What you'll need to decide 

is whether to keep the spreadsheet in its original format or save it in the new format. Excel 2007 

recognizes the spreadsheet, when you open it, as being in the old format and Compatibility Mode is 

activated. In compatibility mode, you can open, edit, and save Excel 97–2003 spreadsheets, but you 

won't be able to use all of the new Excel 2007 features. Behind the scenes, Excel takes note of 

anything you add to the file, such as a new SmartArt graphic, that may not work exactly the same in 

the old format. 
 

Then, when you click Save, Excel displays the Compatibility Checker dialog box. The Compatibility 

Checker warns you about any content that may be incompatible with versions of Excel earlier than 

Excel 2007. You can cancel the checker and select the new format in the Save As dialog box. Or, you 

can choose to continue and save in the old format. 
 

 

Converting Older Spreadsheets 
The Convert command in Excel 2007 provides you with a way to save an older spreadsheet in the new 

2007 format. The effect is that Excel does an "in place" replacement of the old spreadsheet file format, 

converting it to the new format. Converting an old spreadsheet into the new will replace the original 

version of the file. However, you can convert a spreadsheet into the new format and retain the original 

file. Both sets of directions are listed below.  
 

You do not have to convert all of your old Excel spreadsheets into the new file format. Only convert if 

you want to use some, or all, of the new features of Excel 2007. 
 

To use the Convert command, follow these steps: 

1) Open the spreadsheet. 

2) Click the Microsoft Office Button  and click the Convert option. 

3) Click the OK button in the warning dialog box that appears. 

4) The original version of the spreadsheet has been replaced with the new. Edit the spreadsheet as 

needed and resave it as you normally would. 
  

To use the Save As command, to save a copy of the spreadsheet in the new format and retain the 

original spreadsheet in the old format, follow these steps: 

1) Open the spreadsheet. 

2) Click the Microsoft Office Button  and click the Save As option. 

3) Browse to a folder location where you can save the spreadsheet.   

4) Enter a file name at the bottom of the Save As dialog box. 

5) In the Save as type field, choose Excel Spreadsheet. 

6) Click the Save button. The old file will still exist in the old format in the original folder 

location. 
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Saving Down 
If you are taking the spreadsheet to a computer that does not have Excel 2007, or you are sending it to 

an individual who does not have the new version, you should save the file in the older spreadsheet 

format. This makes the file more accessible for those users who cannot open the new spreadsheet file 

format. 

1) Click the Microsoft Office Button  in the upper left corner of the program. 

2) Point to the Save As option in the Office Button menu. 

3) Click the Excel 97-2003 Spreadsheet option in the Save as submenu. 

4) In the Save as dialog box, browse to the location where you want to save the file using the drop 

down list in the Save in field at the top. 

5) Enter a meaningful file name in the bottom of the dialog box.  

6) Click the Save button. 
 

 

GGeettttiinngg  HHeellpp  

The Microsoft Office Help system provides concise, printable descriptions and procedures for virtually 

any Office feature. The Help system is useful for troubleshooting problems and explaining specific 

subjects. The topics found in the Help system are actually stored in an extensive help library on 

Microsoft's Office web site. The Help system in the Office 2007 programs utilizes a direct connection 

to this web site and allows for updated and new content (click the button in the lower right corner of 

the Help window to check the connection). 

 

To open the Help system, click the HELP icon  in the upper right corner of the screen (or press the 

F1 key on the keyboard) to open the Help dialog box. There are a number of buttons available in the 

Help toolbar at the top of the Help dialog box to help you navigate through the Help system: Back, 

Forward, Home, Print, Show Table of Contents, etc (see Figure 18). 

 

There are two ways to search for help topics. You can use the search text box at the top or you can 

browse Office Help for information on your subject using the links in the main area of the window. 

Figure 18: The Excel 2007 Help system dialog box. 

Help toolbar buttons 
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