Shelly Cashman Excel 2013 A
Chapter10: SAM Project la

FINN CAREER C ENTER

USING MACROS, CONTRO LS AND VBA WIIH EXC EL

PRO JEC TDESC RIPTION

Patrick Fitzgerald is the director of Career Development at Finn Technical Institute, a local
community college. The Institute offers workshops on resume writing, interview techniques,
and networking skills, along with job placement services for students at their on-campus
career center, Finn Career Center. Patrick has asked for your assistance streamlining the
process of entering workshop data into the Finn Career Center online listing. He would also
like your help streamlining the form used to update the Center’s mailing list.

GEIIING STARIED
e Download the following file from the SAM website:
o SC _Excel2013_C10_P1a_FirstLastName_1.xlsm
e Open the file you just downloaded and save it with the name:
o SC _Excel2013_C10_P1a_FirstLastName_2.xlsm

o Hint: If you do not see the .xIsm file extension in the Save file dialog box, do
not type it. Excel will add the file extension for you automatically.

e With the file SC_Excel2013_C10_P1a_FirstLastName_2.xlsm still open, ensure
that your first and last name is displayed in cell B6 of the Documentation sheet. If cell
B6 does not display your name, delete the file and download a new copy from the SAM
website.

e |f you see a Message Bar with a security warning at top of the Excel window, click the
Enable Content button in the Message Bar to enable the macros contained in the file
(refer to Figure 1).

Figure 1: Security Waming Message Bar

I  SECURITY WARNING Macros have been disabled. Enable Content

UICI’OSO l pro!u!l screens"ols use! WII" permission from H ICroso l !orporallon.
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e To complete this project you will need to display the Developer tab. To add this tab to
the Excel ribbon, click on the File tab to open Backstage view and then click Options.
In the Excel Options dialog box, click on the Customize Ribbon option and click the
Developer check box (see Figure 2). Click the OK button to close the Excel Options
dialog box and confirm the Developer tab appears in the Excel Ribbon.

Figure 2: Customize Ribbon section of Excel Options Dialog Box
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e To complete this project you will need to display the Form button to the Quick Access
toolbar. Follow the steps below to add this button to the Quick Access toolbar:

o Right click on the Quick Access toolbar and select the Customize Quick Access

Toolbar.

o Select the Commands not in the Ribbon option from the Choose commands
from list.

o Find the Form option on the command list (see Figure 3), select it, and then
click the Add button to add the Form command to the Quick Access Toolbar.

o Click the OK button to close the Excel Options dialog box and confirm the Form
option appears in the Quick Access Toolbar.

Figure 3: Customize Quick Access Toolbarsection of Excel Options Dialog Box
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PRO JEC T STEPS

1.

Go to the Event Schedule — 2018 worksheet and use the password
J@Nuary18 to unprotect the worksheet.

Select cell A4 and use a Data Form to enter a new record shown (using the
information shown in Figure 4) into the Event Schedule - 2018 worksheet.
The Event field value is intentionally left blank.

Figure 4: New Record for Event Schedule - 2018 Worksheet

3.

Event Schedule - 2018 (% =]

Event ID: |JAN_2018_R2

- Mew Fecord

Event: |

)
m
T
o
T

Event Description: | Resume Review

|
|
| ete
Event Type: | Resume Review |
Event Date: 1/30/2018 | Crnaga)
| FindPrev |
Event Time: |3:ﬂﬂ pm |
Event-Location: | Warner-200 |
EBuilding: |Warner |
o |
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In cell B4, enter a formula using the PROPER function that converts the text
in cell C4 to proper case. Copy the formula into the range B5:B11. Adjust the
width of Column B to best fit the content it contains and then hide Column
C.

Select cell J7. Make sure the Use Relative References option (in the Code
section of the Developer tab) is active and then begin recording a macro as
described below:

a. Set the name of the Macro to Event_Cleanup.

b. Set the shortcut key for the macro to Ctrl+ Shift+L (by pressing the
Shift and L keys at the same time).

c. Store the macro in the current workbook.

d. Set the description of the macro to This macro splits the Event-
Location entry into a Building and a Room entry. (including
the period).



With the macro recording, enter the formula = SEARCH("-",G7)
into cell J7.

Move to cell 17 and enter the formula =RIGHT(G7,3) into the cell.

Copy then paste the Value of cell 17 into cell 17 so that the cell
contains just a number, rather than a formula. (Hint: Ignore the
error about the number being stored as text.)

Move to cell H7 and enter the formula = LEFT(G7, J7-1) into the
cell.

Copy and then paste the Value of cell H7 into cell H7 so that the
cell contains a value, rather than a formula.

Stop recording the macro.
Assign the macro to the macro button labeled Entry Cleanup.

Confirm the macro works by selecting the cell J8 and running the
Entry_Cleanup macro (either using the macro button or the
shortcut command).

. Select cell J10 and run the Entry_Cleanup macro again to clean

up another entry in the Event Schedule - 2018 worksheet.

Use Figure 5 as a guide while formatting the Center Signup Form in steps 5-10.

Figure 5: Center Signup Form Worksheet
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10.

11.

Go to the Center Signup Form worksheet. Add an Option Button (Form
Control) to the worksheet, using Figure 5 as a guide. (Hint: The button
should be located in the range D18:E19.)

a. Edit the text in the control to read Remove from List.

b. If necessary, resize and reposition the control so that the control
text is completely visible and completely within the Group Box 9
control.

Select the option button labeled Option Button 8 and then edit the text to
read U.S. Mail (as shown in Figure 5).

Select the four option buttons in the range F9:G15. Align the option buttons
using the Left option and then vertically distribute the buttons.

Add a Group Box (Form Control) that complete encloses the four option
buttons in the range F9:G15, using Figure 5 as a guide. (Hint: Your Group
Box control may have a different label than the one shown in Figure 5.) Make
sure that the Group Box control completely encloses the four option buttons’
text fields, which may be wider than the text displayed for each button.

Format the option button control labeled Email, so that it has a cell link to
$K$45.

Add a Check Box (Form Control) into the worksheet, using Figure 5 as a
guide (Hint: The Check box control should be located in the range D24:E24).
Update the Check Box Control as identified below:

a. Edit the text in the control to read Other.

b. If necessary, resize and reposition the check box control so that
the control text is completely visible and the check box control is
located within the range D24:E24.

c. Format the Check Box control so that it has a cell link of $R$44.

In cell L44, use the INDEX function to return the value from the named
range Request_Type (which represents the range V44:V46) based on value
in cell L45.



Use Figure 6 as a guide when adding a record in step 11.

Figure 6: Center Signup Form Worksheet with New Record
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¢ FINN CAREER CENTER
7 Workshop Mailing List
8
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City Zip Code
11 N 73000 3
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16
17 Group Box 9
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23 Writing Resumes ] Writing Cover Letters [ Interview Techniques
Networking Skills Job Search Tools [ other
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12. Add a record to the Center Mailing List by completing the following steps:

a. Use the button labeled Click to Enter Contact I nformation to
enter the information shown in Table 1.



Table 1: Center Signup Form Information

13.

14.

Field Value

First Name Finn

Last Name Callahan .
Street 234 W. Main St. §
City Norman é:)
Sta te Oklahoma g
ZIPcode 73000 §
Daytime Phone 405-555-2313

Evening Phone 405-555-0003

Email Finn_Callahan@example.fcc.edu

b. Select the Daytime Phone for the Contact By option. (Hint: You
will need to manual select this option — you will not be prompted
by message boxes.)

c. If necessary, select Add to List for the Request option.

d. Select the Writing Resumes, Networking Skills, and Job
Search Tools check boxes.

e. Confirm that your worksheet matches Figure 6 and then click the
button labeled Click to Submit I nformation.

Switch to the Visual Basic Editor view. (Hint: Click the View Code button in
the Controls section of the Developer tab.) Open the immediate window and
run the following code:

Sheets(“Center Sighup Form”).groupboxes.visible=false

Then, switch back to the Center Signup Form worksheet and confirm that the
Group Box borders are no longer visible. (Hint: If the code above produces an
error, you can also try using the code activesheet.groupboxes.visible=false
to produce the same outcome. For this code to work, the Center Signup Form
worksheet will need to be the active worksheet.)

With the Center Signup Form worksheet active, turn on Design Mode. Select
the button labeled Click to Clear I nformation (on the Center Signup Form
worksheet) and view the code associated with this button. Enter VBA code
shown in Figure 7 as the procedure that will occur when CommandButton3 is
clicked. (Hint: Remember there are no spaces before or after the parentheses
in the VBA code, even if it appears that way in Figure 7.)



Figure 7: CommandButton3_Clic k() Procedure

Private Sub CommandButton3 Click()
'Enter VBA code to Clear Data below
REange ("BE44:J44") .ClearContents
REange ("E45:L45") .ClearContents
REange ("M44:R44") .ClearContents
REange ("B&") .5elect

End Sub

Confirm your VBA code is correct by switching back to the Center Signup
Form, turning off Design Mode, and clicking the button labeled Click to Clear
Information. The range B9:G24 should be blank and none of the controls
should be checked.

Your workbook should look like the Final Figures on the following pages. Save your changes,
close the workbook, and exit Excel. Follow the directions on the SAM website to submit your
completed project.

Final Figure 1: Event Schedule - 2018 Worksheet

A B D E F G H | ]
; ey e |
3 Event ID Event Event Type Event Date EventTime  Eveni-Locafion  Building Room
4 [JaN_2018_R1 Resume Writing: Maximizing Your First Imprassion Resume Writing Wadnesday, Janvary 10, 2018 5.00 PM Warner 280
5 JAN_2018_N1 Networking Skills: Discovaring Your Hiddan Network Networking Skills Sunday, January 14, 2018 3.00 PM Warmner 180
& JAN_2018_C1 Writing Cover Letrers: Rising Above The Pack Writing Cover Leftars Waednesday, January 17, 2018 5:00 PM Wamer 280
7 JAN_2018_1 Inferviewing Techniques: Tips And Techniques Interview Technique Wednesday, Janvary 17, 2018 7:00 PM Lyons-110 Lyons " e 6
5 |1AN_2018_N2 Networking Skills: Alumni Event Netwarking Skills Friday, January 19, 2018 5:00 PM Smithfield-100  Smithfield 100 n
9 JAN_2018_C1 Writing Cover Letters: One-On-One Reviews And Critiques  Writing Cover Leftars Sunday, Janvary 21, 2018 5:00 PM Wamer-280 Warner 280
10 |JAN_2018_O1 The Job Search: Preparing For A Marathon, Not A Sprint Other Sunday, January 28, 2018 3.00 PM Wamner-280 Wamer | 280 7
11 JAN_2018_R2 Resume Raview Rasume Review Tuesday, Janvary 30, 2018 3.00 PM Warner-200 Warmner 200
12
13
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Final Figure 2: Center Signup Form Worksheet
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15 Email
16
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18 Request: €3 Add to List ) Update Information (") Remaove from List
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21 Select the topics you be interested in learning more about at the Finn Career Center:
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23 [] writing Resumes [] writing Cover Letters [] Interview Techniques
4 [ Networking Skills [] Jeb Search Tools [] other
25
26
27
28
29
30
Documentation Event Schedule - 2018 Center Signup Form | @
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