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PDF Web Form

In this project, you’ll create a PDF form that can be used to
collect user data online.

In this exercise, you’ll learn how to:

· Design a layout for a functional form.

· Add form fields and set properties.

· Publish a PDF form.
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PDF Web Form

To introduce you to the world of PDF forms, we’re going to create a
simple form to allow users to sign up to a newsletter. Along the way, we’ll
show you some of the valuable tools available in PagePlus.

However, before we dive in and start placing form objects, there are a
couple of things to do first that will save us time in the long run. Use a
blank piece of paper to complete these initial steps.

Creating the form design

Let’s think about the information we need to collect from our potential
newsletter recipients. At the very least, we’ll need to know who is
subscribing and their email address. However, we could also get some
information that might be useful for marketing campaigns at a later date.

Let’s assume that we want to
capture the following data:

· Name (first and last)

· Email address

· Age

· Gender

· Whether or not they want
to be informed of other
offers

The next step is to map out the form design with paper and pencil.
Although it’s tempting to skip this part, try not to. If you sketch your form
layout on paper first, you’ll end up with a better overall design and save
time as you’ll only place the objects that you really want.

To continue an earlier theme, we’re going to use a design to match the
poster that we created in the Artistic Text tutorial. You’ll find a project file
form.ppp in the ...\Workspace\Form folder.

In a standard installation, this is found in:

C:\Program Files\Serif\PagePlus\X4\Tutorials

 Design guidelines

· Keep your form simple and uncluttered.

· Group related form fields together.

· Give your form fields clear, meaningful labels
and position them consistently relative to
the object.

· Provide clear and simple instructions (use
ToolTips where necessary) to help users
complete the form as easily as possible.

· If users must complete certain information
on the form, be sure to indicate that these
fields are mandatory. For example, with an
asterisk or colour-coding.
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We drafted out the form design
illustrated here.

All we need to do now is recreate it in
PagePlus. Let’s get started...

To open the workspace document

1 On the File menu, click Open...

2 In the dialog, browse to the
Workspace folder, select
anaconda.ppp and click Open.

The document opens in the
workspace.

3 Next, on the File menu, click Save
As...

4 Name the document PDF form.ppp
and click Save.

Layout aids

The document has been set up using a 5 x 5 layout grid. If you can’t see
the grid, on the View menu, ensure that Trimmed Mode is unselected
and that Guide Lines are selected. This will help you to position the
elements.

Now we’re ready to start creating our form.

Creating the form text and labels

The form we’ve designed has two distinct
object types: text objects (information and
labels—blue) and form objects (for user
data—red). We’ll add the text objects
first.

We’ll assume that you’re already familiar
with using text objects so we’ll summarize
this section. If you need more help with
any of the steps, see the Artistic Text and
Frame Text tutorials, refer to the How To
tab or see online Help.
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To add the title and information text

1 On the Tools toolbar, click the Standard Text Frame tool.

2 Click and drag on the page to place a text frame approximately 1cm
high and 14.7 cm (4 columns) wide.

3 On the Text context toolbar, select the Title Col style and type in the
title, ‘NEW PRODUCTS FROM ANACONDA’.

4 Once again, click the Standard Text Frame tool.

5 Click and drag on the page to place a text frame below the title frame.
The text frame
should be
approximately
3.5 cm high and
should span all 5
columns of the
layout grid.

6 On the Text context toolbar, select the Body Text Normal style
and type your introductory text. Alternatively, press F5 to add
placeholder text.

Next we’ll place our form labels.

7 Click the Standard Text Frame tool. Starting just below the
previous frame, click and drag in the second column of the layout grid
to place a text frame 1 column wide and approximately 0.7 cm high.

8 On the Text context
toolbar, select the Body
Text Normal style and

click Align Right.
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From our form design, we know that we need 6 form items. Before we
type our first label name, let’s save ourselves some effort by using the
Replicate dialog to make copies our newly created text box.

9 With the text box still selected, on the Edit menu, click Replicate...

10 In the dialog:

· Select Replicate
Method to Create
grid.

· Set the Replicate
Count to Grid size, 1
x 6.

· Set the Spacing to
Gap and change the
Horizontal spacing to
0.0 cm and the
Vertical spacing to 0.3
cm.

· Click OK.

The six text frames appear
neatly aligned on the page.

11 Click inside the first text
box and type the label,
‘First Name’.

Dynamic Guides

To easily line up multiple objects, why not turn on Dynamic Guides?

· Click the arrow on the Snapping button. From the flyout menu, select

Dynamic Guides.

For more information, see online Help.
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12 In the subsequent text boxes, add the labels for:

· *Last Name

· *E-mail

· *Age

· *Gender

· Check this box to be informed of our
special offers.

13 Resize the final text frame to fit the text
by dragging the lower left corner handle
of the frame to the left of the page.

14 Finally, add a text frame to hold the
information about unsubscribing.

Your form should resemble the one
illustrated. Why not save your progress
at this point?

Now that we’ve completed our labels,
it’s time to add the form objects.

Creating the form objects

We’ll use the Form toolbar for this exercise, but you can also click
Insert > Form Field. The Form toolbar is a floating toolbar, which you
can drag to any position in the PagePlus workspace.

To view the Form toolbar

· On the View menu, click Toolbars and then click Form.

The buttons on the toolbar represent the form field types available. For
our first three fields we want users to type in their names and email
address. For each of these we’ll use a text field.

To create a text field

1 On the Form toolbar, click the Text Field button.

2 Move the cursor next to the ‘First Name’ label and click and drag to
insert the field.
Make sure that
the field spans
two columns of
the layout grid.
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3 Right-click the text field and then click Form Field Properties.

4 In the Name text box, type ‘First_Name’. Click OK.

5 Repeat steps 1 and 4 to add two
more text fields next to the ‘Last
Name’ and ‘E-mail’ labels. Rename the
boxes ‘Last_Name’ and ‘Email’.

Next we need to add a form field for the age range. Although we could
use a text field and get the user to type in their age, we don’t need to
be that exact. All we need to know is whether the user is under 18 or
18 and over. For this, we can use a radio button.

To add a radio button

1 On the Form toolbar, click Radio Button.

2 Move the cursor next to the ‘Age’ label and click
and drag to insert the radio button. (If you press
Shift while dragging, the aspect ratio will be
maintained.)

3 On the Transform tab, set the width and
height to 0.7 cm.

To insert a second button, we can copy the first.

4 Press and hold the Ctrl key while
clicking on the first button and drag it
to the right. An exact copy is created.

Text field properties

Each text field can have its properties customized. To do this, right-click the field and then
click Form Field Properties.

Within the dialog, you can adjust settings such as:

· Give a unique name to the field.

· Add a ToolTip to give the user information about the data field.

· Format the line around the text box, and the text that the user types into the box.

· Limit the number of letters that can be typed into the box.

For more information see online Help or the screen tutorial, Creating a PDF Expenses Form.
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5 Release the Ctrl key and position the button in line with the first with
a grid column between the two.

6 Right-click the first radio button and then click Form Field
Properties.

7 In the dialog, in the Name text box, type ‘Under_18’. Click OK.

8 Right-click the second radio button and then click Form Field
Properties.

9 In the dialog, in the Name text box, type ‘18+’. Click OK.

The default properties of the radio buttons will suit our needs for this
simple form. However, we do need labels to tell the user what the
buttons are for!

10 Click the Standard Text Frame tool and click and drag on the
page to place a text frame next to the first radio button.

11 On the Text context toolbar, select the Body Text Normal style
and type ‘Under 18’.

12 Repeat steps 10 and 11 to add a label for ‘18 and over’.

Our next step is to add a form field for ‘Gender.’ As there are only
ever two options for this, we can use a combo box.

To create a combo box

1 On the Form toolbar, click the Combo Box button.

2 Move the cursor next to the ‘Gender’ label. Click and drag on the page
to place the combo box.

Radio button properties

Radio buttons have special properties that include the Field Group. This allows buttons
that belong to the same group to work in a mutually exclusive way, ie. only one button
can be selected at a time.

For more information about this and other radio button properties, see online Help or
the screen tutorial, Creating a PDF Expenses Form.
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Now we need to set the properties.

3 Right-click the combo box and then click Form Field Properties.

4 In the dialog:

· On the General tab, in the Name text box type ‘Gender’.

· Click the Options tab.

· In the Item box, type
‘Male’ and click Add.
‘Male’ appears in the
Item list box.

· Repeat this process to
add ‘Female’ to the list.

· Click OK.

The combo box is now complete. We need to add one more form
field to our form—a check box.

To add a check box

1 On the Form toolbar, click the Check Box button.

2 Move the cursor next to the ‘special offers’ label and click once to add
the check box.

3 Right-click the newly placed check box and then click Form Field
Properties.

4 In the dialog:

· On the General tab, in the Name text box type ‘offers’.

· Click the Options tab and
select Checked by
default.

· Click OK.

Our form objects are complete. However, before we can publish the
form we need to add a Submit Button to allow the users to send the
data to us.
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PDF forms are only useful when you
can collect the data. A good way to
use this is to use the Submit
Button. When the user clicks the
button, the data is sent to either Serif
Web Resources or to your own Web
server. Setting this up is easy thanks
to the Form Submit Wizard.

To add a Submit Button

1 On the Form toolbar, in the  button flyout, click the Submit
Button.

2 In the Form Submit Wizard:

· Click Next to begin.

· Click Next to use Serif Web Resources.

· Type a Form ID or click the Get a Form ID button, then click
Next.

· Leave the Data format set to html and click Next.

· Click Finish.

3 Click and drag on the page beneath
the check box to place the button
between the layout guides.

Let’s give the button a useful name.

4 Right-click the button and then click
Form Field Properties.

5 In the dialog:

· On the General tab, change the Name to ‘Subscribe_btn’.

· On the Options tab, in the Caption box type ‘Subscribe’.

· Click OK.

The button text is updated on the page.

 To use Serif Web Resources,

you will need to set up an
account. For more information
on form data collection, see the
topic Collecting data from forms in
online Help.
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That’s it, your form is complete! To
check your form you’ll need to publish it
to PDF (it’s also a good idea to save your
form if you haven’t done so already). Let’s
look at this now.

You can export any PagePlus publication
as a PDF file—not just forms. This project
covers the basic steps and options. For
more information, see Exporting PDF files
in online Help.

To publish a PDF form

1 On the Standard toolbar, click

Publish as PDF.

2 On the General tab, in the
Compatibility drop-down list, select
the appropriate Acrobat version.

3 Select the Preview PDF File check box, and then click OK.

4 In the Publish to PDF dialog, type a file name for the PDF, and save it
in a convenient location.

The Publish to PDF dialog closes and
your form opens in your PDF reader.
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Now that you’ve finished your
form, the final step is to create
a link to it from a web page
and upload it to your website.
For more information on this
and other web publishing
features in PagePlus, see the
section, Producing web pages in
online Help.

 Your work is not finished yet—you still

need to check your form to make sure that it
works in the way you expect.

When checking your form, you should:

· Hover over the form fields and make sure
that any ToolTips are spelled correctly.

· Make sure you can type into all text fields.

· Check that all fields are long enough to hold
the typed text or predefined list item.

· Check the entries in the combo box drop-
down lists—are the items spelled correctly,
does all of the text display properly?

· Make sure that you can’t select more than
one radio button in a group.


