VAT Invoice Template with 2
Separate Rates in PDF Format

VAT Invoice Template with 2 Separate Rates was initially released on
http://www.InvoicingTemplates.com on Saturday, April 26, 2014, and is
categorized as Sales. As always VAT Billing Form with 2 Separate Rates was
published in two editions - one free VAT Invoice Template with 2 Separate
Rates, and another Uniform Invoice Software version that is able to turn VAT
Invoice Template with 2 Separate Rates into a complete invoicing system. This
"VAT Invoice Template with 2 Separate Rates in PDF Format" document
includes brief description about the template, as well as a PDF invoice form
exported from "vatinvoicetemplate2rates.xIsx".

Like VAT Invoice Template with 2 Separate Rates? Visit VAT Invoice
with 2 Separate Rates to download it for free.
VAT Invoice Template with 2 Separate Rates Features

and Facts

VAT Invoice Template with 2 Separate Rates was originally published on office-kit.com as a
sample on customizing the default sales invoice template included in Uniform Invoice Software
and a sample on using custom fields. It applies one of the defined VAT rates to each product /
item depending on its tax category.

Unlike the previously released ¢5005 VAT invoice template, InvoicingTemplates.com revised this
template and add the default LOGO image back to the invoicing template, at the top center of the
spreadsheet. In case you don't need it, you can move it out of the printable area, or delete it
completely. To do this, you'll have to first unprotect the spreadsheet, and then switch to design
mode.

The protection of the Invoice worksheet in VAT Invoice Template with 2 Separate Rates
prevents accidental modifications to layouts and formulas. If you have Uniform Invoice Software
installed, it could even display a warning message when you close a template without protecting
the invoice worksheet. However for the purpose of this sample, we should firstly unprotect the
Invoice worksheet in VAT Invoice Template with 2 Separate Rates.

In design mode, Microsoft Excel allows you to move, add, or delete controls or images inside
VAT Invoice Template with 2 Separate Rates. Here are how you can switch to design mode.

e In Excel 2003 click the Design Mode button on the Control Toolbox toolbar. Tip: If the Control
Toolbox toolbar is invisible, click Excel menu View > Toolbars > Control Toolbox.

e In Excel 2007, Excel 2010 and Excel 2013, click the Design Mode button in the Controls
group of the Developer tab.
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TIP: If the Developer tab is not available in Excel 2007, do the following to display it: a) Click
Microsoft Office Button, and then click Excel Options; b) In the Popular category, under Top
options for working with Excel, select the Show Developer tab in the Ribbon check box, and
then click OK.

Or in Excel 2010 and Excel 2013 to display the Developer tab: a) Click File > Options >
Customize Ribbon; b) In the area on the right, ensure that the box next to Developer is
checked; c) When you click OK, the Developer tab will appear in the ribbon.

Once you have finished your design work for VAT Invoice Template with 2 Separate Rates,
click the Design Mode button again to exit design mode.

To show gridlines and row/column headers in Excel 2000 - 2003:

1. Click and activate the worksheet you want to display gridlines and row/column headers for.
2. On the Tools menu, click Options, and then click the View tab.
3. Under Window options, check the Gridlines and Row & Column Headers check boxes.

After your customization, go back to the Tools menu, Options, View tab. Under Window options,
REMOVE the checks you previously placed by the two check boxes to hide gridlines and
row/column headers. This will restore the appearance of your template.

To show/hide gridlines and row/column headers in Excel 2007, Excel 2010 and Excel 2013:

1. Click and activate the worksheet you want to display gridlines and row/column headers for.
2. Go to the View tab of the Ribbon.
3. Click Show/Hide, and then check or uncheck the Gridlines and Headings options.

The gridlines and row/column headings could help a lot when design the layout of the invoice
form.

Once the Invoice worksheet is unprotected and switched to design mode, you can move the logo
image by dragging and dropping. Or to delete it completely, click to select it and hit DEL key on
your keyboard.

To replace the default LOGO image in VAT Invoice Template with 2 Separate Rates with your
own image, follow the steps below:

Right click the Logo image, and then select Properties from the menu.
Click the Picture property, and then click the "..." button.

Browse to the folder containing your icon file. Select and open the icon file.
Close the Properties dialog box.

Drag the border of the image object to resize it, if needed.

If you don't need the LOGO image and want to delete it, simply hit the DEL key on your keyboard
after you selected it with your mouse key. Deleting the LOGO image leaves an empty area to the
left of the Company Information section. You may like to move the entire Company Information
section to fill in the empty area. To do this: Drag your mouse to select the entire Company
Information area, including Company Name, Street Address, City, ST Zip Code, etc.; Push your
mouse key on the border of the selected area; drag it to the new location

To use the VAT invoice template

1. Set VAT tax rates.



Open the invoice template in Excel. Click the Settings button. On the Taxes tab specify the
tax rates for the two VAT taxes. Click Apply.

2. Create new customer accounts.

New customers can be added by either clicking the Save As New Customer button on the
invoice form, or by using the New Customer window that can be opened by clicking the
Customers button on the Invoice worksheet.

In either way, you can enter the VAT ID (VAT #) of the customer.

When creating invoices, you pick up a customer by clicking the icon button, the VAT ID of the
customer is retrieved along with other customer information. If a VAT ID is present, the
invoice is VAT free.

3. Create product/service items.

To add new products, click the Products button on the Invoice worksheet, and then click Add
Product. On the New Product window, you can find a TaxCategory field on the Custom Fields
tab; with this field you can specify the tax category of the current product or service item.
Please make sure the tax category you enter here matches the tax name you enter on the
Settings window.

Custom fields

VAT Invoice Template with 2 Separate Rates uses several custom fields to implement the
feature that are not found in the default sales invoice template shipped with Uniform Invoice
Software.

Fortunately Uniform Invoice Software support custom fields or user-defined fields, which is a
unique feature that allows you to add new fields to the backend database as well as to the invoice
form. VAT Invoice Template with 2 Separate Rates uses custom fields to implement the
features that are not available in the default sales invoice template. With the support for custom
fields in the database, Uniform Invoice Software has the ability to manipulate the newly added
fields in database, includes adding them to reports. With the support for custom fields in the Excel
worksheet, Uniform Invoice Software has the ability to create the relationship between fields - for
example, one field should be the sum of the other fields, or the value of one field should be
calculated only when another field value equals a certain value.

The support for custom fields makes it possible for even an end user who does not know
programming at all, could add new features to her/his invoicing creator such as VAT Invoice
Template with 2 Separate Rates without writing one line of programming code. For example, in
this tax invoicing template named Mixed Tax Rates in an Invoice, we implement the support of
mixed tax rates in the same invoice by using custom fields. The result of the customization is
offered in two editions, as what we do to all the other templates available here on
InvoicingTemplates.com, that are one freeware edition, and another edition that works only with
Uniform Invoice Software installed.

When working with Uniform Invoice Software version of VAT Invoice Template with 2 Separate
Rates, how does Uniform Invoice Software know to which cell when a field value write to when
loading data from the database, and to which field a cell value must save when saving an invoice,
a customer or a product item? That is, how does Uniform Invoice Software create the map or
relationship between Excel cells on the template VAT Invoice Template with 2 Separate Rates
and database fields? The answer is by using names. For example, if the field name in the Product
table in a database is "ProductType", it is writing to a cell named "oknProductType_?" (where ? is
the line number of the invoicing item) when you pick up a product or item on creating an invoice,
and when saving an invoice, all cells with the name "oknProductType_?" are saved to the
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"ProductType" field in the Invoice Body database table. By using cell names, Uniform Invoice
Software allows you to move a cell on the form without breaking the feature depending on the
field / cell. You can place the "Product Type" column either inside the printable area, which is
printed when you issue the Print command in Excel or click the Print command on the Invoice
form; or place the Product Type column outside the printable area, which will be included when
you print or extract an invoice.

VAT Invoice Template with 2 Separate Rates added custom fields to Customer, Product, Invoice
Header and Invoice Body database tables.

Adding a custom field to the Product table in the database makes it possible to save the field
value to database along with the other data of a product. For example, adding the custom field
"Product Type" to the Product database table allows you to save the type, such as "General" or
"Labor", to the database when you save a product or item. If you use Uniform Invoice Software
version template VAT Invoice Template with 2 Separate Rates and add the custom field to the
invoice form, the value is retrieved whenever you pick up a product on creating an invoice.

Adding a custom field to the Invoice Body database table makes it possible to save the data on
the invoice form to database when the "Save To DB" button is clicked. For example, adding the
custom field "Product Type" to the Invoice Body database table allows save the type value on the
invoice form, such as "General" or "Labor", to database when you save an invoice by clicking the
"Save To DB" button. This feature is not supported in the freeware edition of VAT Invoice
Template with 2 Separate Rates.

Note that custom fields is a powerful feature introduced by previous version of Uniform Invoice
Software, i.e. Excel Invoice Manager. The support for custom fields in Excel Invoice Manager
requires a database definition file ("FDINFO10.rst") to be present in the folder where the
database file was installed. With Uniform Invoice Software, using custom fields is much simpler
than in Excel Invoice Manager, and the database definition file is no longer required.

If your items have two VAT rates, download VAT Invoice Template with 2 Separate Rates for free
and test it to see if it meets your business requirements, or use it as a starting point of creating
your own invoicing form. Remember that Microsoft Excel already provides all the tools you need
to customize the template.
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Your company hame

[N
Your company address lﬂmlﬂﬂgrﬂmpfﬂf
Your company city, ST ZIP DATE: April 27, 2014
Your company contact info. INVOICE #:
VAT registration number (if VAT registered)
BILL TO: SHIP TO:
#
Name Name
Address Address
City, ST zZIP City, ST zIP
Country Country
Phone Contact
VAT #
P.O. # Sales Rep. Name Ship Date Ship Via Terms Due Date
Sales1 4/27/2014 UPS Net 60
Product ID Description Quantity Unit Price Line Total
SUBTOTAL
VAT (6%)
VAT (19%)
Notes: SHIPPING & HANDLING

THANK YOU FOR YOUR BUSINESS!

TOTAL
PAID
TOTAL DUE
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