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Chapter 1  
Before You Begin

1.1 About This Book

This guide describes how to use the Touch Sensing Software Electrode Graphing Tool (TSSEGT). The 

TSSEGT allows you to visualize the capacitance variance of electrodes when it is used along with the 

Touch Sensing Software (TSS). 

For more information on using the Touch Sense Software, refer to the Freescale Proximity website at 

www.freescale.com.

This document is intended for software, hardware, and system engineers who are developing their products 

or software applications using Touch Sensing Library to integrate capacitive sensing.

Table 1-1 shows the summary of chapters included in this guide.

Table 1-1. TSSEGTUG Summary

1.2 Reference Material

Use this book in conjunction with:

� Touch Sensing Software Users Guide (document TSSUG)

� Touch Sensing Software API Reference Manual (document TSSAPIRM)

� Touch Sensing Software EVB Users Guide (document TSSEVBUG)

For better understanding, refer to the following documents.

� Application note titled Designing Proximity Sensing Electrodes (document AN3863)

� Application note titled Touch Panel Applications Using the MC34940/MC33794 E-Field IC 

(document AN1985)

� CodeWarrior Help

Chapter Title Description

Before You Begin This chapter provides the prerequisites of reading this book.

Introduction This chapter provides an introduction for the Electrode Graphing Tool (EGT).

Electrode Graphing Tool 

Setup 

This chapter provides information about the installation process and requirements needed 

for the use of the EGT.

DEMOJM Setup This chapter explains the configuration and setup of the DEMOJM board.

Using the EGT Software This chapter explains all the functions of the EGT.

Troubleshooting This chapter provides guidelines to the most frequent errors when using the EGT. 
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You can download the latest version of the documents at Freescale website, www.freescale.com.

1.3 Conventions

This guide uses the following notations:

� Courier monospaced type indicates commands, command parameters, code examples, expressions, 

datatypes, and directives.

� Italic type indicates replaceable command parameters.

� All source code examples are in C.

1.4 Acronyms and Abbreviations

EGT Electrode Graphing Tool

GPIO General-Purpose Input/Output

MCU Microcontroller Unit

PC Personal Computer

TSS Touch Sensing Software 

TSSEVB Touch Sensing Software Evaluation Board
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Chapter 2  
System Overview

2.1 Introduction

The Electrode Graphing Tool (EGT) is a graphic user interface created to work with the TSS. EGT allows 

you to calibrate your TSS application for every electrode used in the system. EGT shows the behavior in 

real time of all the electrodes present in the system.

EGT uses a DEMOJM that serves as a bridge between the PC and the application. The DEMOJM board 

communicates with the application through IIC protocol and with the PC using USB protocol.

The DEMOJM board must be previously loaded with the EGT Communication firmware. The firmware 

can be downloaded from the Freescale web site at www.freescale.com.

Figure 2-1 shows the modules needed to use the EGT.

Figure 2-1. TSS and EGT Communication System
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Chapter 3  
Electrode Graphing Tool Setup 

3.1 Overview

This chapter describes the EGT installation process and the driver installation for the DEMOJM board.

3.2 Electrode Graphing Tool Requirements

To use EGT, you need to meet the following requirements:

1. Install Microsoft .NET Framework 2.0 or higher (installation will notify you if you have already 

installed it). You can get Microsoft .NET Framework on the Microsoft web site at 

www.microsoft.com/downloads/.

2. A DEMOJM board with the EGT communication firmware. The DEMOJM board serves as a 

bridge between the application's MCU and the PC. You can download the EGT communication 

firmware on the Freescale web site at www.frescale.com.

3. A Freescale MCU (any S08) and a properly designed hardware for electrodes (Freescale's 

TSSEVB board recommended). For more details on the electrode hardware needed to test the TSS, 

refer to TSSEVB board documentation.  

NOTE

EGT must be installed before plugging the DEMOJM board in the system. 

When you first plug a board in the system, the system will prompt you to 

install drivers. If this occurs, do not allow Windows to automatically search 

for and install the drivers.

3.3 Electrode Graphing Tool Installation 

This section describes the EGT installation process.

To install EGT, perform the following steps:

1. Get the latest version of EGT on the Freescale web site at www.freescale.com.

2. Unzip the EGTInstaller.zip file to a local folder in your computer.

3. Launch the Electrode Graphing Tool installer EGTInstaller.msi. The wizard installer window 

appears. Click Next to begin the installation process. 
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Figure 3-1. Wizard Installer Window

4. The Select Installation Folder window, as shown in Figure 3-2, will appear. Choose a destination 

folder or leave the default destination path. Select if application will be available for all users on 

the computer or only for the current user (administrator privileges are needed to make an 

installation for all users). The Disk Cost button shows the free space on your local drive and gives 

information about how much disk space the application will require. Click Next to continue.
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Figure 3-2. Select Installation Folder Window

5. The Confirm Installation window will appear. Click Next to start copying the files into your 

computer. A window indicating the installation progress will appear. After installation, a window 

indicating that the installation is completed will appear. Click the Close button.
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Figure 3-3. Confirm Installation Window

3.4 DEMOJM Driver Installation 

EGT needs a DEMOJM board with the EGT Communication firmware that serves as a bridge between the 

PC and the application. To start communication between the DEMOJM board and the PC, install the 

appropriate driver on the PC.

Install EGT before plugging the DEMOJM board into your PC.

This section describes the installation of the driver of the DEMOJM board.

1. Plug the DEMOJM board into the USB port of your computer. The New Hardware Wizard will 

appear. Check the Install from a list of specific location (Advanced) option and click Next. 
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Figure 3-4. New Hardware Wizard 

2. The system will prompt you to choose the path where the driver is located. Select the Include this 

location in the search checkbox, and click the Browse button.

Figure 3-5. Driver Path Window
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3. The Browse For Folder window will appear. Navigate to the driver location. The DEMOJM 

Board driver is included with the EGTInstaller. The driver resides in the installation folder 

c:\Program Files\Freescale\Electrode Graphing Tool\Driver. After finding the folder, click the OK 

button.

Figure 3-6. Browse For Folder Window

4. The window will be closed. Once the driver path has been set, click on the Next button.

Figure 3-7. Driver Path Window
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5. Windows will start installing the driver.

Figure 3-8. Driver Installation

6. After the installation, a window will notify you of the successful installation. Click the Finish 

button. The DEMOJM driver is now installed. 
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Figure 3-9. Driver Installation Complete
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Chapter 4  
DEMOJM Setup

You must correctly configure the DEMOJM board to ensure the correct operation of EGT. This section 

chapter describes the configuration process of the DEMOJM board. If you are using another 

communication board, refer to the appropriate documentation.

4.1 Hardware Setup

4.1.1 IIC Module

Connect the DEMOJM board to your TSS application. The DEMOJM board and the application's MCU 

communicate with each other using the IIC module. To locate the IIC pins from the MCU used on your 

application, refer to the MCU's Reference Manual. On the DEMOJM board, the IIC pins are located in the 

number 26 (SCL) and 28 (SDA) of the MCU Port. Figure 4-1 shows the pinout for the MCU Port 

connector on the DEMOJM board. For more information regarding the DEMOJM board, refer to the 

DEMOJM User Manual (document DEMOJMUM). 
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Figure 4-1. DEMOJM MCU Port

4.1.2 Power

Power the DEMOJM board using the same power supply that the TSS application is using to power the 

MCU. You can connect the power supply to the DEMOJM MCU port as shown in Figure 4-1. If you are 

using any other communication board, refer to the board documentation to ensure that no other power 

source is enabled in the board. 

4.1.3 Mini USB

Connect the PC to the DEMOJM board using a USB cable. 

To connect the PC to the DEMOJM board:

1. Connect one side of the cable to the Mini USB port located on the DEMOJM.
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2. Connect the other side of the cable to any free USB port of the computer.

NOTE

In case the driver has not been installed, follow the instructions presented in 

the section 2.3.

4.1.4 Application Setup

You must add the files that allow the application communicate with the DEMOJM board through IIC 

protocol. In addition, add a couple of instructions to your application code. This section will guide through 

the setup and configuration of the EGT communication module. 

Adding the EGT Communication Files

1. Select Start > Programs > Freescale CodeWarrior > CodeWarrior > CodeWarrior for 

HC(s)08 Development Studio.

2. From the CodeWarrior IDE menu bar, select File > Open.

3. On the Open File dialog box, find the project file (*.mcp) and click on the Open button. The IDE 

opens the Project.mcp as shown in the following figure.

Figure 4-2. Existing Project Structure
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4. When adding the EGT communication files to an existing project, create a group to store the TSS 

files together. From the CodeWarrior main menu, select Project > Create Group. The create 

group window appears. Enter a name for the group and click the Ok button.

Figure 4-3. Creating a Group

5. On the project window, click the group created to select this item. From the CodeWarrior main 

menu bar, select Project > Add Files. The Open File dialog box appears. Find the EGT 

Communication files, select all the files, and click the Open button. CodeWarrior adds the files into 

the group created. 
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Figure 4-4. Adding Files to the Group

6. Add the following files:

— I2CDvr.c

— I2CDvr.h

NOTE

Before adding the TSS files to an existing project, make a copy of the TSS 

files and paste them on the folder where the existing project is saved. This 

way, the files are better organized and the modification of the original TSS 

files is avoided. The TSS files should be copied to the 

c:\...Project\Source folder. Project indicates the name of an existing 

project where the TSS files are added.

4.1.5 Initialization Function

The EGT communication module must be initialized. 

To initialize the EGT communication module, perform the following steps:

1. Include the I2CDvr.h header file into the main.c file of the TSS application.



DEMOJM Setup

Touch Sensing Software Electrode Graphing Tool Users Guide, Rev. 1

4-6 Freescale Semiconductor

 

Figure 4-5. main.c File Definition

2. Call the I2CInit() to initialize the EGT Communication module. Add the initialization function 

into the initialization section of the application.

Figure 4-6. Communication Module Initialization

There are some MCUs that have more than one assigned pin for each IIC signal. Correctly configure the 

IIC pin signals in the application MCU.

4.1.6 Main Function

The EGT module includes a main task that must constantly be called by the user application like the TSS 

main task.

Add the EGT module main task EGTTask() to the main loop of your application.

Figure 4-7. Communication Module Main function
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Chapter 5  
Using the EGT Software

This chapter describes how to launch and use EGT.

5.1 Launch EGT

To launch EGT, perform the following steps:

1. Connect the DEMOJM board to your application board through the IIC module.

2. Connect the DEMOJM board to the PC through the USB cable.

3. To start EGT, select Start > Programs > Freescale > Electrode Graphing Tool > Electrode 

Graphing Tool.

EGT requires no further configuration since it automatically detects the electrodes present in the system. 

EGT should start the electrode measurements as soon as it is launched.

Figure 5-1. Electrode Graphing Tool Main Window
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5.2 Electrode Graphing Tool

This section describes the features of EGT. 

EGT features the following windows:

� Graph 

� Values 

� Config 

You can change between windows by clicking the tabs located at the top of the EGT window. Figure 5-2 

shows the tabs that allow you to select any of the windows.

Figure 5-2. Electrode Graphing Tool Tab Selection

5.2.1 EGT Graphs

The Graph window plots the capacitance measurements and the Baseline values of each electrode. 

5.2.1.1 Control Graph

This part of the Graph window plots the capacitance and baseline values. The capacitance values are 

plotted with a continuous line while the baselines values are plotted with a doted line. Each electrode is 

represented with a different color waveform.

Figure 5-3 shows the control graph.

Figure 5-3. EGT Control Graph
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5.2.1.2 Electrode Legend

The Electrode legend section shows the color waveform assigned to each electrode present in the 

application. Figure 5-4 shows the Electrode Legend section.

Figure 5-4. EGT Electrode Legend

EGT assigns one color for each electrode. However, you can choose the waveform color for each electrode. 

To change the plotting color of the waveform, perform the following steps:

1. Double-click any of the Electrodes Legends. The Change Color dialog box appears. 

2. On the Change Color dialog box, provide the number of electrode you wish to change color and 

click the OK button. 

Figure 5-5. Electrode Selection

3. A color selector dialog box (Figure 5-6) appears. Choose the new color for the waveform, and click 

the OK button. The waveform color will change.



Using the EGT Software

Touch Sensing Software Electrode Graphing Tool Users Guide, Rev. 1

5-4 Freescale Semiconductor

 

Figure 5-6. Color Palette

5.2.1.3 Selector Section

In the selector section, you can select the electrodes and baselines you wish to plot. By default, EGT plots 

all the capacitance values and baseline values for all the electrodes present in the application. Figure 5-7 

shows the Selector section.

Figure 5-7. Electrode and Baseline Selector

You can enable or disable all the electrodes capacitance waveforms at once by clicking the All checkbox. 

The same applies to the baseline waveforms. 

5.2.1.4 Plot Delta

EGT allows you to choose between plotting the capacitance measurements along with its respective 

baseline value or plotting the delta values. The delta value is the deference between the baseline value and 
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the capacitance value. To plot the delta values, click the Plot Delta checkbox. Figure 5-8 shows the Plot 

Delta checkbox. 

Figure 5-8. Plot Delta Option

5.2.1.5 Zoom

EGT features a zoom option so that you can observe in detail the capacitance and baseline waveforms. 

Figure 5-9 shows the zoom section.

Figure 5-9. EGT Zoom Control

By default, EGT starts with the automatic zoom. When the automatic zoom is selected, EGT automatically 

sets the limits on the vertical axis of the control graph. The limits are based on the capacitance values that 

the TSS is detecting on the electrodes. This way the zoom is adjusted so that you can see all the capacitance 

waveforms.

When the Manual zoom option is selected, EGT sets arbitrary limits to the vertical axis that may or may 

not show all the capacitance measurement waveforms. In the Manual Zoom option, you can establish the 

vertical axis limits. To establish the axis limits, perform the following steps:

1. Select the Manual Zoom option by clicking the Manual check box.

2. Click the lowest and highest values of the vertical axis and assign the new limit values.
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Figure 5-10. EGT Control Graph Vertical Limits

The Zoom option also allows you to zoom in a captured waveform. To do so, perform the following steps:

1. Select the manual zoom option.

2. Click the Stop Measurements button.

3. In the Control graph section, click and drag to select the part of the waveform you wish to zoom in. 
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Figure 5-11. EGT Control Graph Manual Zoom

4. As soon as you select the zoom in area, EGT will perform the zoom. 

Figure 5-12. EGT Zoom Selected Area

5. To restore the zoom function, click the Zoom Out button.  

5.2.1.6 Refresh Rate

EGT allows you to select the speed of the data refresh from the TSS application. To do so, perform the 

following steps: 

1. From the Refresh Rate section, select the desired refresh time rate. The minimum allowed value is 

3 ms.
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2. Click the Send button. Figure 5-13 shows the Refresh Rate section. EGT sets the refresh rate value 

to 8ms as default.

Figure 5-13. EGT Refresh Rate in Milliseconds

5.2.1.7 Data Logger

EGT allows you to save a log file of the plotted values into a csv file. To save a log file, perform the 

following steps:

1. Click the Output filename textbox to set the destination path where the csv file will be saved. A 

save file dialog box appears. 

Figure 5-14. EGT Control Graph Manual Zoom

2. Choose the destination path, set a name for the csv file, and click the Save button.

3. Click the Capture Waveform button to start saving the data.
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Figure 5-15. EGT Data Logger Option

4. To stop capturing, click again the Capture Waveform button. EGT will stop capturing and the file 

will be saved on the location specified.

If you want to capture again after you stopped, you must set the path and name of a new file. When the 

capture with Graph Disable option is selected, EGT will save the data but without showing the waveform 

in the Graph Control section.

5.2.1.8 Control Buttons

On the Graph window, EGT provides main control buttons that allow you to start and stop measurements 

and enable a feature that shows the status of the electrodes. Figure 5-16 shows the control buttons section.

Figure 5-16. EGT Control Buttons

� Start Measurements — To start the measurements, click the Start Measurements button. This 

button is disabled if there is no communication between the bridge and the EGT application. By 

default, EGT starts the measurements when launched without the need of clicking the button.

� Stop Measurements — To Stop the measurements, click the Stop Measurements button.

� Show Electrode Status — When you click the show Electrode Status button, EGT will launch a 

window showing the status of each electrode. The Electrode Status window includes one LED for 

each electrode present in the system. The LED will turn on when the corresponding electrode is 

detected as Touched. Figure 5-17 shows the Electrode Status Window.
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Figure 5-17. EGT Electrode Status

5.2.1.9 Values

The Values window provides information regarding the capacitance and baselines measurements. These 

values are plotted on the Graph window.
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Figure 5-18. EGT Values

5.2.2 Config

The Config window gives the opportunity to read the configuration registers of TSS. It also allows 

modification of the configuration registers in real time without the need of reloading the program on the 

MCU. You can modify the register values to test and debug the performance and behavior of the electrodes 

under different configuration parameters. The Config window also allows you to fine tune the sensibility 

parameters for each electrode.

To modify any value, change the value in the textbox of each parameter, and click the Write button.

You can use the Read all button to read all the parameters at once. 
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Figure 5-19. EGT Configuration Registers
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Chapter 6  
Troubleshooting

This chapter describes how to troubleshoot common errors when using the Electrode Graphing Tool.

6.1 Microsoft .NET Framework

To install and use EGT, you must install the .NET Framework version 2.0 or later. If you do not install the 

.NET Framework on your computer, the installer will help you to get it.

6.2 Device Connected Before Installation

If you connect the device before installing EGT, it is possible that the correct driver may not be present. 

Windows will then try to install another driver. An incorrect driver will cause the application not to 

communicate correctly. Uninstall the incorrect driver and install the driver. For the driver installation 

instructions, refer to Chapter 2, “Electrode Graphing Tool Setup” or update the driver.

6.3 Multiple Driver Installation

Every time you connect the device to a different USB port in your computer, Microsoft Windows will 

prompt you for driver installation. This is because when you install the driver, a virtual USB port is created.

6.4 Device Connected Before Launch

If you launch EGT before the USB is connected to computer, the application may not launch correctly. 

Always connect USB before to start the application.


