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ABSTRACT

From the end user’s perspective, the advantages of having an Excel graph include familiarity with Excel
application and the ability to modify the graph by changing the underlying data in the Excel spreadsheet.
Although the process of exporting the data from a SAS data set to an Excel file is relatively straightforward,
someone has to manually create and format an Excel graph, which can be a time consuming process. It is
possible to embed a SAS graph image into the Excel file, but this static graph cannot be altered once
created.

This paper presents a detailed step by step approach to programmatically create an Excel graph based on N
observations from a SAS data set. In most circumstances, we have a fixed number of variables with
unknown number of observations for creating an Excel graph. Therefore, we will perform a minor tweak to
the recorded Excel macro to satisfy this need.

This paper covers a little Visual Basic coding, but it is not necessary for you to know how to write it.

INTRODUCTION

Why bother creating an Excel graph when we can have a beautiful looking SAS graph? | often ask myself
that question when | receive these requests from my users. A little bit of my work experience... My job
focuses more on web application development where | build online data entry screens and customized web
reports for wide range of users, such as doctors, nurses etc... Most of the web reports consist of some
graphs created using SAS/GRAPH. While my users are satisfied with the reports, many of them later tell me:
“Excellent, now make them Excel graphs so that | can modify the graph myself”.

| can always create these graphs as images (JPG or GIF files) from SAS and insert them in the Excel file,
but these static images cannot be modified once created.

This is where DDE comes into play. Dynamic Data Exchange (DDE) allows two different applications, in this
case SAS and Excel applications, to interact with one another. Once the communication bridge is set up,
SAS uses X4ML commands to provide further instructions to the Excel application.

The goal of this paper is not to explain how DDE works or explore the X4ML commands, but to get you
going right away in creating an Excel graph from SAS. There are many great past SUGI papers on DDE and
X4ML topics, and it is highly recommended that you read them to learn more about the tips and tricks.
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GENERAL OVERVIEW
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In this paper, we will do the following example together:-

1.  SAS exports AIR data set from SASHELP library to an Excel file called AIR.XLS.
2. The “Macro1” Excel macro in TEMPLATE.XLS reads data and creates an Excel graph in AIR.XLS.
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First of all, the SASHELP.AIR data set has to be exported to an Excel file so that the Excel macro can read
the data and create an Excel graph. Although there are many ways for SAS to export the data to Excel file,
in this example, we will use PROC EXPORT to do so. Why? It’s fast, hassle free, and requires less code to
be written.

Once SAS exports the data to an Excel file (we called it AIR.XLS), SAS will communicate with the Excel
application using DDE by passing X4ML commands. The X4ML commands will open TEMPLATE.XLS and
execute “Macro1” Excel macro. This “Macro1” Excel macro will read data from AIR.XLS and create an Excel
graph in it.
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EXECUTING EXCEL MACRO FROM SAS

In this step, SASHELP.AIR data set is exported into an Excel file with an additional column called “Total”,
which basically keeps track of the total number of observations in the data set. Once the Excel file is
created, the X4ML commands will invoke the “Macro1” Excel macro in TEMPLATE.XLS to generate the
Excel graph.

/*****************************************************************

**% Clear SAS log and output.

*****************************************************************/

dm 'clear log; clear output';
options mrecall mprint mlogic symbolgen;

%racro creat eExcel G aph;
%local 1lib dsn xlsCmdPath outputPath xlsTemplatePath;

/*****************************************************************

*** Excel application path.
*****************************************************************/

$let xlsCmdPath = C:\Program Files\Microsoft Office\OFFICEll\excel.exe;

/*****************************************************************

*** Data library and data set name. In this example, we will
*** use "AIR" data set from "SASHELP" library.
*****************************************************************/
%$let lib sashelp;
%$let dsn = air;

/*****************************************************************

*** Excel template file path. This file should contain the Excel
*** macro called "Macrol".
*****************************************************************/

%$let xlsTemplatePath = C:\sugi\template.xls;

/*****************************************************************

**% Excel output file that will have the generated Excel graph.
*****************************************************************/

%$let outputPath = C:\sugilair.xls;

proc sqgl noprint;
/*************************************************************
**% Get number of rows in data set and store the count in
*** macro variable "total".
* % %
*** The dictionary.tables are special read-only tables that
*** contains plenty information about SAS data sets.
*************************************************************/
select nlobs into :total
from dictionary.tables
where libname = upcase("&lib.") and memname = upcase("&dsn.");

/*************************************************************

*** Add a "total" variable and store the computed total in it.
*** Since the Excel macro will be reading the third column

*** (column C) to retrieve the total row count, it is

*** important to make sure that the "total" variable is stored
**% at the right location.

* k%

*** The reason we choose the data set name to be "sheetl" is
*** because when we do a PROC EXPORT, the Excel spreadsheet
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**% i35 automatically named after the SAS data set name.
*** To simplify the process, we choose "sheetl", which is the

**% default name for the first Excel spreadsheet.
*************************************************************/

create table sheetl as
select date, air, &total. as total
from &lib.. &dsn.;

quit;

/*****************************************************************

**% Export the data set to excel file.
*****************************************************************/

proc export data=sheetl outfile="&outputPath." dbms=excel replace;
run;

options noxsync noxwait;

/*****************************************************************

*** Open Excel application.
*****************************************************************/

x "'&xlsCmdPath.'";

/*****************************************************************

*** Suspend SAS for 5 seconds to allow Excel to be fully started.

*****************************************************************/
data _null_;
rc = sleep(5);
run;

/*****************************************************************

**%* Create a file reference to the excel sheet.
*****************************************************************/

filename sas2xl dde 'excel|system';

/*****************************************************************

**% Use X4ML commands to communicate with Excel.

*** Although you can use X4ML commands to format the Excel

**% gspreadsheet's look and feel (colors, borders etc...), it is

*** preferable to keep it to minimum use, and have the Excel

*** macro to do those formatting. This makes your SAS code look

*** clean and readable.

* k% %

*** So, in the below steps, we will open the Excel template file

*** and execute "Macrol" Excel macro.

*****************************************************************/
data _null_;

file sas2xl;

/*************************************************************

**% Open Excel template file in read-only mode. This file

*** should have the Excel macro that you have created.
*************************************************************/

put "[open(""&xlsTemplatePath."", 0 , true)l";

/*************************************************************

*** Execute the Excel macro. By default, the macro name is

*** called "Macrol".
*************************************************************/

put "[run(""Macrol"")] ",

/*************************************************************

*** Close the Excel template file.
*************************************************************/

put '[file.close(false)]';




SUGI 31 Posters

/*************************************************************

*%% Close Excel application.
*************************************************************/
put '[quit()]';
run;

/*****************************************************************

*** Suspend SAS for 5 seconds to allow Excel to be fully closed.
*****************************************************************/
data _null_;
rc = sleep(5);
run;

/*****************************************************************

*** Delete sheetl data set.
*****************************************************************/
proc datasets library=work nodetails nolist;
delete sheetl;
quit;
%rend createExcelGraph;

screat eExcel Graph;

CREATING SAMPLE DATA IN EXCEL (SAMPLE.XLS)

Before we start recording an Excel macro to create an Excel graph, we need a sample data that reflects the

actual data.
A | B | ¢ | D |

1 |DATE AlR TOTAL

2 | 1/1/1949 112 4

3 | 2111949 118 4

4 | 311949 132 4

5 | 4111949 129 4

G

When we run a PROC EXPORT to export SASHELP.AIR data set to AIR.XLS, we will get the similar
spreadsheet layout as shown above. Columns A and B are part of SASHELP.AIR data set and we added
Column C to keep track of the total row count. We will call this Excel spreadsheet (with 4 data rows)
SAMPLE.XLS.

Once we have successfully recorded an Excel macro, we can safely delete SAMPLE.XLS and use the
actual Excel file, which is AIR.XLS.
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RECORDING EXCEL MACRO (TEMPLATE.XLS)
In this step, we will record an Excel macro that creates a simple Excel graph based on the data in
SAMPLE.XLS. This Excel macro will be called “Macro1” and it will be saved in TEMPLATE.XLS.

1. Open Excel application.

2. Click “Tools” > “Macro” = “Security”. Set Security Level from Medium (by default) to Low. This
suppresses the Excel macro warning prompt when SAS opens the Excel file that contains a macro.

H “* ”
Then, click “OK”.
2| %
—wT— Security 2|
% speling... 7|42 @@ -@f) Trusted Publishers |
ﬁi Research... Alt+Click  po | 2= sz e .y A !
% crror Checking PE=T==== - " Wery High, Only macros installed in trusted locations will be allowed
= ‘ta run, All ather signed and unsigried macras are disabled.
Speech »
N —re— £ High, Only signed macros fram brusted sources will be allavwed ta
= [F=T%bo0 [ H ] I [ J [ K ruri, Unsigned macros are automatizally disabled,
Share Workbook. .. -~
Track Changes N Mediurn, You can choose whether or not to run pakentially unsafe.
R R & Lo (rot recommended), You are not protected from potentially
- unsafe macros, Use this setting only if you have wirus scanning
Cnline Callaboration 4 saftware installed, or you have checked the safety of all documents
Goal Seek... YOG pEG
Scenarios. ..
Formula Auditing »
Macro L3 | b Macros... Ale+F8
Add-Ins... @  Record New Macra,,.
¥ AutoCorrect Options. .. | Securty, .
Custamize. . ] visual Basic Edior Alt+F11
Qptions. . @ Microsoft Script Edieer Alt+Shift+F11 = I Cancel |

3. Click “Tools” > “Macro” > “Record New Macro”. By default, the macro name is “Macro1”. We will use
this macro name for this example. Click “OK”. It will start recording all the actions you do for creating the
Excel graph and convert these actions into Visual Basic code.

Taols ‘ Data ‘window Help Adobe PDF
I @mn% - .:@l!

% speling... F7 .
G Research... Alt+Click bo - A v!

‘ﬁ) Error Checking. ..

L

Speech 3

o el oo oo

Share Workbook. ..
Track Changes s Macro name:

IMacru:ul

Protection 3

Online Collahoration v ShDrtEUt BE':-": Skare macro Ll'i:
(ol Seck... Ctrl+r IThis ‘Warkboak, j

Scenarios...

Description:
Macro recorded 121712005 by LIMC

Farmula Auditing >

Macro Ml b Macros... Alt+F8

add-Ins... | @ Record Mew Macra...

e

AutoCorrect Options, . SEeCurity...

‘Wisual Basic Editar Al+F11 :
o4 I Cancel
Microsoft Script Editor  Al+Shift+F11

Customize. ..

8

Options...
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4. Click “File” = “Open”. Located your SAMPLE.XLS and open it.

‘3 pile | EdE Misw  Insert  Format  Teols  Data Window
1B 1 Hew... ChlM
; ||_j Open... Chl+o |-'I
P Close

: A 3 :
T = save Ctrl+s

S Save As

5. Highlight the saniple data.
A,

B c | D |
1 [DATE AR TOTAL
2 | 1/1/1948 112 4
3 | 2/1/1949 118 4
4 | 311949 132 4
5 | 4/1/1949 1291 4
B

6. Click “Insert” > “Chart...”. Select the chart you want to create. Here, you can step through the Chart
Wizard to modify the chart properties. To simplify the example, we will click “Finish”.

i = e ; 2
Irsert | Format  Tools  Dat Chart Wizard - Step 1 of 4 - Chark Type » _Iil
Cells... i Standard Types | Cuskom Types I
Rows = Chart tvpe: Chart sub-type:
Colunins =
Worksheet |t Line
|[ﬂ Chatt, .. |' 0 e
L | ®Y (Scatter)
Symbal. .. by Area
) Dioughnut
@ Radar
S« Function... @ surface
Hame » L5 Bubble
-] Comment Clustered Column, 'Compares values across
. cateqories,
Pickure 3
2:'3 Diagrarm...
Press and Hold ta Yiew Sample I
Chject...
% Hypetlink. ..  Ckrl+k Cancel I = Fark | Mext = Finish |
7. Highlight whole Column C by clicking the letter C once.
A | B O
1 |DATE AlR TOTAL
2| 111949 112 4
3 | 211949 118 4
4 | 3/111949 132 4
5 | 411949 129 4
]
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8.

10.

11.

12.

13.

Click “Delete” key to delete the whole column. Although we are deleting this column, we will need to

tweak the Visual Basic source code so that

&, B
_1 |[DATE AR
L2 ] 1111549 12
L3 | 2548 118
4| 3141948 132
_5 | 44171949 129
a]

Click “File” - “Save”.

it picks up the value first before deleting it.
]

EiT' Edit  Wiew Insert Format Tools Data  Window

1 Hew Ctrl+M )

5 Open ChrHo
Close

|H Save Chrl+5 |
Save s r

Click “File” > “Close”.

File | Edit  Wiew Insert  Format  Tools Data  Window

] Hew.. Chrl+M |

[ oOpen... Chrl+0

| Close |

&l save ChrH+5

Click Stop Recording button (blue square).

Delete SAMPLE.XLS since it is not needed anymore.

Click “Tools” > “Macro” > “Macros...”. All the recorded steps for creating the Excel graph are stored in
“Macro1”. Click “Edit” to view the Visual Basic source code.

Ioolslgata ‘Window  Help  Adobe PDF

T gpeling... 7oloal gl e - @ ! .
Gl Research.. Ale+Click B 5= 55 ci. o A~ ! [Macro name:
b Eror checng... %
Shared Warkspace. .. [ H [ [ J | K
Share Workbook...
Track Changes 3
Protection 3
Opline Collabaration 3
Goal Seek...
SCenarios. ..
Formula Auditing 3 ;I
Macro Hi[ o macros... aiFs | ¥
T - ET— Macros in; IAII Open \Wworkbooks ;I
Z AutoCorrect Cptions... Security., Drescripkion
Gl=tonicely P visual Basic Edior AlL4FLL Macro recorded 12/7{2005 by LIMC
E oo @O Microsoft Script Editor Ale+ShiF+F1 L

2

[x

Bun

:

Cancel

Step Inko

Edit

(ErEate

il

Delete

options...
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14. We have to make a little modification to the recorded source code so that it reads from AIR.XLS
instead of SAMPLE.XLS. We also want to make sure that the Excel graph is created based on N rows
of data instead of just 4 data rows.

Sub Macrol ()
Workbooks.Open Filename:="C:\sugilexcell\xls\sample.xls"
Range ("A1:B5") .Select
Charts.Add
ActiveChart.ChartType = xlColumnClustered
ActiveChart.SetSourceData Source:=Sheets ("SHEET1") .Range ("A1:B5")
ActiveChart.Location Where:=xlLocationAsObject, Name:="SHEETL"
ActiveWindow.Visible = False
Windows ("sample.x1ls") .Activate
Columns ("C:C") .Select
Selection.ClearContents
ActiveWorkbook. Save
ActiveWorkbook.Close
End Sub

15. Make the highlighted changes to the source code.

Sub Macrol ()
'Initialize variables
Dim lastRow As Integer
Dim xlsPath As String
Dim x1sFile As String

'Excel file path and file name
x1sPath = "C:\sugilexcellxls\"
x1sFile = "air.xls"

'Replace "C:\sugilexcell\xls\sample.x1ls" with xlsPath & xlsFile
Workbooks.Open Filename:=xlsPath & xlsFile

'"Column C contains the total data count, so we need to

'store the value first before this column is deleted.

'We need to add 1 to the total count to include the title row
lastRow = Sheets (1) .Range ("C2") + 1

'Replace ("Al:B5") with ("Al:B" & lastRow)
Range ("A1:B" & lastRow) .Select

Charts.Add

ActiveChart.ChartType = xlColumnClustered

'Replace ("Al:B5") with ("Al:B" & lastRow)
ActiveChart.SetSourceData Source:=Sheets ("Sheetl") .Range ("A1l:B" & lastRow)

ActiveChart.Location Where:=xlLocationAsObject, Name:="Sheetl"
ActiveWindow.Visible = False

'Replace sample.xls with xlsFile
Windows (x1sFile) .Activate

Columns ("C:C") .Select

Selection.ClearContents

ActiveWorkbook.Save

ActiveWorkbook.Close
End Sub

16. Finally, save this Excel file to be TEMPLATE.XLS.

17. Close Visual Basic and Excel applications.
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TESTS AND RESULTS

When the SAS code is executed, AIR.XLS is created and will look similar to the screenshot below.

A B T EE e E e E e s e e e

71 [DATE AR

T2 adsaE 12 -

T3 2afsa i

4| a4 1w

TE | 4/1/1949 129] | T

TB | A/ 121

7 eafea 13

T8 | A 148

To | gnfeds 149

90 9948 136

1 10A/1948 118

Tz 11AA848 104

30120948 118

940 a0 115

5| enfmE0 126

6| atnmsn 41

7| 4nfms0 135

98| 5A7980 125

93| 6950 149

20| 7afss0 170

21| eafmE0 170

22| oipesn 158
HELPFUL TIPS

1. Practice and take note of the Excel graph settings before recording the actual Excel macro. This will
prevent you from recording redundant steps in the Excel macro.

2. If you plan to create a complex Excel graph that requires many steps, it is highly recommended to
record these steps in multiple small Excel macros. These small Excel macros can then be combined

into one big Excel macro. They also act as “checkpoints” so that you can easily recognize the
functionalities of the recorded Visual Basic source code.

CONCLUSION

This paper provides a detailed step-by-step approach and helpful tips for creating an Excel graph based on
N observations from a SAS data set. Although there are many ways to create an Excel graph from SAS, this
paper presents one proven technique that has been working well in the production environment.
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