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General Notes

SIMCom offers this information as a service to its customers, to support application and engineering
efforts that use the products designed by SIMCom. The information provided is based upon
requirements specifically provided to SIMCom by the customers. SIMCom has not undertaken any
independent search for additional relevant information, including any information that may be in the
customer’s possession. Furthermore, system validation of this product designed by SIMCom within
a larger electronic system remains the responsibility of the customer or the customer’s system

integrator. All specifications supplied herein are subject to change.

Copyright

This document contains proprietary technical information which is the property of Shanghai
SIMCom Wireless Solutions Ltd, copying of this document and giving it to others and the using or
communication of the contents thereof, are forbidden without express authority. Offenders are liable
to the payment of damages. All rights reserved in the event of grant of a patent or the registration of
a utility model or design. All specification supplied herein are subject to change without notice at

any time.

Copyright © Shanghai SIMCom Wireless Solutions Ltd. 2013
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Revision history

Revision | Date Description of change Author

1.00 2013-01-11 | Initial MXN

SCOPE

This document describes how to use the IDE tool to develop user’s own application.

Examples are also given for reference. This document can be used for SIM900 serial modules, like
SIM900, SIM900D, SIM900B and SIM900A.

This document is subject to change without notice at any time.
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1 Introduction

SIMDevIDE is an IDE tool developed by SIMCom to integrate its core Embedded AT environment
with customer’s application development process. SIMDevIDE allows customers to edit, compile,
link core libraries and download MOT file effortlessly. SIMDevIDE works with all versions of

Windows. This document describes how to develop your project in Eclipse IDE.

2 Getting Started
Before installing SIMDevIDE tool, user should install arm complier tool first.

2.1 Install SimDevlde

Uncompress the rar file (e.g.“1137B02V01SIM900A64 ST EAT.rar”). Execute installation file
(e.g. “SIM900ADevIDE V1.01 (1137B02V01SIM900A64 ST EAT).exe”) and follow the install

instructions.

2.2 Install Java SE Development Kit

Go to the website
http://www.oracle.com/technetwork/java/javase/downloads/jdk7-downloads-1880260.html to
download the latest JDK.

2.3 Install Gee compiler

Go to the website http://www.yagarto.de/ to download YAGARTO Tools and YAGARTO GNU
ARM toolchain. When the user has downloaded these two tools, please install them and note that

these two tools must be only installed in the no-space and only English path.

2.4 Download Eclipse and its plug-in

Go to the website http://www.eclipse.org/downloads/ to download Eclipse IDE for C/C++

Developers and go to the website http://sourceforge.net/projects/gnuarmeclipse/ to download
org.eclipse.cdt.cross.arm.gnu_0.5.4.201202210114.

SIM900 Eclipse environment install Application 4 1/11/2013
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2.5 Install Eclipse environment.

1. Uncompress the zip file (Eclipse IDE for C/C++ Developers) and click “eclipse.exe”.
2. Then select your workspace as following, and then click OK and wait for eclipse initialization.

& Yorkzpace Launcher

Select a workspace

Eclipse =stores wour projects in a folder called a workspace.
Choose a workspace folder to use for this session.

DEmbeddedAT V| [ Browse. ..

Workspace:

Duse thiz as the default and do neot ask again

[ 0K | [ canca

3. The eclipse IDE will show as following:

& C/CH — Eclipse

File Edit Souwrce Refactor Havigate ZSearch Run Project Hindew Help

@ Yelaome 32

% ”
- Welcome to the Eclipse IDE for C/C++ Developers

)

r
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4. Install org.eclipse.cdt.cross.arm.gnu_0.5.4.201202210114. Please click “help->install new

software”, and it will show a dialog as following:

& Install

Available Software |

Selact a =ite or enter the location of a =ite. - caly

v aaa.. |

Work with: |

Find more software by working with the “hvailsble Software Sites” preferences.

Hame Version

D@ There is no site selected.

[ Select A11 ] [Eeselect A1

Details
Show only the latest werszions of awvailable software Dﬂide items that are already installed
Qroup items by category fhat 1= already installed?

DShow only software appliecable to target enviromment

Eontact all update =sites during install to find required software

o

5. Click “Add” and then it will show a dialog as following and click “OK”:

Type gnu here.

& idd Repository

Hame: [lg:nu |][ Loeal. ..

Location: |_13r file:/TI:/GCCf org. eclipse. cdt. cross. arm. gnu_ 0. 5|

@ 0K || Ccancel

4
Click  “Archive...” to  select
org.eclipse.cdt.cross.arm.gnu_0.5.4.2
01202210114 location where you
download in Char. 2.4.

SIM900 Eclipse environment install Application 6 1/11/2013
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6. Unselect “Group items by category” and select “GNU ARM C/C++ Development Support”,
and then click “Next”.

& Install

Awvailable Software
Checle the item= that you wiszh to install.

Weork with: !g;nu = jar: file /T f/GCC orz eclipse. edt. eross. arm. zou 0. 5.4 201202210114 zip! S vi [ hdd. .. ]

Find more software by working with the “hvailsble Software Sites” preferences.

Version

0.5, 4. 201202210114

Hame
['-E“i GHI ARM C/C++ Dewelopment Support]

» Select this option.
[ Select A11 ] [Eeselect A1 1 item zelected
Details
Unselect this option.
Show only the latest werszions of awvailable software Dﬂide items that are already installed
e e S ] Whiah = balvaniy dnatal Lads

DShow only software appliecable to target enviromment

Eontact all update =sites during install to find required software

=

)
.|
=
)
L
-
I
I
1
[l
g
o
n
=

SIM900 Eclipse environment install Application 7 1/11/2013

Note _V1.00



=1l Com
A company of S Tech

Smart Machine Smart Decision

7. Select “I accept the terms of the license agreement” and click “Finish”.

& Install

Review Licenses

Licenszes must be reviewed and accepted before the =oftware can be inztalled

License text (for GHU ARM C/C+t Dewelopment Support 0.5.4. 201202210114):

The “GHU AEM Eclipse Flugz—in" iz free software. |
{Permission is hereby granted, free of charge, to any person obtaining a 1
lcopy of this software and as=zoriated documentation files: (the

!"Software"), to deal in the Software withoeut restrictioen, including

!without limitation the rights to usze, copy, modify, mergs, publish,
idistribute, sublicensze, andfer sell copies of the Toftware, and to
\permit persons to whom the Software is furnished to do so, subject to
Ithe following conditions:

!The abowe copyright notice and this permizsion notice shall be includad
lin &l11 copies or substantial portions of the Software.
|

ITHE SOFTYARE IS FROVIDED “AS IS, WITHOUT WARRAWTY OF AWY EIND, EXPRESS
|OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
\MERCHANTABTLITY, FITHESS FOR A PARTICULAR PURPOSE AND

HONIFFEINGEMENT. TN RO EVENT SHALL THE AUTHORS OF COPYRIGHT HOLDERS BE
LIAELE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
OF CONTEACT, TORT OF OTHERXTSE, ARTSTHG FROM, OUT OF OR IN CONWECTION
WITH THE SOFTWARE OR THE USE OR OTHER DEALTIHGS IN THE SOFTHWARE.

@I accept the termz of the licensze agreement

OI do mot accept the terms of the licensze agreement

-

&) Hoxt Finish | [ Caneal |

8. Click “OK” when the following dialog is shown.

& Security Warning

anthenticity or walidity of this software canmot be established. Do xou

"'_., Warning: You are installing software that contains unsigned content. The
want to continue with the installation?

| 0K ||  Cancel || Details 2>

9. Wait for install finished. And click “Yes” when the following dialog is shown and wait the
eclipse restarts.

& Software UOpdates r5_<|

You will need to restart Eclipse for the changesz to tale effect. Would you
\'"«IJ/ like to restart now?

10. Now we finish the eclipse gun arm plug-in installation.

SIM900 Eclipse environment install Application 8 1/11/2013
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2.6 Import a project

1. Copy “EmbatSIM” folder (which is in the SIMDevIDE tool root path) into eclipse workspace
path. (In this document, the eclipse workspace path is “I:\Embedded AT”)

2. Click “File->Import” and select “General-> Existing Projects into Workspace”. And then
click “Next”.

B(=1/3

Select

Create naw projects from an archiwe file or directory. |_E Jg

Select an import source:

[=-[= General
[E, Archive File
'@ Existing Projects into Workspace
|:L File Swstem
EL Freferences

[== CFCH

= C¥3

[~ Git

[~ In=tall

[= Remote Systems

[-=- EFM

[~ Bun/Debug

[ Tasks

[~ Team

[~ Tracing

©

SIM900 Eclipse environment install Application 9 1/11/2013
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3. Click “Browse” to select the project location. The project is located in “SIMDevIDE tool root
path\ eclipse_example”. And there are two projects in this folder. One is using SIMCom libraries
(SampleUseSIMComLibs) instead of using GCC C standard running libraries. This project is that
when the core firmware is changed, you must compile your app again. The other one is using
GCC C standard running libraries (SampleWithGecLibs). This project is that when the core
firmware is changed, you don’t need to compile your app again.

Click “Finish”.

- B

Import Projects -
Zelect a directory to search for existing Eclipse projects. i .-"

-

G}Select root directory: ;.]-:I'LSIMQDDDEVIDE_DWF_M‘JltiT&Ek_GCEI".EEli]; I Browse. ..

OSelect archiwve file: | |

Frojects:;

| [ SanplelizeSINConLibs (T: \SIMIO00DewIDE_DTME MiltiTask GCChecli [ Select ALL
Dezelect All

Refrezh

[# | >

[i:-:up}' projects into workspace ]—> Sellast (s eraie.

Yorking =ets

Dﬁldd project to working sets

@ [ Finish | [ Canesl

4. If you import “SampleWithGccLibs™ project, you don’t need to modify anything, just to
compile it. Note that if you use this project and when the core is changed, you don’t want to

compile your app again, you must call the function point API instead of function API such as
“eat_GetEvent”. Please don’t call “eat]l 02GetEvent” function.
If you import “SampleUseSIMComLibs”, you must modify the .x file path. The steps are as

following:

SIM900 Eclipse environment install Application 10 1/11/2013
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a)Click the project which you want to modify. Here we select the project
“SampleUseSIMComLibs”.

X

E C/Ci+t — SampleWithGeelibs/code/syscalls. ¢ — Eclipse

File Edit Sowce Refactor HNavigate Search Project Bun Window Help

e B LY o -l G- Bs-0- Q- &E &7~ 2 S = {gu ‘E‘f‘@:/:u‘
R el sysealls.e B2 =8 o0 x @8 Er =8
Hif defined USE C_STANDARD LIBS £¢ defined CONP_GCC A EERY o % o 7
T2 SamplefdihGoclibs #include <stdio.h> TR
#include <stdlib.h> 55 —edlibh
#include <string.h> W stringh
#include <sys/stat.h> U sysfstath
- ++ Debughriteleconst vaidr, int
extern int DebugWrite (const void *huffer, int len); # STDIN FILEWD
# STDOUT_FILENO
fdefjne STDIN FILENC O /7 standard input file descriptor %/ = # STDERR_FILEWO
#deflne STDOUT FILENO 1 /7 standard output file descriptor =/ — B _exitlnt) - veid
S 1 t “S 1 SIMC L'b softdefine STDERR FILENO 2 /7 standard error file deseriptor 7/ @ _stat (chark, struet stat¥)
clec ampleUse OmL1bs @ _fstatlint, struct state)
@ ctackoptr  chard
“void _exit (int n) ® _sbrkr(veidk, sizet) co
® isattyGat) @ int
while (1) ~ @ _lsesk(int, int, int) . ant
§ “ ® _open(oonst chark, int) ¢ i
% nsaw @ _close(int) . int
¥ ©® _write(int, const veid#, un
¥ © _resdfind, woidk, unsigned
P Debughrite(const veids, int
~int _stat(char "file, struct stat 7st) {
return (0):
H
~int _fstat (int fd, struct stat * st)
{
if (£d == STDOUT_FILENOQ)
{
memset (st, 0, sizeof (* s5t)):
#  st-»st_mode = 5 _IFCHR:
& st->st _blksize = 1024:
return 0;
¥ v
] D | @ ‘ >
Problems = Tasks [l Comsole 32 Properties o ==

Ho consoles to display st this tine

125 SamplelizeSINConLibs 20131 11H

SIM900 Eclipse environment install Application 11 1/11/2013
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b)Click “Project->Properties” and it will show a new dialog as following. Select “C/C++
build->Settings->ARM Targets Windows GCC C Linker”. And modify the “.x” file

3

name. The “.x” file is located in “EmbatSIM\gsmos\coreSW\rvctcore” of the Eclipse

workspace. Please find .x file and replace the file name.

& Properties for SaspleUseSINCoaLibs @
type filter ' | Settings oms -
[ Resource

Builders ( \
= C/oH Build Configwation: | [ ALL eonfigurations ] | [Mamege Conti gurations
Build ¥arisbles \¥ J
Discovery Optiens
Envirorment ————— > —
Loceine ) Tool Settines | 5 Build Steps | 4 drtifact | [ Binary Parsers | @ Frror Parsers
Settings
Tool Chein Bditer ‘ (2 Target Frocessor / | Comnand; [armnone-aabi-ld
2} 5 Nebuzzin T
B gmf* GT‘;Q Lk 1 [-nostartfiles —M1, Map, SanpleVseSINConLibs, map ~mepu=arn@e —mtkumb-interwork
voject References
Run/Debug Settings
o 13 1 2
sracwnty [ Select “All configuration
HikiTent
(% Warnings
(% Miscellaneous Expert se
(= 55 ABM Tagarto Windows GCC C Compiler 5;’:’2“2[““ W gsmos/ cor et rveteore/113T _ST_EAT_FOR_HOM_2012_1203_1006. %" “${build project}. f /Emhat]]
(% Preprovessor 2 &

(2 Directories

(3 Libraries v
(3 Miseellaneous

=53 ABM Yagarto Windows G Create Flash Tnage . . . .
B o Find the .x file in this line.
(2 Section
(2 Miscellaneons

(=53 ARM Tagarto Windows GHI Create Listing
(% General

(=55 ARM Yagarto Windows GHU Print Size
(% Gemeral
Modify this file name according
to your EmbeddedAT firmware
+
@

Expert settings:

Command

line pattern: | “$i{build project}.. . .fEmbatSIMfrgsmosj'coreS'l\'frvctcore;{lISTBUI‘.I'CIISIMQUUM128_INTEL_DTHF_J'D_EAT. x" ]'$ {build_|

Note: Please don’t delete fl main, fl ctrQ.s, syscalls.c files. These files are the gcc
environment boot files.

2.7 Compile your project

Click and select the project which you want to compile as following. Click Hammer icon to
compile the project.

If the compilation is completed with no problem, the binary file, with a name of xxx.hex,

will be generated under the Release or Debug directory of the project directory,depending on

which configuration mode you are currently working on.

SIM900 Eclipse environment install Application 12 1/11/2013
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i i v % —m—5»  Click here to compile the project.
i.-|“_‘-| Froject Explorer 2 [—| f{, o S | EE
= Select the project
I+ fz= camplenithircclibs
The following is the compiler result:
|._|>_‘|Prl:-ject Explorer &2 [—] % & ¥ = 8

=== Samplelz=SIMConLibs
#:;P Binaries
[}l Includes
[= aine
[= code
[=][= Debug
[=)[= code
fl_ertl. o — [armfle]
fl_customer. o — [armfle]

fl main o - [arm/le]
=l f1_crtl. 4
=| f1_ertd. o. 1=t

fl_customer. d

i) i

fl customer. o. 1lst
fl main. d
fl main. o. 1lst
| @ =ubdir. mk
i} SamplelUzeSIMComLibs. e1f - [armile]
| makefile
| g ohjects. mk This is the binary file which
[ 5] SampleliseSIMComLibs. hex |
=| SamplellzeSIMComLibs. 1=t
g SamplellseSIMComLibs. map

| @ sources. mk

i) i

is used to downloaded into

the module

2.8 Add a new file

Click “File->New->Source File” or “File->New->Header File”. It will show the dialog as
following. Click “Browse” to select the path where you want to store the file. In “Source file”

line, please input the file name which you want to add.

SIM900 Eclipse environment install Application 13 1/11/2013
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& NHew Source File

Source File
Create a new source file. C
Source folder: |Smple'|'|'itthcLib5,'rcnde | [ Browse. .. ]

Source file: [|5m5.c | |

J

enplate- \Defiault C source template v || Confifgure. .. |
v
v Click “Browse” to
Input the file name select the path where
which you want to add. you want to store the
file.

@ Finish ||  Cancel

2.9 Add an existing file

1. Click “File->Import” and select “General->File System”, then click “Next”.

SIM900 Eclipse environment install Application 14 1/11/2013
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&= Import |:I El E'

Select
Import resources from the local file =ystem into an existing project. |_E Jg

,

Select an import source:

[=)[= General
[E, Archive File
@ Existing Frojects into Workspace
|:L File Swstem
EL Preferences

[=- CfC++

[=- C¥5

= Git

[~ Imstall

[= Remote Systems

[-=- EFM

[~ Bun/Debug

[ Tasks

[= Team

[~ Tracing

@

2. Click “From Directory->Browse” to select the file location and select the file which you want
to import. And Click “Into folder” to select the folder which you want to put files into. At last,

SIM900 Eclipse environment install Application 15 1/11/2013
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click “Finish”.

File system o
Impert resources from the local file swstem. IfJ_IT
-

From directory: E,_]:;G:;i_ilgiﬁa{presso_g._El_._lé-__i-lfl.é_S.\workspace\T_e;_-‘fagarto_lZEH_E:cc_l“i-'B\_-;il[BLDWT]l
_é/ CO&-E _D E callTask - |

"l E} Context. o -
[ lcl distdiSdispley. e | Click here to select

1 c fl_atc. o
Select the files which \ l E ﬂ:a:CProcess. ) ] the file location.

you want to import. T T 1 £l 2t ctuene, ¢
][5 flertn s

7] EI fl_customer. o
] _|£, fl main. ¢

1 el f1_mse e

£

Filter Types... ] [ Select A1l J [ Deselect All l

Into folder: ESample'UseSIMComLibs,"code

Options

ngerwrite existing resources without warning

[Create top-lewel folder Click here to select

the folder which you

want to put the files

in.

®

Finish | [ Canmcel

2.10 Download to SIMCom Module

1. Select “Build->Download” menu.
2. Configure the options as below. It is recommended to use the default value for the options

SIM900 Eclipse environment install Application 16 1/11/2013
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Select module type

SERTAL Dowrload ] Confirm the serial

number in
Tarzet Fort Baud Bate DownloadOption ReadBufferZi port nu be

SIMG00 v | |[COM3 | 460800 v | |Embeddedt v | |2048

Download File
Core File |I:\Embedded.hT"xEmbatSIH'igsmns"ucnreS'ﬁ"‘xrvctc-:-re"xllﬂ =

user’s PC’s Device

Manager.

Select the core file

: Time 2013-01-07, 16:45:25 00000000 Size Ox3FECOS in the path ..
Note: This
address \EmbatSIM\gsmos\
should be Time—POL3~Gimt 04700 00400000 Size [DxAd coreSW\rvctcore\”.
00400000. Erase Type: |Erase User Data and Code | 0
Select the
application file
Flash Type created in the path.
Note that it is .hex
Start Dowrdoad file.
025 Fxit
Refresh COM port
Status:

Figure 11
3. Download user’s application to the module by pressing “Start Download” button.

Note: If user only needs to download the application file, set the “DownloadOption” option to
“NORMAL” and “Erase Type” to “Erase User Data and Code”’.
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Contact us:

Shanghai SIMCom wireless solutions Ltd.

Address: Building A, SIM Technology Building, No. 633 Jinzhong Road, Shanghai,
P. R. China 200335

Tel: +86 21 3252 3300

Fax: +86 21 3252 2030

URL: www.sim.com/wm
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