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Summary 

Geographic Information Systems (GIS) have been used in various fields and disciplines to summarize and analyse spatial patterns and 

distributions, for the purpose of understanding how geographic and non-geographic entities interact with each other over space and time. 

Although honey bees are directly related to and influenced by their local environment, few studies have incorporated honey bee data into GIS 

for the purposes of gauging these spatial relationships. This paper will briefly discuss some of the types of spatial analyses and GIS methods 

that have been used for bees, and also, how some methodologies developed in the non-Apis bee domain could be applied to honey bee 

research. With this paper, we aim to stimulate spatial thinking processes and thus the future use of GIS analyses to better understand the 

relationships between environmental characteristics and honey bee health and abundance. We will introduce the framework and some 

important basic concepts of GIS, as well as provide detailed instructions for becoming familiar and comfortable in using the GIS softwares 

ArcGIS and Quantum GIS (QGIS) (a commercial and free GIS package) for the basics of geospatial research. 

   

Uso estándar de las técnicas de Sistemas de Información 

Geográfica (SIG) en la investigación de la abeja de la miel 

Resumen  

Los Sistemas de Información Geográfica (SIG) se han utilizado en diversos campos y disciplinas para resumir y analizar los patrones y 

distribuciones espaciales, con el fin de entender cómo las entidades geográficas y no geográficas interactúan entre sí en el espacio y en el 

tiempo. Aunque las abejas melíferas están directamente relacionadas e influidas por su ambiente local, pocos estudios han incluido estos 

datos en los SIG para analizar estas relaciones espaciales. Este artículo discutirá brevemente algunos de los tipos de análisis espaciales y 

métodos de SIG que se han utilizado para las abejas, así como también, algunas metodologías desarrolladas en dominios no-Apis que podrían 

ser aplicadas a la investigación de la abeja de la miel. El objetivo de este trabajo es fomentar los procesos de pensamiento espacial y por lo 

tanto el futuro uso de los análisis SIG para entender mejor las relaciones entre las características ambientales con la salud de las abejas 

melíferas y con la abundancia de estas. Vamos a introducir el marco y algunos conceptos básicos importantes de los SIG, así como 

proporcionar instrucciones detalladas para familiarizar y facilitar el uso de los programas SIG, ArcGIS y Quantum GIS (QGIS) (un paquete SIG 

comercial y libre) para los fundamentos de la investigación geoespacial.  
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2 Rogers, Staub 

地理信息系统技术在蜜蜂研究中的标准应用 

摘要 

为了理解地理和非地理的实体之间如何在空间和时间上互作，地理信息系统（GIS）已被用于多种领域和学科以概括和分析空间模式和分布。尽

管蜜蜂与它们的生活区域环境直接相关并受其影响，但很少有研究将蜜蜂的数据与GIS结合起来测定这些空间关系。本文将简要讨论已用于蜜蜂

的一些类型的空间分析和GIS方法，以及如何将一些在非蜜蜂领域发展起来的方法应用于蜜蜂研究。通过本文，我们意图刺激空间思考的进程，

从而实现未来通过GIS分析来更好的理解环境特征与蜜蜂健康和丰富度的关系。我们将介绍GIS的框架和一些重要的基本概念，同时提供GIS软件

ArcGIS和Quantum GIS（两者分别是商业化和免费的GIS包）详细的使用说明，使人们熟悉并轻松地使用以作为地理空间研究的基础。 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Keywords: COLOSS BEEBOOK, GIS, spatial analysis, honey bee, ArcGIS, Quantum GIS  
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al., 2010), there is an urgent need to better understand how 

environmental changes affect habitat, life patterns, and the overall 

health of honey bees. This type of research can be facilitated through 

the use of Geographic Information Systems (GIS), which can briefly 

be described as a software system for handling and analysing map  

 

1. Introduction 

Due to the close relationship between honey bees and their 

surroundings, and because of recent increases in colony mortality in 

many regions of the world (Carreck and Neumann, 2010; Williams et  
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data through the use of coordinate systems and georeferenced 

information to aid in the analysis of spatial patterns that may exist 

between entities on the Earth’s surface (Burrough and McDonnell, 1998). 

Because of its broad application, GIS methods are used in a diverse 

array of disciplines, including geoscience (Bonham-Carter, 1994), 

economics (Pogodzinski and Kos, 2012), and biology (Kozak et al., 2008). 

For example, GIS has been used extensively to undertake spatial 

analyses of the effects of land-use and climate change on declines of 

native bee abundance and health (Arthur et al., 2010; Biesmeijer et al., 

2006; Chifflet et al., 2011; Choi et al., 2012; Fitzpatrick et al., 2007; 

Giannini et al., 2012; Kremen, 2002; Kremen et al., 2004; Watson et al., 

2011; Williams et al., 2012).  

Through the use of spatial analyses, researchers using GIS were 

able to determine that native bees were more efficient crop pollinators 

when access to nearby forests was provided (Arthur et al., 2010; 

Kremen et al., 2004; Watson et al., 2011). Additionally, relationships 

between climate and native bee species richness and abundance have 

been identified using GIS modelling procedures (Giannini et al., 2012). 

For honey bees, GIS analyses have been incorporated into relatively 

few research initiatives (Berardinelli and Vedova, 2004; Naug, 2009; 

Henry et al., 2012). With this paper, we aim to stimulate spatial 

thinking processes and thus the future use of GIS analyses to better 

understand the relationships between environmental characteristics 

and honey bee health and abundance for a broader geographic 

overview of the mechanisms affecting their plight (Naug, 2009). In 

this paper, we introduce the framework and some important basic 

concepts of GIS, and provide detailed instructions about using the GIS 

softwares ArcGIS and Quantum GIS (QGIS) for the geospatial study of 

honey bees. We hope that the knowledge gained from this paper will 

further the field of honey bee science, but also promote the use of 

GIS in other fields of study. 

 

  

2. What is GIS?  

2.1. Definition  
Geographical Information Systems (GIS) are computer systems based 

on hardware, software, and georeferenced data that can be used to 

collect, store, manage, process, analyse, and visualize both spatial 

and non-spatial information representing real-world geographic  

 

phenomena (Burrough and McDonnell, 1998; Neteler and Mitasova, 

2008). Georeferenced data refers to any data that are linked to a 

location on the Earth’s surface through the use of a geographic or 

projected coordinate system. GIS data are digital objects which 

represent real-world entities (Longley et al., 1999) and are defined 

by: their geometric properties (spatial location), their attributes 

(characteristics associated with each object), and their topology 

(definition of how entities are related to others in space) (Burrough 

and McDonnell, 1998). In other words, data provide means to locate 

them in space and can be overlaid, calculated, manipulated, visualised 

and analysed along with other data layers that use the same coordinate 

system. Each entity in the real world is represented by a data layer 

with geometric and topologic properties and an associated set of 

attributes, in the form of a table, which define the characteristics of 

that entity. GIS facilitates the analysis of spatial relationships within 

datasets based on the topological properties within the data. Topology 

refers to the interconnectivity and interrelated properties between 

data and defines and describes how spatial objects relate to their 

neighbours in space. This geographic descriptor is what sets GIS data 

apart from other data types (Burrough and McDonnell, 1998) (for a 

list of free GIS books and other information sources see Table 1). 

 

2.2. GIS framework  

The main principles of GIS (geometric properties, attributes, and 

topology) are built into two data structures: vector (e.g. points, lines, 

and polygons) and raster (e.g. climatic, altitude, or satellite imagery). 

The terms “layer” or “dataset” are used to denote a raster or a vector 

file type that contains a similar theme, for example, varying elevations 

across a terrain or locations of honey bee colonies, respectively. It is 

possible to convert a raster layer to a vector layer and vice versa, 

depending on what type of analysis will be conducted with the data. 

Each layer contains information about its geometric properties and a 

table of attributes associated to and linked with, its respective 

geometric properties (Fig. 1). You can view each layer’s properties in 

GIS to see the resolution, file type, size of the file, and other information 

of importance. 

 

2.2.1. Vector data structure 

Vector layers represent discrete features in space in the forms of 

points, lines, and polygons. They represent unchanging static entities 

5 The COLOSS BEEBOOK: GIS  

Name of publication Author(s), year Website 
Map Projections: A Working Manual Snyder, 1987 http://pubs.er.usgs.gov/publication/pp1395 
Geospatial Analysis - A comprehensive 
guide 

De Smith, Goodchild, and Longley, 
2007 http://www.spatialanalysisonline.com 

A Practical Guide to Geostatistical Mapping Hengl, 2009 
http://www.lulu.com/shop/tomislav-hengl/a-practical-guide-to-
geostatistical-mapping/ebook/product-17389015.html 

GIS Commons: An Introductory Textbook 
on Geographic Information Systems Schmandt, 2009 http://giscommons.org/ 

Various ESRI E-books Many http://www.esri.com/industries/ebooks 

Table 1. Publication names, authors, and websites of free GIS Books and information sources. 

D
o
w

n
lo

ad
ed

 b
y
 [

5
4
.2

0
9
.1

4
0
.2

0
7
] 

at
 1

1
:1

6
 2

6
 A

p
ri

l 
2
0
1
6
 



and do not contain spatial or temporal information (Burrough and 

McDonnell, 1998). For example, a polygon layer could represent the 

extent of an apiary, and a point layer could represent a honey bee 

colony on a map. Line layers can represent rivers, roads, tracks, and 

any other linear features. In Fig. 2 a polygon, point, and line layer are 

shown as examples.  

 

2.2.2. Raster data structure 

Raster layers represent continuous features such as aerial and 

satellite imagery, as well as Digital Elevation Models (DEM), which 

store elevation data across a surface (see section 3.2.4. for more 

information). The value of each pixel of a thematic raster layer 

represents the attribute value. For satellite imagery, pixel values 

represent physical values of surface reflectances and for terrain-model  

6 Rogers, Staub 

data pixel values represent absolute topographic heights (Campbell,  

2002). For example, if the resolution of the image is 25 m, then each  

25 m pixel in the image will be representative of the average value of 

that 25 m on the ground. In Fig. 3, a land cover vector layer was 

transformed to a raster to visualize the pixel differences and value 

types. 

 

2.3. GIS functionalities  
The main functionalities of GIS include interfaces for database 

management, geoprocessing and spatial analysis, as well as 

visualisation and map creation. Here, these functionalities are 

introduced and the specific tools will be discussed more in-depth in 

further sections.  

Fig. 1. The GIS data framework is made up of both geometric properties and attributes associated with the geometry. A row in the attribute 

table exists for every polygon on the map. Some of the attributes for this Swiss layer include the names of cantons and their abbreviations, 

the country code, the country name and abbreviation, and the area. Reproduced with permission of Swisstopo (BA13016). 

Fig. 2. A map displaying a point, lines, and polygons. Reproduced 

with permission of Swisstopo (BA13016). 

Fig. 3. A map displaying the raster data structure of a landcover layer 

which was converted from vector format. The legend denotes the 

landcover properties which are displayed. Reproduced with permission 

of Swisstopo (BA13016). 
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2.3.1. Database management  
 

A GIS database is used to store, create, organize, manipulate, and 

query spatial and their linked non-spatial datasets (Burrough and 

McDonnell, 1998). GIS facilitates the link between geographic and non

-geographic data and enables the comparison and assessment of 

various data types (Rigaux et al., 2002). Compared to traditional (non

-spatial) databases (e.g. those without geographic coordinates), 

geographic databases make explicit locational distinctions for each 

dataset stored in the database, that is, all geographic information is 

linked to a location on the earth’s surface through coordinates (Arctur 

and Zeiler, 2004). 

 

2.3.2. Geoprocessing and spatial analysis  

GIS can be used to calculate, analyse, and manipulate spatial data to 

examine spatial relationships and to create new data (De Smith et al., 

2007). Basic manipulations of geographic datasets such as extracting 

new information from existing layers or clipping specific geographic 

extents can be referred to as geoprocessing. Geoprocessing refers to 

the process of creating a new geographic data layer after the 

calculation of an input layer(s) (Wade and Sommer, 2006). 

Spatial analysis is a central concept in GIS and refers to more 

complex calculations which have been developed from various 

quantitative methodologies outside of GIS and incorporated into GIS 

over time (Longley et al., 1999; Conolly and Lake, 2006; De Smith et 

al., 2007). Spatial analyses can be used to summarize and analyse the 

spatial properties of geographic distributions, to solve spatial problems 

through modelling, and finally, to aid in spatial decision making 

(Longley et al., 1999). Because this is a basic introduction to GIS, we 

will focus more on the geoprocessing aspects of GIS and touch briefly 

on more complex spatial analyses. 

 

2.3.3. Data visualisation and map creation 

One of the main benefits of GIS is that it gives researchers the ability 

to visualize their data in a variety of formats, which enables the 

creation of new links and relationships between spatial entities while 

discovering spatial interactions that were perhaps unknown before. 

GIS is also a common cartographic platform which facilitates the 

production of maps, either to present a geographic area or the results 

of data analysis using spatial data. The results of GIS analysis can be 

displayed as maps using a variety of symbolisations and annotation 

features as the final step in a GIS investigation.    
 
 

3. Geographic data  
GIS data represent real-world phenomena based on their geometric 

properties, attributes, and topology (Burrough and McDonnell, 1998). 
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3.1. File types and extensions  
Often, GIS software has its own file types for vector and raster data. 

For example, the Environmental Systems Research Institute’s (ESRI) 

commercial ArcGIS software most commonly uses shapefiles for 

vector data and grids for raster data. Shapefiles and grids have come 

to be some of the most commonly known GIS formats and can often 

be read by and incorporated into other GIS programs without the 

need for conversion, as is the case for Quantum GIS (QGIS). It is 

important to note that most layers are made up of multiple files with 

different file extensions. For example, a shapefile may look like a 

single file in the GIS, but actually, it is composed of multiple file 

extensions. It is detrimental to the data layer if one of these 

extensions gets lost or deleted. Some of the extensions often 

associated with shapefiles are: *.shp (required file that stores the 

feature geometry), *.shx (required file that stores the index of the 

feature geometry), *.dbf (database table that stores the attribute 

information) or *.prj (file that stores the coordinate system information). 

The entire list of extensions can be found by searching “shapefile file 

extensions” in the ArcGIS help menu (http://resources.arcgis.com/en/

help/main/10.1/). 

Multiple raster dataset file formats including ASCII (*.asc), GeoTiff 

(*.tif), JPEG (*.jpg), and GIFs (*.gif), to name only a few, can be 

supported in most GIS software. Again it is important to keep all files 

when copying and moving data. For example, a Geotiff file often comes 

with two files, *.tif and *.tfw. The *.tif holds the image, and the *.tfw 

holds the information about the georeference. 

 

3.2. Common GIS data types  
The geometric aspect associated with GIS data is what separates 

geographic databases from other databases (Burrough and 

McDonnell, 1998). Geographic databases are sometimes referred to as 

geodatabases, which refer to databases specific to geographic data. 

Until recently, most GIS data were generated and distributed by 

government or private industries and had to be purchased. Now, 

there are many sources for downloading free data (Table 2). The 

amount of available data largely depends on the area of interest, as 

urban areas tend to have more data available than rural or remote 

areas. Another important aspect of geographic data is the metadata. 

Metadata are the information provided about the data, thus, data 

about data (Burrough and McDonnell, 1998). When downloading data 

online or receiving data from an outside source, metadata are 

important for obtaining knowledge about when the data were created, 

for what purpose, by whom, and using which coordinate system, 

among other things. Without this information, data would be of 

limited use only. In the following section we will introduce some of 

the common file formats and extensions, as well as some geographic  
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data examples. The possibilities of types of data in GIS are becoming 

broader as the technology develops. The following is a non-exhaustive 

list that shows some of the data types you may encounter when using 

GIS. 

 

3.2.1. Maps 

Topographic maps (Fig. 4) are representations of the terrain which 

include both natural and man-made features, including, relief (in the 

form of contour lines), towns, villages, roads, and other geographic 

characteristics (Burrough and McDonnell, 1998). They are those maps 

which people are most familiar with. In GIS, topographic maps are 

stored in raster format in their entirety, but can also be broken down 

into their respective categories (rivers, buildings, roads, etc.) in vector 

layers. 

 

3.2.2. Aerial imagery 

Photos taken from the air, usually from an aircraft, are referred to as 

aerial imagery or photographs (Fig. 5). These images provide valuable 

information about landscape changes by comparing photos over time. 

When aerial images are georeferenced, i.e. located with respect to a 

geographic or projected coordinate system, they can be used as 

raster layers in GIS (Burrough and McDonnell, 1998). The different 

types of aerial images include black and white, true colour, 

panchromatic, and infrared and can each be used for different 

purposes (Campbell, 2002). 
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3.2.3. Satellite imagery 

Satellite images are those that have been taken from satellites. 

Landsat (Fig. 6) is one of the longest running platforms for image 

acquisition using the Thematic Mapper (TM) or the Enhanced  

Fig. 4. A sample topographic map (scale 1: 200 000) covering the 

study area of Fribourg, Switzerland. This map comes from Swisstopo 

(2013) and must only be used for visualization purposes in this paper. 

Reproduced with permission of Swisstopo (BA13016). 

Name Website Types of data 
Aster GDEM http://asterweb.jpl.nasa.gov/gdem.asp 30 m DEM of the world 

CloudMade downloads.cloudmade.com 
Layers created from Open Street Maps for various 
places in the world 

Corine Land Cover 2006 (European 
Environment Agency (EEA)) 

http://www.eea.europa.eu/data-and-maps/data/
corine-land-cover-2006-raster-2 

Land cover raster data for Europe 100 m and 250 m 
resolutions 

European Environment Agency 
(EEA) 

http://www.eea.europa.eu/data-and-maps/
data#c5=all&b_start=0&c9=CLC2006 Land use, economics, natural resources, water, etc. 

FOSSGIS (Free and Open Source 
Software for GIS) http://freegis.org/ Many from multiple sources 

Global Land Cover Facility (GLCF) Glcf.umd.edu/data/ 
Satellite imagery, products derived from satellite 
imagery, vector products 

Open Street Map  www.openstreetmap.org Global or individual country or state map data 

Swisstopo Landsat Image 
http://www.swisstopo.admin.ch/internet/ 
swisstopo/en/home/products/images/ortho/ 
landsat.html 

Digital satellite mosaic 

United Nations Geographic  
Information Working Group 
(UNGIWG) Second Administrative 
Level Boundaries (SALB) 

http://www.unsalb.org/ International borders 

United States Geological Survey 
(USGS) Earth Resources Observation 
and Science (EROS) Center 

http://eros.usgs.gov/#/Find_Data 

Aerial Photography 
Satellite Imagery 
Elevation 
Land Cover 
Digitized Maps 
Image Gallery Collections 

Table 2. Names, websites, and types of data available from various free data sources. 
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3.2.4. Digital Elevation Model (DEM) 

A DEM (Fig. 7) is a raster dataset that represents the altitude of the 

terrain. Depending on the resolution of the image, each pixel 

represents the average altitude of the terrain covered by that pixel. 

For example, if the image resolution is 30 m, the altitude of the 

terrain on the ground that is covered by that pixel within that 30 m 

square is averaged and the value is assigned to that pixel.  

With a DEM, numerous calculations can be performed including 

the calculation of slope (in degrees or percent) of the terrain, the 

direction each slope is facing (aspect), and where shadows exist when 

the sun is hitting the terrain from a certain angle (hillshade). A DEM is 

also the base dataset for calculations of solar radiation, hydrographic, 

and various modelling calculations. 

 

3.2.5. Thematic vector data 

Vector (Fig. 2) data represent a broad range of information, as they 

include all layers represented by points, lines, or polygons. In a GIS 

database, common vector layers might represent administrative 

boundaries (the locations of countries, provinces, states, cantons, 

etc.), hydrography (rivers, dams, lakes, etc.), built-up areas 

(buildings, stations, airports, etc.), and land cover. 

 
 

4. Coordinate systems  
This section will briefly introduce the concept of coordinate systems in 

GIS. For any analysis, it is important to know the coordinate system of 

the data which represent the study area (region of interest) and to 

ensure that all of your data layers are already in, or can be converted 

 

Thematic Mapper (ETM) satellite image acquisition systems (http://

landsat.gsfc.nasa.gov/) which provide multispectral imagery for the 

whole world (Campbell, 2002). Satellite imagery is often expensive to 

buy as the equipment is difficult to operate and maintain, but 

conveniently, Landsat and other satellite images can be added as 

raster layers directly into the GIS interface. 

The COLOSS BEEBOOK: GIS 9  

Fig. 5. A sample orthophoto, with a resolution of 50 cm, showing the 

study area of Fribourg, Switzerland. This photo comes from Swisstopo 

(2013) and must only be used for visualization purposes in this paper. 

Reproduced with permission of Swisstopo (BA13016). 

Fig. 6. A section of the Swisstopo (2013) Landsat image (freely  

available from at http://www.swisstopo.admin.ch/internet/swisstopo/

en/home/products/images/ortho/landsat.html) with a resolution of 25m, 

covering the study area of Fribourg, Switzerland. Reproduced with 

permission of Swisstopo (BA13016). 

Fig. 7. A sample Digital Elevation Model (DEM) (30 m resolution) 

covering the study area of Fribourg, Switzerland. This map was a free 

download from ASTER GDEM which was projected to the Swiss  

projected coordinate system (CH1903 LV03). 
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to, that coordinate system. Basic knowledge about coordinate systems 

is recommended before any type of spatial analysis is conducted as 

they can affect the resulting outputs. It is also important to know the 

capabilities and weaknesses of each specific coordinate system used 

in analysis. For more in-depth information about coordinate systems 

in GIS see Seeger (1999). 

 

4.1. Geographic coordinate systems 

A geographic coordinate system is defined by the ellipsoid and datum 

that are used to calculate longitudes and latitudes which represent 

locations on the Earth's surface (Snyder, 1987). It is represented in 

degrees, minutes, and seconds north or south of the equator 

(latitude) or east and west of the equator (longitude) (i.e. Fribourg, 

Switzerland is at 46° 48’ 00’’ N, 7° 09’ 00’’ E), and is the simplest 

solution for representing places on the globe (Burrough and McDonnell, 

1998). Decimal degrees are also used to represent latitude/longitude 

coordinates and can be calculated with the following equation: 

Decimal Degrees = Degrees + Minutes/60 + Seconds/3,600 (http://

support.esri.com/en/knowledgebase/techarticles/detail/27215) (i.e. 

same location above would be represented as 46.8 N, 7.15 E). There 

are various online sources for calculating conversions between 

latitude/longitude and decimal degrees (e.g. http://transition.fcc.gov/

mb/audio/bickel/DDDMMSS-decimal.html).The most commonly used 

geographic coordinate system is the World Geodetic System (WGS) 

1984 (Fig. 8). However, geographic coordinate systems do not transfer 

nicely into two dimensions, causing major distortions in distance, area, 

shape, or direction (Snyder 1987; Seeger, 1999) on a map or computer 

screen. To solve these issues, projected coordinate systems are used. 

 

4.2. Projected coordinate systems  
Projected coordinate systems are created to allow a two-dimensional 

representation on a screen or map sheet (Snyder, 1987). Latitudes 

10 Rogers, Staub 

and longitudes are converted to meters with respect to the centre of 

projection by applying calculations to geographic coordinate systems 

to counteract and offset the distortions on the map. Map projections 

have been developed for both local and regional scales. There is a 

large body of research based on the calculations of map projections 

(see Snyder, 1987 or Seeger, 1999 for more information). One of the 

most important things to remember is that all map projections create 

distortion of a least one parameter of the following: distance, direction, 

scale, conformity (shape), and area (Snyder, 1987; Seeger, 1999). The 

goal of map projections is to show specific areas with the least amount 

of distortion. For specific regions, take Switzerland as an example, a 

map projection has been created (CH 1903 LV03 - the coordinates  

for Fribourg in the CH1903 LV03 projection are 577965.97 m E, 

183244.73 m N) to display the least amount of distortion for the 

country, but very high levels of distortion elsewhere (Fig. 9). 

 

Fig. 8. A map of the world shown in the WGS 84 geographic coordinate system.  

Fig. 9. A map of the world shown in the CH 1903 projected coordinate 

system.  
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different university-level institutions and thus oriented to concrete 

solutions, e.g. in environmental science or modelling and on 

technological improvements. Besides that, most open source software 

is available for free and the users can benefit from the availability and 

transparency of the open source (program) code, which may be 

adapted for specific consumer needs and can again be shared within 

the community. Furthermore, open source software becomes more 

and more platform-independent and integrative between various 

projects, libraries, and standards. Some of the software that exists for 

open source GIS includes the System for Automated Geoscientific 

Analysis (SAGA, http://www.saga-gis.org), the Geographic Resources 

Analysis Support System (GRASS, http://grass.osgeo.org), and 

Quantum GIS (QGIS, http://www.qgis.org/). QGIS is based on an 

intuitive mapping interface with optional plugins (supplementary 

program code providing additional functionalities, similar to ESRI 

ArcGIS extensions) for geoprocessing, analysis, and interoperability 

with various other software, standards, and data types. GRASS is 

more advanced in terms of its inherent spatial analytical ability 

especially for raster data, but some programming knowledge is of 

advantage for more sophisticated analysis and script automation. The 

integration of GRASS applications in QGIS through a plugin has a long 

tradition in the QGIS history, meaning that one can benefit from the 

strengths of both systems at once. Furthermore, the latest releases of 

QGIS provide a toolbox called “SEXTANTE” (http://www.sextantegis.com) 

where various Open Source software and libraries like SAGA can be 

accessed through the straightforward user interface of QGIS. Chapter 

7 provides a tutorial for QGIS with basic applications adapted to 

honey bee research. For further information about open source GIS 

software and the different projects mentioned above see the Open 

Source Geospatial Foundation website http://www.osgeo.org.  
 

5.3. Tutorial data  
The following sections contain step by step information on how to 

complete certain GIS tasks using both ArcGIS and QGIS. To follow 

these steps, the file “GISBEEBOOK”, can be downloaded from (http://

www.ibra.org.uk/articles/GISBEEBOOK). Download the data and save 

them in a location with a few gigabytes of space available. Within the 

GISBEEBOOK folder, there are two sub-folders, one for ArcGIS and 

one for QGIS, each containing the same original data. When working 

through each tutorial, it is recommended that you save your outputs 

in the respective software’s folder to help with file and data 

organisation. Both folders are located within the GISBEEBOOK folder. 

The GISBEEBOOK file contains the two folders (ArcGIS and QGIS) 

with the following data layers in each:  

 Point file: This file was created solely for the purpose of this 

exercise and does not represent the actual locations of honey 

bee colonies. 

 ArcGIS: An Excel file containing point locations: 

colony_locations.xlsx.  

The COLOSS BEEBOOK: GIS  

5. Types of GIS software 
  

Various types of GIS software exist, each with their own strengths 

and weaknesses. For the purpose of this paper, we will focus on and 

discuss one commercial off-the-shelf GIS (COTS GIS) software, ArcGIS, 

and one Free and Open Source GIS (FOSS GIS) software, QGIS. 

These two software suites were chosen due to their popularity and 

use in the field of GIS. Throughout the next sections, some basic 

functions of GIS will be introduced and explained.  

 

5.1. COTS GIS - ArcGIS 

One of the most well-established and popular GIS programs is ESRI’s 

ArcGIS suite. ArcGIS was established in 1969 originally as a research 

group focused on landuse planning initiatives (ESRI, 2013). Since then, 

ArcGIS has grown exponentially and is now the leading commercial 

GIS software which incorporates mobile, desktop, server, and online 

platforms. Until recently, the licence levels in ArcGIS were organized 

by the naming scheme ArcView, ArcEditor, and ArcInfo, which 

denoted the amount of access to tools and functionalities within the 

software. Now, the different levels are called Basic, Standard, and 

Advanced, respectively, to make the licence levels more intuitive. The 

Basic level allows access to mapping and interactive visualization 

functionalities, the Standard level offers those as well as multiuser 

editing and advanced data management, and the Advanced level 

offers all of the above, plus, advanced analysis, high-end cartography, 

and extensive database management possibilities (ESRI, 2013). These 

different levels allow the buyer to choose the package that fits their 

needs. Also, you can add extensions such as Spatial Analyst, 3D 

Analyst, and Geostatistical Analyst, which are sets of tools for specific 

tasks (ESRI, 2013). Extensions allow the user to add more advanced 

functions without the need for upgrading to a different licence. 

However, one major problem with ArcGIS and other ESRI products 

are costs, which can often only be afforded by large corporations, 

universities, and government agencies. Students or research groups 

can often acquire versions for free, or at reduced costs, respectively. 

However, the price is often a deterrent when a company or individual 

is choosing which GIS software to purchase. Free trials are also 

available from http://www.ESRI.com/software/arcgis/arcgis-for-

desktop/free-trial. Also, various online training courses (http://

training.esri.com/), tutorials (http://resources.arcgis.com/en/help/

main/10.1/index.html#//00qn0000013t000000), and other resources 

(http://resources.arcgis.com/en/home/) are available online to help 

with specific tasks. 

 

5.2. FOSS GIS - QGIS  
Open Source software is gaining ground in the GIS software business. 

The scientific community is coming together to use, create, and 

enhance open source GIS tools. The development of open source GIS 

is usually driven by very active communities closely collaborating with 
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 QGIS: A comma-separated text file (*.csv) containing the 

same point locations: points-table.csv. 

 A shapefile containing commune information: 

commune_boundary_FR.shp (plus 6 other file extensions 

which must stay together). This data comes from a clip of the 

Vector200 Swisstopo (Swisstopo, 2013) data layer which is 

provided to the readers of this paper for testing purposes only 

and cannot be shared or used for data analysis purposes 

outside of this tutorial. Communes are a type of 

administrative unit in Switzerland.  

 30 m DEM:  

 ArcGIS: Located within the DEM folder: aster30_frib_ch.tif 

(along with 4 other extensions that should be kept together 

with this file for georeferencing purposes).This DEM was a 

free download from the ASTER GDEM website (http://

gdem.ersdac.jspacesystems.or.jp/). The projection was 

previously changed to the Swiss coordinate system (CH1903) 

and clipped to the area around Fribourg. 

 QGIS: ASTER30_WGS84.tif. Also downloaded from the ASTER 

GDEM website but left in the WGS 1984 coordinate system.  
 

 

6. Using ArcGIS (version 10.1)  

6.1. Main components of ArcGIS  
The main components of ArcGIS include ArcMap, ArcCatalog, and 

ArcToolbox, however, the other platforms that are included in ArcGIS 

for Desktop are ArcScene and ArcGlobe which both enable 3D data 

viewing and manipulation. ArcGIS has also grown to include mobile 

applications, map viewers (ArcGIS Explorer: http://www.esri.com/

software/arcgis/explorer), and cloud mapping (www.arcgis.com), 

which will be discussed in section 6.10.10. For more information about 

ArcGIS in general refer to Ormsby et al., 2010. 

 

6.1.1. ArcMap  
ArcMap (Fig. S 10) is the main interface for conducting analyses and 

creating maps. Here, feature classes and shapefiles can be populated, 

data can be edited, calculations can be performed, and finally, maps 

can be created for displaying the results of the GIS analysis. ArcMap 

projects are stored as map documents (*.mxd) which save all of the 

layers added to the map as well as the results of any of the 

geoprocessing tools which were used. It is important to note that the 

*.mxd does not store the actual data, but only references to them and 

user-defined layer organization and symbols. Upon first opening 

ArcMap (Start menu > All programs > ArcGIS > ArcMap 10.1) a 

dialog box will pop-up. Select a recently used map from the list, 

browse to a map that was previously saved, or just click Cancel or 

close the window to open a blank map. 
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6.1.2. ArcCatalog  

ArcCatalog (Fig. S 11) is where GIS data can be searched for, previewed, 

and managed. Also, some ArcToolbox tasks can be performed and 

visualized, but not overlaid with other layers like in ArcMap. Since 

ArcGIS version 10.0, a more compact version of ArcCatalog can also 

be accessed directly in ArcMap. ArcCatalog should be used when 

geographic data are added, moved, or deleted from GIS in order to 

avoid losing important file extensions (e.g. the geographic reference, 

see section 3.1 for more information). To open ArcCatalog: Start 

menu > All programs > ArcGIS > ArcCatalog 10.1. 

  
6.1.3. ArcToolbox  
ArcToolbox (Fig. S 12) is where all of the geoprocessing and spatial 

analysis tools are located. There are hundreds of tools available and 

they range from basic to advanced. The toolbox can be accessed in 

both ArcMap and ArcCatalog by clicking the       icon from the 

standard tools menu or by selecting Geoprocessing > ArcToolbox 

from the main menu. To easily find a tool, type the name of the tool 

into the Search window to save time from manually searching through 

the toolbox. In the following sections, some of the more basic toolbox 

tools will be discussed, but this is by no means an exhaustive tutorial.  
 

6.2. Navigating the software  
At first, the multiple functionalities and options within ArcGIS may 

seem overwhelming, but there are a lot of resources that exist to help 

navigate the software and search for help if there are problems. 

 

6.2.1. Help menus  

Help menus can be accessed by choosing Help from the main menu, 

or by pressing F1, in both ArcMap and ArcCatalog. The entire ArcGIS 

help menu can also be found online, which is slightly more intuitive 

and easier to search through. The online help menu can be found at: 

http://resources.arcgis.com/en/help/main/10.1/. For previous versions 

of ArcGIS, the help menus can be found at http://

resources.arcgis.com/en/help/previous-help/index.html. 

 

6.2.2. Search window 

The Search window can be found in the standard toolbar (      ) or by 

selecting Customize > Search from the main menu. The search  

window can be used to search for GIS content including data located 

on the computer and tools within ArcGIS. 

 

6.2.3. Toolbars 

In ArcMap there are a variety of toolbars, used for different tasks, to 

choose from. To display or hide toolbars, from the main menu select 

Customize > Toolbars and check which ones to display and hide. By 

hovering over the tools in the toolbars you can see the name of each 

respective tool. 
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To set the coordinate system of the map document: 

1. Go to View. 

2. Select Data Frame Properties. 

3. Open the Coordinate System tab.  

4. For the remainder of this paper, we will use data from 

Switzerland, therefore we will use the projected coordinate 

system called CH1903 LV03. Double-click Projected 

Coordinate Systems. 

5. Double-click National Grids. 

6. Double-click Europe. 

7. Select the CH1903 LV03 option. 

8. Click OK. 

 Or: 

1. Using the search bar, directly type in the following: CH1903 

LV03. 

2. Click the Search button.  

3. Double-click on Projected coordinates folder > select the 

CH1903 LV03 option from the list 

4. Click OK.  

5. To save these properties in the map document (*.mxd), go to 

File. 

6. Click Save As. 

7. Name the file and click OK.  
 

6.3.2. Add data button 

Data can be added from File > Add Data > Add Data or by selecting 

the Add Data symbol          from the standard toolbar. Alternatively, 

data can be added via drag and drop from ArcCatalog. Since version 

10.0, there are also the options of adding base map and other data 

from ArcGIS online. This will be discussed further in the cloud 

mapping section (6.10.10.). 

 

6.3.2.1. Connecting to folders 

To access the tutorial data, first the GISBEEBOOK folder must be 

connected to. Browse to the location of the GISBEEBOOK folder using 

this icon        in the Add Data dialog box. This path to the GISBEEBOOK 

folder is now saved for the next time data are added from the same 

folder.  

 

6.3.3. Importing vector and raster data 

Vector data are point, line, and polygon features on the map which 

represent real world entities while raster data represent continuous 

features such as altitude or satellite imagery (see section 3.2. for data 

explanations). Here we will add a polygon layer which represents the 

administrative boundaries in and around Fribourg, Switzerland, and a 

DEM from the same area.   

To add a vector layer: 

1. Click the Add Data button. 

2. Browse to the commune_boundary_FR shapefile.  

6.2.4. General reminders, shortcuts, timesavers 

Here is a list of items that will save time when using ArcGIS: 

 Naming schemes for files, folders, and anything else 

associated with ArcGIS should not have spaces. Instead, 

underscores (“_”) should be used when a space is needed. 

 In case data or project files (*.mxd) are moved to a different 

location, it is useful to save the relative paths of the data so 

that ArcMap is able to automatically locate the data without 

having to manually point to the data every time in ArcMap 

(when ArcMap cannot find the data, a small red exclamation 

(!) point appears beside the layer in the table of contents 

(TOC)). To do this: 

 File > Map Document Properties > Pathnames: check the 

“Store relative pathnames…” option. 

 To make this feature permanent, go into the ArcMap options 

Customize > ArcMap Options > General tab > and check the 

“Make relative paths the default for new map documents”. 

▪ Also while in the ArcMap options, have a look at the other 

options and customize your ArcMap interface to fit your 

needs. 

 When both ArcCatalog and ArcMap are open on the desktop, 

files from ArcCatalog can be directly dragged and dropped 

into ArcMap without having to use the Add Data button. 

 After performing geoprocessing or spatial analyses, the results 

for all tasks are stored in the results window which can be 

opened by selecting Geoprocessing > Results from the main 

menu in ArcMap. The Results window is useful for keeping 

track of the tools you already used and easily allows you to 

reuse them again with alterations to the inputs. 

 The naming of raster layers in grid format (ArcGIS native 

format) cannot be more than 13 characters long. 

 Save frequently to avoid losing work!     

 

6.3. Setting the coordinate system and adding 

data to ArcMap 

Upon opening ArcMap, first close the pop-up to open a blank map. It 

is good practice to set the coordinate system to match the data which 

will be added, but this step is not required as ArcMap will take on the 

same coordinate system as the first layer that is added. All subsequent 

data will be projected “on-the-fly” to the coordinate system specified 

in the first layer. This will become more apparent later. 

 

6.3.1. Setting a coordinate system and saving a new map 

document (*.mxd) 

 Setting the correct map units is important for all types of quantitative 

analysis and for appropriate cartography. Despite on-the-fly projection 

capabilities, if layers are in different coordinate systems, this will pose 

major problems in the display and analysis of data. 

D
o
w

n
lo

ad
ed

 b
y
 [

5
4
.2

0
9
.1

4
0
.2

0
7
] 

at
 1

1
:1

6
 2

6
 A

p
ri

l 
2
0
1
6
 



Depending on the type of vector added, it will have a point      , 

line       , or polygon       icon. This one is a polygon layer. 

3. Single-click the commune_boundary_FR shapefile. 

4. Click Add. 

Now the vector layer can be seen in the TOC and in the map. 

5. Change the symbology to make the polygons hollow (no fill, 

thicker line) so the DEM is visible (Fig. S 13). 

6. In the TOC the name of any layer can be changed by slowly 

double-clicking the layer name or by going into the Properties 

> General and change the layer name there to make it more 

intuitive, if needed. 

7. Now would also be a good time to save the map document 

(*.mxd). Go to File > Save (or use the shortcut Ctrl + s).  

 

To add a raster layer: 

1. Click the Add Data button. 

2. Open the DEM sub-folder in the GISBEEBOOK folder. 

3. Double-click the aster30_frib_ch.tif file to add it to the map.  

In ArcGIS rasters are represented by this icon       . Now the DEM 

can be seen in the TOC and on the map (Fig. S 14).  
 

6.3.3.1. Importing XY data from text files 

Many people work with spatially related data even without recognizing 

it, for example when dealing with observation or address data from 

multiple locations. It is easy to make use of spatial information also 

from data stored in text files, calculation spreadsheets or any database. 

Often, point data representing  X, Y, and sometimes Z (altitude) 

coordinates in the real world are contained within text files and can be 

imported into ArcMap as an Excel spreadsheet (*.xls or *.xlsx), a text 

file (*.txt), or comma separated value (*.csv) file. To ensure that this 

is done without problems or annoyances, ensure the data are properly 

formatted. For example, the field names in the header line of the text 

file should not use spaces or special characters, nor should the 

filename.  

To add points from a text file (Fig. S 15): 

1. Go to File.  

2. Select Add Data.  

3. Select Add XY Data.  

4. Browse to the GISBEEBOOK folder.  

5. Double-click the colony_locations.xlsx file. 

6. Double-click Sheet1$. 

7. Choose the respective fields that hold the X and Y data (or 

longitude and latitude, depending on which coordinate system 

is used). If the file contains altitude information, add that field 

in the Z field. In this case: 

a. X Field: POINT_X 

b. Y Field: POINT_Y 

14 Rogers, Staub 

8. The coordinate system has already been defined for this layer. 

9. Click OK. 

It is important to note that this layer is loaded into ArcGIS and 

available for any display and map creation purpose and also some 

basic analysis, but not physically stored as geodata in the file system. 

A warning dialog box (Fig. S 16) may appear which indicates that the 

created layer will have to be exported to a shapefile if all 

functionalities are needed.  

10. Click OK. 

Now the points can be seen in the map and the layer can be seen 

in the TOC. 

11. Right-click the “Sheet1$ Events” layer in the TOC. 

12. Select Data. 

13. Select Export Data to export these temporary points and 

make a permanent shapefile. 

14. Choose to use the layer’s source data as the correct 

coordinate system should have already been set in the 

previous steps. 

15. Browse to the GISBEEBOOK/ArcGIS folder to name the files 

intuitively, for example, we will name this layer colony_locations.  

16. Save as type: Shapefile. 

17. Click OK. 

18. Click Yes when asked to display the new layer on the map. 

19. Remove the Sheet1$ Events layer by right-clicking on Sheet1$ 

Events layer. 

20. Select Remove. We now have the permanent shapefile, so 

this temporary layer is no longer needed (Fig. S 17). 

21. To change the symbology of the point layer to make the 

points more visible, either: 

a. Single-click on the symbol in the TOC and choose the new 

symbol and size. 

b. Go into the properties of the layer by right-clicking Layer. 

c. Select Properties. 

d. Click the Symbology tab.  

e. Change the symbol to a yellow circle for example.  

f. Click OK. 

Also to note, there are multiple symbol libraries that can be added 

by clicking the Style References button when in the Symbol Selector 

dialog box. The symbol libraries provide more options for symbol styles.  
 

6.3.3.2. Importing GPS data (*.gpx files) 

Geographic coordinates, often collected via a handheld Global 

Positioning Systems (GPS) receiver can be imported and displayed in 

ArcGIS (since version 10.1). GPS data are in the GPS eXchange 

Format (*.gpx) and can be converted to shapefiles using the GPX To 

Features (Conversion) tool, which can be found in the Conversion 

Tools toolbox > From GPS toolset.   
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feature. In the example (Fig. S 18), it can be seen that the location on 

the map which was clicked is somewhere in the commune of Düdingen 

and has an altitude of about 612 m. This information comes from the 

commune layer and the DEM that are currently in the ArcMap *.mxd.  

The second, more advanced, type of query in GIS refers to the 

database query. This type of query uses a structured query language 

(SQL), adopted from database management systems, which allows 

the retrieval of information from the database (Longley et al., 1999). 

In ArcMap, the tool that incorporates SQL is the Select by Attributes 

(6.4.1.1.) tool. To go beyond the database search, the Select by 

Location (6.4.1.2.) tool can be used for geographic or locational 

queries of data. Selections can also be conducted manually using the 

Select Features tool (6.4.1.3.). These three selection methods can 

also be used in combination by changing the method of selection 

(Create new selection, Add to current selection, Remove from current 

selection, Select from current selection) in each respective dialog box. 

Any selection can be removed by clicking the Clear Selected Features 

button. 

 

6.4.1.1. Select by attributes 

The Select by Attributes tool is located on the main menu in Selection 

> Select by Attributes, or also within the attribute table of each layer: 

Right-click layer > Open Attribute Table > Table Options          >        

Select by Attributes. This tool allows the user to select a set of data 

from a layer based on the attribute properties of the layer. In the 

following example, all the communes within the canton of Fribourg, 

Switzerland, will be selected because all of the honey bee colonies are 

within that canton.  

1. From the main menu, go to Selection. 

2. Click Select by Attributes. 

3. The input layer is the layer from which data will be selected. 

In this case, choose the commune_boundary_FR layer as input. 

4. There are multiple methods available:  

a. Create new selection, 

b. Add to current selection, 

c. Remove from current selection, 

d. Select from current selection. 

5. Choose Create new selection. 

In the next section there is a list of attributes corresponding to 

those of the input layer.  

6. Select the KANTONSNR attribute by double-clicking on the name. 

7. Click the equals =  button. 

8. Click the Get Unique Values button to see all the values in 

that attribute field. In this case, the values represent two 

cantons in Switzerland. 

9. Double-click the 10 to add it to the equation. In this example, 

10 was clicked because that is the canton number for Fribourg. 

10. Now the SQL equation looks like this: SELECT * FROM 

commune_boundary_FR WHERE: “KANTONSNR” = 10 (Fig. S 19). 

6.3.4. Layer organisation and navigation 

It is essential to have some basic knowledge about layer organisation 

and navigation in order to optimize the map display (e.g. to change 

the order and how layers are drawn in the Data View) and to preserve 

a good organisation among all the different data, intermediate 

calculation results and map elements, especially for a growing GIS 

project with many layers. In ArcMap, the layers will be displayed on 

the map in the same order as in the TOC. In Fig. S 13 for example, 

the colony_locations layer is above commune_boundary_FR and 

aster30_frib_ch.tif layers therefore everything can be seen clearly, 

since we made the commune boundaries hollow. If the DEM was at 

the top of the layer list in the TOC then the other two layers would be 

hidden. At the top of the TOC there are five icons   

which allow different views of the data in the TOC. To rearrange the 

layers in the TOC, select the first icon (List by Drawing Order) and 

click and drag the layers to their new positions. The layers can be 

turned on and off by checking or unchecking the box beside the layer.  
 

6.3.5. Layer properties 

The properties of one specific layer can be accessed by right-clicking 

the layer and selecting Properties from the context menu, or simply 

by double-clicking the layer name. The Layer Properties might vary 

between different file formats, but every layer will at least have tabs 

for Symbology options, General settings and provide metadata (see 

section 3.) in the Source tab. Look at the metadata of the layer 

commune_boundary_FR.shp by opening the Source tab in the Layer 

Properties. Apart from the extent (maximum and minimum values for 

X and Y), data source, and geometry type, there is also information 

about the coordinate system and projection used. From the Display 

tab, the transparency of the layer can be set and the Labels tab 

enables the labelling of features in the layer. 

 

6.4. Database investigations and editing 

Some databases have hundreds, if not thousands or millions, of 

entries. This makes manual searching almost impossible. Like any 

other form of database management system, ArcMap offers a number 

of options to efficiently browse, select, export and edit these records. 

 

6.4.1. Queries 

One of the characteristics of GIS is the possibility to combine information 

about several layers and datasets by using a geographic reference, 

e.g. a given point, a set of polygons or specific grid cells in a raster 

image. Queries are used to locate specific records from tables or 

places on the map based on the shared properties of layers. In GIS, a 

query can refer to two different functions. The first is a very basic GIS 

function that enables the user to interactively obtain information 

about a specific location in the GIS, using the Identify         tool. The 

Identify tool is used to get information about specific pixel values 

within a raster image or to look at the attribute values of vector 
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11. Click OK 

12. Open the attribute table of the layer from which data were 

selected (Right-click > Open attribute table). 

13. Click the Show selected records button to view the records 

corresponding to the selection        . 

14. The selected records (49 out of 51) in the table match those 

selected on the map (Fig. S 20). 

15. Now the selection can be cleared using the icon      to begin a 

new selection in the next section.  
 

6.4.1.2. Select by location 

Now two layers will be used to select the communes which have 

colonies inside them. To do this (Fig. S 21): 

1. Go to Selection.  

2. Choose Select by Location. 

3. Choose the Selection method: select features from the target 

layer: commune_boundary_FR. 

4. Select the Source layer: colony_locations. 

5. Select the Spatial selection method: intersect the source layer 

feature (this tool has various options for spatially querying 

data and applying search distances to discover geographic 

relationships). 

6. The selected results: 11 records out of 51 (Fig. S 22), 

meaning 11 communes had colonies inside their boundaries.  

 

6.4.1.3. Manual selection 

Data can also be selected manually with the Select Features tool        

in the Tools toolbar. With this tool, you can select the data by various 

shapes (rectangle, polygon, circle, etc.) and export the selected items 

to their own shapefile (see section 6.4.2.). 

 

6.4.2. Creating new layers from selected data 

If a selection of data has to be exported, to send to someone who 

needs only a part of a data layer, for instance, a new data layer can 

be created with the selected features. We will create a new layer with 

the data selected in section 6.4.1.2. 

1. Perform step 6.4.1.2. 

2. Close the Select by Location dialog box. 

3. Right-click on the commune_boundary_FR layer in the TOC. 

4. Go to Data. 

5. Select Export Data.  

6. Select Export: Selected features. 

7. Use the same coordinate system as the source data. 

8. Save as a new shapefile in the ArcGIS BEEBOOK folder. Call it 

colony_communes.shp. 

9. Click Save. 

10. Click OK. 

11. Click Yes to add the new layer to the map. 

12. Clear the selected features, go to Selection. 

13. Click Clear selected features. 

14. Turn off the commune_boundary_FR and aster30_frib_ch.tif 

(DEM) layers in the TOC.  

15. Right-click on the colony_communes layer. 

16. Click Zoom to layer (Fig. S 23) to focus the map on that layer.  

 

6.4.3. Attribute table data editing 

Not only can the attributes of layers be displayed and used for selection, 

but they may also be changed or removed. The data in tables can be 

edited and new fields can be added and populated. The attribute table 

for the colony_locations layer has two fields with no data in them. To 

populate information about the site location and the apiary number 

(as examples), the table can be edited.  

To edit attribute tables: 

1. Right-click the colony_locations shapefile. 

2. Go to Open Attribute Table. 

3. Open the Editor toolbar. 

4. Go to Customize. 

5. SelectToolbars. 

6. Select Editor. 

7. From the Editor toolbar, select Editor. 

8. Select Start Editing. 

9. Choose the colony_locations layer to be edited. 

10. Click OK. 

Previously the column names in the attribute table were grey; 

when in editing mode they will turn white which means they are 

editable (Fig. S 24). 

11. Click in the cell to edit and type the information. Information 

can be manually typed or if the information exists in a text 

file, copy and paste them into the table while in editing mode. 

12. Periodically save your edits: Click Editor. 

13.  Click Save Edits. 

14. Click Editor again. 

15. Click Stop Editing to end the editing session. 

 

6.4.4. Add new field 

To add a new field to the table: 

1. Open the table options        .  

2. Select Add field. Note: Fields can only be added outside of the 

editing mode!! 

3. Name the new field you would like to add. 

4. Select the type of data which will populate it (see Table 3 to 

learn about data types). 

5. Click OK.  

6. A message might warn you that you are performing calculations 

outside of an editing session. Check the Don’t warn me again 

option.  

7. Click Yes. 

8. To manually add information to the new attribute field, go 

into the editing mode and type them into the new field. 
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6.4.4.1. Advanced table calculations 

1. For more advanced table management: 

a. Use the field calculator to calculate the inputs in the field:  

i. Right-click new field name. 

ii. Select Field Calculator. 

iii. Use computer programming code to write the 

equation for the calculation. 

b. Use the calculate geometry option to calculate the x and y 

coordinates of point layers, or areas, and centroids of 

polygon layers:  

i. Right-click on New Field Name. 

ii. Select Calculate Geometry. 

iii. Choose one of the calculation options. 

 

6.5. Basic vector tools 

The following section shows how to perform selected vector data 

calculations. The name of the tool will be given and the name of the 

toolbox in which the tool is located in ArcToolbox will be given in 

brackets (tool (toolbox)). 

 

6.5.1. Clip  

Using the Clip tool, two layers can be overlaid with each other. The 

output layer (which has to be specified as a new vector file) will 

contain the content of the first layer (Input vector layer) reduced to 

the geometry and extent of the second layer (Clip feature) (Fig. 25). A 

similar process is also followed when clipping raster data, but the Clip 

(Data Management) tool is used instead. This tool is also useful if you 

require all data layers to have the same spatial extent, for example if 

you are working with a specific region and only need a small piece of  
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a bigger layer. Note: A specific example is not shown here, but this is 

how the tool would be used. 

To use the Clip tool: 

1. Open the Search window       . 

2. Type “clip” (or browse to Analysis Tools > Extract > Clip in 

the ArcToolbox). 

3. Choose the Clip (Analysis) tool. This one is for vector data. 

4. The Input features layer is the layer that will be clipped. 

5. The Clip Feature will be the new extent of the clipped layer. 

6. Name and save the new clipped layer. 

7. Click OK. 

 

6.5.2. Intersect 

The Intersect (Analysis) tool computes a geometric intersection of the 

layers. Only those input features which overlap will be included in the 

output layer. This tool is useful for connecting multiple layers and 

joining their attributes together, by discarding the portions which do 

not overlap. In the next example, we will intersect the colony_locations 

layer (colony locations) with the colony_commune layer so that the 

intersected layer will have the point locations but also the commune 

information for each point. To use the intersect tool (Fig. S 26): 

1. Open the Search window       . 

2. Type “intersect” (or browse to Analysis Tools > Overlay > 

Intersect in the ArcToolbox). 

3. Choose the Intersect (Analysis) tool. 

4. The Input Features will be all of those to intersect, in this case 

the colony_locations and colony_communes layers. 

5. Save the output as intersect.shp.  

6. Leave the defaults for the rest of the options. 

7. Click OK. 

In this case, the resulting geometry of the point file has not 

changed, but the attribute table of the intersected layer now 

includes the colony locations and commune information (Fig. S 27).  

 

6.5.3. Union 

The Union (Analysis) tool is used to create a geometric connection 

between polygon layers where all features and geometries will be 

added to the resulting layer. The union function is useful when the 

Table 3. Description of data types which are found in attribute tables, as well as the range of numbers or text they store and their uses. 

Adapted from the ArcGIS help menu (ESRI, 2013). 

Data type Storable range Applications 

Short integer -32,768 to 32,767 
Numeric values without fractional values within 
specific range; coded values 

Long integer -2,147,483,648 to 2,147,483,647 
Numeric values without fractional values within 
specific range 

Single-precision floating-point number (float) approximately -3.4E38 to 1.2E38 
Numeric values with fractional values within 
specific range 

Double-precision floating-point number 
(double) approximately -2.2E308 to 1.8E308 

Numeric values with fractional values within 
specific range 

Text --- Store alphanumeric symbols 
Date --- Store dates, times, or both 

Fig. 25. A visualisation of how the clip tool works in ArcGIS taken 

from the help menu (ESRI, 2013).  
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geometries and attributes of different layers should be merged. In 

ArcGIS, all input polygons will be transferred to the output layer, 

regardless as to whether they spatially overlap or not, leaving the 

resulting dataset with three feature types: those found only in the first 

input layer, those found only in the second input layer, and those 

found in both the first and second input layers (Ormsby et al., 2010).  

 

6.5.4. Spatial join 

In section 6.4.1. spatial queries were performed. In a similar manner, 

multiple layers can be spatially linked to each other using the Spatial 

Join (Analysis) tool. Spatial joins allow the attributes of features in 

separate layers to be linked together based on their shared spatial 

locations. This is useful for amalgamating different types of information 

into the same layer. The Spatial join (Analysis) tool can be used to 

perform this task. The Target Features can be any spatial data source 

supported by ArcGIS and will be transferred to the Output Feature 

Class along with the Join Features. The Join Operation determines 

how joins between target and join featured will be handled if multiple 

join features have the same spatial relationship with a single target 

feature; one-to-one or one-to-many (search spatial join in the ArcGIS 

online help menu for more information). 

 

6.5.5. Buffer(s) 

Buffers are one of the most important geoprocessing operations and 

frequently used for data analysis and cartography. A buffer increases 

the features area by a given radius, exactly following its original 

geometry (point, line or polygon). Buffers are also useful for determining 

proximities. For honey bees, this tool could be useful for determining 

the extent of the foraging radius with regards to various land covers, 

for example. 

  

6.5.5.1. Single buffer 

To create a single buffer (Fig. S 28): 

1. Type “buffer” into the Search window (or browse to Analysis 

Tools > Proximity > Buffer in the ArcToolbox). 

2. Select the Buffer (Analysis) tool. 

3. Input features will be the colony locations: colony_locations. 

4. Create a new output feature class: buffers.shp. 

5. Choose “2000 m” as the search radius. 

6. Leave the default options for the remaining. 

7. Click OK. 

The results show the buffered area surrounding each point  

(Fig. S 29). 

 

6.5.5.2. Multiple ring buffers 

To create multiple ring buffers (Fig. S 30): 

1. Type “buffer” into the Search window (or browse to Analysis 

Tools > Proximity > Multiple Ring Buffer in the ArcToolbox). 

2. Select the Multiple Ring Buffer (Analysis) tool. 

3. Input features will be the colony locations: colony_locations. 

4. Create a new output feature class: multi_buffers.shp. 

5. Type “100”. 

6. Click the plus sign (+). 

7. Do the same for 200, 300, 400, 500, and 1000 m. 

8. Choose the buffer unit (meters in this case). 

9. Keep the field name of “distance” for the new attribute table 

of the multiple buffer layer. 

10. Keep the default for the dissolve option, otherwise all buffers 

will be aggregated to one single feature without the different 

attributes (see section 6.5.7. for more information about 

Dissolve). 

11. Click OK. 

The results show the multiple buffers created surrounding the 

points (Fig. S 31). 

 

6.5.6. Summary statistics 

A Summary Statistics (Analysis) tool exists in ArcGIS and is useful for 

performing basic calculations on fields in an attribute table. This can 

be valuable for summarizing large quantities of data within GIS 

(similar to basic statistics that can be calculated in Excel). For example, 

the sum, mean, min, max, range, standard deviation, and count can 

be calculated for each selected attribute. The results are saved in an 

output table and can be viewed directly in ArcMap. Also, to access the 

statistics of single fields in an attribute table, Right-click the layer in 

the TOC > Open attribute table and then Right-click field name and 

choose the Statistics option.  

 

6.5.7. Dissolve 

Dissolve is another very useful function that merges several features 

together, based on their attributes. All features within a given vector 

layer containing the same attribute value will be combined to one 

single feature (one entry in the Attribute table). Shared borders 

between these geometries will disappear and in the case of spatially 

divided (geometrically non-adjacent) input features, the result will be 

a so-called “multipart” feature. The Dissolve (Data Management) tool 

is useful for portraying or visualizing specific information from a 

shapefile. For example, here we used the commune_boundary layer 

for Switzerland (basically the same as the commune_boundary_FR 

layer, but for all of Switzerland). The geometry of the layer currently 

represents the communes of Switzerland, but we want to visualize 

countries instead of communes. In the attribute table, there is a 

column indicating which country each commune belongs to, thus we 

can “dissolve” the administrative boundaries based on that field. In 

the next example, the attributes in the commune layer will be 

dissolved to create a new layer based on the country geometry. 

NOTE: Here we will use a layer that has not been provided in the 

tutorial. This is to illustrate what might be done using the dissolve 

tool. 
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To use the dissolve tool (Fig. S 32): 

1. Type “dissolve” into the Search window (or browse to Data 

Management Tools > Generalization > Dissolve in the 

ArcToolbox). 

2. Select the Dissolve (Data Management) tool. 

3. The Input features will be the commune_boundary (for all of 

Switzerland) in this case. 

4. Name and save the output layer as a shapefile. 

5. In this case we will dissolve based on the COUNTRY attribute. 

6. Leave the default options for the remaining. 

7. Click OK. 

The result (Fig. S 33) shows that the geometry and the attributes 

represent only the countries. 

 

6.5.8. Project 

Data layers often need to be “projected” to get them into the same 

coordinate system as other layers. For example, if data comes from 

different places (e.g. online, governmental agencies) or represents 

different areas on the map, there is a good chance that the coordinate 

systems between layers will differ, therefore a projection of the data 

is required. If layers are not in the same coordinate system and not 

overlapping correctly, there will be errors in the resulting layers created 

after analyses. The Project (Data Management) tool is used to change 

a vector layer from one coordinate system to another. The same 

process can also be used for raster layers, but the Project Raster 

(Data Management) tool is used instead. If the layer’s coordinate 

system is unknown, it must first be defined, either in the layer 

properties in ArcCatalog or by using the Define Projection (Data 

Management) tool in ArcMap. In this example, we will project the 

colony_communes layer from the Swiss projection to WGS 1984 and 

import the results into Google Earth (KML file) (6.5.9.). 

To use the project tool (Fig. S 34): 

1. Type “project” in the Search window (or browse to Data 

Management Tools > Projections and Transformations > 

Feature > Project in the ArcToolbox). 
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2. Select the Project (Data Management) tool. 

3. Input layer: colony_communes. 

4. The coordinate system of the layer will automatically be added.  

5. Save the output as: commune_wgs84.shp.  

Indicating the new coordinate system in the name is useful for 

layer organisation. 

6. Choose the output coordinate system. 

7. Click the Browse button. 

8. Expand the Geographic coordinate systems option. 

9. Click World. 

10. Select the WGS 1984 coordinate system. 

11. Select a transformation from the predefined list. In this case, 

the first is sufficient. 

12. Click OK. 

13. Click OK again. 

The resulting layer will possess the new projection and is 

automatically added to the map document (Fig. S 35). The green 

commune_wgs84 polygon layer is slightly shifted to the south 

compared to the blue colony_communes layer underneath. As 

another example of the differences in coordinate systems, Fig. 36 

shows an example from Switzerland between the WGS 1984 

coordinate system (a) and the CH1903 projection (b).  

 

6.5.9. Layer to KML and import to Google Earth 

A KML (Keyhole Markup Language) file is a geographic data layer 

which was developed for use with Google Earth. Using these steps, 

any layer (shapefile or raster) from GIS can be imported to Google 

Earth (conversely, the KML to Layer tool can be used to bring data 

from Google Earth into ArcGIS). This conversion is useful for sharing 

geographic information with people who do not use GIS. In previous 

ArcGIS versions, a shapefile needs to be saved first as a “layer” file 

before converting it to KML. To do that, the Save to Layer File tool 

can be used. A layer file is basically a pointer to the shapefile which 

stores specific symbolization properties. In version 10.1, the user is no 

longer required to save as a layer file before converting to a KML. 

Fig. 36. World Geodetic System (WGS 84, a) versus the Swiss projection (CH1903 LV03, b). Reproduced with permission of Swisstopo (BA13016). 
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To export a layer from ArcMap for import into Google Earth (Fig. S 37): 

1. Type “kml” in the Search window. 

2. Select the Layer to KML (Conversion) tool. 

3. Input layer: commune_wgs84. 

4. Output: GE_commune_wgs84.kmz. 

5. Leave the other options with their default values. 

6. Click OK. 

7. Open Google Earth (if not already installed, it can be 

downloaded from: http://www.google.com/earth/index.html) 

8. In Google Earth go to File. 

9. Click Open. 

10.  Select the GE_commune_wgs84.kmz layer. 

11.  Click OK. 

The layer created in ArcMap should now be displayed and 

correctly georeferenced in Google Earth (Fig. S 38). 
 

6.6. Basic raster tools 

Some of the previously mentioned vector data tools also exist specifically 

for rasters, for example, Clip and Project. However, most raster tools 

have different names and functionalities which are unrelated to vector 

analyses.  Below, we will briefly touch on some of the basic raster 

calculations that can be performed, specifically some of the most 

commonly used tools for terrain analysis and raster file management.  

  

6.6.1. Mosaic 

The Mosaic (Data Management) tool allows multiple raster layers to 

be combined with an existing raster dataset, while the Mosaic to New 

Raster (Data Management) tool allows multiple raster layers to be 

combined together to create a new raster dataset. The input raster 

images can vary in resolution and extent, but the defined output 

resolution may cause some input images to increase or decrease in 

resolution, sometimes leading to a loss in information. Also, the input 

rasters must have the same predefined coordinate system and the 

same number of bands.   

 

6.6.2. Surface Analysis 

The Surface Toolset in ArcGIS allows you to calculate and visualize 

different properties of the terrain from an input DEM (see section 

3.2.1.4.). The surface toolset is part of the Spatial Analyst toolbox in 

ArcGIS. In the following section we will perform calculations based on 

the same 30 m DEM introduced earlier. For the next sections, one of 

either Spatial or 3D Analyst extensions is required. To turn on 

extensions select Customize > Extensions from the main menu. If you 

do not own a license, you will get a message when you try to click an 

extension.  

 

6.6.2.1. Slope 

The Slope (Spatial Analyst or 3D Analyst) tool calculates the slope of 

the terrain, either in degrees or percentage rise.  
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To calculate the slope of the terrain (Fig. S 39): 

1. Turn on Spatial and 3D Analyst extensions, go to Customize 

(from the main menu). 

2. Select Extensions. 

3. Check the Spatial Analyst (and/or 3D Analyst) extension. 

4. Click Close. 

5. Type “slope” into the Search window (or browse to Spatial 

Analyst Tools > Surface > Slope in the ArcToolbox). 

6. Select the Slope (Spatial Analyst or 3D Analyst) tool. 

7. Choose the DEM as the input raster (aster30_frib_ch.tif). 

8. Save the output raster as “slope”. 

9. Choose the output measurement to be used, here we will use 

degrees. 

10. If the X, Y, and Z (altitude) coordinates are all in meters, 

leave the Z factor as 1. Otherwise click the Show Help button 

in the tool to read about how to convert the Z factor. 

11. Click OK. 

12. Turn off all other layers in the TOC, right-click Layer at the 

top of TOC. 

13. Select Turn all layers off. 

14. Turn on the new slope raster in the TOC. 

The results show the default classification scheme in degrees 

ranging from 0 to about 58 degrees in eight categories (Fig. S 40). 

Now the results will be classified in a different way by opening the 

layer properties (Fig. S 41). 

15. Right-click slope layer in the TOC. 

16. Select Properties. 

17. Select the Symbology tab. 

18. Choose the “stretched” option in the Show dialog box. 

19. Select a colour ramp.  

20. Choose the stretch type of Minimum-Maximum. 

21. Click OK. 

The results (Fig. S 42) show that the region is not so diverse in 

terms of slope. 

 

6.6.2.2. Aspect 

The Aspect (Spatial Analyst or 3D Analyst) tool calculates the direction 

in which slopes are facing. Values are given in degrees in regards to 

the degrees on a compass (with north as 0 and 360 degrees). 

To calculate the aspect of the terrain (Fig. S 43): 

1. Type “aspect” into the Search window (or browse to Spatial 

Analyst Tools > Surface > Aspect in the ArcToolbox). 

2. Select the Aspect (Spatial Analyst or 3D Analyst) tool. 

3. Choose the DEM as the input raster. 

4. Save the output raster as aspect. 

5. Click OK. 

In the TOC the results (Fig. S 44) can be seen in degrees. 
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6.6.2.3. Hillshade 

Shaded relief rasters (also called hillshade) are frequently used for 

visualization and cartographic purposes and are calculated from a 

DEM and predefined values for the azimuth (horizontal deviation from 

north, clockwise) and the solar elevation angle (vertical inclination 

between the sun and the horizon). The Hillshade (Spatial Analyst or 

3D Analyst) tool calculates the shaded relief of the terrain in ArcGIS. 

This tool is useful for determining which areas of the terrain are 

shaded and which are not, during certain hours of the day, month, or 

year.  

To calculate the hillshade of the terrain (Fig. S 45): 

1. Type “hillshade” into the Search window (or browse to Spatial 

Analyst Tools > Surface > Hillshade in the ArcToolbox). 

2. Select the Hillshade (Spatial Analyst or 3D Analyst) tool. 

3. Choose the DEM as the input raster. 

4. Save the output raster as aspect. 

5. Click OK. 

The results will be shown in a greyscale with values ranging from 

0 to 254 (Fig. S 46), where 0 is black, representing completely shaded 

areas, 254 is white, representing illuminated areas, and all values in 

between representing an increasingly lighter shade of grey, thus 

different levels of illumination from the sun.  

Hillshade rasters are good for visualizing terrain under different 

layers. To display the terrain properties under the DEM: 

1. Drag the hillshade layer to the bottom of the layer list in the 

TOC. 

2. Turn off all of layers except for the hillshade and the DEM. 

3. Open the properties of the DEM, right-click DEM layer. 

4. Select Display. 

5. Set the transparency to 50%. 

6. Go to the Symbology tab. 

7. Select a different colour ramp. 

8. Click OK. 

The resulting image (Fig. S 47) enables a more intuitive view of 

the terrain with high elevations in red, low elevations in green, and 

the ability to see shadows from the hillshade. 

 

6.6.2.4. Contour 

The Contour (Spatial or 3D Analyst) tool generates an output vector 

file containing elevation levels (contour lines) from an input raster (in 

most cases a DEM). Contour lines are frequently used in cartography 

as they can easily be combined with other raster images (like aerial 

photos or pixel maps). 

To generate contour lines from a DEM: 

1. Open the Search window. 

2. Type “contour” (or browse to Spatial Analyst Tools > Surface 

> Contour in the ArcToolbox). 

3. Use a DEM as the Input raster. 
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4. Choose a location to save the Output polyline features (vector 

format). 

5. Define the Contour interval which will be the distance 

between the contours (if you are using the Swiss projection 

this will be in meters). 

6. Set the optional Base contour value, if desired (contours will 

start after the base value). 

7. If using a different unit than meters, click the Z factor input box. 

a. Click Show Help to learn about Z factor conversions. 

8. Click OK. 

The new vector line file will be generated and added to the 

document. To achieve better results for visualisation, a smoothing 

algorithm could be performed on the line feature, e.g. with the tool 

Simplify or Smooth Line (Cartography Tools > Generalization > 

Simplify or Smooth Line from the ArcToolbox). 

 

6.6.3. Zonal statistics 

The Zonal statistics (Spatial Analyst) tool calculates the statistics on 

values of a raster within the zones of another dataset. For example, 

buffers could be used as input zones to calculate the statistics from 

any raster layer (DEM, slope, aspect, etc.) to determine the mean, 

majority, maximum, median, minimum, minority, range, standard 

deviation, sum, or variety of the raster pixels which are located within 

the buffer confines. The results are contained in a new raster layer 

and this should be conducted for each statistic required. To obtain 

multiple statistics at one time, the Zonal Statistics as Table (Spatial 

Analyst) tool can be used to generate the statistical results in table 

form for either all or selected statistic types. For an example of the 

use of the zonal tools, see the case study in section 6.9.7. 

 

6.6.4. Raster calculator 

The raster calculator is used for more advanced raster calculations, 

including raster math and building conditional and trigonometric 

expressions. It can be found using the search window or in the Spatial 

Analyst > Map Algebra toolset. For example, the formula 

“aster30_frib_ch.tif" * 3.28084” would convert the elevation data in 

the DEM from meters into feet by creating a new raster image. 

For more information search “raster calculator” in the help menu 

(http://resources.arcgis.com/en/help/main/10.1/). 

 

6.7. Format conversions 

ArcGIS provides a variety of different conversion functions between 

vector and raster data formats similar to other GIS software. As both 

of these formats have their advantages and disadvantages (see 

section 2.2.) in terms of data management, analysis, and display 

options, format conversions should be clearly linked to a precise 

purpose (e.g. when an elevation model is only available as raster 

data, but a map containing contour curves has to be created). There 
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are various tools available to switch between data formats. See the 

Conversion Tools toolbox to view all of the options. The most common 

conversions are between raster and vector formats. Conversion 

operations can lead to data loss or decreased precision – so apply 

these functions with care. 

 

6.7.1. Vector to raster 

This function rasterizes vector geometries (Fig. 2) into the band(s) of 

a raster image (Fig. 3). 

To convert to a raster from a vector: 

1. Expand the Conversion Tools in the ArcToolbox. 

2. Select To Raster. 

3. Depending on the type of vector data you want to convert, 

select either Point to Raster, Polygon to Raster, or Polyline to 

Raster. 

4. Indicate where the output will be saved. 

5. Click OK. 

 

6.7.2. Raster to vector 

To convert to a vector from a raster: 

1. Expand the Conversion Tools in the ArcToolbox. 

2. Select From Raster. 

3. Depending on the type of vector data you want to convert to, 

select eitherRaster to Point, Raster to Polygon, or Raster to 

Polyline. 

4. Indicate where the output will be saved. 

5. Click OK. 

 

6.8. Spatial Statistics 

The purpose of this section is to introduce the Spatial Statistics toolset 

in ArcGIS so that researchers are aware of its existence. Since most of 

the same tools can be found in other statistical packages, they will not 

be explained here in-depth, but their geographic links will be discussed. 

For more information on these tools see the overview in the ArcGIS 

online help menu by typing “An overview of the Spatial Statistics 

toolbox” into the search window. Additionally, see Lee and Wong 

(2001) or Wong and Lee (2005) for further tool descriptions. Be 

aware that these texts used previous versions of ArcGIS so the 

tutorials are not completely compatible. Unfortunately, these are the 

most updated versions available.  

 

6.8.1. Analysing patterns 

This toolset includes: Average Nearest Neighbour, High/Low Clustering 

(Getis-Ord General G), Incremental Spatial Autocorrelation, Multi-

Distance Spatial Cluster Analysis (Ripley’s K Function), and Spatial 

Autocorrelation (Morans I). These tools can be used for analysing 

spatial patterns based on features, or the values associated with features.  
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6.8.2. Mapping clusters 

Cluster and Outlier Analysis (Anselin Local Morans I), Grouping Analysis, 

and Hot Spot Analysis (Getis-Ord Gi*) are located in this toolbox and 

can be used to identify statistically significant hot spots, cold spots, 

and outliers.  

 

6.8.3. Measuring geographic distributions 

These tools enable the researcher to ask spatially defined questions 

about their data by using the Central Feature, Directional Distribution 

(Standard Deviational Ellipse), Linear Directional Mean, Mean Center, 

Median Center, and Standard Distance tools.  

 

6.8.4. Modelling spatial relationships 

This toolset can be used to conduct regression analyses or creating 

spatial weights matrices. The tools include Exploratory Regression, 

Generate Network Spatial Weights, Generate Spatial Weights Matrix, 

Geographically Weighted Regression, and Ordinary Least Squares.   

 

6.9. Case study – zonal statistics with land cover 

properties 

Until now, several concepts and tools in ArcGIS have been introduced. 

Now, to combine some of the different tasks discussed, a case study 

will be presented. Within this short case study, geostatistical 

relationships between honey bee colonies and land cover properties 

will be calculated. The content of this case study is equal to the one 

for QGIS (see section 7.9.), but adapted to the tools of ArcGIS. The 

prerequisite for this case study is an ArcMap document (see section 

6.3.) with a point vector layer (e.g. the honey bee colony locations 

colony_locations.shp, created in section 6.3.3.1.) and a buffer polygon 

layer (e.g. buffer.shp, created in section 6.5.5.1.). In this case study, 

the percentages of land cover types within 2 km radii of honey bee 

colony locations will be calculated. This will allow the user to obtain 

information about forage availability near colony locations.  First,  you 

will go through the process of downloading the Corine (which means 

“coordination of information on the environment”) Land Cover 2006 

(CLC06) dataset from an online source. The CLC06 layer is a free 100 m 

resolution raster representing 50 different land cover classifications 

for the continent of Europe including, agricultural areas, forests, 

wetlands, and water bodies (for more information see http://

sia.eionet.europa.eu/CLC2006). This layer will then be projected to 

the Swiss coordinate system and clipped to the study region around 

Fribourg, Switzerland in order to make analysis and map rendering 

more time efficient. You will then learn how to assign land cover 

codes and a predefined colour scheme to the CLC06 layer and how to 

optimise the layer for the study region. After, raster calculator will be 

used to calculate conditional rasters which will be used as the basis of 

the statistical analysis for determining land cover types within the 2 

km radii surrounding each honey bee colony location.   
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6.9.1. Downloading data and changing projection 

First, land cover data for the region surrounding Fribourg will be 

downloaded and extracted.  

1. Download the dataset g100_06.zip (CLC06 – 100 m) from the 

website http://www.eea.europa.eu/data-and-maps/data/

corine-land-cover-2006-raster-2  to a local directory (e.g. on 

the Desktop).  

2. Unzip the file g100_06.zip with a file archiving program of 

your choice (if you need additional software for this task, the 

program “7-zip” is a good choice: www.7-zip.org) into your 

ArcGIS working directory (e.g. the GISBEEBOOK folder). Note: 

data in zipped folders cannot be seen in ArcGIS applications 

so you must first unzip. 

3. Open ArcCatalog. 

4. Navigate to folder containing the land cover raster g100_06.tif 

and select the Preview tab to get a visual impression of the 

data. As you can see, the data layer covers all of Europe. 

5. Now open the Properties of the raster layer by double-clicking 

the layer name. 

From the General  tab in the layer properties, you see that CLC06 

is a 1 band raster dataset with 8 bit unsigned integer values (that 

correspond to different land cover categories) at 100 m horizontal 

resolution. Because it covers all Europe, the CLC06 raster is quite 

large and the rendering on the screen may take some time. We will 

improve the performance by clipping to the extent of interest. The 

coordinate system is different (ETRS89_ETRS_LAEA) than the one 

used in Switzerland therefore it is best to project it into the same 

coordinate reference system as the other layers (CH1903 LV03).  

6. Now, add the CLC06 layer into a new blank *.mxd by 

dragging the layer from ArcCatalog into ArcMap directly, or 

using the Add Data button in ArcMap. 

7. To reproject the raster to the Swiss coordinate system, open 

the Project Raster (Data Management) tool (browse to Data 

Management Tools > Projections and Transformations > 

Raster > Project Raster). 

8. Select g100_06.tif as the Input Raster. The Input Coordinate 

System will already be filled in.  

9. Save the Output Raster Dataset to your working folder as 

g100_06_ch1903.tif. 

10. Choose CH1903 LV03 as the Output Coordinate System 

(Projected Coordinate Systems > National Grids > Europe > 

CH1903 LV03). 

11. Choose the NEAREST Resampling Technique.  

12. Leave the default Output Cell Size (100 m) (Fig. S 48). 

13. Click OK. 

14. Click OK again to run the tool.  

Be patient, this is a large file and it will take some time to 

complete (~ 10 minutes but depends on your processing system). 

You will get a pop-up at the bottom right-hand side of your screen 

when the process has finished. 
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The resulting projected raster (g100_06_ch1903.tif) will be 

automatically added to the *.mxd. The original CLC06 layer can now 

be removed from the document as it is no longer needed: 

15. Right-click the g100_06.tif layer in the TOC. 

16. Select remove. 

 

6.9.2. Adding vector layer and changing document properties 

Since the CLC06 layer covers all of Europe, it should first be clipped to 

the extent of the required study area using the Clip (Data 

Management) tool so that map rendering is less time consuming in 

the next steps. This process can also be conducted using the Extract 

by Rectangle (Spatial Analyst) tool. We will use the 

commune_boundary_FR.shp to define the output extent of the clipped 

land cover raster layer so add the layer to the map now. Note: 

because the first map layer which was added to the document 

(g100_06.tif) was in the ETRS89_ETRS_LAEA coordinate system, the 

*.mxd properties automatically take on the properties of that 

coordinate system. For that reason, you will get a pop-up warning 

when you try to add layers from the Swiss coordinate system. The 

warning will state that there may be a problem because a layer with a 

different coordinate system is being added. Close the warning and 

change the document properties: 

17. Go to menuView. 

18. Select Data Frame Properties. 

19. Open the Coordinate System tab. 

20. Manually change the coordinate system to CH1903 LV03 

(same path as step 10). 

21. Click OK. 

22. Save the *.mxd to keep these changes (File > Save As…). 

Now the map document coordinate system corresponds to the 

data being used in the Swiss projection. Next we will clip to the extent 

of the study area. 

 

6.9.3. Clipping to study area extent 

23. Open the Clip (Data Management) tool (Data Management 

Tools > Raster > Raster Processing > Clip). 

24. Input Raster: g100_06_ch1903.tif. 

25. Output Extent: commune_boundary_FR.shp. The X and Y 

maximums and minimums will be automatically populated 

based on the output extent layer. 

26. Check the Use Input Features for Clipping Geometry option. 

27. Save the Output Raster Dataset as g100_06_ch_FR.tif. 

28. Change the NoData Value to 9999 (Fig. S 49). 

29. Click OK. 

30. Turn off the g100_06_ch1903.tif  and 

commune_boundary_FR.shp layers (uncheck in TOC). 

31. Right-click the g100_06_ch_FR.tif layer. 

32. Select Zoom to layer to view the result (Fig. S 50). 
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6.9.4. Applying a colour map 

The layer g100_06_ch_FR.tif is now an efficient size for our analysis, 

but we still do not know what the numbers (raster values) in the 

raster represent (see Fig. S 50). This is due to the fact that the 

attribute table of the g100_06.tif layer does not include the official 

CLC06 land cover codes because of a purely technical reason: the 

codes (50 in total) range from 111 to 999 and cannot be displayed in 

a single band 8-bit integer raster dataset because the range of values 

is limited to 0-255. Of course a 32-bit floating-point raster image 

could be used to display the whole range of values from 111 to 999. 

However, this would almost quadruple the size of the dataset which 

would cause problems for download, storage, and analysis. For this 

reason, the European Environment Agency (EEA) provides a layer file 

along with the raster image to indicate the code and colour map 

information which can be easily integrated into ArcGIS. 

To add the code and colour map information: 

33. Browse to the unzipped land cover folder (g100_06.tif). 

34. Add the clc_colortable_92.lyr file to ArcMap (section 6.3.3.). 

35. In the TOC, you should now see a layer called: 

lceugr250_00_pct.tif (which corresponds to the 

clc_colortable_92.lyr file) with a red exclamation point (!) 

beside it. That means that the layer does not know where the 

data are located. The codes (e.g. 111, 112, etc.) in this file 

represent the land covers type from the CLC06 dataset.  

36. Right-click the lceugr250_00_pct.tif layer. 

37. Click Data. 

38. Now click Repair Data Source to tell the layer where the data 

are located. 

39. Browse to the g100_06_ch_FR.tif layer. 

40. Click Add. The red exclamation point beside 

lceugr250_00_pct.tif  should have disappeared.  

 

6.9.5. Selecting and labelling land cover values 

Now we will remove the land cover values which are not within our 

study area in order to further optimise the data to fit our needs. 

41. Open the properties of the lceugr250_00_pct.tif layer. 

42. Open the Symbology tab. 

43. Manually select and remove all values which have a “0” Count 

value (use the Ctrl button on the keyboard to select more 

than one at a time) (Fig. S 51). 

44. Click OK. This leaves 14 values in that layer. 

Now open the excel file from the previously unzipped folder 

(clc_legend.xlsx) so the land cover names can be added as labels to 

the codes. This step is not completely necessary but it adds another 

element to the data. For each code, find the corresponding name 

(“Label 3”) and add it to the TOC by slowly right-clicking the code and 

pasting the name beside (Fig. S 52). In the following tasks we will 

make use of the code numbers and names which were just added  

manually as labels. 
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6.9.6. Conditional expressions using the raster calculator 

To statistically analyse the area covered by three land cover types of 

interest (arable land, coniferous, and mixed forest) within the 2 km 

buffers (created in section 6.5.5.1.), we will first create three new 

raster layers using raster calculator.  

45. Open the Raster calculator (Spatial Analyst Tools > Map 

Algebra > Raster calculator). 

46. Combine Layers and Variables and functions until the Raster 

calculator expression equals “Con("g100_06_ch_FR.tif"   ==  

12, 1, 0)” (Fig. S 53) (12 is the raster value for “Non-irrigated 

arable land” in the CLC06 dataset). The expression is a 

conditional statement (Con) which literally means: if the value 

of a pixel from the g100_06_ch_FR.tif layer equals 12, assign 

that pixel a new value of 1. If not, assign a value of 0. This 

will create a binary raster. 

47. Specify an output raster, e.g. lc_class211.tif, which denotes 

that the new layer will represent the 211 (Non-irrigated arable 

land) land cover code.  

48. Click OK. 

49. Repeat steps 45 to 48 with the following raster values: 24 

(replaces 12 in the equation in step 46.) (class 312 as the 

output, Coniferous forest) and 25 (class 313, Mixed forest).  

The newly created raster images contain zones with the value 1 

(where the Raster calculator expression was true, i.e. the land cover 

represents the non-irrigated arable land category) and 0, where the 

expression was false (i.e. the land cover does not represent the non-

irrigated arable land category).  

 

6.9.7. Zonal statistics of land cover values within buffers  

With this binary classification, we can now do a simple statistical 

analysis of the land cover within each buffer polygon layer. Below, the 

Zonal Statistics as Table tool will be used to summarise the values of 

the land cover layer within the buffers created in section 6.5.5.1. and 

output the results into a table. Specifically, we will calculate the mean 

percentages of non-irrigated arable land, coniferous forest, and mixed 

forest within a 2 km radius of the honey bee colony locations.  

50. Open the Zonal Statistics as Table Tool (Spatial Analyst Tools 

> Zonal > Zonal Statistics as Table).  

51. Input raster or feature zone data: buffer2000.shp (browse to 

or add to *.mxd). 

52. Zone field: FID (Unique identifier). 

53. Input value raster: one of the newly created binary raster 

images (e.g. lc_class211.tif).  

54. Output table: stats211. 

55. Check the Ignore NoData in calculations option. 

56. Choose the Statistics type MEAN (Fig.54). 

57. Click OK. 

58. Open the Results window (Geoprocessing > Results) and 

double click the Zonal Statistics as Table option (since that 

was the last process completed).  
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72. Open the Table Options for the colony_locations layer. 

73. Click Add Field.  

74. Name: LC_other. 

75. Choose the Type Float. 

76. Use the field calculator to populate this column. Right-click on 

LC_other field name.  

77. Select Field calculator. Fill out the dialog box according to Fig. 

S 57 with the equation: 1 - ([stats211:MEAN] + 

[stats312:MEAN] + [stats313:MEAN]) which calculates the 

percentage of “other” land cover types in relation to the three 

we have already used.   

78. You will end up with a table similar to the one in Fig. S 58. 

We will use these four new fields later in the Map creation 

section (6.10.). 

Note: as you can see in Fig. S 58, there are “<NULL>” values for 

FID 16. This seems to be a glitch in the Zonal Statistics as Table tool. 

There are ways this can be fixed in the table but we will not deal with 

them now. 

 

6.9.10. Visualisation of attributes using graphs and charts 

To visualise the statistical data another way, graphs and charts can 

also be created in ArcMap. To create a graph similar to that in Fig. S 59., 

go to View > Graphs > Create Graph. Use the mean values for 211, 

312, 313, and LC_other. In the next section, a final map will be created 

showing the case study results.  

 

6.10. Map creation 

Map creation is one of the main functionalities in ArcMap. Here we will 

give a brief tutorial about how to create a map as the final product of 

the GIS analysis. This task assumes that all layers created in the 

previous steps are already in the map document (including the results 

of the case study). 

  

6.10.1. Data view vs. layout view  

In ArcMap there are two different views: one for viewing, manipulating, 

and analysing data (Data View, Fig. S 60), and one for creating the 

final map product (Layout View, Fig. S 61). To switch between the 

two, toggle the buttons at the bottom left hand corner of the data 

frame (map display, see Fig. S 60).The toolbars used in each of these 

views can be confusing as there are multiple tools for zooming. The 

Tools toolbar is used for zooming in and out of the data frame, thus 

the actual data, and the Layout tools toolbar is used to zoom in and 

out on the final map document. See Figs. S 60 and S 61 to help 

understand the differences between these two views and also the 

different toolbars.  

 

6.10.2. Symbology  

The layer symbology can be changed within the properties of each 

layer under the Symbology tab. Depending on the type of data you 

want to symbolize, there are various options. For example, layers can 

59. Repeat steps 50 to 57 for the other input rasters by altering 

the input dialog for the classes 312 and 313 (choosing 

appropriate filenames for the results). 

Now look at the table results in the TOC (Fig. S 55). If you cannot 

see the tables in the TOC, make sure you are in List by Source view 

instead of List by Drawing Order (section 6.3.4.). In each table you 

will see columns for Rowid, FID (unique identifier corresponding to 

buffer ID), COUNT (number of pixels of particular land cover class 

inside the buffers), AREA (calculation of square meters of land cover 

class within the buffers), and MEAN (in percentage). In Fig. S 55, the 

mean values directly correspond to the percentage of non-irrigated 

arable land within each buffer (uniquely identified by its FID value).  

 

6.9.8. Joining statistical information to attribute table 

Now we will do a table join to connect the calculated statistical 

information directly to the colony_locations.shp shapefile based on the 

unique identifier in both the statistics table and the attribute table of 

the colony locations layer. By doing this, statistical information will be 

directly linked to the colony locations attribute table. This allows for 

the symbolisation and visualisation of statistical information on the 

map based on the geographic location of the colonies. For example, in 

section 6.10.4. we will symbolize each colony based on its statistical 

properties.    

60. Right-click on the colony locations layer in the TOC. 

61. Select Joins and Relates.  

62. Click Join.  

63. Select the option to Join attributes from a table (Fig. S 56). 

64. Choose the FID as the fields on which to base the join with 

the stats211 table. 

65. Keep all records. 

66. Click OK. 

67. Open the Attribute table for buffer2000.shp and scroll over to 

the right. You will see the values from the stats211 table have 

been added to the end. Since we are only interested in the 

MEAN, turn off the other fields (right-click column name > 

Turn field off). For table organisation purposes, other fields 

can also be turned off (this is not permanent – to undo go to 

Table Options (top left corner of table) and Turn all fields on). 

68. To distinguish this MEAN column (211) from the other 2 other 

mean value columns (312 and 313), which we will add in the 

next steps, let’s rename the column (Right-click column name 

> properties). 

69. In the Alias field, change the name to “211MEAN”. 

70. Click OK. 

71. Repeat 60-70 for the 312 and 313 statistics tables.  

 

6.9.9. Adding and populating a new field in attribute table 

Now, to obtain a value for all of the other land cover classes besides 

211, 312, and 313, we will create a new column in the table  and then 

calculate the values of “other” land cover values inside each buffer.  
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be symbolized based on one set of features (Features), categories of 

attributes based on unique values or unique values using many fields 

(Categories), or quantities of attributes (Quantities). As an example, 

we will use the commune_boundary_FR layer and change the 

symbology so that each commune is represented by a different 

colour.  

To change symbology to represent unique features: 

1. Right-click commune_boundary_FR layer. 

2. Select Properties. 

3. Select Symbology. 

4. Select Categories. 

5. Select Unique values.  

6. For the Value Field choose the attribute to be symbolized. In 

this case it is GEMNAME.  

7. Click the Add All Values button. 

8. Click OK. 

The results show each commune represented by a different colour 

(Fig. S 62). 

 

6.10.3. Labels 

Labels can be automatically added for any layer. 

To add labels to a layer: 

1. Right-click the commune_boundary_FR layer. 

2. Click the Labels tab. 

3. Check the Label features in this layer option. 

4. Label field: GEMNAME. 

5. Click OK. 

Now the name of each commune can be seen (Fig. S 63). 

6. To make the label larger or change the font Properties > 

Labels. 

 

6.10.4. Advanced symbolization 

In this step, the statistical results of the case study will be symbolized 

using pie charts.  

1. To begin, open the layer properties of colony_locations.shp. 

2. Open the Symbology tab. 

3. Choose Charts and make sure Pie is selected. 

4. Add the MEAN attributes (including LC_other) to the Symbol/

Field box. Change the colours to correspond with the original 

land cover values (Fig. S 64). 

5. Click OK.  

6. Now label the colony locations to denote the FID identifier 

number (see above).  

The map should now look something like Fig. S 65, which is the 

data in Data View. Maybe you will notice that FID 16 is missing. 

Because of the error we encountered earlier, it did not get symbolized 

or labelled.  
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6.10.5. Final map preparation  

Now we will put the finishing touches on the map in Layout View. For 

the final map the pie charts and communes will be displayed with the 

background of the DEM and the hillshade for terrain visualization.  

To finalize the map: 

1. Turn on the commune_boundary_FR, colony_locations 

(symbolized as pie charts), hillshade, and DEM layers in the 

TOC. 

2. Go into Layout View (bottom left hand corner of the map 

window). 

3. The page size is automatically set to normal printing page 

size. To change the page size, go to File. 

4. Select Page and Print Set-up. 

5. Uncheck Use Printer Paper Settings. 

6. Insert your own values for the width and height of the page 

(22 x 24 cm were used here).  

7. Click OK. 

8. Rescale the data frame (dotted green line) to fit inside the 

page border (solid black). Leave some white space between 

the data frame and the page border to insert a grid later. 

9. Right-click the colony locations layer. 

10. Select Zoom to layer to focus the map on this layer. 

Remember to use the standard tools to zoom in and out on the 

data, and the layout tools to zoom in and out on the page. 

11. Play around with the transparency values of the layers to 

make a nice end product. Go to Properties. 

12. Select the Display tab. 

13. Insert a value between 0 (no transparency) and 100 

(completely transparent).  

 

6.10.6. North arrow, scale bar, legend, title, text 

To add a north arrow: 

1. From Layout view, click Insert (main menu). 

2. Click North arrow. 

3. Select the style of the north arrow.  

4. Click OK. 

To add a scale bar: 

1. Click Insert. 

2. Select Scale bar. 

3. Choose the style. 

4. Click Properties. 

5. Select the number of divisions and units. 

6. Click OK. 

7. Click OK again. 

8. Double-click Scale to change the properties. 

To add a legend: 

1. Click Insert. 
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2. Select Legend. 

3. Choose the layers to add to the legend. 

4. Click Next. 

5. Choose the legend title. 

6. Click Next. 

7. Choose a border, background, or shadow. 

8. Click Next. 

9. Click Next again. 

10. Click Finish.  

To add a title or other text: 

1. Click Insert. 

2. Click Text. 

3. Type the text. 

4. Hit Enter. 

5. Double-click on the text box to open the properties. 

6. Change the size and font. 

7. Click OK. 

Once added to the map, you can double-click on any feature in 

the layout view to open its properties. Also, the scale bar and legend 

are linked directly to the map, therefore they change as the map 

changes. For example, the scale bar will adjust to the scale of the 

map, and the legend items will adjust if the symbologies or names of 

layers change in the TOC. To adjust these features manually they 

must first be converted into graphics and ungrouped.  

To manually change the legend: 

1. Right-click the legend. 

2. Select Convert to graphics (this unlinks the feature from the 

map). 

3.  Right-click the legend again. 

4. Select Ungroup to have the ability to select individual features 

and edit them (some features required a second “ungrouping” 

to be editable, e.g. the symbols and labels). 

5. Select the item to edit.  

Note: once the item has been converted to graphics, there is no 

going back (you would have to insert the item again from scratch) 

and, the item is no longer dynamically linked to the map contents. 

Therefore changing layers and map scales will no longer change 

legend items or scales. It is recommended that conversion to graphics 

is the final step in the map creation process. 

 

6.10.7. Drawing toolbar 

The Drawing toolbar is useful for adding graphics such as shapes, 

text, and lines to the map.  

To open the toolbar: 

1. Go to Customize. 

2. Select Toolbars. 

3. Select Draw. 
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6.10.8. Adding a grid 

To add a numbered grid around the map: 

1. Go to View (main menu). 

2. Select Data Frame Properties. 

3. Select Grids. 

4. Select New Grid. 

5. Select the Measured Grid option (this is for projected 

coordinate systems (meters)), Graticule is for Geographic 

coordinate systems (latitude/longitude)). 

6. Choose the Labels only option.  

7. Click Next. 

8. Here you could change the axes and labels, click Next. 

9. Click Finish.  

10. Click OK.  

To adjust the properties of the grid, go back into the View > Data 

Frame Properties > Grids menu. Here, there is also the option to 

convert the grid to graphics in order to manually adjust it. See Fig. S 

66 for the final map in ArcMap. 

 

6.10.9. Exporting a map 

To export the final map product: 

1. Go to File. 

2. Select Export Map. 

3. Name it and choose the format (JPEG, PDF, etc.). 

4. Choose the resolution (high quality resolution is 300 dpi (dots 

per inch) and draft quality is normally 96 dpi; also line art 

(contour lines, labels, ...) should be at 600 dpi and raster 

graphics at 300.). 

5. Click Save. 

6. Browse to the exported map. 

7. Open it to view the results and see if any changes are needed 

(see Fig. 67 to view the exported map). 

 

6.10.10. Cloud mapping and ArcGIS Explorer 

Recently, ArcGIS has created a cloud mapping platform online which 

allows users to share their maps and data with others, access their 

maps online, on their desktop, and on mobile devices through the use 

of the cloud. On ArcGIS online, users can create maps by adding their 

own data, choose from different base layers, and use other people’s 

shared data that has been uploaded to the site. This site is useful for 

map creation when you do not have access to the ArcGIS software, 

but want to make a basic map. All you need is an ESRI Global Account 

which is free to sign up for. For more information about ArcGIS online 

visit https://www.arcgis.com/home/. 

 ArcGIS Explorer is an application that can be downloaded for 

the purposes of exploring, visualising, and sharing geographic 

information. Users can also access ArcGIS’ basemaps and layers,  
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customise maps by adding data, photos, reports, and videos. Basic 

spatial analyses can also be performed. ArcGIS Explorer can be 

downloaded from http://www.esri.com/software/arcgis/explorer.   
 

 

7. Using Quantum GIS (version 

1.8.0.) 

This section provides a brief hands-on tutorial as an introduction to 

Quantum GIS (QGIS) and shows examples of how open source GIS 

can be used instead of proprietary software for the same research 

applications as demonstrated in the previous chapter. QGIS is licensed 

under the GNU General Public License (http://www.gnu.org) and is an 

official project of the Open Source Geospatial Foundation  

(http://www.osgeo.org). This tutorial is based on QGIS version 1.8.0. 

“Lisboa” that was the latest stable release at the end of 2012 and 

runs on the 64-bit Microsoft Windows 7 operating system. Detailed 

information about QGIS, its functionalities, and the installation 

procedure on different platforms is well documented on the project 
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website (http://www.qgis.org) and in the manual to version 1.8.0 

(QGIS Development Team, 2013).   

 

7.1. Main components of QGIS 

QGIS includes the main program QGIS Desktop, QGIS Browser for 

data management, and a variety of optional plugins that provide 

specific functionalities.  

 

7.1.1. QGIS Desktop 

QGIS Desktop is the main interface for data collection, analysis, and 

presentation on the client-side and is similar to ArcMap (see section 

6.1.1.). The language of the GUI is chosen automatically by the system 

defaults, but it can be changed within the menu Settings > Options > 

Locale. Most of the menus and symbols (Fig. S 68) are self-evident 

and should be easy to use for anyone with basic knowledge in GIS 

techniques, but in particular the menu “Plugins” is different than other 

software and will be discussed more in detail (see 7.1.3.). Projects 

(equivalent to map documents within ArcGIS, see section 6.3.1.) saved 

within QGIS are stored using the XML-Standard (Extensible Markup 

Language, machine and human-readable) and with the extension *.qgs.  

Fig. 67. The final map exported as a JPEG file. Reproduced with permission of Swisstopo (BA13016). 
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7.1.2. QGIS Browser 

Starting in version 1.7., a new feature has been added to QGIS: The 

QGIS Browser (Fig. S 69). This browser is a data management 

program similar to ArcCatalog (see section 6.1.2.), simplifies file 

navigation within the file system, and provides preview options for 

various file types. Items can be easily added to the Map View of QGIS 

Desktop by drag and drop.  

 

7.1.3. Plugins 

In addition to its core functionalities, QGIS can be extended modularly 

with additional features and functionalities, downloadable from so-

called repositories through the internet. By the end of 2012, about 

175 plugins were listed on the project website provided by various 

authors (http://plugins.qgis.org/plugins). Because the application is 

open source, everyone is authorized to change or add features for 

special purposes by programming in the languages C++ or Python. 

Often, popular external plugins that have a big impact on the user 

community are implemented into the core functionalities of QGIS in 

the following release.  

Plugins can be loaded and unloaded from the main menu Plugins 

> Fetch Python Plugins (Fig. S 70) from various internet repositories 

directly into the QGIS Desktop. Some of the plugins might require 

additional software packages or libraries, or are still marked as 

“experimental”, indicating an early stage of development.  

Within this tutorial the plugins listed in Table 4 will be used, so it 

is recommended to install them now:  

1. Open QGIS, go to the Start Menu. 

2. Go to All Programs. 

3. Open the Quantum GIS Lisboa folder. 

4. Select Quantum GIS Desktop 1.8.0. 

5. From the main menu go to Plugins. 

6. Select Fetch Python Plugins. 
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7. Open the Repositories tab. 

8. Click Add… and type in the name and URL for the “Faunalia 

Repository” corresponding to Table 4.  

9. Click the checkbox to enable the repository. 

10. Click OK.  

11. Verify if the “Faunalia Repository” is listed and if the 

connection works correctly (indicated with a green icon).  

12. Repeat steps 8 to 11 also for the Repository called QGIS 

“Contributed Repository” (see Table 4). 

13. Switch to the tab Options. 

14. Activate the checkbox Check for updates on startup. 

15. Set the allowed plugins to Show all plugins, even those marked 

as experimental. 

16. Switch back to the tab Plugins within the QGIS Python Plugin 

Installer. 

17. Filter for a plugin name (e.g. “GdalTools”) and select it in the 

list. 

18. Click Install/upgrade plugin.  

19. Repeat the steps 17 and 18 for all these Plugin names: 

“GdalTools”, “qgSurf” and “Chart Maker”. 

20. Close the QGIS Python Plugin Installer. 

To remain focused on the most important functionalities for your 

daily work, it is recommended to make use of the Plugin Manager 

(Fig. S 71): 

1. Open Plugins. 

2. Select Manage Plugins.  

3. Click Select All. 

4. Click OK. 

For more detailed information about managing and troubleshooting 

QGIS plugins on different platforms, see the QGIS user guide (QGIS 

Development Team, 2013). 

 

Plugin name Repository 
Add Delimited Text Layer 
(see section 7.3.3.1.) 

Core plugin, automatically installed with QGIS 
(can be enabled and disabled in the Plugin Manager) 

fTools 
(see section 7.6.) 

Core plugin, automatically installed with QGIS 
(can be enabled and disabled in the Plugin Manager) 

Spatial Query 
(see section 7.4.1.) 

Core plugin, automatically installed with QGIS 
(can be enabled and disabled in the Plugin Manager) 

Raster Terrain Analysis Plugin 
(see section 7.7.2.) 

Core plugin, automatically installed with QGIS 
(can be enabled and disabled in the Plugin Manager) 

GDAL Tools 
(see section 7.5. and 7.7.) 

Faunalia Repository (http://www.faunalia.it/qgis/plugins.xml) 

qgSurf 
(see section 7.8.3.) 

QGIS Official Repository (http://plugins.qgis.org/plugins/plugins.xml) 

Chart Maker Plugin  
(see section 7.9.) 

QGIS Contributed Repository 
(http://pyqgis.org/repo/contributed) 

SEXTANTE 
(se section 7.8.2.) 

QGIS Official Repository (http://plugins.qgis.org/plugins/plugins.xml) 

QGIS Cloud Plugin 
(see section 7.9.5.) 

QGIS Official Repository (http://plugins.qgis.org/plugins/plugins.xml) 

XyTools 
(see section 7.3.3.1.) 

QGIS Official Repository (http://plugins.qgis.org/plugins/plugins.xml) 

Table 4. QGIS Plugins and Repositories list used or mentioned in this tutorial. 
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7.2. Navigating the software 

One motivation for the development of QGIS was to provide a user 

friendly GIS software with a simple and straightforward graphical user 

interface (GUI, QGIS Development Team, 2013). This was also one 

major motivation for why we chose QGIS as the representative for 

open source GIS within this tutorial. 

 

7.2.1. Help menu and tooltips 

The Help menu is placed at the right of the main menu bar in QGIS 

Desktop (Fig. S 68) or can be opened with the shortcut F1 (on Windows). 

The majority of the functions and tools are well documented in the 

user guide (QGIS Development Team, 2013) and additional information 

is accessible at the QGIS project website (http://www.qgis.org). 

Useful information is provided by the tooltips (that usually appear 

when the mouse cursor is placed over an icon for a few seconds) 

indicating the name or functionality of the buttons and plugins. In 

addition, several functions and plugins have their own help button like 

the example in Fig. S 70. Thanks to a huge effort from the community, 

the GUI and large parts of the help menu have already been translated 

into many different languages. 

 

7.2.2. User guide and documentation 

All documentation for QGIS can be found on the project website 

http://www.qgis.org, divided into the two categories “Manuals”   

(containing user guides and tutorials) and “Developer” (providing 

programming help for developers). The official manual, the QGIS user 

guide (QGIS Development Team, 2013) cited in this tutorial, was 

released on the 15th of January 2013 and might have changed since 

then.   

 

7.3. Adding data and working with different file 

formats 

Adding geodata to QGIS Desktop is as easy as with ArcMap (see 

section 6.3.): a variety of file formats can simply be dragged and 

dropped, for example, from a folder within the file system directly into 

the Map Legend panel on the left of QGIS Desktop or loaded from the 

Manage Layers toolbar. The following hints and remarks will provide a 

start-up aid for users new to GIS and for some specific data types.  

 

7.3.1. Setting a coordinate system and saving the new QGIS 

project (*.qgs)  

Similar to the ArcGIS section (6.3.1.), it is important and 

recommended to first set the coordinate system according to the data 

used for the analysis or the target projection of the final map product, 

respectively (Fig. S 72): 

1. Go to Settings. 

2. Select Project Properties. 

30  Rogers, Staub 

3. Select Coordinate Reference Systems (CRS). 

4. Activate the checkbox on top called Enable “on-the-fly” CRS 

transformation. 

5. Select the projection called CH1903 / LV03 with the EPSG-

code 21781 within the list of the Coordinate reference 

systems of the world (Group Swiss. Obl. Mercator, see Fig. S 

72) with a double-click. 

6. Click OK to apply these settings and close the Project 

Properties dialog. 

7. Verify by checking if the EPSG-code 21781 is written in the 

Status Bar (see Fig. S 68). 

Note: This step is very important for the rest of this tutorial, 

because choosing the wrong CRS may lead to various problems in 

geoprocessing. 

Advanced users who deal with a variety of different projections 

might appreciate the possibility to filter the list of all coordinate 

systems (Fig. S 72) by names or the identification number of the 

EPSG Geodetic Parameter Dataset (http://www.epsg-registry.org). 

Switching back to the General tab of the Project Properties, the Layer 

units will be now set to meters, because the Swiss oblique Mercator 

projection uses metric units.  

8. Save the new project and settings, go to File. 

9. Select Save Project As, or click the button       to the desired 

destination folder (A QGIS project file with the extension *.qgs 

will then be created). 

10. It can be reopened directly by a double-click on the file or 

within the QGIS main menu File > Open Project or the open 

project button       from the File toolbar.  

 

7.3.2. Add data to the project 

Most of the functions to add and remove data or to change layer 

properties and appearance can be accessed through the main menu 

Layer. Of particular interest are the functions (listed in Table 5) 

contained in the Manage Layers toolbar:  

Only data of the appropriate type (see sections 2.2.1. and 2.2.2.) 

will be selectable as a source for adding vector or raster data, 

respectively. In case the data type or the file extension is unknown, 

try to drag and drop the files directly from the source folder into the 

Map Legend in QGIS Desktop (Fig. S 68). Take into consideration that 

some common file formats consist of multiple files and that the main 

file has to be chosen (e.g. the file with the extension *.shp for a 

shapefile or the *.tif for a raster in GeoTIFF format, respectively, see 

also section 3.1.). Due to the Geospatial Data Abstraction Library for 

raster data translation GDAL (http://www.gdal.org) and the OGR 

Simple Feature Library (http://www.gdal.org/ogr) QGIS has excellent 

data interoperability capabilities and almost every geodata file format 

from any source can be loaded into the Map View.  
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7.3.3. Importing vector and raster data 

Now it is time to add some data to the new empty QGIS project:  

1. Choose Layers. 

2. Select Add Vector Layer. 

3. Browse to the source folder of your Geodata (for example 

select commune_boundary_FR.shp, see section 5.3.). 

4. Press Open to load the shapefile.  

As an intermediate result, a rectangle full of polygons (see section 

2.2.1.) representing different administrative districts, called communes, 

within the canton of Fribourg (western Switzerland) appears (Fig. S 73).  

In the same way, but with the Add Raster Layer function, a DEM 

(see section 3.2.4.) can be added to the map:  

1. Open Layers. 

2. Select Add Raster Layer.  

3. Browse to the source folder of your Geodata (for example 

select ASTER30_WGS84.tif).  

4. Click Open to load the DEM into QGIS.  

A rectangular greyscale raster image appears around the city of 

Fribourg in western Switzerland (Fig. S 73). If the raster is not visible, 

please check that the “on-the-fly” CRS transformation is enabled 

within the dialog accessible through the menu Settings > Project 

Properties > Coordinate Reference Systems (CRS) (see also Fig. S 72).  

If the raster image is displayed in a uniform grey, the display 

options must be adapted: 

5. Open Layer. 

6. Click Properties. 

7. Select the Style tab. 

8. Click Load in the Load min/max values from band option. 

9. In the Contrast enhancement option, choose Stretch to 

MinMax. The raster values range from 407 (black) to 883 

(white), that represents the altitude above sea level in meters.  

10. Click OK. 
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The new data will be added to the top of the map, thus probably 

hiding some other content behind it (the display order is defined by 

the hierarchy in the Map Legend). Considering the current map 

display, we see that the raster image has a smaller extent than the 

vector layer and only few a details are visible at this scale. To zoom to 

the region of interest around Fribourg, suitable operations are:  

 Using the Zoom and Pan icons in the Map Navigation toolbar 

or the same functions in the menu View  

 

 

 Right-click on the raster image in the Map Legend (in our 

example called ASTER30_WGS84) and choose the option Zoom 

to layer extent.  

 Zoom with the mouse wheel placing the cursor at the centre 

of the area of interest.  

Now the topography and the Sarine River crossing the city of 

Fribourg from south to north are visible (Fig. S 74). First of all, from 

this step we learn that QGIS has several tools for similar applications, 

and every user will find and choose the most efficient manner to 

achieve their goals. Second, it is beneficial to use (or even try) the 

right mouse button, for example to set the Map View exactly to the 

extent of one specific layer or to the access the Layer Properties. 

Advanced users might be comfortable using the mouse wheel to change 

the zoom level while other tools stay activated (e.g. during digitisation). 

 

7.3.3.1. Add delimited text layer (*.txt, *.csv) 

In this section, a simple text file will be added to QGIS to visualize 

and analyse it spatially (for more information about this refer to 

section 6.3.3.1.):  

1. Open Layer. 

2. Choose Add Delimited Text or click the appropriate button 

from the Manage Layers toolbar (Table 5). 

Table 5. The most important functions of the Manage Layers toolbar. This toolbar can be enabled and disabled by the main menu View > 

Toolbars > Manage Layers. 

Menu Entry Layers Icon Purpose 

New 
 

Creates a new layer without content (shapefile or SpatiaLite database) 

Add Vector Layer 
 

Add new vector layer(s) (see section 7.3.3.) 

Add Raster Layer 
 

Add new raster layer(s) (see section 7.3.3.) 

Add PostGIS Layers 
 

Manage connections to PostGIS databases, load PostGIS layers and tables  
(http://www.postgis.org/) 

Add WMS Layer 
 

Add and manage layers from Web Map Services  
(http://www.opengeospatial.org/standards/wms) 

Add WFS Layer 
 

Add and manage layers from Web Feature Services  
(http://www.opengeospatial.org/standards/wfs) 

Remove Layer 
 

Remove layer(s) (see section 7.3.3.1.) 

Add Delimited Text Layer 
 

Import delimited text files (see section 7.3.3.) 

Create new GPX Layer 
 

Create a GPX file for the use in Handheld GPS devices (see section 7.3.3.2.) 
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3. Choose the source text file (in our case the comma delimited 

textfile points_table.csv).  

4. Give a name to the output layer (e.g. 

bees_colony_locations_tab) . 

5. Select the appropriate delimiters (e.g. semicolon or comma) 

and the columns containing the coordinates in East (X) and 

North (Y) according to Fig. S 75. 

6. Click OK. 

7. Choose the CH1903/LV03 projection from the CRS selector 

list. 

8. Click OK. 

9. Go to File.  

10. Click Save Project.  

As a result, the honey bee colonies are shown as point information 

on top of the Map View (Fig. S 76). It is important to note, that this 

layer is loaded into QGIS and available for any display and map creation 

purpose and also some basic analysis, but not physically stored as 

geodata in the file system. To get the full functionality of a point vector 

file, save this layer e.g. as a shapefile by performing the following steps:  

1. Right-click the layer in the Map Legend (Fig. S 68).  

2. Choose the Save as option in the context menu. 

3. Select a file format (in our case it will be an ESRI Shapefile). 

4. Select a target destination folder within the file system (e.g. 

with the filename bees_colony_locations.shp). 

5. If special text characters are included, choose an encoding 

that is suitable (e.g. for Western Europe utf-8 or latin1 are 

good options). 

6. Select the correct CRS (in our case it is CH1903 / LV03). 

7. Enable the option Add saved file to map (Fig. S 77). 

8. Click OK.  

A message (“Export to vector file has been completed”) will 

appear and the layer will be added on top of the Map Legend.  

9. Select the old text file from the Map Legend using a left 

mouse click. 

10. Press the button remove layer(s) (see Table 5) to remove it 

from the project – we will only need our newly created 

shapefile for all future steps.  

Using the plugin called “XyTools” (Tab. 4) it is also possible to 

import Microsoft Excel or OpenOffice spreadsheets, similar to the 

procedure presented in section 6.3.3.1. 

 

7.3.3.2. GPS and KML data, working with different coordinate 

systems 

Other important functionalities of modern GIS are those to import and 

export GPS data (e.g. those acquired by handheld GPS devices), and 

the transformation between different coordinate systems. Because the 

GPS eXchange Format *.gpx is common and integrated within the 

OGR library (see section 7.3.2.), the import of existing GPS data is as 

simple as adding other vector data (see section 7.3.3.). Assuming that 
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our point vector layer added in the previous step represents colony 

locations of honey bees we would like to locate in the field, this vector 

layer needs to be exported to a new *.gpx-file to be uploaded onto a 

handheld GPS device. This can be done with the same function used 

to save a layer to a new shapefile (Fig. S 77), but modified settings:  

1. Right-click on the layer in the Map Legend. 

2. Select Save as. 

3. Choose the GPS eXchange Format (supported by a majority of 

GPS devices).  

4. Set the target coordinate system to “WGS84” (because GPS 

devices are natively working in World Geodetic System 1984). 

5. Enable the option Skip attribute creation (because we only 

need the coordinates for a stakeout of the colony locations in 

the field, without any attributes).  

6. Click OK and verify if the new file (e.g. with the file name 

bees_colony_locations_WGS84.gpx) has been created within 

the chosen destination folder.  

Behind this two very important technical GIS functionalities are 

working: first, the translation from a source file format (*.shp) to a 

target file (*.gpx) format and second, a precise transformation 

between two different coordinate systems, even with different map 

units. If you have a software like Google Earth for instance, you can 

easily verify if the coordinate transformation to WGS84 worked 

correctly (if you do not have Google Earth installed, you can skip this 

paragraph, or download the software from http://www.google.com/

earth/index.html).  

1. Open Google Earth. 

2. To open the *.gpx-file in GoogleEarth, go to File. 

3. Click Open. 

4. Browse to the location of *.gpx file. 

5. Beside the File name box, choose the Gps option from the 

dropdown menu. 

6. Click Open.   

7. The GPS data Import dialog window will appear asking if KML 

tracks should be created from the GPS data. Check the 

options Create KML Tracks and Adjust altitudes to ground 

height (with this function, all elements are attached on top of 

the elevation model behind GoogleEarth and you are sure that 

all features will be visible) and confirm with OK. 

8. Google Earth will do a file format conversion that results in a 

new temporary layer named “GPS device” in the panel Places 

> Temporary Places. The new created placemarks in Google 

Earth should be at the same location as in the QGIS project.  

9. Right-click on the layer GPS device. 

10. Click Save Place As to save this temporary layer to the file 

system in the KML format (Fig. S 78, make sure to choose 

KML instead of the zipped KMZ format). 

The Keyhole Markup Language (KML) is another file format 

supported by the OGR library. It provides great possibilities to share 
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spatial information of vector based geodata with people who are not 

familiar with GIS software, since almost everybody can handle 

software like Google Earth. Of course it is also possible to import the 

KML file back to QGIS. We will see if the coordinate transformation 

from WGS84 back to the Cartesian CRS of Switzerland works fine:  

1. Just drag the KML file from its data source to the Map Legend 

in your QGIS project.  

2. By activating and deactivating the checkbox to the left of the 

layers you can check if the geometries are congruent.  

If there is a lateral shift between the point layers or an error in 

scale, the option “on-the-fly” CRS transformation was probably not 

enabled – you can fix this by navigating to the main menu Settings > 

Project Properties where you choose the second tab Coordinate 

Reference Systems (CRS).  

 

7.3.4. Layer organisation and navigation 

Managing layers with QGIS is very similar to ArcGIS, thus the 

following hints are complementary to sections 6.3.4. and 6.3.5:  

 The drawing order of one specific layer relative to the others 

can be changed in the Map Legend (Fig. S 68): click on the 

layer and hold the left mouse button to move layers upwards 

or downwards in the hierarchy.  

 Within a large project it is recommended to make groups 

(right-click on the Map Legend > Add New Group), to be 

more flexible to turn a whole group of layers on and off 

together, for instance, or to get more space in the layer 

hierarchy by collapsing multiple legends.  

 To avoid losing the most important buttons and menus, have 

a look at the main menu View > Panels and View > Toolbars: 

Here you can enable additional panels to the QGIS GUI (e.g. 

the Overview or the QGIS Browser window) and show or hide 

several toolbars and buttons (the most essential toolbars are 

Attributes, File, Manage Layers and Map Navigation).  

 To achieve a good visualization result, changes in the layer 

Layer Properties are often required – the topic of the following 

section. 

 

7.3.5. Layer properties 

The properties of one specific layer can be accessed by the main menu 

Layer > Properties, a right-click on the layer name and choosing the 

entry Properties in the context menu or simply by double-clicking the 

layer name. The Layer Properties might vary between different file 

formats, but every layer will at least have tabs for Style options, 

General settings and provide Metadata information. Let’s first have a 

look at the Metadata, the information about the data: opening the 

Metadata for the layer commune_boundary_FR.shp, the following 

information appears (Fig. S 79): 

Apart from the file format, data source, and geometry type, we 

can also learn something about the number of features (n = 51), the 
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coordinate reference system (CRS) used for projection and the spatial 

extent (minimal and maximal values for X and Y). The current 

administrative districts are digitized as polygons, displayed with an 

opaque colour fill. To combine them with our elevation model, the fill 

colour could be removed and the border set to a bright colour: 

1. Open the Layer Properties window by a method of your choice 

(see above). 

2. Switch to the tab Style. 

3. Click the button Change to the left and a further window with 

Symbol properties will open. 

4. Select an appropriate Symbol layer type in the Symbol 

properties window (dropdown-menu on top) (Fig. S 80). By 

default, polygon layers are visualized by a “simple fill” with a 

uniform colour for the fill area and black lines representing 

the polygons boarders. Change the layer type e.g. to Outline: 

simple line. 

5. Fill with a colour of your choice.  

6. Click to close the Symbol properties. 

7. Click Apply to implement the changes.  

8. Close the Layer Properties with OK.  

9. Move the polygon layer one level higher in the Map Legend on 

top of the elevation model. 

 

7.4. Data selection and editing  

This section presents the most important selection queries and editing 

tasks using different techniques in QGIS. 

 

7.4.1. Spatial query and select by location 

Similar to ArcGIS (section 6.4.1.), different functions exist to obtain 

information for defined locations: The Identify Features button       is 

the same as the Identify tool of ArcGIS (see section 6.4.1.) and is 

used to obtain information about specific pixel values within a raster 

image or to look at the attribute values of a vector feature. Before 

applying the Identify Features tool, it is necessary to activate and 

select the appropriate layer in the Map Legend. In addition, various 

spatial operations are provided within the main menu Vector. Of 

particular interest is the function Spatial Query that allows more 

advanced queries by using vector geometries. To demonstrate this 

functionality with QGIS we will ask for all communes that contain at 

least one honey bee colony.  

1. Choose Vector from the main menu. 

2. Select Spatial Query (a dialog window will appear).  

3. Select the layer commune_boundary_FR.shp as Source 

Features and the point vector file with the honey bee colonies 

as Reference Features.  

4. Choose the operator Contains to be applied between these 

two features.  

5. Choose to create a New Selection (alternatively, it could be 

added to or removed from an existing selection).  
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6. Click Apply and close the dialog, if the result looks similar to 

Fig. S 81. 

Intersection operations can also be applied with the help of the 

function Select by location:  

1. Go to Vector. 

2. Choose Research Tools. 

3. Select Select by location. 

4. Choose the settings according to Fig. S 82 to achieve similar 

results as displayed in Fig. S 81. 

In practice, spatial selection operations are frequently used to 

assign attributes of one layer to another layer and for raster 

calculation tasks or modelling tasks.  

 

7.4.2. Select by attributes 

Let’s have a look at the result of the spatial query from the last 

section: In total eleven features were highlighted (that means 

selected) within the layer bees_colonies_locations.shp. So far so 

good, but what if the research question was to get the names of all 

communes containing honey bee colonies? To achieve this goal: 

1. Right-click the commune_boundary_FR.shp layer. 

2. Choose Open Attribute Table or use the button       within the 

Attributes toolbar.  

It is written in the headline of the Attribute table that the selected 

layer contains 51 entries in total (representing communes). 

Because they are topologically correct (see section 2.1.), none of 

these communities intersects with another and all the borders are 

congruent (that means that there are no blank “islands” in 

between).  

3. To focus on the selected features within a large dataset, use 

the checkbox named Show selected only within the Attributes 

table (Fig. S 83). Browsing to the right within the different 

attributes, within the column called “GEMNAME”, the name of 

each community is given.  

4. The Attribute table can stay open while other functions are 

performed, e.g. during digitizing or editing tasks.  

Assuming that the goal to produce a map that shows only the 

municipalities of the canton Fribourg, the following workflow can be 

applied:  

1. Right-click the commune_boundary_FR.shp layer. 

2. Select Query. 

The Query Builder dialog opens (Fig. S 84). The attribute 

"KANTONSNR" contains an ID that represents the canton in 

Switzerland and in the case for Fribourg it is 10. So it is now our 

goal to restrict the features by means of a formula like 

"KANTONSNR" = 10. QGIS will then perform a restriction on the 

polygons displayed similar to an SQL Selection-Query by the use 

of a “where clause” (http://www.w3schools.com/sql/sql_where.asp).  
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3. Try to rebuild the formula mentioned above by activating the 

options Fields, Operators and Values (otherwise it can also be 

written manually). 

4. Confirm the query with OK.  

5. Right-click on layer and Zoom to the layer extent.  

 Two polygons in the north-west outside of the canton of 

Fribourg will have disappeared from the Map View and will also no 

longer be selectable within the Attributes table (there are only 49 

features left, Fig. S 85.). However, they are not deleted from the file 

and can be restored by removing any SQL “where clause” in the 

Query Builder.  

 For other applications where a  section of a vector file should 

be selected without blanking out all the other features, the same 

Query Builder dialog can be accessed by the Attribute table > 

Advanced search. Of particular use is the combination of different 

“where clauses”, e.g. selecting attributes above or below a certain 

threshold or containing a given text string. 

 

7.4.3. Manual selection 

Sometimes the easiest way to select geometries or entries in the 

Attribute table is by hand, especially for digitizing or editing tasks. To 

create new selections use the selection button          within the 

Attributes toolbar. Clicking on the little black arrow to the right, a drop

-down menu opens, containing some more options for the selection 

using rectangles, polygons, freehand forms, or a radius. To select 

multiple features or to remove some from a given selection, hold the 

CTRL key (Windows) down while selecting or deselecting the features 

with the left mouse button (see the manual (QGIS Development 

Team, 2013) for the same function on Mac and Linux).  

Any selection can be removed using the main menu View > Select 

> Deselect Features from All Layers or the button        within the 

Attributes toolbar. 

 

7.4.4. Creating new layers from selected data 

If a given selection has to be exported into a new layer, e.g. to share 

the file with business colleagues, this can be done by saving a vector 

layer (see section 7.3.3.): open the layers context menu by a right-

click within the Map Legend > Save Selection As. Choose all the 

polygons in the layer commune_boundary_FR.shp that intersect with 

at least one of the honey bee locations with a selection tool of your 

choice and load the new created layer into the QGIS project (Fig. S 86.).  

The newly created polygon layer will only contain 11 features and 

will again be symbolized by a non-transparent simple fill pattern.  

 

7.4.5. Attribute table data editing  

QGIS provides a set of editing tools and conventions similar to ArcGIS 

(see section 6.4.3.). To edit a vector layer, it has to be set into “edit  
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mode” by the Toggle Editing function. As usual, this function is accessible 

by several buttons and menu entries: 

 Main menu Layer > Toggle Editing. 

 The button Toggle Editing          within the Digitizing toolbar 

or the Attribute table. 

 The context menu within the Map Legend > Toggle Editing. 

If the Toggle Editing function is greyed out, the selected layer is 

probably not in an editable vector file format (not all the file formats 

that can be imported and displayed with QGIS may also be changed, 

so that in some cases a file conversion is necessary first) or accessed 

by another program or other users. 

1. Set the newly created layer containing all municipalities where 

colonies of honey bees were sighted into the Edit mode.  

2. In the Map Legend a pencil will appear to the left of the layers 

name and in the Map View the different vertices of the 

polygons are marked by transparent circles.  

3. Open the Attribute table and look at the buttons to the left 

(see Table 6):  

4. Now add a new field (column in the Attribute table) with the 

button       , where additional values (e.g. the number of 

honey bee colonies) can be filled in. 

5. Within the Add column dialog, choose appropriate settings for 

name (avoiding special characters and blanks, e.g. 

‘bees_colonies’), data type (e.g. integer, only whole numbers 

will be needed) and width (2 digits are sufficient as there will 

not be more than 99 colonies per entry).  

6. Now, fill in some numbers into the newly created fields as a 

test (Fig. S 87).  

Because of the restriction to integer values of 2 digits maximum 

width, all types of characters and also numbers higher than 99  

will be refused. This is one of the ways GISystems deal with 

aspects of data integrity.  

7. Click the Save Edits button        to make the changes 

permanent, i.e. written to the file system. 

Save often to avoid data loss and finish successful edit sessions by 

turning the edit mode off (Toggle Edits button again > save all 

changes). 
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The number of honey bee colonies could be counted and written 

to the table manually, but of course QGIS provides several tools for 

this task that run automatically, even when the editing mode is not 

active or no empty field has been created before: 

1. Go to Vector. 

2. Choose Analysis Tools. 

3. Select Points in Polygon. 

4. Choose the appropriate input layers and a name for the new 

attribute field (e.g. “bee_colony”) 

5. Specify a path and a name for the new shapefile that will be 

created (Fig. S 88). 

6. Click OK. 

7. Click Yes when asked if the newly created shapefile should be 

added to the table of contents (TOC). 

In which commune are most honey bee colonies located? 

1. Switch back to the Attribute table of the new shapefile. 

2. Sort the attributes by descending in the field 

“bee_colony” (click the arrow beside of the column name). 

Within the commune of “Düdingen”, with the “BFSNR” = 2293, 5 

colonies of honey bees were found.  

 

7.4.5.1. Using the field calculator and adding geometry 

columns 

As the communes in this example have different areal extents, one 

could also ask for the commune area in relation to the number of 

honey bee colonies. With GIS software, this kind of problem is easy to 

solve. Also the extraction of statistical information about geometries 

like point coordinates, line length, perimeter or area from the features 

of a vector layer can be efficiently processed.  

Let’s demonstrate this with the polygon layer already containing 

the attribute “bee_colony” created in the previous section: 

1. Open the Attribute table. 

2. Again toggle on the Edit mode. 

3. Open the Field calculator. 

4. Activate the checkbox to create a New field. 

5. Set the output field name to something like “area_bee” and 

the other parameters as follows: field type (decimal number), 

width (10) and precision (3). 

Table 6. The most important functions and the corresponding buttons for editing tasks. 

Function Icon Purpose 

Toggle editing mode 
 

Start and End editing sessions. Changes have to be confirmed (or rejected) at the end 
of an editing session. 

Save Edits 
 

Saves the edits permanently. 

Delete Selected Features 
 

Deletes only the selected features 

New column 
 

Inserts a new column (field) at the end of the attribute table. A field name and a data 
type must be defined. 

Delete column 
 

Deletes the selected column(s) 

Open field calculator 
 

Opens the field calculator 
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6. Search now for “area” within the Function List > geometry 

and select the function with the name $area by a double click.  

7. Click the appropriate button for a division operation and select 

the field containing the number of honey bee colonies.  

8. Confirm with OK, if the resulting Expression corresponds to 

“$area / bee_colony” (Fig. S 89, “bee_colony” represents the 

column name, selectable by Function List > Fields and Values).  

The values in the field “bee_area” (to the right within the 

Attribute table, ratio area per bee colonies) could be a first indicator 

about the occurrence of honey bees (of course with strong limitations, 

as the polygon layer only represents administrative boundaries): The 

minimum value belongs to the community of “Granges-Paccot” with 

the “BFSNR” 2198. 

We learned in this section to calculate the area of a polygon layer 

and write these values into an attribute field. Another possibility to 

add standard geometry information (e.g. point coordinates, line 

length, perimeter or area) is the function Export/Add geometry 

columns. This function is of particular use in combination with 

different coordinate reference systems (CRS), which can easily be 

demonstrated with the KML file created in section 7.3.3.2. (e.g. 

bees_colony_locations_WGS84.kml):  

1. Go to Vector. 

2. Select Geometry Tools (Fig. S 90). 

3. Choose Export/Add geometry columns. 

4. Select bees_colony_locations_WGS84 as Input vector layer. 

5. Choose to calculate the geometry columns using the Layer 

CRS (e.g. WGS84).  

6. Specify the path and filename for the destination file that will 

contain the geometry columns (it is the best to convert it back 

to a shapefile again).  

7. Click OK and wait until the progress bar is at 100%.  

8. Confirm to import this new shapefile by clicking Yes on the 

next dialog and close the Export/Add geometry columns 

window. 

9. Open the Attribute table of the new shapefile. 

 Like its origin (the KML file), the shapefile is referenced in 

WGS84 but because of the “on-the-fly” CRS transformation, the points 

representing the honey bee colonies are still congruent with those 

referenced in the projected coordinate system (which is defined as 

CH1903 / LV03). Within the Attribute table two new fields have been 

created that show the latitude and longitude in degrees (according to 

WGS84).  

 

7.4.5.2. Table manager plugin 

New attribute fields can be added or deleted directly within the 

Attribute table or the Field calculator dialog. But at this stage there is 

no option to rename any given field. For all changes within the table 

structure (adding, renaming and removing operations), the Table 

manager plugin is the perfect tool. As this is an optional plugin, it has 

to be downloaded first from the Official QGIS Repository (see section 
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7.1.3.). In this example, we rename the geometry columns: 

1. Go to Plugins. 

2. Select Table. 

3. Select Table Manager (the edit mode has to be turned off). 

4. Locate the field in the list called “XCOORD”. 

5. Click the Rename button        and rename it as “longitude”. 

6. Click OK.  

7. Do the same with “YCOORD” renaming it as “latitude”. 

8. Confirm the changes by the button Save.  

If changes are made for fields used for layer styling or labelling, 

some features may become invisible. This should not be the case 

in this example. 

9. Click Yes to keep the current layer style. 

The Table Manager is very strict in terms of the length of field 

names and the characters allowed. Due to this, it may be difficult 

to find suitable field descriptions, but this is the price to pay for 

preserving interoperability options between different file formats. 

10. Save the layer to a new shapefile into the CRS CH1903/LV03 

(see section 7.4.4., e.g. with the name 

bees_colony_locations_coordinates.shp) 

11. Import this new shapefile (e.g. and add geometry columns 

again, see section 7.4.5.1.)  

12. Open its Attribute table. 

13. Compare the different columns.  

Now the coordinates of the points are listed as attributes in the 

two CRS, one in degrees (WGS84) and one in meters (CH1903/LV03). 

 

7.5. Format conversions and projections 

QGIS provides a variety of different conversion functions between 

vector and raster data formats similar to other GIS software like 

ArcGIS (sections 2.2 and 6.7.). The most important plugin for data 

conversion functions within QGIS is called GDAL Tools, so make sure 

it is installed and activated (see section 7.1.3.).  

 

7.5.1. Vector to raster 

The Vector to raster function rasterizes vector geometries into the 

band(s) of an existing or a new raster image.  

1. Go to Raster. 

2. Select Conversion. 

3. Choose Rasterize (Vector to raster). 

4. Choose the input shapefile (e.g. the layer 

commune_boundary_FR.shp) and a suitable attribute field 

(e.g. “Shape_Area”). 

Be aware that any layer intersection (different features overlaying 

each other) cannot be transformed to raster data without data 

loss (in the intersecting areas). 

5. Specify an output raster file and a resolution in pixel value 

(Fig. S 91).  

6. Launch the conversion by clicking OK.  

The newly created raster image will probably be displayed in 
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uniform grey colour. To apply different colours for the corresponding 

values (generated by the shape area of each polygon) proceed as 

follows:  

1. Open the Layer Properties. 

2. Select Style. 

3. Choose Single band properties. 

4. Select Colormap in the dropdown menu Color map. 

5. Switch to the tab Colormap and increase the number of 

entries, e.g. to 5. 

6. Click Apply.  

7. Navigate to the tab Transparency and make 0 values 

transparent (otherwise regions outside of the original polygon 

remain filled).  

8. Have a look at the changes on the Map View by clicking Apply.  

9. Close the Layer Properties with OK, if the result looks similar 

to Fig. S 92. 

Notice that the resolution of the polygon boundaries is coarse in 

the raster and not as smooth as in the original vector layer (zoom to 

the boundaries).  

 

 

7.5.2. Raster to vector 

As the name of this function suggests, a polygon layer will be created 

according to the different raster values (contrary to the function 

Contour demonstrated in section 7.7.2.4., which creates a line vector 

layer based on raster grid values). 

1. Go to Raster. 

2. Select Conversion. 

3. Choose Polygonize (Raster to vector).  

4. Choose the newly created raster from the previous section 

(7.5.1.) and convert it back to a vector file (so specify an 

output shapefile, see Fig. S 93).  

5. Start the conversion by clicking OK. 

6. Open the newly created shapefile. 

An attribute field containing the former raster values will be 

created. 

Beside the fact that the geometry became coarser (the boundaries 

are no longer smooth), we see that many of the original attributes 

have been lost (e.g. as seen with the Identify tool or within the 

Attribute table).  

 

7.5.3. Reproject data to a new coordinate reference system 

(CRS) 

Sometimes, not only one raster file needs to be converted to another 

coordinate reference system, but a whole folder with many raster 

images. In this example, the ASTER30_WGS84 DEM will be projected 

to the CRS CH1903/LV03 of Switzerland.  

1. Go to Raster. 

2. Select Projections. 

3. Choose Warp (Reproject). 
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4. Select single input and output files (e.g. ASTER30_dem_CH1903) 

or source and destination folders (for processing in batch mode). 

5. Specify both the source and target reference system (SRS).  

6. Choose bilinear or cubic as Resampling method.  

7. Activate the checkbox Load into canvas when finished (Fig. S 94). 

8. Start the projection by clicking OK. 

Depending on the type of the raster image values different 

Resampling methods should be used (e.g. nearest neighbour for 

categorized thematic data and bilinear or cubic for continuous data 

such as raster images like elevation models). In addition, it might be 

useful to define a value for pixels without data (so that they can be 

made transparent afterwards). 

 

7.6. Basic vector tools 

The standard tools for data processing and analysis provided by 

different GIS software have a similar appearance. All tools described 

in the following sections can be accessed by the main menu Vector > 

Geoprocessing Tools (if the plugin fTools has been successfully 

installed and activated before, see section 7.1.3.).  

 

7.6.1. Buffer(s) 

In QGIS, the Buffer tool can be accessed in the following way (see 

section 6.5.5. for a description of the tool): 

1. Go to Vector. 

2. Select Geoprocessing Tools. 

3. Choose Buffer. 

4. Select a realistic buffer value for honey bees (e.g. 2,000 

meters). 

5. Leave the dissolve option blank (otherwise all buffers will be 

aggregated to one single feature without the different 

attributes, see Fig. S 95). 

6. Specify the path and name for the destination file. 

7. Click OK.  

8. Click YES to confirm loading the newly created vector file to 

the QGIS project. 

One should consider the use of the buffer function may lead to 

topologically incorrect vector files, e.g. when the distances between 

the features of origin are closer than the double buffer radius, leading 

to overlaps between different features. The circle polygons created in 

this step are visible in Fig. 99. 

 

7.6.2. Clip 

See section 6.5.1. for a description of the Clip tool. As an example, 

the clip operation could be performed between the honey bee 

locations and the commune of Fribourg.  

1. Activate the layer commune_boundary_FR.shp in the Map 

Legend. 

2. First select the polygon that represents the city of Fribourg 

(“BFSNR” = 2196) with an appropriate selection tool (see 

section 7.4.). 
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3. Open the Clip tool, go to Vector. 

4. Select Geoprocessing Tools. 

5. Choose Clip. 

6. Choose the point layer containing the honey bee colony 

locations as Input vector layer and the polygon layer as Clip 

layer.  

7. Make sure that the checkbox the Input Vector Layer Use only 

selected features (with this the operation could be performed 

on a selection of features only) remains blank (there is no 

selection), and that the one for the Use only selected features 

Clip Layer (beneath) is checked (Fig. S 96). 

8. Launch the Clip operation by clicking OK.  

9. Click YES to confirm loading the newly created vector layer 

(containing only 3 points) to the project.  

 

7.6.3. Intersect 

Identically to ArcMap, the intersect operation in QGIS computes a 

geometric overlap of two layers. This can be best demonstrated by 

the use of two polygon layers with different geometries: 
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1. Go to Vector. 

2. Select Geoprocessing Tools. 

3. Choose Intersect. 

4. Choose the newly created buffer layer as Input vector layer. 

5. Leave the checkbox beneath Use only selected features blank. 

6. Select the layer commune_boundary_FR.shp (where the city 

of Fribourg should still be selected). 

7. Check Use only the selected feature of this layer of the city of 

Fribourg (Fig. S 97).  

8. Click OK. 

The new layer contains only the common area of the two 

polygons (the geometry of the buffer within the city of Fribourg). 

 

7.6.4. Dissolve 

In section 7.4.2., a definition query was set from the polygon layer 

representing different municipalities within the canton of Fribourg 

(Fig. S 85). To aggregate all features that contain the same attribute 

“KANTONSNR” by producing a vector layer of all districts, the Dissolve 

function is a good option (see section 6.5.7. for further explanation 

about the dissolve tool): 

Fig. 99. After applying the Dissolve tool, the polygon layer is divided into 5 different districts. The thin black lines on top represent the former 

state (51 different municipalities). The yellow circles were created using a radial buffer of 2000 m around of all the honey bee colony  

locations. Reproduced with permission of Swisstopo (BA13016).  
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1. Open the Query Builder for the polygon layer you want to use 

by right-clicking.  

2. Make sure that no restriction is made within the SQL “where 

clause” (If you use the layer commune_boundary_FR.shp, 

delete the entry "KANTONSNR" = 10, if this still exists). 

3. Confirm with OK.  

4. Go to Vector. 

5. Select Geoprocessing Tools. 

6. Choose Dissolve. 

7. Locate the layer commune_boundary_FR.shp as Input vector 

layer. 

8. Leave the checkbox Use only selected features blank (with 

this the operation could be performed on a selection of 

features only, but in our case no selection has to be applied). 

9. Select an attribute (e.g. “BEZIRKSNR”) as Dissolve field.  

10. Choose a path and name for the destination file to be created 

(Fig. S 98).   

11. Finish by clicking OK.  

Now the whole canton of Fribourg is selectable at once 

(representing only one line within the Attribute table), and the 

“island polygons” in the north-western part demonstrate what is 

meant by a “multipart polygon”. What happened to the attributes? 

– Of course some of the attributes are no longer thematically 

correct: the dissolve function allocates the attributes from the first 

line of each value that was aggregated. The display of the new 

layer can be improved: 

12. Open the Layer Properties. 

13. Select Style. 

14. Set a categorized symbol style with different fill colours for all 

5 districts (by using the column “BEZIRKSNR”). 

15. Choose a colour ramp. 

16. Click Classify.  

17. Apply the changes. 

18. Close the Layer Properties dialog by clicking OK.  

19. The result will look similar to Fig. 99. 

 

7.6.5. Union 

In QGIS the Union tool can be found within Vector > Geoprocessing 

Tools > Union (see section 6.5.3. for an explanation of the union 

function).  

 

7.6.6. Join attributes by location 

In section 7.4.1. spatial queries were performed. In a similar manner, 

different layers and their features can also be spatially linked to each 

other, e.g. to relate thematic data to known coordinates or 

geometries:  

1. Go to Vector. 

2. Select Data Management Tools. 

3. Choose Join attributes by location. 
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4. Select a target (e.g. bee_colony_locations.shp) and a join 

vector layer (where the attributes are taken from, e.g. 

commune_boundary_FR.shp). 

5. Choose how the attributes should be attached to the target 

layer (by the first matching feature is usually the best choice 

if text fields are joined, but in the case of numerical attributes 

different aggregation modes may also be suitable).  

6. Set the path and name for the destination shapefile (Fig. S 100).  

7. Click OK  

8. Load the new shapefile into the project by clicking Layer > 

Add Vector Layer.  

Within the Attribute table of the new shapefile, the attributes of 

the commune layer will be added.  

 

7.6.7. Basic statistics, list unique values 

Especially for large vector data files containing a variety of attribute 

fields and features, it can be useful to display some statistical 

information before performing calculations with these attribute values. 

Two very useful tools are provided by the fTools plugin (see section 

7.1.3.) and explained in the following examples: 

To display basic statistics based on attributes,  

1. Go to Vector. 

2. Select Analysis Tools. 

3. Choose Basic statistics. 

4. Any vector layer can be chosen within the QGIS project as 

Input Vector Layer. 

5. Select a target field, where the statistics (mean value, 

standard deviation, sum, minimum, maximum etc.) should be 

performed. 

6. Click OK (Fig. S 101).  

Sometimes the total number of attribute values within a given 

field are not important, but the different values themselves are: 

1. Go to Vector. 

2. Choose Analysis Tools. 

3. Select List unique values.  

4. Select a target vector layer and an attribute field.  

5. Click OK to perform the calculation. 

It is possible to export the values to the clipboard if they are used 

in another program (e.g. calculation spread sheet or text editor). 

 

7.7. Basic raster tools 

In the following section, some basic raster functionalities in QGIS will 

be discussed. Many of these tools rely on the GDAL Tools plugin (see 

section 7.1.3.), so install or activate this first. 

 

7.7.1. Merge 

The Merge function is similar to the mosaic tool of ArcMap, where 

several raster layers and files can be combined to a new raster 

dataset (see section 6.6.1. for more information).   
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1. Go to Raster. 

2. Select Miscellaneous. 

3. Choose Merge. 

4. Select the input raster images (or even a whole directory). 

5. Create one single output raster file in a destination folder.  

6. Enable the lowermost checkbox so that the new raster image 

will be added directly to the project. 

  

7.7.2. Terrain analysis 

Beneath the elevation information itself, DEMs can serve as a source 

of data for various terrain analysis operations to calculate geometrical 

properties (e.g. slope or aspect) and other derivatives (e.g. clear sky 

factor). All functions for terrain analysis are accessible by the menu 

Raster > Terrain analysis. In some cases these functions are also 

useful for analysis or visualisation of thematic raster data. 

 

7.7.2.1. Slope 

The Slope (Terrain analysis) tool calculates the slope angle of each 

raster cell in degrees. 

To calculate the slope of the terrain (Fig. S 102): 

1. Go to Raster. 

2. Select Terrain analysis. 

3. Choose Slope. 

4. Choose the DEM as the input raster. 

5. Browse for a destination path and save the output raster as 

“slope”. 

6. Choose the output format to be used from the list (various 

formats within GDAL). 

7. Click OK. 

8. Adapt the raster symbolization if necessary (Layer Properties 

> Symbol). 

Besides the Terrain analysis tools there is a set of Terrain analysis 

functions (with even more options) provided by the GDALTools Plugin 

(Fig. S 103): these tools are accessible by menu Raster > Analysis > 

DEM (Terrain models).  

 

7.7.2.2. Aspect 

The Aspect (Terrain analysis) tool uses a DEM to calculate the direction 

in which slopes are facing (see section 6.6.2.2. for more information). 

To calculate the aspect based on a DEM: 

1. Go to Raster. 

2. Select Analysis. 

3. Choose DEM (Terrain models). 

4. Choose the mode Aspect (Fig. S 103) (the function Raster > 

Terrain analysis > Aspect is just another option to achieve the 

same result). 

5. Select the DEM as the input raster. 

6. Browse for a destination path to save the output raster as 

ASTER30_aspect_CH1903.tif.  
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7. Some optional settings can be activated or deactivated in the 

checkboxes, to make flat areas (that do not have a valid 

aspect value by default) zero values, for instance.   

8. Click OK.  

9. Adapt the raster symbolization if necessary (Layer Properties 

> Symbol). 

 

7.7.2.3. Hillshade 

Hillshade rasters are useful for determining which areas on the terrain 

are shaded from the sun and which are not and are calculated from a 

DEM (see section 6.6.2.3) for further information about the tool.  

To calculate the hillshade based on a DEM:  

1. Go to Raster. 

2. Select Terrain analysis. 

3. Choose Hillshade. 

4. Select the DEM as the input raster. 

5. Specify an output (raster) layer.  

6. Choose reasonable values for the horizontal and vertical angle 

of the illumination (in degrees), the Z factor can usually stay 

at 1 (otherwise the terrain will be super-elevated when 

working in a CRS). 

7. Click OK. 

8. Adapt the raster symbolization if necessary (Layer Properties 

> Symbol, notice that the results are shown in degrees (Fig.  

 S 104)). 

  

7.7.2.4. Contour 

This function generates an output vector file containing elevation levels 

(contour lines) from an input raster (see section 6.6.2.4. for more 

information). To create contours from a DEM:  

1. Go to Raster. 

2. Select Extraction. 

3. Choose Contour. 

4. Specify the input DEM and the output vector file. 

5. Choose an appropriate interval between the different contours 

(e.g. 50 meters).  

6. Activate the first checkbox to store the elevation information 

within an attribute and specify a field name (Fig. S 105).  

7. Click OK. 

8. Load the resulting vector layer into QGIS.   

To achieve better results for visualisation, a smoothing algorithm 

could be performed on the line feature, e.g. with the tool Simplify 

geometries (Vector > Geometry Tools > Simplify geometries) or the 

Generalizer plugin (Plugins > Generalizer > Generalizer). 

Contour lines can also be created by the Contour plugin that 

provides some more options (e.g. minimal and maximal height). After 

the installation (see section 7.1.3.) it can be started in the menu 

Plugins > Contour > Contour. 
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7.7.3. Raster calculator 

The raster calculator is a very flexible and useful tool to combine 

raster images with conditional and trigonometric expressions and any 

other task that requires raster math operations. It can be found within 

the menu Raster > Raster calculator. The formula 

“ASTER30_dem_CH1903@1 * 3.28084” would convert the elevation 

data in the DEM from meters into feet by creating a new raster image 

(with an elevation range from 1,332 to 2,982 feet). 

 

7.8. Spatial statistics and scientific modelling 

QGIS provides several tools for spatial statistics and interfaces to 

statistical software like R (http://www.r-project.org). This section 

demonstrates some introductory examples of how statistics of 

spatially related data can be processed, as well as suggestions for 

useful plugins and software to perform more sophisticated spatial 

analysis. If you search for a specific application linked to spatial 

statistics, browse through the QGIS Plugins (see section 7.1.3.) and 

have also a look at the projects and their features listed on the OSGEO 

website (http://www.osgeo.org). A more general introduction to 

statistics in honey bee research is provided in the BEEBOOK paper on 

statistics (Pirk et al., 2013). 

 

7.8.1. Example 1: Computing mean coordinates 

A very basic analysis could be to compute the mean coordinates of 

the honey bee locations. Of course this could be done by computing 

the X and Y coordinates into an attribute first, but now we will use the 

tool mean coordinate(s): 

1. Go to Vector. 

2. Select Analysis Tools. 

3. Choose Mean coordinate(s). 

4. Select the input vector layer (e.g. bees_colony_locations.shp). 

5. Specify the output shapefile (Fig. S 106).  

6. Start the calculation with OK.  

The new shapefile will contain one point at the coordinates 

577289.7 / 184622.7. 

 

7.8.2. Example 2: Nearest Neighbour Analysis and Distance 

matrix 

Is the spatial distribution of our honey bee colonies disperse or 

clustered? – The level of clustering in a point vector layer can be 

assessed by Nearest Neighbour Statistics (Analysis tools):  

1. Go to Vector. 

2. Select Analysis Tools. 

3. Choose Nearest Neighbour Analysis. 

4. Select the point vector layer representing the bee’s locations. 

5. Click OK to view the result.  

In this case, the observed mean distance between nearest 

neighbours is 1356 meters. If the distances between different points 

(or groups of points) are of interest, the Distance matrix function can 

be useful:  

The COLOSS BEEBOOK: GIS  41 

1. Go to Vector. 

2. Select Analysis Tools. 

3. Choose Distance Matrix. 

4. Select the bees_colony_locations.shp as both input and target 

vector layer. 

5. Select the field ID as unique field (Fig. S 107).  

This function could also be performed using two different point 

layers, or using the same layer but different ID fields. 

6. Click OK to perform the calculation and view the result.  

The resulting delimited text file contains a list of all point 

combinations and the distance (computed in map units, thus meters 

in our example) in-between these points. In case of our honey bee 

locations, the maximal distance (12.5 kilometres) is between the 

honey bee colony Nr. 12 and 20, the minimal distance is only 484.5 

meters (between ID 1 and 16). 

 

7.8.3. Example 3: Computing intersections between a DEM 

and planes 

GIS is very useful for applications in natural sciences and a variety of 

tools are provided, e.g. for visibility analysis or to delimit watersheds, 

calculate flow paths, or even simulate natural hazards. This example 

demonstrates a very specific function, based on the qgSurf plugin for 

QGIS:  

1. Load and activate the plugin qgSurf (see section 7.1.3.). 

2. Go to Plugins. 

3. Select qgSurf. 

4. Select the DEM ASTER30_dem_CH1903 and choose source 

point for the plane (e.g. around Fribourg 

578000/183000/627).  

5. Play around with the values for orientation and inclination of 

the plane and calculate the intersections (Fig. S 108).  

6. Save the output as point or line shapefile.  

To analyse spatially related processes in more detail or for 

modelling, functions within GRASS GIS (http://grass.osgeo.org, 

Neteler and Mitasova, 2008) or SAGA (http://www.saga-gis.org) can 

be useful. To access these, GRASS and/or SAGA have to be installed 

on your computer and within QGIS the SEXTANTE Toolbox plugin 

(http://plugins.qgis.org/plugins/sextante) needs to be installed and 

configured correctly (see QGIS Development Team, 2013). If you 

work with R, the plugin Spatial Data Analysis for Point Pattern 

(SDA4PP) might also be a good option (see section 7.1.3.). 

 

7.9. Case study – zonal statistics with land cover 

properties 

Until now, several concepts and tools in QGIS have been introduced. 

Now, to combine some of the different tasks discussed, a case study 

will be presented. Within this short case study, geostatistical 

relationships between honey bee colonies and land cover properties 

will be calculated. The content of this case study is equal to the one 

for ArcGIS (see section 6.9.), but adapted to the tools of QGIS. The 
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prerequisites for this case study include an opened QGIS project (see 

sections 7.3.1. and 7.3.3.) with a point vector layer (e.g. the honey 

bee colony locations bees_colony_locations.shp, created in section 

7.3.3.1.) and a buffer polygon layer (e.g. bees_colony_locations_ 

buffer.shp, created in section 7.6.1.). For more information about this 

case study see section 6.9. 

 

7.9.1.  Downloading and extracting 

First we need land cover information for the region around Fribourg. 

If you have already downloaded the CLC06 dataset for the ArcGIS 

case study (see section 6.9.), skip the following paragraph and 

continue with step 4.  

1. Download the dataset g100_06.zip (CLC06 – 100 m) from the 

website http://www.eea.europa.eu/data-and-maps/data/

corine-land-cover-2006-raster-2  to a local directory (e.g. on 

the Desktop).  

2. Unzip the file g100_06.zip with a file archiving program of 

your choice (if you need additional software for this task, the 

program “7-zip” is a good choice: www.7-zip.org) into your 

QGIS working directory (e.g. “BeeBook_data”).  

3. Navigate to the raster g100_06.tif in QGIS Browser to open 

the tab Metadata. For a first visual impression of the data, 

you can also check out the Preview tab.  

From step 3 you see that CLC06 is a 1 band raster dataset with 8 

bit unsigned integer values (that correspond to different land cover 

categories) at 100 m horizontal resolution. Because it covers all 

Europe, the CLC06 raster is quite big and the rendering on the screen 

may take some time. We will improve the performance by clipping on 

the extent of interest (see steps 15-22).  

 

7.9.2. Projecting data into another coordinate reference 

system (CRS) 

The coordinate system is different (ETRS89 / ETRS-LAEA, EPSG-code 

3035) from that one of Switzerland, and for our purpose its best to 

bring it into the same coordinate reference system as the other layers 

(CH1903 / LV03).  

4. Switch to QGIS Desktop. 

5. Open the menu Raster. 

6. Choose Projections. 

7. Click Warp (Reproject). 

8. Select the raster image g100_06.tif as Input file. 

9. Choose a name and destination for the Output file (e.g. 

g100_06_ch1903.tif). 

10. The Source SRS should be automatically detected (ETRS89 / 

ETRS-LAEA), but the Target SRS has to be defined: click 

Select > filter for “CH1903 / LV03” and select the remaining 

CRS listed. 

11. Confirm with OK. The EPSG-codes should be set 

corresponding to Fig. S 109.  
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12. Choose the Resampling method Near because we have 

categorized data and want to keep the original integer values 

(see section 7.5.3.). 

13. Activate the checkbox Load into canvas when finished.  

14. Click OK. The projection process of large raster datasets can 

take several minutes depending on the computer processing 

power, so please be patient. 

  

7.9.3. Clipping to study area extent 

The resulting raster g100_06_ch1903.tif still covers all Europe, so we 

will now clip it to the extent of our polygon layer commune_boundary_ 

FR.shp.  

15. Open Raster. 

16. Select Extraction. 

17. Open Clipper. 

18. Select g100_06_ch1903.tif as Input file.  

19. Choose CLC06_Fribourg.tif as Output file name.  

20. Choose Extent within the Clipping mode and enter the 

minimum and maximum values for x and y according to Fig. S 

110 (xMin: 564835, yMin:168930, xMax: 593200, yMax: 

196915). To look up these values, double-click the layer 

commune_boundary_FR.shp in the Map Legend > Layer 

Properties >  Metadata. In GIS, minimum and maximum x 

and y values can also be obtained manually by hovering over 

a location on the map and reading the x and y values from 

the bottom right-hand corner of the screen (Fig. S 110). 

21. Activate the checkbox Load into canvas when finished.  

22. Click OK to start the clipping process. 

23. After the clipping has finished, remove the big layer 

g100_06_ch1903.tif from the Map Legend.  

24. The result should then look similar to Fig. S 111. 

 

7.9.4. Raster layer styling and predefined colour maps  

The layer CLC06_Fribourg.tif is now quite handy for our purpose, but 

so far we do not know for what the numbers (raster values) stand for 

(see Fig. S 111). Luckily, a colour map is provided by the European 

Environment Agency (EEA) and can be loaded into QGIS (similar to 

the ArcGIS layer file, see section 6.9.4. for more information): 

25. Double-click on the layer CLC06_Fribourg in the Map Legend 

to open its Layer Properties. 

26. Navigate to the Tab Colormap and Click the Symbol         

Load color map from file. 

27. Navigate to the folder that you have unzipped in step 2 (e.g. 

CORINE_2006_100m), select the text file clc_legend_qgis.txt 

and click Open.  

28. Click Apply (see Fig. S 112) and close the Layer Properties 

with OK.  

Note that the raster values do not correspond with the numbers 

(categories) indicated in the labels (Fig. S 112). You can verify this by 
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using the Identify Features button        and comparing this with the 

entries in the Map Legend. This might be a little confusing, but the 

reason is of technical nature: the official CLC06 land cover category 

numbers (50 in total) ranging from 111 to 999 cannot be displayed 

with a single band 8-bit integer raster dataset, where the range of 

raster values is limited to 0-255. Of course a 32-bit floating-point 

raster image could be used to display the whole range from 111 to 

999, but then the dataset would become almost 4 times larger and 

unhandy for download, storage and analysis. In the following tasks 

we will make use of numbers written in the labels of 

CLC06_Fribourg.tif.  

 

7.9.5. Conditional expressions using the raster calculator 

Let’s now analyse the area covered by some land use types of interest 

(arable land, forests) within the buffer zones of our honey bee 

colonies (see section 6.9.6. for more information).   

29. Open the menu Raster > Raster calculator. 

30. Combine Raster bands and Operators until the Raster 

calculator expression equals “CLC06_Fribourg@12 = 

211” (211 is the raster value for “non-irrigated arable land in 

the CLC06 dataset). 

31. Specify an Output layer, e.g. CLC06_class211.tif. 

32. Activate the Raster band CLC06_Fribourg@1 again and click 

Current layer extent to make sure that the output layer has 

the same extent as the source.  

33. Verify that the parameters are set according to Fig. S 113 and 

click OK to start the calculation. 

34. Double-click on the new greyscale Layer CLC06_class211 to 

open the Layer Properties > Tab Style. 

35. Check Estimate (faster) within Load min/max values from 

band and click Load, select Stretch to MinMax in the Contrast 

enhancement (see section 7.3.3.). 

36. Click Apply to make the layer styling effective and close the 

Layer Properties dialog with OK.  

37. Repeat steps 29 to 36 with the following raster values: 24 

(class 312, Coniferous forest) and 25 (class 313, Mixed 

forest).  

 

7.9.6. Zonal statistics of land cover values within buffers 

The newly created raster images contain zones with the value 1 

(where the Raster calculator expression was true) and 0, where the 

expression was false. This binary classification can now be used to 

calculate the percentage of each land cover class within any polygon 

layer, e.g. the honey bee colony buffers (also see section 6.9.7.): 

38. Open the menu Raster > Zonal statistics > Zonal statistics.  

39. Choose one of the newly created binary raster images (e.g. 

CLC06_class211.tif) as input Raster layer.  

40. Select bees_colony_locations_buffer.shp as input Polygon 

layer containing the zones. 
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41. Choose an appropriate column prefix (e.g. the land cover 

class “211”) and Click OK.  

42. Repeat steps 38 to 41 for the other input rasters (choosing 

appropriate filenames for the results, see Fig. S 114). 

Opening the attribute table of the layer bees_colony_locations_ 

buffer.shp, you see new fields at the end: The field “211mean” 

represents the average percentage of the land cover category “non-

irrigated arable land” within the respective buffer (honey bee colony).  

 

7.9.7. Visualisation of attribute values 

The proportion of the three land cover categories can be used for any 

symbolisation and vector calculation, but also visualized within a 

simple chart: 

43. Open Plugins > Chart Maker > Chart Maker. If you don’t see 

this entry, you probably have to install or enable first the 

Chart Maker plugin (see section 7.1.3.). 

44. Select the Vector layer bees_colony_locations_buffer.shp. 

45. Set the attribute fields for the X and Y axis you want to 

display (e.g. the ID for X and a land cover percentage for Y). 

46. Click Plot chart and look at your chart.  

47. Feel free to display all land cover categories you have 

processed by incrementing the number of series (see Fig. S 115).  

48. If you want, you can save the chart as picture file.  

 

7.9.8. Mathematical operations using the field calculator 

Within most of the honey bee colony buffers there are also other land 

cover categories that can be calculated using the following procedure:  

49. Right-click on bees_colony_locations_buffer.shp in the Map 

Legend > Open Attribute Table. 

50. Toggle on the editing mode with the button       . 

51. Open the Field calculator        . 

52. Make sure the checkbox Create a new field is activated and 

specify an Output field name (e.g. “other”).  

53. Change the Output field type to decimal. 

54. Increase the Precision to 3.  

55. Combine the Attribute Fields and Values and different 

operators so that the resulting Expression equals 1-

("211mean"+"312mean"+"313mean") (see Fig. S 116.). 

56. Click OK to perform the calculation and have a look at the 

new field created on the right within the attribute table..  

57. Repeat steps 51 to 56 and add a new field (type decimal) 

called “sum” that summarizes all 3 land use categories 211, 

312 and 313 (the Expression should equal 

211mean"+"312mean"+"313mean"). 

58. Toggle off the editing mode with the button        . 

The resulting attribute field “other” represents the remaining area 

not covered by the CLC06 categories 211,312, and 313 relative to the 

total area of the polygon layer. The field “sum” summarizes the 

relative area covered by these three land cover categories of interest. 

D
o
w

n
lo

ad
ed

 b
y
 [

5
4
.2

0
9
.1

4
0
.2

0
7
] 

at
 1

1
:1

6
 2

6
 A

p
ri

l 
2
0
1
6
 



7.9.9. Joining attributes from other vector layers 

For visualisation purposes (see map creation in section 7.10.) we must 

join the land cover percentage per honey bee colony buffer (see sections 

7.9.6. and 7.9.8.) to the original point layer bees_colony_locations.shp 

(see 6.9.8. for more information). To do this:  

59. Double-click on bees_colony_locations.shp in the Map Legend 

to open its Layer Properties. 

60. Switch to the Tab Joins. 

61. Click the button       to add a join to another vector layer.  

62. Select bees_colony_locations_buffer.shp as Join layer (Fig. S 177). 

63. Make sure the Join and Target fields are set to their identifier 

“ID”.  

64. Leave unchecked both of the checkboxes and click OK.  

65. Click OK to close the Layer Properties.  

Congratulations, you have finished your first geo-statistical 

analysis with QGIS. The next section is about the creation of maps. 

 

7.10. Map creation 

Creating maps with QGIS is similar to the procedure with other GIS 

software like ArcMap. This section collects the most important steps 

from managing geographic data to its visualisation (see section 2.3.3.) 

and requires the results of the case study (see section 7.9.). 

 

7.10.1. Layer styling and labelling 

Some basic settings in the Layer Properties for styling were already 

discussed in this tutorial (see sections 7.3.4. and 7.3.5.). Based on 

this experience, we will look at some more techniques to visualise 

different geometry types and attribute information together: 

1. Add the vector layer commune_boundary_FR.shp to the QGIS 

project (see section 7.3.3.). 

2. Double-click this layer in the Map Legend to open the Layer 

properties. 

3. Select Style. 

4. Select Graduated instead of Single Symbol. 

5. Choose an attribute (e.g. “Shape_Area”). 

6. Choose a number of Classes (e.g. 7) and the Mode Natural 

Breaks (Jenks). 

7. Choose colour ramp (e.g. “BuPu”). 

8. Click Classify.  

9. Click Apply (the Layer Properties can stay open).  

As an intermediate result, all polygons (representing different 

municipalities) are filled with a colour from the chosen spectrum 

corresponding to the chosen attribute (e.g. “Shape_Area”). This is 

already a good start, but perhaps the map should also provide the 

names of the communes?  

10. Switch to the Label tab (Fig. S 118). 

11. Activate the checkbox to display labels. 

12. Choose an attribute field that should be displayed (e.g. 

“GEMNAME”). 
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13. Feel free to adjust font size and colour or the placement 

options below.  

14. Click OK. 

15. Activate and select the layer 

bees_colony_locations_buffer.shp created in section 7.6.1. 

16. Place it at least one level higher than 

commune_boundary_FR.shp. 

17. Open again the Layer Properties. 

18. Select the Style tab. 

19. Click the button Change. 

20. Choose Outline: Simple line as Symbol layer type. 

21. Select a dark colour (e.g. black), a Pen width of about 0.25 

and Dot Line as Pen style. Confirm with OK. 

22. Set the transparency to about 30%.  

23. Close the Layer Properties of bees_colony_locations_buffer.shp. 

24. Move the layer bees_colony_locations.shp on top of the Map 

Legend and open its Layer Properties. 

25. Not only do colours and attributes matter for the visualisation 

of spatial data, but also size. To demonstrate this, select the 

size 5, click Advanced > Size scale field and choose an 

attribute field of your choice (e.g. “sum”).  

26. Adjust the Size to reach a good result on the Map View. The 

honey bee colonies close to the city of Fribourg have now the 

smallest symbols, the ones closer to arable land and forests 

are bigger.   

27. Switch to tab Diagrams (Fig. S 119). 

28. Activate the checkbox Display diagrams and choose Pie chart 

as Diagram type. 

29. Set the Size to about 8 mm, the Placement AroundPoint with 

a Distance of 6.  

30. Now add some content for the pie charts: Use the Button       

to add the fields 211mean, 312mean, 313mean and other 

(see section 7.9.). The colours can be adjusted by double-

clicking on the coloured bar.  

31. Make the changes permanent by clicking Apply and close the 

Layer Properties with OK.  

32. Save the QGIS project (and all the layer styling you have done 

so far) by the menu File > Save.  

The result (Fig. S 120) is already a good start for a first 

visualization of geodata and it will serve as an example for the next 

paragraphs describing map creation functions.  

In some cases it makes sense to save the layer symbology not 

only within a project, but also for different layers. This can be done 

layer by layer at the bottom of the Layer Properties dialog (see Fig. S 

118) using the button Save Style. This will safeguard all styling 

information in a *.qml-file. You can import these styles later also into 

other projects and apply the styles to more layers (Layer Properties > 

Load Style) – so this is probably the most important time-saver for 

larger mapping projects within QGIS.  
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7.10.2. Print composer 

The Print Composer is the main mapping program within QGIS, 

equivalent to the layout view of ArcMap (see section 6.10.1.).   

1. Click File. 

2. Select New Print Composer and a new window opens. 

3. Select Layout. 

4. Choose Add Map in the menu on top.  

5. Draw a rectangle to the map canvas below to define the map 

position.  

Within the Item Properties to the right you can now see the 

dimensions and the scale of your map. To get familiar with the Print 

Composer (Fig. S 121), look at all the buttons on top and try to: 

 Move or change the map extent using the Select/Move Item 

button  

 Move the map content within the frame with the Move Item 

button  

 Save the current map as template using the button        . 

A map like this may be suitable for certain tasks, but it is not 

complete. In the next section, it will be shown how additional map 

elements can be added. 

 

7.10.3. North arrow, scale bar, legend, title, labels 

The final map should provide information about the map scale and 

orientation and explain the map content. Let’s now add the most 

common map elements using the QGIS Print Composer:  

1. Open the menu Layout. 

2. Choose Add Image and click somewhere on the map canvas 

(all items can be moved afterwards).   

3. Select a north arrow of your choice (within the set of 

preloaded images).  

4. Now add a scale bar (Layout > Add Scalebar) and click 

somewhere on the map. A basic scale bar will show up and 

within the Item Properties the unit label must be defined (e.g. 

m or meters). There are a lot of other optional settings.  

5. Up to now we have no information about the different map 

elements shown, so we add a map legend. Go to Layout. 

6. Select Add Legend, click somewhere on the map canvas and 

customize the items listed.  

7. The names of the different layers can be changed in QGIS 

desktop by a right click to the Map Legend. 

8. Select Rename.  

9. A map needs a title, or sometimes additional labels to explain 

some features. Go to Layout. 

10. Click Add Label and place it on top of the map. Labels and 

legend items can be formatted and changed within the Item 

Properties. 

11. Last but not least, try to also add a grid according to the CRS 

used (in this case it is metric, CH1903/LV03). Click with the 

Item selection tool on the map frame and locate within the 

Item Properties the section Grid.  
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12. Activate the checkbox and experiment with the settings below. 

At the end, the map should look somehow similar to Fig. S 122. 

13. Save the template again, and be proud of your first map 

made with QGIS! 

 

7.10.4. Exporting a map 

Maps can be exported from the QGIS Print Composer in different 

ways:  

 In most cases the aim will be to create a printable PDF file. 

Go to File and select Export as PDF. By default the settings 

should be already in the range for good printing results.  

 For special map dimensions or to change the resolution 

settings, go to the Composition tab beside the Item 

Properties.  

 Of course a map can also directly be sent to a printer device 

(File > Print).  

 For a special purpose it might make sense to export a map to 

a vector or raster image. The two corresponding functions are 

File > Export as SVG and File > Export as Image, respectively.  

 

7.10.5. Cloud mapping and sharing maps online 

By the means of the QGIS Cloud plugin (see section 7.1.3. and Table 

4) developed by Sourcepole (http://www.qgiscloud.com), users can 

easily publish their own maps directly from QGIS desktop to a PostGIS 

2.0 database within a cloud online storage. There are also many other 

ways to share geodata and maps produced by open source GIS using 

Web Map (WMS) and Feature Services (WFS), for example by the 

means of the open source projects OpenLayers, MapServer or degree. 

The official website of the Open Source Geospatial Foundation 

(OSGEO, http://www.osgeo.org) provides a good overview about the 

different projects and their technical capabilities. 

 

 
 

8. Future perspectives  
The main purpose of the paper was to stimulate spatial thinking in 

honey bee research by introducing the basic principles and methods 

of GIS. With an introduction to the basics of GIS, we hope that more 

honey bee researchers will build on techniques already developed in 

the native bee domain, and discover new geospatial methods for 

exploring the relationships between honey bees and their environment. 

As of now, relatively few honey bee researchers have studied the 

effects of how environmental characteristics and mechanisms have 

affected honey bee health, abundance, and honey production 

(Berardinelli and Vedova, 2004; Naug, 2009; Henry et al., 2012). 

Because of the recent colony losses in many parts of the world 

(Carreck and Neumann, 2010; Williams et al., 2010), it is important to 

mechanistically study and attempt to discover new factors which 

directly and indirectly affect honey bee populations (Naug, 2009) from 

both broad and local scales.    
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GIS and spatial analyses have been used to make great progress 

in regards to studying the effects of landscape characteristics in 

research about native bees (Arthur et al., 2010; Biesmeijer et al., 2006; 

Chifflet et al., 2011; Choi et al., 2012; Fitzpatrick et al., 2007; Giannini 

et al., 2012; Kremen, 2002; Kremen et al., 2004; Watson et al., 2011; 

Williams et al., 2012). Various researchers have looked at the links 

between land cover properties and their effects on bees using satellite 

imagery to perform land cover classifications (Arthur et al., 2010; 

Kremen et al., 2004) and aerial imagery to quantify land cover 

properties (Watson et al., 2011) using GIS. Positive correlations were 

established between native bees and their surrounding landscapes, 

perhaps most notably the link between wooded areas and the increase 

in bee populations and abundance. In terms of climate, Giannini et al. 

(2012) have used GIS to help reveal that native bees populations are 

decreasing because of a changing climate and are projected to continue 

to decline in the future due to the loss of suitable habitats.   

Because of the obvious similarities between native bees and 

honey bees, it is assumed that similar relationships will be found 

between honey bees and their surrounding landscapes and changing 

climate. Naug (2009) was one of the first to use GIS to test the 

effects of land cover changes on honey bee colony health and 

productivity. By looking at the effects of nutritional stress due to 

habitat loss in the U.S.A., Naug (2009) established that the relative 

extent of open land area is an important predictor of colony losses, 

and that states with the largest open area proportions had higher 

honey yields, meaning that their honey bees were more productive. It 

is necessary to study these types of relationships from a broad scale 

in order to get a better general understanding of the overall processes 

linking honey bees to the surrounding environments. Research of this 

type can and should be expanded upon to explore more specific 

geographic regions as well as local scales. Climate research, similar to 

the work by Giannini et al. (2012), can also be conducted in GIS to 

study not only its effects on honey bees directly, but how changes in 

climate affect honey bee pathogens.  

In conclusion, there are numerous opportunities for expanding 

geospatial analyses in the honey bee domain and we hope that this 

paper will motivate and stimulate spatial thinking for researchers.  
 

 

9. Acknowledgements 

We would like to acknowledge the Swiss National Science Foundation 

(SNF) for providing funds to the authors and Swisstopo for the use of 

their data through a contract with the University of Fribourg for 

research purposes. We would like to thank Geoffrey Williams, Jamie 

Ellis, and Vincent Dietemann for suggesting the idea for this paper, 

and Christina Zweifel for stepping into the world of GIS to test the 

tutorials. The COLOSS (Prevention of honey bee COlony LOSSes) 

network aims to explain and prevent massive honey bee colony 

losses. It was funded through the COST Action FA0803. COST 

(European Cooperation in Science and Technology) is a unique means 

46 Rogers, Staub 

for European researchers to jointly develop their own ideas and new 

initiatives across all scientific disciplines through trans-European 

networking of nationally funded research activities. Based on a pan-

European intergovernmental framework for cooperation in science and 

technology, COST has contributed since its creation more than 40 years 

ago to closing the gap between science, policy makers and society 

throughout Europe and beyond. COST is supported by the EU Seventh 

Framework Programme for research, technological development and 

demonstration activities (Official Journal L 412, 30 December 2006). 

The European Science Foundation as implementing agent of COST 

provides the COST Office through an EC Grant Agreement. The 

Council of the European Union provides the COST Secretariat. The 

COLOSS network is now supported by the Ricola Foundation - Nature 

& Culture.  
 

 

10. References 

ARCTUR, D K; ZEILER, M (2004) Designing geodatabases: case studies 

in GIS data modeling. ESRI Press; Redlands, USA. 411 pp. 

ARTHUR, A D; LI, J; HENRY S; CUNNINGHAM, S A (2010) Influence of 

woody vegetation on pollinator densities in oilseed Brassica fields 

in an Australian temperate landscape. Basic and Applied Ecology 

11(5): 406-414.  

 http://dx.doi.org/10.1016/j.baae.2010.05.001 

BERARDINELLI, I; VEDOVA, G D (2004) Use of GIS in the 

management of apiculture: preliminary note. APOidea - Rivista 

Italiana di Apicoltura. v. 1(1): 31-36. Available at: http://

agris.fao.org/agris-search/search/display.do?f=2007/IT/

IT0639.xml;IT2006601932 [accessed 10/01/13].  

BIESMEIJER, J C; ROGERS, S P M; REEMER, M; OHLEMÜLLER, R; 

EDWARDS, M; PEETERS, T; SCHAFFERS, A P; POTTS, S G; 

KLEUKERS, R; THOMAS, C D (2006) Parallel declines in pollinators 

and insect-pollinated plants in Britain and the Netherlands. 

Science 313(5785): 351–354.  

 http://dx.doi.org/10.1126/science.1127863 

BONHAM-CARTER, J M (1994) Geographic Information Systems for 

geoscientists: modelling with GIS. Elsevier; Oxford, UK.  

 420 pp. 

BURROUGH, P A; MCDONNELL, R A (1998) Principles of Geographical 

Information Systems. Oxford University Press; Oxford, UK. 333 pp.  

CAMPBELL, J B (2002) Introduction to remote sensing (3rd Edition). 

Guilford Press; London, UK. 621 pp.  

CARRECK, N L; NEUMANN, P (2010) Honey bee colony losses. Journal 

of Apicultural Research  49(1): 1-6.  

 http://dx.doi.org/10.3896/IBRA.1.49.1.01  

CHIFFLET, R; KLEIN, E K; LAVIGNE, C; LE FÉON, V; RICROCH, A E; 

LECOMTE, J; VAISSIERE, B E (2011) Spatial scale of insect-

mediated pollen dispersal in oilseed rape in an open agricultural 

landscape. Journal of Applied Ecology 48 (3): 689-696.  

 http://dx.doi.org/10.1111/j.1365-2664.2010.01904.x 

D
o
w

n
lo

ad
ed

 b
y
 [

5
4
.2

0
9
.1

4
0
.2

0
7
] 

at
 1

1
:1

6
 2

6
 A

p
ri

l 
2
0
1
6
 



CHOI, M-B; KIM, J-K; LEE, J-W (2012) Increase trend of social 

hymenoptera (wasps and honey bees) in urban areas, inferred 

from moving-out case by 119 rescue services in Seoul of South 

Korea. Entomological Research  42(6): 308-319.  

 http://dx.doi.org/10.1111/j.1748-5967.2012.00472.x 

CONOLLY, J; LAKE, M (2006) Geographical Information Systems in 

archaeology. Cambridge University Press; Cambridge, UK. 338 pp. 

DE SMITH, M J; GOODCHILD, M F; LONGLEY, P A (2007) Geospatial 

analysis: a comprehensive guide to principles, techniques and 

software tools. Troubador Publishing Ltd; Leicester, UK. 418 pp. 

ESRI (Environmental Systems Research Institute) (2013). Available at: 

www.esri.com.  

FITZPATRICK, U; MURRAY, T E; PAXTON, R J; BREEN, J; COTTON, D; 

SANTORUM, V;  BROWN, M J F (2007) Rarity and decline in 

bumble bees - a test of causes and correlates in  the Irish fauna. 

Biological Conservation 136(2): 185-194.  

 http://dx.doi.org/10.1016/j.biocon.2006.11.012 

GIANNINI, T C; ACOSTA, A L; GARÓFALO, C A; SARAIVA, A M; ALVES

-DOS-SANTOS, I; IMPERATRIZ-FONSECA, V L (2012) Pollination 

services at risk: bee habitats will decrease owing to climate 

change in Brazil. Ecological Modelling  244(0): 127–131.  

 http://dx.doi.org/10.1016/j.ecolmodel.2012.06.035 

HENRY, M; FRÖCHEN, M; MAILLET-MEZERAY, J; BREYNE, E; ALLIER, F; 

ODOUX, J-F; DECOURTYE, A (2012) Spatial autocorrelation in 

honey bee foraging activity reveals optimal focus scale for 

predicting agro-environmental scheme efficiency. Ecological 

Modelling 225(0): 103-114.  

 http://dx.doi.org/10.1016/j.ecolmodel.2011.11.015 

KOZAK, K H; GRAHAM, C H; WIENS, J J (2008) Integrating GIS-based 

environmental data into evolutionary biology. Trends in Ecology & 

Evolution 23(3): 141–148. http://dx.doi.org/10.1016/j.tree.2008.02.001 

KREMEN, C (2002) Crop pollination from native bees at risk from 

agricultural intensification. Proceedings of the National Academy 

of Sciences 99(26): 16812-16816.  

 http://dx.doi.org/10.1073/pnas.262413599 

KREMEN, C; WILLIAMS, N M; BUGG, R L; FAY, J P; THORP, R W (2004) 

The area requirements of an ecosystem service: crop pollination 

by native bee communities in California. Ecology Letters  7(11): 

1109-1119. http://dx.doi.org/10.1111/j.1461-0248.2004.00662.x 

LEE, J; WONG, D W S (2001) Statistical analysis with ArcView GIS. 

John Wiley & Sons; New York, USA. 192 pp. 

LONGLEY, P; GOODCHILD, M F; MAGUIRE, D J; RHIND, D W (Eds) (1999) 

Geographical Information Systems: principles, techniques, applications 

and management (2nd Ed.), Volume 1. Wiley; New York, USA. 580 pp. 

NAUG, D (2009) Nutritional stress due to habitat loss may explain 

recent honey bee colony collapses. Biological Conservation 142

(10): 2369-2372. http://dx.doi.org/10.1016/j.biocon.2009.04.007 

NETELER, M; MITASOVA, H (2008) Open source GIS: a GRASS GIS 

approach (3rd Ed.). The International Series in Engineering and 

Computer Science, Volume 773. Springer; New York, USA. 406 pp.  

The COLOSS BEEBOOK: GIS  47 

ORMSBY, T; NAPOLEON, E J; BURKE, R; GROESSL, C; BOWDEN, L 

(2010) Getting to know ArcGIS: desktop. ESRI Press; Redlands, 

USA. 584 pp. 

PIRK, C W W; DE MIRANDA, J R; FRIES, I; KRAMER, M; PAXTON, R; 

MURRAY, T; NAZZI, F; SHUTLER, D; VAN DER STEEN, J J M; VAN 

DOOREMALEN, C (2013) Statistical guidelines for Apis mellifera 

research. In V Dietemann; J D Ellis; P Neumann (Eds) The 

COLOSS BEEBOOK, Volume I: standard methods for Apis mellifera 

research. Journal of Apicultural Research 52(4):  

 http://dx.doi.org/10.3896/IBRA.1.52.4.13 

POGODZINSKI, J M; KOS, R M (2012) Economic development and 

GIS. ESRI Press; Redlands, USA. 229 pp. 

QGIS Development Team (2013) QGIS 1.8.0 Geographic Information 

System User Guide. Open Source Geospatial Foundation Project. 

Electronic document: http://docs.qgis.org/1.8/pdf/QGIS-1.8-UserGuide-en.pdf 

RIGAUX, P; SCHOLL, M O; VOISARD, A (2002) Spatial databases: with 

application to GIS. Morgan Kaufmann; San Francisco, USA. 411 pp. 

SCHMANDT, M (2009) GIS Commons: an introductory textbook on 

Geographic Information Systems. Available at:  

 http://giscommons.org/  

SEEGER, H (1999) Spatial referencing and coordinate systems. In 

Longley, P; Goodchild, M F; Maguire, D J; Rhind, D W (Eds) 

Geographical Information Systems: principles, techniques, 

applications and management (2nd Ed.), Volume 1. Wiley; New 

York, USA. pp 427-436. 

SNYDER, J P (1987) Map projections - a working manual. United 

States Government Printing Office; Washington, USA. 410 pp. 

SWISSTOPO (2013) Federal Office of Topography. Available at: 

www.swisstopo.ch.  

WADE, T; SOMMER, S (2006) A to Z GIS: an illustrated dictionary of 

geographic information systems. ESRI Press; Redlands, USA. 268 pp. 

WATSON, J C; WOLF, A T; ASCHER, J S (2011) Forested landscapes 

promote richness and abundance of native bees (Hymenoptera: 

Apoidea: Anthophila) in Wisconsin apple orchards. Environmental 

Entomology 40(3): 621-632. http://dx.doi.org/10.1603/EN10231 

WILLIAMS, G R; TARPY, D R; VANENGELSDORP, D; CHAUZAT, M-P; 

COX-FOSTER, D L; DELAPLANE, K S; NEUMANN, P;  PETTIS, J S; 

ROGERS, R E L; SHUTLER, D (2010) Colony Collapse Disorder in 

context. BioEssays 32(10): 845-846.  

 http://dx.doi.org/10.1002/bies.201000075 

WILLIAMS, N M; REGETZ, J; KREMEN, C (2012) Landscape-scale 

resources promote colony growth but not reproductive 

performance of bumble bees. Ecology 93(5): 1049-1058.  

 http://dx.doi.org/10.1890/11-1006.1 

WONG, D W S; LEE, J (2005) Statistical analysis of geographic 

information with ArcView GIS and ArcGIS. Wiley; New Jersey, 

USA. 446 pp.  
 

D
o
w

n
lo

ad
ed

 b
y
 [

5
4
.2

0
9
.1

4
0
.2

0
7
] 

at
 1

1
:1

6
 2

6
 A

p
ri

l 
2
0
1
6
 



Journal of Apicultural Research 52(4)                                                                  © IBRA 2013 
 

D
o
w

n
lo

ad
ed

 b
y
 [

5
4
.2

0
9
.1

4
0
.2

0
7
] 

at
 1

1
:1

6
 2

6
 A

p
ri

l 
2
0
1
6
 


