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DISCLAIMER 

We have attempted to write this manual as accurately as possible. However, mistakes 

are bound to occur, and we reserve the right to make changes to EEProbe or the 

EEProbe Databrowser, which may render parts of this manual invalid. We assume no 

liability as a result of the use or application of this product. 

No part of this manual may be copied or reproduced without the express permission 

of the authors. 

 

 

 

 

 

 

 

 

NOTICE 

EEProbe, the EEProbe Databrowser, the incorporated EEP modules and any 

auxiliary scripts are research software. It is not to be used as the sole or partial basis 

for clinical diagnosis or treatment. 
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ABOUT EEPROBE 
 

 

‘EEP’ was developed at the Max-Planck Institute for Cognitive Neuroscience (MPI-
CNS), Leipzig, Germany. The ‘ERP Evaluation Package’ consists of a number of 
modules (programs) for advanced ERP processing and analysis. This package is 
available exclusively through ANT Software b.v., Enschede, The Netherlands, under 
the name EEProbe. Further improvements to the package are developed at both 
MPI-CNS and ANT. 

In this manual, we will use the terms 

EEProbe programs, to refer to the set of (command line) programs, and 

EEProbe Databrowser, to refer to the windowing program that puts a graphical user 
interface (GUI) around some of the EEProbe programs. 
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1. EEPROBE DATABROWSER 

Overview  

• Introducing the EEProbe Databrowser 

• Installation procedure 
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1.1. Introducing the EEProbe Databrowser 
The EEProbe Databrowser is a program that provides a graphical user interface 
(GUI) to a sub-set of the EEProbe programs for ERP research.  

The Databrowser 

• acts like a ‘shell’ around the implemented EEProbe programs, 

• facilitates ‘browsing’ of your data in a well structured directory tree,  

• lets you work on selected data of multiple subjects/experiments, and 

• eases the learning and handling of the EEP configuration files 

 

The Databrowser adds a graphical window layer around the EEProbe programs. The 
program interfaces those EEProbe programs that are mostly used for the processing 
of ERP data. The incorporated functionality is designed after the EEProbe programs, 
and still uses the concept of configuration files (see Chapters 2 and 3). 

The Databrowser introduces you to EEProbe’s philosophy for file handling, using 
configuration files to store the settings of your data processing, and keeping your data 
well organized. EEProbe’s strength in quickly reviewing and processing a large 
number of files is very easy with the Databrowser.  

The EEProbe Databrowser cannot replace advanced scripting possibilities such as a 
‘Makefile’. However, it is quite easy to incorporate a shell-script in the graphical 
interface that allows you to repeat quickly a set of common procedures to your data. 

1.1.1. How to use this manual 

Section 1.2 of this chapter describes the installation procedures.  

If you want to learn about the general concepts of the Databrowser, read chapter 2. 

Use chapters 3 and 4 for reference about all implemented EEProbe functionality and 
the user interface dialogs as provided in the Databrowser. 

Chapter 5 demonstrates some typical ERP analysis procedures, based on an example 
data file. Use this to quickly familiarize yourself with the basic usage of the 
Databrowser. 

Read chapter 6 and further for some more ‘advanced’ topics. 

The appendices to this manual are for reference of the keyboard and mouse shortcuts 
as implemented in the Databrowser (Appendix A: page 96), a summary of the usage 
of regular expressions (Appendix B: page 100), and Appendix C: (page 101) contains 

some (technical) notes, advanced usage of the eeprobe startup script and copyright 

information. 

In this manual we will sometimes refer to the EEProbe Reference manual. This 
manual is available on-line in the Databrowser via the Help menu. Ready-to-print 

version of the manuals are available as .pdf files on the EEProbe installation CD. 

Contact ANT for additional information on printed materials. 

1.1.2. Further development 

The development team at ANT Software is ready to learn from your usage of the 
Databrowser; do not hesitate to contact us for feedback or ideas. Please take a 
moment to phrase your thoughts in an e-mail; mail to ‘eeprobe@ant-software.nl’. 
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1.2. Installation procedure 

1.2.1. Software requirements 

EEProbe and the EEProbe Databrowser run on a variety of Linux systems. For a 
selection of Linux distributions we have created custom installation files. 

The EEProbe software makes use of several ‘shared’ system libraries:  

  blas  
  lapack  
  openmotif  (or lesstif) 
  tkinter  (or python-tk) 
 

These libraries will be used in their ‘native’ version (specific/optimized per Linux 
distribution). The dependencies will typically be resolved automatically during the 
installation procedure. 

Python/tkinter 

It is not strictly required to install the python/tkinter software in your Linux system 
before running the EEProbe installation. You can also install these modules 
afterwards, please read section C.1.5 in Appendix C: of this manual. 

If your Linux distribution does not include the required installation files, please go to 

the /root or /tmp directory and run the following commands as ‘root’: 

 tar xvzf <mountpoint-of-your-cd>/Python/Python-2.2.2.tgz 

 cd Python-2.2.2 

 ./configure 

 make install 

 

(this requires that you have a proper Linux development environment, e.g., the 

packages gcc , tcl-devel) 

 

EEProbe installation files 

On the installation CD, EEProbe and the EEProbe Databrowser are present as rpm or 
deb files, which can be found on the installation media in sub-directories named e.g., 
Redhat9.0, Mandrake9.1. You can find the installation files in a subdirectory 

Install. The distribution-specific files are located in a sub-directory Extra on the 

EEProbe installation CD. 

Alternatively, you may have downloaded the file from the ANT web-site; you should 
select the appropriate files for your Linux distribution.  

Unpack the main installation file as user 'root':  

  tar xvzf eeprobe-3.2.tgz 

This will create the Install directory as mentioned below. 

The 'extra' shared libraries will be installed automatically if you have downloaded the 

file eeprobe-3.2-extra.tgz to the same directory (no need to unpack this file).  

Install as 'root' from the Install directory:  

  cd Install 

Check the rest of the procedure in the next paragraph.  
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1.2.2. Installation on Redhat, Mandrake or SuSE
1
 

Please locate the correct sub-directory for your Linux distribution on the EEProbe 

installation CD, go to the Install sub-directory and open a terminal (console) 

program. 

 

As user ‘root’, type the command: 

  ./install-rpm.sh 

 

This will install EEProbe, and will ask you several questions related some optional 
installation steps: 

Do you use an EEProbe dongle (key-lock) on this computer? [y] 

The package "usbutils" must be removed for USB dongles, OK ? [y] 

You must answer these question with ‘y’ (or just <Enter>) if you are using an 
EEProbe USB dongle. 

 

Copy the shell environment settings to /etc/profile.d ? [y] 

Copy the default app-defaults X settings to /usr/lib/X11/app-defaults ? [y] 

Answer these questions with ‘y’ to obtain the correct environment settings. 
Otherwise, the installation script will describe how to do this manually. 

 

Install the EEProbe Databrowser (requires Python2 and Tkinter2) (y/n)? [y] 

Type ‘y’ to install the EEProbe Databrowser (GUI): 

  /opt/eep/bin/eeprobe  (the startup script) 

  /opt/eep/eeprobe_gui  (contains the python scripts, default settings) 

 

Installation notes (rpm only) 

The install-rpm.sh script supports two arguments: 

  ./install-rpm.sh check 

Use this to check if EEProbe has some dependency problem in your Linux 
environment. 

  ./install-rpm.sh uninstall 

Use this command to uninstall EEProbe. 

1.2.3. Startup and licensing the software 

After the installation, restart your bash environment (typically a restart of the 

terminal is sufficient). 

As a normal user, type 

  eeprobe 

 

This will start the EEProbe Databrowser. 

                                                      
1 not tested on other distributions that use RPM 
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EEPROBE LICENSE 

 

In the EEProbe Databrowser, under the Help menu, you can start the 'EEProbe 
License' dialog. This dialog allows you to save the information that we need to 
provide you with a License. 

You will be asked to indicate if the (optional) EEProbe dongle should be checked for 
its license information. Answer ‘Yes’ when you have your dongle connected. 

Please save the text to a file 'license.info'. 

 

 

 

Figure 1-1 Save the EEProbe license information to a file. 

 

 

Alternatively, to license the software on your machine(s), run the command 

 

  licinf > license.info 

 

E-mail the resulting file 'license.info' to ANT Software at the e-mail address 
info@ant-software.nl (mailto:info@ant-software.nl) 

 

You will receive the license file in the reply mail. 

Copy this file (as user ‘root’) to /opt/eep/license.rc 

 

The current procedure for licensing the software typically includes an automatic 
license renewal procedure every year (via e-mail). 

 

© 2000-2003 A.N.T. SOFTWARE BV EEPROBE 3.1 11 



EEPROBE USER MANUAL  EEProbe Databrowser [ Installation procedure ] 

1.2.4. Per-user settings 

After installing the first start of the EEProbe Databrowser, you should be able to start 

it by typing the command "eeprobe" as a normal user.  

A special "settings" file is used that contains all user configurable settings. The 

Databrowser program automatically installs this file in $HOME/.eep directory at the 

first startup. Most of the settings are available through the ‘Tools’ menu, ‘Settings’. 

The settings file contains the default project directory, the layout of a new project and 
the default configuration files, the channel layout and other items. This will be 
explained on page 55 and further. 

After a new installation (or update) the startup script "eeprobe" can be used also to 

update your "settings" file, or for run-time optimization of the python scripts. 

Type 

  eeprobe --help 

 

for all available options. 

 

Customization of the display configurations 

The X-configuration files in /opt/eep/app-defaults are usually copied to 

/usr/lib/X11/app-defaults at installation time. This gives you proper default values 

for the display ‘look’ of EEProbe’s graphical programs. However, you can make a 

copy of the files in /opt/eep/app-defaults to your home directory to customize the 

display of  

• the continuous data viewer xcnt 

          ~/Xcnt 

• the average viewer xavr 

          ~/Xavr 

• the filter design program xfir 

          ~/Xfir 

• the EOG classification program xeog 

          ~/Xeog 

• the display configuration of the Databrowser2 - after the first start - is in 

          ~/.Xdefaults 

 

The environment settings for the Bourne Again Shell (bash) in 

  /opt/eep/scripts/setEnv.sh 

The environment settings for the C Shell (csh) in 

  /opt/eep/scripts/setEnv.csh 

(These files are copied to /etc/profile.d/eep.sh and /etc/profile.d/eep.csh at 

install time; however, if your Linux system does not have a /etc/profile.d 

directory, or simply because you prefer this, you can also include this in your own 

resource file (e.g. ~/.bashrc for the bash environment). 

                                                      
2 The icon for the Databrowser  - e.g., to put a shortcut on your X desktop - is available in the 
file /opt/eep/eeprobe_gui/eeprobe-icon.xpm 
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The environment setting LICENSE is by default set to 

  /opt/eep/license.rc 

 

However, the license file can be placed anywhere on the file system. Just update the 
LICENSE variable accordingly (alternatively, you can also use EEP_LICENSE as 
the environment variable). 
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2. USING THE EEPROBE DATABROWSER 

Usage summary 

• General description, files and directories, concepts 
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2.1. General description 

Startup … 

After installation, start the EEProbe Databrowser: from a terminal (console) window, 

type ‘eeprobe’, and the program window presents itself: 

 

Figure 2-1 EEProbe Databrowser startup screen. 

Your startup screen will probably be empty, because your directory structure may not 

contain a ~/data directory. In chapter 5 is explained how to create a new project, 

load some example data from the CD, and how to perform basic ERP analysis. 

2.1.1. Usage summary 

The ‘caption’ – the top line of the window – lists ‘EEProbe: /home/mvelde/data’. 
The indicated directory is the current project location, and can be a standard directory 
anywhere in the filesystem where you have read / write access. 

Menus. Immediately below the caption, you see the menus: File, Recording, View, 
Analyze, Tools, Scripts, and Help. The contents of the menus will be explained in the 
next paragraphs. 

Data browsing. The three window panes under ‘Experiment’, ‘Subject’, and 
‘Datafile’ are the space where you ‘browse’ your data. Use the mouse to click on an 
experiment and open the corresponding subject list. ‘Experiments’ and ‘subjects’ are 
standard directories. The third pane lists the datafile(s) of the selected subject. Click 
on a subject to open the corresponding datafile listing.  

Workset. The large pane on the bottom of the Databrowser window is used to list the 
‘Workset’, a list of files on which you want to perform a particular processing step. 
Open an experiment (click), open a subject (click), select a datafile and add it to the 
Workset (double-click, or <Enter>).  
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Most ‘View’ and ‘Analyze’ commands in the menus are only available after making 
a file selection in the Workset. Some default view commands are quickly accessed 
just by double-clicking on a file in the Workset, or by pressing <Enter>. 

2.1.2. Directory structure 

The EEProbe Databrowser uses a standard directory structure like this: 

 

 
 project 
    |___ experiment1 
    |       | 
    |       |_______ subject1 
    |       |            |___ datafiles 
    |       |_______ subject2 
    |       |            |___ datafiles 
    |       |_______ subject3 
    |                    |___ datafiles 
    |___ experiment2 
    |       | 
    |       |_______ subject1 
    |       |            |___ datafiles 
    |       |_______ subject2 
    |       | 
    |       |___ cfg 
    | 
    |___ experiment3 
    | 
    |___ cfg 
    |     |___ *.cfg, *.dat 
    |___ fir 
    |     |___ *.fir 
    |___ scripts 
          |___ *.sh, *.awk, *.tmpl, (etc) 

 

Figure 2-2 EEProbe directory structure. 

 

The experiments that are part of one project all share one configuration directory, 

‘cfg’, one directory ‘fir’ for filter files and one directory ‘scripts’ for custom 

scripts. These are not displayed in the ‘Experiment’ listbox of the Databrowser. 

Although the EEProbe Databrowser does not restrict you from having completely 
different experiments in one project, the best working practice is to include in one 
project only experiments that use ‘similar’ settings for data processing. For example, 
a P300 study may contain different conditioning with tones or pictures, but similar 
filtering and averaging settings. 

Note: It is highly recommended that subject directories be named with 4 characters, 

e.g., vp01, vp02, m101, n217. See also the general usage guidelines in the EEProbe 

Reference manual , Chapter 2 ‘Usage’. 

In each project, the cfg directory will contain some default configuration files. For 

example, the EEProbe Databrowser will use the settings in cntaverage.cfg for the 

Dialog window for the cntaverage program (see page 39). The default configuration 

files will be written upon creation of a new project.  

For the sub-directories representing ‘experiments’, also a ‘cfg’ directory may be 

present, which can be created through the Databrowser. 

© 2000-2003 A.N.T. SOFTWARE BV EEPROBE 3.1 16 



EEPROBE USER MANUAL  Using the EEProbe Databrowser [ General description ] 

2.1.3. Browsing your data 

Main screen 

 

Figure 2-3 The main screen of the Databrowser: browse through Experiments, 

Subjects, Datafiles, and process one or more files in the Workset. 

 

The window as shown in the picture above, is the main screen in which you will 
work with your files, where you will see the result files of your analyses. The upper 
three window panes show the project’s data, structured as Experiments, containing 
Subjects, containing Datafiles. 

Directory structure. As explained in the previous paragraph, the project structure 
reflects the directory/file structure on disk. Three special directories are not listed 

under Experiment: the cfg , fir and script directories. Furthermore, the 

Experiment and Subject windows only list directories, so any files located in an 
Experiment subdirectory are not shown in the Databrowser. 

Datafile listing of selected files. During the processing of data, the number of files for 
a particular subject can increase dramatically. Therefore, the listing of the subject’s 
datafiles can be filtered using the checkboxes ‘avr’, ‘cnt’, ‘trg’, ‘txt’, ‘ps/pdf’, and 
also using regular expressions. For example, you can also type ‘vp’ in the Select field 
to list only the files containing ‘vp’ in their name. Appendix B: on page 99 explains 
more about regular expressions, and summarizes the use of some special regexp 
characters. 

• click on an Experiment name to view the Subject list belonging to the 
experiment. 

• click on a Subject to open the Datafile listing. 
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• Double-click on a Datafile to add it to the Workset.  

o Or, press the <Enter> key to add the file selection to the Workset.  
Or, right-click with the mouse on the file selection, and choose ‘Add 
to Workset’ from the context menu.  

Tip 

You can add more files to the Workset at once using the mouse: 
you can use the Shift or Ctrl keys together with the mouse: hold 
the Shift key to extend the selection to the next file you click on, 

or hold the Ctrl key to add single files to the selection.  

After each processing step, you will often have some new output (result) file added to 
the Subject’s directory. Sometimes you have to ‘refresh’ the Datafile listing using the 
right-click mouse menu. 

As most data processing is performed on continuous and average data, these are the 
file types that you typically have to ‘Add to the Workset’ from the Datafile listing. 
The EEProbe commands in the View and Analyze menus are only available when a 
file with an appropriate file extension is selected in the Workset. For example, the 

‘View, Continuous’ is only available when only cnt files are selected. Also some 

commands in the Tools menu are only available when you have selected cnt or trg 

files. 

Edit Selected Files (text). You can use the Databrowser also to open text files, of a 
type/extension known to the Databrowser (i.e., as defined within the EEProbe file 

formats). For instance, you can open a trigger file (e.g., m101.trg) or rejection file 

(e.g., m101.rej) by using the menu entry ‘Edit Selected Files’ in the ‘View’ menu. 

First add the file to the Workset, and select the file; now the menu entry is enabled. 

View Postscript files. You can open through the View menu also the output postscript 
files as created from the xavr program (average viewer). 

Working with the ‘View’ and ‘Analyze’ menus 

The ‘Analyze’ menu is indicated below: 

 

Figure 2-4 The Analyze menu. Menu entries for 

continuous data files enabled. 

 

The ‘black’ entries in the ‘Analyze’ menu are the 

commands for continuous (cnt) files. The ‘grayed’ items in 

this picture are only available when average files (avr) are 

selected in the Workset. 

Below, you see the ‘View’ menu, again with only the 

options for cnt files enabled: 
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Figure 2-5 The View menu. Menu entries for continuous data files enabled. 

 

Figure 2-6 Start the xcnt viewer for continuous data from the Databrowser. 

 

© 2000-2003 A.N.T. SOFTWARE BV EEPROBE 3.1 19 



EEPROBE USER MANUAL  Using the EEProbe Databrowser [ General description ] 

To start the viewer for continuous data files, follow the actions as presented in Figure 

2-5 and Figure 2-6: select ‘Continuous’ from the ‘View’ menu, and the xcnt viewer 

will be started as shown.  

Process multiple files 

 

Figure 2-7 Select multiple files for processing, e.g. to filter 3 files in one pass. 

 

Figure 2-7 shows you how you can use the EEProbe Databrowser for processing of 
more than one file. Select the files in the Workset window pane, and then choose 
‘Filter Continuous’ from the ‘Analyze’ menu.  

In this example, the cntfilter program will process all three files as selected, and 

will show the process in a ‘Command Output’ window. 

File entries 

Almost all file entry fields in the Databrowser will show only the basename of 
filenames. You can see the complete path of the entry by moving the mouse over the 
filename; a ‘tooltip’ will be shown: 

 

Figure 2-8 The complete location of file entries will be shown in a tooltip. 

Some of these entries have a default path associated, and if you just type a name in 
the entry field, this default path will be appended automagically. See for instance the 
example in Figure 3-32 on page 53, where the default path is based on the first 

selected cnt file in the Workset. 
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Dialogs and configuration files 

Most of the entries/commands in the ‘Analyze’ menu start an additional dialog 
window that presents you with the available processing parameters for that particular 
command. In fact, the Databrowser looks for a default configuration file. If this 
default configuration file is found, the Databrowser scans the file and sets the 
parameters in the dialog accordingly (also see C.1.2 on page 102 about comments in 
the configuration file). 

Configuration files 

On-line help 

The layout and parameters in the configuration files used in the EEProbe 
Databrowser are (almost) identical to the configuration files for the individual 
EEProbe programs. Therefore, you are advised to use the EEProbe Reference manual  
(on-line from the ‘Help’ menu: ‘Index’) together with the brief info given via the 
small buttons showing a question mark ‘?’. Alternatively, use the <F1> key.  

 

 

Figure 2-9 On-line help is provided throughout the Databrowser, here shown for 

the ‘Correction threshold’ parameter in the detrending procedure. 

Default parameters 

At the startup of the dialog window for a particular analysis command, the 

Databrowser searches in the projects cfg directory for a default configuration file. 

The name of the default configuration file is identical to the name of the related 

EEProbe program. So, for the cntdetrend program, the default configuration is 

cntdetrend.cfg (Figure 2-9); for the cntaverage program, the default configuration 

file is cntaverage.cfg in the cfg directory (see Figure 2-10). For programs that do 

not use a configuration file, no default parameters can be used in the Databrowser. 

One command from the ‘Analyze’ menu is available to both cnt and avr files: 

Rereferencing. The configuration file is identical, and therefore the default 

configuration file is named reref.cfg. 

 

 

Figure 2-10 The caption of the analysis dialogs reveal the name of the EEProbe 

program that will be started using the Apply button. This caption label is also the name 

of the configuration file that is parsed for default parameters. 
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Apart from using the default parameters, and/or editing the parameters in each dialog 
according to your processing needs, you can also save your own configuration files, 
and load this configuration again when you arrive to the same analysis step. 

This is supported through the buttons ‘Read Configuration’ and ‘Save Configuration 
as…’ as seen in Figure 2-11. These buttons are present for all EEProbe programs that 
make use of a configuration file. 

 

 

Figure 2-11 Buttons for reading and saving configuration files. 

 

Pressing the ‘Read Configuration’ button will bring up an ‘Open’ dialog, which lists 

the files in the project’s cfg directory. To load a particular configuration, click on its 

file name, and use the ‘Open’ button. The parameters in the dialog window will be 
updated according to the contents of the file just opened. 

 

 

Figure 2-12 The dialog window for opening of a configuration file. 

 

In order to prevent confusion in the naming of configuration files, you are advised to 
use a meaningful name.  
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Figure 2-13 The dialog window for saving your configuration to a file. 

 

The Databrowser helps to identify the configuration files related to each EEProbe 
program: when saving an edited configuration, supply the (new) name of the 
configuration file in the entry field right to the ‘Selection’ label as depicted in Figure 
2-13. Supply a correct name, using no spaces, or other illegal characters. The 
Databrowser automatically inserts a non-existing name, with a sequence number and 

with the extension ‘.cfg’. Also, in the example above, if you would just type ‘test’, 

the Databrowser will save the file as ‘cntaveragetest.cfg’. Of course, you can also 

overwrite an existing file. 

Without using the ‘Save as’ button, you can simply overwrite the default 
configuration file. Just click on the ‘Keep changes as Default Configuration’ before 
‘Close’, or ‘Apply’ (Figure 2-11). The next time when you start ‘Average’ from the 
‘Analyze’ menu you will load the parameters from this file automatically.  

Tip: safeguard your configurations 

If you use a lot of different settings, e.g., per subject fine-tuning 
of rejection thresholds, save the configurations using the name of 

each subject. Do not overuse the default file.  

Save the configuration files for later reference/use (e.g., when you 
write the ‘methods’ section of your publication), or reproduce 

your results easily from the original data. 
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Channel selections 

In various places in the EEProbe Databrowser, you will encounter the possibility 
make (sub-) selections for channels: indicate which channels you want to 
include/exclude from e.g. filtering, averaging, referencing. This selection process is 
facilitated through the following dialog: 

 

 

Figure 2-14 The ‘Standard’ channel selection dialog. 

However, the channels as displayed here may not match with the channels as present 
in your data files. The layout as displayed above can be changed in the settings file to 
represent your own (‘customized standard’) electrode layout: for more information, 
see paragraph 4.2.1 on page 62. 

For a correct listing of available channels, enable the ‘Datafile’ representation: 

 

 

Figure 2-15 The channel selection dialog for channels in the datafile. 
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3. DATABROWSER REFERENCE 

Description of the user interface 

• Functionality: user menus, implemented EEProbe programs 
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3.1. Implemented EEProbe programs 
A summary of the incorporated functionality in the Databrowser is given below. The 
first paragraph lists the menu structure; in parenthesis you’ll find what EEProbe 
tool(s) corresponds to the menu command. The next paragraph presents the graphical 
interface to each tool. 

 

Menu entry/command   related program/file 

File 

  - Open Project 
  - Create Project 
  - New Experiment 
  - New Subject 
  - Import Data   (data converters) 
  - Export Data   (data converters) 
  - Exit 
 
View 

  - Continuous   (xcnt) 

  - Average   (xavr) 

  - Header   (cntview, avrview) 

  - Edit Selected Files  (default kate, kedit) 

  - Show File Info  (ls -lph) 

 - View PS/PDF files  (e.g. postscript output from xavr) 

 
Analyze 

 - Reject Continuous  (cntreject) 

  - Reject Trials   (cntreject_t) 

 - Events   (cntevents) 

  - Filter Continuous  (cntfilter) 

  - Detrend Continuous  (cntdetrend) 

- EOG detection  (xeog) 

- Average   (cntaverage) 

  - Rereference   (cntreref, avrreref) 

 - Filter Average   (avrfilter) 

  - Detrend Average  (avrdetrend) 

 - Channel Interpolation  (avrinterpol) 

 - Resample Average  (avrdown) 

  - Grand Average  (avraverage) 

- Subtract Averages  (avrdiff) 

- t-test Averages  (avrstats) 
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Tools 

  - Filter Design   (xfir) 

 - Open Terminal  (as defined in ‘Settings’) 
  - Show Session Logfile 

  - Show Disk Usage  (df) 

- Condition/Trigger tools 

 Trigger count / ISI inspection (trgcount , trgisi) 

 Trigger recoding 
 Trigger/response time validation 
- Continuous data tools 

 Cut Epochs  (cntepoch) 

 Concatenate files (cntcat) 

 Resample Continuous (cntdown) 

- Settings   (specification of default project, 
     importers, exporters, and 
     special viewers) 

 
 
Help 

  - Reference Manual  (/opt/eep/index.html) 

- Command Index  (/opt/eep/doc/eepindex.html) 

  - EEProbe license  (licinf) 

- About the Databrowser 
 

 

 

Not implemented, but available on the command line: 

 

Automatic amplitude - peak - detection avrretrieve 

Sophisticated grand averaging 
(allows to grand average multiple conditions, 
multiple subjects in one pass) 

avraverage 

Remove or rename channels in avr files avrchannels 

Merge avr’s with different channel sets to one file avrmerge 

Manipulate channel attributes, rename, remove, 
calculate bipolar channels, etc 

cntsetup 

 

These programs will be included in a future release of the Databrowser. 

Other EEProbe programs (shell scripts, or scripts in perl, awk, ...) may be included 
through the Scripts menu in the Databrowser. 
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3.2. The File menu 

File: Projects 

Open a project 

The ‘Open Project’ command expects this location to exist as a directory on your file 
system. For proper functioning of the Databrowser, two special subdirectories should 

be present, the cfg and fir directories. 

Create a (new) project 

The ‘Create Project’ command can be used to create a new directory, and writes the 

subdirectories cfg , fir and scripts according to the ‘skeleton’ as defined in the 

settings file (see paragraph 4.2 on page 61). You should have write permission in the 
directory were you want to create the new project. 

This command can also be used to update/revert an existing project directory with the 
default ‘skeleton’ files. For any existing files, this command will prompt you for 
confirmation to overwrite or skip the (re-) installation of the skeleton configuration 
file. Also see paragraph 5.1.1 on page 65. 

File: Import Data 

The import of continuous data is facilitated with this menu command. It can be used 
to copy files (‘No Conversion’), or to convert files from a different format than 

EEProbe’s cnt format.  

 

 

Figure 3-1 The File Import dialog. 

 

• Use the ‘Select Files’ button to select a file and add it to the list box at the 
top of the FileImport dialog. To remove a file already included in the list 
box, select the file in question and press <Delete>, or right-click with the 
mouse: a popup menu will appear that allows you to remove file(s). 
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• ‘Experiment’: also allows you to type a new experiment name. 

• ‘Subject’: supply a new or existing subject name. 

• ‘File Format’: select the desired conversion. If ‘No Conversion’ is selected, 
the file will simply be copied. 

• If you want to change the command that is used by the Databrowser, click on 
‘Edit’ to add or remove some options in the ‘Command’ field (the command 
will be inserted before each file). 

If you have selected already in the Databrowser the Experiment and Subject, 
these will be used as default when you select the ‘Import Data’ command. 

In the Settings dialog, you can indicate a default directory where you want the 
File Import facility to start. For instance, if the location of the raw data from your 

recording station is always mounted under /mnt/pc_rec/rawdata, you can have 

the ‘Select Files…’ dialog start in that directory.  

File: Export Data 

 

 

Figure 3-2 The File Export facility. 

 

By default available as file exports are the cnt2asc, cnt2edf, avr2asc, avr2asa 
converters. 

Add the desired set of cnt or avr file to the Workset, and select ‘Export’ from the 

‘File’ menu. 

Select the desired output format, and if you want to write to a default output file (in 

the subject directory). Output extensions are ‘txt’ and ‘msr’, ‘msm’ for ASCII and 

ASA respectively (ASA export for averages only)3.  

The ASA export results in two files, where the msr file contains the general header, 

the msm file the data matrix. 

You have two options for the location of the output files: 

• ‘use default name/path’ will place the result files in the subject directory  

• ‘ask individual name/path’ presents you with a ‘Save’ dialog for every output 
file. 

                                                      
3 The ASA export is only needed for ASA versions 2.x; ASA version 3 and later can 
automatically read the avr and cnt file formats. 
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3.3. The View menu 

View: Continuous 

EEProbe program: xcnt 

This command starts the xcnt viewer for continuous data files (cnt). If more than one 

cnt file is selected in the Workset, multiple instances of the xcnt viewer are started. 

The viewer is started in the subject directory, which is easy when you want to save 
changes in the trigger- and/or rejections-files (after manual changes in the viewer). 

The xcnt viewer uses a default file (channels.cfg) – if present – in the project’s cfg 

directory for user-definable sub selections of the data channels. See the EEProbe 

Reference manual  for more information on the channels.cfg file. 

The viewer also starts with the xcnt.cfg file from the subject directory, or, if not 

present, the default xcnt.cfg from the project’s cfg directory. This file can be used 

to define custom channel colors in the Channel Legend (see chapter 5, Figure 5-6), 

scaling, and other options; after your display adjustments in the xcnt viewer, just 

save the file via the File menu, Save configuration file. 

View: Average 

EEProbe program: xavr 

This command starts the xavr viewer for average data files (avr). All files selected in 

the Workset are loaded in the viewer.  

The average viewer xavr loads a default configuration file, xavr.cfg, when present 

in the project’s cfg directory. If not present, the Databrowser will prompt you for a 

start-up configuration file. The basename (e.g., ‘xavr’) of the default configuration 

file is used to load all related configurations (e.g., ‘xavr*.cfg’). Also a related 

electrode positions file is loaded (following the example: ‘xavr.dat’) for possible 2D 

mapping objects in the configuration file(s). 

The different (display) configurations can be accessed from the ‘Window’ menu in 

the xavr viewer (e.g. see the tutorial, chapter 5.7 ‘Visualize the results’ on page 74). 

The Databrowser scans all *.pk (components) files and writes these data to a 

standard file ‘xavr.components.pk’ in the project directory. This file is loaded to 

visualize any peak scoring as performed in xavr. After the viewer exits, these data 

will be distributed again (by the Databrowser) to individual *.pk files corresponding 

to each *.avr file. 

View: Header 

EEProbe programs: cntview, avrview (correct program is automatically selected) 

For the file(s) selected in the Workset (cnt and avr files) you can view the header 

information, using the ‘Header’ menu entry in the ‘View’ menu. 

Review file info 

Use this command to review the recording settings, and also to 
review a file’s processing history. 

 

Additional information is displayed about the length of the recording, the number of 
channels, the file history (previous processing steps) and the list of channel names 

contained in the file. For average files (avr) you can also review if the file(s) contain 

valid variance information. 
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Figure 3-3 Review the recording settings (example output of cntview shown). 

View: Edit Selected Files 

You can use the Databrowser also to edit for example the trigger files and rejection 
files (both standard ASCII). First add the file(s) to the Workset, and select the file(s); 
now the menu entry is enabled and you can start the editor (as configured in the 
settings dialog – see page 58). 

View: Show File Info 

Default system command: ls -lph 

This command in the ‘View’ menu shows you the output of the system command 

(default ‘ls -lph’). Use this to see the file properties: file size, permissions, file date. 

This command can be modified in the Settings dialog (see page 56) 

View PS/PDF files 

Default system command: kghostview 

This command can be used to view any *.ps, *.eps, *.pdf file. From the average 

viewer xavr, you can create a postscript file, e.g., to include later in a document. A 

*.pdf file may be created using the standard Unix command ps2pdf. 

Since release 1.1.2.4 this command is also enabled for gif/jp(e)g/png/bmp graphics 
files. This is useful for instance when you have a general purpose graphics viewer on 
your system (e.g., konqueror). 

This command (the program that is started) can be modified in the Settings dialog 
(see page 58). 
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3.4. The Analyze menu 

3.4.1. Continuous data analysis 

Analyze: Reject Continuous 

EEProbe program: cntreject 

Result file: foo.cnt -> foo.rej 

 

Figure 3-4 Rejection of continuous files: channel thresholds and other settings. 

 

This dialog presents the parameters as available for the automatic rejection 
procedure. This procedure is similar to the ‘Reject Trials’ command. The interface 
aspects related to the selection/adding/removing of channels are explained in the next 
paragraph.  

However, the implementation of the rejection analysis here is different in the 
following way: 

• You can select only one of ‘Threshold’ or ‘StdDev’; this setting applies to all 
channels. 

• For ‘Threshold’ mode, enter two values: use both the ‘Min’ and ‘Max’ entry 
fields (uV). 

• For ‘StdDev’ mode, enter only the ‘Max’ amplitude value (uV). 
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In Figure 3-4, the other parameters ‘Sliding Window Width’,  ‘Histogram scaling’ 
and ‘Cutoff Point’, are presented with good default values.  

For further explanation about the parameters, see the EEProbe Reference manual. 

Analyze: Reject Trials 

EEProbe program: cntreject_t 

Result file: foo.cnt -> foo.rej 

 

Figure 3-5 Rejection dialog: click to select a channel and review/update the 

corresponding properties.  

 

The implementation of the rejection analysis based on trials is allows you to: 

• Select ‘Threshold’ or ‘Delta’ mode for every channel individually. 

• For ‘Threshold’ mode, enter two values: use both the ‘Min’ and ‘Max’ entry 
fields (uV). 

• For ‘Delta’ mode, enter only the ‘Max’ amplitude value (uV). 

In the ‘Channel Thresholds’ box (Figure 3-4 and Figure 3-5), you have to ‘click’ on 
the channel name (in the list top-left) to display its properties (in the upper right part 
of the dialog). 

Channel manipulations 

Adding a new channel is performed using the entry field just under the list box. Here, 
you can type the new channel name/label, or select a channel from the list (see Figure 

3-6). The list supplies all channel names as found in the first cnt file, as selected in 

the Workset. Using the ‘Add’ button to the left, or typing <Enter> will add the 
channel to the list, after which you can manipulate its settings. The default values for 
the new channel(s) will be set to the values last used in this dialog. 

You can also enter (a group of) channels using regular expressions, e.g., 

  CZ=-50,50 

This adds all channels with Cz in their label, using ‘Min/Max Thresholds’ -50/50. 

  [FC]Z=30 

This adds the channels Fz, Cz, FCz (and FCCz if available) with a ‘Max StdDev’ 30. 
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You can add all channels by selecting ‘all’ from the list, or when you enter one of the 
expressions (all resulting in identical behaviour): 

  .=30 

  all=30 

  *=30 

Removal of a channel can be achieved using the <Delete> key, or with the right 
button of your mouse, and remove channels by selecting the ‘Remove’ or ‘Remove 
All’ options. 

Some more examples are given in chapter 5, on page 68. 

 

 

Figure 3-6 Rejection dialog: add a new channel from the list, or by typing its 

name, and click the ‘Add’ button to update the channel list. 

 

The ‘trial based rejection’ work correctly only if you supply a cntaverage 

configuration file that reflects the ‘trial parameters’. The Databrowser automatically 

supplies the default ‘cntaverage.cfg’ file. You may select another configuration. 

Click on the ‘Edit’ button to review the settings, as shown below.  

The normal CntAverage command dialog is explained on page 39.  
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Figure 3-7 Configuration window for cntaverage.cfg, as part of the trial 

rejection process. 

 

 

Analyze: Events 

EEProbe program: cntevents 

Result file: foo.cnt -> foo.trg 

 

Figure 3-8 The command output of the cntevents program. 
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Each cnt file stores triggers as reference points in the time axis. Usually, they are 

recorded during the EEG session. The EEProbe programs do not use the internal 

triggers, they use an external ASCII file *.trg. This is an ASCII listing of all the 

events in the continuous data file. The ‘Events’ command extracts the triggers/events 

contained in the cnt file to a trigger file. 

If such a trigger file is not already available as the result of some previous 
conversion/import action, the Databrowser will automatically create this file when 
needed for a specific command (e.g., View menu: Continuous). 

Since the original triggers are stored in the cnt file, this also provides a ‘backup-
procedure’ to revert, if any changes to the trigger file have been made (you can edit 
the trg file by adding it to the Workset, and selecting View|Edit). 

Please note that this command has no additional options. In the EEProbe Reference 

manual , you will find that the cntevents program supports some command line 

switches, e.g., to merge the internal triggers with an already existing trigger file. For 

example, if you have made a “classified” trigger file using the xeog program, the 

‘Events’ command in the Databrowser will (prompt you to) simply overwrite the 
existing file and the classification will be lost. 

 

Analyze: EOG detection 

EEProbe program: xeog 

Result files: foo.cnt -> foo.pfc, foo.cls, updated foo.trg 

 

Figure 3-9 The screen layout of the interactive EOG detection (xeog). 

 

This menu command will start the xeog program.  

The program requires the existence of a rejection file ‘filename.rej’ to present the 

rejected periods. This program is typically used to perform the EOG prototype 

classification and trial classification.  
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When starting this program from the EEProbe Databrowser, the trial classification 

can only be performed correctly when the default configuration file cntaverage.cfg 

in the project’s cfg directory matches the desired average configuration (trigger 

codes, time windows). The new output files ‘.pfc’ and ‘.cls’ of the EOG detection 

program should be written in the subject directory, having the same name as the data 

file on which the cntaverage program should perform the EOG correction. 

Also update the trigger file ‘.trg’ to supply the trial classification for the averaging 

procedure (‘blinks’, ‘move’, ‘reject’, ‘unclassified’ are saved in the ‘.trg’ file). 

The xeog.cfg configuration file 

Because the naming convention for EOG channels may differ 
between laboratories, the default configuration as supplied with 

the Databrowser program does not include the EOG channels, but 
some frontal, temporal channels. 

Please take a moment to review also the settings in the EOG configuration file 
(available in the submenu). Here you define the sub-selection of  displayed channels, 
the number of rows and columns in the display layout.  

Analyze: Filter Continuous 

EEProbe program: cntfilter 

Result file: foo.cnt -> foof.cnt 

For continuous data files, this command opens the following dialog window: 

 

Figure 3-10 The dialog for filtering of continuous data files. 

 

Use the ‘Select…’ button to enter a file name for a filter file in the first entry field 
(see Figure 3-11). You have to make sure that the filter parameters are suited to the 

data file(s); check that the sample frequency for the filter is the same as in the cnt 

file(s). The dialog informs you of the sample frequency that it has found 

automatically (in the first *.cnt file). Also see the ‘View, Header’ command above. 

You can selectively filter only a subset of the channels in the original file. For this 
you can use the ‘Select…’ button next to the ‘Filter channel(s)’ field. You can also 
simply type the channel names in this field. Please note that the output file will only 

contain the selected channels! 

The ‘DC offset correction’ is on by default. This indicates that the filter process will 
first calculate the DC signal from a small period at the beginning of the recording4, 
which will be subtracted in each channel before filtering. 

                                                      
4 The DC value is recalculated at each ‘discontinuity’ event (segment boundary). 
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New filter files can be designed using the xfir program, which is available through 

the ‘Edit’ button, or from the ‘Tools’ menu. 

 

 

Figure 3-11 Filter file selection. 

 

Analyze: Detrend Continuous 

EEProbe program: cntdetrend 

Result files: foo.cnt -> food.cnt, food.lin 

Detrending of continuous data requires a lot of configuration parameters, as 
presented in the following dialog window: 

 

Figure 3-12 The entry fields in the dialog for cntdetrend. The entries are identical 

to the contents of the cntdetrend configuration file. 
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The estimation uses a regression (least error squares) robust estimation (least error 
absolutes) algorithm. For further information about this command, please read the 
corresponding section in the EEProbe Reference manual . 

 

Analyze: Average 

EEProbe program: cntaverage 

Result file: foo.cnt -> foo<c1>.avr, foo<c2>.avr, foo<c3>.avr ... 

 

Figure 3-13 The dialog of the averaging configuration. 

 

For the averaging process, several time-related parameters can be set: 

• The ‘Window’ is the time window relative the each trigger point that is 
included in the actual average waveform 

• The ‘Rejection’ window indicates the time where the rejection marks should 
be checked to decide if the trial should be included or excluded from the 
averaging process. 

• The ‘Baseline’ window indicates the interval from which the mean value is 
taken as the zero amplitude. 
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trigger = 0 msec

window 
baseline 

 

Figure 3-14 The time-related parameters are specified relative to the trigger point. 

 

Enable the ‘Compute covariance’ option by clicking on the little square just to the 
left of the label. This results in an extra output file being written, containing the 
covariance matrices. 

Enabling the ‘EOG Compensation’ requires the existence of a “classified” trigger file 

(.trg) and a “propagation factors file” (.pfc) having the same basename as the cnt 

file on which the averaging is performed. 

The ‘Conditions’ box in the middle of the CntAverage dialog window works in a 
similar way as the ‘Channel Thresholds’ box in the rejection procedures (page 33): 

• ‘click’ on the condition to display its properties.  

• Remove a condition by selecting it with the mouse: then click with the right 
button of your mouse, and select the ‘Remove’ option. 

• Add a condition using the entry field just under the list box. Type the new 
condition name. Press the ‘Add’ button immediately to the right to add the 
condition to the list; next, edit its settings. 

The ‘Trigger’ is usually a number (the actual trigger value) that can be selected from 

the list (press on the ). The triggers are automatically extracted from the first cnt 

file in the ‘Workset’ selection.  Specify multiple triggers by typing in the ‘Trigger’ 
field, and separate the triggers with comma’s. 

Specify an ‘Alias’, which will be used in the naming of the resulting average files. 
Although the alias is optional for conditions relating to single triggers, you must 
specify an alias when you want to include multiple triggers in one condition (i.e., one 
average). You are actually advised to use an alias always, and always use for instance 
a combination of 2 characters. 

The ‘Color’, associated with the condition, can be selected from the list and is also 
stored in the output average files. 

In the bottom of the dialog you can specify an alternative output path for the averages 
(created as sub-directories in the subject directory – by default maximum 2 levels 

deep - as well as a ‘New code’. Normally, the cntaverage program creates *.avr files 

having the same basename as the input cnt file. The optional ‘New code’ can be used 

to substitute the default basename of the cnt file). 

For the more advanced options ‘Reference displacement’ and ‘Scanning for triggers’, 
please refer to the EEProbe Reference manual . 
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Analyze: Rereference 

EEProbe programs cntreref, avrreref 

Result file: foo.cnt -> foor.cnt, or  foo.avr -> foor.avr 

Rereferencing computes a virtual reference channel from other channels and 
subtracts this signal from the specified channels before writing the output file. 

 

 

Figure 3-15 Rereferencing of all channels based on common rereference. 

In the example indicated this figure, a common reference is calculated from all 
channels, and this common reference is subtracted from all channels for the new data 
file. 

You may specify a new channel name for a ‘Virtual Reference’ in the third entry 
field, when you want to insert the calculated reference as a channel in the output file. 

 

Special note:  

Unlike all other configuration files, the default configuration file 

for the ‘Rereferencing’ analysis is called reref.cfg 

 

You can specify some operators in the entry field ‘New Reference Channel(s)’, e.g., 

A2*0.5 when you want to reference relative to A2/2. 
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3.4.2. Average data analysis 

Analyze: Reference Average 

This analysis command is identical for both average and continuous files. In fact, you 

can perform the rereference procedure on both avr and cnt files in one pass. See the 

previous page for a screenshot of the dialog window and its description. 

 

Analyze: Detrend Average 

EEProbe program: avrdetrend 

Result file: foo.avr -> food.avr, food.lin 

 

Figure 3-16 Detrending options for average files. 

 

The EEProbe command avrdetrend removes a linear trend from average files. This 

can be performed using a ‘Least squares’, or a robust estimation (least error 
absolutes) algorithm. 

The baseline correction is gone after detrending, unless you specify a (new) baseline 
window. 

You can exclude parts of the ERP waveform from trend estimations in the field 
‘Exclude range(s)’. Specify more than one range by separating the exclusion intervals 
with a comma (‘,’). 

The trend is only removed from the average file(s) if its amplitude deviation is more 
than the specified ‘Correction threshold’, provided that the specified ‘Maximum 
linearity error’ was not exceeded. 
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Analyze: Filter Average 

EEProbe program: avrfilter 

Result file: foo.avr -> foof.avr 

 

Figure 3-17 Filter average file(s): select the desired filter file. 

 

For the filtering of average files, this command in the EEProbe Databrowser asks you 
to specify the filter file that you want to use. As with the continuous data files, the 
dialog informs you of the sample frequency that it has found automatically (in the 

first *.avr file); you can also use the ‘View’, ‘Header’ command to check the sample 

frequency of average(s). The sampling rate should correspond to the sampling rate 

that was specified in the xfir program during the design of the FIR filter. 

Although this command allows you to filter the averages after 
(almost all?) your ERP processing was done, a better routine is to 

perform the filtering on the continuous data file. 

Analyze: Resample Average 

EEProbe program: avrdown 

Result file: foo.avr -> foos.avr 

 

Figure 3-18 Averages can be downsampled to a new sample frequency. 

 

As with the continuous data files, you can down-sample an already calculated 
average file to a new sampling frequency. 
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Analyze: Channel interpolation 

EEProbe program: avrinterpol 

Result file: foo.avr -> fooi.avr 

 

Figure 3-19 Use the Channel interpolation to repair bad channels in the averages. 

 

The Channel interpolation command computes "virtual" ERP signal data at requested 
positions at a unit sphere surface as given by the ‘3D sensor positions’ file.  

Basically, a model of the amplitude topography at the unit sphere surface is generated 

from "good channel" signal data in an avr file. Using this model an interpolated 

value at any point of the sphere surface can be computed. 

Specify the (bad) channels that should be recomputed in the ‘Interpolate channel(s)’ 
field. 

Optionally, you can use the ‘Test mode’ to review how the avrinterpol program will 

perform the calculation. 

The program will create a *i.avr file. You can however use the ‘Output overwrites 

original file’ option (this is performed by the Databrowser, not by avrinterpol).  
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Analyze: Grand Average Process 

EEProbe program: avrprocess 

 

Figure 3-20 Calculate a grand average from a selected set of averages. 

 

The ‘Grand Average’ command actually implements the avrprocess EEProbe 

program, which does not require a configuration file, like the avraverage program. 

This command provides a little more flexible way of grand averaging as needed for 
averaging of any set of files that you can select in the Workset pane. 

For this command you also need to specify the ‘Output filename’ for the grand 

average waveform. Only one output avr file will be generated. You are advised to 

create a new directory in the ‘Save file’ dialog as depicted in the figure: the button on 

the top-right of the dialog  allows you to create for instance a ‘grand’ directory at 
the same level as the subject-directories. 

Also specify a new ‘Grand Average’ condition label, and associate a ‘color’ with the 
new condition. 
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Analyze: Subtract Averages 

EEProbe program: avrdiff 

 

Figure 3-21 Calculate the difference of two averages to a new average file. 

 

Unlike most of the other EEProbe programs that are implemented in the 

Databrowser, the dialog for the avrdiff program requires you to give the output 

name of the result file. 

Use the ‘Switch #1 and #2’ button to change the order of the files as used in the 
subtraction. This changes the actual entries in the ‘Input’ fields.  

When this dialog window starts (with two average files selected in the Workset), the 
order is like in the Workset window. 

Optionally you can specify a new condition label, and associate a ‘color’ with the 
new condition. 
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Analyze: t-test Averages 

EEProbe program: avrstats 

 

Figure 3-22 Create an average file containing the ‘running t-test’ values. 

 

This command can be used to create a *.t.avr file that contains the result of the 

running t-test. This calculation is performed exactly identical as is available ‘on-line’ 

in the xavr viewer (‘show significance’).  

The result file of this procedure allows you to view the significance information also 
in mapping view to display a t-map or significance-map.  

For a proper view, use as ‘palette’ the ‘tmap01’ or ‘tmap05’ in the xavr 
configuration. An example configuration is provided when you have created a new 

project: xavr.t-map.cfg. 

 

 

Figure 3-23 t-test information shown as a time series of significance maps. 
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3.5. The Tools menu 

3.5.1. General tools 

Tools: Filter design 

EEProbe program: xfir 

The xfir tool is started in the fir directory, which is located directly under the 

project directory. 

See the EEProbe Reference manual for further explanation and some general 
guidelines how to design filter files. 

Tools: Open Terminal 

This menu entry will open a terminal window in the ‘current’ directory (i.e., currently 
selected subject). 

The terminal program that is started by the Databrowser can be changed in the 
Settings dialog, see page 58. 

Tools: Show Session Log 

Session Output Log 

 

Figure 3-24 Open the Session Output Logfile to review the processing. 

You can access the command output of all processing that you have performed in 
your current ‘session’ with the EEProbe Databrowser from the Tools menu.  

Info: the Session Output Logfile is automatically saved when 

you exit the EEProbe Databrowser 

When you exit the Databrowser, the session logfile is stored 
automatically with a date stamp and session sequence number in 

the project directory. So, you can always review the settings used. 
However, these files are not listed in the Databrowser. You may 

want to clean up the project directory from time to time. 
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Session Command Logfile 

 

Figure 3-25 Review the Command Logfile to start creating your own scripts. 

You can use the log of the commands issued by the EEProbe Databrowser to redo a 
complete analysis process. You would have to save the ‘Session Command Log’ as 
available  in this menu, and give the file ‘executable’ rights in order to run the logfile 
as a script. 

Unlike the session’s Output Log, by default the Command Log is not automatically 
written at the exit of the Databrowser. However, you can enable this in the general 
settings dialog (see page 56). 

Tools: Show Disk Usage 

System command: df -h 

This ‘tool’ shows the output of the ‘df’ (disk free) command; it informs you about 

the available disk space on the computer where the EEProbe Databrowser is running. 
This lists the information for all mounted file systems, as shown in the figure below: 

 

Figure 3-26 Information dialog showing disk usage. 
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3.5.2. Trigger manipulation tools 

In EEProbe you can easily manipulate the processing of continuous data files by 
changing the corresponding trigger files. This is useful for instance for conditional 
averaging. 

Tools: Trigger count / ISI inspection 

EEProbe command: trgcount, trgisi 

 

Figure 3-27 Inspect the number of triggers in a trigger file and review the statistics 

of the time intervals between selected triggers. 

Use the large button on the top of this dialog to start the trgcount script for all 

selected trigger files and show a count of all trigger occurrences (totals per trg file). 

The ‘Trigger Inter-Stimulus-Interval inspection’ allow you to select different triggers 
and review the mean, minimum, maximum and standard deviation of the ISI times. 
Select ‘Values’ to obtain the ISI times of all trigger pairs on which the statistics are 
based. 

The ‘Maximum value for ISI’ is given in seconds (regardless of the selected ‘Units’). 
This parameter is used to exclude long intervals from the statistics calculation. For 
instance, you may be interested in the mean reaction time of a subject, but excluding 
too long reaction times. In this case, select the ‘stimulus’ trigger and the ‘reaction’ 
trigger in the dialog, and use the ‘Maximum ISI’ to specify the maximum reaction 
time (e.g., 0.8 sec = 800 msec). This parameter also prevents the search algorithm to 
look to far ahead and erroneously include triggers; its default value is 2 seconds. 

The default behavior of closing the dialog after processing is not implemented for the 
TrgIsi tool, because you often want to run the tool several times, using different 
triggers / parameter settings. 
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Tools: Trigger recoding 

EEProbe program: trged 

 

Figure 3-28 Conditional averaging 1: trigger (sequence) recoding. 

This is a search-and-replace tool for trigger code sequences in trigger files. Its main 
purpose is the recoding of false responses (i.e., resulting in an invalid trigger 
sequence) that were recorded from the stimulation program. 

Enter the first code of the trigger pair by typing or via the ‘Select 1st...’ button. 
Supply the second code in a similar way. 

Below, click on the check-buttons ‘don’t touch’ to leave a code unchanged, or enter a 
replacement code (in the example shown in Figure 3-28: trigger ‘1’, when followed 
by the - invalid – response code ‘2’, is replaced by ‘_11_’; thus the trials containing 
an invalid response ‘2’ are excluded when averaging based on trigger ‘1’).  

Tools: Trigger / response time validation 

EEProbe command: trgvalid 

 

Figure 3-29 Conditional averaging 2: recode triggers with invalid (long) intervals. 

Typically, the trigger recoding for the trgvalid command is also used in 

experiments where a subject had to react to stimuli by pressing response buttons. In 
this kind of experiments, you may only want to average trials in which the subject 
responded within a certain time window (‘min time’, ‘max time’ fields in Figure 3-29 
– enter the values in milliseconds).  

The trgvalid command can be used to recode triggers for which the time interval 

is invalid, i.e., where the response was made too quickly, or too slow. 
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3.5.3. Continuous data tools 

Tools: Cut Epochs 

EEProbe program: cntepoch 

Result file: foo.cnt -> fooe.cnt 

This command can be used to make a sub-selection from a recording, e.g., when it 
contains some distorted periods that you want to remove. For this you can best use 

the continuous data viewer xcnt: 

 

Figure 3-30 Manually add triggers at the desired time-points. 

At the beginning of the period that you want to include in your new file, put a trigger 

‘255’: enter this code in one of the ‘Trigger’ fields at the bottom of the xcnt window, 

and click on ‘Set’. 

Similarly, at the end of the period that you want to include, put a trigger ‘254’. 

You can define more periods in this interactive way, all inside the xcnt viewer. 

When you want to quit the viewer, first select the ‘Save Triggers’ option from xcnt’s 

File menu (see Figure 3-30). 

Next, you open ‘Cut Epochs’ in the Databrowser: 
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Figure 3-31 Selected periods in a continuous data file can be written to a new file 

using the cntepoch program. 

Here, you will normally find the triggers ‘255’ and ‘254’, corresponding to the start 
and stop of each period that you have marked in the continuous data viewer. 

These trigger points will be used to create the output file. 

Alternatively, in this dialog you can also specify some periods that you want to use in 
the output file.  

Example. For instance, by entering ’10-20’ as ‘Epoch definition’, the Databrowser 
will insert triggers ‘255’ and ‘254’ at 10 sec and 20 sec in the trigger file, before the 
cntepoch program is started. By specifying that this is a ‘New epoch definition’ (see 
the dialog), any previous triggers ‘255’ and ‘254’ (or other values that you entered) 
will be deleted before inserting the triggers at 10 sec. and 20 sec. 

 

Tools: Concatenate files 

EEProbe program: cntcat 

 

Figure 3-32 Concatenate continuous data files. 
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Using this program, you can append data files to one-another. After you have made 

your file selection in the Workset, you can still reorder the sequence in which the cnt 

files will be concatenated: just ‘click&drag’ a file up or down in the listbox. You 
must specify an output file: if you just type a name in the ‘Output filename’ field, it 
will be written automatically to the directory of the first file as selected in the 
Workset (as shown by the tooltip in the figure above – the popup shows 
automatically when you move your mouse over the entry field). 

The ‘Common channel set’ option is useful to add files that have a different channel 

naming; channels that do not appear in all cnt files, will not be written to the output 

file. 

‘Use external trigger files’ is a way to create an output cnt file where the internal 

events table (triggers) is based on the triggers files. This requires that for every input 

cnt file there is a corresponding trg file. 

 

Tools: Continuous data tools: Resample Continuous 

EEProbe program: cntdown 

Result file: foo.cnt -> foos.cnt 

This command allows you to resample the continuous data file(s) to a new (lower or 
higher) sample frequency. This may be useful to compare data that was originally 
sampled at different sample frequencies. 

 

 

Figure 3-33 Downsampling of continuous data. 

For the mode, two options are available (also see the Reference manual): 

• ‘Downsampling factor’ corresponds to the -s <skip> command line option. 

The factor results in skipping every <skip>th source sample and writing this 
to the destination file. 
The ‘Anti-aliasing’ option makes sure that the output sample is a mean value 
of the <skip> samples. 

• ‘New sampling frequency’ can be specified. The samples in the output file 
will be calculated via a linear interpolation method. 
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4. EEPROBE DATABROWSER SETTINGS 

User and environment settings 
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4.1. The Settings dialogs 
Most of the settings in your $HOME/.eep/settings file can be change interactively via 

the Tools menu, Settings. Below, the different dialogs are presented: 

4.1.1. General 

 

Figure 4-1 General settings. 

All options are explained through the on-line help (the ‘?’ buttons, or with the <F1> 
key). Below, only some of the entries are described. 

Project directory 

Here you can indicate your default project directory that is opened when you start 

eeprobe . You can overrule this with the command line option ‘-p project_dir’, or 

by using an environment variable PROJDIR. 

Cognitrace binary 

Indicate the location of the recording program ‘Cognitrace’ (typically 

/opt/refa/bin/cognitrace). Only when this field contains a valid entry, the 

‘Recording’ menu will be enabled. 

Write command logfile 

Enabling this option will write the ‘Session Command Logfile’ automatically when 
you exit the Databrowser. These files will be placed in the project directory, with a 
date and sequence number, corresponding to the ‘Session Output Logfile’. See 
paragraph 3.5.1 on page 49 for more explanation on its usage. 

Auto work select 

Choose the desired selection mechanism in the ‘Workset’:  

workselect (default setting) automatic selection of datafiles for the next 
processing step 

viewselect as above, and start of xavr/xcnt viewers (xcnt 

viewing only for single file processing) 

workselect+  and viewselect+ functionality as the counterparts above, and also 
automatically restrict the Datafile listing to show 

files of the appropriate type (e.g. ‘f.cnt’ after 

filtering) 
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4.1.2. Importers and Exporters 

 

Figure 4-2 Settings: Importers. 

 

Figure 4-3 Settings: Exporters. 

In the ‘Importers’ and ‘Exporters’ tabs you can define your own selection of 
converter programs that will be available in the File menu: Import, Export. 

Double-click on an entry in order to edit the label, program, and format fields. Click 
on the ‘Add/Update’ button to include the (new) program in the listing. Using the 
mouse, you can also change the order of the listing: e.g., ‘drag’ an entry to the top of 
the listing to make it the default converter. 

The converter programs are uniquely identified with their ‘Label’. 
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4.1.3. Helper programs 

 

Figure 4-4 Settings: Editor program. 

The editor program as specified here will be used in the View menu: Edit. This is 
also used as ‘Script editor’ via the scripts menu. 

 

 

Figure 4-5 Settings: Terminal program. 

The terminal can be started via the Tools menu, or with the keys <Ctrl+T>. 

It will be started in the current subject directory, or in the current experiment 
directory if no subject was selected. 
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Figure 4-6 Settings: Postscript viewer. 

This viewer is used to open postscript files via the View menu. 

 

 

Figure 4-7 Settings: Browser program. 

The browser is used to open the on-line help via the Help menu. 

4.1.4. Electrode layout 

In the Databrowser at various locations in the Analysis procedures, you can make use 
of a ‘Channel Selection’ dialog. The actual electrode positions may not match exactly 
with your electrode layout, a default table of positions is provided. Of course, you 
can switch to the list of channels as available in the datafile, but using a topographic 
layout is sometimes more appropriate. Using the ‘Electrode layout’ tab in the 
Settings dialog you can select from three standards: electrode_1020, electrode_1010, 
and electrode_1005: 
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Figure 4-8 Settings: Electrode layout. 

The actual layout is quite easy to specify as a table (row, column values) in the 
settings file (see the next section). 
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4.2. The $HOME/.eep/settings file 
In the settings file itself, you will find all entries as available through the Settings 
dialogs. General settings contained in the settings file are startup project location, the 
location where the file import utility should start its ‘Select Files…’ dialog, and the 
location of the EEProbe programs. Some extra parameters may be specified here. 

 

 

Figure 4-9 The contents of the settings file. 

Some advanced options can only be changed in the settings file. These special 
options are written under a section heading {advanced_options}, and pertain to: 

• The number of sub-directory levels that can be shown in the Datafile listbox 
(please be careful when changing this, searching ‘deeper’ can take considerably 
more time); 
parameter specification: list_datafile_levels = 2 

• A list of file types (extensions) that are available in the ‘Select’ feature under the 
‘Datafile’ listbox; 
parameter specification: datafile_custom_ext = ext1, ext2, ext3, … 

• The extra command that is used to show the sub-directory sizes when requesting 
‘Info’ in the context menu of of the Experiment listbox; 
parameter specification: dirinfo = du –h 

• The command that is used under the Tools menu, Disk usage; 
parameter specification: diskusage = df -h 
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And, only applicable if you have the recording program ‘Cognitrace’ installed: 

• Some special parameters are available to obtain a pre-filled ‘Cognitrace’ dialog 
(Recording menu); 
parameters: rec_experiment, rec_subject, rec_cfg, rec_out  

(see Figure 4-9 or in the settings file) 

4.2.1. Channel layout settings 

Further down in the settings file you will find one or more lists of channel names and 
associated ‘x’ and ‘y’ values. These values are used in the ‘Select Channels’ dialog 
window for display of the ‘standard’ channel selection, as found in several dialogs 
for entries in the ‘Analyze’ menu. If you want to edit this list, only use integer values, 
and find the correct layout using ‘x’ and ‘y’. You do have to restart the EEProbe 
Databrowser before any changes to the channel layout can be used. 

You can keep different lists for different channel layouts in one settings file; the list 
that is actually used is indicated by the {electrode_layout} parameter (see Figure 
4-10). 

 

 

Figure 4-10 The settings file: the channel list and electrode_layout parameter. 

 

See Figure 4-8 for an example dialog with channel labels according to the 
‘electrode_1010’ specifications as indicated in the settings file. 
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4.2.2. Configuration files for new projects 

Edit the sections {newproj_dir} and {newproj_file} carefully. This set of files will be 

created in a new project directory, under the special ‘cfg’ and ‘fir’ and ‘scripts’ 

directories. 

For advanced users: in the installation directory of the EEProbe Databrowser 

(/opt/eep/eeprobe_gui) you will find a script ‘projskel.sh’ that will help you in the 

creation of your own set of files to be included in the settings file. 
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5. BASIC ERP PROCEDURES 

Step-by-step data analysis 
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5.1. Installation of the example data 
The example data file used in this chapter can be installed from a tar file, available on 
the CD, or from the download-site where you obtained the EEProbe Databrowser 
files. 

You should have installed the EEProbe Databrowser. 

The default project directory that the Databrowser will open after the first start, is 
$HOME/data 

5.1.1. Create project 

After the first start of the Databrowser the default project directory $HOME/data may 

not exist; in this case, you will be prompted to create a project. If you already have 
this directory, you can choose to create a project there anyway, or create a new 
project at another location.  

For any existing files in a (project) directory, you will be prompted: 

 

Figure 5-1 Interactive project (re-)creation 

Tip: use the <Enter> key for ‘Yes’, and <Escape> for ‘No’.  
If you click on ‘No to All’, only non-existing files will be created. 

 

 

Figure 5-2 Review the newly created project files in the log window. 
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Note 

The file listing of new project files is not included in the overall 
‘Session Output Logfile’; if you want to save the list, do it in the 

above dialog window. 

5.1.2. Open the project 

You can also specify the location of a project on the command line: 

  eeprobe –p ~/data 

 

or you can open it from the EEProbe Databrowser: File | Open project, and specify 

/home/james/data, if that is where you installed this project.  

 

 

Figure 5-3 Open project directory: the icons containing ‘waveforms’ are EEProbe 

project directories containing a cfg and fir sub-directory. 

 

After you have successfully opened your 
project, use the File import facility from the 
File menu, and select the data file m101.cnt 
on the EEProbe CD from the 

Examples/P300 subdirectory: 

 

Figure 5-4 Import the example data. 

 

As Experiment, type ‘P300’ 

As Subject, type ‘m101’ 

Use the ‘No conversion’ option, and click 
on apply to copy the file to your hard disk. 

 

On this file, you will perform a typical P300 
analysis. 
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5.2. View the data 
Add the continuous data file to the Workset and select it as explained in paragraph 
2.1.3 on page 17. Double-click on the file, or press <Enter> to start the viewer. 

 

Figure 5-5 Add the m101.cnt data file to the Workset for processing. 

 

Figure 5-6 View the example data set. 

In the xcnt viewer you can browse your data. You can change the colors of each trace 

in the Channel Legend and save this as default color scheme. To save the color 

scheme for the current subject only, just type ‘xcnt.cfg’ as ‘Selection’ in the ‘Save 

Configuration file’ dialog. You can also edit triggers and/or rejection marks, inspect 
amplitudes; please see the EEProbe Reference manual for detailed usage. 
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5.3. Artefact rejection 

5.3.1. Menu command: Analyze, Reject Continuous 

Open the CntReject dialog window through the ‘Analyze’ menu, select the ‘Reject 
Continuous’ command. 

Check the following settings for identical processing as in this tutorial: 

‘StdDev’ mode for all channels: 

EOGV  ‘Max’ = 30  

EOGH  ‘Max’ = 30 

FZ  ‘Max’ = 20 

‘Sliding Window’ of 200 (msec) 

‘Histogram scaling’ 0.1 

‘Cutoff Point’ 15 

 

The pictures below explain how to quickly set the channel parameters if they are not 
yet correct. 

 

 

Figure 5-7 Remove unwanted channels with the right-click (mouse) menu. 

 

 

Figure 5-8 Quickly add the EOG channels using a simple formula, click ‘Add’ or 

press <Return>. 
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Figure 5-9 Add ‘fz=20’ to include the StdDev parameter for the Fz channel; click 

on a channel label to review its setting. 

 

Click on the ‘Apply’ button to start the rejection process: 

 

 

Figure 5-10 The rejection analyis: a rejection output file is created (m101.rej). 

 

When the processing is finished, the ‘Command Output’ will end with ‘done’ in blue, 
and the two buttons in the bottom of the ‘Command Output’ dialog are enabled 
(grayed/disabled during processing). You can save the output text as shown to a text 
file using the ‘Save as…’ button, but it will be appended to the overall Session Log 
file anyway. So, typically you close the dialog with the ‘OK’ button. 
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If some errors occurred, these will typically be displayed as red text5. 

 

After the rejection processing, open the m101.cnt file in the continuous data viewer 

xcnt via the View menu.  

 

 

Figure 5-11 Open the data file in the ‘continuous data viewer’ (xcnt) to review the 

EEG data together with the triggers and rejection marks (red markings). 

 

 

                                                      
5 The context colors green, blue and red are not displayed in the overall ‘Session Output Log’. 
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5.4. Filtering 

5.4.1. Menu command: Analyze, Filter Continuous 

 

Figure 5-12 The filtering process. 

In the entry field for the ‘Filter filename’, we enter the name of a band-pass filter 
from 0.3Hz to 30Hz, that was designed for the sampling frequency of 256 Hz. Select 
the file using the ‘Select…’ button. 

By default, you process all channels in the filtering process (see Figure 5-12). 

When the cntfilter program is finished, the buttons ‘OK’ and ‘Save as…’ at the 

bottom of the ‘Command Output’ window are enabled: during the processing these 
buttons are non-functional, after processing they turn from gray to black. 

Click ‘OK’ to close the ‘Command Output’ window. 

5.4.2. Notes 

You can design your own filters using the xfir program (see the EEProbe Reference 

manual ). This program is available from the ‘Tools’ menu: ‘Filter Design’. 

The example above uses a filter file with the name 

  fs256Hz_bp0.3-30.fir 

which is a sensible way of naming your filter files: 

   fs256Hz = sampling frequency of 256 Hz 

   bp0.3-30 = band-pass filter from 1-30Hz 

Use ‘lp’ for low-pass filters, ‘hp’ for high-pass filters, or ‘n’ for notch filters. 
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5.5. Rereferencing 

5.5.1. Menu command: Analyze, Rereference 

Select the m101f.cnt filtered file to add it to the Workset (this is done automatically 

by the Databrowser, when using the default ‘workselect’ mode in the Settings dialog, 
see page 56). 

 

 

Figure 5-13 Rereference the data: common reference except ear and EOG channels. 

For the rereferencing process, use the settings as displayed in the figure above: we do 
not include the EOG channels, nor the right/left ear channels for the calculation of the 
new reference: 

• Click on the ‘all’ check-button (top-right) 

• Select the A1, A2, EOGH, EOGV channels in the Channel selection dialog 
that opens via the ‘Except’ button6 

Press the ‘Apply’ button and the referencing process is started. 

Its output file will be named m101fr.cnt, because we have used the filtered file 

m101f.cnt as input. The cntreref program adds an ‘r’ to the basename of the file. 

                                                      
6 The data were recorded using A1 as a reference. To obtain a ‘linked-ear’ reference, deselect 
‘all’, and type ‘A2*0.5’ as new reference channel. 
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5.6. Averaging 

5.6.1. trigger, rejection filename convention 

In the next step, we will perform the averaging process on the the m101fr.cnt file. 

This process expects that the trigger file (for the different conditions) and the 
rejection file (to reject any contaminated trials) have the same base name as the 
continuous data file. Therefore, after each step, the EEProbe Databrowser has copied 
the original trigger and rejection files automatically to the new basename.  

5.6.2. Menu command: Analyze, Average 

For the selected m101fr.cnt file, start the ‘Average’ command dialog from the 

‘Analyze’ menu, and review that the settings match the following configuration: 

 

 

Figure 5-14 The configuration parameters for the P300 averaging process. 

 

For the condition ‘standard’, use the Alias ‘s1’, for the ‘deviant’ triggers, use an Alias 
‘d1’. If the default project was installed properly, this is already configured as such. 
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5.7. Visualize the results 

5.7.1. Menu command: View, Average 

Now that we have the final result avr files, we can review these ERP waveforms in 

the xavr viewer. 

The avr result files are automatically added to the Workset listing, the averages are 
automatically selected, and we can immediately choose ‘Average’ from the ‘View’ 
menu. Or, press <Enter> in the Workset. 

 

Figure 5-15 Review the averages together in the viewer. 

 

Figure 5-16 Use the Window menu to open different configurations (display pages). 
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5.7.2. Notes on 2D mapping view 

The default 3D position file 

The startup of the xavr viewer via the Databrowser, automatically loads a default 

xavr.dat 3D electrode position file. The 3D positions are used for a spherical spline 

interpolation to create a spherical surface map, which is unwrapped into a plane to 
display 2D plots with acceptable distortions. 

Since the electrode layout as used in different experiments may be different than in 
the example data as shown in this chapter, the 2D mapping view may not be optimal, 
or can even show a distorted picture. 

If this is the case for your data, you can try to reload the default sensor positions 
through the File menu, Load Sensor Positions. Change the default setting for the 

number of ‘Mesh Control Points’  n to 1, and reload the xavr.dat file: 

 

 

Figure 5-17 Recreate the ‘mesh’ as used for the mapping display. 

 

The number of points controls the map interpolation as follows (n is the number you enter and 

ndat is the number of valid sensor positions in the .dat file): 

n = 0  
no interpolation at all, a value of -1e30 is assigned if no ERP channel is available for 

an sensor in the .dat file(this is the default)  

0 < n <= ndat  

no additional control points, interpolation for sensor positions with missed ERP 
channels  

ndat < n  

insert additional control points, need interpolation always 

 

Create your own 3D position file 

For EEG data, a helper-script ‘generate3Dpos.awk’ is installed as part of the default 

files when creating a new project. This script can be used to create a .dat file based 

on the channel layout of your data. Select a cnt or avr file in the Workset, and from 

the Scripts menu, run the script: 
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Figure 5-18 Create a custom 3D position file. 

 

For the example data, its output will tell you: 

 

 

Found 59 positions out of 346 standard positions (sphere_1005) 

Creating 3D position file '/home/mvelde/data/P300/m101/xavr59.dat' 

Unmatched channels: 

  EOGH 

  EOGV 

 

 

After starting the xavr viewer, you can load the result file ‘xavr59.dat’ through the 

File menu, Load Sensor Positions. 

 

You can easily edit this file to remove any unwanted channels (e.g., ear, or mastoid 
channels): in the Databrowser, add the file to the Workset, and select ‘Edit Selected 
Files’ in the View menu.  

In most editors (the figure below shows the default editor ‘kate’ as available in the 

KDE 3 desktop environment) you can save a copy of this file to ‘xavr.dat’ in the 

cfg directory of the project. Choose ‘Save as...’ in the File menu, and navigate to the 

cfg directory (two levels up). Click on the xavr.dat file and click ‘Save’. Thus it 

becomes the default sensor position file for the next startup of the xavr viewer: 
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Figure 5-19 Edit and save a Sensor positions file to the default ‘xavr.dat’. 

 

This concludes this chapter about basic ERP procedures. In the next chapters you will 
find some additional explanations about specific procedures in EEProbe, and how 
these are facilitated using the Databrowser. 

In the chapter following this one, you can actually find a description of how to 
perform the same set of analyses as described in the previous pages with just a few 
mouse clicks! See section 6.2 about ‘Templates’ on page 80. 
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6. SCRIPTS AND TEMPLATES 

Incorporating external commands 
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6.1. Scripts 
Any scripts that are placed in the ‘scripts’ sub-directory of a project will 

automatically (and immediately) be available via the ‘Scripts’ menu in the EEProbe 
Databrowser7. 

 

Scripts are started with all file(s) selected in the Workset as argument(s) appended 

after the script name. The resulting command-line is started in the currently selected 

experiment/subject directory. 

 

In the Scripts menu, you can choose to start the ‘Script Editor’. The editor will start 

in the scripts directory of the current project to facilitate opening of an existing 

script, or save a new script in the correct directory.  

6.1.1. Installed scripts in a default project 

The default scripts that are installed when you create a new project in the 
Databrowser, are: 

  average-preview.sh 

  average-simple.sh 

  generate3Dpos.awk 

  average-process.sh 

 

(The last script will not show up in the Scripts menu, because it is accompanied by a 
template file that has the same basename: 

  average-process.tmpl 

The description of this template/script and how to create new templates will be 
described in the next paragraph) 

 

The average-preview.sh and average-simple.sh scripts are provided as learner 

scripts (bash environment) to create your own custom scripts, if needed. The first 

script can be used to perform a standard averaging process for any trigger present in 
the recording, do a standard rejection, filtering, rereference (to common) and 
averaging, and start the average viewer. 

 

The ‘generate3Dpos.awk’ script works on both cnt and avr files, and will create a 3D 

electrode position file8 containing 346 standard electrode positions (EEG only) 
following the 10/5 system9. A sub-selection of the available electrodes will be written 

to an EEProbe *.dat file (also see paragraph 5.7.2). 

                                                      
7 You may want to check the ‘executable’ permissions of your scripts; in case you select in 
the Databrowser a script that ‘not executable’, it will search for the interpreter on the first line 
of the script (requires the ‘magic’ string: #!), and launch the script via the interpreter. 
8 Adapted from a standard electrode file based on original by Robert Oostenveld. 
9 Oostenveld, R. and Praamstra, P. The five percent electrode system for high-resolution EEG 

and ERP measurements, Clinical Neurophysiology 112 (2001) 713-719. 
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6.2. Templates 

6.2.1. The ‘average-process’ script/template 

One standard template is installed by creating a new project, which allows you to 
quickly redo the analysis as performed in all of chapter 5 “Basic ERP procedures”. 

Select the file m101.cnt in the Workset, go to the Scripts menu and choose ‘Edit’ 

from the little sub-menu right to the ‘template: average-process.tmpl’ entry: 

 

 

Figure 6-1 Select and ‘Edit’ the average-process template. 

 

Now the following dialog will show: 

 

 

Figure 6-2 The average-process template facilitates a set of standard processing 

steps. 

The figure shows you the available options as programmed in the script that is shown 

at the top line. This script ‘average-process.sh’ implements a lot of processing steps 
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for you to choose from. Just click on one or more of the check-buttons to the left of 
the dialog to switch on or off a processing step. The second column shows the 
implemented ‘switches’ (e.g., -filter, -reref) that will be passed to the 

average-process.sh script after you press ‘Run’. The configuration files in the third 

column will be placed just after each ‘switch’, and the average-process.sh script 

will automatically find the configuration/filter file in the correct directory. 

 

 

Templates provide a generic way of designing a interface to a command line 
program, or a script. Typically, on the command line you specify the options, which 
manipulate the functionality of the program/script. In this interactive Template 
Builder, you can specify 'short' and 'long' options, which can be looked upon as 
'modifiers' and 'valued options' respectively. 

The command/script is started with all enabled options inserted between the 

command and files selected in the Workset. The command is started in the current 

experiment/subject directory. 

For 'long options' where no '=' (equal) sign is specified, a space is inserted between 
option and value. 

 

 

When you click ‘Run’, all the ‘checked’ process options will be performed. The 
resulting average files now arrive in a sub-directory ‘result1’; select the files, and 
right-click with your mouse to ‘Add to Workset’ these files, as shown in the Datafile 
listing below: 

 

 

Figure 6-3 Select the resulting avr files to add them to the Workset. 

 

Next, press <Enter> to start the average viewer. 

 

The ‘average-process’ template is installed in a ‘locked’ state (as shown in Figure 

6-2). You can see how the average-process.sh performs its job by clicking on 

‘Unlock’ and then on the ‘Edit’ button next to the command. 
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6.2.2. Creating a new template 

We will implement here an interface dialog for the ‘ls’ command (also see ‘man ls’), 
for example using short options ‘-a’ ‘-l’, and long option ‘--sort=WORD’. 

 

 

Figure 6-4 Choose a name for the new template. 

 

In the Scripts menu, choose ‘Create New Template’ and type ‘ls’ in the ‘Selection’ 
field. Click on the OK button. 

 

 

Figure 6-5 Create a new template for a selected command/script. 

 

Supply ‘ls’ as the Command/Script name. 

Type ‘show hidden’ in the ‘Label’ field, and click on the ‘Short Option’ button.  

The Template dialog will resize and show a new row (as in Figure 6-5): now type ‘-a’ 
in the entry field on the newly inserted row. 

Type ‘long listing’ in the ‘Label’ field, and click on the ‘Short Option’ button (as 
shown in the figure above). Type ‘-l’ in the entry field on the new row. 

Next, type ‘sort’ in the ‘Label’ field, and click on ‘Long Option’. Supply ‘--sort=’ in 
its first entry field.  
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Click on the ‘Lock’ button to arrive at a dialog that looks like this: 

 

 

Figure 6-6 Use the ‘ls’ template to show a sorted file listing. 

 

In the entry field next to the sort option, you can use for instance ‘extension’, ‘size’, 
or ‘time’ to change the way of sorting the file listing. 

Click on the ‘Save’ button to save the current state of the Template. 

Click on the ‘Run’ button to run the ‘ls’ command with the options chosen. 

Even when you do not select any files in the Workset, running this command from 
the Scripts menu will show the files in the current selected (subject) directory, 
because that is where the command is started. 

6.2.3. Remarks 

For some commands/scripts you may want to disable the ‘Show Command Output’. 

For example, you can easily create a template for one or more (alternative) editors, or 
a template to start another viewer program. Then you may not be interested in its 

stdout/stderr (‘command-line’) messages. 

 

Some commands that you may want to use are actually ‘normal’ binary program files 
(like the ‘ls’ command). Using the ‘Edit’ button (in ‘unlocked’ state of the template) 
you may be able to open the editor10 and see its (binary) contents. In the current 
version of the Databrowser we have not implemented any warning for this.  

However, for most programs it is unlikely anyway that you are able to distort 
anything, simply because you will not have the permission to write to the (system) 
program file. 

 

                                                      
10 Some editors may actually prevent you to open a binary file. 
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7. PEAK (COMPONENTS) SCORING 

Manual amplitude / latency extraction 
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7.1. Peak scoring in xavr 
 

Open the average viewer, and open the signal inspector by a right-click on a 
waveform diagram in the main display: e.g. select ‘Inspect’ for channel FCz as 
above. 

 

 

Figure 7-1 Use the signal inspector to perform some peak scoring 

 

Next, use the left mouse button to position one of the cursors on a peak, and use the 
right mouse button to open a peak menu (see the figure). In this menu, select a label, 
and subsequently the ‘Signal Values’ window will open. 

The process can be repeated for different peaks, in different conditions/channels. You 
can also just assemble the amplitude data at a certain latency by pressing the space 
bar <Space>. 

The list of peaks that can be ‘scored’ is the combined list of labels as found in all 

configuration files that are loaded in the xavr viewer. The peaks can be shown in the 

main window of the average viewer - provided that its ‘component’ definition is 
available in the current display page (configuration file); see the EEProbe Reference 

manual for more details. 
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Figure 7-2 Visualize the peak scoring 

You can visualize the peak scoring by pressing ‘Apply’ in the Signal Values window. 
This requires the presence of a ‘components’ section is in the configuration file; see 
the EEProbe Reference manual for more details. 

Save the amplitude / latency data 

Before you exit, do not forget to save the scoring: click ‘Save…’ 

 

 

Figure 7-3 The default components file for xavr 

 

Just click ‘OK’ in the dialog as shown here: do not 
change the default filename.  

 

At the startup of xavr, the Databrowser scans all 

*.pk (components) files and writes these data to the 

standard file ‘xavr.components.pk’ in the project 

directory.  

After the xavr viewer exits, the data found in the 

default file will be distributed again (by the 

Databrowser) to individual *.pk files corresponding 

to each *.avr file. 
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Figure 7-4 After the peak scoring, *.pk files result for each ‘scored’ average file. 

 

7.2. Interaction between the Databrowser and xavr 

7.2.1. Display configurations 

The average viewer xavr loads a default configuration file, xavr.cfg, when present 

in the project’s cfg directory. If not present, the Databrowser will prompt you for a 

start-up configuration file: you can then select one of the available configuration files 

in the ‘cfg’ directory.  

For example, you have deleted the default xavr.cfg file, and in the dialog select 

xavr1010.cfg. The basename (e.g., ‘xavr1010’) of this default configuration file is 

used to load all related configurations (e.g., ‘xavr1010*.cfg’). Also a related 

electrode positions file is loaded (following the example: ‘xavr1010.dat’) for 

possible 2D mapping objects in the configuration file(s). 

No more than 25 configurations will be passed to the xavr command line. 

The different (display) configurations can be accessed from the ‘Window’ menu in 

the xavr viewer. 

7.2.2. Components file 

Also at startup, the Databrowser scans all *.pk (components) files for the avr files 

as selected in the Workset. These data are all written to a standard file 

‘xavr.components.pk’ in the project directory. This ‘component’ file is then loaded 

to visualize any peak scoring as performed earlier in xavr.  
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Any new amplitude / latency data will be appended to the listing in the Components 
window (‘Signal Values’). The peaks are not shown in Signal Inspector, but will be 
shown in the main display after pressing ‘Apply’ in the ‘Signal Window’. In order to 
facilitate the review of a lot of data in this window, you can ‘Sort’ the data (may also 
be used to delete invalid entries). 

After the viewer exits, the data in the ‘xavr.components.pk’  file will be distributed 

again (by the Databrowser) to individual *.pk files corresponding to each *.avr file 

(as selected earlier in the Workset). 

Within the xavr viewer you can also load average files from the File menu. If you 
perform some peak scoring on these, the Databrowser will not be able to distribute 

the data to the correct path. Instead, it will create files ‘xavr.<filename>.pk’ for 

each file for which it cannot find the full path. You must make sure that you use 

unique names for avr files of different experiments/subjects (this is common 

practice anyway). 

Also, the ‘xavr.components.pk’ file will not be deleted; so, it will always contain 

the data of the last startup of the average viewer, as performed through the 
Databrowser. This is actually a nice way to quickly assemble ‘peak’ data to one file 
for subsequent statistical analysis. 

7.2.3. Using multiple instances of the average viewer 

As with the continuous data viewer, you can start multiple instances of the average 

viewer (when selecting multiple cnt files in the Workset, the Databrowser will 

simply start the xcnt viewer for every file, as separate processes). 

Start the average viewer more than once by switching back to the Databrowser 
window (e.g., by using <Alt+Tab>, or via the taskbar – if present in your window 

environment). Make a selection of avr files in the Workset, and start another 

instance of xavr. 

Configuration files 

The viewer will be started with the same set of configuration files, so be careful when 

making changes (xavr menu: Edit, Configuration). 

Components file 

However, this second startup from the Databrowser will detect that a 

‘.xavr.components.pk’ (hidden file) is present, and will use a different name for the 

overall components file: ‘xavr.components-1.pk’ that is passed to xavr on the 

command-line. The sequence number ‘1’ is updated for every subsequent start of 

xavr through the Databrowser (based on the presence of the hidden file 

‘.xavr.components-1.pk’, etc.).  

The file permissions of the overall components file(s) are set to read/write access 
(mode ‘0666’) for everybody (e.g., on the network). The hidden files will be deleted 

automatically after you exit the xavr viewer. 

If at one time you experience that you have difficulty saving a components file, this 
may be due to sharing a project with another user on a drive where you cannot 
change the file permissions. In that case please check with your system administrator, 

or ask the other users to delete or move their ‘xavr.components.pk’ files and any 

hidden files, if present. 
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8. THE ‘SELECT’ FEATURE 

Usage tips for file browsing and grand averaging 
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8.1. Working with ‘Select’ on datafiles 

8.1.1. File selection 

The check-buttons and the ‘Select’ field provide a flexible way of ‘filtering’ the list 
of files as shown in the Datafile listbox: 

 

 

Figure 8-1 The ‘Select’ feature is available in the Databrowser’s main window. 

 

The check-buttons ‘avr’, ‘cnt’, ‘trg’, ‘ps/pdf’, ‘txt’ will result in the display of only 
those file types corresponding to the ‘checked’ buttons. This can be used to quickly 
find the appropriate files for a certain processing/review step. 

For the last file type ‘txt’ you can actually choose from a list, which includes all of 
the file types as used in EEProbe. You can also type a custom file extension here. 

You can click on a check-button with the mouse to turn it ‘on’ or ‘off’.  

When you are ‘in’ the Datafile listbox (as indicated with a special colored square), 
you can also turn on/off this file selection mechanism by pressing the keys that 
corresponds to the underlined characters (see Figure 8-1). 

 

The ‘Select’ entry field / list allows you to enter a regular expression to make a sub-
selection of files in the Datafile listing. You can learn this behavior best by doing: 
start by typing the characters of a filename that you see in the Datafile listbox. 
During the typing of characters, the listing will update and show fewer and fewer 
files. Only those matching your typing will remain. 

So, you see that you can find quickly a sub-set of files, just by typing some ‘normal’ 
characters, without bothering about regular expressions. 

The regular expression feature is actually a powerful search mechanism; when you 
enter for instance ‘[fr].cnt’, you can find the files: 

m101f.cnt 

m101fr.cnt 

m101r.cnt 

 

The ‘.cnt’ in the entry here is actually optional, you can achieve a similar (sometimes 
not completely identical!) listing by typing only ‘[fr]’ and ‘checking’ the ‘cnt’ button. 

You can learn more details about regular expressions in Appendix B: “Regular 
expressions”, page 99. 

 

The entries that you type in the ‘Select’ field are automatically kept in a list, which is 
available through the  button). However, the list is not stored between sessions of 
the Databrowser (and is also cleared when you open/create a project). 

© 2000-2003 A.N.T. SOFTWARE BV EEPROBE 3.1 90 



EEPROBE USER MANUAL  The ‘Select’ Feature [ Working with ‘Select’ on datafiles ] 

Quickly clear the entry field by clicking on the ‘Show All’ button (or by pressing 
<Escape>). If the ‘Select’ field is empty, the ‘Show All’ button will turn off all 
check-buttons. 

 

Next to the ‘Show’ label, only a selected number of check-buttons for some 
‘standard’ types of files are available. However, there are more types used in 
EEProbe, identified by their file extension; these are available in the ‘lookup-list’ 
associated with the last checkbutton. 

To find ‘result’ files associated with your avr files, you can make use of regular 

expression, as illustrated in the two figures below: 

 

 

Figure 8-2 Find ‘peak’ (components) files associated with your averages. 

 

Figure 8-3 Find ‘baseline’ files associated with your averages, using a regular 

expression. 

As shown in Figure 8-3 the extensions for the two file types can be separated with a 
comma. The average file extension was entered as ‘avr$’, which indicates that the 
string ‘avr’ should be at the end of the filename (regular expression syntax). The ‘$’ 
was added in the above examples, because the directories also contained some files 

‘xavr.ps’, which would otherwise show up in the listing. You can make use of 

expressions like this, to quickly find files in all sub-directories for experiments (read 
on). 
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Find files 

The ‘Select’ entry can also be used to find specific files (e.g., filtered files, or files 
relating to a certain condition) in the complete directory structure of an Experiment 
(including all subject sub-directories). Just enter your search string (e.g., ‘f.cnt’) and 
use the context menu (right-click) of the Experiment (or Subject) listboxes. Here, the 
‘find’ functions use the ‘Select’ entry to search in all sub-directories of the selected 
Experiment (or Subject). 

These ‘find’ functions do not take into account any of the check-buttons for the 

standard file types next to the ‘Show’ label. 

The use of the ‘find’ function will be illustrated in the next section 8.2. 

 

8.1.2. Organize your average files 

Often, you will want to find a set of average files in the Datafile listing. You can 
probably achieve this using the ‘Select’ feature as described in the previous 
paragraph. However, it becomes more difficult if you have a lot of conditions or want 
to compare the average results when using different parameters in different 
processing steps.  

To overcome this, you use different output paths during the averaging step. In the 

bottom of the ‘Analyze: Average’ dialog (cntaverage) you can specify the sub-

directory (directories) for the averages (also see page 39): 

 

 

Figure 8-4 Use the ‘Output path’ during averaging. 

For instance, to see the difference of the effect of filtering and rejection, you could 
write the result files to a set of sub-directories: 

filter/norej 

filter/rej 

nofilter/norej 

nofilter/rej 

 

Result files in sub-directories will be displayed first in the Datafile listing (see for 
instance Figure 8-3). 
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8.2. Support for grand averaging 
 

The ‘Select’ entry field also has a lookup list attached that automatically stores your 
‘selection’ entries. 

When you have ‘checked’ the ‘avr’ file type, the listbox will automatically show the 

conditions as found in the projects cntaverage configuration files (file mask: 

*cntaverage*.cfg) (this requires that you have selected a subject): 

 

 

Figure 8-5 Create a ‘filter’ for sub-selection of average files. 

Each entry in the ‘Select’ list will show a regular expression (regex) that corresponds 
to the average file name of a certain condition. For example, in chapter 5, we have 
performed some averaging, using the alias ‘d1’ for the P300 deviant tones (page 
73).This condition will be available in the list as regex ‘d1[id]*.avr’.  

Each condition can be identified by its name11, as shown in Figure 8-5. 

The regular expressions allow the display of average files that may have been 
included in further processing: 

• When you have performed ‘Channel interpolation’, the avr file name will 

have been appended with ‘i’. 

• When you have performed ‘Detrending’, the avr file name will have been 

appended with ‘d’. 

You can easily adapt the regex’s for filtered averages (‘f’), rereferenced (‘r’) or 
downsampled (‘s’) averages. 

                                                      
11 Any text placed between parentheses will not be included in the regular expression. 
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After selection of the proper condition we can use the context menu (right-click) of 
the Experiment, and automatically find all average files that match the regex of the 
condition (see Figure 8-6).  

All ‘find’ functions in the context menu for Experiments and 
Subjects use the ‘Select’ entry to search the directory structure. 

After the files have been listed in the Workset, you make a selection, and go to the 
‘Grand Average Process’ function in the Analyze menu (see paragraph 3.4.2, page 
45). 

However, this is still a lot of work when you have to perform this procedure for a 
great number of conditions, or need to calculate a grand average often within your 
analyses. A more powerful solution for grand averaging of multiple conditions, 

multiple files is available using the EEProbe program avraverage, which is described 

in the EEProbe Reference manual. 

 

 

Figure 8-6 Find all files matching the selected condition. 

 

Please note that: 

 ‘Select’ entries for different conditions may not be unique, and a 

‘find’ action may include avr files of more than one condition. 

In the averaging procedure, you are actually advised to use an alias always, and 
always use (unique within an Experiment) a combination of 2 characters (see page 
39, “Analyze: Average”). 
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Appendix A: SHORTCUTS 

Keyboard and mouse shortcuts 
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A.1 Keyboard and mouse shortcuts 
Below, “Button 1” refers to the left mouse button, “Button 3” to the right one. The 
proper function of these buttons (and also the mouse wheel - scroll button) may 
depend on your mouse configuration. The “Return” key is often indicated as “Enter” 
or using the symbol . The Left, Right, Up, Down buttons are the  keys. 

Main window 

Key Action 

F1 Help Contents (the on-line EEProbe Reference manual) 

Alt+F Open the File menu 

Alt+R Open the Recording menu (if enabled) 

Alt+V Open the View menu 

Alt+A Open the Analyze menu 

Alt+T Open the Tools menu 

Alt+S Open the Scripts menu 

Alt+H Open the Help menu 

In the menus, the accelerator keys are underlined. You can also use the arrow keys to 
maneuver; press the ‘Return’ key to activate (run) a menu entry. 

Ctrl+T Open the terminal program 

Ctrl+O Open a new project 

Ctrl+N Create a (new) project 

Ctrl+I File Import 

Ctrl+E File Export 

Ctrl+Q Quit the Databrowser 

Left, Right12 Move the ‘focus’ to the left/right on the Experiment, 

Subject, Datafile and Workset listboxes 

Tab Move the ‘focus’ between Experiment/Subject/Datafile/ 
Workset and the ‘Select’ field (below the Datafile listbox) 

General listbox behavior: 

Up/Down Move the cursor up, down in a listbox 

Home/End, PageUp/PageDown Move the cursor to start, end, page up/down 

 

Experiment listbox 

Key Action 

Button-1 Select experiment 

Button-3, F11, Ctrl+F (for ‘find’) Context menu 

Delete Delete experiment (with confirmation) 

I Directory, file info, show subject dir size 

R Refresh the directory listing 

N Create a new experiment 

Ctrl+R Rename the current selected experiment 

 

                                                      
12 For ‘vi’-adepts we have also implemented the following keys: h, j, k, l, Ctrl+d, Ctrl+u, 
(Shift+)G. Except for ‘G’, the Shift key (e.g., Shift+J, Shift+K) is implemented to ‘extend’ a 
selection (Datafile and Workset). However, these keys only work in the main window. 
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Subject listbox 

Key Action 

Button-1 Select subject 

Button-3, F11, Ctrl+F (for ‘find’) Context menu 

Delete Delete subject (with confirmation) 

I Directory, file info 

R Refresh the directory listing 

N Create a new subject 

Ctrl+R Rename the current selected subject 

 

Datafile listbox 

Key Action 

Double-click Button-1 Add the file under the mouse to the Workset 

Return Add the current file selection to the Workset 

Button-1 Select datafile 

Shift+Button-1 Extend the file selection 

Ctrl+Button-1 Add/remove the file under the mouse to/from the selection 

Drag Button-1 Extend file selection 

Shift+ Up/Down, Home/End, 
PageUp/PageDown 

Extend the file selection in the direction of the key 

Ctrl+A Select all files in the current listing 

Button-3, F11 Context menu 

Delete, Ctrl+X Delete file (with confirmation) 

I File info 

R Refresh the file listing 

Ctrl+R Rename the current selected file 

Ctrl+C Copy the current selected file 

A Turn on/off the ‘avr’ check-button 

C Turn on/off the ‘cnt’ check-button 

T Turn on/off the ‘trg’ check-button 

X Turn on/off the ‘txt’ check-button 

P Turn on/off the ‘ps/pdf’ check-button 

Escape 1st) Delete any ‘Select’ entry, 2nd) turn off all check-buttons 
(works identical to the ‘Show All’ button) 

The ‘Select’ field 

Key Action 

F1 Show the help for the check-buttons and Select entry 

Tab, Return Move the ‘focus’ to the previously active listbox 

Up, Down Select the previous, next entry available in the list 

Shift+Up, Shift+Down Open the list (identical to a click on the  button) 

Escape 1st) Delete the Select entry, 2nd) move ‘focus’ to previous 
listbox 
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Workset 

Key Action 

Double-click Button-1 Default action on file under the mouse (view for cnt, avr, 
ps/pdf files, edit for known text types, file info otherwise) 

Return Perform default action on current file selection 

Button-1 Select file 

Shift+Button-1 Extend the file selection 

Ctrl+Button-1 Add/remove the file under the mouse to/from the selection 

Drag Button-1 Extend file selection 

Shift+ Up/Down, Home/End, 
PageUp/PageDown 

Extend the file selection in the direction of the key 

Ctrl+A Select all files in the current listing 

Button-3, F11 Context menu 

Delete, Ctrl+X Clear the current selection (the files will be removed from 
Workset listing, this is not a file delete) 

I File info 

Escape Deselect all 

 

Analysis / Tools dialogs windows 

Key Action 

F1 (on an item in the dialog) Show the context help (same as the ‘?’ keys) 

Return Validate the item’s contents (invisible action, unless you 
have a ‘debug’ level > 0) 

Ctrl+R Read configuration file 

Ctrl+S Save configuration file 

Ctrl+D Turn on/off ‘Keep as Default Configuration’ (this option 
works with the ‘Apply’ button, and by clicking on ‘Close’) 

Ctrl+Return Same as the ‘Apply’ button: run the current command 

Escape Close the dialog (if the ‘Keep as default...’ button was on, 
this is cleared first: press ‘Escape’ again to close the dialog) 

 

Create new project dialog 

Key Action 

Ctrl+Return Same as ‘Create’ button 

Return, Escape Same as ‘Close’ button 

The ‘Overwrite’ question dialog (recreate files in an existing project): 

Return Same as ‘Yes’ button 

Escape Same as ‘No’ button 

 

Other dialog windows  

This applies to Error, Warning, Notice, Question and File dialogs. 

Key Action 

Return Same as ‘OK/Close/Open’ button 

Escape Same as ‘Cancel/Close’ button 

 

© 2000-2003 A.N.T. SOFTWARE BV EEPROBE 3.1 98 



EEPROBE USER MANUAL  Regular expressions [ REGEXP quick reference ] 

Appendix B: REGULAR EXPRESSIONS 

REGEXP quick reference 
The text in this appendix was adapted from the “Python Library Reference”. 

A brief and somewhat simplified explanation of the format of regular expressions is 
given. For further information consult the Regular Expression HOWTO, accessible 
on the Internet, at http://www.python.org/doc/howto/.  
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B.1 Regular expressions summary 
A regular expression (short: regexp or RE) specifies a set of strings that matches it. In 
the EEProbe programs, this lets you check if a particular string matches a given 
regular expression, to select a subset of channels, or files.  

Regular expressions can contain both special and ordinary characters. Most ordinary 

characters, like "A", "a", or "0", are the simplest regular expressions; they simply 

match themselves. You can concatenate characters, so last matches the string “last”.  

Some characters, like "|" or "(", are special. Special characters either stand for 

classes of ordinary characters, or affect how the RE around them are interpreted.  

The special characters are:  

"."  

(Dot.) In the default mode, this matches any character. 
"̂ "  

(Caret.) Matches the start of the string.  
"$"  

Matches the end of the string. For example, foo matches both 'foo' and 

'foobar', while the regular expression foo$ matches only 'foo'.  
"*"  

Causes the resulting RE to match 0 or more repetitions of the preceding RE, 

as many repetitions as are possible. ab* will match 'a', 'ab', or 'a' 

followed by any number of 'b's.  
"+"  

Causes the resulting RE to match 1 or more repetitions of the preceding RE. 

ab+ will match 'a' followed by any non-zero number of 'b's; it will not 

match just 'a'.  
"?"  

Causes the resulting RE to match 0 or 1 repetitions of the preceding RE. ab? 

will match either 'a' or 'ab'.  
"\"  

Either escapes special characters (permitting you to match characters like 

"*", "?", and so forth). Use '\\' to include the literal backslash character 

'\'. 
[]  

Used to indicate a set of characters. Characters can be listed individually, or a 
range of characters can be indicated by giving two characters and separating 

them by a "-". Special characters are not active inside sets. For example, 

[akm$] will match any of the characters "a", "k", "m", or "$"; [a-z] will 

match any lowercase letter, and [a-zA-Z0-9] matches any letter or digit. If 

you want to include a "]" or a "-" inside a set, precede it with a backslash, 

or place it as the first character. The pattern []] will match ']', for example.  

You can match the characters not within a range by complementing the set. 

This is indicated by including a "̂ " as the first character of the set; "̂ " 

elsewhere will simply match the "̂ " character. For example, [̂ 5] will match 

any character except "5".  
"|"  

A|B, where A and B can be arbitrary REs, creates a regular expression that 

will match either A or B. To match a literal "|", use \|, or enclose it inside a 

character class, as in [|].  

In the Databrowser, you can actually use a comma for this: e.g., list peak 
files and average files in the ‘Datafiles’ pane: type “pk,avr” in the ‘Select’ 
field. 

© 2000-2003 A.N.T. SOFTWARE BV EEPROBE 3.1 100 



EEPROBE USER MANUAL  Notes [ Notes relating to the current version ] 

Appendix C: NOTES 

Notes relating to the current version 

• Known issues, usage tips  

• Reporting bugs 
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C.1 Known issues, usage tips 

C.1.1 Known issues 

Output file overwrite 

The EEProbe programs overwrite output files without prompting. This is the default 

behavior of the programs, e.g., using the cntfilter program on m101.cnt, its output 

will be written to m101f.cnt. For some users this is an undesired feature; for now, we 

decided not to implement any warning on top of this standard behavior. 

Startup failure of commands 

Some EEProbe programs may seem not to start under certain conditions. For 
instance, when the EEProbe license has expired, the output error message related to 

this is displayed only in the console window from which eeprobe was started.  

You are therefore advised always to run the EEProbe Databrowser from a 
console/terminal window. Even when starting the ‘eeprobe’ command via an icon on 
your desktop, most X window managers allow you to specify ‘startup via terminal 
application’. 

C.1.2 Usage tips 

Configuration files 

The names of the default configuration files are lower case. The EEProbe 
Databrowser uses lower case for all default configuration files. On Linux systems, 

the files xavr.cfg and XAVR.CFG are different files! 

Comments in configuration files. Configuration files with comments (lines that start 
with a semi-colon ‘;’) can be read, but will be saved from within the Databrowser 
without comments. 

File naming 

Although the EEProbe Databrowser adheres to the standard Linux support for the use 
of ‘spaces’ in file names, you are advised not to use this. The current implementation 
for building and starting the command lines of the EEProbe programs does not 
always support the use of spaces in filenames. 

Links 

You may experience problems when using ‘links’ created with the ln command. In 

general, the EEProbe Databrowser does have complete support (symbolic) links for 
files within a project (directory structure). However, the behavior of links can vary 
between machines and Linux installations. 

However, you may use links for the top-level project directory. 

You may also successfully use links for the experiment, and subject directories. 
However, you may experience difficulties trying to rename or copy files/directories 
from within the Databrowser (right-click menus). 
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C.1.3 Installation support 

Supported platforms: 

• PC i386 

Currently supported Linux distributions: 

• Redhat 6.2, 7.x, 8 

• Debian 2.2, 3.0 

• SuSE 7.x, 8.x 

The EEProbe Databrowser requires the correct installation of Python2 and Tkinter2. 
For details about Python, visit the Python web-site; http://www.python.org 

Most Linux distributions contain standard installation files for Python2 and 
Tkinter2; unfortunately, these are often not installed in a default system setup. 

I you experience any difficulties or need help on a specific distribution: please 
contact ANT for support. 

C.1.4 Dependencies 

The EEProbe script library and EEProbe Databrowser itself make extensive use of 
some ‘standard’ system commands. Therefore it is required that the following system 
commands are available: 

awk  (/usr/bin/awk) 

basename 

bash  (/bin/bash) 

cat 

chmod 

df 

du 

file  (/usr/bin/file) 

find 

grep, egrep 

perl  (/usr/bin/perl) 

pwd 

sed 

su 

 

C.1.5 The startup script ‘eeprobe’ 

The EEProbe Databrowser program is started with the command 

 

  eeprobe 

 

You can display a short explanation of its advanced usage by adding the ‘-h’ switch: 
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----------------------------------------------------------------------------- 
ANT Software b.v. (c) 2003 - EEProbe Databrowser startup script (rev 1.47) 
eeprobe - mvelde - Tue May  6 10:35:06 CEST 2003 
----------------------------------------------------------------------------- 
eeprobe - startup/install facility for the EEProbe Databrowser 
 
typical usage: 
  eeprobe 
  eeprobe -p project_dir 
or: 
  eeprobe [ --update | --default | --help | -h ] 
 
for experts only: 
  eeprobe --compile 
  eeprobe <module>.py 
 
  optional arguments: 
    --update [section] :  this updates the per-user settings file with new sections; 
                          specify a specific section, or when omitted the sections  
                          newproj_dir and newproj_file are updated 
                          (useful after installing an update) 
    --default          :  this forces a fresh copy of the settings file 
                          (reset any changes made in the Settings dialog) 
    --help (or -h)     :  this help text 
 
  expert arguments: 
    --compile          :  creates the compiled python files *.pyc for all modules 
                          for run-time optimization (requires the root password) 
    <module>.py        :  runs only the specified module (dialog testing) 

 

Below, some more help is given on the usages and different arguments of this script. 

When you start by typing only: 

  eeprobe 

you will open the default project as indicated in the ~/.eep/settings file. This 

setting can be adjusted easily in the Settings dialog. When you have specified a 
PROJDIR environment variable, this will override the default project. 

 

When you start as: 

  eeprobe –p /data/eeprobe-project/erp 

you will open the project directory /data/eeprobe-project/erp as specified. If this 

is not a valid path, the program will warn you after the main window of the 
Databrowser has started. This command line setting will override a PROJDIR 
environment variable, and overrides the default project. 

 

When you issue the following command: 

  eeprobe –-update 

you will update your $HOME/.eep/settings file with a list of files that make up a new 

project for EEProbe. This is useful after installing an update of the Databrowser 
program, when files may have changed or added.  

To add new files to an existing project: select ‘Create Project’ from the ‘File’ menu, 
click on the ‘Create’ button. The Databrowser will prompt you to overwrite files that 
are already present.  

Tip: use the <Enter> key for ‘Yes’, and <Escape> for ‘No’.  
If you click on ‘No to All’, only non-existing files will be created. 
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You may use the –-update command also for example to update only specific 

section(s) in the settings file: 

  eeprobe –-update importers exporters 

This is for instance needed when certain sections have a new implementation (e.g., 
the indicated sections for the ‘import’ and ‘export’ facility where updated in release 
1.1.2.0). 

 

When you issue the following command: 

  eeprobe –-default 

you will simply copy the default file /opt/eep/eeprobe_gui/settings to your 

$HOME/.eep/settings file. 

 

When you have installed the required Python2 version after installation of the 
Databrowser, you can still use all of the above functions. However, you may 
experience that the Databrowser can run somewhat faster after the following 
command: 

  eeprobe –-compile 

This will optimize the run-time interpretation by the python interpreter of the scripts 
that constitute the EEProbe Databrowser. If you are not ‘root’, you will still need to 
type the ‘root’ password, because this procedure needs to write the compiled python 

files *.pyc to the /opt/eep/eeprobe_gui directory. 

 

The last option is best illustrated by doing; type: 

  eeprobe cntaverage.py 

to show the Databrowser’s dialog of the cntaverage program. The dialog will have a 

different ‘look’ than in a normal startup, because it will not use the display settings as 

defined in your $HOME/.Xdefaults file. 

This is not useful for processing, but python developers use this for testing. 

C.1.6 Bug reporting 

When submitting a bug, please answer any relevant questions as suggested below, 
and supply the any additional information that you deem relevant: 

• The Linux distribution, kernel version? 

• Is it a bug in the Databrowser? or 

If in the Databrowser, which dialog window  
(look at the caption bar for its title)? 

• Is it a bug in one of the EEProbe programs? 

• If yes, which EEProbe program, e.g., avraverage, cntfilter, xavr? 

• What configuration file(s) did you use? 

• Is the error easily reproduced, and can we have access to the data file(s) that 
you used? 
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C.2 Copyright information 
 

EEProbe GUI version 1.1 

 

Copyright (c) 2000-2003 ANT Software 

 

For more information visit http://www.ant-software.nl 

 

Parts of this application are: 

Copyright (c) 1995-2001 Corporation for National Research Initiatives 

Copyright (c) 1991-1995 Stichting Mathematisch Centrum, Amsterdam 

Copyright (c) 1997-2001 by Telstra Corporation Limited, Australia (ACN 051 775 556) 

 

 

The EEProbe Databrowser is distributed under a ‘Modified BSD’ license; see the 

LICENSE file in the installation directory. 

 

 


