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This brief guide to translating FrameMaker and Structured FrameMaker docu-
ments concentrates on handling multilingual translations of complex docu-
ments in the biopharmacy field. This industry and the entire medical and life 
sciences sector that it is part of, are highly regulated in terms of documentation 
and require exact translations into the official languages of all countries where 
the biopharmaceutical firm is established. Documentation must not only 
present required information, it must do this in a format that complies with 
industry-wide standards and regulation. Documents in this field include 
product notices, installation qualifications, safety precautions, operating quali-
fications, product marketing flyers and brochures, and have to be translated 
into twenty to thirty different languages, many of which pose particular prob-
lems such as character encoding, word length and writing direction. 

In the biopharmacy field, you will find both SGML and XML although the 
former is becoming less common. In particular, there are fewer and fewer 
biopharmaceutical documents produced in classic, “unstructured” 
FrameMaker. With its capacity to define what an element must include, XML is 
an ideal medium for biopharmaceutical documents where regulations and stan-
dards require specific types of information. The use of XML and specifically 
FrameMaker structured applications in this sector is therefore bound to 
continue to increase.

FrameMaker is a powerful but complex tool Not mastering this complexity can 
make translation complicated and generate production overruns. Fortunately, 
MemoQ offers an environment in which you can master this complexity and 
avoid some of the inherent problems that might arise. 

The complexity of FrameMaker can be summarized as follows:

• A structure of book (aggregating file) and chapter documents that allows 
you to create long documents with coherent numbering and pagination 
properties.

• Three types of page structure known as body pages, master pages and 
reference pages.

• Rich character and paragraph design palettes.

• Coherent cross-reference, indexing and table of content creation features.

The overall objective of this document is to help LSPs avoid traps and even 
generate new sources of revenue associated with translating Structured 
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FrameMaker documents. By constantly following a coherent workflow, the 
complexity can work for you rather than being an obstacle or source of prob-
lems.

Structured FrameMaker only adds an adjective to the product name, but repre-
sents a completely different type of document: well-defined SGML or XML 
documents. 

Project management objectives

The objectives in preparing and processing FrameMaker documents are as 
follows:

• Translate only what is strictly required. (To save time and money, and also 
generate money on return business where the customer may use variables, 
Cross-Reference formats and Markers that he/she isn't using in the 
current project)

• Avoid any unecessary last-minute editing in FrameMaker (time and 
resource-consuming)

• Eliminate potentially confusing, extraneous text for the translator (reduce 
questions and possible sources of translation error ... lack of context).

FrameMaker

Managing translation of non-XML FrameMaker documents

When translating classic FrameMaker documents, you encounter the following 
common workflows:

Source file Format for MemoQ Deliverable

Binary FM MIF Binary FM plus a published form such as 
PDF

MIF MIF MIF and publication as PDF
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Some of the problems you may find include:

• Character encoding problems particularly with versions of FrameMaker 
prior to version 8, or workflows using other tools such as older versions of 
Microsoft Word, for example.

• Hyphenation problems when margin-based titles are used.

• Key text on master pages not translated. This could include document 
reference numbers that change with each language, or words like “page” 
not translated into the target language.

• Book-wide or document-wide variables that aren’t selected for transla-
tion.

Pre-preparation inspection

Because FrameMaker is a complex tool that can produce highly complex, long 
documents, you need to check documents that you receive for translation. 
There may be text to translate that is not accessible in the body page view, and 
variables that are not easy to access and that need not be translated.

TASK

1. If you receive a MIF file, open it in a text editor and check whether the 
author generated the MIF in FrameMaker 7, 8, 9 or 10. 

ADDITIONAL INFORMATION: New file to add: Avoiding character encoding prob-

lems 1. Problem when FM 7 files are delivered ... If your client delivers a MIF, 

check heading and look for \xnn ... Save as FM 8, 9 or 10, export new MIF and 

check for UTF conversion (optional).If material is delivered as Word files (not 

recommended but preferred by some clients who think of Word as a tool to 

use to sketch out layout and/or changes to the layout). Warning. The trans-

lator may not be using a system or a Word installation operating with UTF-8, 

they may still be language-specific ASCII. Try re-saving the document in Word 

2007 or Word 2010 (Can you select character-encoding this way?).

Microsoft Word MIF after inserting 
text into FM model 
and saving in the 
interchange format.

Binary FM plus a published form such as 
PDF

Source file Format for MemoQ Deliverable
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2. Preview the new document in FrameMaker.

a Click View > Body pages, View > Master pages and View > Reference 

pages to check alls aspects of the document pages  in order to see 

where translatable text is. Note: translatable text is not necessarily 

confied to body pages.

b Click Find > Any Variable to check for variables that requires transla-

tion.

c Click Find > Any Cross-Reference to check the Cross-reference formats 

for text that requires translation

d Click Special > List of > Markers to check markers for text that requires 

translation

3. If you find translatable text in any of the searches outlined in 4. above, 
make sure you use the Master pages or Reference pages options 
presented in the Preparation procedure section to add your document.

Preparation procedure

When you have identified all features that need to be translated in the source 
material, you are ready to prepare the material in a way that allows you to avoid 
random ad-hoc rectifications that add time and cost overruns to your project.

TASK

1. If you receive an FM source document, before you open it, click File > 
Preferences > Remember Missing Font Names just in case the 
customer's fonts are missing on your system.

ADDITIONAL INFORMATION: If the customer’s fonts are in fact missing, FrameMaker 

will report which font is missing and which substitute font is being used in a 

message window when you open the file. You should note 

that the fonts will be different in any PDF output you produce because this 

could be a source of confusion for your customer. When your customer opens 

the FM file, the correct fonts will be used.

2. Click File > Save as. In the dialog box, click MIF 9.0 or if you are using 
an older version, MIF (*.mif) to generate the MIF file for translation in 
MemoQ.

3. Click Save as PDF (FrameMaker 9.0 and higher) or Print and then select 
a PDF printer to generate a PDF version of the source document, so that 
the translator has a reference layout with the same fonts as you as 
opposed to those of your customer.
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4. Click Translations tab > Add document as to add the MIF file created 
in 2. above.
• If you have translatable text on the master page, e.g. in headers and 

footers, check the Master pages checkbox and leave the default selec-
tion Body pages as is.

• If there is not translatable text on the master page or the reference page, 

leave the Body pages checkbox selected. This is the default setting.

5. Open the document you have just added, find any segments 
containing unused Cross-reference formats, variables and markers (on 
basis of what you found in the Pre-preparation inspection section 
above), click Edit > Copy source to target and double-click the trans-
formation status icon (a red X or a green checkmark) to lock each of 
these segments. 

6. Click Edit > Copy source to target and double-click the transformation 
status icon to lock any segments containing only non-translatable text 
e.g. product reference number, manual reference number, product 
name, e.g. in footers.

7. Calculate the document statistics.

8.  Click Translations tab > Export bilingual as > MemoQ Bilingual 
Document to export the bilingual document as an MBD or Transla-
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tions tab > Export bilingual as > XLIFF to export the bilingual docu-
ment as an XLIFF file. 

Translation procedure

Your files are now ready for translation. You can send them to the translator.

TASK

1. Send the bilingual document and PDF of source document to transla-
tors.

2. When the translator returns the finished work, click Translation tab > 
Import/Update bilingual to import the bilingual document to 
MemoQ.
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3. Click Project > Export document to generate a MIF file in the target 
language.

4. Open the translated MIF in FrameMaker and check the compliance of 
translated document formating with the formating in the model as well 
as no double spaces, missing punctuation etc.

5. Generate another PDF file and if you made changes in 4. above, export 
a bilingual RTF, MBD or XLIFF version and send it to the translator for 
translator proofreading / double-checking compared to the source 
PDF.

6. If translator makes changes, import the new bilingual document to 
MemoQ and repeat steps 3. and 4. above.

Proofreading procedure

TASK

1. Click Translations tab > Export bilingual as and select the RTF Bilin-
gual Document radio button to export a bilingual RTF file.
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2. Generate a new PDF. Open the new PDF in Adobe Acrobat Pro (any 
version higher than 7) and click Comments > Enable for Commenting 
and Analysis in Adobe Reader. This is in the likely event that your 
customer has Adobe Reader rather than Adobe Acrobat Pro. Your 
customer will now be able to make corrections directly in the PDF file, if 
desired
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3. Send PDF and bilingual RTF versions of translation to customer.

4.  Encourage corrections in the form of Post-its/comments OR Correc-
tions and/or comments in bilingual RTF.

ADDITIONAL INFORMATION: Choice is important: some customers are uncomfort-

able working outside the layout, especially if it is complex.

5. Integrate customer corrections to MemoQ MIF file using the 
customer-commented PDF file OR the customer-commented bilingual 
RTF file. 
• If the customer has used comments in the PDF file to correct the trans-

lation, open the Comments view and copy the changes to the transla-
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tion document in MemoQ, indicating the changed status in each PDF 

comment.

• If the customer has used the bilingual RTF file to correct the translation, 

click Translations tab > Import/update bilingual to import the 

changes in this file.
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6. Regenerate a target language MIF file.

7. Open the MIF file and click Save as PDF or Print and select your PDF 
printer to regenerate an updated PDF file of the translated work.

Structured FrameMaker

Managing translation of Structured FrameMaker documents

In both SGML and XML in FrameMaker, you can work in a purely SGML or 
XML production process, or use binary structured FrameMaker files as an 
intermediary format. Binary structured FrameMaker documents have a copy of 
the FrameMaker template and EDD (Element Definition Document) 
embedded in each binary file. This means that you don’t need the DTD, 
read/write rules or templates to view and edit the files. You will not, however, 
be able to save them as XML files, which, as shown in the table below, is the 
required file format to add this type of document to a MemoQ project.
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Consequently, the optimal start to translation of Structured FrameMaker docu-
ments is for your customer to provide you with XML files and the corre-
sponding DTD. If you want to open the document in FrameMaker for 
inspection, editing and generating PDF versions, you will need to define the full 
structured application. In this scenario, you need the read/write rules and 
template files as well as the DTD. In fact, it is a good idea to ask for the extra 
structured application files, particularly if you are going to be working with your 
customer on a long-term basis. Defining the structured application gives you 
flexibility to optimize your production process.

In both SGML and XML in FrameMaker, you can work in a purely SGML or 
XML production process, or use binary structured FrameMaker files as an 
intermediary format. Binary structured FrameMaker documents have a copy of 
the FrameMaker template and EDD (Element Definition Document) 
embedded in each binary file. 

As we noted above, MemoQ does not support MIF exports of binary structured 
FrameMaker files though. So you have to use the XML files in your translation 
projects. Now, Structured FrameMaker allows you to use traditional paragraph 
designer and character designer menus to perform format overrides, e.g. reduce 
a point size or change a font on the paragraph or character level. However, all 
such non-structured format overrides are stripped away when the document is 
"saved as XML" in preparation for translation. So you have to engineer your 
production process carefully to avoid accidents.

Pre-preparation inspection

TASK

1. Make sure that along with the file for the document to be translated, 
you get the DTD, read-write rules, and any template file that the DTD 
references.

Source file Format for MemoQ Deliverable

Binary Structured 
FrameMaker

XML Binary Structured FrameMaker plus a 
published form such as PDF

XML XML XML plus a published form such as PDF
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2. Set up the structured application for this document type as outlined in 
the Defining a structured application section.

ADDITIONAL INFORMATION: Note that this step is optional and/or dependent on 

whether your customer supplies you with the read-write rules and templates. 

It is, however, preferable because it allows you to produce PDF files of the 

translation to return to the translator for review. This is highly advisable 

because complex layouts affect how we interpret the text.

Defining a structured application

If your customer provides you with binary Structured FrameMaker files, you 
must define the corresponding structured application in order to save the 
binary files as XML files. This is because MemoQ only supports XML files in 
Structured FrameMake translation, not Structured FrameMaker files saved as 
MIF files. A better solution is for your customer to provide you with XML files. 
In both cases, the customer must supply you with the DTD. In the structured 
application scenario, you also need the read/write rules and template files. Even 
if you receive XML files, you should ask for the extra structured application files, 
particularly if you are developing a long-term relation with your customer. 
Defining the structured application gives you flexibility to optimize your 
production process.

TASK

1. Copy the DTD, read-write rules and template files into the structure 
directory of your FrameMaker installation: C:\Programs\Adobe\Adobe 
FrameMaker 9\Structure\xml or C:\Programs\Adobe\Adobe Technical 
Communication Suite 2\Adobe FrameMaker 9\Structure\xml

2. Click StructureTools > Edit Application Definitions to add the defini-
tion of the new structured application to your FrameMaker installation.
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STEP RESULT: The Structured Application Definition Document structapps.fm 

opens for editing.
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3. Click the STRUCTURE VIEW icon in the structure tool pod (by default 
located or “docked” on the right hand side of your FrameMaker 
window, or click StructureTools > Structure View.

STEP RESULT: The structure view window opens for structapps.fm.

4. Place the cursor on the vertical trunk line that represen ts the first level 
of the XML document. 
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5. Click the Elements icon in the same pod and then click XMLApplica-
tion.
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6. Click the Insert bar at the bottom of the pane.
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7. Enter the name of the structured application. You will find this in the 
root element declaration in the DTD file: <!ELEMENT 
element_name content_specification>, where 
content_name is the name of the application and 
content_specification is the list of the names of the content 
elements in the application. If in doubt, check with your customer.

8. In the Structure View, place the cursor below the Application Name 
element. Click the Elements icon and then click DTD.
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9. Enter 
$STRUCTDIR\xml\application_name\DTDfileName.dtd as 
the path to the DTD file.

10. In the Structure View window, place the cursor below the DTD element. 
Click the Elements icon and then click ReadWriteRules.
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11. Enter 
$STRUCTDIR\application_name\ReadWritefileName.rw 

as the path to the ReadWrite rules file.

12. In the Structure View window, place the cursor below the ReadWriteR-
ules element. Click the Elements icon and then click Template.
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13. Enter 
$STRUCTDIR\xml\application_name\TemplateFileName
.tpl as the path to the template file.

14. In the Structure View window, place the cursor below the Template 
element. Click the Elements tab and then click DOCTYPE.
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15. Enter applicationName as the document type.

16. Save structapps.fm.

STEP RESULT: Your new application is now available. When you open your 

customer’s XML files that use this definition, FrameMaker finds the appro-

priate application and displays the files correctly. It also allows you to save 

Structured FrameMaker binary files defined by this application as defini-

tion-compliant XML files.

Preparation procedure

When you have identified all features that need to be translated in the source 
material, you are ready to prepare the material in a way that allows you to avoid 
random ad-hoc rectifications that add time and cost overruns to your project

TASK

1. If you receive a binary Structured FM source document, before you 
open it, click File > Preferences > Remember Missing Font Names 
just in case the customer's fonts are missing on your system.

ADDITIONAL INFORMATION: If the customer’s fonts are in fact missing, FrameMaker 

will report which font is missing and which substitute font is being used in a 

message window when you open the file. You should note that the fonts will 

be different in any PDF output you produce because this could be a source of 
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confusion for your customer. When your customer opens the FM file, the 

correct fonts will be used. 

2. Again, if you receive a binary Structured FM source document, follow 
the procedure outlined in the Defining a structured application section. 
This allows you to save the binary Structured FM files as XML files, which 
will be the basis of your translation project.

3. Click Save as PDF (FrameMaker 9.0 and higher) or Print and then select 
a PDF printer to generate a PDF version of the source document, so that 
the translator has a reference layout with the same fonts as you as 
opposed to those of your customer.

4. Click Translations tab > Add document as to add the XML file.

ADDITIONAL INFORMATION: With XML files from Structured FrameMaker applica-

tions, you can ignore the MemoQ element and attribute discovery function-

ality: the DTD contains everything you need for a safe translation of the XML 

files in the MemoQ environment.

5. Open the document you have just added, find any segments 
containing any non-translatable text e.g. product reference number, 
manual reference number, product name (alone, e.g. in footer). Click 
Edit > Copy source to target and double-click the transformation 
status icon (a red X or a green checkmark) to lock each of these 
segments.

6. Calculate the document statistics.

7. Click Translations tab > Export bilingual as and select the MemoQ 
bilingual document radio button to export the bilingual document as 
MBD, or select the XLIFF radio button to export the bilingual document 
as XLIFF. 
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Translation procedure

Your files are now ready to be translated. You can send them to the translator.

TASK

1. Send bilingual document and PDF of source document to translators.

2. When you receive the translated bilingual document from the trans-
lator, click Translations tab > Import/Update bilingual to import it 
into MemoQ.

3. Click Project > Export document to generate the translated XML file.

4. Open the translated XML file in FrameMaker and check the compliance 
of translated document formating with the formating in the model as 
well as no double spaces, missing punctuation etc.

5. Generate another PDF file and if you made changes in 4. above, export 
a bilingual RTF, MBD or XLIFF version and send it to the translator for 
translator proofreading / double-checking compared to the source 
PDF.

6. If translator makes changes, import the new bilingual document to 
MemoQ and repeat steps 3. and 4. above.
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Proofreading procedure

TASK

1. Click Translations tab > Export bilingual as > RTF Bilingual Document to 
generate a bilingual RTF file. The bilingual RTF format has several argu-
ments in its favour in proofreading. The most significant one is that it is 
the only way to transfer comments if different TEnTs are in use in the 
project.

2. Click File > to generate an updated target language MIF file. Generate 
a new PDF. 

3. Open the new PDF in Adobe Acrobat Pro (any version higher than 7) 
and click Comments > Enable for Commenting and Analysis in 
Adobe Reader. This is in the likely event that your customer has Adobe 
Reader rather than Adobe Acrobat Pro. Your customer will not be able 
to make corrections directly in the PDF file, if desired.

4. Send PDF and bilingual RTF versions of translation to customer

5. Encourage corrections in the form of Post-its/comments OR Correc-
tions and/or comments in bilingual RTF.

ADDITIONAL INFORMATION: Choice is important: some customers are uncomfort-

able working outside the layout, especially if it is complex.

6. Integrate customer corrections to MemoQ MIF file using the 
customer-commented PDF file OR the customer-commented bilingual 
RTF file. 
• If the customer has used comments in the PDF file to correct the trans-

lation, open the Comments view and copy the changes to the transla-
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tion document in MemoQ, indicating the changed status in each PDF 

comment.

• If the customer has used the bilingual RTF file to correct the translation, 

click Translations tab > Import/update bilingual to import the 

changes in this file.
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7. Regenerate the target language XML file.

8. Open the XML file and click Save as PDF or Print and select your PDF 
printer to regenerate an updated PDF file of the translated work.

ADDITIONAL INFORMATION: If the XML file is part of a book-like collection of files, 

as is probably the case, select the aggregating tree structure, for example, the 

DITA map if the structured application is a DITA (Darwin Information Typing 

Architecture) one, and click the same command as above.

Why you should use an all XML workflow

To publish any structured application using Adobe FrameMaker, you don't 
need to convert back and forth XML to FM to XML. As long as your structured 
application allows extensions and processing instructions, which DITA does, 
for example, you can save book chapters directly in native XML file format, and 
use external files to control all formatting. Any unauthorized (i.e. not defined in 
the DTD) style and/or format overrides are eliminated whenever a chapter or 
document is saved. This way, you avoid unnecessary post-translation document 
reconstruction. You can control language-specific formatting with a single 
template and one DITA attribute. The language specified in the attribute 
invokes a supplementary style sheet through DITA processing instructions that 
modifies language specific formatting from a single template when the XML 
document is opened. Only one structured template is required for multiple 
languages. This extension can be replicated in any structured application that 
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allows extensions. It works by specifying a series of conditions for each language 
in a list.

The following are cases where you could use a single template to advantage:

• Header and footer changes, e.g. Page 12 of 24 > Seite 12 von 24> Page 12 
de 24 ...

• Paragraph initial elements with a hanging indentation, e.g. Note: > 
Hinweis: > Note : > Megjegyzés: ..., Table n: > Tabell n: > Tableau n: ...

• Fonts and font sizes

In Structured FrameMaker, you can make any changes necessary in the EDD 
(Element Definition Document). And this is the subject of another paper.

© 2011 Douglas McCarthy
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Optimizing FrameMaker Translation workflows for MemoQ
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