
STD-10  SHARDAYATAN-EM PAGE - 1 

 

SHARDAYATAN - EM 
STD-10 

SUB – COMPUTER 

CHAPTER : 1 INTRODUCTION TO HTML 
(1) On the platform of the internet, a distributed information system exists, which is called 

World Wide Web, in short ___________. 

 WWW 

(2) The notion of the web was conceived in __________ by _____________. 

 1991, Team Berners Lee 

(3) ________ is considered as a language for describing web pages. 

 HTML 

(4) HTML stands for _________________________. 

 Hyper Text Markup Language  

(5) HTML is derived from ________ which is developed by the International Organization for 

Standards in 1986. 

 SGML 

(6) SGML stands for _________________________. 

 Standardized General Markup Language 

(7) A _______ is made up of letters, words and numbers enclosed between a left and right 

angular bracket. 

 Tag 

(8) The whole document is embedded between opening _______ and _________ closing tags. 

 <html>, </html> 

(9) HTML document is structured into _______ major parts. 

 Two 

(10) In HTML document, first part is _______ section and second part is _________ section. 

 Head, body 

(11) The ______ section contains information about the page such as title and description of the 

page. 

 Head 

(12) In the head section, information should be embedded within the _______ and ______ tags. 

 <head>  ……..</head> 

(13) The body element is embedded within the ________ and _______ tags. 

 <body> ……..</body> 

(14) The content within body section can be seen within the ________. 

 Web browser 

(15) The element having starting and closing tags are called _______ tags. 

 Paired tags 

(16) The element does not need closing tag is known as _______ tags. 

 Empty 

(17) The _______ element does not have an opening and closing tags. 

 <br> 

(18) ______ is an abbreviated form of break. 

(19) Advanced versions like XHTML use _____ tag for break. 

 <br/> 

(20) If we want to embed the content into pre-formatted tag set using ________. 

 <pre> and</pre> 

(21) _______ tag is used to display content into bold letters. 

 <b> 

(22) _______ tag is used to display content  with underlined letters. 

 <u> 

(23) _______ tag is used to display content into italics letters. 

 <i> 

(24) The content of _______  element is displayed with a strikethrough a thin line through the 

text. 

 <s> or <strike> 

(25) The content of a ______ element is written in typewriter type of fonts, which is also 

identified as mono-spaced font. 

 <tt> 

(26) Set of such words or text that appears in different colour (generally blue and underlined) are 

called ________. 
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 Hyperlink 

(27) A hyperlink is created using an ______. 

 <a> 

(28) In the ______ tag, content is displayed one font size smaller than the rest of the text 

surrounding it. 

 <small> 

(29) In the ______ tag, content is displayed one font size bigger than the rest of the text 

surrounding it.  

 <big> 

(30) _____ tag displays content in super-script. 

 <sup> 

(31) _____ tag displays content in sub-script. 

 <sub> 

(32) _____ tag defines the content as an acronym. 

 <acronym> 

(33) _____ tag defines a special term. 

 <dfn> 

(34) _____ tag defines quotation mark. 

 <q> 

(35) An attribute is made up of two parts ______ and _______. 

 Name, value 

(36) SciTE is a text editor based on a free source code editing component called _____. 

 Scintilla 

(37) _______ tag is used to display content as heading. 

 <h1> 

(38) There are ______ type of heading tags. 

 Six -<h1>  to <h6> 

(39) _______ tag displays the biggest heading. 

 <h1> 

(40) _______ tag displays the smallesr heading. 

 <h6> 

(41) WWW stands for __________________. 

 World Wide Web 

(42) HTML stands for ___________________. 

 Hyper Text Markup Language 

(43) SGML stands for ___________________. 

Standardized General Markup Language 

 

CHAPTER -2  HEAD AND BODY SECTIONS   
(1)       In how many segments HTML document divided? 

(A)   2   (B) 3   (C)   4   (D) 5 

(2)       In which of the following segments is HTML document divided? 

(A)   Head, Title (B)   Head, Html (C)   Head, Body (D)   Head, Meta 

(3)       Which writing of head segment it written within which tags? 

(A) <head>...</head>          (B) <head>...<!head>     

(C) <head>...<\head>      (D) <head>...<%head> 

(4)       Which is the first matter that can be included in head segment? 

(A)   Color  (B)   Title  (C)   Background (D)   Font 

(5)       Which of the following tag's result is shown as title of window browser? 

(A)   <title>  (B)   <head>  (C)   <hl>  (D)  <heading> 

(6)       If head segment has no title, what is shown as majority of browser title? 

(A) URL Path  (B) File Name  (C) Name of computer(D)   (A) or (B) 

(7)    What is full form of URL? 

(A)   Unified Resource Locator  (B)   Uniform Resource Locator 

(C)   Unzip Resource Locator   (D)   Unformed Resource Locator 

(8)    What type of information comes in Head segment? 

(A) Heading      (B) HTML document 

(C) Some additional Information about writing     (D) All of these 

(9)    How is the tag giving additional information in HTML known? 

(A)  Meta-tag  (B)   Mega-tag  (C)   Master tag (D)   Main tag 

(10)    What makes the job of searching webpage easier by search engine? 

(A)   Heading tag (B)   Title tag  (C)   Link tag  (D)   Meta tag 
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(11)    In what segment of HTML is meta-tag written?  

(A)   Head  (B)   Body  (C)   Title  (D)   Any of the given 

(12)    When meta tag is used in HTML, then what matter does it describe? 

(A)   Description    (B)   Key words  

(C)   Information of writer of creator  (D)   Any one of these 

(13)     Which of the following can be presented as key words? 

(A)    Names of important attributes  (B)    Objective of Web page 

(C)    Important points    (D)    All of these 

(14)     Which of the following attribute gives information about its creator or writer? 

(A)   Writer  (B)  Author  (C)   Creator  (D)  Person 

(15)     What provides the chance of giving additional information? 

(A)   Meta-tag  (B)   Heading  (C)   Base  (D)  Comments 

(16)     Where are comments seen in HTML? 

(A)    In Web Browser    (B)    In Source Code 

(C)    In result of HTML   (D)    All of these 

(17)     Which tags are used to put comments in HTML? 

(A)   </-- ... -->  (B)   </-- ... --/> (C)   <-- ... --!>  (D)  <!-- ... --> 

(18)     Which of the following show the beginning of comment in HTML? 

(A)   <!--  (B)   <--!  (C)   </--  (D)  <\~ 

(19)     Which of following tags show the end of comment in HTML? 

(A)   --!>  (B)    !-->  (C)   -->   (D)   --/> 

(20)     Which of the jobs can be done with meta-tag? 

(A)   Webpage can be told to bring a specific URL after certain seconds 

(B)   Webpage can be told not to appears 

(C)   Both (A) and (B) 

(D)   This type of job is not possible with meta tag 

(21)     Which of the following tag determines base URL or target? 

(A)   <meta>  (B)   <url>  (C)   <base>  (D)  <target> 

(22)     Which tag is used to define a common address or target for all the links of a webpage ?  

(A)   <link>                    (B)   <script>  (C)   <base>                   (D)  <style> 

(23)     Which tag is used to define documents and external source ? 

(A)   <style>                   (B)   <link>  (C)  <script>                  (D) <meta> 

(24)     Which tag is employed to define scripts towards client ?                                                  

 (A) <scr>   (B) <src>                        (C)   <script>      (D)  <jscript>                 

(25)     Which tag is employed to define document related style ? 

(A)   <style>                   (B)   <script>                 (C)   <meta>                 (D)    <link> 

(26)     Between which tag is Body section of HTMl document ? 

(A) <body> ... <\body>    (B) <body> ... </body>  

(C) <body>...<#body>     (D) <body> ... <%body> 

(27)     Which element of HTML stores matter lying within browser ? 

(A)   <html>                   (B)   <head>                   (C)   <title>                    (D)   <body> 

(28)     What is given to each attribute of HTML ? 

(A)   Effect                      (B)   Value  (C)   Description            (D)   Key word 

(29)     What is form of recognized HTML image ?  

(A)   JPG                         (B)   BMP  (C)   PNG, TIFF              (D) All of these 

(30)     What is full form of JPG ? 

(A)    Joint Photographic Expert Group (B)    Joint Photographic Export Group 

(C)   Joint Photographic Extra Group  (D)   Joint Photographic Exchange Group 

(31)     What is the full form of BMP ? 

(A)   Bitmapping           (B)   Bitmanaging (C)   Bitmap                   (D)  Bitmanage 

(32)     What is the full form of PNG ? 

(A)    Pagewise Network Graphics  (B)    Portable Network Graphics 

(C)   Portrait Network Graphics  (D)   Permanent Network Graphics 

(33)     What is the full form of TIFF ? 

(A)    Tagged Image Format Folder  (B)    Tagged Image File Folder 

(C)   Tagged Image Format File  (D)   Tagged Image File Format 

(34)     What should be ensured while using file within HTML code ? 

(A)   File Name              (B)   Extension of File (C)   File Path                 (D) All of these 

(35)     How can a web page be made attractive by using what in the background image ?         

(A)    Background writing   (B)    Background colors   

(C)   Background sound      (D)   Background file 

(36)     Which attribute determines color in HTML? 

(A)   Background (B)   Bground  (C)   Bgcolor                   (D)  Backcolor            
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(37)     Which code will you use to show yellow color in background of HTML ? 

(A)    <body bgcolor="yellow">  (B)    <bodybackcolor= "yellow" >     

(C)   <body bgproperties="yellow">  (D)   <body background="yellow" > 

(38)    What code will you use arrange background image and color at the same time ? 

(A)   <body background="computer.jpg" backcolor ="Yellow"> 

(B)   <body backcolor=" computer.jpg" bgcolor ="Yellow"> 

(C)   <body bgcolor="computer.jpg" backcolor ="Yellow"> 

(D)   <body background="computer.jpg" bgcolor ="Yellow" > 

(39)    What is the full form of VDU ? 

(A)   Voice Display Unit   (B)   Visual Display Unit  

(C)   Vocal Display Unit   (D)   Visualization Display Unit 

(40)    How is  the  color combination for basic electronic medium known ? 

(A)   Red, Green, Blue    (B)   Red, Green, Yellow  

(C)   Red, Green, Orange   (D)   Red, Yellow, Blue 

(41)    Which  color  mix is   needed  for  making computer colors ? 

(A)   Binary              (B)   Eight digital (C)   Decimal  (D)  Sixteen digital 

(42)     How many figures go into the presentation of HTML code ? 

(A)   2             (B) 4           (C)   6             (D) 8 

(43)     What is code for red ? 

(A)   FF0000           (B)   00FF00  (C)   0000FF               (D)   FFFFFF 

(44)     In FF0000, which color is given FF value ? 

(A)   Red       (B) Green     (C)   Blue        (D) Yellow 

(45)     In FF0000, which value is given to each color ? 

(A)    Red = 00, Green = FF, Blue = 00  (B)    Red = FF, Green = FF, Blue = FF 

(C)   Red = 00, Green = 00, Blue = FF  (D)   Red = FF, Green = 00, Blue = 00 

(46)     What is the range of value given to any color in HTML ?  

(A)   0 to 64              (B)   0 to 255  (C)   0 to 256                 (D)  0 to 264 

(47)     How many values are there to give to present any color ? 

(A)   64           (B) 255          (C)   256          (D) 264 

(48)     What is the color code for red ? 

(A)   FFFFFF                   (B)   FFFF00   (C)   000000                 (D)  FF0000 

(49)     What is the color code for black ? 

(A) FFFFFF                    (B) FFFF00   (C)   000000                 (D)  FF0000 

(50)     What is the color code of blue ?  

(A)   FF00FF                   (B)   00FF00   (C)   000000                 (D)  0000FF 

(51)    What is the color code of green ? 

(A)   FFOOFF                  (B)   00FF00   (C)   000000                 (D)  0000FF 

(52)    In HTML, by what attribute of body tag color can be defined ? 

(A)   Text                       (B)   Font  (C)  Textcolor               (D)  Fontcolor 

(53)  In general, which color does hyperlink shows ? 

(A)   Red        (B) Green    (C)  Blue        (D) Black 

(54)  What happened when one click on hyperlink ? 

(A)   It takes to other page   (B)   If takes to other line  

(C)   It takes to picture file   (D)   It takes to original file 

(55)  While visiting a webpage, by what name a hyperlink is known ? 

(A)   Visited link            (B)   Active link (C)  Dynamic link        (D) Master link 

(56)  While visiting webpage in what abbreviated hyper link is moved ? 

(A)   alink      (B) blink      (C)  vlink      (D) xlink 

(57)  White visiting a webpage, by what name hyperlink is known ? 

(A)   Visited link            (B)   Active link (C)   Dynamic link        (D)  Master link 

(58)  While visiting a web page in what abbreviated form an active lint is known ? 

(A)   alink      (B) blink      (C)  vlink      (D) xlink 

(59)  What is difference between visited link and active link ? 

(A)    Different size (B)    Different shape (C)   Different background (D)   Different color 

(60)  Which code is used for setting red color foi visiting a active link ? 

(A)    <body vlink ="#FF0000">  (B)    <body alink ="#00FF00"> 

(C)   <body vlink ="#00FF00">  (D)   <body alink ="#00FF00"> 

(61)  Which attribute is used for setting the length of line? 

(A)  Width                     (B)   Size  (C) Align                       (D)  Noshade 

(62)  Generally, what is the width of the line in <hr> tag ? 

(A)   25%        (B) 50%        (C)   75%         (D) 100% 

(63)  In <hr> tag, to arrange the line, which attribute is used ? 

(A)   Width                     (B)   Size  (C) Align                       (D) Noshade 
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(64)  To which side a line can be arrange in <hr > tag? 

(A)   Right                      (B)   Center  (C)  Left                         (D)  None of these 

(65)   Which type of style tag are there ? 

(A)   Physical style tag     (B)   logical style tag   

(C)   Both (A) and(B)        (D)  None of these 

(66)  According to browser instruction, which HTML tag can be used ? 

(A)   Physical style tag     (B)   Logical style tag 

(C)   Master style tag       (D)  Base style tag 

(67)   Which of the following indicate the text in bold ? 

(A)   <i> ... </i>             (B)   <b> ... </b>  (C)   <u> ... </u>           (D)  <tt> ... </tt> 

(68)   Which of the following indicate the text in slanting form ? 

(A)   <i> ... </i>             (B)   <b> ... </b>  (C)   <u> ... </u>           (D)  <tt> ... </tt> 

(69)   Which of the following indicate the text with underlined ? 

(A)   <i> ... </i>             (B)   <b> ... </b>  (C)   <u> ... </u>           (D)  <tt> ... </tt> 

(70)   Which tag is used when a text is cut off ? 

(A)   <tt> ... </tt>          (B)   <strike> ... </strike>  (C)   <sub> ... </sub>   (D)  <sup> ... </sup> 

(71)   Which of the tag is used, when a text is smaller than its previous letter and is in the lower line ? 

(A) <tt> ... </tt>          (B) <strike> ... </strike>  (C)   <sub> ... </sub>   (D)  <sup> ... </sup> 

(72)   Which of the tag is used when a text is smaller than its previous letter and is in the same line ? 

(A)   <tt> ... </tt>        (B)   <strike> ... </strike> (C)   <sub> ... </sub>   (D)   <sup> ... </sup> 

(73)   To display the tag in typewriter form, which tag is used ? 

(A)   <tt> ... </tt>        (B)   <strike> ... </strike> (C)   <sut» ... </sub>   (D)  <sup> ... </sup> 

(74)   To obtain a customized text, which style tag is used ? 

(A)   Logical style        (B)   Physical style  (C)   Master style         (D)  Text style 

(75)   Which of the following tag emphasis the text ? 

(A)   <em>, <strong>  (B)   <cite>, <code>  (C)   <dfn>                     (D)  None of these 

(76)   To display the title of the book, movie, etc, which tag is used ? 

(A)   <code>                 (B)   <strong>   (C)   <cite>                     (D)  <dfn> 

(77)   To demonstrate computer programming code as well as the text in fixed font, which tag is used? 

(A)   <cite>   (B) <em>      (C)   <code>   (D) <dfn> 

(78)   Out of the following, which one is used as a code for color ? 

(A)   Binary system     (B)   Octal system   (C)   Decimal system    (D)  Hexa system 

(79)   Which attribute is used with font tag ? 

(A)   Size                       (B)   Color   (C)   Both (A) and (B)    (D) Type 

(80)   Which attribute decide the color of the text ? 

(A)   fcolor                    (B)   bgcolor   (C)   fontcolor                (D)  color 

(81)   Which of the following code is used for entire HTML web page having font type Arial and Font     

size-16? 

(A)    <fontbase face="Arial" size="16">  (B)    <basetext face="Arial" size="16"> 

(C)   <basefont face="Arial" size="16">  (D)   <textbase face="Arial" size="16"> 

(82)   Generally Linux does not used file extension. Choose the correct statement. 

(A)    This statement is true.    (B)    This statement is false. 

(C)   Nothing can be said about this statement. (D)   None of these 

(83)   Out of following, which indicate HTML extension ? 

(A)   .h           (B) .hmt        (C)   .html      (D) .hmlt 

(84)   In HTML, what is used as a prefix for spel symbol ? 

(A)   &            (B) %             (C)   #             (D) @ 

(85)   In HTML, instead of special symbols, which a can be used ? 

(A)   ANSI      (B) ASCII      (C)   C            (D) HTML 

(86)   Full form of ASCII is ......... 

(A)   American Standard Code for Interchange Information 

(B)   American Standard Code for International Information 

(C)   American Standard Code for Increment Interchange 

(D)   American Standard Code for Information Interchange 

(87)  Which code is used for less than and greater than ? 

(A)   1, g                          (B)   lg, gt   (C)  lt, tg                      (D)   lt, gt 

(88)  Which code is used for & ? 

(A)   am                          (B)   amp   (C)  ap                          (D)  apm 

(89)  In HTML, to add a comment, which code is used ? 

(A)   <--....... -->               (B)   <// ... //>  (C)  <!-- ....... -->          (D)  <!-- ....... --!> 

(90)  To display the letter in bold, which tag is used ? 

(A)   <b> ... <\b>           (B)   <b> ... </b>  (C)  <bd> ... <\bd>       (D)  <b> ... </bd> 

(91)  In web page display URL, which tag is used ? 
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(A)   <base>                   (B)   <basefont>  (C) <baseurl>               (D)  <baseu> 

(92)  To set a default font for a entire web page, which tag is used ? 

(A)   <font>                    (B)   <bfont>   (C)  <basefont>      (D)  <bodyfont> 

(93)   In HTML to display the body section, which tag is used ? 

(A)    <html> ... </html>   (B)    <body> ... </body> 

(C)   <base> ... </base>   (D)   <main> ... </main> 

(94)   In HTML along with body tag, which attribute can be used ? 

(A)   background color  (B)   text color  (C)  link color               (D) All of these 

(95)   Which tag is used to view book title, movie name etc ? 

(A)   <cite>                     (B)   <code>  (C)   <script>                (D)  <style> 

(96)   Using <cite> tag the text appear in which format ? 

(A)   bold                        (B)   Underline  (C)   Italic                       (D) All of these 

(97)   Which tag is used to display the text in computer programming code having require size ? 

(A)   <cite>                     (B)   <code>  (C)   <script>                  (D)  <style> 

(98)   Which tag is used to display the text in require style and an Italic ? 

(A)   <font>                    (B)   <script>  (C)   <style>                   (D)  <dfn> 

(99)   To emphasis a text, which tag is used ? 

(A)   <em>                      (B)   <tt>  (C)   <style>                   (D)  <font> 

(100)   Which tag is used for to display the tag in require type and size ? 

(A)   <cite>   (B) <code>   (C)   <font>   (D) <style> 

(101)   Which tag is used to display the header part in HTML document ? 

(A)   <html>                   (B)   <head>  (C)   <body>                   (D) <title> 

(102)   In HTML, which tag is used to display the horizontal line ? 

(A)   <hr>                       (B)   <ruler>  (C)   <hruler>                 (D)  <mruler> 

(103)   Which attribute is used with <hr> tag ? 

(A)   size, color              (B)   width, alignment (C)   noshade                 (D) All of these 

(104)   To display text in Italic style, which tag is used ? 

(A)   <i> ... <\i>             (B)   <i> ... </i>  (C)   <it> ... <\it>          (D)  <it> ... </it> 

(105)   To give link between document and other page, which tag is used ? 

(A)   <link>                     (B)   <style>  (C)   <dfh>                     (D)  <meta> 

(106)   To give author, keywords, description, purpose, to search engine and Utility program, which tag 

is used? 

(A)   <script>                  (B)   <sub>  (C)   <meta>                   (D)  <em> 

(107)   Using meta tag what information can be cited for search engine and other Utility program ? 

(A)   Author  (B)    Keywords (C)   Description, Purpose (D)   All of these 

(108)   Which tag is used to define client script ? 

(A)   <sc>                       (B)   <st>  (C)   <script>                  (D)  <mscript> 

(109)   Which tag is used to strike off the text ? 

(A)   <strike>                  (B)   <strong>  (C)   <tt>                        (D)  <hr> 

(110)   To display the text bold, which tag is used ? 

(A)   <tt>                        (B)   <b>  (C)   <style>                   (D)  <strong> 

(111)   Which tag is used to define the document with different style ? 

(A)   <meta>                   (B)   <script>  (C)   <style>                   (D)  <tt> 

(112)   Out of following, which tag displays the text smaller than its previous letter and in lower line ? 

(A)   <sub>                     (B)   <sup>  (C)   <lower>                  (D)  <down> 

(113)   Out of following, which tag displays the text smaller than its previous letters and in bigger line ? 

(A)   <sub>                     (B)   <sup>  (C)   <upper>                 (D)  <top> 

(114)   Which of the following tag displays the text in typewriter format ? 

(A)   <t>                         (B)   <tw>  (C)   <tt>                        (D)  <twt> 

(115)   Which of the following tag draws a line at the bottom of the text ? 

(A)   <t>                         (B)   <u>  (C)   <style>                   (D)  <dfn> 

 

CH-3    HANDLING IMAGES IN HTML 
(1)      What attract majority of persons and convey an important message to the audience? 

(A)  Audio                       (B)   Video  (C) Pictures or images (D)  Text 

(2)     ........element is used to insert image in HTML webpage. 

(A)   <p>                          (B)   <i>  (C)  <pict>                      (D)  <img> 

(3)     ........option is used to insert image in HTML document. 

(A)    <img="flower.jpg">   (B)    <img link="flower.jpg"> 

(C)   <img src= "flower.jpg">   (D)   <img add="flower.jpg"> 

(4)     ........attribute is used in <img> element to insert image in HTML document. 

(A)   alt         (B) src          (C)  link         (D) joint 

(5)      The image element does not cause a line break. What is it known as? 
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(A)   Outline element     (B)   Empty element  (C)  Inline element        (D)  Full element 

(6)   ........ type of location is mentioned by src attribute. 

(A)   Main location       (B)   Subsidiary location (C)  Source location     (D)  Last location 

(7)    ........is used for the location of the image. 

(A)   UVR       (B) URV       (C)   URL        (D) ULR 

(8)     What is the full form of URL? 

(A)    Uniform Resource Locator  (B)    Uniform Resource Location 

(C)   Uniform Resource Level   (D)   Uniform Resource Lesson 

(9)    ...........type of file can be inserted in HTML document. 

(A)   jpg, gif                   (B)   png, tiff  (C)   bmp                       (D) All of these 

(10)     Full form of jpg is......... 

(A)    Joint Photographic Extra Group  (B)    Joint Photographic External Group 

(C)   Joint Photographic Experts Group (D)   Joint Photographic Exchange Group 

(11)     What is the full form of gif? 

(A)    Graphical Information Format  (B)    Graphical Interchange Format 

(C)   Graphical Internet Format  (D)   Graphical Intelligent Format 

(12)     What is the full form of png? 

(A)    Portable Netware Group  (B)    Portable News Group 

(C)   Portable Newswire Group  (D)   Portable Network Graphics 

(13)     tiff stands for......... 

(A)    Tagged Image Format File  (B)    Tagged Image File Folder 

(C)   Tagged Image File Format  (D)   Tagged Image Folder Format 

(14)     bmp stands for......... 

(A)    Byte Mapped Picture   (B)    Bit Mapped Picture 

(C)   Basic Mapped Picture   (D)   Beginners Mapped Picture 

(15)    ........ option is used by right clicking on the image to get the address. 

(A)   Image copy           (B)   Image link  (C)   Image insert          (D)  Image source 

(16)     What is given with img tag? 

(A)    Source of an image   (B)    Necessary attributes 

(C)   Both (A) and (B)    (D)   Any type of text is given 

(17)     What type of tag is <img>? 

(A)   Empty tag              (B)   Full tag  (C)   Main tag                (D)  Subsidiary tag 

(18)     The inserted image must be available to 

(A)   Local computer    (B)   Server  (C)   Both (A) and (B)    (D)  None of these 

(19)     If we have used a URL, check that your working or not . 

(A)    Internet connection    (B)    Document    (C)   HTML code      (D)   None of these 

(20)     It is a good practice to create a separate.... images. 

(A)   Folder                     (B)   Directory  (C)   (A) or (B)               (D)  None of thea 

(21)     Comments are written in......... 

(A)   <!-- and -->             (B)   <--and--!> (C)   <!-and-!>             (D)  </--and--/> 

(22)     Why are comments written? 

(A)    For ease of reading   (B)    For better understanding 

(C)   Both (A) and (B)    (D)   None of these 

(23)     Browser will accept only......HTML statement 

(A)   valid                       (B)   invalid  (C)   common                (D)  none of these 

(24)     Comments are not displayed by browser. Choose the correct option. 

(A)   True                        (B)   False  (C)   Can't say               (D)  None of these 

(25)     It is always advisable to define........attribute as it describes the image. 

(A)   id          (B) alt          (C)  src         (D) ma 

(26)    Using........attribute it is done that when the web page is read by the software such as  

 screen reader and search engine, the interpretation of the image becomes easy. 

(A)   src         (B) alt          (C)  map       (D) id 

(27)   ....... is the software specially designed for the people having eye sight defect. 

(A)  Screen reader        (B)   Blind reader  (C) Source reader        (D) Master reader 

(28)    The........attributes specify the values of height and width of the image in pixels. 

(A)  height, length        (B)   length, height (C) height, width          (D) width, height 

(29)    Values of width and height attributes can be specified using......... 

(A)  inches                       (B)   pixels  (C) vector                       (D)  meter 

(30)    ........ attribute is for the horizontal length of the image. 

(A)   Height                      (B)   Width  (C)   Length                    (D)  Size 

(31)    ........attribute is for the vertical length of the image. 

(A)   Height                      (B)   Width  (C)   Length                    (D)  Size 

(32)    ........ attributes are mentioned in number of pixels. 
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(A)   alt, space                 (B)   align, src  (C)   src, map                  (D)  height, width 

(33)     What happens by providing extra information about height and width to the browser? 

(A)    It becomes easier to bring image to the browser 

(B)    Presentation becomes easy 

(C)    Both (A) and (B) 

(D)   None of these 

(34)    ........knows what is size to be allocated to the image. 

(A)   Server                       (B)   Browser  (C)  Webpage                (D) All of these 

(35)     Image should not be larger than......... 

(A)   other image           (B)   text  (C)   screen                    (D)  all of these 

(36)     Which is the value for align attribute?  

(A)   Top, bottom          (B)   Left, right  (C)   Middle                   (D)  All of these 

(37)     Using........value, the image is aligned at the top of the current line of text 

(A)   top                          (B)   left  (C)  bottom                    (D) right 

(38)     Using........value, the bottom of the image aligned with the baseline of the current liner text.                         

(A)   top         (B) left         (C)  bottom   (D) right 

(39)     Using........value, the image is aligned to the left side of the containing window or  element. 

(A)   top                         (B)   left  (C)   bottom                   (D)  right 

(40)     Using........value, the image is aligned to the right side of the containing window or    

Element. 

(A)   top                          (B)   left  (C)  bottom                    (D) right 

(41)     Using........value, the image is aligned in such a way that the middle of the image appears  

the current text. 

(A)   top        (B) left         (C)  middle   (D) right 

(42)     An image on a web page can be highlight with......... 

(A)   picture                   (B)   border  (C)   circle                      (D)  all of these 

(43)    The border attribute was created to specify the width of the border in......... 

(A)  vector                     (B) inch  (C) meter                       (D)  pixels 

(44)    Attribute id stands for......... 

(A)  Identifier                (B)   Identification (C) Idioms                      (D)  Ideality 

(45)    The image can be referred by the identifier in a script written in a programming language  

 such as......... 

(A)   C, C++                     (B)   BASIC  (C) Java                           (D) All of these 

(46)    To add space around an image........attributes are used. 

(A)  vspace, hspace      (B)   aspace, bspace  (C) vspace, uspace       (D) hspace, dspace 

(47)     To add space over and under the image the........ attribute is used. 

(A)   hspace                   (B)   vspace  (C)   Both (A) and (B)    (D)  none of these 

(48)     To add space to the left and right of the image the........attribute is used. 

(A)   hspace                   (B)   vspace  (C)   (A) and (B) both    (D)  none of these 

(49)     hspace leaves the space on........side. 

(A)   left and right    (B) top and bottom     (C) both (A) and (B)     (D) does not leave space 

(50)     vspace leaves the space on........ side. 

(A)   left and right   (B)   top and bottom   (C) both (A) and (B)   (D)  does not leave space 

(51)     Till the high resolution (original) image is loaded, we may temporarily publish a low  

resolution image. Choose the correct option. 

(A)   True                        (B)   False  (C)   Can't say                (D)  None of these 

(52) ........type of file can be included in image tag. 

(A)   bmp, gif                 (B)   jpeg, png  (C)  tiff                           (D) All of these 

(53)   Digital cameras and web pages normally use ........files. 

(A)   bmp                        (B)   tiff  (C)   png                         (D) jpg / jpeg 

(54) ........file format compresses the data drastically. 

(A)   tiff                          (B)   jpg / jpeg  (C)   bmp                        (D)  png 

(55) ........is the best format for photographs. 

(A)   jpg / jpeg              (B)   png  (C)   tiff                           (D)  bmp 

(56) ........  format  is  comparatively slower  in reading and writing. 

(A)   jpg / jpeg              (B)   png  (C)   bmp                        (D)  tiff 

(57)   By applying a link to each of the small image on a page, we can say that the image is  

 considered as......... 

(A)   master text            (B)   external text (C)  hot text                  (D)  normal text 

(58)   The location of image working as hot text ii known as ......... 

(A)   image spot            (B)   hot spot  (C)  master spot           (D) source spot 

(59)   Small images are also known as......... 

(A)   imagenail               (B)   thumbnail (C)   smallnail                (D)  viewnail 
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(60)  What is the location where the link is given known as? 

(A) joint spot               (B)   hot spot  (C) master spot            (D) image spot 

(61)  Hot spots should be of........types. 

(A)  bigger in size            (B)   with clearer view 

(C)   user is able to identify easily  (D)   all of these 

(62)  The location of a hot spot is mentioned using 

(A)   x - co-ordinates    (B)   x and y - co-ordinates 

(C)   x, y, z co-ordinates   (D)  All of these 

(63) How many ways co-ordinates can be used in Hot spot? 

(A)   2            (B) 3             (C)  4             (D) 5 

(64)   What is used to specify co-ordinates of the image? 

(A)   Coords                   (B)   Coor  (C)  Coimage                 (D)  Coorcode 

(65)   <map> and <area> tags are used along with ........attribute into its image tag. 

(A)   usermap                 (B)   usemap  (C)   iap                          (D) map 

(66)  Hot spot co-ordinates and their links are mentioned in........tag. 

(A)    <image> ..... </image>   (B)    <link> ..... </link> 

(C)   <map> ..... </map>   (D)   <imap> ..... </imap> 

(67)   What is the value for circular shape in image map? 

(A)   Round                    (B)   Circle  (C)   Oval                       (D) Any of these 

(68)  What is the value for rectangle shape in image map? 

(A)   Rect                       (B)   Square  (C)   Cube                      (D)  Diamond 

(69)   What is the value for polygon shape in image map? 

(A)   Multi                      (B)   Diamond  (C)  Poly                        (D) Any of these 

(70) ........tag is used for mention shape in image map. 

(A)   Shape                     (B)   Area  (C)   Part                        (D)  Location 

(71) ........ shape is valid for image map. 

(A)   Circle                     (B)   Rectangle  (C)   Polygon                 (D) All of these 

(72) ........ values are given for the respective shapes circle, rectangle and polygon. 

(A)    Circle, rect, diamond   (B)    Circle, square, poly 

(C)   Circle, rect, poly    (D)   Round, rect, poly 

(73) ........tag is used to include audio and video. 

(A)   anchor   (B) src          (C)   image     (D) link 

(74)   Where can the multimedia file be for HTML document? 

(A)   Another website    (B)   At any other location 

(C)   Both (A) and (B)    (D)   None of these 

(75) .......is the extension for movie file. 

(A)   .mp3                      (B)   .mp4  (C)   .wav                        (D) All of these 

(76) .......is the extension for video file. 

(A)   .mov, .avi              (B)   .wmv, .swf (C)   .meg, .mpeg         (D) All of these 

(77) .......option is for audio file. 

(A)   .mp3                      (B)   .mp4  (C)   .mov                       (D) All of these 

(78) .......to be downloaded for executing video file of the webpage. 

(A)   Audio player         (B)   Video player (C)   Master player       (D) Any of these 

 

CH-4      List and TableHandling in HTML 
(1)       There are basically how many types of HTML lists? 

(A)   2            (B) 3             (C)   4             (D) 5 

(2)       Which of the following options show the type of HTML list? 

(A)   Ordered list          (B) Unordered list (C)   Description list    (D) All of these 

(3)       Which of the list contains item along with a symbol? 

(A)   Ordered list          (B)   Unordered list (C)  Description list     (D) All of these 

(4)       What is called a symbol contains in unordered list? 

(A)   Bullet                     (B)   Serials  (C)   Description           (D)  Numbers 

(5)     Which of the following tag pairs are used to create an unordered list in HTML? 

(A)   <ol>.....</ol>         (B)   <dl>......</dl> (C)   <ul>.....</ul>         (D)  <dd>......</dd> 

(6)     What is the full form of li in <li> tag? 

(A)   Last Item               (B)   Leave Item  (C)   List Item                (D)  Lost Item 

(7)     HTML code is written in which program? 

(A)   SciTE                      (B)   SceTE  (C)   ScTE                        (D)   STE 

(8)     In which form bullet is shown in unordered list? 

(A)   Unfilled circle       (B)   Filled circle (C)   Square                    (D) Any one 

(9)     Which attribute is used to change the bullet in unordered list? 

(A)   Type      (B) Part        (C)   Change   (D) Style 
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(10)     An unordered list bullets are shown in which form? 

(A)   Unfilled circle       (B)   Filled circle (C)   Square                   (D) All of these 

(11)    Which attribute is used to show unfilled circle as a bullet in unordered list? 

(A)   Round                    (B)   Circle  (C)   Ring                       (D)   Disk 

(12)    Which tag is used to show a unfilled circle as a bullet in unordered list? 

(A)    <ul type=" circle ">   (B)    <ol type="circle"> 

(C)    <dl type="circle">   (D)    <dl type="circle"> 

(13)    Which tag is used to show a square as a bullet in unordered list? 

(A)    <dl type="square">   (B)    <ol type=" square "> 

(C)   <dl rype="square">   (D)   <ul type="square"> 

(14)    What is called a list without any bullets? 

(A) Ordered list           (B) Description list  (C)   Unordered list       (D)   Subject list 

(15)    Which   tag   pairs   are   used   to   create   a description list in HTML? 

(A)   <ol>......</ol>           (B)   <dl>.......</dl> 

(C)   <ul>.......</ul>          (D)  <dd>.......</dd> 

(16)     In description term the items are enclosed within which tag pair? 

(A)   <ol>......</ol>           (B)   <li>.......</li> 

(C)   <dt>.....</dt>            (D)  <ul>......</ul> 

(17)     What is the full form of dt in <dt> tag? 

(A) Data Term       (B) Database Term      (C)   Delete Term       (D)  Description Term 

(18)     In description list to define sub-items, we use which description tag pair? 

(A)   <dd>.....</dd>          (B)   <dl>......</dl> 

(C)   <dt>.......</dt>         (D)  <ds>.....</ds> 

(19)     What is the full form of dd in <dd> tag? 

(A)    Description Data    (B)    Description Database 

(C)   Description Describes   (D)   Description Details 

(20)  Which tag is used to provide heading of a list? 

(A)   <th>       (B) <lh>        (C)   <dh>       (D) <vh> 

(21)   Where the heading of list must appear? 

(A)   Before the list     (B)   Between the list  (C)   After the list         (D) Any one 

(22)     What are shown along with items in ordered list? 

(A)   Numbers               (B)   Alphabets  (C)   (A) or (B)               (D)   Bullets 

(23)     Generally the ordered list starts with which number? 

(A)    1               (B)   A   (C)   i                             (D) Any one 

(24)    Which facility is available in HTML to present structured information? 

(A)   Lists                       (B) Tables  (C)  Frames                   (D) All of these 

(25)    In which form a table contains information? 

(A)   Grids                      (B)   Frames  (C)   Lists                       (D) Any one 

(26)    In which form information can be presented in a table? 

(A)   Rows                      (B)   Columns  (C)  Both (A) and (B)   (D) Any one 

(27)    Which tags are used to create table in HTML? 

(A)    <cell....</cell>    (B)    <table>....</table> 

(C)   <row>....</row>    (D)   <column>.....</column> 

(28)    Which attributes are used within the <table> and </table> tags? 

(A)   Tide of the table      (B)   Table border 

(C)   Table row and column   (D)   All of these 

(29)     By which tag a row in a table is defined? 

(A)   <tr>       (B) <td>       (C)   <ta>        (D) <tl> 

(30)     What is the full form of th in <th> tag? 

(A)   Table Height     (B)   Table Hyper  (C)   Table Heading       (D)  Table H 

(31)     Which attribute is used to specifies table border? 

(A)   Border   (B) Line       (C)  Frame    (D) Stroke 

(32)     In which form the size of border is given? 

(A)   Centimeters         (B)   Meters  (C)   Inches                    (D)  Pixel 

(33)     <table> tag can carry which attributes? 

(A)   Align , dir , frame    (B)    Bgcolor , border , rules 

(C)   Cellpadding , cellspacing , width  (D)   All of these 

(34)     Which attribute leaves specified gap between edges of the cells and their content? 

(A)   Cellspacing            (B)   Cellpadding (C)   Border                    (D) Align 

(35)     Which attribute manages space between each cell of the table? 

(A)   Align                      (B)   Border  (C)   Cellspacing            (D)  Cellpadding 

(36)    Which attribute controls the outermost border of the table? 

(A)   Border   (B) Align      (C)   Frame     (D) Dir 
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(37)    Which attribute controls the presentation of inner borders of table? 

(A)   Dir         (B) Rules      (C)   Align      (D) Border 

(38)     Which attribute specifies width of the table?  

(A)   Width   (B) Height   (C)  Length   (D) Weight 

(39)     Cellpadding attribute is used for what in the table? 

(A)    Gap between edges of the cells and their content 

(B)    Space between the cells of the table 

(C)   Background of the table 

(D)   Table border 

(40)     Cellspacing attribute is used for what in the table? 

(A)    Background of the table   (B)    Table border 

(C)   Space between the cells of the table (D)   Alignment of table 

(41)     Dir attribute is used for what in the table? 

(A)    Description of the table   (B)    Controls inner border of the table 

(C)   Controls outermost border of the table (D)   Direction of the text in the table 

(42)     Frame attribute is used for what in the table? 

(A)    Controls outermost border of the table (B)    Controls inner border of the table 

(C)   Direction of the text in the table  (D)   Description of the table 

(43)     Rules attribute is used for what in the table? 

(A)    Direction of the text in the table (B)    Controls inner border of the table 

(C)   Description of the table   (D)   Controls outermost border of the table 

(44)     Width attribute shows what in the table? 

(A)    Width of the table   (B)    Breadth of the table 

(C)   Length of the table   (D)   All of these 

(45)    Which   attribute   is   used   to   specify   the background color in the table? 

(A)   border                   (B)   color  (C)   bcolor                   (D) bgcolor 

(46)    What can be given as a value for the bgcolor in the table? 

(A)   Color name   (B)   Six digit code (C)  Both (A) and (B)    (D)  None of these 

(47)  Which decimal code is used to give value to bgcolor attribute in the table? 

(A)   Dualdecimal          (B)   Octadecimal (C)  Decadecimal          (D)  Hexadecimal 

(48)  How many digit are there in hexadecimal code of bgcolor attribute? 

(A)   two        (B) four        (C)  six          (D) eight 

(49)   In the value of cellspacing attribute, the percentage is percentage of what? 

(A)   Percentage of width of each cell. (B)    Percentage of width of each row. 

(C)   Percentage of width of each column (D)   Percentage of width of table 

(50)   In which form the value of width attribute can be specified to decide the width of the table? 

(A)   Percentage             (B)   Pixel  (C)   (A) or (B)                (D) Inches 

(51)  Which of the attribute given below specifies the vertical alignment of the contents of each cell in a 

row? 

(A)  Align                       (B)   Valign  (C)  Cellspacing            (D)  Cellpadding 

(52) What is the general syntax of valign attribute? 

(A)   <valign> = 'position'   (B)   valign = 'position' 

(C)   <valign> ="position"   (D)   valign ="position" 

(53)  Which of the following options show the possible value of valign attribute? 

(A)   Top, bottom          (B)   Middle  (C)  Baseline                 (D) All of these 

(54)  Which attribute from the given below, indicates number of columns that the cell spans across? 

(A)   Headers                  (B)   Nowrap  (C)   Height                    (D)  Colspan 

(55)   Which attribute from the given below, indicates corresponding headers to the cell? 

(A)   Headers                  (B)   Nowrap  (C)   Height                    (D)  Colspan 

(57)  Which attribute from the given below, stops text from automatically wrapping into a new line 

within the cell? 

(A)   Headers                 (B)   Nowrap  (C)  Height                   (D)  Colspan 

(58)  When any cell spans across more than one row, which of the given attribute can be used? 

(A)   Span                       (B)   Scope  (C)  Rowspan               (D)  Colspan 

(59)  Which tag is used to give name to the table? 

(A)   <table>                  (B)   <name>  (C)   <caption>              (D)  <tname> 

(60)   What is used in HTML document to combine multiple web pages and display them as a single web 

pages? 

(A) Tables                     (B) Lists   (C)   Frames                   (D)  Forms 

(61)   What is known as bringing again of HTML code? 

(A)   Loading                 (B)   Reloading  (C)   Upload                   (D) Download 

(62)   What is known as collection of frames in the browser window? 

(A)   Forms                    (B)   Framesource (C)  Frameset                (D) Framewave 
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(63)  Which element is used to create a frameset document? 

(A)   <fr>                        (B)   <frame>  (C)   <frameset>            (D)  <frames> 

(64)   Within the frameset, each frame is represented by which tag pair? 

(A)    <f>.....</£>    (B)    <fr>....</fr> 

(C)   <frame>.....</frame>   (D)   <frameset>......</frameset> 

(65)   Which element provides an alternative message for users, when the browser used does not 

support frames? 

(A)   <noframes>          (B)   <notframes> (C)   <noframe>             (D)  <notframe> 

(66)  What is the extension of HTML form file? 

(A)   .h                            (B)   .ht   (C)   .html                       (D) Anyone 

(67)   To split browser window horizontally, we may use frameset element with what? 

(A)   Rows      (B) Cols        (C)   Row        (D) Col 

(68)   To split browser window vertically, we may use frameset element with what? 

(A)   rows      (B) cols        (C)   row        (D) col 

 

CH  - 5   Introduction to Calc 
(1)       Which of the following program is a example of OpenOffice suit ? 

(A)   Calc                        (B) Write  (C)   Publisher               (D) Excel 

(2)       Which type of program is Calc ? 

(A)   Word processor   (B) Spreadsheet  (C)   Presentation         (D) Database 

(3)       What is Spreadsheet ? 

(A)   Document             (B)   Slide  (C)   Software package (D) Table 

(4)     Which program is used for fast and accurate calculations as well as formatting of data in a      

document ? 

(A)   Calc                        (B)   Base  (C)  Writer                     (D)  Impress 

(5)       Which type of calculation done by Calc ?  

(A)   Fast                        (B) Accurate  (C)   Both (A) and (B)   (D) None of these 

(6)       Which type of activities that can be done through Calc ? 

(A)    Financial Statement and statement of account 

(B)    Preparing document 

(C)   Statistical and scientifically data analysis :     

(D)  All of these 

(7)     Calc is capable for which of the following ? 

(A)    Store data    (B)    Manipulate data 

(C)   Create graphical representation of data (D)   All of these 

(8)     How does spreadsheet represent its information ? 

(A)   Line                        (B) Pixel  (C)   Vector                    (D) None of these 

(9)     In which format, spreadsheet gives permission for entering the data in it ? 

(A)   Horizontal             (B)   Vertical  (C)   Both (A) and (B)  (D)  None of these 

(10)     What is called horizontal row in a spreadsheet ?  

(A)   Colum   (B) row        (C)   Cell         (D) Sheet 

(11)     What is called vertical row in a spreadsheet ?  

(A)   Column                 (B)   Row  (C)   Cell                        (D)  Sheet 

(12)     For analysis and calculations of data, what is called the area of vertical and horizontal rows ?  

(A)   Column                 (B)   Row  (C)   Cell                        (D)   Sheet 

(13)     Which type of facilities does spreadsheet gives to make the work easy ? 

(A)   To add data          (B)   Formatting (C)  To add formula     (D) All of these 

(14)     Which type of formulas and functions are present in spreadsheet ? 

(A)   Mathematical        (B)   Financial  (C)  Statistical, logical         (D)All of these 

(15)     What is the main purpose of workbook ? 

(A)   To format collection of spreadsheet (B)    To insert collection of spreadsheet 

(C)   To enter collection of spreadsheet (D)   To manage collection of spreadsheet 

(16)     What is included in Calc to prepare result analysis and merit list preparation ? 

(A)   Calculating result    (B)   Sorting on result  

(C)  Filtering on result     (D) All of these 

(17)     What is called to arrange data in order ?  

(A)   Sorting                   (B)   Inserting  (C)  Filtering                 (D) Deleting 

(18)     What is called to filter data ? 

(A)   Sorting                  (B)   Inserting  (C)  Filtering                 (D) Deleting 

(19)    wnicn is included in ststistical data analysis? 

(A)   Mean                      (B)   Median  (C)   Probability             (D) All of these 

(20)     How many spreadsheets are there by default ?  

(A)   2            (B) 3             (C)   4             (D) 5 
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(21)     "Worksheet can be added or removed as per requirement". Choose the correct option. 

(A)   True                        (B) False  (C)   Can't say               (D) None of these 

(22)     How many maximum worksheet in spreadsheet document ? 

(A)   3            (B) 24           (C)   256          (D) 65536 

(23)    Which are included in Calc program ? 

(A)    Title bar, Menu bar 

(B)    Standard toolbar,  Formatting toolbar, Formula bar 

(C)   Horizontal row, Vertical column, cell 

(D)   All of these 

(24)     Which menu available in Calc menu bar ?  

(A)   File, Edit, View        (B) Insert, Format, Tools 

(C)   Data, Window, Help  (D)   All of these 

(25)     Before printing we see the document on screen, what is called this process ? 

(A)   Print View                (B)   Print Preview 

(C)   Print Screen             (D)  Print Document 

(26)     From the following, which options are available in Edit menu ? 

(A)   Cut, Copy, Paste  (B)   Find and Replace (C)   Select All               (D) All of these 

(27)     To view format of document, which menu is used ? 

(A)   Edit        (B) Format   (C)   File         (D) View 

(28)     Which options are available in view menu ? 

(A)    Page Break, Preview, Toolbars  (B)   Formula Bar, Status Bar 

(C)   Full Screen, Zoom   (D)   All of these 

(29)     Which menu have additional tools ?  

(A)   File                         (B)   Insert   (C)   View                       (D)  Tools 

(30)     Which options are available in Tools menu in Calc ? 

(A)    Spelling, Language   (B)    Goal seak, Solver, Macro 

(C)   Share Document, Merge Document, Protect Document 

(D)   All of these 

(31)    Which type of work is done by the Data menu of Calc ? 

(A)   Data processing    (B)   Data sorting  (C)  Filter                      (D) All of these 

(32)    To filter data with condition, this process is called 

(A)   sorting                    (B)   filter  (C)   inserting                (D)  deleting 

(33)    What is called to arrange data in ascending and descending order ? 

(A)   Sorting                   (B)   Filter  (C)  Inserting                (D)  Deleting 

(34)    Which options are available in Data menu of Calc ? 

(A)    Define Range, Select Range  (B)    Sort, Filter 

(C)   DataForm, Subtotals, Validity  (D)   All of these 

(35)     From the following, what will be done by window menu in Calc ? 

(A)    Open New Window   (B)    Freezing Cells 

(C)   List of open OpenOffice.org documents (D)   All of these 

(36)    Which options are available in Window menu ? 

(A)    New Window, Close Window  (B)    Split     

(C) Freeze      (D) All of these 

(37)    Which menu is used about functions, Information about applications and versions of software ? 

(A)   File        (B) Tools      (C)   Help       (D) View 

(38)     Which options are available in Help menu of Calc ? 

(A)    OpenOffice.org Help   (B)    Get Help Online 

(C)   About OpenOffice.org   (D)   All of these 

(39)     Which dialog box is open when we click Save As option in file menu ? 

(A)   Save As                  (B)   Save  (C)   Save File                (D)  Save As File 

(40)   When we select Save As options in Calc which information will ask in dialog box ? 

(A)    File name    (B)    Location where the file is to be saved 

(C)   Both (A) and (B)       (D)  None of these 

(41)   Which options are available in Save dialog box ? 

(A)    Name, Save in folder   (B)    Browse for other folders 

(C)   File type, Save with password  (D)   All of these 

(42)  In Calc, most common commands present in which type ? 

(A)   Menu bar             (B)   Toolbar  (C)  Scroll bar              (D) All of these 

(43)  Which menu is used to toolbar can be turn off and on ? 

(A)   File        (B) Edit        (C)  View       (D) Insert 

(44)  From the following, which is the default toolbar ? 

(A)   Standard Toolbar (B)   Formatting Toolba (C)   Formula Toolbar   (D) All of these 

(45)  Which Toolbar is located at the top in Calc? 
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(A)   Standard Toolbar    (B)   Formatting Toolba  

(C)   Formula Toolbar      (D) Drawing Toolbar 

(46)   In Standard toolbar, which menu contains most frequently used commands ? 

(A)   File, View              (B)   File, Edit  (C)   Edit, Format          (D)  Edit, Tools 

(47)  Which tools are available on the Standard toolbar from the following ? 

(A)   New, Open, Save    (B)   Print, Page Preview, Printer Settings 

(C)   Cut, Copy, Paste    (D)   All of these 

(48)  Which toolbar is located as a second position in Calc screen ? 

(A)   Standard Toolbar    (B)   Formatting Toolbar  

(C)  Formula Toolbar       (D) Drawing Toolbar 

(49) On   formatting   toolbar,   which   type   of commands are available ? 

(A)   For formatting content of a cell  (B)   For Add information in a cell 

(C)   Editing information in cell  (D)  Arrange information in cell 

(50)  To do work with the use of tools buttons of the formatting toolbar, 

(A)    to change font, change font size 

(B)   to change text in bold, italic and underline 

(C)   to arrange text in right, left and justify 

(D)   all of these 

(51)  Which tools are available on Standard toolbar ? 

(A)    Bold, Italics, Underline   (B)    Left, Center, Right, Justify 

(C)   Font Name, Font Size, Font Color (D)   All of these 

(52)   Which toolbar is used for entering and editing formula within a cell ? 

(A)   Drawing toolbar      (B)   Formula toolbar 

(C)   Formatting toolbar   (D)   Standard toolbar 

(53)   Which sign is used for entering function ? 

(A)   f(x)                           (B)  f(y)  (C)    f(z)                          (D) All of these 

(54)   "Buttons in toolbars can be modified". Choose the correct option. 

(A)   True                        (B)   False  (C)   Can't say               (D) None of these 

(55)   What is made by dividing column and row ?  

(A)   Source                    (B)   Cell  (C)  Worksheet              (D) Workbook 

(56)  Column is identified by what ?  

A)   Alphabet                (B)   Number  (C)   Symbol                  (D) Any of these 

(57)   Row is identified by what ? 

(A)   Alphabet                (B)   Number  (C)   Symbol                  (D) Any of these 

(58)  A cell is an intersection of what ?  

(A) Alphabet                 (B) Number   (C)   Both (A) and (B)   (D)  Symbol 

(59)   A column as a whole can be selected by what ? 

(A)    Corresponding letter on spreadsheet (B)    Corresponding number on spreadsheet 

(C)   Corresponding cell on spreadsheet (D)   Corresponding heading on spreadsheet 

(60)  A row as a whole can be selected by what ? 

(A)    Corresponding letter on spreadsheet (B)    Corresponding number on spreadsheet 

(C)   Corresponding cell on spreadsheet (D)   Corresponding heading on spreadsheet 

(61)   How is Cell made ? 

(A)    Column alphabet  (B)    Row number     (C)   Both (A) and (B)   (D)  None of these 

(62)   The cell which is currently selected is known as ........... 

(A)   master cell            (B)   source cell (C)   active cell              (D)  base cell 

(63)   What is active cell ? 

(A)   Main cell               (B)   Working cell (C)   Formatting cell     (D)  Base cell 

(63)  What is called highlighted rectangle in corner of active cell ? 

(A)   Autofit handle       (B)   Automated handle (C)  Automatic handle (D) Autofill handle 

(64)   How many Horizontal rows in Calc ?  

(A)    1 to 256                 (B)    1 to 1024   (C)   1 to 65536              (D)   1 to 1048576 

(65)   How many rows in Calc ? 

(A)   256         (B) 1024        (C)   65536      (D) 1048576 

(66)   How many columns name in Calc ?  

(A)   A to IV                   (B)   A to AJ   (C)   A to AMJ                (D)  A to ZZZ 

(67)   How many columns are in Calc ?  

(A)   256                         (B)   1024   (C)   65536                      (D)   1048576 

(68)   Which is the basic element of a spreadsheet ?  

(A)   Cell                        (B)   Worksheet (C)  Workbook               (D)  Row and column 

(69)   What are entered in a cell ? 

(A)   Data                       (B)   Formulas  (C)   Both (A) and (B)   (D)  None of these 

(70)   What are cell hold ? 
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(A)   Text                        (B)   Numbers  (C)   Formulas                (D) All of these 

(71)  Which type of facility is given by the empty line of formula and data Input bar ? 

(A)   Data                     (B)   Formula  (C)  Both (A) and (B)  (D) None of these 

(72)  What is seen on the left side of formula an Data Input bar ? 

(A)   Selected cell address (B)   fix) (C)   empty Box            (D)  

(73)  What is display in workspace in Calc ? 

(A) User's data             (B) User's file      (C) User's information (D) Calc information 

(74)  What is the use of Zoom tool ? 

(A)   Zoom In                (B)   Zoom Out  (C)  Both (A) and (B)   (D)  None of these 

(75)  By clicking on Zoom tool, which dialog box will open ? 

(A)   Zoom Layout    (B)   View Layout  

(C)   Zoom & View Layout   (D)   Zoom with View Layout 

(76)  What will be insert when worksheet size is more than the computer screen size in Calc ?  

(A)   Scrollbar               (B)   Rular bar  (C)   Status bar              (D) Task bar 

(77)   In which form scroll bar is seen in Calc ?  

(A)   Horizontal             (B)   Vertical  (C)  Both (A) and (B)   (D)  None of these 

(78)   Which bar  shows  present  status   of the document, sum of the selected cells, page style, 

selection mode and unsaved changes ?  

(A)   Scroll bar               (B)   Ruler bar   (C)   Status bar              (D)  Task bar 

(79)   By the help of which, we can move between two worksheet ? 

(A)   Sheet tab               (B)   Master tab (C)   Base tab                 (D) Status tab 

(80)   To rename a worksheet, what will you do ?  

(A)   Click                      (B)   Double click (C)   Right click             (D)  Drag 

(81)  Which option is select when we want to rename a worksheet and click on right click ?  

(A)   Rename...                  (B)   Rename sheet   

(C)   Rename worksheet ...                     (D)   Modify sheet ...                                                 

(82)   Which menu option is used for rename a worksheet ? 

(A)    Format -> Sheet —> Rename  (B)    Format -> Sheet -> Modify 

(C)   Edit —> Sheet —> Rename  (D)   Edit -> Sheet -> Modify 

(83)   How many sheet tabs are there in a worksheet by default ? 

(A)   2            (B) 3             (C)   4             (D) 5 

(84)   In which of the following form, the name of sheet appears in Sheet tab ? 

(A)    SI, S2, S3     (B)    File 1, File 2, File 3 

(C)  Book 1, Book 2, Book 3   (D) Sheet1, Sheet2, Sheet3 

(85)  Which type of package is Calc ? 

(A)   Word processor     (B)   Spreadsheet  (C)   Database                (D)  Presentation 

(86)  Which menu option is used to save Worksheet in Calc ? 

(A)   File -» Store          (B)   File -» Save (C)  File -> Add             (D)  File -» Set 

(87)  What is the extension of spreadsheet file in Calc ?  

(A)   .odb       (B) .odt        (C)   .odg        (D) .ods 

(88)   Which symbol is used for multiplication in Calc ? 

(A)   *             (B) @            (C)   /              (D) & 

(89)   Which symbol is necessary to write at the starting of formula ? 

(A)   =            (B) %            (C)   #             (D) @ 

(90)   If formula does not start with = symbol, than which type of data is it considered ? 

(A)   Numeric data        (B)   Equatial data (C)   Textual data          (D) Any one of these 

(91)   Which of the following is used beneficially to enter direct value in Calc ? 

(A)   Cell reference        (B)   Cell type   (C)   Cell value              (D)  Cell symbol 

(92)   Which key is pressed to see the result after entering formula in Calc ? 

(A)   Enter key               (B)   Shift key  (C)   Insert key              (D)  Control key 

(93)   By dragging the cell contains formula, what will be copied automatically ? 

(A)   Data                       (B)   Formula  (C)   Word                      (D)  Symbol 

(94)   What will be used to drag the cell contains formula in Calc ? 

(A)    Right side corner of the cell  (B)    Left side corner of the cell 

(C)   Top corner of the cell   (D)   Bottom corner of the cell 

 

                                       CH – 6       Data Editing and Formating in Calc 
(1)      ........is the basic unit data for storing data in spreadsheet. 

(A)   Worksheet              (B)   Cell  (C)   Row                       (D)  Column 

(2)       What is horizontal line known as ?  

(A)   Column                  (B)   Row  (C)   Cell                        (D)  Worksheet 

(3)       What is vertical line known as ?  

(A)   Worksheet            (B)   Cell  (C)   Row                       (D)  Column 
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(4)       What is the intersection of row and column known as ? 

(A)   Row                        (B)   Column  (C)  Worksheet              (D)  Cell 

(5)      ........type of information can be entered in a cell. 

(A)   Data                       (B)   Formula  (C)   Function                (D) All of these 

(6)       What is modifying  the data known as ?  

(A) Data formatting  (B) Data deleting  (C)   Data editing          (D)  Data inserting 

(7)       To arrange the data in attractive and proper manner is known as 

(A)   data formatting   (B)   data deleting  (C)   data editing           (D)  data inserting 

(8)     Spreadsheet is known as ........ the other name. 

(A)   mastersheet         (B)   basesheet  (C)  worksheet              (D)  workingsheet 

(9)    ........ operation is done many times for the worksheet. 

(A)    Opening a new or an existing spreadsheet (B)    Saving the spreadsheet 

(C)   Adding/deleting worksheets   (D)   All of these 

(10)    ........   menu   option   is   used   to   open   a worksheet. 

(A)    File -» Spreadsheet   (B)    File -> New -» Spreadsheet 

(C)   File -> Open -> Spreadsheet  (D)   File -> Add -> Spreadsheet 

(11)    ........ is the shortcut key to open a new document. 

(A)   Ctrl + D                 (B)   Ctrl + F  (C)   Ctrl + M                 (D)  Ctrl + N 

(12)     By default how many worksheet are displayed ?  

(A)   2            (B) 3             (C)   4             (D) 5 

(13)    ........is the combination of so many rows and columns. 

(A)   Grid                        (B)   Grass  (C)   Grill                        (D)  Grace 

(14)    ........is the option to open a document. 

(A)   File -> Open          (B)   File -> Start (C)  File -> Display      (D) File -> New 

(15)    ........is the short cut key to open a document. 

(A)   Ctrl + N                  (B)   Ctrl + D  (C)   Ctrl + O                  (D)  Ctrl + X 

(16)    ........ feature is given by ubuntu to search a file. 

(A)   Search utility        (B)   Find  (C)   Replace                  (D) Navigation 

(17)   ........    button    is    pressed    after    giving information in   Search for Files dialog box. 

(A)   Search                    (B)   Look  (C)  Find                         (D)  Invent 

(18)     What is displayed as a result of Search for Files ?  

(A)  List of files              (B)   List of folders (C) List of directories  (D)  List of networks 

(19)   ........option is useful to save the worksheet. 

(A)   File -> Save            (B)   File -> Store (C)  File -> Copy            (D)  File -» Worksheet 

(20)    To save the file with some other name ........ is useful. 

(A)   File -» Save            (B)   File -» Save As (C)  File -> Store            (D)  File -> Store As 

(21)    ........is to be entered if the file to be saved for the first time. 

(A)   File name               (B)   Path to save file (C)   Both (A) and (B)    (D)  None of these 

(22)    ........is used to close the opened spreadsheet. 

(A)   File -» Close           (B)   File -> End (C)   File -» Shut            (D)  File -» Lock 

(23)    ........is the extension of the file in calc. 

(A)   .ode       (B) .ods        (C)   .odb        (D) .odg 

(24)     ........is the extension for template format in calc. 

(A)   .dbf        (B) .ots         (C)   .ods         (D) .csv 

(25)    ........ is the extension for files which are typically used for  data exchange  among various                     

         programs. 

(A)   .html     (B) .pdf        (C)   .csv         (D) .xlsx 

(26)    ........ is the extension of HTML file. 

(A)   .html     (B) .pdf        (C)   .xlsx       (D) .xls 

(27)    ........is the extension for the portable document. 

(A)   .html     (B) .pdf        (C)   .xlsx       (D) .xls 

(28)    ........ is the format most frequently used. 

(A)   PDF        (B) PPT         (C)   XLS         (D) DOC 

(29)    ........ option is the worldwide adobe file format. 

(A)   .html     (B) .pdf        (C)   .xlsx       (D) .xls 

(30)    ........ is useful to insert a new worksheet. 

(A)   File -> Sheet         (B)   Format -> Sheet (C)   Edit -> Sheet         (D)  Insert -> Sheet 

(31)     How many worksheets can be added at time in Insert Sheet dialog box ? 

(A)   1             (B) 2             (C)   3             (D) Many 

(32)     To insert a new worksheet........is selected by right clicking on the sheet tab. 

(A)   New Sheet            (B)   Add Sheet  (C)   Insert Sheet           (D)  Put Sheet 

(33)    ........ is the option to insert a new row in worksheet. 

(A)   File -» Rows          (B)   Edit -» Rows (C)   Format -» Rows    (D)  Insert -> Rows 
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(34)    ........  is  the  default width  of column  in centimeters. 

(A)   2.23 cm                  (B)   2.25 cm  (C)   2.27 cm                  (D)  2.29 cm 

(35)    ........is the default height of row in centimeters. 

(A)   0.41cm                  (B)   0.43 cm  (C)   0.45 cm                  (D)  0.47 cm 

(36)    ........ is useful to change width of column. 

(A)    Edit -> Column -f Width   (B)    Format -» Column -» Width 

(C)   Tools -» Column -» Width  (D)   Insert -> Column -> Width 

(37)    ........is useful to change height of row. 

(A)    Format -» Row -» Height  (B)    File -> Row -» Height 

(C)   Insert -» Row -» Height   (D)   Edit -> Row -» Height 

(38)    ........ is clicked to select the column. 

(A)    Column header (B)    Column footer (C)   Column cell          (D)  Column sheet 

(39)   ........is the option to keep row/column header visible. 

(A)   Window -> Freeze up   (B)   Window -» Freeze stop 

(C)   Window —» Freeze view   (D)   Window -> Freeze 

(40)   ........ type of data can be entered in a cell. 

(A)   Text                        (B)   Formula  (C)   Relative cells          (D) All of these 

(41)    ........   key is used to select random cells. 

(A)   Shift       (B) Alt          (C)   Ctrl         (D) Tab 

(42)    ........ is used to select the whole worksheet. 

(A)    Click on last button of row header (B)    Click on last button of column header 

(C)   Click on last button of row header and column header 

(D)   Click on beginning button of row header and column header 

(43) ........ type of data can be entered in a cell. 

(A)   Text                        (B)   Formula  (C)   Relative cells         (D) Any of these 

(44) ........is used to fill the data automatically in cells. 

(A)  Autofill                   (B)   Automatic  (C) Autofit                    (D) Autotype 

(45)  The series created by autofill is known as......... 

(A)   serial series          (B)   predefined series (C)  sequential series  (D)  autofill series 

(46) ........shows the sequential series. 

(A)   1, 2, 3, 4, 5...             (B)    10, 20, 30, 40, 50, ... 

(C)   25, 50, 75, 100, 125, ....   (D)   All of these 

(47)  If we copy the cells made of formulas , the addresses ......... 

(A)    are changed by calc itself.  (B)    are not changed by calc. 

(C)   are suggested to be changed.  (D)   are replaced by other cells. 

(48)   If the address of the cell change by copying the formula is known as ........ . 

(A)   absolute address      (B)   relative address  

(C)  both (A) and (B)       (D)  none of these 

(49)   If the address of the cell does not  change by copying the formula is known as ......... 

(A)   absolute address      (B)   relative address   

(C)  both (A) and (B)       (D)  none of these 

(50)  ........sign is used to create absolute cell address. 

(A)   #            (B) %            (C)   $             (D) & 

(51) ........suggests the exact location of the cell. 

(A)   Absolute address      (B)   Relative address  

(C)   both (A) and (B)       (D)  None of these 

(52) ........ category is form numbers in Format Cells dialog box. 

(A)   Number, Percent  (B)   Date, Time (C)   Currency, Scientific (D)   All of these 

(53) ........ category is available in numbers tab of Format Cells dialog box. 

(A)   English (USA)        (B)   English (India)  (C)   English (UK)           (D)  English (US) 

 

(54)   What is the arrangement of data known as ? 

(A)    Data filtering (B)    Data sorting (C)   Data inserting       (D) Data validation 

(55) ........ arranges the data in ascending or! descending order. 

(A)   Data filtering        (B)   Data sorting (C)  Data inserting       (D) Data validation 

(56)   Data can be sorted in ........order. 

(A)   ascending              (B)   descending (C)   both (A) and (B)   (D) none of these 

(57) ........is useful to sort the data. 

(A)   Format -» Sort      (B)   Edit -» Sort  (C)   Tools -» Sort          (D)  Data -» Sort 

(58)   Sorting can be done on......... 

(A)   only text                (B)   numeric data (C)   date information  (D) all of these 

(59)  What is extracting the data known as ? 

(A)   Data validation     (B)   Data sorting (C)   Data inserting (D)   Data filtering 
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(60) ........ is useful to display the content as per user's wish. 

(A)   Data validation     (B)   Data sorting  (C)   Data inserting       (D)  Data filtering 

(61) ........ is useful for filtering data. 

(A)    File -> Filter -> Auto Filter  (B)    Tools -> Filter -> Auto Filter 

(C)   Data -> Filter -> Auto Filter  (D)   Format -> Filter -> Auto Filter 

(62) ........is useful to close the filter. 

(A)    File -> Filter -» Auto Filter  (B)    Tools -> Filter -> Auto Filter 

(C)   Date -> Filter -» Auto Filter  (D)   Format -» Filter -» Auto Filter 

(63) ........   type  of condition   is   displayed  in Standard Filter dialog box. 

(A)    =, <, >, <=, >=, <>    (B)    Largest, Smallest 

(C)   Constains, Begins With, Ends with  (D) All of these 

(64)   To avoid errors in entering data, we may use ............ 

(A)    data validations (B)    data sorting (C)   data inserting (D)   data filtering 

(65) ........ tab is useful for controlling the invalid data. 

(A)   Criteria                   (B)   Input Help (C)   Error Alert             (D) Any of these 

(66) ........ tab is used to give the help to the user for entering valid data. 

(A)   Criteria                   (B)   Input Help (C)   Error Alert             (D) Any of these 

(67) ........tab is used to give some alert message if wrong data is entered. 

(A)   Criteria                   (B)   Input Help (C)   Error Alert             (D)  Any of these 

(68) ........   displays  the  tool  button  for Auto Spellcheck. 

(A)   Formatting toolbar    (B)   Drawing toolbar  

(C)   Standard toolbar      (D)  Master toolbar 

(69) ........ line is displayed under the wrongly entered words. 

(A)   Green   (B) Red        (C)  Blue        (D) Yellow 

(70)   Which type of button is Auto Spellcheck ?  

(A)   Toggle button       (B)   Twin button (C)   Dongle button      (D) Double button 

(71)   The button which can be turned on or off is known as ........ type of button. 

(A)   On/Off button      (B)   Twin button  (C)   Dual button          (D)  Toggle button 

(72)   By........on the wrong spelling, list of options is displayed. 

(A)   Clicking                 (B)   Double Clicking (C)   Right Clicking       (D)  Drag and Drop 

(73)  ........ is used for spell check in Calc. 

(A)   Encyclopedia         (B)   Dictionary (C)   Internet                 (D) All of these 

(74) ........ function key is for spell check. 

(A)   F5          (B) F6           (C)   F7           (D) F8 

(75) ........button is used to add a new word in the dictionary of Calc. 

(A)   Attach   (B) Add        (C) Put          (D) Append 

(76)   Which option is used to search the data and replace ? 

(A)   Find & Change       (B) Search & Replace  (C)  Find & Replace     (D)  Search & Change 

(77)   Which  is   the   short   cut  key  for  Find & Replace ?  

(A)   Ctrl + F                  (B)   Ctrl + R  (C)   Ctrl + D                  (D)  Ctrl + E 

(78)   Which option is useful to find the data and replace ? 

(A)    File -> Find & Replace   (B)    Format —> Find & Replace 

(C)   Edit -> Find & Replace   (D)   View —> Find & Replace 

(79)   Which is the option to search the data in Find & Replace dialog box ? 

(A)   Search for              (B)   Find  (C)   Find All                 (D) All of these 

(80)   Before printing the document........option is advisable. 

(A)   Print                       (B)   Print Preview (C)   Page Setup             (D)  Page Preview 

(81)   Print Preview provides view of spreadsheet with........ option. 

(A)   page break            (B)   margin  (C)  both (A) and (B)   (D)  none of these 

(82)  Which option is useful for print preview ? 

(A)   View -» Page Preview   (B)    Format -> Page Preview 

(C)   File -» Page Preview   (D)   Edit —> Page Preview 

(83)   Which are the orientation Page tab in Page Style dialog box ? 

(A)   Portrait                   (B)   Landscape (C)   both (A) and (B)   (D)  None of these 

(84)  Which type of margin can be set Page tab in Page style dialog box ? 

(A)    Top, Bottom    (B)    Left Side, Right Side 

(C)   both (A) and (B)       (D)  None of these 

(85)   What is the border of the cell known as ?  

(A)   Cell grid                 (B)   Cell grill  (C)   Cell grade              (D)  Cell grace 

(86)  Which option is used to print document ?  

(A)   Format -> Print    (B)   File -» Print (C)   Edit -» Print         (D)  Data -» Print 

(87)  Which tool button is used to print the document ? 

(A)   Print                       (B)   Print Preview (C)   Page Setup             (D)  Print Setup 
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(88)   What   is   the   shortcut   key  to   print   the document ? 

(A)   Ctrl + R                 (B)   Ctrl + T  (C)   Ctrl + P                 (D)  Ctrl + L 

(89) ........ can be done using Page Break Preview option. 

(A)    See the page end mark   (B)    Change the page end mark 

(C)   both (A) and (B)    (D)   None of these 

(90) ........is useful to see the general view of page 

(A)   File -> Normal      (B)   Edit -* Normal  (C)  View -> Normal    (D)  Format -> Normal 

(91)   The upper part of the page is known as........ 

(A)   header                    (B)   heading  (C)   topping                 (D)  upper part 

(92)   The lower part of the page is known as........ 

(A)   bottom                  (B)   footer  (C)   base                        (D)  down part 

(93)  Header and footer part is divided into how many parts ? 

(A)   3            (B) 4             (C)   5             (D) 6 

(94)  Which part holds the header and footer part ?  

(A)   Left area                (B)   Center area (C)  Right area              (D) All of these 

(95) ........ is displayed by default in Center area of header part. 

(A)   Sheet area             (B)   Sheet name (C)   Sheet data (D)   Sheet row or column 

(96)  Which option is useful to get help ? 

(A)    File -> OpenOffice.org Help  (B)   View —> OpenOffice.org Help 

(C)   Data —> OpenOffice.org Help  (D)   Help -> OpenOffice.org Help 

(97) ........ is the function key to get help. 

(A)   Fl           (B) F2           (C)   F3           (D) F4 

 

CH – 7    Function in Calc 
1. After name of the function, value provided in bracket is known as......... 

(A)    variables of function region 

(B)    cells of function region 

(C)   prefix of function region 

(D)   arguments of the function

2. ........ can be given as the argument of the function. 

(A)   Cell address             (B)   Cell range  (C)   Constant value     (D) Any of these 

3. ........separator can be used for cell addresses. 

(A)   , (Comma)              (B)   ; (Semi colon) (C)   : (Colon)                  (D) Any of these 

4. Where you will find the result of the function? 

(A)   Title bar                     (B)   Menu bar  (C)   Formula bar           (D) Task bar 

5. The cell mentioned in formula is displayed with........color. 

(A)   red          (B) blue        (C)   green      (D) yellow 

6. The method for inclusion of formula is always 

(A)   similar                       (B)   different  (C)   can't say                (D)  none of these 

7. ........is compulsory for function. 

(A)    Variable of function (Argument)  (B)    Correct spelling of function 

(C)    Both (A) and (B)     (D)    None of these 

8. Due to ........functions results into an error. 

(A)  Spelling mistake in the name of the function 

(B)  Not giving necessary variable for function 

(C)    Both (A) and (B) 

(D)   None of these

9. Arrange the steps in ascending order for entering the function. 

(1)     Start the content with = sign 

(2)    press enter key 

(3)    Enter the name of the function 

(4)    Select the cell where function is to be entered. 

(5)    enter the variable of the function  

(A)   4, 3, 1, 5, 2              (B)   4, 1, 3, 2, 5  (C)   4, 1, 5, 3, 2             (D) 4, 1, 3, 5, 2  

10. .........option shows operator sign. 

(A)   +                                 (B)   *   (C)   %                             (D)   # 

11. When = sign is used ? 

(A)   In the beginning for entering variable  (B)    At the end of the variable 

(C)   In the beginning of entering the function (D)   At the end of the function 

12. For what Function Wizard is used? 

(A)    It is not possible to keep all the icons of the functions in the bar 

(B)    It is difficult to remember all the functions with their syntaxes 

(C)    Both (A) and (B) 

(D)    None of these 

13. Function wizard tool is displayed on........bar. 

(A)   Standard bar          (B)   Formula bar (C)   Formatting bar      (D) Status bar 

14. ........is the shortcut key to open the function wizard. 
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(A)   Ctrl + F2                  (B)   Shift + F2  (C)   Alt + F2                 (D) Ctrl + Alt + F2 

15. ........is useful to open function wizard. 

(A)   View --» Function    (B)   View --» Function Wizard 

(C)   Insert --» Function    (D)   Insert --» Function Wizard 

16. How many types of categories are there for the functions? 

(A)   10            (B) 11           (C)   12           (D) 13 

17. ........is the category for the function. 

(A)    Database, Time & Date, Financial, Information 

(B)    Logical, Mathematical, Array, Statistical 

(C)   Spreadsheet, Text, Add-in 

(D)   All of these 

18. In sum function, maximum how many variable, values or Cell addresses can be given?  

(A)   10            (B) 20           (C)   30           (D) 40 

19. Which button is clicked to select values in function wizard dialog box? 

(A)   Select                      (B)   Add  (C)  Value                      (D)  Number 

20. Which area is displayed by clicking on 1 select button of the function wizard? 

(A)   Area of function    (B)   Area of table  (C)  Area of worksheet (D) Area of menu 

21. By clicking on which button of function wizard, the whole dialog box is converted into the small 

rectangle toolbar. 

(A)   Select                      (B)   Category  (C)   Formula                 (D) Array 

22. The functions included in the categories of the calc are known as.......... 

(A)   Built-internal functions    (B)    Built-in functions 

(C)   Built-base functions    (D)   Built-inner functions 

23. LN(8) gives the answer of......... 

(A)  log8e       (B) loge8      (C)   logn8       (D) log8n 

24. LN(8) results to ......... 

(A)   2.0794415417           (B)   3.0794415417 (C)  4.0794415417        (D)   5.0794415417 

25. LOG10 is ........ type of function. 

(A)  string                       (B)   mathematical (C) logical                     (D)  statistical 

26. ........is the syntax for   LOG10. 

(A)   =LOG10(n)              (B)   =LOG10(-n) (C)  =LOG10(n,p)          (D)   =LOG10(n,x) 

27. In LOGlO(n) ,   n displays ......... 

(A)   negative number   (B)   positive number  (C)  (A) or (B)                (D)  none of these 

28. ........is the syntax of POWER function. 

(A)   =POWER (n)             (B)   =POWER(-n) (C)   =POWER(n, p)       (D)   =POWER(p) 

29. In POWER (n;p), n suggests ......... 

(A)   number                   (B)   exponent  (C)   (A) or (B)                (D)  none of these 

30. In POWER (n,p), p suggests ......... 

(A)   number                   (B)   exponent  (C)   (A) or (B)                (D)  none of these 

31. ........function is used to find out the exponent value of the number. 

(A)   POWER                   (B)   PRODUCT  (C)   SQRT                      (D)  EXP 

32. POWER means ......... 

(A)   square                     (B)   square root (C)   multiplication       (D)  exponent 

33. =POWER(10,3) results to ......... 

(A)    10            (B) 100          (C)   1000        (D) 10000 

34. PRODUCT function has........syntax. 

(A)   =PRODUCT(n1,n2,n3,..........n30)   (B)    =PRODUCT(n1,n2,n3,..........n) 

(C)   =PRODUCT(n)     (D)   =PRODUCT(n,p) 

35. Maximum........number of values can be multiplied using PRODUCT function. 

(A)   10            (B) 20           (C)   30           (D) Infinite 

36. SQRT, INT, PRODUCT, POWER, ROUND are ........type of function. 

(A)   string                       (B)   mathematical (C)   logical                    (D)  statistical 

37. ........is the syntax of SQRT function. 

(A)   =SQRT(n)                (B)   =SQRT(-n)  (C)   =SQRT(n,p)           (D)  =SQRT(p) 

38. What does n suggest in SQRT (n) ? 

(A)   Negative number  (B)   Positive number  (C)   (A) or (B)               (D) None of these 

39. INT has........syntax. 

(A)   =INT(n)                    (B)   =INT(-n)  (C)   =INT(n,p)              (D)  =INT(p) 

40. What does n suggest in =INT(n) ? 

(A)   A word                    (B)   A number  (C)   (A) or   (B)             (D)  None of these 

41. INT stands for ......... 

(A)   Integration             (B)   Integer  (C)   Intelligent             (D) Internet 

42. ROUND function has ........ syntax. 
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(A)   =ROUND(n)            (B)   =ROUND(-n) (C)   =ROUND(n,p)       (D)  =ROUND(p) 

43. What does n suggest in =ROUND(n,p) ?  

(A)   A word                    (B)   A number  (C)   Position                 (D) Format 

44. In ROUND (n,p), what does p suggest ?  

(A)   A word                    (B)   A number  (C) Location                 (D) Format 

45. =ROUND (-56.547890,3) results to ......... 

(A) -56                            (B)   -56.000  (C)   -56.547                   (D) -56.548 

46. ROUNDUP and ROUNDDOWN has ...... of syntax. 

(A)   different                  (B)   similar  (C)  variation                (D) can't say 

47. =ROUNDUP(12.15652;2) results to ....... 

(A)   12.15       (B) 12.16      (C)   12.00      (D) 12 

48. =ROUNDDOWN(12.15652;2) results to ..  

(A)   12.15       (B) 12.16      (C)   12.00      (D) 12 

49. TRUNC is ........ type of a function. 

(A)   string                       (B)   mathematical (C)  logical                     (D)  statistical 

50. ........is the syntax of TRUNC function. 

(A)   =TRUNC(n)             (B)   -TRUNC (-n) (C)   =TRUNC(n,p)        (D)  =TRUNC(p) 

51. In TRUNC (n,p), what does n suggest ?  

(A) A word               (B) A number  (C) Number of decimal points  (D)   Format 

52. In TRUNC(n,p) What does p suggest ?  

(A) A word               (B) A number  (C) Number of decimal points  (D)   Format 

53. TRUNC stands for ......... 

(A)   Truncation              (B)   Truncate  (C)   Traction                 (D) Tractor 

54. .......type of function is Average. 

(A)   Statistical                (B)   Financial  (C)   String                     (D) Logical 

55. ........is the syntax of average function. 

(A)    =AVERAGE(n)     (B)    =AVERAGE(n,p)  

(C)   =AVERAGE(n1, n2, n3,.... n30)   (D)   Any of these 

56. AVERAGE is known as........ . 

(A)    Mean of arithmetic    (B)    Mean of Statistics 

(C)   Mean of string     (D)   Average mean 

57. How the average is achieved? 

(A)   Multiply all the values and divide by number of values 

(B)   Subtract all the values and divide by number of values 

(C)   Addition of   all the values and divide by number of values 

(D)   Divide all the values and divide by number of values 

58. Values are separated using........in AVERAGE function. 

(A)   ;              (B) *             (C)   .              (D) & 

59. ........function   is   used to display most repetitive value. 

(A)   AVERAGE                (B)   MIN  (C)   MEDIAN                (D) MODE 

60. =MODE(10;7;6;8;6;5) results to ......... 

(A)    10            (B) 8             (C)   6             (D) 5 

61. What is mode? 

(A)   The most common value    (B)   Average of numbers 

(C)   Division value     (D)   Counted value 

62. ........type of function is GEOMEAN. 

(A)   Statistical                (B)   Financial  (C)   String                     (D) Logical 

63. ........ is the syntax for GEOMEAN function 

(A)   =GEOMEAN(n)          (B)   =GEOMEAN(n, p)  

(C)   =GEOMEAN(n1, n2, n3 ..... n30)   (D)   Any of these 

64. What is the meaning of GEOMEAN?  

(A)   Mode                       (B) Maximum   (C) Geometric mean   (D) Counted mean 

65. Using........type of values geometric mean can be achieved using GEOMEAN function. 

(A)   Positive                   (B)   Negative  (C)   (A) or (B)               (D) None of these 

66. ........root is extracted by multiplying n numbers in GEOMEAN function. 

(A)   nx           (B) nz           (C) nth          (D) an 

67. ........type of function is HARMEAN. 

(A)   Statistical                (B)   Financial  (C) String                      (D)  Logical 

68. ........is the syntax of HARMEAN function. 

(A)   =HARMEAN (n)          (B)   =HAR (n, p)  

(C)   =HARMEAN (n1, n2, n3, ....n30)   (D)  Any of these 

69. HARMEAN stands for......... 

(A)  Harmonic Mean     (B)   Harman Mean (C)   Hardware Mean    (D) Harford Mean 
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70. ........is the syntax of MEDIAN function. 

(A)   =MEDIAN(n)              (B)   =MEDIAN(n, p)  

(C)   =MEDIAN(n1, n2, n3, ....n30)   (D)   Any of these 

71. ........is used to get the middle value by arranging them either in ascending or descending order. 

(A)  AVERAGE                 (B)   MEDIAN  (C) RANK                     (D) COUNTA 

72. What is the meaning of MEDIAN function? 

(A)   Arrange the values and get the middle value (B)    Maximum value 

(C)   Most common value    (D)   Counted value 

73. MEDIAN   function displays........value after arranging all values. 

(A)   maximum               (B)   minimum  (C)   middle                   (D) any of these 

74. If there are two middle values after arranging the numbers........is done in Median function. 

(A)   Average of first two numbers is taken  

(B)   Average value of two middle values is taken 

(C)   Average of last two numbers is taken 

(D)   Displays error message 

75. COUNTA, MAX, MEDIAN, MODE, MIN are........type of function. 

(A)   Statistical                (B)   Financial  (C)   String                     (D) Logical 

76. ........ is the syntax of COUNTA function. 

(A)    =COUNTA (n)     (B)    =COUNTA (n, p)  

(C)   =COUNTA (n1, n2, n3,....n30)   (D)   Any of these 

77. To display number of cells containing values ........function is used. 

(A)   AVERAGE                (B)   MEDIAN  (C)   RANK                     (D) COUNTA 

78. COUNTA function counts........types of cells. 

(A)   empty cells                (B)   cells having values  

(C)   both empty cells and cells having values (D)   none of these 

79. ........type of value can be there in a cell. 

(A)   Text                         (B)   Number  (C)   Formula                 (D) All of these 

80. COUNTA function does not consider the empty cells. Choose the correct options. 

(A)   True                         (B)   False  (C)   Can't say               (D) None of these 

81. =RANK(67;x;0), where values of x are   67, 47, 56, 78, 59, 66 then result will be ......... 

(A)   2             (B) 3             (C)   4             (D) 5 

82. ........is the syntax for MAX function. 

(A)   =MAX(n)                    (B)   =MAX(n, p)   

(C)   =MAX(n1, n2, n3, ....n30)    (D)   =MAX(number; range; order) 

83. ........function    can    simply   return   the maximum number within the arguments. 

(A)   LARGE                     (B)   MAX  (C)   BIG                         (D)  TOP 

84. =MAX (67, 47, 56, 78, 59, 66) results to ......... 

(A)   47            (B) 56           (C)   66            (D) 78 

85. ........is the syntax of   MIN function. 

(A)    =MIN (n)      (B)    =MIN (n, p)   

(C)   =MIN (n1, n2, n3, ....n30)    (D)   =MIN(number; range; order) 

86. ........function can take up and simply return the minimum number within the arguments 

(A)   SMALL                     (B)   MIN  (C)   SMALLER              (D)  DOWN 

87. MIN stands for ......... 

(A)   Minimum                (B)   Minima  (C)   Minimal                 (D)  Minimums 

88. ........shows the relational operator. 

(A) AND, OR, NOT           (B) =, >, <, >=, <=, < >  

(C) IS, LIKE, BETWEEN     (D)   All of these 

89. What does Relational operator = suggest? 

(A)    One operand is smaller than second operand. (B)    One operand is bigger than second operand. 

(C)   Both operands are different.   (D)   Both operands are same. 

90. What does Relational operator < suggest? 

(A)    One operand is smaller than second operand. (B)    One operand is bigger than second operand. 

(C)   Both operands are different.   (D)   Both operands are same. 

91. What does Relational operator > suggest? 

(A)    One operand is smaller than second operand. (B)    One operand is bigger than second operand. 

(C)   Both operands are different.   (D)   Both operands are same. 

92. What does Relational operator >= suggest? 

(A)    One operand is bigger than second operand or both operands are same. 

(B)    One operand is smaller than second operand or both operands are same. 

(C)   Both operands are different.   (D)   Both operands are same. 

93. What does Relational operator <= suggest? 

(A)    One operand is bigger than second operand or both operands are same. 
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(B)    One operand is smaller than second operand or both operands are same. 

(C)   Both operands are different.   (D)   Both operands are same. 

94. What does Relational operator < > suggest? 

(A)    One operand is bigger than second operand or both operands are same. 

(B)    One operand is smaller than second operand or both operands are same. 

(C)   Both operands are different.   (D)   Both operands are same. 

95. ........is the logical operator. 

(A)   IF                             (B)   TRUE, FALSE (C)   AND, OR, NOT     (D)   All of these 

96. ........type of function is IF. 

(A)   Statistical                (B)   Financial  (C)   String                     (D)   Logical 

97. ........is the syntax of IF condition. 

(A)    =IF(TEST)      (B)  =IF("TRUE","FALSE")  

(C)   =IF(TEST,"TRUE","FALSE")   (D)   =IF(TEST, "FALSE", "TRUE") 

98. ........function is used for logical processes.  

(A)   MEDIAN                  (B)   IF   (C)   AVERAGE               (D)   MODE 

99. How many arguments are there in IF function?  

(A)   2             (B) 3             (C)   4             (D) 5 

100. ........is the argument of If function. 

(A)   TEST                        (B)   TRUE  (C)   FALSE                    (D) All of these 

101. One IF condition used within another IF condition is known as......... 

(A)   Master IF                (B)   Secondary IF (C)   Nested IF               (D)  Loop IF 

102. ........is useful for not allowing   the error to occur in a function. 

(A)   Function board      (B)   Function menu (C)   Function view      (D) Function wizard 

103. ........is the main advantage of function wizard. 

(A)    We don't have to select the function (B)    We don't have to type the correct name of function 

(C)   Values are not to be selected   (D)   All of these 

104. If there is a mistake in the function wizard ........colored dots are displayed. 

(A)   green                       (B)   red  (C) blue                        (D) purple 

105. TRUE, FALSE, NOT, AND, OR are ........ type of function. 

(A)   statistical                (B)   financial  (C) string                     (D) logical 

106. ........is the syntax of TRUE function. 

(A)   =TRUE ()                        (B)   =TRUE (TEST)  

(C)    = ("TRUE", "FALSE")    (D)   = ("FALSE", "TRUE") 

107. ........function displays TRUE as logical result of function. 

(A)   YES         (B) OK         (C)   TRUE      (D) FALSE 

108. ........is the syntax of FALSE function. 

(A) =FALSE ()                    (B) =FALSE (TEST) (C) = ("TRUE", "FALSE")(D) = ("FALSE", "TRUE") 

109. ........ is the syntax of NOT function. 

(A) =NOT()                          (B) =NOT(TEST)  

(C) =NOT("TRUE", "FALSE")    (D)    =NOT("FALSE", "TRUE") 

110. ........function reverse the logical value. 

(A)   AND       (B) OR         (C)  IF            (D) NOT 

111. ........is the syntax of AND function. 

(A)   =AND()                          (B)   =AND(TEST)  

(C)   =AND(Condi1, Condi2, ..... Condi30)  (D)    =AND("FALSE", "TRUE") 

112. AND function can compare maximum ........ results. 

(A)    10            (B) 20           (C)   30           (D) 40 

113. ........ can be used to compare the results. 

(A)   AND                         (B)   NOT  (C)   IF                           (D) Any of these 

114. AND function displays ........ as result. 

(A)   YES, NO                     (B)   AND, OR, NOT (C)   TRUE, FALSE        (D)  OK, CANCEL 

115. The result displayed as TRUE and FALSE are known as ........ values. 

(A)   boolean                   (B)   binary  (C)   biometric               (D)  master 

116. If all the results of conditions/arguments are True then what will be the result? 

(A)   TRUE                           (B)   FALSE  (C)   (A) OR (B)              (D)  ERROR 

117. If all the results of conditions/Arguments are False then what will be the result ? 

(A)   TRUE                           (B)   FALSE  (C)   (A) OR (B)               (D)  ERROR 

118. =AND(12=12, 12=6) will display........as result. 

(A)   TRUE      (B) FALSE   (C)  YES         (D) OK 

119. ........ is the syntax of OR function. 

(A)   =OR()                             (B)   =OR(TEST)  

(C)   =OR (Condi1, Condi2, ..... Condi30)  (D)    =OR("FALSE", "TRUE") 

120. ........is the case sensitive function. 
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(A)   TRIM                        (B)   CONCATENATE (C)   EXACT                    (D)   SMALL 

121. EXACT function shows ........ as result. 

(A)   0                             (B)    1    (C)   0 or 1                     (D)  -1, 0 or 1 

122. If two strings are same then EXACT function shows........ as result. 

(A)   0                             (B)   1    (C)  -1                            (D) Any of these 

123. LEFT, RIGHT, MID, LEN is ........ type of function. 

(A)    Statistical function    (B)    String function 

(C)   Mathematical Function    (D)   Logical function 

124. ........ is the syntax for LEFT function. 

(A)   =LEFT(text)                (B)   =LEFT(text, n)  

(C)   =LEFT(textl,text2,text3, .....)   (D)   =LEFT(t1, t2, ..... t30) 

125. ........function returns the first character from the string text, or a specified number of n characters 

starting from the left. 

(A)   LEFT                       (B)   EXTRACT   (C)   TRIM                      (D)   LEFTSPACE 

126. In =LEFT (text, n) ........is the optional part. 

(A)   text   (B) n             (C)   both (A) and (B)  (D)  each part is compulsory  

127. For =LEFT (text, n), if n is not provided then ........will be the result. 

(A)    displays first character from the left side (B)    displays first word from the left side 

(C)   displays first division from the left side  (D)   gives error message 

128. ........is the syntax for RIGHT function. 

(A)    =RIGHT(text)     (B)    =RIGHT(text, n)  

(C)   =RIGHT(textl,text2,text3, .....)   (D)   =RIGHT(tl, t2, ..... t30) 

129. ........ function returns the last n characters from the end (right side) of the string text.  

(A)   RIGHT                     (B)   EXTRACT  (C)   TRIM                      (D)  RIGHTSPACE 

130. RIGHT function is used for ......... 

(A)    compare the strings from the right side  (B)    remove the extra space from the right side 

(C)   get the characters from the right side of string (D)   change the right side characters of string 

131. ........is the syntax for MID function. 

(A)   =MID(text)                 (B) =MID(text, start) 

(C)   =MID(text, start, number)   (D)   =MID(tl, t2, ..... t30) 

132. ........ function provides utility to find middle of a string. 

(A)   RIGHT                     (B)   MID  (C)   EXTRACT                (D)  SPACE 

133. MID function is used for......... 

(A)    get the characters from the left side of string (B)    get the characters from the right side of string 

(C)   get the characters from the center part of string (D)   all of these 

134. In =MID(text, start, number), what does start suggest ? 

(A)    Given string   (B)   Location from where the characters are to be extracted 

(C)   Value for how many characters to be extracted 

(D)   Beginning characters of string 

135. In =MID(text,   start,   number),  what   does number suggest 

(A)    Given string   (B)    Location from where the characters are to be extracted 

(C)   Value for how many characters to be extracted 

(D)   Beginning characters of string 

136. =MID("Tejas Thakkar",3,3)  shows  ...... as result. 

(A)   Tej          (B) jas          (C)  Tha        (D) kar 

137. ........is the syntax for LEN function. 

(A)   =LEN(text)                 (B)   =LEN(text, start  

(C)   =LEN(text, start, number)   (D)   =LEN(tl, t2, ..... t30) 

138. ........function returns the length of the given string including the white space. 

(A)   LENGTH                  (B)   LEN  (C) COUNT                  (D) COUNTA 

139. LEN function is used for......... 

(A)    count characters with white space 

(B)    count characters without white space 

    (C)   count characters removing white space 

    (D)   display characters without white space

140. LEN function shows ........ as result. 

(A)   character                (B)   number            (C)   sign                         (D)  any of these     

141. =LEN("Good Morning") shows........as result 

(A)   10            (B) 11                     (C)   12           (D) 13  

142. ........is the syntax for DATE function. 

(A)   =DATE()                  (B)   =DATE(date)  (C)   =DATE(date,type)  (D)  

=DATE(date,mode) 

143. To display valid date as per given year, date and day........ function is used. 

(A)   DAY()                     (B)   TODAY()   (C)   DATE()                   (D)  WEEKDAY() 

144. DATE function is used for......... 
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(A)    display valid date as per given year (B)    display valid date as per given date 

(C)   display valid date as per given date (D)   display valid date as per given year, date and date 

145. DATE function requires the value of year, date and day in........ format. 

(A)   integer                   (B)   real value   (C)   decimal value        (D)  any of these 

146. DAY, WEEKDAY, DATE, MONTH, YEAR, DAYSINYEAR, DAYS are ........ type of function. 

(A)    Statistical function    (B)    Date and Time 

(C)   Mathematical function    (D)   Logical function 

147. ........is the syntax for DAY function. 

(A)   =DAY()                   (B)   =DAY(date)  (C)   =DAY(date,type)    (D)  =DAY(date,mode) 

148. If only date is to be displayed from the date ……...function is used. 
(A)   WEEKDAY()            (B)   TODAY()   (C)   DATE()                   (D)  DAY() 

149. DAY function is for ......... 

(A)   getting date only      (B)   getting month only  

(C)   getting year only      (D) all of these 

150. if   the   system   date   is   18/02/2014   then =DAY (TODAY ()) will give ........result. 

(A)    18                           (B)   02    (C)   2014                        (D)   18/02/2014 

151. =DAY(date((2014,2,18))   will  give  ........  as result. 

(A)   2014                       (B)   02    (C)   18                           (D)   18/02/2014 

152. ........is the syntax for WEEKDAY function. 

(A)   =WEEKDAY()              (B)   =WEEKDAY(date) 

(C)   =WEEKDAY(date, type)    (D)   =WEEKDAY(date, month, year) 

153. The........ function is used to convert a validate given into a day of the week. 

(A)   WEEKDAY()            (B)   TODAY()   (C)   DATE()                   (D)  DAY() 

154. WEEKDAY function is used to ......... 

(A)    convert a valid date given into a day of the week 

(B)    convert a valid date given into a number of the month 

(C)   convert a valid date given into a number of the year 

(D)   any of these 

155. If the   system   date   is   18/02/2014   then, =WEEKDAY(TODAY()), will give........as result 

(A)   3             (B) 2              (C)   1             (D) 0 

156. For =WEEKDAY(date, type) if we take type=1 then days are taken as ......... 

(A)    For Monday 0, Tuesday 1.......Sunday 6  (B)    For Monday 1, Tuesday 2,......Sunday 7 

(C)   For Sunday 1, Monday 2,   ......Sunday 7  (D)   Any of these 

157. ........ is the syntax for MONTH function. 

(A)    =MONTH()     (B)    =MONTH(date)   

(C)   =MONTH(t)     (D)  =MONTH(date, month, year) 

158. .......... is not enough for the real world application. 

(A)    Process of taking complex decisions (B)   Analyzing a large amount of data 

(C)   Both (A) and (B)    (D)   Entering data and simple mathematical expressions 

159. ........is done for the real world application. 

(A)    Process of taking complex decisions (B)    Analyzing a large amount of data 

(C)   Both (A) and (B)    (D)   Entering data and simple mathematical expressions 

160. ........ is used for process of taking complex decisions and analyzing a large amount of data. 

(A)   Writer                     (B)   Calc   (C)   Impress                  (D)  Draw 

161. ........types of functions are provided by calc. 

(A)    Mathematical, logical    (B)    Statistical, time & date 

(C)   Financial, string     (D)   All of these 

162. Functions start with........sign. 

(A)   =            (B) &             (C)   @            (D) % 

163. ........ is important to use a function. 

(A)    = sign      (B)    Name of function  

(C)   Function variable in bracket   (D)   All of these 

164. How many variables can be inserted in bracket of function ? 

(A)   Only one                (B)   Only two  (C)   One or more (D)   Variable cannot be inserted 

165. ........ operator is used with function a operator. 

(A)   %           (B) +              (C)   @            (D) # 

166. ........is used to specify textual string. 

(A)   =            (B) %             (C)   #             (D) @ 

167. ........ can be used as a variable for function 

(A)    Value, cell address    (B)    Text, constant value 

(C)   One or more functions    (D)   All of these 
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168. ........function is used for addition. 

(A)   PLUS      (B) SUM       (C)   ADD       (D) JOIH 

169. ........sign can be used for addition. 

(A)   £             (B) 3              (C)   6             (D) ¥ 

170. =SUM(A1:A10), where........is the prefix 

(A)   =                              (B)   SUM   (C)   A1 and A10             (D)  : 

171. The........ function is used to convert a valid date given into a number of the month 

(A)   WEEKDAY()               (B)   MONTH()   (C)   DATE()                     (D)  YEAR() 

172. MONTH function is used for ......... 

(A)    convert a valid date given into a day of the week. 

(B)    convert a valid date given into a number of the month 

(C)   convert a valid date given into a number of the year 

(D)   any of these 

173. If system date is 18/02/2014 then = MONTH (NOW()) will give ........as result. 

(A)   3             (B) 2              (C)   1             (D) 0 

174. =MONTH(DATE(2014,2,18)) will give ........ as result. 

(A)   3              (B) 2              (C)   1             (D) 0 

175. ........ is the syntax for MONTH function. 

(A)    =YEAR()      (B)    =YEAR(date)          

(C)  =YEAR(t)       (D)  =YEAR(date, month, year) 

176. ........function is used to convert a valid date given into a number of the year. 

(A)   WEEKDAY()             (B)   MONTH()  (C)    DATE()                        (D) YEAR() 

177. ........is the syntax for DAYSINYEAR function. 

(A)     =DAYSINYEAR ()     (B)     =DAYSINYEAR (date) 

(C)    =DAYSINYEAR(t)     (D)   =DAYSINYEAR (date, month, year) 

178. The ........ function is used to convert a valid date given into number of days of that year.  

(A)   WEEKDAY()             (B)   DAYSINYEAR() (C)   MONTH()              (D)  YEAR() 

179. DAYSINYEAR function is used for......... 

(A)    convert a valid date given into number of days of that year. 

(B)    convert a valid date given into number of weeks of that year. 

(C)   convert a valid date given into number of years of that year. 

(D)   any of these 

180. ........function is used to check whether the year is a leap year or not. 

(A)   WEEKDAY()             (B)   DAYSINYEAR() (C)   MONTH()              (D) YEAR() 

181. DAYS function has ........ syntax. 

(A)    = DAYSINYEAR ()     (B)    = DAYSINYEAR (date2,date1) 

(C)    =DAYSINYEAR(t)     (D)   = DAYSINYEAR (date, month, year) 

182. The........ function calculates the number of days between two dates. 

(A)   WEEKDAY()               (B)   DAYSINYEAR() (C)   MONTH()                 (D)  DAYS() 

183. DAYS() function is used for ......... 

(A)    convert a valid date given into number of days of that year. 

(B)    convert a valid date given into number of weeks of that year. 

(C)   convert a valid date given into number of years of that year. 

(D)   calculate the number of days between two dates. 

184. =DAYS(date2, date1) where date2 should be ........ than date1. 

(A)   bigger                      (B)   smaller  (C)   same                      (D)  any of these 

185. In =DAYS(date2, date1) if date2 is smaller than date1 then........will be the result. 

(A)   positive                   (B)   negative  (C)   real value               (D)  can't say 

186. For =DAYS(date2,date1), not to have negative result........can be used. 

(A)   ABS                          (B)   VAR  (C)   PRODUCT              (D)  INT 

187. DAY function suggests......... 

(A)   day of month            (B)   date of month  

(C)   number of days between two dates  (D)   number of dates between two dates 

188. DAYS function suggests......... 

(A)    day of month     (B)    date of month  

(C)   number of days between two dates  (D)   number of dates between two dates 

189. DAYS function displays ........ as result. 

(A)   word                        (B)   number  (C)   symbol                   (D)  any of these 

190. To display the age as number of days..... function is used. 

(A)   DAY()                       (B)   DAYINYEAR() (C)   DAYS()                   (D)  DATE() 

191. To display the age as number of days.....function is used, (where B1 cell holds the birth date of student) 
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(A)   =DAY(NOW(),B1)       (B)   =DAYS(NOW(),B1) 

(C)   =DATE(NOW(),B1)    (D)   =DAYSINYEAR(NOW(),B1) 

192. WEEKS has ........ syntax. 

(A)    = WEEKS (StartDate,EndDate)   (B)    = WEEKS (date2,date1) 

(C)   = WEEKS (StartDate, EndDate, WeekType) (D)   = WEEKS (date, month, year) 

193. ........function calculates the number of weeks between two dates. 

(A)   WEEKDAY()             (B)   DAYSINYEAR() (C)   WEEK()                   (D)  DAYS() 

194. WEEKS() function is used for......... 

(A)    convert a valid date given into number of days of that year. 

(B)    convert a valid date given into number of weeks of that year. 

(C)   convert a valid date given into number of years of that year. 

(D)   calculate the number of days between two dates. 

195. In =WEEKS(StartDate,EndDate,WeekType), WeekType has which values ? 

(A)   0, 0         (B) 0, 1         (C)   1, 1         (D) -0, 1, 0 

196. ........function calculates the number of years between two dates. 

(A)   YEARS()                   (B)   WEEKDAY() (C)   DAYS()                   (D)  DAYSINYEAR() 

197. YEARS() function is used for ......... 

(A)    convert a valid date given into number of days of that year. 

(B)    convert a valid date given into number of weeks of that year. 

(C)   convert a valid date given into number of years of that year. 

(D)   calculate the number of days between two dates. 

198. =YEARS (StartDate, EndDate, Type) has which values ? 

(A)   0, 0          (B) 0, 1         (C)   1, 1          (D) -0, 1, 0 

199. To display age as number of years, ........ function is used. 

(A)   DAY()                       (B)   DAYINYEAR() (C)   DAYS()                   (D) YEARS() 

200. To display age as number of years, ........ function is used. 

(where Bl is the cell of birth date) 

(A)    =DAY(B1,NOW(),0)    (B)    =YEARS(B1,NOW(),0) 

(C)   =DATE(B1,NOW(),0)    (D)   =DAYSINYEAR(B1,NOW(),0) 

201. ........ software has the functions like calc. 

(A)    Microsoft word     (B)    Microsoft powerpoint 

(C)   Microsoft excel     (D)   Microsoft access 

202. ........can be a difference between calc and excel. 

(A)    May be slight change in syntax 

(B)    May be slight change in spelling 

(C)   , can be used as a separator of arguments instead of ; 

(D)   Any of these 

 

CH – 8      Charts in Calc 
(1) ........   is   also   considered   as   a  graphical presentation of numerical data. 

(A)   Fontwork                (B)   A chart  (C)  A function               (D)  Legend 

(2) The chart would be helpful in your business, but you need to know......... 

(A)    when to use a particular type of chart  (B)   what information it conveys 

(C)   which type of decisions can be made using such chart.  (D)   all of these 

(3) According to ........ a chart type should be selected. 

(A)    the nature of applications   (B)   requirements 

(C)   both (A) and (B)     (D)   none of these Charts are used for ......... 

(4) ....... shows the usage of charts. 

(A)   For comparisons, for demonstration of distribution. 

(B)    For understating of situation, for analysis of trend over the time. 

(C)   For investigating deviations, for identifying and understanding the relationship between entities. 

(D)   All of these 

(5) Making chart attractive is known as ........ 

(A)   editing                     (B)   renaming  (C)   formatting               (D)  deleting 

(6) ........ is the first step to create a chart. 

(A)   Formatting data     (B)   Preparing data  (C)   Editing data            (D)  Deleting data 

(7) Once ........ in a spreadsheet document, you can view it in a graphical manner. 

(A)    data are entered     (B)    data are formatted 

(C)   data are renamed    (D)   data are saved 

(8) ........ is useful to insert a chart. 

(A)   File -^ Chart              (B)   Edit -> Chart  
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(C)   Insert -* Chart          (D)  Format -> Chart  

 (9)    Chart tool button is on........tool bar. 

(A)   standard toolbar       (B)   formatting toolbar  

(C)   drawing toolbar        (D)  database toolbar 

(10)     What is done before inserting a chart ? 

(A)    Chart is selected     (B)    Data range is selected 

(C)   Data base is selected    (D)   Data is saved 

(11)    ........ dialog box is displayed when we select the option to insert a chart. 

(A)   Chart Type                        (B)        Chart Data  

(C)   Chart Wizard             (D)  Chart Database 

(12)     To make chart in spreadsheet is ......... 

(A)   easy                        (B)   friendly   (C)   sequence of steps  (D)  all of these 

(13)     User has just........while making a chart using wizard. 

(A)    to select data range    (B)    to select form range 

(C)   to format data          (D)  to edit data 

(14)     Chart wizard has ........ steps. 

(A)   3            (B) 4              (C)   5              (D) 6 

(15)     Which is the step of chart wizard ? 

(A)    Chart Type     (B)    Data Range, Data Series 

(C)   Chart Elements         (D) All of these 

(16)     Which is the first step of chart wizard ?  

(A)   Chart Type             (B)   Data Range   (C)   Data Series             (D)  Chart Elements 

(17)    ........ shows the usage of chart type. 

(A)    To select type of chart    (B)    To select 3D Look 

(C)   To select shape         (D) All of these 

(18)     We can also see preview of how a typical column chart looks. Choose the correct optic 

(A)   True                        (B)   False   (C)   Can't say                 (D)  None of these I 

(19)     Which is the type of chart ? 

(A)    Column, Bar, Pie     (B)   Area, Line, XY (Scatter) 

(C)   Bubble, Net, Stock, Column and Line  (D)   All of these 

(20)     There are ........ types of charts in Calc. 

(A)    10           (B) 11            (C)   12            (D) 13 

(21)    ........can be selected after selecting the chart. 

(A)   Look                       (B)   Shape   (C)   Both (A) and (B)     (D)  Data Selection 

(22)     In chart type......type of look can be selectd 

(A)   2D          (B) 3D           (C)   4D           (D) 5D 

(23)     In........type of chart, 3D look can be select? 

(A)   column, bar          (B)   pie, area   (C)   both (A) and (B)     (D)  none of these 

(24)    ........ are the shapes in chart type. 

(A)   Box, Cylinder         (B)   Cone, Pyramid   (C)   Oval, Rectangle     (D)  both (A) and (B) 

(25)     What does the column show in the step chart type ? 

(A)   Chart Type             (B)   Look   (C)  Shape                       (D) None of these 

(26) As soon as we select the first step of chart wizard, by default graph   is displayed in the background. Choose 

the correct option.  

(A) True                          (B)   False   (C)  Can't say                  (D)  None of these 

(27) After completing the first step of chart wizard, calc displays the chart in which part ? 

(A)   Upper part     (B)   In the background part 

(C)  In another worksheet    (D)  Displays the  chart after all the steps completed 

(28) To display the predefined chart after which step a button is clicked ?  

(A) First                         (B)   Second    (C) Third                       (D)  Fourth 

(29) What does second step of chart wizard show ? 

(A)   Give data range     (B)  To decide type of chart 

(C)  To select shape of chart    (D)  To decide elements of chart  

(30) In........step, we have to select the range of dxata for chart. 

(A) first      (B) second    (C)  third        (D) fourth 

(31) ........is given after deciding the type of chart. 

(A)    Necessary data for chart   (B)    Necessary components  for chart 

(C)   Necessary legend for chart 

(D)   Necessary database for chart 

(32) At what time data range can be given ? 

(A)    Data range can be selected previously (B)    Second step of  Insert —> Chart 
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(C)    Both (A) and (B)    (D)   None of these 

(33) What can be selected for data range ? 

(A)    Existing data of document  (B)    Data of any other document 

(C)    Both (A) and (B)    (D)   None of these 

(34) Data range of other document can also be given while creating a chart. Choose the 

correct option. 

(A)   True                        (B)   False  (C)   Can't say               (D)  None of these 

(35) After entering the data in........, we can get its copy of spreadsheet. 

(A)   Writer                        (B)   Draw  (C)   Impress                    (D) All of these 

(36) ........sign is useful for absolute cell addresses. 

(A)   @           (B) %            (C)   $             (D) # 

(37)     If the data is described in columns, which option is useful ? 

(A)    First row as label   (B)    First column as label 

(C)   Data series in rows  (D)   Data series in columns 

(38)     If the data is described in rows, which option is useful ? 

(A)    First row as label   (B)    First column as label 

(C)   Data series in rows  (D)   Data series in columns 

(39)     Data range can be selected as per user's choice. Choose the correct option. 

(A)   True                        (B)   False  (C)   Can't say               (D)  None of these 

(40)     What does the third step of chart wizard show ? 

(A)    To select type of chart   (B)    To select data series 

(C)   To select data range   (D)   To select shape of chart 

(41)     Which step of chart wizard give the feature of selecting data series. 

(A)   First                       (B)   Second  (C)   Third                      (D)  Fourth 

(42) Which is the option of Data Series step. 

(A)   Data Series            (B)   Data Ranges (C)   Range for name    (D) All of these 

(43) If we click select button in Data Series step, will make the chart ......... 

(A)   small                       (B)   medium   (C)   big                           (D)  any of these  

(44) If we click select button in Data Series sti where it will the user ?  

(A)   Chart Area             (B)   Worksheet Area  (C)   Data series Area    (D)  Database Area  

(45) In Data Series, if we forget cell addresses ........ is useful. 

(A)   Data      (B) Display  (C)   Select     (D) Cell 

(46) What does the fourth step of chart wizard ? 

(A)    To select data elements   (B)    To select data series 

(C)   To give data range   (D)   To select the data shape 

(47) Fourth step of chart wizard gives the feature of selecting......... 

(A)   chart type                (B)   data range (C)  chart elements      (D)  data series  

(48)  Which is the option of chart elements ?  

(A)  Title, Subtitle             (B)   X-axis, Y-axis, Z-axis 

(C)   Display grids, Display legend  (D)   All of these  

(49) Which step is used for titles, axis, legends, grid etc? 

(A)  Chart type               (B)   Data range (C) Chart elements     (D)  Data series 

(50)   Which option is used to give title to chart in chart elements ? 

(A) Title                          (B)   Subtitle  (C) Add Title                  (D) Add Subtitle 

(51)   Which option is used to give sub title to chart in chart elements ?  

(A) Title                          (B)   Subtitle   (C) Add Title                 (D) Add Subtitle 

(52) How many axis are there for chart ? 

(A)  1            (B) 2              (C)   3               (D) 4 

(53) Which type of grid is available in chart wizard ?  

(A) X-axis                      (B)   Y-axis  (C) Z-axis                      (D) All of these 

(54) Which check box is selected for displaying legend ? 

(A) Add legend             (B)   Show legend (C) Display legend       (D)  View legend  

(55) How many options are there in display legend of chart elements ? 

(A) 2          (B) 3              (C)   4               (D) 5 

(56)   Where the legend is displayed by default ? 

(A)   Left side                   (B)   Right side (C)   Top                            (D)  Bottom 

(57)   When we click finish button, where the chart is displayed ? 

(A)    In the desired sheet  (B)    In the current worksheet 

(C)   In sheetl    (D)   As per user's selected sheet 

(58) Which of the following shows the component of a chart ? 

(A)   Chart area, data range, data series (B)    Chart title, sub title, chart floor 
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(C)   Chart axis, chart legends   (D)   All of these 

(59) When data series is selected,........is displayed 

(A) web of horizontal lines    (B) web of vertical lines 

(C) Both (A) and (B)       (D)  web of cross lines 

(60)  ........is useful to know the values when values not displayed with chart. 

(A)   Axis with values       (B)   Data range with axis 

(C)   Title and sub title    (D)   Chart area 

(61)   Which type of title can be given to the chart.  

(A)   Title                        (B)   Sub title  (C)   Both (A) and (B)   (D)  Optional title 

(62)   What is the purpose of subtitle ? 

(A)    To display extra information  (B)    To display use of graph 

(C)   To display task given to the chart (D)   Both (A) and (B) 

(63)   In which part   of chart area,  a chart is included ? 

(A)   Data series              (B)   Chart floor (C)   Data range              (D)  Chart wall 

(64)   Data area is also known as ......... 

(A)   Chart wall               (B)   Chart  (C)   Data series              (D)  Chart floor 

(65) ........is the main component in chart area. 

(A)   Chart                        (B)   Legend  (C)   Chart floor              (D)  Chart wall 

(66)   Chart is on........ part of area. 

(A)   left side                    (B)   right side (C)   in the middle        (D)   any of these 

(67)   Chart is also known as ......... 

(A)   data series             (B)   data area  (C)   data floor               (D)  data wall 

(68)   Which type of data should be there in the chart ? 

(A)    Content related to data   (B)    Information related to chart 

(C)   Textual data             (D) All of these 

(69)   For each data series which type of color is selected ? 

(A)   Same                         (B)   Different  

(C)   User is asked to select color  (D)   None of these 

(70)   In which type of chart, chart floor is very important ? 

(A)   Bar chart                (B)   Column chart (C)   Both (A) and (B)   (D)  Pie chart 

(71) ........ can be used for mentioning series I units and objects on X and Y-axis. 

(A)   Data series            (B)   Data area  (C)   Chart area             (D)  Legend 

(72)   Where can legend be given ? 

(A)   On X-axis              (B)   On Y-axis  (C)   Both (A) and (B)   (D)  None of these 

(73)   Which method can be used to create a chart . 

(A) Insert -> Chart  (B) Chart Tool button  (C)   Both (A) and (B)   (D)  None of these 

(74)  A chart is insert ........before clicking finish button. 

(A)    in the previous worksheet  (B)    in the next worksheet 

(C)   in the current worksheet   (D)   in sheetl 

(75) Which option is true for charts ? 

(A)   Its location can be changed.  (B)   It can be copied 

(C)   It can be moved    (D)   All of these 

(76)  Which mode is usedful to modify the charts ?  

(A) Modify                      (B)   Display  (C) Edit                           (D)  Change 

(77).........is done to take chart to edit mode. 

(A)   Click on chart area   (B)   Double click on chart area 

(C)   Right click on chart area   (D)   Drag the chart area 

(78)   If we take chart to edit mode, borders become in .......... color. 

(A)   gray                           (B)   black  (C)   red                             (D)  green 

(79)   To change parameters..........is done on chart. 

(A)   click                          (B)   double click (C)  right click                (D) drag 

(80) ..........is useful to change the type of graph. 

(A)    Edit -> Chart Type   (B)    Format -> Chart Type 

(C)    View -> Chart Type   (D)   Tools -> Chart Type 

(81)   Chart Type dialog box gives ........feature. 

(A)   chart type              (B)   chart 3D look (C)   chart shape           (D)  all of these 

(82)   Chart Type dialog box give how many types of charts ? 

(A)   8              (B) 9              (C)   10             (D) 11 

(83)   Chart Type dialog box has which type of chart ? 

(A)    Column, Bar, Pie, Area   (B)    Line, XY (Scatter), Bubble 

(C)   Net, Stock, Column and line  (D)   All of these 
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(84)   Chart Type dialog box has which types of shapes ? 

(A) Box, Cylinder           (B)   Cone, Pyramid (C)   Both (A) and (B)  (D)  Bar, Pie, Column 

(85)   By default the border of chart is ......... 

(A)   visible                    (B)   not visible  (C)   both (A) and (B)   (D) none of these 

(86)   The style of border is......... 

(A)   continuous line    (B)   dotted line  (C)   thick line               (D)  all of these 

(87)   The chart area can be filled up using ......... 

(A)   color                      (B)   gradient  (C)   bitmap image        (D)   all of these 

(88)   Using font effect tab, which type of effectH be given ? 

(A)    Font color, Underline   (B)    Outline, Shadow                                   

(C)   Overlining, Strikethrough  (D)   All of these 

(89) X-axis dialog box gives the feature of ....... formatting. 

(A) location of axis      (B)   labels of axis  (C) font size                  (D)  all of these 

(90) Scale of X-axis are set by........ . 

(A) user                          (B)   automatic (C) administrator        (D)  any of these  

(91) How are the axis labels ? 

(A) Short                        (B)   Descriptive (C)   (A) or (B)                  (D)  None of these 

(92) Which is the tab of chart wall dialog box ? 

(A) Borders                    (B)   Area  (C) Transparency        (D) All of these 

(93)   Which feature is provided in chart wall dialog box ? 

(A)    Hide or unhide borders   (B)    Type and color of border 

(C)    Thickness of border   (D)   All of these 

 (94) ........chart is circular. 

(A) Column                   (B)   Area  (C) Pie                            (D)  Stock 

(95)........type of formatting can be done in a chart. 

(A)   Chart type, chart area   (B)   Data series, fonts, font effects 

(C)  Legend, chart floor , chart wall  (D)  All of these 

(96) What does hyperlink show ?  

(A) Data relation         (B)   Data option  (C) Data address          (D)  Data axis 

(97) Hperlink is connected to ......... 

(A) document                  (B) a part of document;  

(C) both (A) and (B)    (D)  source of document  

(98) The text or document connected to hyperlink is known as......... 

(A)   Hyperweb                (B)   Hypertext (C)   Hypersource           (D)  Hyerfont 

(99)   Hyperlink can be connected to ......... 

(A)   chart                        (B)   a part of chart (C)   both (A) and (B)    (D)  chart type 

(100)   LAN stands for ......... 

(A)    Logic Area Network   (B)    Local Area Network 

(C)    Lanbase Area Network   (D)   Layout Area Network 

(101)   Chart can be connected to ......... 

(A)    with current document   (B)    with new document 

(C)    with a webpage    (D)    all of these 

(102)  ........ is useful to create hyperlink. 

(A)    View —> Hyperlink   (B)    Format -» Hyperlink 

(C)    Insert —> Hyperlink   (D)   Edit -* Hyperlink 

(103)  ........ is the option of Hyperlink dialog box. 

(A)   Internet                      (B)   Mail & News  

(C)   Document, New Document  (D)   None of these 

(104) ........ type of link can be given in Hyperlink type dialog box. 

(A)   Web                        (B)   FTP  (C)   Telnet                    (D) All of these 

(105)   FTP stands for ........ . 

(A)    File Transfer Protocol   (B)    Folder Transfer Protocol 

(C)   Frame Transfer Protocol   (D)   Form Transfer Protocol 

(106) ........ is necessary to experiment hyperlink with a chart. 

(A)    Connection of e-mail   (B)    Connection of user 

(C)   Connection of internet   (D)   Connection of source 

(107) ........ short cut key is important to follow hyperlinks.  

(A)   Ctrl + Alt               (B)   Ctrl + Enter (C)   Ctrl + Shift            (D)  Ctrl + Tab 

(108) To export the document having chart is having........extension. 

(A) DOC     (B) XLS        (C)   PDF        (D) ODT 

(109) PDF stands for.........                                                                    
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(A)   Portable Document Format  (B)   Portable Document File 

(C)  Portable Document Folder  (D)  Portable Document Form  

(110) ........is useful to export the file. 

(A) Format -> Export     (B)   Edit -> Export 

(C) Tools -> Export        (D)  File -> Export  

(111) Chart can be exported as ........ . 

(A) PDF, DOC               (B)   PDF, XHTML (C) XHTML, DOC       (D)  XHTML, ODS \ 

(112) Exporting of chart can be done with ........ extension. 

(A) .html                      (B)   .xhtml  (C) .pdf                        (D) All of these 

(113)  ........ type of information is given in PDF options dialog box to export chart as PDF.  

(A)   Number of pages    (B)   Image format 

(C)   Bookmark                 (D) All of these 

(114)   Chart can be copied to which program ?  

(A)   Writer                     (B)   Impress  (C)   Both (A) and (B)   (D) All of these 

(115)   How to delete the chart ? 

(A)    Select the chart and press delete button  

(B)    Select Edit -> Delete 

(C)   Right click on chart and select delete. 

(D)   All of these 

(116)   How to print the chart ? 

(A)   File -> Print as         (B)   File -» Print  

(C)   File —> Print preview   (D)    File -> Print view 

(117) ........ is used to see the preview of chart ? 

(A)   Print preview           (B)   Page preview  

(C)   document preview   (D)   graph preview   

 

 

 CH-9     Problem and Problem Solving  
(1)       Problems can be classified into........types. 

(A)   2            (B) 3             (C)   4             (D) 5 

(2)      ........is the type of a problem. 

(A)   Well defined problems   (B)    111 defined problems  

(C)   Both (A) and (B)    (D)   None  

(3)      ........is the example of well defined problem. 

(A)   To find out value of x from 2x + 4 = 0  

(B)    To find meaning of word computer from a dictionary 

(C)   Both (A) and (B) 

(D)   To find a friend in Hide and Seek 

(4)      ........is the example of ill defined problem. 

(A)   To find out value of x from 2x + 4 = 0 

(B)    To find meaning of word computer from a dictionary 

(C)   Both (A) and (B) 

(D)   To find a friend in Hide and Seek 

(5)     The solution of problem is in........form. 

(A)   stages                     (B)   steps  (C)   both (A) and (B)     (D)  graphical 

(6)     Computer can solve the problems of ........ types of problems. 

(A)    clearly defined problems   (B)    problems without clear definition 

(C)   both (A) and (B)        (D)  none of these 

(7)     What is the solution for problems in computer field ? 

(A)    Sequential instructions given to computer 

(B)    Random instructions given to computer 

(C)   Ascending instructions given to computer 

(D)   Descending instructions given to computer 

(8)     What type of problems are solved by computer.  

(A)   Very easy               (B)   Very complica  (C)  Both (A) and (B)   (D) None of these 

(9)     Computer cannot solve the problems   Choose the correct option. 

(A)   True                        (B)   False  (C)   Can't say               (D)  None of these 

(10)     What does the  computer do to solve problem ? 

(A)    Find the solution itself    (B)    Solve the problem itself 

(C)   Be helpful to solve the problem   (D)   Both (A) and (B) 

(11) ........method is indicated by the steps of finding that the given number is even or odd. 
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(A)   Pseudo code Method   (B)   Flowchart Method 

(C)   Algorithm Method   (D)   None of these 

(12)     What do you mean by Pseudo Code ?  

(A)   Fake                           (B)   Simulated   (C)   Clear                          (D)   (A) or (B) 

(13) To identify even and odd numbers - which meaning of the pseudo code is accepted for the given problem ? 

(A)   Fake                           (B)   Simulated  (C)   Clear                          (D)   (A) or (B) 

(14)     What is Flowchart ? 

(A)   Technique              (B)   Alternative  (C)   Simulative              (D)  Source method 

(15)    ........ is the pictorial representation of every action that user performs within the machine  

 process that solves a problem. 

(A)   Pseudo Code           (B)   Flowchart  (C)  Algorithm              (D) All of these 

(16)     The symbols used to carry out different processes in flowchart are known as ........ 

(A)   elements of flowchart   (B)    machines of flowchart 

(C)   components of flowchart  (D)   input of flowchart 

(17)     To indicate each process in flowchart ........ symbols are available. 

(A)    same (B)    unique  (C)   user defined (D)   administrator defined 

(18) Which   shape   is   used  to   show   start   in flowchart ? 

(A)   Parallelogram       (B)   Round  (C)   Oval                       (D)  Rectangle 

(19) How many times in flowchart is the symbol used ? 

(A)   Only once             (B)   Only twice  (C)   Beginning and end (D)   Many times  

(20) The start and end symbol in flowchart ii known by which name ?  

(A) Terminal symbol     (B) End symbol  

(C) Both (A) and (B)     (D) Master symbol  

(21) In which direction the arrow points from the end symbol in flowchart ? 

(A)    Outside of End symbol   (B)    Towards of End symbol 

(C)    (A) or (B)     (D)   None of these 

(22)    Which symbol is seen in start symbol ? 

(A)   Symbol going inside   (B)    Symbol going outside 

(C)   Symbol going inside and outside  (D)   None of these 

(23)    Which symbol is seen in end symbol ? 

(A)    Symbol going inside   (B)    Symbol going outside 

(C)   Symbol going inside and outside  (D)   None of these 

(24)     Which of the following plays a key role in solving a problem? 

(A)   Process                  (B)   Decision  (C) Input                     (D) Output 

(25)     Which of the following is the series of process?  

(A)   Input                     (B)   Output  (C) Process                  (D) Decision 

(26)     Which shape for symbol is used to show a process ? 

(A)  Arrow                     (B)   Rectangle  (C)  Diamond               (D) Round 

(27)     Generally which type of work does a computer do through a flowchart? 

(A)   Arithmetic             (B)   Logical  (C)   (A) or (B)               (D) Descriptive 

(28) Which of the following is helpful to take a decision? 

(A)   Arithmetic process   (B)   Logical process  

(C)   Both (A) and (B)    (D) None of these 

(29) Which of the following is used when the answer to the question is either yes or no?  

(A)    Arithmetic process (B)    Logical process (C) Both (A) and (B)   (D) None of these  

(30) In which of the following situation is symbol used ?  

(A)   To change the general series to solve I problem 

(B)    To execute particular statements based on the result of decision 

(C)   (A) or (B)                   (D) None of these 

(31) What is logical symbol ?  

(A)   Relation box         (B)   Decision box (C)  Function box        (D) Result box 

(32)   Is there a need of more than one option to take a decision ? 

(A)   Yes                          (B)   No  (C)   Cant be said         (D)  None of these 

(33)   If the condition is true in flowchart, which of the following statement is executed ? 

(A)   First                       (B)   Second  (C) All                          (D)  None of these 

(34)  What is to be checked if the condition is false in flowchart ? 

(A)  First condition      (B)   Second condition (C) All conditions  (D) None of these  

(35) Which of the following statement is true if the result of the condition is true ? 

(A)   The condition before it is checked  

(B)   The given condition is checked again 

(C)   Check the condition  after  the  given condition 
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(D)   Do not check the condition after the given condition 

(36) Which symbol is used to show the connector symbol ? 

(A)  Rectangle               (B)   Round  (C) Diamond               (D) Arrow 

(37) Connector symbol is used mainly for how many conditions ? 

(A)  2           (B) 3             (C)   4             (D) 5 

(38) In which of the following is the connector symbol used ? 

(A)   The flowchart is too big to fit in one page 

(B)   Two processes cannot be connected by the arrow 

(C)   Both (A) and (B)       (D)  None of these  

(39)  ........symbol can merge multiple conditions. 

(A) Director                 (B)   Connector  (C) Connection           (D)  Diamond 

(40) Which of the following statement is true for connector symbol ? 

(A)   One arrow goes inside the circle. (B)   One arrow moves out of the circle. 

(C)   Both the arrows intersect each other. (D)   Both (A) and (B) 

(41)     What is used to identify different connector symbols in flowchart ? 

(A)    Letters are used in pair   (B)    Symbols are used in pair. 

(C)   Files are used in pair.   (D)   Folders are used in pair. 

(42)     Which of the following symbol is used to show different pairs of the connector symbol ? 

(A)   Arrow                        (B)   Rectangle   

(C)   Round     (D)   Rectangle with curved border 

(43)  What can be done using Flowchart ? 

(A)    To solve a result    (B)    Solution to the problem 

(C)   Solution to the connection  (D)   Solution of a chart 

(44)  What is a variable ? 

(A)   Function                (B)   Entity  (C)  Table                      (D) Database 

(45)   The value of........keeps on changing during a process. 

(A)   variable                  (B)   constant  (C)   function                 (D)  formula 

(46)   If a statement is iterated for multiple times, I is known as......... 

(A)   loop                       (B)   function  (C)   series                     (D) formula 

(47)   How is flowchart helpful ? 

(A)    To summarize the steps for solving a problem 

(B)    Editing the problem 

(C)   To give instructions to the computer 

(D)   All of these 

(48) ........is helpful to discuss different methods of solving a problem. 

(A)   Flowchart               (B)  Algorithm  (C)  Pseudo Code         (D) All of these 

(49) There are........symbols in a flowchart. 

(A)   2            (B) 4             (C)  6             (D) Many 

(50) What will happen if the logic of a program is changed ? 

(A)   A new flowchart is needed to be made. 

(B)   Changes are to be made in the same flowchart. 

(C)   We need to connect it with another flowchart. 

(D)   None of these. 

(51) ........ refers to a step by step procedure for solving a particular problem. 

(A)   Algorithm               (B)   Flowchart (C)  Pseudo Code         (D) All of these 

(52)   What does an algorithm show ? 

(A)   A step by step procedure for solving a particular problem. 

(B)    Numerical working process to solve a problem 

(C)   Sequential working process to solve a problem 

(D)   Symbolic working process to solve a problem 

(53)   In........, an algorithm refers to a step by step procedure for solving a particular problem. 

(A)   Mathematical Science   (B)    Computer Science 

(C)   Human Science        (D)  Genetic Science 

(54)  Algorithm is written in which type of natural language ? 

(A)   English                   (B)   Hindi  (C)  French                   (D) Gujarati 

(55) By using which of the following the task of writing a computer program becomes very easy ? 

(A)   Input                     (B)   Output  (C)  Algorithm               (D) Process 

(56) What is the purpose of flowchart and algorithm ? 

(A)    To clearly and completely state the problem. 

(B)   To state the capacity of computer memory. 

(C)   To send the output to the printer. 
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(D)   To mention the base of number system. 

 

Ch-10     Introduction to C Language  
(1)   Which is the basic step in solving a problem ? 

(A)   Flowchart               (B)   Algorithm  (C)  Both (A) and (B)    (D)  None of these  

(2)   There are..........languages to write a program. 

(A)   one        (B) two         (C)   three       (D) many  

(3)   Which of the following is a computer language ? 

(A)   HTML                     (B)   C, C++  (C)  JavaScript               (D) All  

(4)   We can write a program in Gujarati as well as English - Choose the correct option for the given 

        statement. 

(A)   True                        (B)   False  (C)   Can't say                (D)   None of these 

(5)    Why can't we write a program in Gujarati as well as English? 

(A)   This type of language is not compatible with computer. 

(B)   This type of language is not available in computer.  

(C)   The fonts of these languages are not available in the computer. 

(D)   These type of languages is difficult for the user. 

(6)   To take the desired work from the computer, each sentence should be of..........type. 

(A)   meaningful             (B)   definite  (C)   both (A) and (B)    (D)  none of these 

(7)   How  many meanings should be there for the instructions given to the computer ? 

(A)   Only one                (B)   Only two  (C)   Only three              (D)  Many 

(8)  The set of predefined rules form .......... that language. 

(A)   phrase                    (B)   syntax   (C)  word form              (D)  numerical form  

(9)    When we learn any new programming language it is like........... 

(A)    learning the alphabets of a language 

(B)    learning the syntax of a language 

(C)   learning new grammar of a language 

(D)   learning the history of a language 

(10)     Which language does a computer understand ?  

(A)   Gujarati                  (B)   English   (C) The language of 1 and 2 (D)The language of 0 and 1 

(11)     What is the language of  0 and 1 known ? 

(A)    Binary language   (B)    Language with two meanings 

(C)   Language with two words  (D)   Language with two formats 

(12)     Which of the following option is true for the two people who does not understand each others language 

? 

(A)    One person learns the language of the other person 

(B)    The second person learns the language of the first person 

(C)   Take the help of a third person who knows both the languages 

(D)   Both the people learn the sign language 

(13)     The person who helps two people who don't know each other’s language is known as.......... 

(A)   translator               (B)   interpreter  (C)   both (A) and (B)    (D) programmer 

(14)     To convert one language into another is known as.......... 

(A)   interpreter             (B)   translator (C)   both (A) and (B)    (D)  programmer 

(15)     Which software has the solution for the problem of not understanding our language by the computer ? 

(A)   Translator              (B)   Flowchart (C)  Algorithm               (D)  Function 

(16)     Translation software are known as........... 

(A)   translation             (B)   compiler  (C)   interpreter             (D)  copy writer 

(17)     A..........can be defined as finite set of precise and clear instructions given to a computer for   

 performing a predefined task. 

(A)   program                 (B)   flowchart  (C)   algorithm               (D) function 

(18)     A program can be defined as........... 

(A)   precise instruction (B)   clear instruction (C)   predefined task      (D)  All of these 

(19)     The process of writing these step by step instructions using a chosen language is known as........... 

(A)   program                 (B)   programming (C)  translation             (D)  transalator 

(20) How many inputs can a program take ?  

(A)   Zero                       (B)   Except zero  (C)   One or more          (D) Zero or more  

(21) How many outputs can a program give ?  

(A)   Zero                       (B)   Except Zero  (C)   One or more          (D) Zero or more  

(22) The characteristics of a program is similar to _________. 

(A)   algorithm               (B)   flowchart  (C)   function                 (D)  all of these 

(23) C language was introduced in which year ?  
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(A) 1970   (B) 1971   (C) 1972   (D) 1973  

(24) C language was introduced in which laboratory 

(A)    C laboratory (B)   AT&T Bell laboratory (C)   IBM laboratory (D)   Denis laboratory  

(25) The credit of C language goes to.......... 

(A)    Dennis M. Ritchie    (B)    Charles Babbage 

(C)   Herman Holerith     (D)   Blaze Pascal  

(26) C language is derived from which language ?  

(A)   BCLP                      (B)   BCPA    (C)   BCPL                      (D)  BCAL  

(27) Whats is the full form of BCPL ? 

(A)    Basic Combined Program Language  (B)    Basic Combined Programming Language 

(C)   Basic Combined Printable Language  (D)   Basic Combined Pointer Language 

(28) Main purpose of C language was to develop.......... 

(A) system software    (B)   application software (C)   programming software (D)   all of these   

(29) Which of these language became the favorite  language of the programmers ? 

(A)  Logo      (B) BASIC    (C)   C               (D) Cobol 

 (30)  What type of language is C language ? 

(A)   General Programming Purpose Language (B)   General Purpose Printable Language 

(C)   General Purpose Pagewise Language  (D)   General Purpose Programming Language  

 (31) C language was standardized by ANSI in which of the following years? 

(A)   1972        (B) 1979        (C)   1982         (D) 1989 

(32) What is the full form of ANSI ? 

(A)  American National Source Institute   (B) American National Standard Institute 

(C)   American National Section Institute  (D)  American National State Institute  

(33) What name was given to C language after it was standardized by American National Standard Institute 

(ANSI) ?                        

(A) AN C                          (B)   ANS CX  (C)  ANSI C                   (D)  MASTER CN 

(34) ANSI C was supported by........... 

(A)    different types of operating system  (B)    different types of compilers 

(C)   different types of administrator   (D)   both (A) and (B)  

(35) What type of language is C ?  

(A)   Structured                (B)   Multilevel   (C)   Multipurpose         (D)  Optional 

(36)       The facility of dividing a program in small divisions in C language is known as........... 

(A)   key-word                (B)   identifier   (C) character-set          (D) function  

 (37) C program can be run on any other operating system or compiler with minimum changes done 

to it, this is known as........... 

(A)   user defined           (B)   built in    (C)  portable                 (D)  all of these  

(38)  C language is also known as........... 

(A)    middle level language    (B)    higher level language 

(C)   lower level language    (D)   both (A) and (B)  

(39) What type of language is C language ? 

(A)    General purpose programming language (B)    Structured and portable 

(C)   Middle level and higher level language  (D)   All of these 

 (40)     C program is the collection of........... 

(A)   flowchart                (B)   algorithm  (C)   function                 (D)  key-word 

 (41)    .......... component holds the C structure. 

(A)    Optional section  (B)    Compulsory section for all executable % C programs 

(C)   User defined functions (D)   All of these 

(42)     What of the following is included in the Optional Section of C language ? 

(A)    Documentation     (B)    Symbolic constant definition 

(C)   File include section/global variable declaration (D)   All of these 

(43)     What of the following is included in the Compulsory section/of C language ? 

(A)    main()            (B)    { Declaration }  (C)   Executable Statements (D)   All of these 

 (44)     In which part of C is /* and */ used ? 

(A)    Documentation section    (B)    Compulsory section for executable program  

(C)  User defined function    (D) All of these 

(45)     Note/Comment in C language is written in between which signs ? 

(A)   / and /                    (B)   \ and \   (C)   /* and */                (D)  •/ and /* 

(46)     Where can comment be added in C language? 

(A)   At the start of the program   (B)    In the middle of the program 

(C)   At the end of the program   (D)   Anywhere in the program 

 (47)   Which of the following statement is true for the comments in C language ? 
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(A)   It is limited and it can be added anywhere in the program. 

(B)   It is enclosed between /* and */. 

(C)   Compiler does not make any process. 

(D)   All of these  

(48)   What is added in the part before symbolic constant definition ? 

(A)   #include                    (B)   #stdio  (C)  #define                      (D)  #conio 

 (49)   #define is also known as........... 

(A)    pre-processor directive    (B)    pre-processor director 

 (C)   pre-processor ditective    (D)   pre-processor document 

 (50)     Symbolic consatant is generally defined by using.......... characters. 

(A)   capital                          (B)   small   

(C)   combination of capital and small  (D)   in the form of digits 

(51)     For what reason is the symbolic constant written in capital ? 

(A)    Small alphabets are not valid for symbolic constant 

(B)    Capital  alphabets   are  only valid  for symbolic constant 

(C)   To differentiate from general variable 

(D)   To display as general variable 

(52)    .......... type of functions are provided by C language. 

(A)    Predefined functions    (B)    Inbuilt functions   

(C)   Library functions     (D)   All 

(53)      Inbuilt functions are also known as ........... 

(A)   library function       (B)   user defined function  (C)   both (A) and (B)     (D)  global function 

(54)     Which of the following is an example of Inbuilt/ Library function ?  

(A)   pow()                       (B)   sqrt()    (C)   Both (A) and (B)     (D)  mainQ 

 (55)     Which function is used to find the exponent of a given value ? 

(A)   p()                           (B)   pow()   (C)  power()                    (D) powar() 

(56)     Which function is used to find the square root of a given value ? 

(A)   sq()        (B) sr()           (C)   sqrt()       (D) sroot() 

(57)     The file which hold the information about the use of Library functions are known as........... 

(A)   header file             (B)   master file  (C)  program file            (D) insert file 

(58)     The file which hold the information about the use of Library functions are known as........... 

(A)   master file             (B)   program file  (C)  insert file                 (D) header file 

(59)     What is the extension of Header File ?  

(A)   .h           (B) .he           (C)   .hea         (D) .hdr 

(60)     The syntax of header file in C language is 

(A)    #define <filename.h>    (B)    #define <filename> 

(C)   #include <filename.h>    (D)   #include <filename> 

(61)   Which of the following represent a Header file ?  

(A)   #include <stdio.h>     (B)   #include <conio.h> 

(C)   #include <math.h>    (D)   All 

 (62) Which of the following represents a type of variable ? 

(A)   Local variable       (B)   Global variable  (C)   Both (A) and (B)    (D)  None of these 

 (63) The scope of C variable is decided using .......... symbol.             

(A)   ( and )                    (B)   # and #   (C)   { and }                     (D)  /* and */ 

 (64)     Local variables are enclosed within .......... symbols. 

(A)   /* and */               (B)   ( and )   (C)   { and }                     (D) # and # 

(65)     Those variables which are used beyond its scope are known as..........types of variables, 

(A)   Global variable     (B)   Local variable   (C)  Both (A) and (B)    (D)  None   of these 

(66)     Where is global variable written? 

(A)    Between { and } (B)    Before all the functions (C)    (A) or (B)  (D)   Anywhere in the program 

(67) .......... function is compulsory in all the C program. 

(A)   main()                    (B)   pow()   (C)   sqrt()                      (D)  int() 

(68)   Execution of C program is started by which of the following function ? 

(A)   int()       (B) scanf()    (C)  main()   (D) return() 

(69)   The control of the program is given to.......... function first and from there other processes are done. 

(A)   printf()                   (B)   scanf()   (C)   return()                  (D) main()   

 (70)   Which of the following is a type of function ?  

(A)  User defined function     (B)  Inbuilt function  

(C)  Both (A) and (B)      (D) None of these  

(71)   The functions created as per the need of a user is known as ..........  

(A)   user defined functions     (B)   in-built functions  
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(C)  user installed functions     (D) user complement function  

(72)   Generally the user defined functions are added ..........  

(A)   before the main() function    (B)   after the main() function 

(C)   in between the main() function   (D)   we can't add this type of function 

 (73)   Inbuilt functions are also known as ........... 

(A)   inbuilt function         (B)   library function  

(C)  both (A) and (B)         (D)  user defined function 

(74)  Which of the following option represent inbuilt function ? 

(A)   printf()                    (B)   pow()  (C)  sqrt()                      (D) All  

(75)   Which of the following is a category of the C character set ? 

(A)    Letters and digits (B)    White spaces (C)   Special characters(D)   All of these 

(76)  Which of the following represent the "letter" category in the C character set ? 

(A)   A to Z, a to z        (B)    0 to 9  

(C)   Blank space, form feed, horizontal tab, vertical tab, new line  (D)    &, >, $, =, /, !, A 

(77)   Which of the following represent the "digits" category in the C character set ? 

(A)   A to Z, a to z        (B)    0 to 9 

CO  Blank space, form feed, horizontal tab, vertical tab, new line   (D) &, >, $, =, /, !, A 

(78)   Which of the following represent the "White space" category in the C character set ? 

(A)   A to Z, a to z               (B)   0 to 9  

(C)   Blank space, form feed, horizontal tab, vertical tab, new line  (D) &, >, $, =, /, !, A 

(79)   Which of the following represent the "Special characters" category in the C character set ?  

(A)   A to Z, a to z               (B)   0 to 9  

(C)  Blank space, form feed, horizontal tab, vertical tab, new line   (D)  &, >, $, =, /, !, A 

(80) .......... is constructed using the character set of C language. 

(A)   Letters                    (B)   Words   (C)   Paragraph              (D) All of these 

 (81)   Set of logically sequential C statements thus is identified as ........... 

(A)   C   function            (B)   C program  (C)  C statement           (D)  C flowchart 

(82)  Words in C language are known as ........... 

(A)   token                      (B)   torken   (C)  toppers                   (D) top en 

(83)   Each character in C language is a ........... 

(A)   letter                      (B)   statement  (C)  token                       (D) program 

(84)   Basically how many types of tokens are this in C language ? 

(A)   5             (B) 6               (C)  7              (D) 8 

(85)   Which of the following represent a token C language ? 

(A)    Key-word, identifier    (B)    Constant, strings 

(C)   Operator, special characters   (D)   All of these 

(86)   Which of the following represents a key-word? 

(A)   int         (B) *               (C)  main()  (D) 12 

 (87)   How many predefined words are supported by ANSI C ?  

(A)   31            (B) 32             (C)   33            (D) 34 

(88)   Predefined words in C language are known as 

(A)   key-word   (B)  identifier    (C)  token  (D) constant 

 (89)   What can a variable name consists of ?  

(A)   Letters                    (B)   Digits   (C)   Underscore            (D) All  

(90)   The first character of variable name must be 

(A)   letters or digits     (B)    letters or underscore  

(C)   digits or underscore    (D)   letters or digits or underscore 

 (91)   The maximum length of variable name as per ANSI standards is ........... 

(A)   30          (B) 31            (C)   32           (D) 33 

 (92)   What type of variable names are these num, NUM, Num, nUm, nuM, nUM, Num ? 

(A)   Equivlent               (B)   Different   (C)  Special                    (D) Can't say 

  (93)   Which of the following is a type of constant ? 

(A)    Numeric constant, symbolic constant  (B)   Character set constant 

(C)   Back slash characters    (D) All  

(94)  The constant that store numeric value is known as ............ 

(A)    numeric constant    (B)    symbolic constant  

(C) character constant     (D) back slash characters 

 (95)   Which of the following is a type of numeric constant ? 

(A)   Integer constant      (B)   Real constant  

(C)  Both (A) and (B)       (D) None of these 

 (96)   Which of the following is a type of integer constant ? 
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(A)   Octal                      (B)   Decimal   (C)   Hexadecimal         (D) All  

(97)   Octal constants use how many digits ?  

(A)   2            (B) 8              (C)   10           (D) 16 

(98)   The base of octal number system is........... 

(A)    16           (B) 10            (C)   8             (D) 2 

(99)   When using the value in C we differentiate octal numbers from decimal numbers by using prefix........... 

(A)   0            (B) 00            (C)   ox           (D) oX 

(100)   Decimal constants use how many digits ?  

(A)   2            (B) 8              (C)   10           (D) 16 

(101)   The base of decimal number system is........... 

(A)    16           (B) 10            (C)   8             (D) 2 

(102)   We can use as prefix .......... with decimal numbers. 

(A)   unary plus             (B)   unary minus  (C)   both (A) and (B)    (D)  None  

(103)   Hexadecimal constants use how many digits?  

(A)   2             (B) 8              (C)   10            (D) 16 

(104)   The   hexadecimal    constants    use    .......... characters. 

(A)   0 to 15 .                 (B)   0 to 16   (C)   0 to 9 and A to F  (D)  A 

(105)   The letter C denotes .......... in hexadecimal constant. 

(A)    11           (B) 12            (C)   13            (D) 14 

(106)   The base of hexadecimal number system is  

(A)    16           (B) 10            (C)   8             (D) 2 

(107)   Due to which of the following reasons Rs. 500 is invalid integer constant ? 

(A)    digits are not valid    (B)    Letters are not valid 

(C)   Zero is not valid        (D) All of these 

 (108) .......... refer to decimal numbers that have fractional part. 

(A)    Integer constant (B)    Mixed constant  (C)   Real constant        (D) All  

(109)   Which of the following is a real constant ?  

(A)    10.50                      (B)   3.14  (C)   -65.75                     (D) All 

(110)   How is a real constant represented ?  

(A) Scientific                 (B) Word form   (C)   Symbolic                (D)  Graphical 

(111)   What is used to represent the real constant in the scientific form ? 

(A)   Mantissa                (B)   Exponent  (C) Both (A) and (B)  (D)  None of these 

(112)   How is 25.75 value represented in scientific form ? 

(A)   0.2575e2                 (B)   0.2575E2  (C) Both (A) and (B)   (D)   (0.2575)2 

(113)   In 0.2575e5, which of the following show mantissa ? 

(A)   0.2575                     (B)   e   (C)   5                             (D)  Both (A) and (C) 

(114)   In 0.2575e5 which of the following show exponent ? 

(A)   0.2575                     (B)   e   (C)   5                             (D)  Both (A) and (C) 

 (115)   ..........   constants   are  used  to   store  the information made of characters. 

(A)    Integer constant (B)    Real constant (C)   Character constant (D)   Any of these  

(116)  .......... value is attached to each character constant.  

(A)   ANSI                         (B)   ASCII   (C)  SciTE                     (D)  No value is attached  

(117)   ASCII stands for ........... 

(A)   American Standard Code for Information Interchange 

(B)   American Standard Code for Interchange Information 

(C)   American Standard Code for Intelligent Interchange 

(D)   American Standard Code  for Internet Interchange 

(118)   String constants are enclosed within .......... symbols. 

(A)   single quote          (B)   double quotes  (C)   round brackets      (D)  curly brackets 

 (119)   T occupies how much memory space ?  

(A)    1             (B) 2              (C)   4             (D) 8 

(120)   "T" occupies how much memory space ?  

(A)    1             (B) 2              (C)   4             (D) 8 

(121)   Each string ends with .......... in C language. 

(A)   \0           (B) /0            (C)   '0'           (D) "0" 

(122)   ......constant uses only two characters. 

(A)  Character constant    (B)  String constant   

(C) Back slash characters   (D) All of these 

 (123)  back slash characters are known as ........... 

(A) escape Sequence  (B)   ex Sequence (C)  access Sequence   (D)  excellent Squence 

(124)   ........value is associated back slash characters. 
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(A)   ANSI                      (B)   IBM  (C) ASCII                     (D) Any of these 

 (125)  ..... back slash character is used to insert a null  value. 

(A) \a           (B) \b           (C)   \t            (D) \0 

(126)  .......... back slash character is used to insert an audible alert. 

(A)   \a           (B) \b           (C)   \t            (D) \0 

(127) ..........back slash character is used to insert a back space. 

(A)   \a           (B) \b           (C)   \t            (D) \0 

 

(128) ..........back slash character is used to insert a horizontal tab. 

(A)   \a           (B) \b           (C)   \t            (D) \0 

(129) ..........back slash character is used to insert a vertical tab. 

(A)   \f           (B) \n           (C)   \r            (D) \v 

(130) ..........back slash character is used to insert a new line. 

(A)   \f           (B) \n           (C)   \r            (D) \v 

(131) .......... back slash character is used to insert form feed. 

(A)   \f           (B) \n           (C)   \r            (D) \v 

(132) ..........back slash character is used to insert a new line during input or output in C language.  

(A)    \a           (B) \r            (C)   \d           (D) \n 

 (133)   In the syntax of symbolic constant #define identifier value, what is pre-processor directive ?  

(A)   #define                   (B)   indentifier  (C)  value                      (D) All  

 (134)   Which of the following is an example of symbolic constant ? 

(A)    #define PI3.14  (B)    #define MAXVALUE 100 

(C)   #define f float         (D) All  

 (135) ..........   instructs   the   compiler   that the occurrence of the symbolic constant used in program should 

be replaced by the constant value specified in the definition. 

(A)    Pre-processor directive statememt  (B)    Pre-processing directive statememt 

(C)   Pre-process directive statememt  (D)   Pre-processed directive statememt  

 (136) Which of the following options is a step to execute a C program ? 

(A)    Text editor and translator  (B)    Linker and loader 

(C)   Both (A) and (B)     (D)  None of these  

(137)  Which is the first step to execute a C program?  

(A)   Text editor             (B)   Translator  (C)   Linker                    (D)  Loader 

(138) The program which is written using a text editor is known as ............ 

(A)  source program     (B)   source code  (C)  (A) or (B)               (D) text program 

(139) What is the file extension in C language ?  

(A)   .c           (B) .cp          (C)   xpc        (D) .ccc 

(140) ..........   text  editor   is   available   in   Linux operating system.  

(A)  vi                            (B)   gedit  (C) emacs                     (D) All  

 (141) ..........   converts   a  source  program  into machine language program known as object code or object 

program.  

(A)   Compiler               (B)   Flowchart  (C) Algorithm               (D)  Processor 

(142) Which is the third step to execute a C program ?  

(A)   Text editor             (B)   Translator  (C)  Linker                    (D)  Loader 

(143) Which of the following links the object code with the executable code ?  

(A)   Text editor            (B)   Translator (C)   Linker                    (D)  Loader 

(144)   Object code is linked with the executable code to give........... 

(A)    executable program / executable code (B)    source code / source program 

(C)   both (A) and (B)       (D)  none of these 

(145)   Which is the fourth step to execute a C program ?  

(A)   Text editor             (B)   Translator   (C)   Linker                    (D)  Loader 

(146)    Executable code is loaded on to memory by a program called .......... along with the data 

required to give us the output. 

(A)   text Editor             (B)   translator  (C)   linker                     (D)  Loader 

(147) .......... gives the final output of the program. 

(A)   Text editor            (B)   Translator (C)   Linker                    (D)  Loader 

(148)  Which text editor is used to write  C program ?  

(A)   vi, gedit                 (B)   SciTE  (C)   emacs                    (D) All  

(149) .......... text editor allows us to compile and run simple programs with one window itself.  

(A)   vi           (B) gedit      (C)  SciTE     (D) emacs 

(150)  What option is selected to open the SciTE Text editor ? 

(A)   Application -> Programming -> SciTE Text Editor 
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(B)   Application —> Editor -> SciTE Text Editor 

(C)   Application —> Text Editor —> SciTE Text Editor 

(D)   Application —> Accessories -> SciTE Text Editor 

 (151)   Default file name given to a file by SciTE is.......... 

(A)   New                       (B)   File  (C)   Untitled                 (D) Text 

(152)  Before writing the C program in SciTE, which option in the menu is selected ? 

(A)   Tools -> C/C++    (B)   Language —> C/C++ 

(C)   Tools -> Language -> C/C++  (D)   Edit —> Language —> C/C++ 

(153) ..........option is used in the menu to save the file in SciTE text editor. 

(A)   File -» Save           (B)   File -> Store (C)  File -> Compile     (D) File -> Run 

 (154)   To find the error once the program is written in SciTE text editor..........is done. 

(A)   run                         (B)   compile  (C)   execute                  (D)  any of these 

(155) .......... menu option is selected to compiles file in SciTE text editor. 

(A)   Tools -> Compile   (B)   File -> Compile  

(C)  Edit -> Compile     (D) View -> Compile 

(156) ..........is the short cut key to compile the fill in SciTE text editor. 

(A)   Ctrl + F5                (B)   Ctrl + F6  (C)   Ctrl + F7                (D) Ctrl + F8 

(157) .......... menu option is selected to execute a file in SciTE text editor. 

(A)   File -> Go             (B)   Tools -> Go  (C)  Edit -* Go              (D) View -> Go 

(158) ..........is the short cut key to execute a file in SciTE text editor. 

(A)   F2          (B) F3           (C)   F4           (D) F5 

(159) .......... window is seen while executing a program in SciTE text editor.  

(A)   Source code          (B)   Output  (C)  Both (A) and (B)   (D) Executable 

 (160)  Which menu opton is selected to show the output window in the SciTE text editor ?  

(A)   View -> Output      (B)   Tools -> Output  

(C)  Format -» Output   (D) Edit -> Output 

(161) ..........is the short cut key to show the output window in die SciTE text editor. 

(A)   F5          (B) F6           (C)   F7           (D) F8 

(162)  To delete the previous results in the output window of the SciTE text editor.......option is used. 

(A)   View -> Clear Output  (B)    Tools -> Clear Output 

(C)   Edit -> Clear Output  (D)   Format -» Clear Output 

(163) ..........is the short cut key to delete the previous results in the output window of the SciTE text editor. 

(A)   Shift + F5              (B)   Alt + F5  (C)   Ctrl + F5                (D)  Ctrl + Shift + F5 

 (164) To execute the input type program in SciTE text editor..........is used. 

(A)   editor                     (B)   terminal  (C)  compiler                (D)  translator 

 (165) Which of the following is an example of a compiler window ? 

(A)   gcc         (B) gedit      (C)   emacs     (D) vi  

(166) gcc is provided by.......... . 

(A)    Open Software Foundation  (B)    Free Source Foundation 

(C)   Open Source Foundation   (D)   Free Software Foundation 

 (167)   gcc is ..........based ANSI C compiler. 

(A)   Unix/Linux              (B)   Windows (C)   Mac operating system (D)   All of these 

(168)  gcc is generally used by........... 

(A)   graphics                 (B)   command line (C)   video based            (D)  all of these 

 (169)   Full form of IDE is ........... 

(A)    Integrated Development Environment (B)    Integrated Database Environment 

(C)   Integrated Development Electronics (D)   Integrated Data Environment 

(170)  To do compilation using gcc,..........command is typed in the terminal. 

(A)    $ filename.c gcc     (B)    $ gcc compile filename.c 

(C)   $ gcc filename.c     (D)   $ gcc filename.c compile  

(171)  To see the output of the C program, type the command ........... 

(A)   $ Aa.out              (B)   $ ./a.out   (C)   $ \a.out                 (D)  $ /a.out  

(172) .......... shows how to give a name to output file using gcc command. 

(A)    $ gcc -o myprogram.o myprogram.c  (B)    $ gcc -d myprogram.o myprogram.c  

(C)   $ gcc -c myprogram.o myprogram.c  (D)   $ gcc -v myprogram.o myprogram.c  

 (173)  To get help regarding gcc compiler .......... command is used. 

(A)   $ gcc man               (B)   $ help gcc (C)   $ assist gcc             (D)  $ user gcc 

(174)  The full form of man is ............ 

(A)   management         (B)   manufacture (C)   manual                  (D)  mantel 

 (175) ..........is case sensitive in C program. 

(A)   Identifier                (B)   Variable  (C)  Value                      (D) All of these 
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 (176) ..........  sign  is  used at  the  end  of each statement in C language. 

(A)   ;             (B) :              (C)   /              (D) /* 

 

CH-11     Data Types, Operators And Expressions In C Language 
 (1)       The type of value to be stored in identifier is known as ........... 

(A)   token                     (B)   data type   (C)   keyword                 (D)  database 

(2)       If 18 is stored in date identifier then what would be its data type ? 

(A)   integer                   (B)   float   (C)  character               (D) Any of these 

(3)      If 12.50 is stored in amount identifier then what would be its data type ? 

(A)   Integer                   (B)   float   (C)   Character               (D) Any of these 

(4)      ..........is used to connect value with the data. 

(A)   Prototype               (B)   Token   (C)   Database                (D)  Keyword 

 (5)      ..........is defined by a keyword. 

(A)    Type of value stored in Identifier  (B)    Memory space in Identifier 

(C)   Both (A) and (B)     (D)   None of these 

 (6)  8 bits = _________ 

(A)   1 Bit   (B)    1 Nibble    (C) 1 Byte   (D) 1 kilobyte 

(7) How many data types  are supported by C language ? 

(A)   2            (B) 3              (C)   4           (D) 5 

 (8)    ..........data type is used to represent real values. 

(A)   int                          (B)   float   (C)  char                        (D) Any of these 

(9).......... data type is used to represent single  character. 

(A)   int                          (B)   float   (C)   char                        (D) Any of these 

(10)     The number which is the positive or whole number is known as........... 

(A)   integer                   (B)   decimal/float  (C)   character                (D) empty 

(11)    ..........option shows the integer values. 

(A)   314, -88                  (B)   503, 8000  (C)   21000, -314            (D) All  

 (12) .........Keyword is used to denote only positive  values. 

(A)   Signed                      (B)   Unsigned   (C) Negative                   (D) Positive 

 (13)   int data type occupies how many bytes ?  

(A)   2            (B) 4             (C)   6             (D) 8 

(14)    What is the range of int data type ? 

(A)    0 to 4294967295   (B)    0 to 429496 

(C) -2147483648 to +21474836411  (D) -21474836 to +21474836 

(15) Positive integer data type is represented using .......... keyword. 

(A)   signed int              (B)   unsigned int (C)   sig int                    (D)  unsig int 

(16) Unsigned int data type occupies how many bytes ? 

(A)   2            (B) 4             (C)   6             (D) 8 

(17)     The range of values of integer data type is based on the occupied........... 

(A)   bit                              (B)   byte  (C)   kilobyte                    (D)  megabyte 

(18)    ..........keyword is used to expand the range of integer datatype. 

(A)   big                             (B)   long  (C)   lengthy                     (D)  large 

(19)     long int occupies how many bytes ?  

(A)   2             (B) 4             (C)   6             (D) 8 

 (20)    ..........keyword is used to represent real values. 

         (A)   f             (B) fit           (C)  float       (D) decimal 

(21)     How many float data types are available in C language ? 

(A)   2            (B) 3             (C)   4             (D) 5 

(22)    .......... shows the float data type. 

(A)   Float                      (B)   Double  (C)  Long double          (D) All  

(23)     Float data type occupies how many bytes ?  

(A)   2            (B) 4             (C)   6             (D) 8 

(24)     Float data type has the precision of .......... digits in the fractional part. 

(A)   4            (B) 5             (C)   6             (D) 7 

(25)     Float data type has .......... range. 

(A)    +/-3.4e-38 to +/-3.4e+38  (B)    +/-1.7e-308 to +/-1.7e+308 

(C)   +/-3.4e-4932 to +/-l.le+4932  (D)   +/-3.4e-18 to +/-3.4e+18 

(26)     If we require more accuracy with float type,..........keyword is used. 

(A)   double                    (B)   long  (C)  long float               (D)  double float 

(27)    .......... is the expanded format for float type. 

(A)   long      (B) wide      (C)  double   (D) Double  
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(28) double data type occupies how many byte?  

(A)   2            (B) 4             (C)   6            (D) 8 

(29) Double data type has the precision of U many digits in the fractional part ?  

(A)   6            (B) 7             (C)   16          (D) 17 

(30) Double data type has the precision of  many digits in the integer part ? 

(A)   6            (B) 7             (C)   16          (D) 17 

(31)     Double data type has the..........range. 

(A)    +/-3.4e-38 to +/-3.4e+38  (B)  +/-1.7e-308 to +/-1.7e+308 

(C)  +/-3.4e-4932 to +/-l.le+4932  (D) +/-3.4e-18 to +/-3.4e+18 

(32)     If more precision is required than double dali type .......... is used. 

(A)   float                       (B)   long  (C)  long float               (D) long double 

(33)    ..........is the expanded format of doubled types. 

(A)   long                       (B)   wide  (C)  long double           (D) large 

(34)     Long double data type occupies how many bytes ? 

(A)   4            (B) 6             (C)   8             (D) 16 

(35)     Long double data type has ..........range. 

(A)    +/-3.4e-38 to +/-3.4e+38  (B)    +/-1.7e-308 to +/-1.7e+308 

(C)   +/-3.4e-4932 to +/-l.le+4932  (D)   +/-3.4e-18 to +/-3.4e+18 

 (36)  ..........is define scientific format of 95.50. 

(A)   0.9550e2                 (B)   0.9550e3 (C)  0.9550e4                 (D)  0.9550e5 

(37) Scientific value 0.9550e2 represents ........... 

(A)   mantissa                (B)   exponent  (C) both (A) and (B)    (D)  None of these 

(38) ..........is*define mantissa for 0.9550e2. 

(A)   0.9550                     (B)   2   (C)  e                             (D) All of these 

(39) ..........represents mantissa in 0.9550e2. 

(A)   0.9550                     (B)   2   (C)  e                             (D) All of these 

(40) How many parts are represented in the memory of float values ?  

(A)   3             (B) 4             (C)   5             (D) 6 

(41) .......... indicates the part of memory for float numbers. 

(A)   Sign                        (B)   Exponent  (C)  Mantissa                (D) All of these 

(42) How many digits are there in the representation of real values ? 

(A)   28                           (B)   29   (C)   30                           (D)  31 

(43) Mantissa represents die series of..........numbers. 

(A)   0 to 22                   (B)   23 to 30  (C)   0 to 18                   (D)  0 to 31 

(44) Exponent part represents .......... series of numbers. 

(A)   0 to 22                   (B)   23 to 30  (C)   0 to 18                   (D)  0 to 31 

(45) Sign part represents..........series of numbers. 

(A)   0                             (B)   22   (C)   23                           (D)   31 

(46)  ..........data type cannot be used to represent "M" or "F" respectively for male and female.  

(A)   int                          (B)   float  (C)   char                        (D)  Both (A) and (B) 

(47)     To display values of character set...........data type can be used. 

(A)   int                          (B)   float  (C)   char                        (D) void 

(48)    ..........data type can be used to store characters. 

(A)   ch                           (B)   char  (C)   chara                      (D)  cheract 

(49)    ..........integer value is attached to each character. 

(A)   ANSI                      (B)   UNICODE  (C)   ASCII                     (D)  TURBO 

(50)     By default char is ........... 

(A)   sign                        (B)   unsigned  (C)   (A) or (B)               (D)  none of these 

 (51)     Char data type has .......... range. 

(A)   0 to +127               (B)   -127 to +128 (C)   -128 to +127         (D)  -128 to +128 

(52)     Char data type occupies how many bytes ?  

(A)   1 Byte                    (B)   2 Bytes  (C)  3 Bytes                   (D) 4 Bytes 

(53)     Unsigned char data type has..........range. 

(A)   0 to 127                 (B)   0 to 128  (C)   0 to 221                 (D)  0 to 255 

(54)     Unsigned char data type occupies how many bytes ? 

(A)   1 Byte                    (B)   2 Bytes  (C)   3 Bytes                   (D)  4 Bytes 

(55)     ASCII value of Blank is ........... 

(A)   30           (B) 31           (C)   32           (D) 33 

(56)    ..........is the special data type of C language. 

(A)   int         (B) float       (C)  void        (D) char 

(57)    C program is the collection of........... 
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(A)   value                    (B)   operators  (C)  functions              (D) token 

(58)    If we want to say the function would not return any values then..........is used. 

(A)   empty   (B) void       (C)  blank     (D) null 

(59)    ..........statement indicates compiler to exit the program. 

(A)   return 0;               (B)   exit 0;     (C)   stop 0;                  (D)  end 0; 

 (60) ..........is the more used syntax of assigning value to the variable. 

(A)   variable = value;    (B)   datatype variable = value; 

(C)   value = variable    (D)   value = data type variasble; 

(61) .......... syntax is used to store 30 in amount integer variable. 

(A)   int amount = 30    (B)   amount int = 30; 

(C)   int amount == 30;   (D)   amount int == 30; 

 (62) Using..........a new data type can be created, 

(A)   Basic Data type       (B)   Special Data type  

(C) New Data type     (D) Administrator Data type 

(63) ..........is the keyword for user defined data type? 

  (A)   typedef                 (B)   enum  (C)   Both (A) and (B)  (D)  None of these 

(64) typedef and enum are..........types of data type 

(A)   Inbuilt                  (B)   User defined (C)  Global                  (D) None 

(65)  What is full name of typedef ?  

(A) Type Definition     (B)   Type Define  (C) Type Deferent       (D)  Type Defence 

(66) What is full name of enum? 

 (A) Enurated  (B) Enumber  (C) Enurising  (D) Enumerated  

(67) Using _______ keyword a variable can be defined which can be used as a data type? 

 (A) typedef  (B) enum  (C) both (A) & (B) (D)None 

(68) ..........to give the alias name to the keyword. 

(A)   typedef                     (B)   enum  (C)   char                           (D)  float 

(69) ........ is the syntax to declare typedef data type. 

(A)   data type variable typedef;  (B)   typedef variable data type; 

(C)   typedef data type variable;  (D)   data type typedef variable; 

(70) .......... keyword is used for enumarated data type. 

(A)   num                          (B)   enum  (C)  enumber                  (D)  enumerated 

(71)  .......... is the example of derived data type. 

(A)   Array, Structure        (B)   Union, Pointer   

(C)  Both (A) and (B)      (D)  None of these 

(72)   Data structure including the group of variables with same characteristics is known as......... 

(A)   array                         (B)   structure (C)   union                        (D)  pointer 

(73)  .......... is the group of variables with same data type. 

(A)   Union                       (B)   Pointer  (C)   Structure                  (D) Array 

(74) ..........is the syntax to define an array. 

(A)    datatype identifier [size];  (B)    datatype variable [size]; 

(C)   datatype keyword [size];   (D)   datatype constant [size]; 

(75)  Array to declare as name with size 10, .......... is given. 

(A) char name [10];    (B) char name [11];  (C) char [10] name;     (D) char [11] name; 

(76)   Generally one variable can store how many values at a time ? 

(A)   None of these       (B)   Only one  (C)   Only two                  (D)  Many 

(77)   How many type of operators are their in C language ? 

(A)   4            (B) 6             (C)   8             (D) 10 

(78)  Which option represents the operators in C language ? 

(A)    Arithmetic operators  (B)   Assignment operators 

(C)   Relational operators  (D)   All of these 

OR  

(A)   Bitwise operators   (B)   Special operators  

(C)   Logical operators   (D) All of these 

OR 

(A)    Increment and Decrement operators (B)    Conditional operators 

(C)   Logical operators (D) All of these  

(79)   How many operators are there for calculation ?  

(A)   4            (B) 5             (C)   6             (D) 7 

(80) ..........is the mathematical operator. 

(A)   +, -                         (B)   *, /  (C)  %                           (D) All of these                

(81) There is no operator for..........in C language. 
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(A)   exponential           (B)   multiplication (C)   division                  (D)  subtraction 

(82) C provides extra operator for...........  

(A)   division                  (B)   square  (C)   modulo                  (D)   exponent 

(83) ..........is the modulo operator. 

(A)   #            (B) %            (C)   @            (D) $ 

(84) ..........operator is used to get the remainder. 

(A)   Division                 (B)   Remainder (C)   Modulo                  (D)  Divisor 

(85) Modulo operator cannot be used with........... 

(A)   integer                   (B)   float  (C)   both (A) and (B)   (D)  none of these  

(86)   Calculation is divided into which part as per the operands available in the expression ?  

(A)   Integer arithmetic    (B)   Real arithmetic 

(C)   Mix mode arithmetic   (D)   All of these 

(87)   If the values used in the expression are positive or negative whole numbers then it is considered as ........... 

(A)   integer arithmetic    (B)   real arithmetic 

(C)   mix mode arithmetic   (D)   all of these 

(88)   Expression with integer values are known as 

(A)    original expression   (B)    functional expression 

(C)   integer expression   (D)   varied expression 

(89)   Result of integer expression is always........... 

(A)   integer                   (B)   float  (C)   (A) or (B)               (D)  can't say 

(90)   If the values used in the expression are positive or negative real numbers then it is considered as ........... 

(A)   integer arithmetic    (B)   real arithmetic 

(C)   mix mode arithmetic   (D)   all of these 

(91)   Expression under real numbers calculation is known as ........... 

(A)    original expression   (B)    functional expression  

(C)   integer expression   (D)   varied expression 

(92)   Result  of real/float  expression  is  always __________. 

(A)   integer                   (B)   float  (C)   (A) or (B)               (D)  can't say 

(93)   Expression with integer and real both values is known as ........... 

(A)    original expression   (B)    mixed expression 

(C)   real  expression    (D)   varied expression 

(94)   Operators capable of assigining values are known as ........... 

(A)    assignment operators   (B)    relational operators 

(C)   arithmetic operators   (D)   logical operators 

(95) .......is used to compare two operators. 

(A)    Conditional Operators   (B)    Logical Operators 

(C)   Relational Operators   (D)   Bitwise Operators 

(96) .......is used to change the flow of execution of the program. 

(A)    Bitwise Operators   (B)    Relational Operators 

(C)   Logical Operators    (D)   Conditional Operators 

(97)   How many relational operators are there for comparison ? 

(A)   3            (B) 4             (C)   5             (D) 6 

(98) ........is the relational operator. 

(A)   >, <                        (B)   >=, <=  (C)   = =, !=                    (D) All of these 

(99) ........is used to check the equality of operands. 

(A)   =            (B) = =         (C)  = !          (D) ! = 

(100) ........ is used to check the non-equality of operands. 

(A)   !             (B) = !          (C)   ! =           (D) !! 

(101) ........ can be used to check the bigger value. 

(A)   >            (B) »           (C)   > !           (D) ! > 

(102) ........can be used to check the smaller value. 

(A)   <            (B) «           (C)   < !           (D) ! < 

(103) ........ can be used to check greater or equal value. 

(A)   = >         (B) > =         (C)   = <          (D) < = 

(104) ........ can be used to check the smaller or equal value. 

(A)   = >         m>=         (C)  = <          (D) < = 

(105) ........ operator is used in place of = to check the equality of two operands in relational symbol. 

(A)   = =         (B) ! =          (C)   = = =      (D) = ! 

(106) ........is used as an assignment operator. 

(A)   = =         (B) =             (C)   ! =           (D) = ! 

(107)   Operator working with the single operand is known as ......... 
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(A)    unary operator    (B)    relational operator 

(C)   logical operator    (D)   arithmetic operator 

(108)   "++" is known as........operator. 

(A)   unary increment      (B)   increment operator  

(C)   both (A) and (B)       (D) bitwise operator 

(109)   "- -" is known as ........operator. 

(A)    unary decrement   (B)    decrement operator 

(C)   both (A) and (B)    (D)   bitwise operator 

(110)  ++ variable;  shows which type  of unary operator ? 

(A)    Pre-Increment operator   (B)   Pre-Decrement operator 

(C)  Post-Increment operator   (D) Post-Decrement operator 

(111)  - - variable; shows which type of unary operator ? 

(A)  Pre-Increment operator    (B)  Pre-Decrement operator ' 

(C) Post-Increment operator    (D) Post-Decrement operator  

(112)  Variable  ++   shows which  type  of unary operator ? 

(A)   Pre-Increment operator   (B)   Pre-Decrement operator 

(C)   Post-Increment operator   (D)   Post-Decrement operator 

(113)  Variable --  shows which  type  of unary operator ? 

(A)   Pre-Increment operator   (B)   Pre-Decrement operator 

(C)   Post-Increment operator   (D)   Post-Decrement operator 

(114) ........is the syntax of conditional operator. 

(A)    (Condition) ? (False statement):   (True statement); 

(B)    (Condition) ? (True statement): (False statement); 

(C)   (Condition) : (True statement) ?(False statement); 

(D)   (Condition) : (False statement) ?(True statement); 

(115) If one condition is true or more conditions are true, to check that ....... are useful. 

(A)   relational operators   (B)   logical operator 

(C)   (A) or (B)     (D)  conditional operators  

(116) How many types of logical operators are there ? 

  (A)  2            (B) 3             (C)   4             (D) 5 

(117) .......is the type of logical operator. 

(A)  AND                       (B)   OR   (C) NOT                        (D) All of these 

(118) .......is the symbol of logical AND. 

(A)   ||             (B) !                (C)   &&          (D) & 

(119).......is the symbol of logical OR. 

(A)   |             (B) | |            (C)   &&          (D) ! 

(120) .......is the symbol of logical NOT. 

(A)   !             (B) !!            (C)   &&          (D) | | 

(121) .......operator is used when we want to check that all conditions must be true. 

(A)   &             (B) &&          (C)   |                (D) 11 

(122) Minimum how many operands are used to use logical END ? 

(A)   0            (B) 1             (C)   2             (D) Many 

(123)   & symbol is.......operator. 

(A)   Bitwise AND         (B)   Bitwise OR (C)   Bitwise NOT         (D)  Bitwise Ex-OR 

(124)   | symbol is.......operator. 

(A)   Bitwise AND         (B) Bitwise OR  (C)   Bitwise NOT         (D) Bitwise Ex-OR 

(125)   ~ symbol is.......operator. 

(A)   Bitwise AND         (B)Bitwise OR   (C)   Bitwise NOT         (D) Bitwise Ex-OR 

 

 

CH-12 Using I/O operations 
(1) What is the information given by keyboard known as ? 

(A)   Output                   (B)   Input  (C)  Process                  (D)  None of these 

(2) ........ can be used as input device. 

(A)   Keyboard               (B)   Mouse  (C)   Both (A) and (B)  (D)  Monitor 

(3) ........is the standard input device. 

(A)   Keyboard               (B)   Mouse  (C)   Scanner                 (D) Microphone 

(4) Some inbuilt statements are available to execute input process in C language. Choose the correct option. 

(A)   True                       (B)   False  (C)   Can't say               (D)  None of these 

(5)  ........ is the inbuilt function. 

(A)   getchar()                (B)   getch()  (C)   getc()                     (D) All of these 
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OR  (A)   getc()                      (B)   gets()  (C)   scanf()                   (D) All of these 

(6)All the programming languages give the feature of showing results for the input data is known as ......... 

(A)   output operation    (B)   process operation  

(C)   input operation       (D)  reader operation 

(7) ........ is the output device. 

(A)   Monitor                 (B)   Printer  (C)   Both (A) and (B)  (D)  Keyboard 

(8)  ........is the standard output device. 

(A)   Printer                   (B)   Monitor  (C)   Keyboard               (D) Mouse 

 (9) ........is the inbuilt output function. 

(A)   purchar()               (B)   puts()  (C)  printf()                   (D) All of these 

(10) Input and output process in short is known as ......... 

(A)   I/O process           (B)   O/I process (C)   O/U process         (D)  U/O process 

(11) I/O stands for......... 

(A)   Internal/Output process   (B)   Input/Overput process 

(C)   Input/Output process   (D)   Interval /Overall process 

 (12) ........shows the input output process. 

(A)    getchar(), getch(), gets()   (B)   putchar(), putc(), puts() 

(C)   scanf(), printf()    (D)   All of these 

(13) ........is used to process the data in a program. 

(A)   Variable                 (B)   Identifier  (C)  Token                     (D) Function 

 (14) ........operator is used while assigning a value to the variable while making a program. 

(A)   Assignment           (B)   Relational (C)   Logical                   (D)  Bitwise 

 (15) ........ shows the basic function of computer system ? 

(A)   Input                      (B)   Process  (C)   Output                   (D) All of these 

(16) Functions to get values from the user from known as ......... 

(A)    Outer Input Function   (B)    Global Input Function 

(C)   Inbuilt Input Function   (D)   Database Inbuilt Input Function 

(17)  Where the different functions for input store in C language ?  

(A)   Compiler               (B)   Library   (C)   Processing             (D) Memory 

(18) ........ is used to use any inbuilt function library in C language. 

(A)   %include               (B)   @include  (C)   &include                (D) #include 

 (19) ........ statement is added in the beginning of C program. 

(A)   #include <std.h>     (B)   #include <stdio.h>  

(C)   #include <stdou.h>   (D)   #include <standard.h> 

(20)  #include <stdio.h>, where stdio stands for..., 

(A)    Section Input/Output   (B)    Source Input/Output 

(C)   Size of Input/Output   (D)   Standard Input/Output 

 (21)  In........header file input and output related functions are stored. 

(A)   #include <studio.h>   (B)   #include <standard.h> 

(C)   #include <stdio.h>   (D)   #include <stdoi.h> 

(22) #include statement gives the feature of finding ........file and giving compiler instructions  add the details in 

the beginning of program. 

(A)   std.h                       (B)   stdio.h  (C)   studio.h                   (D)  stdou.h 

(23) ........is the input inbuilt function. 

(A)   getc()                      (B)   gets()  (C)  getch(), getchar()   (D) All  

(24) ........function is used to read one character. 

(A)  getchar()                (B)   gets()  (C) putchar()                 (D) puts() 

 (25) In ........ function the input character is displayed on the screen. 

(A)  putchar()               (B)   puts()  (C)  getchar()                  (D)  gets() 

 (26) ........is the simplest function to get a character from the user while executing a program. 

(A)   getchar()                (B)   gets()  (C) putchar()                 (D) puts() 

 (27)  getchar() function reads how many characters at a time ? 

(A)   One                        (B)   Any number of (C)   Many                       (D)  None of these 

 (28)    ........ function  does  not  show the  input character on the screen. 

(A)   getch()                    (B)   gets()  (C)   putch()                    (D)  puts() 

 (29)    ........function reads the character from a file. 

(A)   puts()                     (B)   putc()  (C)   gets()                       (D)  getc() 

(30)    ........function is used to get string from a user. 

(A)   gets()                      (B)   getchar()  (C)   getch()                     (D)  getc() 

 (31)     gets() function ends with......... 

(A)   null character       (B)   nill character  (C)   (A) or (B)                (D)  none of these 
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(32)    .......shows the formatted input function. 

(A)   clrscr()                   (B)   scanf()  (C)   getch()                     (D) puts() 

(33)     In ....... format data can be inserted using scanf() function. 

(A)   int                          (B)   char  (C)   float                        (D)  all of these 

 (34)   In scanf() format starts with.......symbol. 

(A)   #            (B) &            (C)   %            (D) @ 

 (35)     In scanf().......symbol is given before variable name. 

(A)   @           (B) %            (C)   $             (D) & 

 (36)     Each variable is defined by....... : 

(A)   name                     (B)  memory location (C)   both (A) and (B)  (D) none of these 

(37)     When  a  variable  name is  mentioned, compiler uses .......for the process. 

(A)    memory location of variable  (B)   memory location of token 

(C)   memory location of identifier  (D)   memory location of function 

(38)     Control string is known as ........ 

(A)   master string        (B)   variable string  (C)   function string     (D) format string 

 (39)     scanf() function uses.......to read real values. 

(A)   %f          (B) %d          (C)   %c          (D) %p 

 (40)    .......  is  the  corresponding character double data type. 

(A)   %df       (B) %dd       (C)   %lf         (D) %fl 

 (41) scanf() function uses.......to read a character. 

(A)  %d         (B) %f          (C)   %c          (D) %s 

(42)  scanf() uses ....... corresponding character to read a string. 

(A)  %d         (B) %f          (C)   %c          (D) %s 

(43) ......will accept only specified characters in scanf. 

(A)  %[characters]           (B)   % [^characters]  

(C) &[characters]             (D)  &[Acharacters] 

 (44) .......will accept the characters only from a to z. 

(A) &[a-z A-Z]                 (B)   %[a-z A-Z]   

(C) &[a to z A to Z]       (D)  %[a to z A to Z] 

 (45)   scanf() statement can accept.......value. 

(A)   integer, float         (B)   character  (C)   string                     (D)  all of these 

 (46)  ....... is used for unsigned integer value in scanf. 

(A)   %h         (B) %u         (C)   %lf         (D) %ld 

 (47)  .......is used for long integer value in scanf. 

(A)   %L                          (B)   %u   (C)   %lf                         (D)   %ld 

(48)  .......is used for double value in scanf. 

(A)   %L                          (B)   %u   (C)   %lf                         (D)   %ld 

(49)  .......is used for long double value in scanf. 

(A)   %L                           (B)   %u  (C)   %lf                         (D)  %ld 

(50)  .......has the inbuilt output functions. 

(A)   <std.h>                  (B)   <standard.h> (C)   <stdio.h>                (D)  <studio.h> 

(51)  .......shows the inbuilt output functions. 

(A)   putchar()                (B)   puts()  (C)   printf()                    (D) All of these 

 (52)   putchar() has the drawback. 

(A)  At different times it displays only one character 

(B)  At a time it displays only one character. 

(C)  At different times it displays multiple I characters. 

(D)  At a time it displays multiple characters, 

 (53) Each string ends with ........ 

(A)   slash      (B) null        (C)   space      (D) variable  

 (54) To display different results with formatting is known as........ 

(A) formatted input        (B)   formatted output 

(C)   formatted processor   (D)  formatted string 

(55) .......is the formatted output function. 

(A) putchar()                (B)   puts()  (C) printf()                  (D)   scanf() 

(56)  printf() stands for........ 

(A) print formatted     (B)   print format  (C) print form             (D)  print formal 

 (57)   Which escape sequence character is used to take the cursor to the new line ? 

(A)    \n          (B) \b           (C)   \t            (D) \a 

(58)   Which escape sequence character is used to give tab ? 

(A)   \n          (B) \b           (C)   \t            (D) \a 
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(59)  .......is given before the specifier of a variable. 

(A)   &            (B) $             (C)   #             (D) % 

 (60)  .......  corresponding character  is  use  for printing a floating point value with exponent in printf(). 

(A)   %c         (B) %d         (C)   %e          (D) %f 

 (61)  .......  corresponding character  is  use for printing a long double value printf(). 

(A)   %lf         (B) %Lf        (C)   %o          (D) %x 

(62)  .......  corresponding character  is  use for printing an integer in octal form in printf(). 

(A)  %lf         (B) %Lf        (C)   %o          (D) %x 

(63)  .......  corresponding  character  is  use for printing an integer in hexadecimal form of printf(). 

(A)   %lf         (B) %Lf        (C)   %o          (D) %x 

 

CH-13       Decision Structure 
(1)  C language provides facilities through special kind of statements that can change the flow                                     

of a sequence instructions in the program are called……  .  
(A)  loop structure statements            (B)   special structure statements                                                       

(C)    flow structure statements            (D)   decision structure statements 

(2)     ..........is the statements help us to jump from one part of the program to another part of program based 

on result of some conditions. 

(A)    Sequential structure   (B)    Decision structure 

(C)   Random structure   (D)   Optional structure 

 (3)  Sometimes decision structure statements are also known as ........... 

(A)    selective structure statements  (B)    branching statements 

(C)   decision making statements  (D)   all of these 

 (4) Statements which are controlling the flow of execution, they are also known as ........... 

(A) controversial statements   (B)   control statements   

(C) input statements    (D) output statements 

(5) C language provides .......... basic types of  decision structure statements. 

(A)  2            (B) 3             (C)   4             (D) 5 

(6)  ..........is the type of decision structure. 

        (A) if                            (B)   switch  (C) Both (A) and (B)     (D) while 

(7)  The.......... statement is one of the powerful decision making statement which can be used I to transfer 

control of instruction execution.  

(A) switch                          (B)   if  (C) while                  (D) untiI 

(8)     What can be the solution of if condition ? 

(A)   Yes                          (B)   No  (C)   (A) OR (B)              (D)  None of these 

(9)     How many ways can if statement be used ?  

(A)   2            (B) 3             (C)   4             (D) 5 

(10)     What is the way to use if statement ? 

(A)    Simple if statement     (B)    Nested if statement 

(C)   if...else  statement  and  else-if ladder statement (D)   All of these 

 (11)    ..........is the simplest way of decision structure. 

(A)    simple if statement   (B)    nested if statement  

(C)   if ... else statement   (D)   else-if ladder statement 

 (12) Which statement is used to change the flow of execution of program and take decisions ?    

(A)   if statement             (B)   switch statement  

(C)  while statement       (D)  until statement 

 (13)     If the condition is true in if ... else statement .......... part is   executed. 

(A)   if                            (B)   else  (C)   both (A) and (B)   (D)  none of these 

(14)     If the condition is false in if...else statement ..........part is executed. 

(A)   if                            (B)   else  (C)   both (A) and (B)   (D)  none of these 

(15)    .......... can be used to find out the biggest of given three values. 

(A)    nested if statement   (B)    else-if ladder statement 

(C)   simple if statement   (D)   switch statement 

 (16)    ..........structure is available to evaluate more than one condition. 

(A)   nested if                (B)   else-if ladder (C)  if                            (D)  if...else 

 (17)     In else-if ladder the test-expression is evaluate from ........... 

(A)   top to bottom      (B)   bottom to top  (C)  left to right           (D) right to left 

(18)     if test_expression is true in else-if ladder the ..........is executed. 

(A)   block above it          (B)   block below it 

(C)   block connected to it                 (D)   block of all the statements 

(19)     If test expression is false in else-if ladder then control is taken to ........... 
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(A)    default-statement-block of first else (B)    default-statement-block of last else 

(C)   statement-block of first else  (D)   statement-block last else 

 (20) Which is the statement for inbuilt multi layer decision statement ? 

(A)   switch                    (B)   if ... else  (C)  else-if                     (D) nested if 

 (21) If one option is to be selected from multiple choices,..........is useful. 

(A)   simple if statement   (B)   else-if ladder statement 

(C)   switch statement    (D)  if...else statement 

(22)     switch statement requires.......... arguments. 

(A)   zero                        (B)   one  (C)   more than one      (D)  many 

 (23)     Each constant or constant expression in case option of switch statement is known as........... 

(A)   case statement      (B)   case label (C)   case argument      (D)  case function 

(24)     Each case label ends with ........... 

(A)   :             (B) ;              (C)   .              (D) , 

(25)     All case labels should be .......... in switch statement. 

(A)   same                       (B)   unique  (C)   extra ordinary       (D)  special 

 (26)  .......... shows the end of case part in switch statement. 

(A)   Break     (B) Default   (C)   Stop       (D) End 

 (27) If the given value does not match with any expression in switch,.......... is executed. 

(A)   case                        (B)   break  (C)   default                    (D)  none of these 

(28) How many times default statement can be used in switch statement ? 

(A)   One                        (B)   Two  (C)   More than one     (D)  Limited times 

(29) Default statement can be given in which part of switch ? 

(A)    Upper part of the program   (B)    Middle part of the program 

(C)   Bottom part of the program  (D)   In any part of program Generally default (30) generally 

default statement is given in which part of switch ? 

(A)   Top                          (B)   Middle   (C)   Bottom                  (D) Any of these  

 (31)  ..........is the arithmetic operator. 

(A)   +, -                         (B)   *, /   (C)   Both (A) and (B)   (D)   &, % 

(32)   Use of compound relational test will help us to reduce number of.......... in our program, 

(A)   logical AND           (B)   logical OR  (C)   logical IF                (D)   (A) OR (B) 

(33)   logical AND operator is written as .......... 

(A)   &            (B) &&          (C)   |              (D) || 

(34)   logical OR operator is written as ........... 

(A)   &            (B) &&          (C)   |              (D) || 

 

                                   CH-14          LOOP CONTROL STRUCTURE 
(1) What is offered by programming language to execute a statement or group of statement multiple times ? 

(A)    Loop control structure   (B)    Case control structure 

(C)   Array control structure   (D)   Process control structure 

 (2)  Which of the given options show the looping part ? 

(A)   Body of loop         (B)   Control statement (C)   Both (A) and (B)  (D)  None of these 

(3)       The main part of looping is known as what? 

(A)   Control of loop        (B)   Body of loop 

(C)   Part of loop              (D)   Entry of loop 

 (4)     Depending on the place of control statement in loop, it can be classified as what ? 

(A)   Entry-controlled      (B)   Exit-controlled 

(C)   Process controlled   (D)   Both (A) and (B) 

 (5)     Which of the following options show the example of entry controlled loop ? 

(A)   For loop                (B)   While loop (C)   Do...while loop     (D)  Both (A) and (B) 

(6)     In which of the following loop it is possible that statements will not be executed even once before exiting 

from the loop ? 

(A)    Entry controlled loop   (B)    Exit controlled loop 

(C)   Both (A) and (B)     (D)  None of these 

 (7) Which of the following options show example of exit-controlled loop ?  

(A)   For loop                (B)   While loop (C)   Do...while loop     (D)  Both (A) and (B)  

(8)  In which of the following loop it is possible that statements will be executed at least once before exiting 

from the loop ? 

(A)    Entry-controlled loop   (B)    Exit-controlled loop  

(C)  Both (A) and (B)     (D)  None of these  

(9) In case of exit controlled loop, the statements can be executed at least minimum how many  times ?   

(A)   One                         (B)   More than one (C)   Cannot be said      (D)  Zero 



STD-10  SHARDAYATAN-EM PAGE - 51 

 

(10)  C language provides how many basic loop  control structure ? 

  (A)   3          (B) 4             (C)   5             (D) 6 

(11) Which of the following options show the type of loop control structure ? 

(A)  For loop                  (B)   While loop (C)  Do...while loop       (D) All of these  

(12) Which of the following statement is used for  looping ? 

(A)  if            (B) from      (C)   for           (D) where 

 (13) Which loop  is used to  execute block of statements for fixed number of times ?  

(A) for loop                 (B)   While loop  (C)  do...while loop        (D) All of these  

 (14) For loop is an example of what ? 

(A)    Exit-controlled loop   (B)    Entry-controlled loop 

(C)   Processing controlled loop  (D)   Process controlled loop 

(15)     For loop is made up of how many divisions ?  

(A)   2             (B) 3             (C)   4              (D) 5 

 (16)     A counter variable that is used to control the number of times a loop is to be executed is known by 

which name ? 

(A)   Process variable   (B)   Counter variable  (C)   Input variable        (D)  Output variable 

 (17)     Which expression of For loop works as a test condition ? 

(A)   Statement-block   (B)   Expression-1  (C)   Expression2            (D)  Expression-3 

(18)     Which expression of For loop is tested every time ? 

(A)   Expression-1          (B)   Expression-2 (C)   Expression-3           (D)  Statement-block 

 (19)     What is used for checking loop terminating criteria ? 

(A) Counter variable    (B)   Process variable  (C) Input variable          (D)  Output variable 

 (20)     Which expression is used for incrementing or decrementing value of control variable ?  

(A)   Statement-block  (B)   Expression-1 (C)   Expression-2           (D)  Expression-3 

(21)     Which of the following command can be given in expression-3 part of For loop ?  

(A)   i = i + 1;                (B)   i = 0;  (C)   Both (A) and (B)   (D)  None of these 

 (22) Which statement is used to display "*" on  screen ? 

(A)  printf()                   (B)   scanf()  (C) int main()                (D)  anyone 

(23) Which of the following option can be executed  by incrementing value of count by 1 ? 

  (A) ++count                 (B)   +count  (C)  count++                 (D)   count+ 

(24) What is known as using one for loop within another for loop ?  

(A) Next for loop            (B)   Nested for loop  

(C) Inner for loop          (D)  Outer for loop 

(25) In  nested For loop, how many For loop can be used within another For loop ? 

(A)One      (B) Two        (C)   Three     (D) Many  

(26) In nested For loop, first of all what is executed ?  

(A) First loop               (B)   Last loop  (C)  Inner loop              (D)   Outer loop 

(27)     Which of the following statement is used for looping ? 

(A)   why       (B) when      (C)   while      (D) where 

(28)     Which loop is used, when number of iteration cannot be pre-determined and when loop terminating 

condition is to be tested before entering the loop ? 

(A)   For                          (B)   While  (C)   Do ... while          (D) Anyone of them 

 (29)     Under which of the following condition, while loop is to be used ? 

(A)   When the number of iteration cannot be pre-determined. 

(B)   When loop terminating condition is to be tested before entering the loop. 

(C)   Both (A) and (B) 

(D)  None of these 

 (30)     While loop is an example of which loop ? 

(A)    Entry-controlled loop   (B)    Exit-controlled loop 

(C)   Process-controlled loop   (D)   Constant-controlled loop 

(31) _________ known as entry controlled loop ? 

(A)   As we check the condition after exit.  (B)   As we check the condition after entry. 

(C)   As we check the condition at the exit point (D)   As we check the condition at the entry point 

 (32) What does program control evaluates first in while loop ? 

(A)   Test expression    (B)   Statement-block (C)   Both (A) and (B)  (D)  None of these 

 (33) In while loop, what is evaluated first of all ?  

(A)  Statement-block      (B)  Test expression 

(C)  (A) or (B) both        (D) None of these  

(34)  What happen if in while loop test expression  is evaluated to true ? 

(A)  Loop containing statement-block is executed   

(B)  Loop containing statement-block is not executed 
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(C)   Loop is terminated 

(D)  Loop is repeated 

 (35)     From the following, which statement is used for looping ? 

(A)   do ... while          (B)   for ... while (C)   when ... while      (D) if ... while 

(36)    Which loop is used, when the test expression is to be checked after executing body of loop ?        

(A) for loop                 (B)   while loop  (C)  do....while loop      (D) anyone 

(37)    Do....while loop is which kind of loop ? 

(A)   Entry-controlled loop   (B)   Exit-controlled loop 

(C)   Entrance-controlled loop   (D)   Both (A) and (B) 

(38)     For which of the reasons do....while loop is known as exit-controlled loop ? 

(A)   As condition is checked at the end of loop. 

(B)   As condition is checked in starting of loop. 

(C)   As condition is checked in middle of loop. 

(D)   As condition is checked everytime. 

(39)     In do....while loop, what is checked after execution of statements ? 

(A)   Statement-block      (B)   Test expression 

(C)   Both (A) and (B)     (D) None of these 

 (40)    In do....while loop, how many times the execution of statement is done ? 

(A)   At least once    (B)   Sometime not even once 

(C)   Can not be said        (D)  None of these 

 (41)     In do....while loop , what is executed first ?  

(A)   Statement-block       (B)   Test expression  

(C)   (A) and (B) both      (D)  None of these 

(42)     In do...while loop, what is done after the execution of statement-block ? 

(A)   Repetition of loop    (B)   Termination of loop  

(C)   Test expression        (D)   Both (A) and (B) 

 (43)   For every do clause, there must be what ?  

(A)   while     (B) does  (C)   if            (D) none of them are compulsory 

(44)   When there is a loop within another loop, it is known as what ? 

(A)   nested loop           (B)   next loop  (C)   nest loop               (D)  null loop 

 (45)   To select the appropriate loop, which thing should be seen first ? 

(A)    Whether  its  entry-controlled  or  exit-controlled loop 

(B)    Its repeating how many statements 

(C)    Loop is infinite or not? 

(D)   All of these 

(46)   What can be used for entry-controlled loop ?  

(A)   for loop                 (B)   while loop  (C)   Both (A) and (B)  (D)  do....while loop 

(47)   What can be used for exit-controlled loop ?  

(A)   for loop                 (B)   while loop  (C)   Both (A) and (B)  (D)   do....while loop 

 (48)   By using what in C language, we may skip any part of loop ? 

(A)   break statement      (B)   continue statement  

(C)   end statement         (D)  Both (A) and (b) 

 (49)   What is done, when break statement comes in loop ? 

(A)   To terminate loop instantly  

(B)   Through program control executes the next statement following the loop 

(C)   Repetition of loop 

(D)   Both (A) and (B) 

(50)   Which statement is used to come out from the loop control structure ? 

(A)   continue                (B)   break  (C)   Both (A) and (B)   (D)  end 

(51)   Which statement is used to terminate a case in the switch statement ? 

(A)   break statement      (B)   continue statement  

(C)   end statement         (D)  anyone of these 

 (52)   From the following under which statement program control executes the next statement following the 

loop ?  

(A)   break     (B) end        (C)   stop        (D) next 

 (53)   From the following, which statement instead of forcing termination of loop, however, continue 

statement forces the next iteration of the loop to take place, skipping any code in   between ?  

(A)   continue                (B)   break  (C)   Both (A) and (B) (D)  None of these 

 (54)   What is the role of continue statement ? 

(A)    To terminate the execution of another statement 

(B)    To starts the execution of next iteration 
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(C)   Both (A) and (B) 

(D)   None of these 

 (55) in continue statement during loop, what is done if there is a execution of any condition?  

(A)  It leaves the other part of loop   (B)  The program control is repeated again 

(C)   Both (A) and (B)      (D) None of these 

(56) which of the following option show the  syntax of continue statement?  

(A)  Continue;               (B)   continue:  (C) continue,                (D) continue. 

(57) If any loop runs forever and program control never comes out of it, then it is known as what ? 

(A)   Regular loop         (B)   Last loop  (C)   Control loop         (D)  Infinite loop 

(58)   Which of the following option is correct for infinite loop ? 

(A)    Infinite loop runs forever  (B)    Program control never comes out of it 

(C)   Both (A) and (b)     (D)  None of these 

(59)   when does loop become infinite? 

(A)    due to availability of exit condition in the logic of loop 

(B)    Due to   non-availability of exit condition in the logic of loop 

(C)   due to availability of entry condition in the logic of loop 

(D)   due to non-availability of entry condition in the logic of loop 

(60)   Which shortcut key is used to terminate infinite loop ? 

(A)   Ctrl + A                  (B)   Ctrl + B  (C)  Ctrl + C                 (D) Ctrl + D 

 

CH-15           Arrays 
(1) What is the collection of elements having same data type known as ? 

(A)   Function                (B)   Array  (C)   Loop                       (D)   Source 

(2) How many names can be given to an array ? 

(A)   One                        (B)   Two  (C)   Three                      (D) Multiple 

(3) C supports which data types ? 

(A)   int                          (B)   float  (C)   char                        (D)  All of these 

(4) To process one value, how many variables are required in C ? 

(A)   One       (B) Two        (C)   Three      (D) Four 

(5) Where is the value of an array stored ? 

(A)  Function                (B)   Memory  (C)  Input                       (D)  Output 

(6) Which data type is used to store and process various types of data ? 

(A)  Integer                   (B)   Float  (C) Array                       (D)  Void 

(7) What is the array name in int marks [i] ? 

(A)  int                          (B)   marks  (C) i                              (D) All of these 

(8) How will we declare an array to store marks of 60 students of one subject ? 

(A)  marks{59};              (B)   marks[60]; (C) marks (61);              (D)  marks<60>; 

(9) To refer individual students mark, which variable can be used in an array of marks [60] 

of a school ? 

(A)   marks(1), marks(2), marks(3), ....marks(60) 

(B)   marks[1], marks[2], marks[3], ...,marks[60] 

(C)   marks(O), marks(l), marks(2), ...,marks(59) 

(D)   marks[0], marks[l], marks[2], ...,marks[59] 

(10)     Array is a collection of elements having how many data types ? 

(A)   One                        (B)   Two  (C)   Multiple                 (D)  Limited 

(11)     What is the collection of elements having same data types known as ? 

(A)   Function                (B)   Loop  (C)   Array                      (D)  Program 

(12)     Which type of collection is an array ?  

(A)   Sequential             (B)   Non-sequential  (C)   Random                 (D) Any of these 

(13)     What type of memory location does array occupied ? 

(A)   Continuous           (B)   Even  (C)   (A) or (B)               (D)  Can't say 

(14)     How is an element in an array accessed ?  

(A)   By name                (B)   By alphabet (C)   By symbol             (D)  By index number 

(15)     What is the index number contain within square bracket known as ? 

(A)   Superscript            (B)   Subscript  (C)   Sourcescript          (D)  Section script 

(16)     What is the other name of subscript ?  

(A)   Master number    (B)  Viewer number  (C)   Index number      (D)  Serial number 

(17)     What is used in subscript of an array ? 

(A)   An integer or an integer expression (B)    Real integer or an integer expression 

(C)   Real expression or an integer  (D)   Real integer or real expression 

(18)     With what number subscript starts ? 



STD-10  SHARDAYATAN-EM PAGE - 54 

 

(A)   Zero      (B) One        (C)   Two        (D) Three 

(19)     What is the first elements of an array ?  

(A)   Negative                 (B)   Zero  (C)   Positive                  (D) Any one of these 

(20)     How many types of arrays are there ? 

(A)   Two        (B) Three     (C)   Four       (D) Five 

(21)     Which of these are types of array ? 

(A)    One dimensional array   (B)    Multidimensional array 

(C)   Both (A) and (B)    (D)   Multiangled array 

(22)     Which of the following is made of one row and one column ? 

(A)    Single dimensional array  (B)    Double dimensional array 

(C)   Three dimensional array   (D)   Multidimensional array 

(23)     What is required as per the program requirement of an array ? 

(A)   Rows                      (B)   Columns  (C)   Both (A) and (B)   (D) Table 

(24)     Multidimensional array is made up of ?  

(A)   One or more rows   (B)   One or more columns 

(C)   One row or one column   (D)   (A) or (B) 

(25)     Which type of array is used for a collection at elements having same datatype ? 

(A)    Single dimensional array  (B)    Multidimensional array 

(C)   Both (A) and (B)    (D)   None of these 

(26)     How many values  can be  stored in one dimensional array ? 

(A)   Zero                       (B)   Only one  (C)   Multiple                 (D) All 

(27)     Array is collection of which type of elements ?  

(A)   Sequential             (B)   Random  (C)   Fixed                      (D)  Not fixed 

(28)     Which things are specified to declare one dimensional array ? 

(A)   Datatype                (B)  Array name (C)   Size                        (D) All of these 

(29)     Which  option   is   true   to   declare   single dimensional array ? 

(A)    datatype arrayname [size];  (B)    arrayname datatype [size]; 

(C)    datatype [size] arrayname;  (D)   arrayname [size] datatype; 

(30)     What is used to specify the types of element that an array stores ? 

(A)   datatype                 (B)   arrayname (C)   size                         (D) Any one 

(31)     Where is the number of elements the array can store specified ?  

(A)   datatype                 (B)   arrayname  (C)   size                         (D)  any one 

(32)     Which datatype is used to store integer vaild in array ?  

(A)   float      (B) int          (C)   char       (D) string 

(33)     Which datatype is used to store real value array?  

(A)   float       (B) int          (C)   char        (D) string 

(34)     Which datatype is used to store very large values in an array ?  

(A)   float      (B) int          (C)   char       (D) double 

(35)     Which datatype is used to store characters: an array ?  

(A)   float      (B) int          (C)   char       (D) string 

(36)   Arrayname should be given in the context of 

(A)    what is the name of that array in that context 

(B)   what is stored in that array in a program 

(C)   what is the process of that array 

(D)   what is the result of that array 

(37)   What indicates the number of elements, the array can store ? 

(A)   datatype                  (B)   arrayname (C)   size                           (D) Any one of these 

(38) To store marks of 60 students which array should be declared ? 

(A)   int marks (60);         (B)   int marks {60};  

(C)  int marks <60>;        (D)  int marks [60]; 

(39) Which array is declared to store characters ? 

(A)   char string (20);      (B)   char string [20]; 

(C)  char string <20>;     (D)  char string {20}; 

(40) To   which    array   is    declared    to    store percentage of students ? 

(A)    float percentages (20)   (B)   float percentages {20} 

(C)   float percentages [20];   (D)   float percentages <20>;  

(41) Which array is declared to store large values ? 

(A)    double numbers [20];   (B)    double numbers <20>; 

(C)   double numbers {20};   (D)   double numbers (20]; )  

(42) In C, by how many types can we initialize the value ? 

(A) Two       (B) Three     (C)  Four       (D) Five  
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(43) Which array assign  values  similar  to  a normal variable at the time of declaration ? 

(A)   Compile time array initialization  (B)   Runtime array initialization 

(C)   Both (A) and (B)     (D) None of these  

(44)     In which type of array it initialize all array elements with list of values given in curly bracket ? 

(A)    Compile time initialization  (B)    Runtime initialization 

(C)    Both (A) and (B)    (D)   None of these 

(45)      Which of the following is the general syntax to set the values of various array elements ? 

(A)    datatype   arrayname [size]   =   (value 1, value2, value3, .........., valueN); 

(B)    datatype   arrayname [size]   =   {value 1, value2, value3, .........., valueN}; 

(C)   datatype   arrayname [size]   =   [value 1 value2, value3, .........., valueN]; 

(D)   datatype   arrayname [size]   =   <valuel, value2, value3, .........., valueN>; 

(46)      During compilation who provide the initial values for successive elements of the array ?  

(A)   datatype                     (B)   arrayname  

(C)    size     (D)   valuel, value2, value3, .........., valueN 

(47)     Which symbol is used to separate two successive elements of the array ? 

(A)   ( )          (B) [ ]           (C)   { }           (D) < > 

(48)     Which symbol is used to separate two successive elements of the array ? 

(A)   ,             (B) .              (C)   ;              (D) : 

(49)     'Specifying size of an array is optional -Select the correct option. 

(A)    The statement is true   (B)    The statement is false 

(C)    Can't be said           (D)  None of these 

(50)      What happens if array size is not specified ? 

(A)    Error message displayed   (B)    Will stop compilation 

(C)   Will automatically calculate the size (D)   Will ask to specify size 

(51)      Which of the following is a correct option ? 

(A)    int marks[5] = {78, 42, 68, 57, 83}; (B)    int marks [5] = {78, 42, 68}; 

(C)    int marks[ ] = {78, 42, 68, 57, 83}; (D)   All of these 

(52)      In array int marks[5] = {78, 42, 68, 57, 83}; how many elements are there ? 

(A)   Four      (B) Five        (C)   Six          (D) Seven 

 

CH-16       Function 
(1)      .......... shows one of the capabilities of C language. 

(A)    Making functions   (B)    Using functions 

(C)   Both (A) and (B)    (D)   None of these 

(2)       The group of instructions solving the big problem by dividing it into small parts is known as ........... 

(A)   flowchart               (B)   algorithm  (C)   function                 (D)  loop 

(3)       Function is also known as ........... 

(A)   method                  (B)   sub routine (C)   procedure              (D)  All 

(4)      ..........shows the function of C language. 

(A)   main()                    (B)   printf()  (C)   scanf()                    (D) All  

(5)       ..........function must be there in any executable C program. 

(A)   main()                    (B)   printf()  (C)   scanf()                    (D) All  

(6)       How many main() functions should be there in a C program ? 

(A)   Zero      (B) One        (C)   Two        (D) Many 

(7)     Use of functions makes a program........... 

(A)   Modular                 (B)   Compress (C)   Powerful                (D)  Executable 

(8)   Modularity means partitioning a complex problem into small sub-problems which are 

(A)    easy to understand but difficult to maintain 

(B)    easy to understand and maintain. 

(C)    difficult to understand but easy to maintain 

(D)   difficult to understand but difficult to maintain. 

(9) How many types of functions are there in C ? 

(A)   Two        (B) Three     (C)   Four       (D) Five 

(10)  ........... shows the type of the function in C language. 

(A)    Library function/System defined function (B)    User defined function 

(C)   Both (A) and (B)      (D)  None of these  

(11) How are the functions available in the library files ? 

(A)   Compiled                  (B)   Non compiled 

(C)    Not compilable    (D)   Compiled as par wish 

(12)     ..........is the library or system defined function. 

(A)   scanf(), printf()        (B)   sqrt(), pow()  
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(C)   cos(), sin()                 (D) All  

(13)    ..........is true for the functions of C library. 

(A)   They are already compiled  (B)   We can directly use them 

          (C)   User needs not to write such function    (D) All  

(14)    ..........file is included while using the library functions. 

(A)   Header                 (B)   Center  (C)   Footer                  (D) All of these  

(15)   C includes a group of .......... functions to be execute different processes. 

(A)   Pre defined functions   (B)   Inbuilt functions 

(C)   Both (A) and (B)    (D)   None of these 

(16) The collection of header files is known as 

(A)   header library          (B)   C library    

(C)  function library        (D) file library 

(17) ......... file contains the standard input/output functions. 

(A)   <stdio.h>              (B)   <math.h>  (C)   <stdlib.h>             (D)  <ctype.h> 

(18)   .......... file contains functions related to character checking. 

(A)   <stdio.h>              (B)   <math.h>  (C)  <stdlib.h>             (D)  <ctype.h> 

(19)  .......... file holds the mathematical functions. 

(A)   <stdio.h>              (B)   <math.h>  (C)  <stdlib.h>             (D)  <ctype.h> 

(20)  .......... file holds the functions for string comparison, string length etc.    

(A)   <stdio.h>              (B)   <string.h>  (C)  <stdlib.h>             (D)  <ctype.h> 

(21)     For .........., <stdio.h> file is useful. 

(A)   conversion of strings   (B)   allocation   of memory 

(C)   generating random numbers  (D)   All  

(22)     <stdio.h> contains .......... types of functions. 

(A)   mathematical functions   (B)   functions for character checking and conversion 

(C)   functions for standard inputs/outputs (D)   functions for group of characters or string 

(23)    .......... is the function available in <math.h> header file. 

(A)    getc(), getchar(), gets(),  printf(), putc(), putchar(), puts(), scanf() 

(B)    cos(),  sin(),  tan(),  exp(),  floor(),  log(), pow(), sqrt() 

(C)   isdigit(),  islower(),  isupper(),  isprint(), isspace(), tolower(), toupper() 

(D)   abs(), exit(), free(), rand() 

(24)    .......... is the function available in <stdio.h> header file. 

(A)   sqrt()                      (B)   pow()  (C)   cos()                       (D) All  

(25)    .......... function is used to find out exponent values. 

(A)   pow()                      (B)   sqr()  (C)   power()                  (D)   sqrt() 

(26)     printf()  function is a part of .......... header file. 

(A)   <math.h>               (B)   <string.h> (C)   <stdio.h>                (D)  <print.h> 

(27)     pow() function is a part of..........header file. 

(A)   <math.h>               (B)   <string.h> (C)   <stdio.h>                (D)  <print.h> 

(28)     The function made by user is known as........... 

(A)    functions created by the user  (B)    user defined function 

(C)   library function    (D)   both (A) or (B) 

(29)     The user made the function for his own convenience is known as ........... 

(A)    user defined function   (B)   library function 

(C)   inbuilt function    (D)   inside function 

(30)     main() is a.......... type of function. 

(A)   library function       (B)   inbuilt function 

(C)   user defined function   (D)   important function 

(31)     C program starts with ..........function. 

(A)   printfO                   (B)   main()  (C)   void()                     (D)  scanf() 

(32)     Function once defined which can be used multiple times in a program it is for........... 

(A)   to make the program shorter  (B)   it saves the memory 

(C)   both (A) and (B)    (D)   program becomes complex 

(33)     Who is to be informed when user defined function is used ? 

(A)   Programmer          (B)   Administrator (C)   Compiler               (D) All of these 

(34)    .......... defines the type of data in the syntax of defining function. 

(A)   function_name        (B)   return_data_type  

(C)   list of arguments     (D) Any of these 

(35)     .......... defines the user defined function in the syntax of defining function. 

(A)   function_name        (B)   return_data_type 

(C)   list of arguments     (D) Any of these 
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(36)    ..........defines the input values with data type in the syntax of defining function. 

(A)   function_name        (B)   return_data_type  

(C)   list of arguments     (D) Any of these 

(37)     If the return value is integer for return_data_type, then what is taken as return_data_type ? 

(A)   float      (B) int          (C)   void        (D) string 

(38)     If the return value is not there for return_data_type, then what is taken as return_data_type ? 

(A)   float      (B) int          (C)   void        (D) string  

(39)    How should be the name of a function ?  

(A)   Meaningful               (B)   Meaningless  

(C)   Extra meaningful     (D) Multipurposeful 

(40)     More than one arguments are separated using........... 

(A)   dot (.)                    (B)   comma (,)  (C)   colon (:)                 (D)  semicolon (;) 

(41)     The statements written between two { } are known as ........... 

(A)   function body      (B)   loop body  (C)   library body          (D)  prototype body 

(42)    ..........type of function need not to be defined ? 

(A)    User defined function   (B)    Library function 

(C)   Both (A) and (B)      (D)  None of these 

(43)    .......... type of functions are already defined previously. 

(A)    Library function    (B)    User defined function 

(C)   Both (A) and (B)     (D)  None of these 

 (44)     To define the user defined before the main() function is known as ........... 

(A)   process of data        (B)   data type  

(C)   function prototype   (D)   none of these 

(45)     Each C program starts with ..........function. 

(A)   main()                    (B)   void()  (C)   printf()                   (D)  scanf() 

(46)    ..........  function can be called in main() function. 

(A)    User defined function   (B)    Library function 

(C)   Both (A) and (B)     (D)  None of these 

(47)     Which important information is to be given while calling the function ? 

(A)   Prototype               (B)   Parameter (C)   Variable                 (D) All of these 

(48)    ..........function prints the messages. 

(A)   printf                     (B)   Printf  (C)   print                      (D)  Print 

(49)     When main() function is not returned any value then return type is ........... 

(A)   int         (B) float       (C)   string     (D) void 

(50)     Which statement returns only the control to its calling function ? 

(A)   void                        (B)   main  (C)   return                    (D)  int 

(51)     If return type of function is .........., then return statement is not needed. 

(A)   void                        (B)   main  (C)   return                    (D)  int 

(52)     The   variable   defined  before   the   main() function is known as ........... 

(A)   global variable         (B)   local variable 

(C)   both (A) and (B)     (D)  none of these 

(53)    .......... variable can be used in either main()  function or user defined function. 

(A)   Global variable        (B)   Local variable  

(C)   Both (A) and (B)       (D)  None of these 

(54)   The   function   which   is   calling   another function is known as ........... 

(A)   caller function         (B)   called function  

(C)   function call             (D)  user function  

(55)   The function which is being called by the other function is known as ........... 

(A)   caller function      (B)   called function (C)   function call         (D) user function 

(56)   In the beginning of the program, user gives the information about the function is........... 

(A)   figure of the function   (B)   nature of the function 

(C)   activity of the function   (D)   prototype of function 

(57)   Calling function and called function should be compatible in ........... 

(A)    number of arguments   (B)    type of arguments 

(C)   both (A) and(B)    (D)   none of these 

(58) Function prototype is given in which part of the program ? 

(A)   Beginning              (B)   In the center (C)  At the end             (D) Any of these 

(59) When the calling function sends the data to the called function, it is known as ........... 

(A)   arguments             (B)   parameter passing (C)   (A) or (B)               (D)  none of these 

(60)   When the parameter is transferred ? 

(A)   When calling function receives the data from the called function. 
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(B)   When calling function sends the data to the called function. 

(C)   When  calling function and the called function send the data. 

(D)   When   calling  function   or   the   called function send the data. 

(61)   While defining a function, what kind of parameter can be there ? 

(A)    Formal Arguments   (B)   Actual Arguments  

(C)    (A) or (B)     (D)   None of these 

(62)   When the function is called, same number of parameters are transferred, they are known as  

(A)    formal arguments   (B)    actual arguments 

(C)    (A) or (B)     (D)   none of these 

(63)  Which is the type of user defined function ? 

(A)   Function with no arguments  and no return values 

(B)   Function with arguments and no return values 

(C)   Function with arguments and return values 

(D)   All of these 

(64) When the calling function provides the data to the called functions, such argument are 

known as ..........arguments. 

(A)   actual argument      (B)   formal argument  

(C)  both (A) and (B)       (D) none of these 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 


