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IntroductionIntroduction

There are number of templates available on the Internet for creating business cards. For my purposes, I have 

a difficult time finding a template that provides the flexibility I would like. After fooling around with a 

number of different business card creating options, I finally discovered how to create my own custom tem-

plates using the free LibreOffice software.

The technique presented here involves basing the business card on a LibreOffice, Label format. The tech-

nique also uses the LibreOffice, Frame function to control the placement of text, and objects within the 

card boundaries. If you are not already familiar with the concept of frames and paragraph styles in 

LibreOffice, by the time you complete this tutorial you will have added these powerful tools to your reper-

toire.

NOTE: I have evolved a standard format for creating my series of tutorials. You will find general 

information in normal paragraphs, notes or important points in pale yellow shaded paragraphs, and steps to 

be completed in green shaded paragraphs.

Creating a Label BaseCreating a Label Base

✔ Open LibreOffice.

✔ From the Menu Bar, select File, New, Labels.

The Labels dialog box should now be on your display. There 

are three tabs on the top of the dialog box. When the Labels 

tab is selected, there are drop down selection boxes for 

Brand and Type. You can select from a listing of standard la-

bel formats. You can also use the Labels dialog box to create 

your own custom labels. Once you have formatted and saved 

your custom label design, it will appear in the list of available 

brands.
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✔ In the Labels dialog box, select the Options tab.

Before defining the size settings for the business 

cards, a couple of options will be set.

✔ In the Options section of the Labels dialog 

box, toggle the Entire page and 

Synchronize contents options ON.

✔ In the Options section of the Labels dialog 

box, select the printer Setup button. Then 

select the desired printer and select 

Properties to set the paper source and 

stock weight for your printer.

Many printers have settings for a bypass tray and 

heavy card stock. I have gotten better results from my 

printer by manually feeding thick paper such as 

business card stock rather than using an internal paper tray.

In this project, standard 8 ½ x 11 inch busi-

ness card stock will be used. Business card 

stock with laser cut perforations is available 

from a number of different manufactures. 

There are ten 3.5 by 2 inch business cards on 

these pages. 

Users outside of the USA can adjust the 

dimensions to local standards.

✔ In the Labels dialog box, select the 

Format tab.

✔ In the Format section of the Labels 
dialog box, adjust the settings as 

shown in the illustration.

✔ When the settings have been adjusted, 

select the Save button.

✔ Enter a name for your custom brand 

and card type.

Once you have saved your label definitions, your custom label will be available in the Brand list the next 

time you select File, New, Label.

✔ After you have saved the label settings, select the Labels tab of the Labels dialog box. Then 

select the New Document button in the Labels dialog box.

This will open a new Untitled document in LibreOffice Writer. It is a good habit to immediately save new 

documents with a file name and known file location.
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✔ From the Menu Bar, select File, Save As and enter a Save In folder and File Name for your 

new document.

Your new document should look similar to the illustration.

Note the floating Synchronize Labels win-

dow. This is used to fill all ten spaces on the 

page with the same contents. More about that 

later. Next, we will work on the basic card for-

mat. To aid in controlling the various areas of 

the card, several Frames will be created. 

Also, new Paragraph Styles will be added 

for the different types of text used on the card.

Each of the ten divisions on the page has an 

initial paragraph in place. To see exactly what 

is going on with the page formatting, the Non 
printing Character option will be turned 

ON.

✔ If the non printing characters are not 

already displayed, from the Menu 

Bar, select View, Non printing 
Characters.

✔ To focus on the card area in the upper left of the page, use 

the display zoom control in the lower right corner of the 

display to adjust the view factor (or select View, Zoom 
and enter a new percentage.

The first line of each card area will have a paragraph, even if there 

are no words in the paragraph. (A non printing paragraph symbol appears for each time 

the Enter key is pressed.) The first paragraph will make a space at the top of the card 

equal to the size of the paragraph style font. The cards in this design will have all ob-

jects and text entries living inside of frames. To minimize the space between the edge 

of the card and the first frame, a new paragraph style will be created that is only 2 type 

points tall.

✔ If the Styles and Formatting list is not on the display, press F11.

✔ Select the small arrow near the bottom of the styles list and then select 

Custom Styles.

✔ Right click in an empty area of the Styles and Formatting list and then 

select New.
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This opens the Paragraph Style dialog box. The next step 

is to create a name for the new style, and also the name of the 

following style.

✔ In the Paragraph Style, Organizer dialog box, the 

Name a tiny paragraph.

✔ In the Paragraph Style, Organizer dialog box, set 

the Next Style to a tiny paragraph.

✔ In the Paragraph Style, Organizer dialog box, set 

Linked with to None.

✔ Select the Paragraph Style, Font tab. 

✔ In the Paragraph Style, Font dialog box, set the 

Size to 2pt (you will have to enter the value since 

this is smaller than the standard sizes in the size 

list).

✔ Select OK to close the Paragraph Style, dialog box.

Next, the paragraph style for the first paragraph in the card 

will be set to a tiny paragraph style.

✔ Click in the first paragraph in the upper left corner 

of the card. Then double click on the a tiny 

paragraph style in the Styles and Formatting list.

✔ Select the Synchronize Labels button and observe that the paragraph size changes for the first 

paragraph in all ten cards.

Next, a Frame will be added to the card.

✔ Position the cursor in the first paragraph in the upper 

left corner of the card, then from the Menu Bar, 

select Insert, Frame.

✔ With the Type tab selected in the Frame dialog box, 

set the Width to 1.75 and the Height to 1.9.

✔ With the Type tab selected in the Frame dialog box, 

set the Position Horizontal to Left.

✔ With the Background tab selected in the Frame 
dialog box, set the Color to Blue Grey.

✔ Select OK to close the dialog box.
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In this exercise, the initial background of the frames will be set to different colors to make it easier to keep 

track of where the frames are. The background colors can be turned off for the final version of the card.

Check the size and location of the first frame. Note that the frame 

contains an initial paragraph. The default paragraph style for this is 

Frame contents, but this can be changed to a custom paragraph 

style.

NOTE: To edit the settings for a frame after it has been inserted, 

double click on the border of the frame to open the Frame dialog box.

As mentioned earlier, frames can contain graphic images or text. For 

this example, a graphic will be inserted using one of the LibreOffice 

drawing tools.

✔ From the Menu Bar, select View, 
Toolbars, Drawing.

✔ From the Drawing Toolbar, select the 

Symbol Shapes tool and then click 

on the Smiley Face option.

✔ Click and drag a smiley face into the 

frame.

To change the color of the smiley face object, 

select a new color from the object formatting 

toolbar.

Now for some fun.

✔ Select the Synchronize Labels 
button.

OK! enough fun. Next, we will add another 

frame on the right side of the card.

✔ Click outside the frame in the upper 

left card. (The a tiny paragraph style should be shown in the format toolbar.)

✔ From the Menu Bar, select Insert, Frame.

✔ With the Type tab selected in the Frame dialog box, 

set the Width to 1.5 and the Height to 1.9.

✔ With the Type tab selected in the Frame dialog box, 

set the Position Horizontal to Right.

✔ With the Background tab selected in the Frame 
dialog box, set the Color to Pale Yellow.

✔ Select OK to close the dialog box.

Next, some text will be added to the new frame, and custom 

paragraph styles will be created for the text.
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✔ Click the cursor in the second frame paragraph. (You may have to first click in an empty area to 

deselect the frame.)

✔ Enter new paragraphs as follows, pressing the Enter key at the end of each paragraph. (Don't 

worry if the text makes the frame too tall for the card. That will be fixed later by defining new 

paragraph styles.)

This is my company name

My company slogan

My name

My street

My address

My phone number

My email 

My email at

The default paragraph style will probably stretch the frame beyond the borders of the first card. This will be 

fixed by creating custom paragraph styles.

✔ Right click in an empty area of the Styles and Formatting list and then select New. 

✔ In the Paragraph Style, Organizer dialog box, enter the Name an email paragraph.

✔ In the Paragraph Style, Organizer dialog box, set the Next Style to an email paragraph.

✔ In the Paragraph Style, Organizer dialog box, set Linked with to None.

✔ Select the Paragraph Style, Alignment tab and set the Options to Center. 

✔ Select the Paragraph Style, Font tab. 

✔ In the Paragraph Style, Font dialog box, set the Font to Ariel, Bold, 10pt.

✔ In the Paragraph Style, Font Effects dialog box, set the Font color to Light Blue.

✔ Select OK to close the Paragraph Style, dialog box.

✔ Place the cursor somewhere in the My email paragraph and then double click on the an email 

paragraph style.

✔ Place the cursor somewhere in the My email at paragraph and then double click on the an email 

paragraph style.

Now that you know how to create a new paragraph style for the email address, you should be able to do this 

for each of the paragraphs on your card. Experiment with font styles and sizes as well as spacing above and 

below paragraphs (observe the tabs in the Paragraph Style dialog box) until things fit nicely on your card.

✔ Repeat the above process and create new paragraph styles for each of the different paragraphs 

on your card.
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After a new paragraph style has been created, you can right click on it in the paragraph styles list, select 

Modify, and make changes to the style. This will immediately change all paragraphs in the document that 

use this style. One of the tabs in the Paragraph Style dialog box is Indents & Spacing. Use this to 

adjust the space above or below each paragraph. The space on a 2 inch tall card is very limited, so you will 

have to be careful about fitting the desired text on the card without making the font too small for people to 

read.

✔ Adjust your paragraph styles until you are satisfied with the text on the card.

✔ Double click on the frame borders and 

remove or modify the Background 
or Border for the frames.

✔ Select the Synchronize Labels 
button to extend your card design to 

all cards on the page.

✔ Save the document.

Now that you have a basic card document, you 

can simply change the document file name, 

edit the card, and create a new card from an 

existing design. However, there are some 

tricks that came make creating new cards eas-

ier.

Custom Card TemplatesCustom Card Templates

In my situation here at Bristol Village 

<www.bvres.org>, there was a need to create 

custom cards, all with the same basic design, 

but each customized for the different members 

of the community. 

To make creating each new card even easier, I 

created a special Template file. But, I added a 

new twist to the design before saving the tem-

plate. I created custom fields for each text en-

try, and inserted the Fields in the master card. 

Here is how it works.

✔ From the Menubar, select File, 
Properties, then select the Custom 
Properties tab. 

✔ Select the Add button and add an 

entry Name and Value for each text 

area on your card. Then select the 

OK button to close the Properties 
dialog box.

Page 7   



      Creating Custom Business CardsCreating Custom Business Cards

✔ Select the company name text in the upper left card. (It should be all highlighted at this point.)

✔ From the Menubar, select Insert, Fields, 
Other. 

✔ In the Fields dialog box, select the 

DocInformation tab, then expand the 

Custom option and select company name.

✔ Select the Insert and Close buttons.

Your company name properties text will now appear 

as a shaded text area. The shading shows that it is 

contents from a Field and cannot be edited as normal 

text.

✔ Repeat the above process for the other text in your 

card.

✔ Select the Synchronize Labels button to extend 

your card design to all cards on the page.

Now that you have replaced the text on the card with the con-

tents of Fields, you can now generate new cards by simply 

modifying the Properties of each new card document.

Next, a Template will be created from the current document.

✔ With your saved card document on the display, 

select from the Menubar File, Templates, Save.

✔ In the Templates dialog box, select the My Templates category. Then enter My Business 
Card as the New template name.

Now that the template is in place, it is time to give it a try.

✔ From the Menubar, select File, New, Templates and Documents and then select My 
Business Card followed by Open.

This will open a new document named Untitled. To change the card text contents do the following.

✔ Select File, Properties, open the Custom Properties tab, and edit the Value of each text field 

to be changed.

When you select OK, all of the cards on the page will contain automatically updated text.
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