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Sybase Unwired Platform Tutorials

Sybase Unwired Platform Tutorials

The Sybase® Unwired Platform tutorials demonstrate how to develop, deploy, and test mobile
business objects, device applications, and mobile workflow packages. You can also use the
tutorials to demonstrate system functionality and train users,

Tip: If you want to see the final outcome of a tutorial without performing the steps, the
associated example project is available on SAP® SDN: http://www.sdn.sap.com/irj/sdn/
mobile ’rid=/webcontent/uuid/40ea4956-b95c-2¢ 10- 1 1b3-e68c 736228 e.

* Learn mobile business object (MBO) basics. and use this tutorial as a foundation for the
Object API application development tutorials:
«  Tutorial: Mobile Business Object Development
*  Create native Object API mobile device applications:
*  Tutorial: Android Object API Application Development
s Tutorial: BlackBerry Object API Application Development
»  Tutorial: 108 Object APl Application Development
*  Tutorial: Windows Mobile Object APl Application Development
* Create a mobile business object, then develop a mobile workflow package that uses it:
«  Tutorial: Mobile Work{flow Package Development
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Task Flow

Task Flow

Use this tutorial to develop, deploy, and test a mobile device application on a simulator or an

emulator.

Task

Goals

Steps

Getting started

« Install Sybase Mobile SDK and
Sybase Unwired Platform Run-
time.

*  Start Unwired Server and other
platform services, if not already
started.

«  Start Sybase Control Center.

*  Start Sybase Unwired Work-
Space, open the Mobile Devel-
opment perspective, and be-
come familiar with the views of
the perspective and the Mobile
Application Diagram.

« Installing Sybase Unwired Plat-
form

»  Starting Unwired Platform
Services

« Starting Sybase Unwired Work-
Space

+ Connecting to Sybase Control
Center

* (Optional) Learning Unwired
WorkSpace Basics

These steps are prerequisites for the
rest of this tutorial. You need to per-
form them only once.

Developing database
mobile business ob-
jects

*  Create a mobile application
project and a connection to the
database.

*  Create two mobile business ob-
jects, and create a relationship
between them.

« Deploy the mobile business ob-
jects to Unwired Server.

Complete the Tutorial: Mobile Busi-
ness Object Development, or obtain
the completed example project.

Note: This tutorial is a prerequisite
for the remaining steps. You need to
perform it only once. If you want to
download the final outcome of a tu-
torial without performing it, the as-
sociated example project is available
on SAP® SDN: hup./
www.sdn.sap.com/iry/sdn/mobile?
rid=‘webcontent/uuid/40ea4956-
b95¢-2el0-11b3-e68c 7362280
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Task Goals Steps

Developing a native de-

. e * Create an iOS device applica- | = Generate the Object API code
vice application

tion, and run it on the i0S sim- | «  Setup the i0S client application

ulator. in Xcode

+ Register the application connec-
tion in Sybase Control Center

*  Create the user interface

*  Deploy the application to the
simulator
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Getting Started with Unwired Platform

Install and learn about Sybase Unwired Platform and its associated components.

Complete the following tasks for all tutorials, but you need to perform them only once.

1.

Installing Sybase Unwired Platform
Install Sybase Mobile SDK and Sybase Unwired Platform Runtime.
Starting Sybase Unwired Platform Services

Start Unwired Server, Sybase Control Center, the sample database, the cache database
(CDB), and other essential services.

Starting Sybase Unwired WorkSpace

Start the development environment, where you can perform tasks that include creating
mobile business objects (MBOs), managing database and server connections, developing
Mobile Workflow applications, and generating Object API code.

Connecting ro Sybase Control Center

Open the Sybase Control Center administration console to manage Unwired Server and its
components,

Learning Unwired WorkSpace Basics

Sybase Unwired WorkSpace features are well integrated in the Eclipse IDE. If you are not
familiar with Eclipse, you can quickly learn the basic layout of Unwired WorkSpace and
the location of online help.

Installing Sybase Unwired Platform

Install Sybase Mobile SDK and Sybase Unwired Platform Runtime.

Before starting this tutorial, be sure you have all the requisite Unwired Platform components
installed. For complete installation instructions, see the Sybase Unwired Platform
documentation at http://sybooks.sybase.comy/nav/summary.do?prod=1289.

Release Bulletin for Sybase Mobile SDK
Installation Guide for Sybase Mobile SDK
Release Bulletin for Runtime

Installation Guide for Runtime

Install these Unwired Platform Runtime components:
* Data Tier (included with single-server installation)
* Unwired Server

Install Mobile SDK, which includes:

Tutorial: iOS Object API Application Development 5
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* Development support for Native Object API applications, HTML5/JS Hybrid (Mobile
Workflow) applications, and OData SDK applications.

* Sybase Unwired WorkSpace, the Eclipse-based development environment for MBOs
and mobile workflows.

Starting Sybase Unwired Platform Services

Start Unwired Server, Sybase Control Center, the sample database, the cache database (CDB),
and other essential services.

How you start Unwired Platform services depend on the options you selected during
installation. In some cases, you may need to manually start Unwired Platform services.
Select Start > Programs > Sybase > Unwired Platform > Start Unwired Platform
Services.

The Unwired Server services enable you to access the Unwired Platform runtime components
and resources.

Starting Sybase Unwired WorkSpace

Start the development environment, where you can perform tasks that include creating mobile
business objects (MBOs), managing database and server connections, developing Mobile
Workflow applications, and generating Object API code.

Select Start > Programs > Sybase > Unwired Platform > Unwired WorkSpace.

The Sybase Unwired WorkSpace opens in the Mobile Development perspective. The
Welcome page displays links to the product and information.

Next
To read more about Unwired WorkSpace concepts and tasks, select Help > Help Contents.

Connecting to Sybase Control Center

Open the Sybase Control Center administration console to manage Unwired Server and its
components.

From Sybase Control Center, you can:

* View servers and their status

* Start and stop a server

*  View server logs

* Deploy a mobile application package
* Register application connections

* Set role mappings

6 Sybase Unwired Platform
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For information on configuring, managing, and monitoring Unwired Server, click Help >
Online Documentation.

1. Select Start > Programs > Sybase > Sybase Control Center.

Note: If the Sybase Control Center service does not open, make sure that the service is
started. See the Installation Guide for Runtime.

2. In Sybase Control Center, log in by entering the credentials set during installation.

Sybase Control Center gives you access to the Unwired Platform administration features
that you are authorized to use.

Learning Unwired WorkSpace Basics

Sybase Unwired WorkSpace features are well integrated in the Eclipse IDE. If you are not
familiar with Eclipse, you can quickly learn the basic layout of Unwired WorkSpace and the
location of online help.

* To access the online help, select Help > Help Contents. Some documents are for Sybase
Unwired Platform, while others are for the Eclipse development environment.

* The Welcome page provides links to useful information to get you up and running.
* Reopen the Welcome page by selecting Help > Welcome.
* To close the Welcome page, click X.
* To learn about tasks you must perform, select the Development Process icon.
* In Unwired WorkSpace, look at the area (window or view) that you will use to access,
creale, define, and update mobile business objects (MBOs).

Window Description

WorkSpace Navigator view Use this view to create Mobile Application projects,
and review and modify MBO-related properties.

This view displays mobile application project fold-
ers, each of which contains all project-related re-
sources in subfolders, including MBOs, datasource
references to which the MBOs are bound, personal-
ization keys, and so on.

Enterprise Explorer view A view that provides functionality to connect to var-
ious enterprise information systems (EIS), such as
database servers, SAP® back ends, and Unwired
Server.

Tutorial: iOS Object API Application Development 7
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Window

Description

Mobile Application Diagram

The Mobile Application Diagram is a graphical ed-
itor where you create and define mobile business
objects.

Use the Mobile Application Diagram to create
MBOs (including attributes and operations), then
define relationships with other MBOs. You can:

* Create MBOs in the Mobile Application Dia-
gram using Palette icons and menu selections —
either bind or defer binding to a data source,
when creating an MBO. For example, you may
want to model your MBOs before creating the
data sources to which they bind. This MBO de-
velopment method is sometimes referred to as
the top-down approach.

*  Drag items from Enterprise Explorer and drop
them (drag and drop) onto the Mobile Applica-
tion Diagram to create the MBO — quickly cre-
ates the operations and attributes automatically
based on the datasource artifact being dropped
on the Mobile Application Diagram.

Each new mobile application project generates an
associated mobile application diagram.

Palette

The Palette is accessed from the Mobile Application
Diagram and provides controls, such as the ability to
create MBOs, add attributes and operations, and de-
fine relationships, by dragging-and-dropping the
corresponding icon onto the Mobile Application Di-
agram or existing MBO.

Properties view

Select an object in the Mobile Application Diagram
to display and edit its properties in the Properties
view. While you cannot create an MBO from the
Properties view, most development and configura-
tion is performed here.

Qutline view

Displays an outline of the active file and lists struc-
tural elements. The contents are editor-specific.

Problems view

Displays problems, errors, or warnings that you may
encounter. This is a valuable source for collecting
troubleshooting information.

Sybase Unwired Platform
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Window Description

Error Log view Displays error log information. This is a valuable
source for collecting troubleshooting information.

Tutorial: iOS Object API Application Development 9
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Developing an iOS Application

Developing an iOS Application

Generate Object API code for the i0OS platform, develop a universal i0S device application
with code, and test its functionality. The device application communicates with the database
MBOs that are deployed to Unwired Server.

Prerequisites
Complete these tasks:

1.

Install Sybase Unwired Platform Mobile SDK and Runtime as indicated in Getting Started
on page 5.

Complete Tutorial: Mobile Business Object Development, which provides the foundation
tasks for this tutorial.

Open the SUP101 mobile application project. In WorkSpace Navigator, right-click the
SUP101 folder and select Open in Diagram Editor.

Be sure you are using the Advanced developer profile.

Task

Note: This tutorial was developed using Mac OS X 10.6 (Snow Leopard), Xcode 4.2, and i0S
SDK 5.0. If you use a different version of Xcode, some steps may vary. For more information
on Xcode, refer to the Apple Developer Connection: fitfp.//developer.apple.com/
technologies/tools/whats-new.html,

1.

Generating Object API Code

Launch the code generation wizard and generate the object API code for a message-based
i0S application.

Setting Up an i08 Client Application in Xcode

Set up an i0S client application in the Xcode IDE.

Registering the Application Connection in Sybase Control Center
Register the iPhone Simulator in Sybase Control Center.

Viewing the SUP101CallbackHandler File

In Xcode, view and understand the SUP101CallBackHandler file.
Creating the User Interface

Use Interface Builder to create and configure the user interface for the SUP101
application.

Deploying the Device Application
Deploy the SUP101 application to the iPhone simulator for testing.

Tutorial:
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Developing an iOS Application

Generating Object APl Code

Launch the code generation wizard and generate the object API code for a message-based i0S
application.
1. In Unwired WorkSpace, open the SUP101 mobile application project.
In WorkSpace Navigator, right-click the SUP101 folder and select Open in Diagram
Editor.
2. Right-click in the SUP101 Mobile Application Diagram and select Generate Code.
3. Make sure the Customer and Sales_order MBOs are selected, then click Next.

4. Enter these configuration options and click Next:

»  Generate Code M= E3

Configure options

Configure options For code generation

—Code generation options

Language: IOb]’ective C

Platform: |iOS

Unwired server: |My Urwired Server

Server domain: I default

Lelbed LefledLe]

Page size: |
Mame prefix; |
Cestination
& Praject path: | |sUP101\Generated Code Browse. .. |
IN
" File system path: | Wy Browse. .,

[ Clean up destination before code generation

Third-party jar Hle: | Browse. ., |

™ Generate metadata classes

i cluding object manager classes

':?} < Back | Rlext = | Finish I Cancel I

12 Sybase Unwired Platform



Developing an iOS Application

Option Description
Language Select Objective C.
Platform Accept the default, i0S.

Unwired server

Select My Unwired Server.

Server domain

Accept default. If you are not connected to
Unwired Server, this field is empty. Connect to
Unwired Server to proceed.

Name prefix

The prefix for the generated files. Leave blank.

Project path

Accept the default or enter a different location
for the generated project files.

(Optional) Clean up destination before code
generation

Select this option to delete all items in the des-
tination folder before generating the device cli-
ent files.

5. Click Finish.

Objective-C code is generated into the specified output location.

Setting Up an iOS Client Application in Xcode

Set up an 108 client application in the Xcode IDE.

Prerequisites

* Generate Objective-C code in to an output location.
* Ensure the directory where Sybase Unwired Platform is installed is a shared directory so

you can access it from your Mac.

* Obtain the header and Objective-C source code files you need to build the user interface
from the SUP_i0S_Custom_Dev_Tutorial_code. zip file. This way, you can
casily copy and paste the code into the corresponding files that are created in Xcode.

* Ifyouare viewing this guide as a PDF, you can obtain the files from the Sybase Product
Documentation Web site at http./sybooks.sybase.com/nav/summary.do?
prod=1289& lang=en&submit="%A0G0 %A0&prodName=Sybase+Unwired
+Platform&archive=(0. Navigate to this topic in the tutorial, then click the link for the
zip file to access the provided source code files.

» If you are viewing this guide online from the Sybase Product Documention Web site,
click SUP_iOS_Custom_Dev_Tutorial_code.zip to access the source code files.

Task

1. On your Mac, start Xcode and select Create a new Xcode project.

Tutorial: iOS Object API Application Development
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Developing an iOS Application

2. Select iOS Application and Window-based Application as the project template, and
then click Next.

3. Enter SUP101 as the Product Name, MyCorp as the Company Identifier, select
Universal as the Device Family product.
Unselect Include Unit Tests, and then click Next.

4. Select a location to save the project and click Create to open it.

Xcode creates a folder, SUP101, to contain the project file, SUP101 . xcodepro j and

another SUP101 folder, which contains a number of automatically generated files.

5. Delete some of the automatically generated files created by default for the Xcode project.

a) Delete SUP101AppDelegate.hand SUP101AppDelegate.m.

b) Under Supporting Files, delete the main.m file.

6. Copy the files from the SUP101 folder on your Windows machine in to the SUP101 folder
on your Mac that Xcode created to contain the the SUP101 project.

a) Connect to the Microsoft Windows machine where Sybase Unwired Platform is
installed

b) From the Apple Finder menu, select Go > Connect to Server.

¢) Enter the name or IP address of the machine, for example, smb: //<machine DNS
name> or smb://<IP Address>,then click Connect.

You see the shared directory.

d) Copythe\UnwiredPlatform\MobileSDK\ObjectAPI\10S folder from the
Unwired Platform installation directory to the SUP101 folder on your Mac. Rename
this folder ObjectiveC.

e) On your Windows machine, navigate to the SUP101 mobile application project and
copy the Generated Code folder to the SUP101 directory on your Mac.

f) To prepare for adding the source code files to the Xcode project, unzip the
SUP_1i0S_Custom_Dev_Tutorial_code.zip archive.

Next
Add libraries, resources, and source code to the SUP101 Xcode project.

See also
*  Registering the Application Connection in Sybase Control Center on page 17

Adding Source Code Files, Libraries, and Resources to the Xcode

Project

Once you set up the initial project in Xcode, you need to add files from the Sybase Unwired
Platform folders you copied from your Windows machine.

1. Inthe Xcode Project Navigator, Control-click the SUP101 folder, then select Add Files to
"SUP101".

14 Sybase Unwired Platform



Developing an iOS Application

Select the Generated Code folder, unselect Copy items into destination group's
folder (if needed), and click Add.

The Generated Code folder is added to the project in the Project Navigator.
2. Control-click the SUP101 folder, then select Add Files to "SUP101".

a) Inthe ObjectiveC folder you copied from the Sybase Unwired Platform installation,
navigate to the Libraries/Debug-iphonesimulator directory.

b) Selectthe libclientrt.a, 1ibSUPOkj.a, 1ibMO.a, libsupcore. a, and
libAfariaSLL. a libraries.

¢) Be sure Copy items into destination group's folder (if needed) is unselected.

d) Click Add.

The libraries are added to the project in the Project Navigator.

Note: The library version corresponds to the configuration you are building. In this
tutorial, you work with the libraries for the Debug version of the iPhone simulator,

3. Control-click the SUP101 folder, then select New Group, then rename it to Resources.
4. Add the source code files fromthe SUP_10S_Custom_Dev_Tutorial_code.zip
archive.
a) Control-click the SUP101 folder, then select Add Files to "SUP101".
b) Select all files, then click Add.

The project now looks like this:

ann [ 5UP101.xcodepra|
-~ PR -
@ (M) [5UP101 . iPad 5.0 Simulator | (- Xoada
- B s | 4 » | Pasuplol
PROJECT | Summary nfo Build Settings Build Phases fulld Rul
=~ -
[ Generated Code & suP201 Jon Apelication Ecual
v [ sup101 TARGETS : o gy
(5] SUP101AppDetegate.h = Idernifier | com.arganization.5UPL01L
m| 5UP101AppDelegate.m Version | 1.0 Build | 1.0
» [ iPad
| iPhane Daviess | Universal -:]
¥ [ supporting Files Ovployment Target | 4.3 =
Sentings.bundle =
[} sup102-infe. plist » iFnone | iPod Deployment infa

InfaPlist.strings

h v iPad L I
|h| SUP1O1-Prefix pch iPad Deployment Info

|m| mainm 5
o Main Storyboard =
|h) SUP101CalIbackHandier.h n’h 3
|m| SUP101CaIIBackHandler.m Main Interface | MainWindow_iPad =

h] SubscriteCantrolier.n
m| SubseriteContralier.m

- SubscribeCantrolier xib
|h] CustamerListContraller.h

] CustomerListController.m I . |;‘ I_‘l
# CustomerListControdler xib I_D

{h] DetaliCortrofisr.h Portrait Upside Landscape  Landscape
|m DemilContralier.m Dewn Left Right

~ DetailContraller.xib
» [ Framewarks
» [ Products

Supparied Dovice Orsentations

App leon

Next
Configure the build settings.

Tutorial: iOS Object API Application Development 15



Developing an iOS Application

Configuring the Build Settings

Configure the build settings for the Xcode project, then build the project.

1. In the right pane, click the Build Settings tab, then scroll down to the Search Paths

section, then enter the location of the iPhone simulator libraries in the Header Search

Paths and Library Search Paths fields.

$SRCROOT is a macro that expands to the directory where the Xcode project file resides.

This tutorial project was created in the /SUP/SUP101 directory.

* In Header Search Paths, cnter the path to the Ob ject iveC/includes directory.
In this example, the path is indicated as " $SRCROOT/SUP101/0ObjectiveC/

includes/**",

« In Library Search Paths, enter the path to the ObjectiveC/Libraries/
Debug-iphonesimulator directory. In this example, the path is indicated as
"$SRCROOT/SUP101/0ObjectiveC/Libraries/Debug-

iphonesimulator".

gasic @D | Levels
Setting

Framework Version

info.plist File

Info.plist Other Preprocessor Flags

Summary Info

| Build Settings | Build Phases Build Rules

Q-
oM 5UP101

A

SUP101/SUP101-Info.plist

Framework Search Paths
I Header Search Paths
¥ Library Search Paths
Debug
Release
Rez Search Paths

User Header Search Paths
¥ Unit Te_sIJ. ng

Other Test Flags

Test After Build

Test Host

Test Rig
¥ Versioning

Sub-Directories to Exclude in Recursiv...
Sub-Directories to Include in Recursive...

Info.plist Output Encoding binary &
Info_plist Preprocessor Definitions
Info.plist Preprocessor Prefix File
Preprocess Info.plist File Mo &
Preserve HFS Data No
Private Headers Folder Path SUP101.app/PrivateHeaders
Product Name SUP101
Property List Output Encoding binary &
Public Headers Folder Path SUP101.app/Headers
Strings file Output Encoding binary &
Wrapper Extension app
| ¥ Search Paths
Always Search User Paths No

fUsers/doug/SUP101/ObjectiveC/includes/**

<Multiple values>
“fUsers/doug/SUP101/0bjectiveC /Libraries/ Debug-iphoneos”
“{Users/doug/SUP101/0bjectiveC/Libraries/Release-iphoneos”

=.nib *.Iproj *.framework *.gch (*) .DS_Store CV5 .swn .git .hg *.xcodeproj *.xcod...
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Developing an iOS Application

2. In the right pane, select the Build Phases tab, then expand the Link Binary with
Libraries section.

Click the + icon below the list, select the following libraries, and then click Add to add
them from the SDK to the project:
¢ AddressBook. framework
s CoreFoundation.framework
e libicucore.A.dylib
» libstdc++.dylib
e 1libz.1.2.5.dylib
¢ QuartzCore.framework
e Security.framework
* CFNetwork.framework
* MobileCoreServices.framework
* SystemConfiguration.framework
3. SelectProduct > Clean, then Product > Build to test the initial set up of the project. [f you
correctly followed this procedure, you see a Build Succeeded message.

Registering the Application Connection in Sybase Control
Center

Register the iPhone Simulator in Sybase Control Center.

Prerequisites
Connect to Sybase Control Center.

Task

1. Log in to Sybase Control Center using the credentials you indicated during installation.

L

In Sybase Control Center, select View > Select > Unwired Server Cluster Management
View.

In the left pane, select Applications.
In the right pane, click Application Connections.
Click Register.

6. In the Register Application Connection window, enter the required information:

ok

* User name —userl
= Server name — </ocalhost.sybase.com>

Note: The information should match the input on the client and
"localhost.sybase.com" should be the actual name of your machine and domain.

Tutorial: iOS Object API Application Development 17



Developing an iOS Application

* Port — the Unwired Server port, 5001,
* FarmID -0
* Activation code — 123
* Application ID — SUP101
* Domain-default
7. Click OK.

Next
In Xcode, view the application source files and walk through how they are created.

See also
«  Setting Up an 108 Client Application in Xcode on page 13

Viewing the SUP101CallbackHandler File

In Xcode, view and understand the SUP101CallBackHandler file.

SUP101CallbackHandlerisasubclassof SUPDefaultCallbackHandler, andis
used to listen for events sent from the server. The header, SUP101CallbackHandler . h,
is referenced in a number of classes in this application, so you would create it first. You can
create new Objective-C class files from the main menu: File > New > New File.

There are two threads involved in the SUP101 application — the main thread, which is driven
by the client application user interface controller, and the mobile object client access thread,
which takes charge of message transportation with the server and synchronization with the
application through the mobile object. In i0S, all code that updates the user interface must be
called on the main thread, soitis a good idea to send notifications that might trigger changes to
the interface from the main thread.

1. Click the SUP101CallbackHandler.h file to view the provided source code.
2. Click the sSUP101CallbackHandler.m file to view the provided source code.

Creating the User Interface

Use Interface Builder to create and configure the user interface for the SUP101 application.

The SUP_i0S_Custom_Dev_Tutorial_code.zip contains the source code for the
user interface for the sample application. Although the user interface is already built once you
add the source files to the Xcode project, you can walk through the rest of the tasks and view
the source code to see how to use Interface Builder to build the sample application.

18
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Developing an iOS Application

See also
*  Deploying the Device Application on page 31

Viewing the SubscribeController View Controller
A view controller functions as the root view screen for the SUP101 mobile application.

When you create the user interface, you assign a target action to a control object — in this
example a Subscribe button so that a message (the action) is sent to another object (the target)
in response to a user event, for example, a touch on the button. The view controller manages
and configures the view when asked.

In Xcode, you can create the view controller by creating a new file using the
UIViewController subclass. Be sure to indicate With XIB for user interface. Xcode creates
the corresponding .h, .m, and . xib files.

1. Inthe SUP101 Xcode project, click SubscribeController.mto view the logic for
the view controller.

2. Click SubscribeController.h to view the header file.

See also
*  Creating the CustomerListController on page 28
*  Adding the DetailController and Configuring the View on page 29

Viewing the SUP101Appdelegate Files

The SUP101Appdelegate.hand SUP101Appdelegate . mfiles are created when you
create the Xcode project; however, you deleted the automatically generated versions and
replaced them with the ones added from the source code zip file.

The SUP101Appdelegate files make use of the SUPApplication and SUPDataVault
APIs to show how to store and retrieve sensitive data (such as Sybase Unwired Platform
credentials) using a PIN.

The applicationDidFinishLaunching: method checks to see if the application has
been run before, then shows a dialog to have the device user enter a PIN to unlock the
application, If running for the first time, the Sybase Unwired Platform user's password is also
requested.

Control passes to the initializeSUP101 method. This code sample does one of two
things depending on whether the application has been run before:

* Ifthe application is running for the first time, it creates a new SUPDataVault secured with
the user-provided PIN, to store the password and other items.

* Ifthe application has been run before, it tries to unlock the existing vault with the provided
PIN. If this fails, the application displays an error dialog and exits.

if(self.firstrun)

{
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NSLog (@"Running the app for the first time."};

// If the application is being run for the first time, we do the
following:

l/ 1. Remowve the messaging data vault created by earlier
versions of the application, if it exists.

I 2. Remove the SUP101 data vault created by earlier versions
of the application, if it exists.

/7 3. Create the messaging vault using the PIN as the password,
leaving it unlocked for use by the messaging layer.

// 4. Create the SUP101 data vault using the PIN as the
password, and store the SUP username/password credentials

I/ and a database encryption key in the wvault.

/i

Btry

{
NSLog (@"Delete preexisting messaging wvault");
[SUPDataVault deleteVault:kMessagingDataVaultlID];
}
@catch (NSException *e)
{
// Ignore any exception
}
Btry {
NSLog (@"Delete preexisting SUP101 data wault");
[SUPDataVault deleteVault:kSUPl0lDataVaultID];
}
@catch (NSException *e)
{
// Ignore any exception

}

Btry {
NSLog (@"Create new SUP101 data vault and store credentials and a
generated encryption key");
suplOlvault = [SUPDataVault createVault:kSUPl0lDataVaultID
withPassword:self.pin withSalt:kSUP10lDataVaultSalt]; // creates the
vault
[supl0lvault setString:@"password" withValue:self.SUPPassword];
[suplO0lvault lock];
}
@catch (NSException *exception) {
NSLog (@"Exception in creating new SUP101 data vault: %@: $%@",
[exception name], [exception reason]);

}

Gtry |
NSLog (@"Create new messaging vault and leave i1t unlocked");
messagingvault = [SUPDataVault createVault:kMessagingDataVaultID

withPassword:self.pin withSalt:kDVStandardSalt];
}
@catch (NSException *exception) {
NSLog (@"Exception in creating new messaging data vault: %@: %@",
[exception name], [exception reascon]);

}
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1
else
{
// If the application has been run before, we get the PIN from the
user, and use it to unlock the existing messaging data wvault
// (otherwise the messaging layer cannot start).
'
/Y
NSLog (@"App has been run before.");
Btry {
NSLog(@"Unlock messaging vault");
messagingvault = [SUPDataVault getVault:kMessagingDataVaultID];
[messagingvault unlock:self.pin withSalt:kDVStandardSalt];
}
@catch (NSException *exception) (
NSLog (@"Exception unlocking messaging data wault: %@: %@",
[exception name], [exception reason]);
[self showNoTransportZlert:kSUP10lErrorBadPin];
}

}

This code sample sets up the Application API settings for connection to the Unwired Server
and registers with the Unwired Server.

// Start up the messaging client., This will attempt to connect to the
server. If a connection was

// established we can proceed with login. See conConnectFailure: for
more information about handling connection failure.
[[NSNotificationCenter defaultCenter] addObserver:self
selector:@selector (onConnectSuccess:) name:0N_CONNECT_SUCCESS
object:nil];

[ [NSNotificationCenter defaultCenter] addObserver:self
selector:@selector (onConnectFailure:}) name:0ON_CONNECT_FAILURE
object:nil];

self.connectStartTime = [NSDate date];
SUPApplication* app = [SUPApplication getInstance];
Atry |

suplOlvault = [SUPDataVault getVault:ksSUP10lDataVaultlID];
[suplOlvault unlock:self.pin withSalt:kSUP101DataVaultSalt];

app.applicationldentifier
SUP101CallbackHandler *ch
[ch retain];

[app setApplicationCallback:chl];

@"suplOl"™;
[SUP101CallbackHandler getlnstance];

SUPConnectionProperties* props = app.connectionProperties;
[props setServerName:self,SUPServerName];

[props setPortNumber:[self.SUPServerPort intValue]];
[props setUrlSuffix:@""];

[props setFarmId:self.SUPFarmID];
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SUPLoginCredentials* login = [SUPLoginCredentials getInstance];
if ({self.SUPManualRegistration)
{
login.username = self.SUPConnectionName;
login.password = nil;
props.activationCode = self.SUPActivationCode;
}
else
{
login.username = self.SUPUserName;
login.password = [suplOlvault getString:@"password"];
props.activationCode = nil;
}

props.loginCredentials = login;
[app registerfApplication:30];

This code sample does one of two things depending on whether the application has been run
before:

» Ifthe application is running for the first time, it creates the SUP101 database, generates an
encryption key, and stores it in the data vault.

« If the application has been run before, it retrieves the encryption key from the data vault,
and sets it in the connection profile so the database can be used again.

// Normally you would not delete the local database. For this simple
example, though,

// deleting and creating an empty database will cause all data to be
sent from the

// server, and we can use [CallbackHandler onImportSuccess:] to know
when to proceed.

[SUP101SUP101DB deleteDatabase];

[SUP1015UP101DB createDatabase];

SUPConnectionProfile *cp = [SUP101SUP101DB getConnectionProfile];
[cp.syncProfile setDomainName:@"default"];

[cp enableTrace:NO];

[cp.syncProfile enableTrace:YES];

// Generate an encryption key for the database.
[SUP101SUP101DB generateEncryptionKey];

[SUP1015UP101DE closeConnection];

// Store the encryption key in the data vault for future use.
[suplO0lvault setString:@"encryptionkey™ withValue: [cp
getEncryptionKey]];

// Since we are creating the database from scratch, we set the
encryption key for the new database

// If we were using the database from a previous run of the app and
not creating it each time, an application should run the code below
instead.

// To successfully access a previously encrypted database, we set the
key used by the connection profile.

NSString *key = [suplOlvault getString:@"encryptionkey"];

NSLog (E"Geot the encrypticn key: %@",key);

[cp setEncryptionKey:key];
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[SUP101SUP101DB closeConnection];
[SUP1015UP101DB setApplication:app];

while ([app registrationStatus] != SUPRegistrationStatus_REGISTERED)

{
[NSThread sleepForTimeInterval:1.0];

1
while ([app connectionStatus] != SUPConnectionStatus_CONNECTED)

{
[NSThread sleepForTimeInterval:1.0];

}

Once the server connection is made, the onConnectionStatusChanged: methodinthe
callback handler posts an ON_CONNECT_SUCCESS notification, and the
SUP101AppDelegate's onConnect Success: method is called. This performs a login to
the Unwired Server, using the username from the application settings, and the password from
the data vault.

Configuring the SubscribeController View

Use Interface Builder to configure the SubscribeController.xib file and create the
user interface, Although the provided XIB file is already configured, you can walk through the
steps to see how to create the interface.

1. Clickthe SubscribeController.xib file to reveal a view of the (presently empty)
screen in the right pane and the following three items represented by icons in the middle
pane:

* TFile's Owner — the object that is set to be the owner of the user interface, which is
typically the object that loads the interface. In this tutorial, this is the
SubscribeController.

» First Responder — the first responder proxy object handles events. Connecting an
action to the first responder means that when the action is invoked, it is dynamically
sent to the responder chain.

9 c=2

*  View — displayed in a separate window to allow you to edit it.

|| <=

2. Select the File's Owner icon, select View > Utilities > Identity Inspector, and make sure
SubscribeController appears in the Class field under Custom Class.
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¥ Custom Class ol

Class [5ubs:ribeController 0:]
v ldentity

Label Xcode Specific Label

»u

Object ID 1
Lock [ Inherited - (Nothing) 4
Notes [_| Show With Selection

¥ Accessibility

This tells Interface Builder the class of the object to allow you to make connections to and
from the File's Owner.

3. Click the View icon, and in the Identity Inspector panel, and make sure UT View appears in
the Class field under Custom Class.

¥ Custom Class

Class | UIView oM

¥ ldentity

Label | Xcode Specific Label
XEE_ =2 E=-

Object ID 1
Lock [ Inherited - (Nothing) |4
Notes [_] Show With Selection

4. To create a Subscribe button, select View > Utilities > Object Library.
a) Inthe Object Library panel, select the Round Rect Button item, drag it onto the view.
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L= functions as a discrete button.

7~ Text Field - Displays editable text
Text and sends an action message to a
target object when Return is tapped. | ¥

b) Double-click it and enter Subscribe and press Return.

5. In the Accessibility section of the Identity Inspector, make sure Enabled is unselected.

Disable the button because the application cannot subscribe to the server for updates until
it is connected.

(%] ) Label | Xcode Specific Label
= =] X W
Object ID 1
Lock [ Inherited - (Nothing)  [#]
Notes [_] Show With Selection

¥ Accessibility
Accessibility | Enabled |
Label

i "y

. Subscribe Hint I
Traits [_] Button [ Link
] Image ] Selected
) Plays Sound It
"] Keyboard Key

] Static Text

"] Summary Element

g User Interaction Enabled
Y
v

("] Updates Frequently
(] Search Field

D {}| & m
(il objects ] (2l

Label - A variably sized amount of m
Label static text.

6. Control-click the Subscribe button to show the inspector.

Tutorial: iOS Object API Application Development 25



Developing an iOS Application

7. Drag from the circle to the right of Touch Up Inside to the File's Owner icon and release,
then click on buttonPressed to establish a connection between the Subscribe button and
the button's action method:

e

%] Button - Subscribe
¥ Sent Events
Did End On Exit
Editing Changed
Editing Did Begin
Editing Did End
Touch Cancel
Touch Down
( . Touch Down Repeat
| Subscribe Touch Drag Enter
e v Touch Drag Exit
Touch Drag Inside
Touch Drag Outside
Touch Up In... » File's ...
button...

O0000000000

O]

Touch Up Outside
Value Changed
Referencing Outlets
New Referencing Outlet O
Referencing Outlet Collections

ole)

New Referencing Outlet Colle...

Making Connections

Add Navigation Controllers to MainWindow_iPhone.xib and

MainWindow_iPad. xib and create a connection from the AppDelegate to the Navigation
Controller.

1. In the left pane, under the iPhone folder, click the MainWindow_iPhone.xib file.

If you do not see the Navigation Controller in the middle pane, drag it from Objects to the
middle pane:
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» [ endproj

¢

i SUP101ARpDelegate_[Phone.h
m SUPL01AppDelegate_Phone.m

| mainen

|h! SubscrineController.h

|m| SubserineController.m

®

+ SubscribeControllerxib
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|h! sUP101AppDelegate
lm| SUP10LAppDeiegae.m
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¥ ] Resources
» [ Semings.bundie
' libelientrt.a
| libMo.a
bSUPOb].a
» [ Generated Code
» (] supporting Files &

» [ Framewarks. i

®

+ ©RE @ Vm
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Na Selection

D & =
| Ll Dtgects BIEEE
‘ "mwerwmm:umwm

View

Navigation Controller - 4
cosntrofler that manages navigation
through 2 hierarciry of wiews,

Tab Bar Controller - A controlier
that manages a set of view
contrciiers that regresent tab bar... | |

WView - Represents 2 rectangulas
| region in which it draws and receives
EVRATE. ~
s

Windiow - Defines windows that ™
a %

2. Under Objects in the middle pane, control-drag from the AppDelegate icon to the
Navigation Controller icon to create a navController outlet.

W% Objects
> App Delegate
|| Window
v & Navigation Controller

< Navigation Bar
» () View Controller - Root View Controller

3. Click on the expansion arrow at the bottom of the middle pane to switch to list view, select
Navigation Controller > View Controller, and in the Identity Inspector, select
SubscribeController in the Class field.

Tutorial: iOS Object API Application Development 27



Developing an iOS Application
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Once the class is selected, the ViewController name in the hierarchy changes to

SubscribeController and the connection from the AppDelegate to the Navigation
Controller is created.

4. Repeat these steps to add a navigation controller to MainWindow_iPad.xib.

Creating the CustomerListController

Create the customer list view.

The source files you added from the SUP_iOS_Custom_Dev_Tutorial_code.zip file contain
the CustomerListController.h, CustomerListController.m, and
CustomerListController. xib filesthatcreate the customer list view. To create these
files manually in Xcode, you would create a new file using the UI'ViewController subclass
template, then indicate it is a subclass of UITableViewController. Be sure to indicate
With XIB for user interface.

1. View the CustomerListController.h file.

2. View the CustomerListController.m file.
CustomerListController.mis atable view controller that displays the customer
datain the client database. The viewWil 1 Appear method uses the Object APT to query

the database for a list of all Customer objects, and builds an NSArray that is used by this
class as the data source for displaying the table view.
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If a row is tapped, the accessoryButtonTappedForRowWithIndexPath
method is run, which pushes aDetailCeontreoller onto the stack to display additional
information and allow the data to be modified.

See also
» Viewing the SubscribeController View Controller on page 19
*  Adding the DetailController and Configuring the View on page 29

Adding the DetailController and Configuring the View

Create the DetailController.xib.

The detail controller view displays information about a single customer in the client database.
he source files you added from the SUP_iOS_Custom_Dev_Tutorial_code.zip file contain the
DetailController.h,DetailController.m,andDetailController.xib
files that create the customer detail view. To create these files manually in Xcode, you would
create a new file using the UI'ViewController subclass template, then indicate it is a subclass
of UIViewController. Be sure to indicate With XIB for user interface.

Although the provided XIB file is already configured, you can walk through the steps to sce
how to create the interface.

1. Clickthe DetailController.xib file to open Interface Builder.

2. Select View > Utilities > Object Library.

3. Inthe Object Library panel, select the Text Field item, drag it onto the view three times to
create three text fields aligned vertically to the right of the screen.

You can resize the text fields using the resize handles and position the button by dragging it
to the desired location.

4. In the Object Library panel, select the Label item, drag it onto the view three times to
create three labels to the left of and aligned with the three text fields. Replace the default
Label text with:

+  First Name
= Last Name
* Phone

5. Inthe Object Library panel, select the Round Rect Button item, drag it onto the view, and
rename it to Submit.

To make connections to the user interface from the view controller, the
DetailController.h file contains the outlets, property declarations for the instance
variables, and a declaration for the action method.

#import <UIKit/UIKit.h>
#import "SUFPl0l1Customer.h"

@interface DetailController : UIViewController {

}
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8.
9.

@property (nonatomic, retain} IBCOutlet UITextField *fname;
@property {(nonatomic, retain) IBCutlet UITextField *lname;
@property (nonatomic, retain) IBOutlet UITextField *phone;
@property {(nonatomic, retain) SUP101_Customer *originalObij;
@property (nonatomic, retain) IBOutlet UIButton *submitButton;

—({IBAction)buttonPressed: (id) sender;

Bend

View the DetailController.m file.

This class displays detailed information about a single customer in the client database. The
information can be edited. If the data is changed and the Submit button is pressed, the
buttonPressed method uses Object API calls to save the changes in the client
database, send the changes to the server, and disable the Submit button.

If the server accepts the changes, the callback handler posts an ON_REPLAY_SUCCESS
notification, which causes the onReplaySuccess notification handler to run. The
cached Ul data is refreshed from the database and the Submit button is re-enabled.

This class also registers for the ON_REPLAY _FAILURE notification to handle the case
where the server rejects the changes, or an error occurs on the server side.

Clickthe DetailController.xib file to open it in Interface Builder, click the First
Name text field, and select View > Utilities > Attributes Inspector.

In the Attributes Inspector panel , scroll to the View section and enter 1 in the Tag field.

Set the tags for the Last Name and Phone text fields to 2 and 3 respectively.

10. Control-drag from the File's Owner icon in the middle pane to each of the text fields and

select the fname, Iname, and phone outlets, respectively, to create connections between
the text fields and the outlets defined in the DetailController.m file.

11. Select View > Utilities > Connections Inspector to confirm that the outlets have been

correctly configured:
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¥ Outlets
fname —{ ®# Text Field @
Iname }~ % Text Field ®
phone = #% Text Field {:l)c
searchDisplayController Q
submitButton O
view — % View
e - ®
¥ Referencing Outlets
MNew Referencing Outlet QO
i ¥ Referencing Outlet Collections
FI I'St Name New Referencing Outlet Collection O
¥ Received Actions
buttonPressed O
Last Name
Phone

Submit

12. Control-drag from the File's Owner icon in the middle pane to the Submit button and
select submitButton.

See also
»  Viewing the SubscribeController View Controller on page 19
* Creating the CustomerListController on page 28

Deploying the Device Application

Deploy the SUP101 application to the iPhone simulator for testing.

Prerequisites
Register an application connection in Sybase Control Center.

You must be connected to the server where the mobile application project is deployed.

Task

1. In the upper-left corner of XCode, make sure that the Scheme is set to SUP101 | iPhone
5.0 Simulator.
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N - s sa

TARGETS

2. Select Product > Build and then Product > Run
The project is built and the iPhone simulator starts.
3. In the iPhone applications screen, open the SUP101 application.
When you run the application for the first time, it exits immediately with a dialog asking

you to enter the application settings in the Settings application. These settings include the
server name, port number, Sybase Unwired Platform user name, and other settings.

4. In the iPhone simulator, go to Settings > SUP101 to enter the connection settings.
+ SUP Server — the machine that hosts the server where the SUP101 mobile application
project is deployed.
* SUP Server Port — Unwired Server port number. The default is 5001.

¢ Farm ID - the company ID you entered when you registered the device in Sybase
Control Center, in this case, 0.

+ SUP Username - the user to be authenticated, supAdmin.
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SUP 101 Settings

SUP Server dlowder-w7vm
SUP Server Port 5001
Farm ID 0

SUP Username supAdmin

Manual registration m_ )

If manual connection:

Connection Name usert

Activation Code esee

) 4
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If the "Manual registration" switch is set to "Off", the application will attempt to perform
an automatic registration, creating an application registration with the same name as the
SUP Username ("supAdmin” in this example). This feature allows a client with a valid
SUP username and password to connect and register with the server without a need for a
manual registration to be created in advance.

If the "Manual registration” switch is set to "On", then the connection name and activation
code need to be filled in, and must match an application connection that has already been
created in Sybase Control Center (see Register an application connection in Sybase
Control Center).

In the iPhone applications screen, reopen the SUP101 application.

You are prompted for a PIN to use to securely store your Sybase Unwired Platform
password, and a database encryption key that is generated when the application launches.
For subsequent launches of the application, only the PIN is required.

Enter a PIN, and enter the password for the SUP username that was entered in step 4.
Click Subscribe.

The customer list appears.

Select a customer record from the customer list and double-click to open the detail view.
The customer detail shows the fields: First Name, Last Name, and Phone.

Change the First Name to something else, and click Submit.

See also

L]

Creating the User Interface on page 18
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Learn More About Sybase Unwired Platform

Once you have finished, try some of the other samples or tutorials, or refer to other
development documents in the Sybase Unwired Platform documentation set.

Check the Sybase Product Documentation Web site regularly for updates: Arip./
sybooks.sybase.com/nav/summary.do?prod=1259, then navigate to the most current version.

Tutorials
Try out some of the other getting started tutorials available on Product Documentation to geta
broad view of the development tools available to you.

Example Projects

Example projects are available for download, if you want the finished tutorial without going
through the steps. Download example projects from: htip.//www.sdn.sap.com/irj/sdn/mobile?
rid=/webcontent/uuid/40ca4956-b95c-2e10-11b3-e68c73b2280e.

Samples
Sample applications are fully developed, working applications that demonstrate the features
and capabilities of Sybase Unwired Platform.

Check the SAP® Development Network (SDN) Web site regularly for new and updated
samples: Atips://ew.sdn.sap.con/cw/groups/sup-apps.

Online Help
See the online help that is installed with the product, or the Product Documentation Web site.

Developer Guides
Learn best practices for architecting and building device applications:

*  Mobile Data Models: Using Data Orchestration Engine — provides information about
using Sybase Unwired Platform features to create DOE-based applications.

*  Mobile Data Models: Using Mobile Business Objects— provides information abouthow to
develop mobile business objects (MBOs) to fully maximize their potential.

Learn about using the API to create device applications:

* Developer Guide: Android Object APl Applications

* Developer Guide: BlackBerry Object API Applications

*  Developer Guide: i05 Object API Applications

*  Developer Guide: Windows and Windows Mobile Object API Applications
* Developer Guide: Mobile Workilow Packages

Customize and automate:
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*  Developer Guide: Unwired Server Management APl — customize and automate system
administration features.

Javadoc and HeaderDoc are also available in the installation directory.
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