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1 Introduction 

 

The Oracle Sample Application (SampleApp) for Business Intelligence Suite Enterprise Edition Plus (EE) is a comprehensive set 

of illustrative examples and best practices for OBIEE 11g. It demonstrates a broad range of OBIEE 11g capabilities including 

Enhanced visualizations such as interactive dashboards, modeling best practices, Action Framework,  BI Publisher, Scorecard 

and Strategy Management, Mobile style sheets, Semantic layer modeling, Multi-source federation  and Integration with products 

such as Essbase, Oracle OLAP, ODM, TimesTen, ODI and so on. 

OBIEE SampleApp contents and its code are distributed free. It is not maintained or supported by Oracle as a licensed product. 

1.1 Prerequisites  

Core components of Sample the following products to be installed and configured. Admin privileges on OBIEE and Oracle DB will 

be required to deploy SampleApp components. 

 Oracle Business Intelligence Enterprise Edition 11.1.1.5, Simple install 

 Oracle 11g R2 Database : OBIEE SampleApp deploys a set of small sized database schemas to support the examples 

 

Optional components within SampleApp have the following prerequisites. They are required if and only you wish to configure 

SampleApp integration to these respective product related contents/ services. 

 Oracle Essbase 

 Oracle Application Express (required for Action Framework configuration) 

 Oracle Data mining option for Oracle 11g R2 Database 

 Oracle TimesTen 11g Database 

 Oracle Data Integrator 11gR1 (11.1.1.3) 

 Microsoft SQL Server 2008 with Analysis Services 

1.2 Content Organization 

 

The dashboards and analyses within SampleApp are grouped together by related 

functional/ product areas. It is sequenced and organised under dashboards as 

shown in the screenshot here.  

 

Once SampleApp is deployed, navigate to “General Index” dashboad to see the full 

list of its contents. “Configuration” dashboard contains the setup details such as 

user credentials, database diagram, dimentional hierarchy diagrams, rpd physcial, 

logical and logical hierarchy diagram and so on.Many of the other dashboard pages 

have inline help documentation on the contents exibited on those respective pages/ 

analyses.  

1.3 Known issue in V107 

A dashboard in SampleApp build 10722 (Dashboard  3.10 Query Building >  Selection Steps on hierarchies) is mistakenly 

pointing to wrong catalog reports. Appendix 1 at the end of this document indicates the simple fix to point it back to appropriate 

content. 



2 Deploying Mandatory Components 

2.1 Laying Out Installation Files 

Follow the instructions below in the sequence listed in order to lay out the installation files into appropriate directories under your 

OBIEE 11g installation – 

 

2.1.1 Configure Install script 

 Download SampleApp V10722 Installation ZIP Files from OTN which contains installation files including database dump 

files  

 

 Save the zip file on to the machine where OBIEE 11g is preconfigured, up and running. 

 

 Use 7-zip (on windows) or unzip command (on Linux) to unzip the zip files to a directory of your choice on the machine. 

On windows environments, unzip file directly under C:\ or D:\ directory to avoid path length potential issues while 

unzipping. Some nested folder structure in the install can get quite long and create issues with Windows envs not 

supporting such long file paths. Placing them directly under a root drive will reduce the file path length and avoid a 

potential unzip issue. Detailed instructions for unzipping the installation files are provided in the README.txt file which is 

available at the same location as zip files.  

 

 Edit the “installSA.bat” installation script using a text editor to specify correct values for the following variable names. 

“installSA.bat” file will be used on Windows/DOS environments and “installSA.sh” file will be used on Linux/Unix 

environments. Double check the values for following variable values. Incorrect values can result in incorrect setup or 

environment corruption : 

 

OBIEE_INSTALL_HOME – this should contain full directory path to OBIEE installation, for 

example, 

- Under Linux : /scratch/laliv/obi11g 

- Under Windows : c:\OBI11G (as shown in the picture) 

 

OBIEE_INSTANCE – this should contain the active instance folder name. It is set to 

“instance1” by default. 

2.1.2 Run Install script 

 Open a command line window and navigate to unzip folder. Execute “installSA.bat” (for Windows/DOS) or “installSA.bat” 

(for Linux/Unix) file from the command prompt. On Linux, you may have to change the permissions of the file in order to 

execute it (example – “chmod +x installSA.sh”). Once execute permissions are assigned you can execute the script from 

its directory as “./installSA.sh” or using the command “sh installSA.sh” 

2.1.3 Troubleshooting Install Script 

 When you execute installSA.sh on Linux, you may encounter the following error  

-bash: ./installSA.sh: /bin/sh^M: bad interpreter: No such file or directory 

http://www.oracle.com/technetwork/middleware/bi-foundation/obiee-samples-167534.html


 If you encounter this error, then create a new file called installSA1.sh, copy and paste the contents of installSA.sh into 

the new file installSA1.sh. Then grant execute privileges on this new file using chmod 777 installSA1.sh. Now execute 

installSA1.sh to run the installer.  

 

 If your OBIEE installation is of is of „Enterprise‟ and not „Simple‟ type, then your setup will have both AdminServer and 

bi_server1. In this case, the installer will give the following error while trying to copy a couple of files for Actions because 

the path needs to be bi_server1 instead of AdminServer 

[INFO] Copying files for Actions 

cp: target 

`/app/oracle/product/obiee/11g/user_projects/domains/bifoundation_domain/servers/AdminServer/tmp/_WL_u

ser/analytics_11.1.1/silp1v/war/res/b_mozilla/actions/' is not a directory 

cp: target 

`/app/oracle/product/obiee/11g/user_projects/domains/bifoundation_domain/servers/AdminServer/tmp/_WL_u

ser/analytics_11.1.1/silp1v/war/res/s_blafp/images/' is not a directory 

 

 These two copy steps need to be manually executed with the appropriate paths on your setup.  

1) Copy Comment.gif and NoComment.gif from your SampleApp install location /Actions/CommentaryArtifacts to the 

following two locations on your OBIEE install  

                                  

/installhome/user_projects/domains/bifoundation_domain/servers/bi_server1/tmp/_WL_user/analytics_11.1.1/7

dezjl/war/res/b_mozilla/actions 

 and                               

/installhome/user_projects/domains/bifoundation_domain/servers/bi_server1/tmp/_WL_user/analytics_11.1.1/7

dezjl/war/res/s_blafp/images 

 

2) Copy UserScripts.js from your SampleApp install location /Actions/CommentaryArtifacts to the following two 

locations on your OBIEE install  

/installhome/user_projects/domains/bifoundation_domain/servers/bi_server1/tmp/_WL_user/analytics_11.1.1/7

dezjl/war/res/b_mozilla/actions 

and 

/installhome/ Oracle_BI1/bifoundation/web/app/res/b_mozilla/actions 

 

 

C:\OBI11G\Oracle_BI1\bifoundation\web\app\res\b_mozilla\actions 

 

 If your environment doesn‟t support neither batch nor shell scripts, then you will have to carry out the copy process 

manually before you proceed with the rest of the steps. Similarly if any part of the “installSA” script fails, retry the failed 

command and all the remaining commands manually. You may open the script using a text editor and refer it to 

understand the source and target files paths and the list of files to be copied.  

 

 RPD file: The SampleApp.rpd file that is in the install directory does NOT need to be moved into your BIEE install. It will 

be used directly by EM administration process, and needs to be copied to the machine where you will run EM browser 

from. 



2.2 Restoring Database Dumps 

In this section, we will use Oracle data pump to import the definition and data for several database schemas. If any of these 

schemas exist, they must be dropped before you begin the import. In case they cannot be dropped, the schemas may be 

imported into different schema names using schema mapping options available for impdp command. If the schema names and/or 

passwords are changed, it will require additional corrections and configurations in SampleApp RPD. 

 

Schema Password Remarks 

BISAMPLE BISAMPLE Main schema that houses data for SampleApp analyses 

OBIEE_NAVTEQ obiee_navteq NAVTEQ copyrighted data used for map views 

BIFOD BIFOD OLTP 3NF model for FOD (Oracle Fusion Order Demo) data model. 

BIBPM BIBPM 
BPM (SOA) Business Process Monitoring model to show how BIEE semantic 

layer can deliver analytics on BPM context 

DEV_ODI_REPO DEV_ODI_REPO This supports the SampleApp Oracle Data Integrator content 

ODI_STAGING ODI_STAGING This supports the SampleApp Oracle Data Integrator content 

 

 From you SampleApp installation files, copy \DataSources\ORCL\SASCHEMAS.dmp file to the machine where Oracle 

database 11gR2 is up and running  

 Unzip this file to a folder on the database server, say “C:\datapump\” 

 Connect to database using a sysdba user and create a directory object to import the database dump. Change the data 

base connection parameters (highlighted in red) to reflect your connection settings.  

 sqlplus "sys/Admin123@sampledb1 as sysdba" 

 create or replace directory datapumpdir as 'c:\datapump'; 

 Import the database dump using the command below. 

impdp "'"sys/Admin123@sampledb1 as sysdba"'" directory=datapumpdir dumpfile=SASchemas.dmp 

version=11.2.0.0.0 schemas=BISAMPLE,OBIEE_NAVTEQ,BIFOD,BIBPM,DEV_ODI_REPO,ODI_STAGING 

LOGFILE=SASchemas_imp.log 

 

        NOTE:- Change the value of Version parameter depending on the version of your target database.  

During the import process you may get the warning ORA-39082: Object type 

VIEW:"BISAMPLE"."ODM_SAMP_CUSTOMERS_LTV" created with compilation warnings 

 This a known warning and can be ignored.  

 

 Once the import is completed, connect back to the database using a sysdba user and execute the following sql 

commands.  

 

To connect use - sqlplus "sys/Admin123@sampledb1 as sysdba" 

alter user BISAMPLE identified by BISAMPLE; 

alter user OBIEE_NAVTEQ identified by obiee_navteq; 

alter user BIFOD identified by BIFOD; 

alter user BIBPM identified by BIBPM; 

alter user DEV_ODI_REPO identified by DEV_ODI_REPO; 

alter user ODI_STAGING identified by ODI_STAGING; 

 

Next connect as obiee_navteq/obiee_navteq@sampledb1 and execute the following insert statements 



insert into user_sdo_maps select * from obiee_navteq.my_maps; 

insert into user_sdo_themes select * from obiee_navteq.my_themes; 

insert into user_sdo_styles select * from obiee_navteq.my_styles; 

insert into user_sdo_cached_maps select * from obiee_navteq.my_tile_cache; 

commit; 

2.3 Creating Weblogic Server Users 

2.3.1 Start Weblogic AdminServer 

On your server, navigate to: \InstallHome\user_projects\domains\bifoundation_domain\bin and run startWebLogic.cmd or 

startWebLogic.sh depending on your environment OS. You will be prompted with your Administrator credentials created during 

platform install. Bringing up this service may take a few minutes depending on your environment, wait until the command line 

stops scrolling and indicates server in RUNNING mode. Keep this command window up to keep server up. 

2.3.2 Importing Users in Weblogic 

This step is required in order to have most of the SampleApp features to work. Make sure the FMW import happens properly on 

your environment.  

 Open the weblogic Administration console online (http://localhost:7001/console use the login 

you created in BIEE installation to log in). 

 From home screen, click on Security Realms link. 

 

 Then select “myrealm” option.  

 

 

 

 

 Go to the migration page tab. Go to the 

Import tab. 

 In the 'Import Directory on Server', 

point to the directory where you saved 

the SampleApp Install files, navigate to the core folder and FMW_Users_Definition subdirectory within that. 

 For e.g.:- c:/SampleAppinstall/Core/FMW_Users_Definition.  

 

 Click on Save. This should import 

all the SampleApp users into your 

environment. To confirm it, click 

on Users and Groups tab.  

 

 

 Verify that you can see the new users like abell, etc 

created now. You should be able to login using any of 

these users in OBIEE. 

 

 



 

2.3.3      User Credentials 

The list of users in this build is listed in the table below. Passwords for all SampleApp users imported, as well as the RPD 

encryption password is uniquely set to : Admin123 

 

2.4 Deploying analyticsRes in WLS 



This step allows to point WLS to the file folder location where you have pasted custom files 

for SampleApp (Images, styles, messages…).  

 Login to weblogic Administration console (http://localhost:7001/console   use the login 

you created in BIEE installation to log in).  

 Navigate to deployments area.  

 Click on the Install button in the 

deployments area to install a new 

web application. (If Install button is 

not enabled, click on Lock & Edit 

on the left frame).  

 

 

 

 

 

 

 

 In the Install Application Assistant 

dialog, provide the path: 

\installhome\instances\instance1\bifoundation\OracleBIPresentationServicesComponent\coreapplication_obips1 

This should give the option to select analyticsRes as a valid application to deploy. 

 Select analyticsRes and click on Next. 

 

 

 

 

 

 

 

 

 In the next screen, choose the default option „Install this deployment as 

an application‟ and click Next.  

 

 In the next screen, under the Source Accessibility section, choose „I will make the deployment accessible from the 

following location’. Click Finish.  

 In the deployment screen, confirm that the new application called analyticsRes is now available.  

http://localhost:7001/console


 

 

 

 

 

 

 

 

 

 

 

 Click on „Activate Changes‟.  

 Once this completes, start the deployment called „analyticsRes‟. 

 

 

 

 

 

 

 

 

 

2.5 Deploying Metadata Dictionary Folder in WLS 

This step is required to make metadata dictionary available within SampleApp.  

 

 IMPORTANT Note :  

The metadata dictionary folder name SampleApp_BI0001 in the path 

\installhome\instances\instance1\metadatadict\SampleApp_BI0001 

should be the same as the rpd name that is online currently. If your rpd name has changed 

to say SampleApp_BI0002 or SampleApp_BI0003, then change the directory name of the 

SampleApp_BI0001 under metadatadict to the same name as the rpd.  

2.5.1.1 Deploying the Dictionary in WLS 

Within the weblogic Administration console 

screen, click on Deployments area.  

 

 Click on the Install button in the 

deployments area to install a new web 

application. (If Install button is not 

enabled, click on Lock & Edit on the left 

frame).  

 



 

 In the Install Application Assistant dialog, provide the path  \installhome\instances\instance1\metadatadict.  

 

 

 

 

 

 

 

 

 

 

 

T

h
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s should give the option to select metadatadict as a valid application to deploy. Select metadatadict and click on Next 

 In the next screen, choose the default option „Install this deployment as an application‟ and click Next. 

 In the next screen, under the Source 

Accessibility section, choose „I will 

make the deployment accessible 

from the following location’. Click 

Finish 

 In the deployment screen, confirm that the 

new application called metadatadict is now 

available. 

 

 Click on „Activate Changes‟ 

Once this completes, start the deployment called 

„metadatadict‟ 

 

 

 

 

 

 

2.6 OBIEE Configuration Settings 

2.6.1 NQSConfig.ini Edits  

Open NQSConfig.ini file from the following location:  

\InstallHome\instances\instance1\config\OracleBIServerComponent\coreapplication_obis1 

2.6.1.1 USER_REF_GUIDS 

Make sure the following tag (in green) is set as shown below in your NQConfig file and save it : 

 



 ->[SERVER]  

  ... 

 FMW_UPDATE_ROLE_AND_USER_REF_GUIDS = YES;   

2.6.1.2 USAGE TRACKING 

The following entry is not mandatory, but will allow the usage tracking SampleContent to show data, it is advised that you set 

these tags as described : 

 

 ->[USAGE_TRACKING] 

 ENABLE = YES;   

  ... 

 DIRECT_INSERT = YES;   

 PHYSICAL_TABLE_NAME = "10 - System DB (ORCL)"."Catalog"."dbo"."S_NQ_ACCT";   

 CONNECTION_POOL = "10 - System DB (ORCL)"."UT Connection Pool";     

2.6.2 Instanceconfig.xml Edits  

Open Instanceconfig.xml file from the following location :  

\InstallHome\instances\instance1\config\OracleBIPresentationServicesComponent\coreapplication_obips1 

Comment the following tag.  

<Catalog> 

         <UpgradeAndExit>false</UpgradeAndExit> 

</Catalog> 

Make sure you have all the following tags (in green below) in the file, within the existing <ServerInstance> tag. Some of these 

entries may already be present in your file. Ensure that entries are made only once and are in appropriate locations. 

 

 <ServerInstance> 

 ... 

<SpatialMaps><LayerDataLayout><MaxRecords>1000</MaxRecords></LayerDataLayout></SpatialMaps>  

<LightWriteback>true</LightWriteback> 

 ... 

<ps:Catalog xmlns:ps="oracle.bi.presentation.services/config/v1.1"> 

         <ps:UpgradeAndExit>false</ps:UpgradeAndExit> 

         <ps:UpdateAccountGUIDs>UpdateAndStartNormally</ps:UpdateAccountGUIDs> 

</ps:Catalog> 

<LogonParam> 

             <TemplateMessageName>LogonParamSQLTemplate</TemplateMessageName> 

             <MaxValues>100</MaxValues> 

</LogonParam> 

<SubjectAreaMetadata> 

<DictionaryURLPrefix>/metadatadict/</DictionaryURLPrefix> 

</SubjectAreaMetadata> 

 … 

 </ServerInstance> 



2.6.3 RPD Edits 

You need to have access to admintool for offline editing of your RPD to configure necessary changes for connectivity to your 

database system. The RPD is included in the „Core‟ folder of the install package. 

If you are using Linux environment, you need to access the rpd by editing it from a windows environment, using the OBIEE 

admintool client. The Admintool client  can be downloaded from url:  

http://www.oracle.com/technetwork/middleware/bi-enterprise-edition/downloads/bus-intelligence-11g-165436.html 

 

 IMPORTANT Note :  

Always open Admintool by opening the Start program menu, and navigating on to the menu icon within the Oracle Business 

Intelligence menu. Do NOT open the RPD simply double click on the RPD file or typing Admintool.exe in command line 

 

Open Admintool then open the SampleApp.RPD file offline from your installer location :  

RPD Password for opening offline : Admin123 

2.6.3.1 Edit BI_EE_HOME Variable Value: 

Navigate to Manage>Variables menu, double click on the BI_EE_HOME Repository Variable, update the default initializer string 

from its current value to the correct full path of the following directory on your BIEE install : 

\InstallHome\instances\instance1\bifoundation\OracleBIServerComponent\coreapplication_obis1 

 

For example, in a Linux environment, as an example, that value could be : 

/scratch/laliv/obi11g/instances/instance1/bifoundation/OracleBIServerComponent/coreapplication_obis1 

2.6.3.2 Update RPD variables that contain database connection information  

The connection pools setting uses repository variables to connect to the underlying database. You must update these variables to 

allow the RPD to properly connect. On the RPD click on Manage->Variables and update the following variables to appropriate 

values to connect to your database. 

 DB_HOST - This variable holds the value of the database host machine. 

 DB_PORT - This variable holds the value of the port. 

 DB_SID  - This variable holds the SID information. 

 DB_USERNAME - This variable holds the database username. (Must be BISAMPLE) 

 WLS_HOST - This host information should be the computer name (or IP) of your Weblogic Server host. 

2.6.3.3 Update Session variables that contain Essbase connection information  

Following session variables and init blocks are used by Essbase Option for connection pools setting. If you are planning to deploy 

Essbase option you must update the initiation of these variables to allow the RPD to properly connect. On the RPD click on 

Manage->Variables and update the following session variable and init block to appropriate values to connect to your databases : 

 Verify DUAL Cube Name (=BISAMPLE) - This variable holds the name of the Sample Essbase cube  

 Verify DUAL ESSB HOST - This variable holds the name or IP of Essbase host server 

Make sure you update the init block default SQL to return the proper value. Also edit the default value for each variables. 

2.6.3.4 Update Database Password in RPD connection pools  

If you have not changed the OOB password for BISAMPLE user (pwd = „BISAMPLE‟), then there should be no edit needed in the 

RPD. If you have changed the value of the password for the BISAMPLE user, you need to edit password values for all the 

Connection Pool entries in RPD that use the above variables with your correct password value. 

http://www.oracle.com/technetwork/middleware/bi-enterprise-edition/downloads/bus-intelligence-11g-165436.html


2.6.3.5 Update settings with RCU db for Scheduler Connection Pool 

The values in “Scheduler Connection Pool” under “07 – Scheduler Jobs” database need to be updated to point to the 

BIPLATFORM schema that is installed during OBIEE installation. In the connection pool, update the data source name with the 

appropriate values of database host, sid, port, username and password of the BIPLATFORM schema.  

 Note : 

 The BIPLATFORM schema is the one that is used during the OBIEE installation process.  

2.6.3.6 Expected Consistency Warnings  

 Important : Expected Consistency Warning 

Run a consistency check of your RPD. You should see the single following consistency warning message : 

This warning is expected; do not try to fix it. Fixing it would break the OLAP API functionality. In case you see other errors or 

warnings coming up, please process previous steps again starting from the original RPD.  

2.6.3.7 Save your offline RPD.  

2.6.4 Setting the default rpd and webcat paths through EM 

Login to the EM administration screen using the url http://localhost:7001/em (Replace the hostname and port-number based on 

your setup) 

2.6.4.1 RPD and Webcat selection 

2.6.4.1.1.1 RPD selection 

 Use the login you created in BIEE installation to log in to the EM console.  

 Expand 'Business Intelligence' node on the left and choose Coreapplication. 

 

 Now click on the Deployment tab on 

the right. Next, go to the Repository 

tab. 

 

 Click on 'Lock and Edit Configuration' 

to enable you to change the default 

settings.  

 

 In the 'Upload BI Server Repository' section, click on the Browse button and locate the SampleApp.rpd that you updated 

with correct connection information, on your client machine.  

 Enter Admin123 as the password ( this is the offline password for SampleApp.rpd) 

 Keep on the same configuration screen to update webcat selection 

 



2.6.4.1.1.2 Webcat selection 

Your platform install, does not yet point to SampleApp catalog, you need to update the path at the bottom of the same EM screen, 

with the location looking like this.  

$ORACLE_INSTANCE/bifoundation/OracleBIPresentationServicesComponent/$COMPONENT_NAME/catalog/XXXXXX.  

Change the path to point to SampleApp Webcat so the location looks like this.  

$ORACLE_INSTANCE/SampleAppWebcat 

2.6.4.1.1.3 Apply changes 

 Click on 

Apply (top 

right corner 

of screen) 

 

 Click on 'Activate Changes‟ 

2.6.4.2 Enable Caching  

EM screen also offers you the possibility of turning OBIEE cache on or off. Leaving cache set to off will allow to see physical SQL 

logs for every query. Performance should not be of issue with the low data volume in the sample database. To Switch Cache off, 

click on tab „Capacity Management‟, sub-tab „Performance‟. Disable cache there and click on Activate changes.  

2.7 Configuring SampleApp Mapviewer Content 

Confirm that WLS server and WLS managed servers are up and running, and make sure OMPNCTL is not running (neither OBIS 

nor OBIPS are running). Stop BI Server and Presentation Server if they are running. 

2.7.1 mapViewerConfig.xml Edits 

Open the Mapviewer console (Login with the username/password that you provided while installing the product). 

Select Management option and click on configuration under „Manage MapViewer‟ page. This will open the mapViewerConfig.xml 

on your setup. Example: http://10.146.219.202:7001/mapviewer/faces/admin/admin.jspx 

Make the following change to the xml file: 

http://10.146.219.202:7001/mapviewer/faces/admin/admin.jspx


2.7.1.1 <security_config> 

In the <security_config> property of this file, make the following changes: 

 

Change the <proxy_enabled_hosts> property to the following :  

Substitute the hostname, IP address and port to the correct values on your setup.  

(NOTE:- There are 4 entries here. Two of them refer to the hostname and while two refer to the ip address of the machine where 

OBI is installed. Update all 4 entries to the hostname and ip address on your setup) 

 

 <proxy_enabled_hosts> 

 http://localhost:7001/mapviewer,http://localhost:7001/,http://10.178.221.72:7001/,http:// 10.178.221.72:7001/mapviewer 

 </proxy_enabled_hosts> 

 

Substitute any entries with these tags with the property entries below: If the entry already exists, confirm that the value is as 

shown below. If the entry does not exist, then add a new entry with the value given below. 

  <disable_direct_info_request> true </disable_direct_info_request> 

  <disable_info_request> true </disable_info_request> 

  <disable_csf>true</disable_csf> 

  <enforce_security_role> true </enforce_security_role> 

 

2.7.1.2 Predefined Data Sources 

At the end of the file, in the section named 'Predefined Data Sources', add the following data source entry. Replace the ipaddress, 

sid and port to the correct values of the database where the obiee_navteq schema has been created in the above steps. 

 

<map_data_source name="OBIEE_NAVTEQ_Sample" 

                   jdbc_host="10.229.147.238"  (use your db ip) 

                   jdbc_sid="orcl"    (use your db sid) 

                   jdbc_port="1521"   (use your db port) 

                   jdbc_user="obiee_navteq"                    

                   jdbc_password="!obiee_navteq" (use your selected password if different from OOB) 

                   jdbc_mode="thin" 

                   number_of_mappers="3" 

                   allow_jdbc_theme_based_foi="false" 

   /> 

 

Make sure all tags have been closed correctly and also make sure the above data source is not within the comments section 

(ensure that it is outside the comments section which is represented by  <!-- ..   -->) 

2.7.1.3 Save & Restart, Verify 

Click on Save & Restart button at the bottom of the file. Once it is restarted, Click on Data sources. You should now see 

OBIEE_NAVTEQ_Sample as an entry there.To confirm that the Mapviewer configuration is working, choose the Map Tile Layer 

called OBIEE_WORLD_MAP and click on 'View Map / Manage tiles' option. In the window that opens up, click on the 'Show Map' 

button. This should display the world map.  Repeat the steps for the Map Tile Layer called OBIEE_WORLD_MAP_FAST and 

confirm that the world map is displayed. 



2.7.2 Configuring Google Maps 

 

 Click on “Manage Tile Layers”. Click “Create” 

 

 

 Select Google Maps as Tile Layer Type 

Select “Google Maps” as type of map source. Click “Continue” 

 Enter “key” 

On the tile layer properties page, enter a valid value for the key. Select a 

data source from the Data Source dropdown. Click “Submit”. Test the tile 

layer by selecting the tile layer from the list of layers and click “View Map / 

Manage Tiles” 

2.7.2.1 Obtaining a Google Maps API Key 

Open URL http://code.google.com/apis/maps/signup.html in your browser. Log in to Google with a google.com user id. Read the 

Terms & Conditions. Enter the URL of your web site. Click “Generate API Key”. Copy and store this key value in a safe place. 

Use this key value when creating tile layers in MapViewer. 

http://code.google.com/apis/maps/signup.html


2.7.3 Known mapviewer error 

On some of the dashboard pages with maps, you might see the error Fail to load “/mapviewer/fsmc/jslib/oraclemaps.js”. 

An immediate workaround to this problem is to refresh the screen and the map should show up. 

 

To fix it permanently, make the following changes to the mapviewer configuration. Edit the file web.xml located under the folder  

/InstallHome/Oracle_BI1/bifoundation/jee/mapviewer.ear/web.war/WEB-INF 

In this file, search for the string „mime‟. Insert the full tag shown below just after the first <mime-mapping> tag, as shown in the 

picture (tag to insert is highlighted)    

   

<mime-mapping>  
<extension>js</extension>  
<mime-type>text/javascript</mime-type>  

</mime-mapping> 

 

 

 

 

 

 

 

Save the file. Clear browser cache and restart WLS services. This should fix the problem. 

NOTE:- Note that this has not yet been officially tested with OBIEE 11.1.1.5.0 by QA, so this MapViewer patch is provided on an 

as-is basis 

2.7.4 Removing drop-shadow effect on graphs 

By default, whenever a chart is created, there is a drop-shadow effect on it. This property makes it difficult to read some of the 

SampleApp charts. In order to turn it off this property, edit the file dvt-graph-skin.xml from the following location on your 

installation.  

  \InstallHome\Oracle_BI1\bifoundation\web\msgdb\s_blafp\viewui\chart 

 Edit the <Graph> tag, add the attribute visualEffects="NONE". (Do not remove the rest of the contents in the file). After 

editing, the contents should look like this.  

 <Graph visualEffects="NONE">  

<SliceLabel>  

   <!-- decimalDigitUsed is false here so that non-percentage pie slices do not pick up this value 

          The DVTChartProcessor sets decimalDigitUsed to true if this is a percentage pie slice --> 

   <ViewFormat decimalDigit="2" decimalDigitUsed="false"/>  

</SliceLabel>   

</Graph> 

 Save the file. 

2.7.5 Start BIEE services and login  



2.7.5.1 Starting services From EM screen 

 Login to the EM administration screen using the url http://localhost:7001/em 

(Replace the hostname and port number based on your setup). Use the login you 

created in BIEE installation to log in.  

 Expand 'Business Intelligence' node on the left and choose Coreapplication.  

 Click on the Overview Tab,  

 Click on blue button „Restart‟ (or green button 

„Start‟) under the Manage System category, 

middle of screen, 

 Click yes on dialog box to confirm the move. 

Wait for message that confirms successful 

restart. 

 

 

 Note : 

If starting using EM is not successful and complaining about OPMNCTL not up, please follow starting process with OPMNCTL 

2.7.5.2 Start services using OPMNCTL 

You don‟t need to complete this step if you have started the services successfully using EM (previous step) 

 Open a command prompt, navigate to \InstallHome \instances\instance1\bin  

 run “opmnctl status, this will show you status of all the OBIEE core services 

 run “opmnctl startall” or “opmnctl stopall” depending on your need.  

2.7.5.3 Login into http://localhost:7001/analytics 

The list of possible users is given in section Error! Reference source not found. 

2.7.5.4 Verify the Spatial & Mapviewer connection 

 Login to Answers. 

 Go to Administration --> Manage Map Data.  

 Click the "Layers" tab. 

 Click the "Add Layer" link. The data source dropdown at the top should contain at least one entry, one of which should 

be "OBIEE_NAVTEQ_Sample". 

 Click the OBIEE_NAVTEQ_Sample entry. It should populate the listbox with all available layers in the data source 

"OBIEE_NAVTEQ_Sample". 

 Check the tabs "Background Maps" and "Images" and ensure that you can see "OBIEE_NAVTEQ_Sample" entry. 

 

 If you do not see "OBIEE_NAVTEQ_Sample" entry, try one or more of the following.  

   - Clear your browser cache 

   - Restart Mapviewer service 

   - Restart OPMN service 

   - Leave the system idle for a few minutes after making the above configurations. 

Now confirm that you can now see "OBIEE_NAVTEQ_Sample" entry under "Layers", "Background Maps" and "Images" tab. 

http://localhost:7001/analytics


2.8 Deploying SampleApp BI Publisher Content 

The BI Publisher Samples depend on a few data sources. Some of these are set up as part of the installation.   Others will require 

manual configuration through the BI Publisher Admin pages.  We will cover all here. 

 Note 

The Oracle Sample OE schema needs to be 

installed as part of the database samples in 

order for some of the BI Publisher examples to 

work. 

 

 From the web UI – http://localhost:7001/analytics -- logged in as 

a user with Admin permissions, click on the Administration link. 

 Next, click on Manage BI Publisher. 

 

This will open a single Administration tab and six groups of links e.g. in the upper left side 

you should see the  

Data Sources 

 From Administration, click the link for JDBC Connection 

 

2.8.1 Create the “BISAMPLE” JDBC 

connection.   

Click on the Add Data Source and provide details of your 

database where BISAMPLE schema was installed,Use the 

“Test Connection” button to ensure it is connecting correctly. 

Note that you must name the JDBC connection exactly as 

BISAMPLE for many of the reports to run. 

 

2.8.2 Create the “Essbase” JDBC connection 

Go to the OLAP tab under Data Sources. Click on Add Data 

Source and provide details of your Essbase database where you 

sample cubes are restored. Use the “Test Connection” button to 

ensure it is connecting correctly. Note that you must name the 

JDBC connection exactly as Essbase for many of the reports to 

run. 

 

2.8.3 “Oracle BI EE” JDBC connection 

Inspect the “Oracle BI EE” JDBC connection.  Use the “Test Connection” button to ensure it is connecting correctly. 



2.8.4 “demo” data source 

NOTE:- The OE schema referenced below needs to 

be as part of the database samples schema 

installation.  

 

Edit the “demo” data source to use a real database 

connection.  You will need to configure “demo” to 

use an oe (Order Entry) schema available in all 

Oracle Databases.  You may need to unlock the OE schema.  Like above, the data source needs to remain “demo”. 

 

Inspect the File data source “demofiles”.  From the operating system see that there are .xml demo files present in the directory. 

2.8.5 Grant access to data sources to BI Author & BI Consumer roles 

For users to be able to see data when they run BI Publisher reports, the BI Author & BI Consumer roles must be granted access 

to data sources.  

  

 Under Administration URL in OBIEE web interface, click on „Manage BI 

Publisher‟ link 

 Then click on the link „Security Center‟ and select Roles and Permissions. 

 In the Add Data Sources column, click the “key” icon for the BI Author role. 

 

 Under Database Connections, add the BISAMPLE, Oracle 

BIEE, & demo data sources to the Allowed Data Sources list. 

 

 

 

 

 

 

 

 

http://10.228.235.83:9704/analytics/saw.dll?bipublisherEntry&Done=%2fanalytics%2fsaw.dll%3fAdmin&Action=admin
http://10.228.235.83:9704/analytics/saw.dll?bipublisherEntry&Done=%2fanalytics%2fsaw.dll%3fAdmin&Action=admin


 Under File Directories, add demo files to the Allowed 

Data Sources list. 

 

 

 

 Under OLAP connections, add Essbase to the Allowed 

Data Sources list 

 Click Apply. 

 Repeat steps 2 – 5 to grand access to the BI Consumer role to the data sources BISAMPLE, Oracle BIEE, demo, 

Essbase & demo files. 

 



3 SampleApp Action Framework Content  

 

This paragraph describes how to deploy Action Framework SampleApp content with BIEE services.  

 

From your SampleApp install folder, navigate to subfolder „Actions‟. This folder contains all the necessary files for deploying 

SampleApp Core content. 

3.1 Prerequisites 

All the steps to deploy SampleApp Core content successfully completed. IN PARTICULAR: IT IS REQUIRED THAT YOU HAVE 

PROPERLY IMPORTED FMW_Users_Definition as part of the Sample App core install process. Make sure you have completed 

this step as described in the paragraph 2.4 of this document. To validate that this setup is properly active, you should be able to 

login in Answers with credentials abell/Admin123. 

3.2 Deploying ActionSamples.ear  

3.2.1.1 OPTIONAL: customizing Sample Actions services (editing Jdev Project) 

NOTE: the file " ActionsSamples V3 (Jdev_project).zip” can be found in the SampleApp install folder \Actions\ActionsDefinitions 

This is the Jdev source project that was used to create this .ear file. This Jdev project is not needed to run SampleApp, but is 

included as part of the install incase user needs to customize the Sample actions services, or is interested in seeing the details of 

their setup. 

3.2.2 Deploying Sample Actions services in WLS 

 Logon to weblogic Administration console using the url http://hostname:7001/console (use your hostname instead). Use 

the username/password that you provided while initial install of the product. 

 Click on Deployments link under 'Domain Structure'. Click on the Install button on the Deployments page on the right. (If 

the Install button is not enabled, then click on the 'Lock & Edit' button under Change Center on the left) 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

 

 In the first screen, it lets you locate the deployment to install. Modify that the path to the following 

\InstallHome\instances\instance1\bifoundation\OracleBIServerComponent\coreapplication_obis1\sample\SampleAppFiles\Actions 

 Choose the ActionSamples.ear    

 

 Click on Next. The next screen lets you Choose the 

targeting style. Choose the default option 'Install 

this deployment as an application' and click on 

Next. 

 

  

 In the Optional Settings screen, enter ActionSamples in the Name 

field. For the remaining options, go with the default selections. and 

click Next.  

 In the final screen, click on Finish.  

 When you see the Overview page for the Actionsamples, click on 

Activate Changes button under Change Center on the left.  

 

 

 Now click on the Deployments link. In the Deployments page, 

confirm that you can see the entry for ActionSamples that you 

just created. Choose ActionSamples, click on Start->Servicing 

All Requests option.  

 

 

3.2.3 Editing ActionSamples WSIL files with correct URLs 

3.2.3.1 Identifying ports used by your own install 

On your installation, verify the port number on which WLS and bi_server1 are listening. 

The weblogic Administrator console is by default running on 7001. This could be 

different on your setup. To check the port number, click on Servers.   

 

Check the 'Listen Port' field. If this is 7001, then you do not need to perform the following 

steps. However if different, then go through the following steps.    

 

 

3.2.3.2 Open inspection.wsil from  

/InstallHome/user_projects/domains/bifoundation_domain/servers/bi_server1/tmp/_WL_user/ActionSamples/XXXXXX/war/ 

Look for the following entry : location="http://localhost:7001/ActionSamples/OrderProcessPort?wsdl" 



Replace the port number with the WLS port on your setup. After making the update, confirm that you can paste the url on a 

browser and see the definition. 

3.2.3.3 Open Builtin.wsil from 

/InstallHome/user_projects/domains/bifoundation_domain/servers/bi_server1/tmp/_WL_user/ActionSamples/XXXXXX/war/ 

Look for the following entry : location="http://localhost:7001/analytics/saw.dll?wsdl" 

Replace the port number with the ANALYTICS port on your setup. After making the update, confirm that you can paste the url on 

a browser and see the definition. 

3.2.3.4 Open secure.wsil from  

/InstallHome/user_projects/domains/bifoundation_domain/servers/bi_server1/tmp/_WL_user/ActionSamples/XXXXXX/war/ 

Look for the following entry : location="http://localhost:7001/ActionSamples/CreditRatingPort?WSDL" 

Replace the port number with the ANALYTICS port on your setup. After making the update, confirm that you can paste the url on 

a browser and see the definition. 

3.3 Adding Required Credentials  

3.3.1 Option 1 : Use Python Script 

Open a command prompt, navigate to the folder Action_Definitions and execute the following command.  

 

/InstallHome/oracle_common/common/bin/wlst “CreateCred.py” username password t3://localhost:7001 

Egg:- On a Linux environment , the command would look like this.  

/scratch/laliv/obi11g/oracle_common/common/bin/wlst.sh "CreateCred.py" weblogic password1 t3://localhost:7001  

NOTE:  

If the CreateCredentials.py is not in the directory current directory, then provide the full path to the file.  

Replace username and password with you OBIEE install login username and password.  

If the credentials already exist on your setup, then the above command will fail with an error message that the credential already 

exists.  

 

Once the script executes successfully, 

it should create the required 

credentials. To confirm, log into EM at 

http://localhost:7001/em.  

 

Expand the tree menu on the left to 

show items under Weblogic domain, 

then right click on the on the 

bifoundation_domain, select the 

Security menu from the choices, then 

select Credentials 

 

 

 

 

 



 

 

 

In the credential store config screen, confirm that you have the following entries created.  

 

MapName   Keyname  Type 

oracle.wsm.security  keystore-csf-key Password 

oracle.wsm.security  enc-csf-key  Password 

oracle.wsm.security  sign-csf-key  Password 

oracle.bi.actions  JNDIUser      Password 

oracle.bi.enterprise  wsil.browsing  Password 

3.3.2 Option 2 : Add Required Credentials Manually (Alternate Method) 

It is highly recommended that you add the credentials by following the method described in section 3.2.4 (which uses a script to 

create the credentials). If that method did not succeed for some reason and you wish to create the credentials manually, then 

follow the steps given below. 

Log in to EM at http://localhost:7001/em. Expand the tree menu on the left to show items under Weblogic domain, then right click 

on the on the bifoundation_domain, select the Security menu from the choices, then select Credentials 

3.3.2.1 New Keys in oracle.wsm.security 

In the credential store config screen, click on the button marked “+ Create Map”, and add a new map named oracle.wsm.security 

Next click on “Create Key”. You should add the following 4 keys to the oracle.wsm.security map: 

    Keyname             Type         Username     Password 

    keystore-csf-key     password     owsm         Admin123 

    enc-csf-key         password     orakey         Admin123 

    sign-csf-key         password     orakey         Admin123 

3.3.2.2 New Keys in oracle.bi.actions 

Repeat previous step for a map called oracle.bi.actions, and create one single key under this map : 

    Keyname         Type         Username     Password 

    JNDIUser      password     abell         Admin123 

3.3.2.3 New Keys in oracle.bi.enterprise 

In the existing map named oracle.bi.enterprise, create keyname wsil.browsing.  

    Keyname         Type         Username     Password 

    wsil.browsing     password     abell      Admin123 

 

3.4 Configuring OBI EE Actions Framework files 

3.4.1 Edit ActionFrameworkConfig.xml 

Open ActionFrameworkConfig.xml from  

/InstallHome/user_projects/domains/bifoundation_domain/config/fmwconfig/biinstances/coreapplication 



3.4.1.1 Port Entry and Aliases 

Look for the entries 7001 and replace it with the 

analytics port number on your setup. (only if 7001 is 

not the port number on your setup). 

Confirm that all the urls setup in to the  Alias tag 

point to correct urls, otherwise fix them with correct 

port and machine name. 

 

3.5 Actions Commentary setup in Oracle Application Express (APEX) 

Oracle Application Express needs to be installed and configured for the Commentary dashboard page under 4.1 Actions 

dashboard in SampleApp webcat to work. This dashboard page showcases how you can add and modify comments on a report 

using Application Express.  

3.5.1 Install pre-requisites 

Oracle Application Express 4.0.1 (or above) needs to be installed on your database server machine. This can be downloaded 

from http://www.oracle.com/technetwork/developer-tools/apex/downloads/index.html  

Once this is done, install APEX listener 1.0.2 (or above) and configure it to your APEX on your database. APEX Listener can be 

downloaded from http://www.oracle.com/technetwork/developer-tools/apex-listener/downloads/index.html 

APEX listener can be configured to run on a standalone mode or can be deployed within your WLS. Once the APEX listener is 

configured and running, note the port number on which it runs. This information needs to be updated in a few places as describe 

in section 3.5.2.2 

3.5.2 Import Commentary Workspace within APEX 

3.5.2.1 Login to APEX Admin 

Login to your APEX environment using the url similar to http://localhost:8080/apex/apex_admin 

NOTE:- Replace the hostname and the port according to your setup. Enter the admin username and password on your setup.  

Manage Workspaces 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

http://www.oracle.com/technetwork/developer-tools/apex/downloads/index.html
http://www.oracle.com/technetwork/developer-tools/apex-listener/downloads/index.html
http://localhost:8080/apex/apex_admin


 

 

Next, click on Manage Workspaces and then Import Workspaces 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Browse to COMMENTARYWSpace.sql which can be found on your SampleApp install files under folder 

Actions\CommentaryArtifacts 

 

 

 

 

 

 

 

 

 

 In the Install Workspace screen, choose Re-use Existing schema as Yes and choose BISAMPLE as the schema. 

 

 

 

 

 

 

 

 

 

Click on the Check box and click Next 

 

 

 

 

 

 

 

 

 

 



Click on Install Workspace. This should install the Commentary workspace.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Login to COMMENTARY Workspace with admin/welcome1. You may be prompted to change the password when you 

login for the first time. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Go to Application Builder 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Select „Import‟ to Import the Commentary application 

 Re-Use the Application ID from the file (If you already have an Application with ID 100 installed on your setup, then 

choose „Auto Assign New Application ID‟. If you choose a new Application ID, then update this new ID along with the 



APEX listener updates described in section 3.5.2.2. Instead of 100 that is used in the URL for APEX, use the Application 

ID that is generated when you import your application.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Test by Running the Commentary application using username/password admin/welcome1 (you will not be able to add a 

comment here). 

 Check that you can see the APEX form by running the Commentary Application. 

 

3.5.2.2 Update Apex listener settings 

NOTE:- If you imported the Application with a different ID (other than the default 100), then replace 100 in the following sections 

with the appropriate Application ID in your environment.  

 

The port on which APEX listener is running on your setup needs to be updated in the following places. 



1) Edit UserScripts.js from the following two locations  

/installhome/user_projects/domains/bifoundation_domain/servers/AdminServer/tmp/_WL_user/analytics_11.1.1/silp1v/war/res/b_

mozilla/actions 

and 

/installhome/ Oracle_BI1/bifoundation/web/app/res/b_mozilla/actions 

 

Look for the following line  

targUrl = "http://localhost:8080/apex/f?p=100:1:::::P1_COMMENT_ID:" + 

argValue; 

Replace the servername and the port to the appropriate values of the 

APEX listener on your setup. Also, if you application ID is not the default 

value of 100, then update it to the right application ID value. 

 

2) In the SampleApp folder, go the following location  

/Shared Folders/4. Actionable Intelligence/Actions/Functional 

Examples/Commentary and Annotations 

Following Actions need to be edited with the correct APEX listener settings  

- Edit the „Add a Comment‟ action. Click on Options. 

Go to Action Results tab. In the Dialog text, edit the APEX listener 

address to point to your server and port.  

-  Edit the „Edit Comment‟ action. Update the URL to 

point to your APEX listener server and port.  

3.6 Restarting Services and Verifying the Install 

 Restart WLS 

 Restart OBIEEservers via OPMNCTL or via EM 

 Login to analytics. Go to the catalog, 4. Actionable Intelligence and Actions folder within that.  

 Execute any of the action saved in the folders by providing the appropriate input values.  



4 SampleApp Essbase Content (Optional) 

 

This paragraph describes how to deploy the SampleApp Oracle OLAP content. This deployment is optional and comes in addition 

to SampleApp Core deployment. 

 

From your SampleApp install folder, navigate to subfolder „Essbase‟. This folder contains all the necessary files for deploying 

SampleApp ESSBASE content 

4.1 Prerequisites 

All the steps to deploy SampleApp Core content successfully completed. 

Access to an Essbase server installed and configured. 

 

NOTE: to have full features of OBIEE integration with Essbase working, you need to run Talleyrand version of Essbase server, or. 

If you do run earlier Essbase server release, you need to apply appropriate Essbase patch to fix integration bugs, otherwise not 

all BIEE features will work. Refer to OBIEE/ Essbase SRSP for more details, or contact PM for more details. 

4.2 Creating Essbase Data sources 

4.2.1 Building the Sample Cube 

To create the application, please perform the following steps: 

 

1. Open Essbase Administration Services 

2. Select and expand the target Essbase Server. 

3. Select the „Applications‟ node. 

4. On the toolbar select File > New > Aggregate Storage Application 

5. Enter “BISAMPLE” as the Application name 

6. On the toolbar select File > New > Database 

7. Select “BISAMPLE” from the list of Applications 

8. Enter “Sample” as the database name and select OK 

9. Select File > Open  

10. Navigate to the file location of the „sample.otl‟ file 

11. Select the „sample.otl‟ file and select OK. 

12. Select File > Save As 

13. Navigate to the „Essbase Server‟ tab in the dialog 

14. Double-click on the “BISAMPLE” application in the displayed list 

15. Double-click on the “Sample” database 

16. Double-click on “Sample.otl”  

17. Select „Yes‟ to confirm replace 

18. Select „Yes‟ to view the outline 

19. In the navigation pane, locate the “Sample” database under the “BISAMPLE” application 

20. Right mouse on the “Sample” database and select „Load Data‟. 

21. Select „Find Data File‟ from the dialog 

22. Navigate to the file location of „data.txt‟ (which is contained inside data.zip)  



23. Select „data.txt‟ and select OK 

24. Select OK to load the data 

4.2.2 SampleGL Cube 

4.2.2.1 Building the cube 

1. Select the „Applications‟ node. 

2. On the toolbar select File > New > Block Storage Application 

3. Enter “BISAMPL2” as the Application name 

4. On the toolbar select File > New > Database 

5. Select “BISAMPL2” from the list of Applications 

6. Enter “samplegl” as the database name and select OK 

7. Select File > Open  

10. Navigate to the file location of the „sample.otl‟ file 

11. Select the „samplegl.otl‟ file and select OK. 

12. Select File > Save As 

13. Navigate to the „Essbase Server‟ tab in the dialog 

14. Double-click on the “BISAMPL2” application in the displayed list 

15. Double-click on the “samplegl” database 

16. Double-click on “samplegl.otl”  

17. Select „Yes‟ to confirm replace 

18. Select „Yes‟ to view the outline 

19. In the navigation pane, locate the “samplegl” database under the “BISAMPL2” application 

20. Right mouse on the “samplegl” database and select „Load Data‟. 

21. Select „Find Data File‟ from the dialog 

22. Navigate to the file location of „samplegl.txt‟ (which is contained inside data.zip)  

23. Select „samplegl.txt‟ and select OK 

24. Select OK to load the data 

4.2.2.2 Saving Essbase Calc scripts for SampleGL 

The calculation script (WhatIf.csc) and the excel sheet (Eden Demo.xls) are required for what-if analysis on SampleGL. The 

calculation script needs to be deployed on your Essbase server (where SampleGL outline has been created according to step 4.3 

in SampleApp deployment guide) by following the steps given below. 

In the EAS console, select File > Open 

Select the File System tab in the dialog and navigate to the location of WhatIf.csc 

Highlight WhatIf.csc and select OK 

In the EAS console, select File > Save As 

Select the Essbase Server tab in the dialog and navigate to the SampleGL cube 

Specify WhatIf as the file name and select OK  

 

4.2.2.3 Possible issue : Essbase Sample Application not available in Smartview 

After you install the SampleApp build, it is possible that you are not able to see the applications like SampleGL within Smartview. 

In order to fix this, perform the following steps.  

 

 Open Excel, select SmartView tab and click on "Open". The SmartView window will be shown on the right.  



 

 

 

 

 

 

 

 

 

 

 

NOTE: If you get an error message here (Unable to connect to the provider) please do the following: 

 Start Essbase Administration Services Console and logon. 

 Right-click on Provider Servers and select "Edit Authenticating Essbase Server".  

 Go back to Excel and click "Next" again. You now should see the following: 

 

 

 

 

 

 

 

 

 

 

 

 Click on the + sign and authenticate with username and password to your Essbase server setup (Eg:- 

biadmin/welcome1).  

 After a successful connection you should now be able to see all Essbase applications/databases including BISAMPLE 

and SampleGL. Select Sample/Basic and select Next. 

 

 

 

 

 

 

 

 

 

 

 

 Supply a name and description and click Finish. 

 Now you can select the provider service from the list of private connections. 

 

 

 

 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Select Sample / Basic and connect.  

 Now select "Ad hoc analysis" to query the Essbase cube.  

4.3 Creating Cube Source for Essbase BIEE integration example 

This section provides instructions for configuring OBIEE 11g so you can use Action Framework to execute an Essbase Calc 

Script from a Dashboard.  Additionally, the package enables direct writeback to an Essbase cube via the OBIEE 11g front end to 

conduct seamless what-if analysis. 

4.3.1 Deploy EssbaseCalc.war in WLS 

 Login to the WLS Console 

 Click on Deployments in the left panel 

 

 

 

 

 

 

 

 

 

 Click Lock & Edit 

 Click Install to start the Install Application Assistant 

 

 

 

 



 

 Go to the folder  

\InstallHome\instances\instance1\bifoundation\OracleBIServerComponent\coreapplication_obis1\sample\SampleAppFile

s\Actions 

Select EssbaseCalc.war and click Next.  

 

 

 

 

 Choose „Install this deployment as an application‟ and click next 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Choose the following security option and click Next 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Accept the defaults. Click Next 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Accept the defaults. Click Finish 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Note the Context Root. This is the path from your bi_cluster (http://localhost:7001). You will be running a .jsp, so the full 

URL to test the application (see below) will be: http://localhost:7001/essbasecalc/calc.jsp 

 Click on Activate Changes 

 After a few moments, you should get a message at the top of the screen: 

 

 

 

 

 

 

 Next, click on Deployments in the left panel 



 

 

 

 

 

 

 

 

 

 In the list of Deployed Applications, click Next until you find essbasecalc. Note that in the State column it says 

Prepared. Click the box next to it, click the Start button and select Servicing all requests 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Click Yes 

 Test the EssbaseCalc.war file from a Browser. Open a new browser window and enter the following URL: 

http://localhost:7001/essbasecalc/calc.jsp. You should see a screen similar to the following: 

http://localhost:7001/essbasecalc/calc.jsp


 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

4.3.2 Deploy Essbase Source Cube 

 Log into Essbase Administration Services. Open the BISAMPL2 application or, if it does not exist create a new Block 

Storage application called BISAMPL2. Once complete, create a database under it called Basic. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 In EAS, go to 'File'->'Open'.  Select your local File System and navigate to the unzipped package directory.  Open up the 

folder \ BISAMPL2\Basic and select Basic.otl. 

 Once you have the outline open, again go to 'File'->'Save As'. You are going to overwrite the default outline with the one 

provided in the package.  Make sure to select 'Essbase Server' and 'Basic'.'Basic.otl'. 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Open up your outline from the EAS panel to verify that is saved correctly.  You should see this 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Copy the calc scripts (.csc) and data.txt of the unzipped package folder (\BISAMPL2\Basic) to the following folder on 

your install \InstallHome\user_projects\epmsystem1\EssbaseServer\essbaseserver1\app\BISAMPL2\Basic.  DO NOT 

copy the .otl, you have already done this via the 'save as' process above. 

 Right click on the 'Basic' db in EAS.  Select Load data. 

 

 



 

 

 

 At the first prompt, select 'Find data file' 

 Select 'data.txt' from your essbase server BISAMPL2.Basic directory. 

 

 

 

 

 

 Run the data load.  You should see a success 

message like below.  This is a full data load, so no 

need to run a 'calc all' after. 

 

 



4.4 Configuration Settings 

4.4.1 RPD settings:  

4.4.1.1 Updating RPD variables 

Following session variables and init blocks are used by Essbase Option for connection pools setting. You must update the 

initiation of these variables to allow the RPD to properly connect. On the RPD click on Manage->Variables and update the 

following session variable and init block to appropriate values to connect to your databases : 

 

 Verify DUAL Cube Name (=BISAMPLE) - This variable holds the name of the Sample Essbase cube  

 Verify DUAL ESSB HOST - This variable holds the name or IP of Essbase host server 

  

 To edit the value of the variable init block,  

4.4.1.1.1.1 first click on “ Edit Data Source” button 

  

  

  

  

  

  

  

  

4.4.1.1.1.2 Then edit the SELECT statement so that it returns the correct string when it executes : 

 Click the Test button to confirm correct value is returned before clicking OK. 

4.4.1.1.1.3 Then, click the “Edit Data Target” Button 

 

Edit the Default Initializer field with the full hardcoded string with all correct values. This default initializer will be used by OBIEE 

server if previous SQL statement fails. 

 

4.4.1.2 Updating Passwords in connection Pools 

 

On the RPD, in the physical layer, edit each Essbase source connection pool and update the username and password to 

appropriate values to connect to your Essbase server.  



4.4.2 Catalog Edits 

Following reports need to be updated in the catalog to point to your Essbase server location with the appropriate username and 

password. 

/Shared Folders/8. Source Specific Features/8.2 Essbase/Writeback/  

Edit Expense Driver report. Go to the Criteria tab.  Edit the formula for the Writeback column  

 

 

 

 

  

Update the server address of your OBIEE environment, the essbase username and password in the following sections  

action="http://localhost:7001/essbasecalc/writeback.jsp (replace localhost with your ip address where OBIEE is deployed) 

value="password" (replace with your essbase server password) 

value=http://localhost:7001/analytics/saw.dll?Dashboard&PortalPath=%2Fshared%2F8.%20Source%20Specific%20Features%2

F_portal%2F8.2%20Oracle%20Essbase&Page=Writeback ( 

(replace localhost with your ip address where OBIEE is deployed) 

 

/Shared Folders/8. Source Specific Features/8.2 Essbase/Writeback/  

Edit the parameters of the actions adjust, clear and trend with the essbase server password that is setup on your environment  

 

4.4.3 Start BIEE services and login:   

Start BIEE services using one of the interfaces below : 

4.4.3.1 Start services using EM 

 Login to the EM administration screen using the url http://localhost:7001/em (Replace the hostname and port number 

based on your setup). Use the login you created in BIEE installation to log in.  

 Expand 'Business Intelligence' node on the left and choose Coreapplication.  

 Click on the Overview Tab,  

 Click on blue button „Restart‟ (or green button „Start‟) under the Manage System category, middle of screen, 

 Click yes on dialog box to confirm the move. Wait for message that confirms successful restart. 

4.4.3.2 Start services using OPMNCTL 

Open a command prompt, navigate to \InstallHome \instances\instance1\bin and run “opmnctl startall”. When the starting 

completes, login to Analytics using using your install login. 

 

 IMPORTANT Note :  

On your Essbase server, confirm that the Analytics Service Provider service is up. This is required for the essbase actions to 

work.  

4.4.4 Verify install 

You should be able to login into Analytics, select Essbase Sample Subject Area and run queries that return results from this 

subject Area.  

http://localhost:7001/analytics/saw.dll?Dashboard&PortalPath=%2Fshared%2F8.%20Source%20Specific%20Features%2F_portal%2F8.2%20Oracle%20Essbase&Page=Writeback
http://localhost:7001/analytics/saw.dll?Dashboard&PortalPath=%2Fshared%2F8.%20Source%20Specific%20Features%2F_portal%2F8.2%20Oracle%20Essbase&Page=Writeback


5 SampleApp TimesTen Content (Optional) 

This paragraph describes how to deploy the SampleApp TimesTen content. This deployment is optional and comes in addition to 

SampleApp Core deployment. 

5.1 Prerequisites 

TimesTen 11g server should be installed. If the TimesTen server and OBIEE are installed on two separate machines, then 

TimesTen 11g client should be installed on the OBIEE install machine, for making the required communication with TimesTen 

server 

TimesTen can be downloaded from http://www.oracle.com/technetwork/database/timesten/downloads/index.html 

5.2 Creating BISAMPLE_TT database 

To create BISAMPLE_TT database on TimesTen server, the first step is create the necessary DSN. Depending on whether your 

TimesTen server is on windows or Linux, follow the appropriate steps given below.  

5.2.1 DSN on Windows 

Using the ODBC Data Source Administrator, create a new System DSN. Choose TimesTen Data Manager as the driver and 

create a DSN with the following properties 

Data Source Name – BISAMPLE_TT 

Description -  BISAMPLE_TT 

Database Character Set – AL32UTF8 

Data Store Path + Name – Point this to a folder where you would want to install the BISAMPLE_TT datastore. 

NOTE:- This folder will need approximately 80Mb of free space 

Permanent Data Size – 40 

Temporary Data Size - 32 

 Leave the remaining parameters as default.  

5.2.2 DSN on Linux 

Open sys.odbc.ini file in the folder TimesTen install folder /TimesTen/tt1121/info. 

Add a new data source name in the section labeled [ODBC Data Sources] 

BISAMPLE_TT=TimesTen 11.2.1 Driver 

For this DSN entry, there is a corresponding set of database properties and attributes that need to be entered. The database 

attributes can be added anywhere after the [ODBC Data Sources] section. 

Note. The DSN name appears inside square brackets at the top of the DSN definition on a line by itself 

 

[BISAMPLE_TT] 

Driver=/scratch/plions/timesten/TimesTen/tt1121/lib/libtten.so 

DataStore=/scratch/plions/timesten/TimesTen/tt1121/ttdata/database/my_ttdb 

LogDir=/scratch/plions/timesten/TimesTen/tt1121/ttdata/logs 

PermSize=40 

TempSize=32 

DatabaseCharacterSet=AL32UTF8 

http://www.oracle.com/technetwork/database/timesten/downloads/index.html


 

Note:-  

Driver attribute = Point to the appropriate TimesTen install folder on your setup. 

DataStore = Point to the folder where you would want to install BISAMPLE_TT datastore. This folder will need approximately 

80Mb of free space. 

5.2.3 Loading BISAMPLE_TT schema  

 Connect to the BISAMPLE_TT either using ttIsql or sqldeveloper.  

CONNECT BISAMPLE_TT;  

 Create BISAMPLE_TT user by issuing the following command.  

CREATE USER BISAMPLE_TT IDENTIFIED BY BISAMPLE_TT; 

GRANT ADMIN TO BISAMPLE_TT;   

 Now disconnect and connect again using the BISAMPLE_TT user created.  

CONNECT  "DSN=BISAMPLE_TT;UID=BISAMPLE_TT;PWD=BISAMPLE_TT"; 

 Next, run the file BISAMPLE_TT_SCHEMA.SQL to create the tables. This file is located under the folder 

DataSources\TimesTen of your SampleApp install directory using the following command.  

RUN BISAMPLE_TT_SCHEMA.SQL 

 Once the tables are created, run the script BISAMPLE_TT_DATA.SQL to load the data. 

RUN BISAMPLE_TT_DATA.SQL 

5.3 ODBC Settings 

On your environment, OBIEE and the TimesTen server could be on the same machine or two different machines. If they 

are on two different machines, then you need to install TimesTen Client on the machine where OBIEE is installed. 

Depending on what your configuration is and whether it‟s a Windows setup or Linux, follow the steps from the 

appropriate section below 

5.3.1 Option 1 – OBIEE and TimesTen server on the same machine 

5.3.1.1 Windows 

If OBIEE and TimesTen are installed on the same Windows machine, then the DSN created in step 5.2.1 will be used in 

the OBIEE environment settings. No other DSN needs to be created. 

5.3.1.2 Linux 

If OBIEE and TimesTen are installed on the same Linux machine, edit odbc.ini file from the following location on your 

OBIEE install.  

 /InstallHome/instances/instance1/bifoundation/OracleBIApplication/coreapplication/setup 

Under the [ODBC Data Sources] section, make the following entry 

BISAMPLE_TT= TimesTen 11.2.1 Driver 

 

For this DSN entry, there is a corresponding set of database properties and attributes that need to be entered. The 

database attributes can be added anywhere after the [ODBC Data Sources] section. 

Note. The DSN name appears inside square brackets at the top of the DSN definition on a line by itself. 

 

 



[BISAMPLE_TT] 

Driver=/scratch/plions/timesten/TimesTen/tt1121/lib/libtten.so 

DataStore=/scratch/plions/timesten/TimesTen/tt1121/ttdata/database/my_ttdb 

LogDir=/scratch/plions/timesten/TimesTen/tt1121/ttdata/logs 

PermSize=40 

TempSize=32 

DatabaseCharacterSet=AL32UTF8 

 

Note:- Change the Driver, DataStore and LogDir paths to point to the appropriate location on your TimesTen server 

install location where BISAMPLE_TT schema was created. 

5.3.2 Option 2 – OBIEE and TimesTen server on different machines 

5.3.2.1 Windows 

If TimesTen server and OBIEE are installed on different machines, then it is required that TimesTen Client is installed on 

the machine where OBIEE is installed. Once the Client is installed, create a DSN called BISAMPLE_TT on this client 

machine to connect to the TimesTen server. To create the DSN using the ODBC Data Source Administrator, choose 

TimesTen Client 11.2.1 as the driver and create a DSN with the following properties 

 

Name – BISAMPLE_TT 

 Server Name or Network Address – Enter the name/ip of the TimesTen server machine 

Server DSN – BISAMPLE_TT (This name should appear in the drop down as this is the DSN created on the TimesTen 

server machine) 

 Connection Name – BISAMPLE_TT 

 User ID – BISAMPLE_TT 

 Password – BISAMPLE_TT 

 

Leave the other parameters as default. Click on Test Data Source Connection and Test Oracle TimesTen Server 

Connection and confirm that it connects to the server successfully. 

 

5.3.2.2 Linux 

If TimesTen Server is installed on a different machine, then it is required that TimesTen Client is installed on the 

machine where OBIEE is installed. Once the Client is installed, edit odbc.ini from the following location in your OBIEE 

install  

/InstallHome/instances/instance1/bifoundation/OracleBIApplication/coreapplication/setup 

 

 Under the [ODBC Data Sources] section, make the following entry 

BISAMPLE_TT= TimesTen Client 11.2.1 

 

For this DSN entry, there is a corresponding set of database properties and attributes that need to be entered. The 

database attributes can be added anywhere after the [ODBC Data Sources] section. 

Note. The DSN name appears inside square brackets at the top of the DSN definition on a line by itself. 

 

[BISAMPLE_TT] 

Driver = /scratch/plions/timesten/TimesTen/tt1121/lib/libttclient.so 

TTC_SERVER = TimesTenServerName 



TTC_SERVER_DSN = BISAMPLE_TT 

 

Note:- Change the Driver location to the appropriate path on your install.  

TTC_SERVER should point to the machine where TimesTen Server is installed. TTC_SERVER_DSN should be 

BISAMPLE_TT. 

5.4 OBIEE Environment settings 

The following settings need to be made within the OBIEE install location in order to enable OBI Server to communicate 

to the TimesTen server. (This needs to be done for both Windows and Linux install of OBIEE) 

 

Open user.sh from the following location on your OBIEE install.  

/InstallHome/instances/instance1/bifoundation/OracleBIApplication/coreapplication/setup 

 

 At the end of the file, add the following to include TimesTen folder location to the LD_LIBRARY_PATH variable.  

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/scratch/plions/timesten/TimesTen/tt1121/lib 

 

- Change the path to the appropriate location on your TimesTen installation.  

- If both OBIEE and TimesTen server are installed on the same machine, then this path will refer to the TimesTen server 

install location. 

- If OBIEE and TimesTen server are installed on different machines, then this path will refer to the TimesTen client install 

location.  

 

Restart OBI Server for these changes to take effect. After restarting, the dashboard pages on 8.6 Oracle TimesTen 

should start showing results.  

 



6 SampleApp MS SSAS Cube (Optional) 

This paragraph describes how to deploy the SampleApp MS SSAS Cube. This deployment is optional and comes in addition to 

SampleApp Core deployment. 

6.1 Prerequisites 

Access to an environment with Microsoft SQL Server 2008 is required, with Analysis Service installed. 

6.2 Attaching BISAMPLE SSAS cube 

 Open the Microsoft SQL Server Management Studio 

6.2.1 Copying database files 

 In your SampleApp install content folder, navigate to subfolder „DataSources/MS_SSAS‟, 

 Copy the whole subfolder named OBIEE_SAMPLE.0.db on your MS SSAS server machine. This folder should be 

located where you have MS_SSAS saving database content. By default, Analysis Services databases reside in : 

“<drive>:\Program Files\Microsoft SQL Server\<Instance Name>\OLAP\Data\” 

 

6.2.2 Attaching the Analysis Service Database Using SQL Server Management Studio 

 Connect to the Analysis Service Database Instance using SQL Server Management Studio, with a local SSAS admin 

login. 

 In the Object Explorer, right click Databases and then select the Attach option from the pop-up menu as shown in the 

snippet below.  



  

  

  

  

  

 In the Attach Database screen, you 

need to specify the folder where you 

saved the OBIEE_SAMPLE.0.db 

Analysis Services folder, and click OK to 

attach the database. 

 When back to the Object Explorer, click 

Refresh on the database list. 

  

6.2.3 Testing the Cube Content 

You should now be able to expand the cube objects and dimensions, as per the image below, and right click on any dimension to 

select the browse option and see some values directly from SQL Server Management Studio. 

6.2.4 Backup file 

If you prefer to use a restore command to create the cube on your SSAS server, a backup file of the OBIEE_SAMPLE cube is 

provided in the install files, the file name is : OBIEE_SAMPLE.abf 

 

6.3 RPD Configuration Edits  

6.3.1 Updating RPD SSAS Connection Pool 

On the online RPD, in the physical layer, edit the SSAS source connection pool and update the following fields to allow 

connectivity to your SSAS server : 



 

 

 URL : update with proper server name/IP in the url 

 Datasource : update with the catalog existing for your connection (you can see this by clicking properties on the server 

line on the SQL Server Management Studio) 

 Catalog : the name of the cube you just created, OBIEE_SAMPLE 

 User name and password : your local SSAS account credentials. 

 Check in the changes and save the RPD. 

6.3.2 Testing the connection 

You should now be able to query your SSAS cube by logging into OBIEE web UI and defining ad hoc queries on the SSAS 

related subject area. 

 



7 SampleApp ODI (Oracle Data Integrator) 

Content (Optional) 

This paragraph describes how to deploy the SampleApp Oracle Data Integrator content. This deployment is optional and comes 

in addition to SampleApp Core deployment. 

7.1 Prerequisites 

ODI 11gR1 (11.1.1.3) should be installed. This need not be on the same machine where OBIEE is installed.  

7.2 Configuring ODI Repository 

Copy the Data folder and its contents from Others\ODI into the machine where ODI is installed.  Open ODI Studio from your 

Oracle Data Integrator Install. Click on Connect to Repository link 

 

 

 

 

 

 

 

 

 

 

 

 

In the Oracle Data Integrator Login screen that comes up, click the  „+‟ icon to define a new repository connection information.  

 

 

 

 

 

 

 

 

 

 

Enter the following information 

Oracle Data Integrator Connection 

 Login Name – SAMPLEAPP_ODI 

 User – SUPERVISOR 

 Password – SUPERVISOR (If you have changed the default password during ODI install, provide the appropriate 

password here) 

 

Database Connection (Master Repository) 



 User – DEV_ODI_REPO 

 Password – DEV_ODI_REPO (If you have changed the default password in ODI_USERS.SQL, provide the appropriate 

password here) 

 Driver List – Oracle JDBC Driver 

 Driver Name – oracle.jdbc.OracleDriver 

 Url - jdbc:oracle:thin:@<host>:<port>:<sid> (Replace the host, port and sid with the appropriate parameters to the 

database where you have installed ODI_USERS. ) 

 

 IMPORTANT Note :  

If the url does not work in the format jdbc:oracle:thin:@<host>:<port>:<sid>, then specify it similar to this entry. 

jdbc:oracle:thin:@//localhost:1521/orcl 

 

Work Repository. Choose Master Repository Only 

Click on Test to confirm that the information provided is correct and click OK.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  Click on OK on the Login screen to connect 

to the Master repository 

 

 

 

 

 

 



Go to Topology navigator tab.  

 

 

 

 

 

 

 

 

Go to Repositories section. Expand Work Repositories and doubleclick on WORKREP.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Click OK on the dialog which says „Unable to connect to remote repository‟. Proceed to configure the work repository.  

 

 

 

 

 

 

 

 

 

 

Click on the Connection icon on the top left of the 

screen.  

 



 

 

 

 

 

 

 

 

 

 

 

In the connection details that show up, click on JDBC. Update the JDBC url to point to the database machine where you installed 

the ODI users.  Click on Test Connection to test the connection to the database.  

 

 

 

 

 

 

 

 

 

In the Test Connection dialog that appears, choose Physical agent as Local (No Agent) and click OK.  

 

 

 

 

 

 

 

 

 

Confirm that the connection is successful.  



 

Next, to configure the SampleApp database connection information, within the same Topology navigator tab, Physical 

Architecture->Technologies->Oracle->BISAMPLE. Double click on this BISAMPLE data server entry.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

In the definition details that come up on the right, click on JDBC, update the JDBC Url value to point to the database where 

BISAMPLE schema is installed. Test the connection. 

 

 

 

 

 

 

 

 

 

 

 

 



 

Next, to configure the file definition where SampleApp data files are located, go Physical Architecture->File->File Generic. Double 

click on the File Generic object within this.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

On the file definition details that come up on the right, update the Directory  (Schema) and Directory (Work Schema) values to 

point to the Data folder where you copied the files from the SampleApp install. (Step Error! Reference source not found.).  

 

 

 

 

 

 

 

 

 

 

 

Click on the Save icon.  

 

 

 

 

 

 



Next, disconnect from the Master repository and connect to the work repository. To do this, choose ODI->Disconnect 

“SAMPLEAPP_ODI” from the menu option.  

 

 

 

 

 

 

 

 

Save any pending changes.  

Again, click on the ODI menu and choose SAMPLEAPP_ODI as the login name. Click on the Edit icon.  

 

 

 

 

 

 

 

 

 

 

In the Repository Connection Information screen, change the Work Repository to WORKREP. Click OK and login. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



7.3 Loading SAMP_REVENUE_F table 

To execute the interface that will load the SAMP_REVENUE_F table from the data files that were copied in step Error! 

Reference source not found., do the following. 

 

In the Designer navigator, go to BIEE Sample->Load Fact->Packages->Load Sample Revenue. Right click and choose Execute.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Keep the defaults in the execution dialog and click ok. It will then show a Session started dialog to indicate that the interface is 

being executed.  

 

 

To view the execution results, on the same view, open the 

Operator Navigator by clicking View->ODI Operator. 

 

 

 

 

 

 

 

 

In the Operator navigator, expand the Session List->All 

Executions node to see the running session and the results. Confirm that the interface ran successfully.  Go to your BISAMPLE 

schema and verify that SAMP_REVENUE_F has 38 new records which have been inserted by this interface.  

 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

 Go to BIEE Sample->Load Fact->Interfaces->Load Sample Revenue. Double click on this entry. On the interface details that 

show up on the right, go to the execution tab. Confirm that the interface ran successfully.  Go to your BISAMPLE schema and 

verify that SAMP_REVENUE_F has 38 new records which have been inserted by this interface.  

 

To view the records that were rejected by the load process, in the 

designer navigator, go to the Models section. Navigate to BIEE 

Sample Apps->BIEE Sample->SAMP_REVENUE_F object. Right 

click on this object and choose Control->Errors.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

View the records that were rejected and the reason for rejecting.  



 

 



8 Additional Optional Configurations 

 

Deploying SampleApp custom style 

8.1 Deploying Custom Skin 

8.1.1 Prerequisites 

This step requires that Core content be properly installed, and particularly, that Weblogic Custom Service deployment (step 2.3) is 

properly completed. After exposing analyticsRes to WLS successfully, this directory can be used for custom skins. Follow the 

steps below for deploying SampleApp custom skin. 

8.1.2 Copying file in appropriate locations 

Copy all the content from folder „Others\Custom_Style\analyticsRes‟ into the following location in your BIEE install: 

\InstallHome\instances\instance1\bifoundation\OracleBIPresentationServicesComponent\coreapplication_obips1\analyticsRes 

 

 IMPORTANT Note :  

If some subfolders should already exist within analyticsRes folder on your system, increment their content with the files from this 

SampleApp deployment. 

8.1.3 Deploying the Custom Skin and Custom Style 

8.1.3.1 Custom Skin  

 Change the skin name in instanceconfig.xml 

<UI><DefaultSkin>Eden</DefaultSkin></UI> 

NOTE: For user specific skin, use NQ_SESSION.SKIN session variable 

 Restart the Oracle BI Presentation Services and clear the browser cache to see the changes.  

8.1.3.2  Few examples for extra skin customization 

 Change the logo: Replace the analyticsRes/sk_Eden/b_mozilla_4/oracle_logo.png and 

analyticsRes/sk_Eden/login/oracle_logo.png with the new png file. Try to keep the size of the new png file close to the 

original file (119X25 px). 

 Change the banner color: Modify HeaderContainer class in analyticsRes/sk_Eden/b_mozilla_4/common.css 

.HeaderContainter {..; background-color: #006600; ..} 

 Change the Tabs color (for dashboard page) in a dashboard: Modify the tab images (*.gif) in 

analyticsRes/sk_Eden/b_mozilla_4/uicomponents/obips.TabBar 

NOTE: If the uicomponents directory does not exist in analyticsRes/sk_Eden/b_mozilla_4 then create the uicomponents directory 

and copy the obips.TabBar from ORACLE_HOME/bifoundation/web/app/res/b_mozilla/uicomponent/obips.TabBar. Delete *.js 

and *.xml files. 

 Change the body color of the home page: Modify the background color of the body in 

analyticsRes/sk_Eden/b_mozilla_4/home.css 

body{..; background-color: #006600; ..} 

 Change the alert color: Modify the HeaderAlerts class in  analyticsRes/sk_Eden/b_mozilla_4/common.css 

.HeaderAlerts a:hover{..; color:#FF7777; ..} 



 Change the header bar separator line: Modify the HeaderBarSeparator class in 

analyticsRes/sk_Eden/b_mozilla_4/common.css 

.HeaderBarSeparator{..; border-top: 1px solid #005500; ..} 

 Change the background color of the dashboard name:  Replace the analyticsRes/sk_Eden/b_mozilla_4/l1_seltab_bg.gif 

with the new image. Make sure the size of the new image is the same as the old one. 

 Change the header spacer line: Replace the analyticsRes/sk_Eden/common/header_spacer_bg.gif with the new image. 

Make sure the size of the new image is the same as the old one. 

 Change the background color of the dashboard page edit and help icon: Replace the 

analyticsRes/sk_Eden/b_mozilla_4/l2_spacer_bg.gif with the new image. Make sure the size of the new image is the 

same as the old one. 

NOTE: The path of this image is hard coded in DashUpperContainer class in portalcontent.css file of the chosen style. This is a 

bug and is being fixed. For now, change this class to reflect the Eden skin (sk_eden). 

 Change the status icon next to Sign Out (top right corner): Replace the 

analyticsRes/sk_Eden/common/page_lev_connected.gif with the new image. Make sure the size of the new image is the 

same as the old one. 

 Change the menu bar separator line: Replace the menubar_gSeparator.gif in 

analyticsRes/sk_Eden/b_mozilla_4/uicomponents/obips.UberBar 

NOTE: If the uicomponents directory does not exist in analyticsRes/sk_Eden/b_mozilla_4, create the uicomponents directory and 

copy the obips.UberBar from ORACLE_HOME/bifoundation/web/app/res/b_mozilla/uicomponent/obips.UberBar. 

 Change the color, font and left margin of the brand name text (next to the logo): Modify the HeaderBrandName class in 

analyticsRes/sk_Eden/b_mozilla_4/common.css and appname class in analyticsRes/sk_Eden/login/login.css 

.HeaderBrandName{..; color:#007700;font-family:Arial; left:120px; ..} 

.appname{..; color:#007700; font-family:Arial; ..} 

8.1.3.3 Deploying Custom Style 

The same analyticsRes directory can be used for a custom style. Files have already been copied into the analyticsRes directory 

during step 8.1.2, to change the style, just edit Dashboard Properties and pick Eden Style. 

NOTE: For user specific style, use NQ_SESSION.STYLE session variable  

You may need to restart the Oracle BI Presentation Services and clear the browser cache to see the changes.  

As an example of extra style customization : Change the background color of the pivot table header: Replace the 

analyticsRes/s_Eden/viewui/pivot/ptgrd_overly.png with the new image. Make sure the size of the new image is the same as the 

old one. 

8.1.3.4 Deploying Custom Message 

Custom messages are also be stored in the same analyticsRes directory. Files have already been copied into the analyticsRes 

directory during step 8.1.2.  

As an example: Change the brand name text –  

Create the message directory for the required language (English language here).  

Create CompanyName.xml and add the text within kmsgHeaderBIBrandName tag: 

<WebMessageTables xmlns:sawm="com.siebel.analytics.web/message/v1"><WebMessageTable protect="true" export="true" 

translate="false" system="ProductMessages" table="ProductNames"> 

<WebMessage name="kmsgHeaderBIBrandName"><TEXT>  Report Center </TEXT></WebMessage> 

</WebMessageTable></WebMessageTables> 

 



8.2 Reverting to SampleAppLite 

If you wish to revert to the SampleAppLite demo, which is the default out of the box demo installed with OBI11g, then perform the 

following steps. 

8.2.1 RPD Selection 

 Use the login you created in BIEE installation to log in to the EM console.  

 Expand 'Business Intelligence' node on the left and choose Coreapplication. 

 

 

 

 

 

 

 

 Now click on the Deployment tab on the right. Next, go to the Repository tab. 

 

 

 

 

 Click on 'Lock and Edit Configuration' to enable you to change the default settings.  

 

 

 

 

 In the 'Upload BI Server Repository' section, click on the Browse button and locate the SampleAppLite.rpd that is 

present with your install folder under the following path.  

\InstallHome\instances\instance1\bifoundation\OracleBIServerComponent\coreapplication_obips1\repository 

 If you are accessing EM from a different client machine, then copy over the SampleAppLite.rpd to the client machine.  

 Enter Admin123 as the repository password. 

 Keep on the same configuration screen to update webcat selection 

8.2.2 Webcat Selection 

Update the catalog location path at the bottom of the same EM screen, with the location looking like this.  

$ORACLE_INSTANCE/bifoundation/OracleBIPresentationServicesComponent/$COMPONENT_NAME/catalog/SampleAppLite 

  

 Click on Apply (top right corner of screen) 

 

 Click on 'Activate Changes‟ 

 

 

 



 

 

  Restart all the OBI components using EM or OPMNCTL. 

  Login to analytics at http://localhost:7001/analytics and SampleAppLite should be up now. 

 

8.3 Custom Authenticator Plug-In 

Custom Authenticator Plug-in samples can be found under Others\Custom Authenticator Plug-In.  

 

This functionality is described in the 11.1.1.3 BI documentation - Security Guide - Appendix A - Alternative Security Administration 

Options - Section A.1.5 - Authentication by Using a Custom Authenticator Plug-In. 

 

8.4 Enabling BI Publisher Usage Tracking 

This section describes how to enable usage tracking on BI Publisher reports.  

8.4.1 Pre-requisites 

In order to save the usage tracking details within a database, the Audit schema needs to be created using the RCU. To do this, 

invoke the RCU, choose Audit Services under AS Common Schemas. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

8.4.2 Enabling auditing feature 

Edit the file xmlp-server-config.xml from the path 

\InstallHome\user_projects\domains\bifoundation_domain\config\bipublisher\repository\Admin\Configuration 

Set the following properties to true 

AUDIT_ENABLED  

MONITORING_ENABLED  

AUDIT_JPS_INTEGRATION  

By default, AUDIT_JPS_INTEGRATION will not be in the file. If it does not exist, add the entry and set the value to true. After the 

edits, the above mentioned properties will look like this  

http://localhost:9704/analytics


 <property name="AUDIT_ENABLED" value="true"/> 

 <property name="MONITORING_ENABLED" value="true"/> 

 <property name="AUDIT_JPS_INTEGRATION" value="true"/> 

 

Go to the folder \InstallHome\oracle_common\modules\oracle.iau_11.1.1\components\ 

Here, create a directory called xmlpserver. Copy the file component_events.xml from the location 

\InstallHome\user_projects\domains\bifoundation_domain\config\bipublisher\repository\Admin\Audit to the newly created 

xmlpserver directory.  

 

Next step is to enable auditing policy within the EM. To do this, open EM from the url http://localhost:7001/em (replace the 

hostname and port number based on your setup).  

Under Weblogic domain, right click on 

bifoundation_domain and select Security 

and then click Audit Policy 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Set the auditing level of BI 

Publisher Server to 

Medium.  

 

 

 

 

 

 

 

 

Next step is to feed the auditing data into a table in the auditing schema by setting up  a weblogic datasource. To do this, open 

the WLS console in the url http://localhost:7001/console (replace hostname and port number based on your setup). Under 

Services, click the Data Sources Link 

http://localhost:7001/em


 

 

 

 

 

 

 

 

 

   

 

 

Click on „Lock&Edit‟ to make changes. Click New –> „Generic Datasource‟ to create a new data source. 

Enter the following details for the new data source:   

Name: Enter the name as Audit Data Source-0.   

JNDI Name: jdbc/AuditDB   

Database Type: Oracle 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Click Next and select “Oracle‟s Driver (Thin XA) for instance connections; Versions: 9.01 and Later”. Click Next and go to the 

Connection properties screen.  

Enter the database information where the auditing schema was created according to section 3.6.1 

Database Name - Enter the database SID where the auditing schema was created 

HostName – Hostname of the database 

Port – Database port 

Database User Name - DEV_IAU (Provide the appropriate username that you specified in step 3.6.1) 

Password – password (Provide the appropriate password) 

Click Next. Accept the defaults and click Test Configuration to 

verify the connection. 

Click Next. Click on AdminServer and click Finish. Click on 

Activate Changes so the new JDBC connection can take effect. 

Restart WLS. 

 

Next step is to register the Audit Data Storing database to the 

domain. To do this, login to EM console 



navigate to Weblogic Domain, right click on bifoundation domain, select Security, then Audit Store. 

 

 

 

Click the searchlight icon next to the Datasource JNDI Name field. Select the Audit JNDI/JDBC datasource you created in the 

previous step in the pop-up window and click OK 

 

 

 

 

 

 

 

 

 IMPORTANT Note :  

If you do not see the datasource entry, it could be because of one of the following reasons.  

WLS was not restarted after creating the datasource Audit Data Source-0 in WLS 

Adminserver is not chosen as a target while creating the datasource.  

            Confirm that these two steps are addressed in order to be able to see the datasource entry in the EM screen.  

 

Click Apply.  Restart WLS for the changes to take effect. 



9 Appendix 1 

 

Dashboard  3.10 Query Building >  Selection Steps on hierarchies is pointing to wrong set of reports from the catalog. It 

needs to be manually edited to point to the right objects, as per the image below.  The 3 correct reports for this dashboard are 

located in the catalog under :  

3. Analysis and Dashboards > Query Elements > Selection Steps > Hier Sel Steps 

 

Save the dashboard after done 

 


