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LabVIEW PDA Module
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This user guide contains system requirements, installation and licensing 

instructions, a tutorial that guides you through building, running, and 

debugging PDA VIs, and new features for the LabVIEW PDA Module.
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System Requirements

The PDA Module has the following requirements:

• A desktop computer with Windows 2000 with Service Pack 4 or later 

or Windows XP.

• LabVIEW 7.1 Full or Professional Edition.

• One of the following PDA devices:

– A Palm OS device with Palm OS 3.5 or later.

– A Pocket PC 2003 device. The PDA Module does not support 

Pocket PC 2002 devices.

• To debug a PDA application on a Palm OS device, you must have 

a serial cable or serial cradle. To debug a PDA application on a 

Pocket PC 2003 device, you can use a serial cable, serial cradle, 

USB cable, or USB cradle.

Installing the PDA Module

Complete the following steps to install the PDA Module.

1. On Windows 2000/XP, log in as an administrator or as a user with 

administrator privileges.

2. If it is not already installed, install LabVIEW 7.1 and the PDA 

software provided with the PDA device on the host computer. For 

Palm OS devices, the PDA software is Palm Desktop and HotSync. 

For Pocket PC 2003 devices, the PDA software is ActiveSync.

3. (Pocket PC 2003) Install the Microsoft Mobile Development Resource 

Kit. Refer to readme.html, located on the PDA Module CD, for 

installation instructions.

4. Install the PDA Module software.

If the PDA Module installation program does not run automatically, 

you can run the installer by running x:\\setup.exe, where x is the 

CD-ROM drive on the computer.
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5. When the installer completes, restart the computer.

6. (Palm OS) Use the Palm Desktop and HotSync software to 

install DatalogMgr.prc and Mathlib.prc, located in the 

LabVIEW 7.1\PDA\Utilities directory, on the PDA device.

Additional Sony Clié Installation Instructions
For Sony Clié devices, you must complete the following additional 

installation steps to obtain the Sony SDK 5.0.

1. On the host computer, create a Sony folder in the Program 

Files\Metrowerks\CodeWarrior\Other SDKs\ directory.

2. Open a Web browser to www.cliedeveloper.com, click the Obtain 

Development Tools link, and click the Sony SDK 5.0 link.

3. After reading the agreement, and if you agree, click the Agree link to 

download the cliesdk50e.zip.

4. When the download is complete, extract the contents of the 

cliesdk50e.zip file into the Sony directory you created in step 1.

Installing the WIDCOMM Bluetooth DLLs on Pocket PC 2003 Devices
You must install the WIDCOMM Bluetooth DLLs on the Pocket PC 2003 

device to build and run PDA applications that use Bluetooth 

communication.

Note The PDA Module supports the WIDCOMM BTW-CE 1.4 or later driver.

Complete the following steps to install the WIDCOMM Bluetooth DLLs.

1. Place the Pocket PC 2003 device in the cradle.

2. On the host computer, run labview\PDA\Utilities\Bluetooth\

setup.exe to install the DLLs on the Pocket PC 2003 device.

Refer to readme.txt, located in the labview\PDA\

Utilities\Bluetooth directory, for information about 

manually installing the WIDCOMM Bluetooth DLLs.
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Installing the PDA Emulator or Simulator

Emulators and simulators are useful tools you can use during development 

to quickly run and test PDA VIs without having to download the PDA 

application to the PDA device. The PDA emulator or simulator you use 

depends on the PDA platform you have installed.

Note (Palm OS) Install the Palm OS emulator if you are using Palm OS 4.x and earlier. 

Install the Palm OS simulator if you are using Palm OS 5.0 and later. Refer to the Palm 

Web site at www.palmos.com for information about the differences between the Palm OS 

emulator and Palm OS simulator.

Installing the Palm OS Emulator and ROM Image
(Palm OS 4.x and earlier) Palm OS emulators use ROM images to enable the 

emulator to behave like a specific Palm OS device. You must have a ROM 

image to run the Palm OS emulator. You can transfer the ROM image from 

a Palm OS device or download ROM images from the Palm Web site at 

www.palmos.com.

Complete the following steps to obtain and install the Palm OS emulator 

and ROM image.

Note If you are using a Sony Clié device, skip to the Installing the Sony Clié 

Palm OS Emulator and ROM Image section to install the emulator and ROM image.

1. Download and install the Palm OS emulator from the Palm Web site at 

www.palmos.com.

2. (USB only) Complete the following steps to enable the Palm OS 

emulator to access the USB port.

a. Navigate to the \Palm directory and copy USBPort.dll.

b. Navigate to the \Palm\emulator directory and paste the copy of 

USBPort.dll.

3. Place the Palm OS device in the cradle and use the Palm Desktop 

and HotSync software to install the ROM Transfer.prc file from 

the \Palm\emulator directory onto the Palm OS device.

4. When the HotSync operation is complete, disable the HotSync 

Manager and close any other applications that are using the serial 

or USB port.

5. Run the ROM Transfer application on the PDA device and tap the 

Begin Transfer button.
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6. On the host computer, double-click emulator.exe and click the 

Download button. (USB only) In the Transfer ROM dialog box that 

appears, select USB from the Port pull-down menu.

7. Click the Begin button. The transfer takes several minutes.

8. Save the ROM image on the host computer. You now can use this ROM 

image to run the emulator. Click the Exit button to close the Palm OS 

Emulator.

9. Restart HotSync and sync the Palm OS device with the host computer.

Installing the Sony Clié 
Palm OS Emulator and ROM Image
Complete the following steps to obtain the Sony Clié Palm OS emulator 

and ROM image.

Note You must register with Sony to obtain these files.

1. Open a Web browser to www.cliedeveloper.com, click the Obtain 

Development Tools link, and click the Palm OS Emulator link.

2. Click the Register link and follow the links to sign up for the Standard 

Program.

3. When you receive the developer program ID by email, return to the 

link in step 1 and click the Palm OS Emulator link.

4. Enter the developer ID and password you received when you 

registered.

5. Follow the instructions on the Sony Web site to download and install 

the emulator and the ROM image.

Installing the Palm OS Simulator
(Palm OS 5.0 and later) Download and install the Palm OS simulator from 

the Palm Web site at www.palmos.com. Palm OS simulators do not use a 

ROM image.

Installing the Pocket PC 2003 Emulator
The Microsoft Mobile Development Resource Kit installs the 

Pocket PC 2003 emulator. The Pocket PC 2003 emulator launches 

automatically when you download a PDA application to the 

Pocket PC 2003 emulator from LabVIEW.

Select Start»Programs»Microsoft PocketPC 2003 SDK»

Pocket PC 2003 Emulator to launch the Pocket PC 2003 emulator 

when LabVIEW is not running.
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Licensing the PDA Module

You must activate the PDA Module license to build PDA VIs into PDA 

applications that run on PDA devices. Complete the following steps to 

active the license.

1. Select Start»Programs»National Instruments» 

NI License Manager.

2. In the left pane of the NI License Manager, expand Software 

Licenses»LabVIEW»Version 7.1»Modules, right-click 

PDA Module, and select Activate License.

3. In the NI License Wizard that appears, select I have not yet activated 

this product on this computer and click the Next button.

4. Enter the serial number in the field provided and click the Next button. 

You can find the serial number on the proof-of-ownership and 

registration card you receive with the PDA Module.

5. Select the activation option. If you select Auto, click the Next button. 

The NI License Wizard automatically sends the registration 

information over a secure internet connection and activates the 

PDA Module license for the current computer. If you select Email, 

follow the instructions that follow to complete licensing the 

PDA Module.

6. Click the Finish button to exit the NI License Wizard.

Note When you attempt to build a PDA VI into a PDA application using an unlicensed 

installation of the PDA Module, a dialog box appears that launches the NI License Wizard 

and prompts you to activate the license. You must restart LabVIEW before you can build 

a PDA VI into a PDA application.

PDA Module Tutorial

Use this tutorial to learn how to create, build, run, and debug a PDA 

application. The PDA Tutorial application you will create generates 

simulated data and saves the data to a file.
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Part 1—Creating the VI on the Host Computer
Complete the following steps to create the PDA Tutorial VI.

1. (Palm OS) On the host computer, create a new directory, C:\PDAdata. 

This new directory is where the PDA Tutorial application copies the 

data it collects when you use HotSync to sync the Palm OS device with 

the host computer.

2. Launch LabVIEW. In the LabVIEW dialog box, select 

Palm OS Device or a Pocket PC 2003 Device from the 

Execution Target pull-down menu.

3. Click the New button to display the New dialog box.

4. Select VI from Template»Palm OS Screen or Pocket PC Screen in 

the Create new list.

5. Click the OK button.

Tip You also can open the Palm OS Screen or Pocket PC Screen VI templates by selecting 

File»New. Select PalmScreen.vit or PocketPCScreen.vit in the New dialog box 

that appears and click the OK button.

Creating the Front Panel
Complete the following steps to create the front panel.

1. Create the following front panel. The controls and indicators are larger 

sizes than controls and indicators on VIs created for the LabVIEW for 

Windows execution target.

(Palm OS) The VI Name in the Palm OS title bar automatically changes 

to the name of the PDA VI when you save the PDA VI.
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Creating the Block Diagram
Complete the following steps to create the block diagram.

1. Create the following block diagram using (Palm OS) Figure 1 and 

Figure 3 or (Pocket PC 2003) Figure 2 and Figure 3 as guides.

(Optional) Instead of creating the block diagram, you 

can open (Palm OS) PDA Tutorial - Palm OS.vi or 

(Pocket PC 2003) PDA Tutorial - Pocket PC.vi, located 

in the \examples\PDA directory, and skip to Part 2—Building the 

PDA VI.

Figure 1.  TRUE Case for Palm OS Tutorial

Figure 2.  TRUE Case for Pocket PC Tutorial
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Figure 3.  FALSE Case for Palm OS and Pocket PC 2003 Tutorial

2. Save the VI to any location on the host computer as 

PDA Tutorial.vi.

Part 2—Building the PDA VI
Complete the following steps to build the PDA VI into an executable 

PDA application.

1. Select Tools»Build for PDA. The Build Settings dialog box appears.

2. On the Build Settings tab, enter a name for the executable file you are 

building in the Application filename text box.

3. (Optional) The default destination directory is labview\PDA. To build 

the PDA VI in another location, enter the path to the directory in the 

Destination Directory box or click the Browse button and navigate to 

the directory where you want build the PDA VI.

4. Click the Build button. LabVIEW builds the PDA VI into an 

executable PDA application, which is a .prc file for Palm OS 

targets or a .exe file for Pocket PC 2003 targets.
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Part 3—Downloading the PDA VI
Complete the following steps to download the PDA application to the 

PDA device.

1. On the host computer, select Operate»Download Application.

2. (Palm OS) Navigate to PDA Tutorial.prc and click the Open 

button. LabVIEW prompts you to press the HotSync button on the 

PDA cradle to download the PDA application to the Palm OS device.

(Pocket PC) Navigate to PDA Tutorial.exe and click the Open 

button. LabVIEW automatically downloads the PDA application to 

the Pocket PC 2003 device.

Part 4—Running the PDA Application on the PDA Device
Complete the following steps to run the PDA Tutorial application on the 

PDA device.

1. Remove the PDA device from its cradle.

2. Navigate to and open the PDA Tutorial application.

3. Tap the Collect button. The PDA Tutorial application begins 

displaying simulated data on the graph.

4. Tap the Save button. The PDA Tutorial application stops collecting the 

simulated data.

5. Tap the Collect button again. The PDA Tutorial application clears the 

graph and begins displaying another collection of simulated data.

6. Tap the Save button again to stop the PDA Tutorial application.

7. Tap the Exit button. The PDA Tutorial application quits and returns 

you to the PDA operating system.
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Part 5—Syncing with the Host Computer
The way you synchronize data between the PDA device and the host 

computer is different for Palm OS and Pocket PC 2003.

Synching with Palm OS Devices
Complete the following steps to sync data stored on the PDA device with 

the host computer.

1. Place the PDA device in the cradle.

2. Press the HotSync button on the cradle. Palm OS connects the 

PDA device to the host computer and syncs the files.

3. After the HotSync is complete, navigate to the C:\PDAdata directory. 

The DatalogMgr copies the data files on the PDA device to this 

directory.

Synching with Pocket PC 2003 Devices
Complete the following steps to sync data stored on the PDA device with 

the host computer.

1. Place the PDA device in the cradle.

2. Use ActiveSync to navigate to \My Documents on the 

Pocket PC 2003 device.

3. Copy the *_samples.txt files to the host computer.

Part 6—Debugging the PDA Application
(Palm OS) To debug a PDA application on a Palm OS device, use a serial 

cradle or serial cable to connect the Palm OS device to the host computer.

(Pocket PC 2003) To debug a PDA application on a Pocket PC 2003 device, 

use a serial cradle, serial cable, USB cradle, or USB cable to connect the 

Pocket PC 2003 device to the host computer.

Complete the following steps to debug the PDA application.

1. On the host computer, enable debugging on the PDA VI by selecting 

File»VI Properties and placing a checkmark in the Allow debugging 

checkbox on the Execution page. Click the OK button.

2. Select the debugging tools you want to use. Add probes for this 

tutorial.

Note You cannot use execution highlighting when you debug PDA applications.
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3. Configure the action of the run button.

a. Select Tools»Options to display the Options dialog box and 

select Run Button Action for PDA Targets from the pull-down 

menu.

b. Place a checkmark in the Download Application checkbox.

c. Select Launch and debug application.

d. Click OK.

4. Build the PDA VI into a PDA application.

a. Select Tools»Build for PDA to open the Build Settings dialog 

box.

b. Click the Code Generation Settings tab and place a checkmark 

in the Generate debug info checkbox.

c. Click the Build button to build the PDAVI into a 

PDA application. If a warning dialog box appears, click the 

OK button to confirm that you want to replace the existing file.

5. Run the PDA Tutorial VI on the host computer. This downloads and 

launches the PDA Tutorial application on the PDA device. You can set 

breakpoints and/or probes when the PDA VI is running on the host 

computer and the corresponding PDA application is running on the 

PDA device.

6. When LabVIEW on the host computer connects to the PDA device, the 

PDA Tutorial application runs on the PDA device. The front panel is 

fully functional on the PDA device, but any changes you make to the 

front panel on the host computer have no effect on the execution of 

the PDA application or on the block diagram on the host computer.

7. The VI runs on the host computer, and the probes you inserted in step 2 

on the block diagram of the PDA Tutorial VI return values from 

PDA Tutorial application on the PDA device.

You can use additional debugging tools on the block diagram of 

the host computer while the PDA Tutorial runs on the PDA device.

8. To end the debug session and stop execution, tap the Exit button 

on the PDA Tutorial application or click the Abort button on the 

PDA Tutorial VI on the host computer. The PDA Tutorial VI on the 

host computer stops when the PDA Tutorial application stops on the 

PDA device.
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LabVIEW 7.1 PDA Module Features

Refer to the LabVIEW PDA Module User Manual and the LabVIEW Help 

for more information about PDA Module features.

Bluetooth Communication Support
The PDA Module supports Bluetooth communication on Palm OS 5.0 or 

later devices and Pocket PC 2003 devices with the WIDCOMM Bluetooth 

driver version 1.4 or later.

(Pocket PC 2003) Refer to Installing the WIDCOMM Bluetooth DLLs 

on Pocket PC 2003 Devices section for more information about installing 

the WIDCOMM Bluetooth DLLs. Refer to the WIDCOMM Web site 

at www.widcomm.com for more information about the WIDCOMM 

Bluetooth driver.

Refer to the Using LabVIEW with Wireless Devices Application Note for 

more information about Bluetooth communication in LabVIEW. Refer to 

the Bluetooth Web site at www.bluetooth.com for more information 

about Bluetooth technology.

PDA Tab Controls
The PDA Module supports tab controls, but PDA tab controls do not 

support the following configuration options:

• Tabs on the left or right side of the tab control

• Disabled pages

• Images on tabs

• Variable size tabs

• Different color tabs
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Expanded Event Support for PDA Targets
The PDA Module supports the Mouse Up, Mouse Down, Mouse Move, 

Value Change, and Menu Selection events. The mouse events work only 

with picture controls.

Note (Palm OS) To use coordinates from the Mouse Move event on Palm OS devices in 

high-density display mode, you must convert the mouse coordinates to the low-density 

equivalent before you wire them to a picture control. For example, you must convert the 

high-density coordinates of 240 × 200 to 120 × 100.

Zoomable PDA Graphs and Charts
Use the Zoom Chart or Graph VI to add zoom functionality to any graph 

or chart in a PDA VI. You also can create a button or menu to add zoom 

functionality.

High-Density Screens
(Palm OS) The PDA Module supports high-density screens, which you 

usually use with graphs, charts, and pictures.

PDA Button Input VIs
Use the PDA Button Input VIs to read the state of the buttons on the 

PDA device.

Showing and Hiding Front Panel Objects in PDA Applications
Use the Show or Hide Control VI to programmatically control the visibility 

of controls and indicators on the front panel of PDA applications.

Palm OS Notifications
Use the Palm OS Notification VIs to register and receive system-level 

notifications on a Palm OS device. You also can use the Palm OS 

Notification VIs to launch other PDA VIs and to respond to Palm OS 

and PDA device-specific events.

Palm OS Expansion Card Support
You can perform file I/O operations using Palm OS expansion cards. 

To write to or read from files on an expansion card, specify a file path of 

Card#://filename, where # is the 1-based volume reference number of 

the expansion card. If you have only one expansion card, the file path is 

usually Card1://filename.
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Run Button Behavior
In previous versions of the PDA Module, clicking the Run button 

debugged the PDA VI. You now can configure the behavior of this 

button. Select Tools»Options to configure the behavior of the Run button. 

The default behavior is to build, download, and debug the PDA VI.

Scalable Fonts
(Pocket PC 2003) The PDA Module supports scalable fonts.

Sound VIs
The PDA Module supports the Sound VIs on Palm OS and 

Pocket PC 2003.

NI-DAQmx Base
The LabVIEW PDA Module software folder includes a new NI-DAQmx 

Base driver for use with the PCMCIA DAQ products. The NI-DAQmx 

Base driver replaces the functionality of the DAQ for Pocket PC 2002 VIs 

that were available in version 7.0 of the PDA Module. The NI-DAQmx 

Base driver increases the fuctionality available on PDA devices when using 

NI PCMCIA DAQ products. Refer to the NI-DAQmx Base installation CD 

for more information about the NI-DAQmx Base driver.

Where to Go from Here

The following documents contain information that you might find helpful:

• LabVIEW PDA Module User Manual, available in PDF format by 

selecting Start»Programs»National Instruments»LabVIEW»

Module Documents»LabVIEW PDA Module User Manual.

• LabVIEW User Manual, available in PDF format by selecting 

Start»Programs»National Instruments»LabVIEW»Search the 

LabVIEW Bookshelf and clicking the LabVIEW User Manual link.

• LabVIEW Help, available by selecting Help»VI, Function, & 

How-To Help. Help specific to the PDA Module is available from 

the PDA Module book in the Contents tab of the LabVIEW Help.

• (Pocket PC 2003) NI-DAQmx Base documentation, available on the 

NI-DAQmx Base installation CD.

• Documentation for the PDA device, emulator, or Palm OS simulator 

you use.
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You must have Adobe Reader with Search and Accessibility 5.0.5 or later 

installed with search and accessibility plug-ins to view the PDFs. Refer to 

the Adobe Systems Incorporated Web site at www.adobe.com to download 

Adobe Reader.


